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Introduction

This example describes the pressure wave propagation in a muffler for an explosion engine. 
The approach is general for analysis of damping of harmonic pressure waves.

The purpose of the application is to show how to treat 3D acoustics in a fairly complex 
geometry consisting of several separate sections and pipes divided by thin perfectly rigid 
walls. The analysis gives the transmission loss in the frequency range 100 Hz–1000 Hz.

Model Definition

The model geometry consists of three separate resonator chambers divided by thin walls. 
The inlet and the outlet correspond to the connection in the direction of the engine and 
of free air, respectively.

Figure 1: The geometry of a muffler. The exhaust fumes enter through the left pipe, pass the 
three resonator chambers, and exit through the right pipe.

D O M A I N  E Q U A T I O N S

You solve the problem in the frequency domain using the Pressure Acoustics, Frequency 
Domain interface. The model equation is a slightly modified Helmholtz equation for the 
acoustic pressure p:
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where ρ is the density, c is the speed of sound, and ω is the angular frequency. The density 
needs to be included in the equation in cases where variations in density in different 
materials exist. The model assumes that in the low-frequency range, reactive damping 
prevails. Resistive damping is therefore not included.

B O U N D A R Y  C O N D I T I O N S

The boundary conditions are of three different types. At all the solid boundaries, which 
include the outer walls of the muffler, the dividing walls between the resonator chambers, 
and the walls of the pipes, sound hard (wall) boundary conditions are used:

At the inlet boundary, a combination of an incoming and an outgoing plane waves is 
assumed:

In this equation p0 denotes the applied outer pressure and i the imaginary unit. At the 
outlet boundary, an outgoing plane wave is set:

Results and Discussion

Figure 2 visualizes the pressure field in the muffler at a frequency of 490 Hz using a 
boundary plot of the absolute value of the pressure and an isosurface plot of the pressure.
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Figure 2: The solution at 490 Hz. The real value of the pressure is plotted as isosurfaces, and 
the absolute value of the pressure is displayed as a boundary plot on the inner walls of the 
muffler.

The following equation defines the transmission loss in the muffler:

Here, Pin and Pout denote the acoustic effect at the inlet and outlet, respectively. The 
acoustic effect is calculated using the following equations:

Figure 3 shows the result of a parametric frequency study. This plot reveals that the 
damping is better at higher frequencies, with the exception of several deep dips 
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throughout the frequency range. The dips correspond to the resonance frequencies for 
different parts of the muffler system.

Figure 3: The damping (dB) in the muffler as a function of the frequency (Hz).

Application Library path: COMSOL_Multiphysics/Acoustics/automotive_muffler

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Acoustics>Pressure Acoustics>Pressure Acoustics, 

Frequency Domain (acpr).

3 Click Add.
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4 Click Study.

5 In the Select Study tree, select Preset Studies>Frequency Domain.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Create the geometry. To simplify this step, insert a prepared geometry sequence.

1 On the Geometry toolbar, click Insert Sequence.

2 Browse to the application’s Application Libraries folder and double-click the file 
automotive_muffler_geom_sequence.mph.

3 On the Geometry toolbar, click Build All.

Name Expression Value Description

p0 1[Pa] 1 Pa Inlet pressure amplitude
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4 Click the Zoom Extents button on the Graphics toolbar.

D E F I N I T I O N S

Define integration operators for the inlet and outlet, then use these to calculate the 
attenuation.

Integration 1 (intop1)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundary 1 only.

5 In the Operator name text field, type intop_inlet.

6 In the Label text field, type inlet.

Integration 2 (intop2)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundary 50 only.

5 In the Operator name text field, type intop_outlet.
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6 In the Label text field, type outlet.

Variables 1
1 On the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

Note that you need to define the incoming power using p0 rather than the pressure 
variable, p, because p is the sum of incident and reflected pressure waves.

Create a selection to simplify setting up the interior boundary conditions.

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, locate the Input Entities section.

3 From the Geometric entity level list, choose Boundary.

4 Click the Transparency button on the Graphics toolbar.

Name Expression Unit Description

P_in intop_inlet(p0^2/(2*
acpr.rho*acpr.c))

W Incoming power

P_out intop_outlet(p*
conj(p)/(2*acpr.rho*
acpr.c))

W Outgoing power

TL 10*log10(P_in/P_out) Transmission loss
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5 Select Boundaries 10, 11, 13, 14, 16, 20–23, 25, 26, 28, 29, 32, and 36–39 only.

To do this, click the Paste Selection button next to the Selection box, paste the text: 10, 
11, 13, 14, 16, 20–23, 25, 26, 28, 29, 32, 36–39 in the text field of the dialog box that 
opens, and finally click OK.

6 In the Label text field, type interior boundaries.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Air.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

By default, the first material you add applies for all domains. In the Material Contents table 
you can see which material properties the physics interfaces use, in this case the density 
andthe speed of sound. Notice that these quantities are functions of the temperature and 
(in the case of the density) the ambient pressure.

1 On the Home toolbar, click Add Material to close the Add Material window.
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P R E S S U R E  A C O U S T I C S ,  F R E Q U E N C Y  D O M A I N  ( A C P R )

Pressure Acoustics 1
In the Model Inputs section you can read off and, if desired, modify the temperature and 
absolute pressure at which the expressions for the air density and speed of sound are 
calculated. For this model, use the default settings.

Plane Wave Radiation 1
1 On the Physics toolbar, click Boundaries and choose Plane Wave Radiation.

2 Select Boundary 1 only.

Incident Pressure Field 1
1 On the Physics toolbar, click Attributes and choose Incident Pressure Field.

2 In the Settings window for Incident Pressure Field, locate the Incident Pressure Field 
section.

3 In the p0 text field, type p0.

4 From the c list, choose From material.

5 From the Material list, choose Air (mat1).

Plane Wave Radiation 2
1 On the Physics toolbar, click Boundaries and choose Plane Wave Radiation.

2 Select Boundary 50 only.

3 Click the Transparency button on the Graphics toolbarto return to the default 
transparency state.

Interior Sound Hard Boundary (Wall) 1
1 On the Physics toolbar, click Boundaries and choose Interior Sound Hard Boundary (Wall).

2 In the Settings window for Interior Sound Hard Boundary (Wall), locate the Boundary 

Selection section.

3 From the Selection list, choose interior boundaries.

M E S H  1

Use the default physics-controlled mesh as a starting point and then modify the maximum 
element size so that you get 10 elements per wavelength for the highest frequency in the 
sweep, that is 1 kHz.

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, click Build All.
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Size
1 Right-click Component 1 (comp1)>Mesh 1 and choose Edit Physics-Induced Sequence.

2 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

3 In the Settings window for Size, locate the Element Size section.

4 Click the Custom button.

5 Locate the Element Size Parameters section. In the Maximum element size text field, type 
343[m/s]/1[kHz]/10.

This corresponds to one 10th of the shortest wavelength.

6 Click Build All.

S T U D Y  1

Step 1: Frequency Domain
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Frequency 

Domain.

2 In the Settings window for Frequency Domain, locate the Study Settings section.
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3 In the Frequencies text field, type range(100,10,1000).

This computes the solution for 91 equally spaced frequencies from 100 Hz to 1000 Hz. 
If you want to run a faster analysis, try the same frequency range but with a step of 100 
Hz instead (to do so, type range(100,100,1000)).

4 On the Home toolbar, click Compute.

R E S U L T S

Acoustic Pressure (acpr)
Before visualizing the acoustic pressure field, add a selection to the default solution data 
set that filters out the upper muffler boundaries for a better view.

Data Sets
In the Model Builder window, expand the Results>Data Sets node, then click Study 1/Solution 

1 (sol1).

Selection
1 On the Results toolbar, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundaries 1–7, 9–14, 16, 17, 19–29, 31–33, 35–41, and 43–50 only.

To do this, choose All boundaries from the Selection list. Ctrl+click to highlight the six 
top faces of the muffler, then right-click to remove them from the selection. 
Alternatively, you can click the Paste Selection button next to the Selection box and then 
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paste the text “1–7, 9–14, 16, 17, 19–29, 31–33, 35–41, and 43–50” in the text field 
of the dialog box that opens before clicking OK.

Acoustic Pressure (acpr)
Reproduce the plot in Figure 2 by following these steps.

1 In the Model Builder window, under Results click Acoustic Pressure (acpr).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Parameter value (freq (Hz)) list, choose 490.

4 In the Model Builder window, expand the Acoustic Pressure (acpr) node, then click Surface 

1.

5 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Pressure Acoustics, 

Frequency Domain>Pressure and sound pressure level>acpr.absp - Absolute pressure.

6 On the Acoustic Pressure (acpr) toolbar, click Plot.

7 In the Model Builder window, right-click Acoustic Pressure (acpr) and choose Isosurface.

8 In the Settings window for Isosurface, click Replace Expression in the upper-right corner 
of the Expression section. From the menu, choose Model>Component 1>Pressure 

Acoustics, Frequency Domain>Pressure and sound pressure level>p - Pressure.
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9 Locate the Levels section. In the Total levels text field, type 10.

What is a suitable number of isosurface levels for the isosurface plot varies with the 
frequency. At frequencies with low damping many of the isosurfaces tend to congregate 
inside the pipe.

10 On the Acoustic Pressure (acpr) toolbar, click Plot.

11 Click the Zoom Extents button on the Graphics toolbar.

Finally, reproduce the plot of attenuation versus frequency shown in Figure 3.

1D Plot Group 4
On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

Global 1
On the 1D Plot Group 4 toolbar, click Global.

1D Plot Group 4
1 In the Settings window for Global, click Replace Expression in the upper-right corner of 

the y-axis data section. From the menu, choose Model>Component 1>Definitions>

Variables>TL - Transmission loss.

2 In the Model Builder window, click 1D Plot Group 4.

3 In the Settings window for 1D Plot Group, type Transmission Loss in the Label text 
field.

4 Locate the Plot Settings section. Select the x-axis label check box.

5 In the associated text field, type Frequency (Hz).

6 Select the y-axis label check box.

7 In the associated text field, type Transmission loss (dB).

8 On the Transmission Loss toolbar, click Plot.

Notice the deep dip in the damping around 490 Hz caused by the resonance in the 
second chamber. If you plot the pressure in the muffler at other dips, resonances in the 
other chambers appear.
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Introduction

There are different types of stock options:

• A call option is the right to buy a security at a specified price (called the exercise or strike 
price) during a specified period of time.

• A put option is the right to sell a security at a specified price during a specified period 
of time.

American options can be exercised at any time up to and including the day the option 
expires. European options can be exercised only on the day the option expires.

The famous Black-Scholes equation computes the cost u of a European stock option

with the following parameters:

• x, the underlying asset price

• r, the continuous compounding rate of interest

• σ, the standard deviation of the asset’s rate of return (also known as volatility)

A put option’s value on the exercise day is

where K is the strike price. The problem domain is infinite and consists of the entire real 
axis across the time domain 0 ≤ t ≤ T.

The assumptions made in deriving the Black-Scholes equation are:

• The underlying stock pays no dividends.

• The price of the stock, one period ahead, has a log-normal distribution with mean and 
standard deviation that are constant over the life of the option. 

• The existence of a risk-free interest rate which is constant over the life of the option.

• You can lend and borrow at the risk-free interest rate.

Black and Scholes derived an analytical expression for the solution to the above problem. 
However, the formula works only for certain cases. For instance, you cannot use it when 
σ and r are functions of x and t. Using the PDE formulation, you can determine the price 
for such cases.

t∂
∂u 1

2
---σ2x2

x2

2

∂

∂ u rx
x∂

∂u
+ + ru=

u T x,( ) max K x– 0,( )=
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Model Definition

Because you work within a finite domain 0 ≤ x ≤ X, it is necessary to specify not only the 
boundary conditions for t = T but also for x = 0 and x = X. It is therefore necessary to 
analyze the problem’s characteristics to determine the location of the input and output 
boundaries.

E Q U A T I O N  D E F I N I T I O N

To put the equation in coefficient form, rewrite the equation as

In the following, denote

To reduce the problems with inflow boundaries, start by considering a put option: Study 
the value of a put option at a strike price K = 40 with σ = 0.3 and r = 0.12.

B O U N D A R Y  C O N D I T I O N S  A N D  I N I T I A L  C O N D I T I O N S

Make the domain be 0 ≤ x ≤ 80 with time running from 12 to 0. Then the initial condition 
at t = 12 and x = 80 is 0 based on the put option’s value. The initial condition in the region 
0 ≤ x ≤ 40 varies linearly from 0 to 40. At the end of the simulation domain, the boundary 
is free (use a homogeneous boundary condition).

Notes About the COMSOL Implementation

Model the Black-Scholes equation using the following approach:

• Create a 1D time-dependent model, using the time-stepping algorithm to solve for c as 
a function of x and t, the time. The time steps go backward in time. Using a variable 
substitution to reverse the sign of the time, the da coefficient becomes −1.

• To model the initial condition, use the logical expression (x<40)*(40-x). This means 
that in the areas where x > 40, the initial value is zero. 

Application Library path: COMSOL_Multiphysics/Equation_Based/
black_scholes_put
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 1D.

2 In the Select Physics tree, select Mathematics>PDE Interfaces>Coefficient Form PDE (c).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

R O O T

1 In the Model Builder window, click the root node.

2 In the root nodes'Settings window, locate the Unit System section.

3 From the Unit system list, choose None.

Keeping track of units is not important in this model; by turning off unit support, you 
avoid the need to specify dimensions for equation coefficients and coordinates to get rid 
of unit warnings.

G E O M E T R Y  1

Interval 1 (i1)
1 On the Geometry toolbar, click Interval.

2 In the Settings window for Interval, locate the Interval section.

3 In the Right endpoint text field, type 80.

4 Right-click Interval 1 (i1) and choose Build Selected.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

C O E F F I C I E N T  F O R M  P D E  ( C )

Coefficient Form PDE 1
1 In the Model Builder window, under Component 1 (comp1)>Coefficient Form PDE (c) click 

Coefficient Form PDE 1.

2 In the Settings window for Coefficient Form PDE, locate the Diffusion Coefficient 
section.

3 In the c text field, type 1/2*sigma^2*x^2.

4 Locate the Absorption Coefficient section. In the a text field, type r.

5 Locate the Source Term section. In the f text field, type 0.

6 Locate the Damping or Mass Coefficient section. In the da text field, type -1.

7 Click to expand the Convection coefficient section. Locate the Convection Coefficient 
section. In the β text field, type (-r+sigma^2)*x.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Coefficient Form PDE (c) click 

Initial Values 1.

2 In the Settings window for Initial Values, locate the Initial Values section.

3 In the u text field, type (x<40)*(40-x).

Flux/Source 1
1 On the Physics toolbar, click Boundaries and choose Flux/Source.

2 Select Boundary 1 only.

Dirichlet Boundary Condition 1
1 On the Physics toolbar, click Boundaries and choose Dirichlet Boundary Condition.

2 Select Boundary 2 only.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Edge.

Name Expression Value Description

r 0.12 0.12 Continuous compounding interest 
rate

sigma 0.3 0.3 Volatility
5 |  T H E  B L A C K - S C H O L E S  E Q U A T I O N



Size
1 In the Settings window for Size, locate the Element Size section.

2 Click the Custom button.

3 Locate the Element Size Parameters section. In the Maximum element size text field, type 
2.

4 Click Build All.

The mesh consists of 40 elements.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(12,-0.5,0).

4 On the Home toolbar, click Compute.

R E S U L T S

1D Plot Group 1
To see the plot of u as a Line Graph at time = 0, follow the steps given below.

1 In the Model Builder window, click 1D Plot Group 1.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Time selection list, choose From list.

4 In the Times (s) list, select 0.

5 Click to expand the Title section. Locate the Plot Settings section. Select the x-axis label 
check box.

6 In the associated text field, type x.

7 Select the y-axis label check box.

8 In the associated text field, type u.

Line Graph 1
1 In the Model Builder window, expand the 1D Plot Group 1 node, then click Line Graph 1.

2 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the x-axis data section. From the menu, choose Model>Component 1>Geometry>

Coordinate>x - x-coordinate.
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3 Click to expand the Legends section. Select the Show legends check box.

4 From the Legends list, choose Manual.

5 In the table, enter the following settings:

6 On the 1D Plot Group 1 toolbar, click Plot.

Legends

Time=0
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Introduction

The incompressible boundary layer on a flat plate in the absence of a pressure gradient is 
usually referred to as the Blasius boundary layer (Ref. 1). The steady, laminar boundary 
layer developing downstream of the leading edge eventually becomes unstable to 
Tollmien-Schlichting waves and finally transitions to a fully turbulent boundary layer. Due 
to its fundamental importance, this type of flow has become the subject of numerous 
studies on boundary-layer flow, stability, transition, and turbulence. This application 
considers the first section of the plate where the boundary layer remains steady and 
laminar, and compares results from incompressible, two-dimensional, single-phase-flow 
simulations obtained in COMSOL Multiphysics to the Blasius similarity solution. The 
solutions converge ideally with respect to both mesh refinement and discretization order.

Model Definition

Consider a homogeneous free-stream flow with speed U0 parallel to an infinitely thin, flat 
plate located along the positive x-axis. The flow is assumed to be steady, symmetric with 
respect to y, and homogeneous in the z direction. Due to friction, the flow adjacent to the 
plate is retarded and a thin boundary layer, where the velocity gradually grows from zero 
to the free-stream value, develops downstream of the leading edge (see Figure 1).

Figure 1: The boundary layer on a flat plate. δ(x) is the boundary-layer thickness, such that 
u(x, δ(x)) = U0.

A reasonably accurate solution for the flow field can be found by considering the 
boundary-layer approximation to the steady, incompressible Navier-Stokes equations

 (1)

 (2)

δ(x)
x

y

U0

u u∂
x∂

------ v u∂
y∂

------+ υ∂2u
∂y2
---------=

∂u
∂x
------ ∂v

∂y
------+ 0=
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Introducing a stream function,

and the similarity transformation,

Equation 1 and Equation 2 reduce to the ODE

 (3)

COMSOL solves Equation 3 on the interval η ∈ [0, 10] with the boundary conditions

by rewriting the equation as a system of two equations,

and implementing the system within the Coefficient Form PDE interface. 

Using the Laminar Flow interface for single-phase flow, the model solves the steady, 
incompressible Navier-Stokes equation in a domain (x, y) ∈ ([-1, 2.1], [0, 0.5]) m with the 
leading edge of the plate located at x = 0 m. The working fluid is air at a temperature of 
T = 20 °C and U0 = 0.75 m/s. The simulations uses discretizations with linear basis 
functions for velocity and pressure (P1+P1) on three different meshes.

Results and Discussion

Figure 2 shows the similarity solution u/U0 = f'(η). At η = 4.99, the deviation from the 
free-stream value is 1%. This value can be used to define the boundary-layer thickness,

u ∂Ψ
∂y
--------,= v ∂Ψ

∂x
--------–=

ψ υxU0f η( ),= η y
υx U0⁄

----------------------=

2f ''' ff ''+ 0=

f 0( ) 0 f ' 0( ) 0=,=

f ' η( ) 1=
η ∞→
lim

f ' fprime=

f ''prime
1
2
---ffprime–=







δ99 x( ) 4.99 υx
U0
-------=
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Figure 2: Similarity solution for the streamwise velocity component.

Figure 3 shows a comparison between the Blasius similarity solution and the results from 
the two-dimensional simulations at xE = 2 m, corresponding to a Reynolds number of 
Rex = 1.0·105. Only the results from the P1+P1 simulation on the coarse mesh show a 
significant deviation from the similarity solution. To quantify differences in the results, 
define the following measure,

ε u
U0
------- f '– 
  2

ηd

0

η∞

=
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Here, η∞ = 10, for which the similarity solution has converged to its asymptotic value to 
within the numerical precision in the computations.

Figure 3: Comparison between the similarity solution and the two-dimensional simulations.

Table 1 displays deviations from the similarity solution together with the number of 
degrees of freedom (DOF) for the three simulations. The convergence is displayed in 
Figure 4 where the mesh size h is calculated as the maximum cell side in the mesh. The 
curve is close to straight line, which means that the model is in a mesh convergence regime; 
that is, the solution converges toward the correct solution when the mesh is refined.

TABLE 1:  DEVIATION FROM THE BLASIUS SOLUTION

1/H 10 20 40

ε 6.10·10-2 3.33·10-2 1.68·10-2

DOF 2016 7749 30375
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Figure 4: Convergence rate as a function of inverse maximum cell side.

Notes About the COMSOL Implementation

The relative tolerance is set to 10−4 in all the solvers to ensure that the equation systems 
become well converged. All meshes have monotonically increasing element sizes away 
from the plate, with distributions employing geometric sequences. A component coupling 
is set up to enable evaluation of the similarity solution in the two-dimensional model.

Reference

1. H. Blasius, “Grenzschichten in Flüssigkeiten mit kleiner Reibung,” Z. Math. Phys., vol. 
56, pp. 1–37, 1908 (Engl. transl. in NACA TM 1256).

Application Library path: COMSOL_Multiphysics/Fluid_Dynamics/
blasius_boundary_layer
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 1D.

2 In the Select Physics tree, select Mathematics>PDE Interfaces>Coefficient Form PDE (c).

3 Click Add.

4 In the Field name text field, type f.

5 Click Add Dependent Variable.

6 In the Dependent variables table, enter the following settings:

7 Click Study.

8 In the Select Study tree, select Preset Studies>Stationary.

9 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

f

fprime

Name Expression Value Description

U0 0.75[m/s] 0.75 m/s Inlet velocity

nu 1.506137e-5[m^2/s] 1.5061E-5 m²/s Kinematic viscosity

xE 2[m] 2 m Evaluation location

b0 nu/U0 2.0082E-5 m B-L scale

N 1 1 Mesh refinement 
factor
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G E O M E T R Y  1

Interval 1 (i1)
1 On the Geometry toolbar, click Interval.

2 In the Settings window for Interval, locate the Interval section.

3 In the Right endpoint text field, type 10.

C O E F F I C I E N T  F O R M  P D E  ( C )

Coefficient Form PDE 1
1 In the Model Builder window, expand the Coefficient Form PDE (c) node, then click 

Coefficient Form PDE 1.

2 In the Settings window for Coefficient Form PDE, locate the Diffusion Coefficient 
section.

3 In the c text-field array, type 0 in the first column of the first row.

4 In the c text-field array, type -2 in the 2nd column of the 2nd row.

5 Locate the Absorption Coefficient section. In the a text-field array, type 1 in the 2nd 
column of the first row.

6 Locate the Source Term section. In the f text-field array, type 0 on the first row.

7 In the f text-field array, type 0 on the 2nd row.

8 Locate the Damping or Mass Coefficient section. In the da text-field array, type 0 in the 
first column of the first row.

9 In the da text-field array, type 0 in the 2nd column of the 2nd row.

10 Click to expand the Convection coefficient section. Locate the Convection Coefficient 
section. In the β text-field array, type -1 in the first column of the first row.

11 In the β text-field array, type f in the 2nd column of the 2nd row.

Dirichlet Boundary Condition 1
1 On the Physics toolbar, click Boundaries and choose Dirichlet Boundary Condition.

2 Select Boundary 1 only.

Dirichlet Boundary Condition 2
1 On the Physics toolbar, click Boundaries and choose Dirichlet Boundary Condition.

2 Click the Zoom Extents button on the Graphics toolbar.

3 Select Boundary 2 only.

4 In the Settings window for Dirichlet Boundary Condition, locate the Dirichlet Boundary 

Condition section.
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5 Clear the Prescribed value of f check box.

6 In the r2 text field, type 1.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Edge.

Edge 1
1 In the Settings window for Edge, locate the Domain Selection section.

2 From the Geometric entity level list, choose Entire geometry.

Distribution 1
1 Right-click Component 1 (comp1)>Mesh 1>Edge 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 From the Distribution properties list, choose Predefined distribution type.

4 In the Number of elements text field, type 10000.

5 In the Element ratio text field, type 100.

6 From the Distribution method list, choose Geometric sequence.

7 Click Build Selected.

S T U D Y  1

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node, then click Stationary 

Solver 1.

3 In the Settings window for Stationary Solver, locate the General section.

4 In the Relative tolerance text field, type 1e-6.

Allocate more memory than the default suggestion to avoid a warning message. The 
solver will automatically increase the allocation factor when needed, but changing it 
manually is more computationally efficient.

5 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 1 node, then click Direct.

6 In the Settings window for Direct, locate the General section.

7 In the Memory allocation factor text field, type 1.5.

8 On the Study toolbar, click Compute.
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S T U D Y  1

1 In the Model Builder window, right-click Study 1 and choose Rename.

2 In the Rename Study dialog box, type Similarity soln. in the New label text field.

3 Click OK.

R E S U L T S

Line Graph 1
1 In the Model Builder window, expand the 1D Plot Group 1 node, then click Line Graph 1.

2 In the Settings window for Line Graph, locate the y-Axis Data section.

3 In the Expression text field, type fprime.

4 Click to expand the Legends section. Select the Show legends check box.

5 From the Legends list, choose Manual.

6 In the table, enter the following settings:

1D Plot Group 1
1 In the Model Builder window, under Results click 1D Plot Group 1.

2 In the Settings window for 1D Plot Group, click to expand the Title section.

3 From the Title type list, choose None.

4 Locate the Plot Settings section. Select the x-axis label check box.

5 In the associated text field, type \eta.

6 Select the y-axis label check box.

7 In the associated text field, type u/U0.

8 Click to expand the Axis section. Select the Manual axis limits check box.

9 In the x minimum text field, type 0.

10 In the x maximum text field, type 10.

11 In the y minimum text field, type 0.

12 In the y maximum text field, type 1.1.

13 Click to expand the Legend section. From the Position list, choose Lower right.

14 On the 1D Plot Group 1 toolbar, click Plot.

Legends

Similarity soln.
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Set up a component coupling to be able to evaluate the similarity solution in the upcoming 
2D model.

D E F I N I T I O N S

General Extrusion 1 (genext1)
1 On the Definitions toolbar, click Component Couplings and choose General Extrusion.

2 Select Domain 1 only.

3 In the Settings window for General Extrusion, locate the Destination Map section.

4 In the x-expression text field, type root.y/sqrt(b0*root.x).

R O O T

On the Home toolbar, click Add Component and choose 2D.

G E O M E T R Y  2

In the Model Builder window, under Component 2 (comp2) click Geometry 2.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Fluid Flow>Single-Phase Flow>Laminar Flow (spf).

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Similarity soln.

5 Click Add to Component in the window toolbar.

6 On the Home toolbar, click Add Physics to close the Add Physics window.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

G E O M E T R Y  2

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.
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2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 3.1.

4 In the Height text field, type 0.5.

5 Locate the Position section. In the x text field, type -1.

6 On the Geometry toolbar, click Build All.

Point 1 (pt1)
1 On the Geometry toolbar, click Primitives and choose Point.

2 Click Build All.

Point 2 (pt2)
1 On the Geometry toolbar, click Primitives and choose Point.

2 In the Settings window for Point, locate the Point section.

3 In the y text field, type 0.5.

4 On the Geometry toolbar, click Build All.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Air.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

L A M I N A R  F L O W  ( S P F )

Inlet 1
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 Select Boundary 1 only.

3 In the Settings window for Inlet, locate the Velocity section.

4 In the U0 text field, type U0.

Open Boundary 1
1 On the Physics toolbar, click Boundaries and choose Open Boundary.

2 Select Boundaries 3 and 5 only.

Outlet 1
1 On the Physics toolbar, click Boundaries and choose Outlet.
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2 Select Boundary 6 only.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundary 2 only.

M E S H  2

In the Model Builder window, under Component 2 (comp2) right-click Mesh 2 and choose 
Mapped.

Mapped 1
In the Model Builder window, under Component 2 (comp2)>Mesh 2 right-click Mapped 1 and 
choose Distribution.

Distribution 1
1 Select Boundaries 4 and 5 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 21*N.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 2
1 Select Boundaries 2 and 3 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 10*N.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 3
1 Select Boundaries 1 and 6 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 From the Distribution properties list, choose Predefined distribution type.

4 In the Number of elements text field, type 20*N.

5 In the Element ratio text field, type 15.

6 From the Distribution method list, choose Geometric sequence.

7 Click Build Selected.
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S T U D Y  2

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

Step 1: Stationary
1 In the Model Builder window, expand the Study 2 node, then click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Values of dependent variables 
section.

3 Locate the Values of Dependent Variables section. Find the Values of variables not solved 

for subsection. From the Settings list, choose User controlled.

4 From the Method list, choose Solution.

5 From the Study list, choose Similarity soln., Stationary.

Solution 2 (sol2)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 2 (sol2) node, then click Stationary 

Solver 1.

3 In the Settings window for Stationary Solver, locate the General section.

4 In the Relative tolerance text field, type 1e-5.

5 In the Model Builder window, expand the Study 2>Solver Configurations>Solution 2 

(sol2)>Stationary Solver 1 node, then click Fully Coupled 1.

6 In the Settings window for Fully Coupled, click to expand the Method and termination 
section.

7 Locate the Method and Termination section. In the Maximum number of iterations text 
field, type 50.

8 On the Study toolbar, click Compute.

Parameter name Parameter value list

N 1 2 4
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R E S U L T S

Cut Line 2D 1
1 On the Results toolbar, click Cut Line 2D.

2 In the Settings window for Cut Line 2D, locate the Data section.

3 From the Data set list, choose Study 2/Parametric Solutions 1 (5) (sol3).

4 Locate the Line Data section. In row Point 1, set x to xE.

5 In row Point 2, set x to xE and y to 10*sqrt(b0*xE).

1D Plot Group 1
In the Model Builder window, expand the Results>1D Plot Group 1 node.

Line Graph 1
In the Model Builder window, expand the 1D Plot Group 1 node.

Line Graph 2
1 Right-click Line Graph 1 and choose Duplicate.

2 In the Settings window for Line Graph, locate the y-Axis Data section.

3 In the Expression text field, type u/U0.

4 Locate the Data section. From the Data set list, choose Cut Line 2D 1.

5 Locate the x-Axis Data section. In the Expression text field, type y/sqrt(b0*x).

6 Click to expand the Legends section. In the table, enter the following settings:

7 On the 1D Plot Group 1 toolbar, click Plot.

Derived Values
In the Model Builder window, under Results click Derived Values.

Line Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Line 

Integration.

2 In the Settings window for Line Integration, locate the Data section.

3 From the Data set list, choose Cut Line 2D 1.

4 Locate the Expressions section. Click Clear Table.

Legends

N=1

N=2

N=4
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5 In the table, enter the following settings:

6 Click Evaluate.

Derived Values
In the Model Builder window, under Results click Derived Values.

Surface Minimum 1
1 On the Results toolbar, click More Derived Values and choose Minimum>Surface Minimum.

2 Select Domain 1 only.

3 In the Settings window for Surface Minimum, locate the Expressions section.

4 In the table, enter the following settings:

5 Locate the Data section. From the Data set list, choose Study 2/Parametric Solutions 1 (5) 

(sol3).

6 Click Table 1 - Line Integration 1 ((u/U0-comp1.genext1(fprime))^2/sqrt(b0*x)).

TA B L E

1 Go to the Table window.

2 Click Table Graph in the window toolbar.

R E S U L T S

Table Graph 1
1 In the Model Builder window, under Results>1D Plot Group 5 click Table Graph 1.

2 In the Settings window for Table Graph, locate the Data section.

3 From the x-axis data list, choose 1/h (1/m).

4 From the Plot columns list, choose Manual.

5 In the Columns list, select Err^2 (1).

6 Locate the Coloring and Style section. Find the Line markers subsection. From the Marker 
list, choose Diamond.

7 From the Positioning list, choose In data points.

Expression Unit Description

(u/U0-comp1.genext1(fprime))^2/sqrt(b0*x) 1 Err^2

Expression Unit Description

1/h 1/m
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8 Click the y-Axis Log Scale button on the Graphics toolbar.

9 Click the x-Axis Log Scale button on the Graphics toolbar.
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Created in COMSOL Multiphysics 5.2a
E l e c t r i c a l  H e a t i n g  i n  a  Bu s b a r
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


For a description of this application, including detailed step-by-step instructions showing 
how to build it, see the book Introduction to COMSOL Multiphysics. 

Application Library path: COMSOL_Multiphysics/Multiphysics/busbar
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Created in COMSOL Multiphysics 5.2a
Con v e c t i v e  Coo l i n g  o f  a  Bu s b a r
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


This is a template MPH-file that you can use as the starting point for extending the model 
Electrical Heating in a Busbar with a study of the convective cooling of the busbar by an 
air stream. For a description of that model, including detailed step-by-step instructions 
showing how to build it, see the book Introduction to COMSOL Multiphysics. 

Application Library path: COMSOL_Multiphysics/Multiphysics/busbar_box
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Created in COMSOL Multiphysics 5.2a
Pa r ame t e r i z e d  Bu s b a r  Geome t r y
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


This is a template MPH-file containing the physics interfaces and the parameterized 
geometry for the model Electrical Heating in a Busbar. For a description of that model, 
including detailed step-by-step instructions showing how to build it, see the book 
Introduction to COMSOL Multiphysics.

Application Library path: COMSOL_Multiphysics/Multiphysics/busbar_geom
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Created in COMSOL Multiphysics 5.2a
Pa r ame t e r i z e d  Woven Ca r bon F i b e r s  Geome t r y
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


This is a template MPH-file containing the geometry for the model Anisotropic Heat 
Transfer through Woven Carbon Fibers. For a description of that model, including 
detailed step-by-step instructions showing how to build it, see Anisotropic Heat Transfer 
through Woven Carbon Fibers.

Application Library path: COMSOL_Multiphysics/Heat_Transfer/
carbon_fibers_geom
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Created in COMSOL Multiphysics 5.2a
Con i c a l  Quan t um Do t
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.
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This application computes the electronic states for a quantum-dot/wetting-layer system. 
It was inspired largely by the work of Dr. M. Willatzen and Dr. R. Melnik (Ref. 1) as well 
as B. Lassen.

Introduction

Quantum dots are nanoscale or microscale devices created by confining free electrons in a 
3D semiconducting matrix. The tiny islands or droplets of confined “free electrons” (those 
with no potential energy) present many interesting electronic properties. They are of 
potential importance for applications in quantum computing, biological labeling, and 
lasers, to name only a few.

Scientists can create such structures experimentally using the Stranski-Krastanow 
molecular beam-epitaxy technique. In that way they obtain 3D confinement regions (the 
quantum dots) by growth of a thin layer of material (the wetting layer) onto a 
semiconducting matrix. Quantum dots can have many geometries including cylindrical, 
conical, or pyramidal. This application studies the electronic states of a conical InAs 
quantum dot grown on a GaAs substrate.

To compute the electronic states taken on by the quantum dot/wetting layer assembly 
embedded in the GaAs surrounding matrix, you must solve the 1-band Schrödinger 
equation in the effective mass approximation:

where h is Planck’s constant, Ψ is the wave function, E is the eigenvalue (energy), and me 
is the effective electron mass (to account for screening effects).

Model Definition

The model works with the 1-particle stationary Schrödinger equation

h2

8π2
--------- ∇ 1

me r( )
--------------- Ψ r( )∇ 
 ⋅ 

 – V r( )Ψ r( )+ EΨ r( )=

∇ h2

8π2m
---------------∇Ψ
 
 
 

⋅– VΨ+ EΨ=
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It solves this eigenvalue problem for the quantum-dot/wetting-layer system using the 
following step potential barrier and effective-mass approximations:

• V = 0 for the InAs quantum dot/wetting layer and V = 0.697 eV for the GaAs 
substrate.

• me = 0.023m for InAs and me = 0.067m for GaAs.

Assume the quantum dot has perfect cylindrical symmetry. In that case you can model the 
overall structure in 2D as shown in the following figure.

Figure 1: 2D geometry of a perfectly cylindrical quantum dot and wetting layer.

You can now separate the total wave function Ψ into

where  is the azimuthal angle. Then rewrite the Schrödinger equation in cylindrical 
coordinates as

Dividing this equation by

Ψ χ z r,( )Θ ϕ( )=

ϕ

h2

8π2
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z∂
∂ 1

me
-------

z∂
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 
  1

r
---

r∂
∂ r
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-------

r∂
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 
 + Θ–

h2

8π2
--------- χ

mer2
-------------

ϕ2

2

d

d Θ
– VχΘ+ EχΘ=
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and rearranging its terms lead to the two independent equations

 (1)

and

 (2)

Equation 1 has obvious solutions of the form

where the periodicity condition  implies that l, the principal quantum 
number, must be an integer. It remains to solve Equation 2, which you can rewrite as

Note that this is an instance of a PDE on coefficient form,

where the nonzero coefficients are

and λ = El.
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Results

This exercise models the eigenvalues for the four lowest electronic energy levels for the 
principal quantum number l = 0. The plots in Figure 2 show the eigenwave functions for 
those four states.

Figure 2: The four lowest electronic-energy levels for the case l = 0.

Notes About the COMSOL Implementation

To solve this problem, use the Coefficient Form PDE interface. The model solves for an 
eigenvalue/eigenfunction, for which you must input appropriate physical data and 
constants. Use electronvolts as the energy unit and nanometers as the length unit for the 
geometry.

Reference

1. R. Melnik and M. Willatzen, “Band structure of conical quantum dots with wetting 
layers,” Nanotechnology, vol. 15, pp. 1–8, 2004.
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Application Library path: COMSOL_Multiphysics/Equation_Based/
conical_quantum_dot

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Mathematics>PDE Interfaces>Coefficient Form PDE (c).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Eigenvalue.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

Define dimensionless parameters for the electron mass and the reduced Planck constant 
expressed in electronvolt units. You can obtain these values by dividing the SI-unit 
values of the corresponding predefined COMSOL Multiphysics constants, me_const 
and hbar_const, by the value of the elementary charge e_const in coulombs:

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

m me_const[1/kg]/
e_const[1/C]

5.6856E-12 Electron mass (eV/
c^2)

hbar hbar_const[1/(J*s)]/
e_const[1/C]

6.5821E-16 Reduced Planck 
constant (eV*s)
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G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose nm.

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 25.

4 In the Height text field, type 100.

5 Locate the Position section. From the Base list, choose Center.

6 In the r text field, type 12.5.

Rectangle 2 (r2)
1 Right-click Rectangle 1 (r1) and choose Build Selected.

2 On the Geometry toolbar, click Primitives and choose Rectangle.

3 In the Settings window for Rectangle, locate the Size and Shape section.

4 In the Width text field, type 25.

5 In the Height text field, type 2.

6 Locate the Position section. From the Base list, choose Center.

7 In the r text field, type 12.5.

Polygon 1 (pol1)
1 Right-click Rectangle 2 (r2) and choose Build Selected.

2 On the Geometry toolbar, click Primitives and choose Polygon.

3 In the Settings window for Polygon, locate the Coordinates section.

V_In 0 0 Potential barrier, 
InAs (eV)

V_Ga 0.697 0.697 Potential barrier, 
GaAs (eV)

c_In hbar^2/(2*0.023*m) 1.6565E-18 c coefficient, InAs

c_Ga hbar^2/(2*0.067*m) 5.6865E-19 c coefficient, GaAs

l 0 0 Principal quantum 
number

Name Expression Value Description
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4 In the r text field, type 0 12 0.

5 In the z text field, type 0 0 3.6.

Compose 1 (co1)
1 Right-click Polygon 1 (pol1) and choose Build Selected.

2 On the Geometry toolbar, click Booleans and Partitions and choose Compose.

3 Select the objects pol1 and r2 only.

4 In the Settings window for Compose, locate the Compose section.

5 In the Set formula text field, type r2+pol1.

6 Clear the Keep interior boundaries check box.

Compose 2 (co2)
1 Right-click Compose 1 (co1) and choose Build Selected.

2 On the Geometry toolbar, click Booleans and Partitions and choose Compose.

3 Click in the Graphics window and then press Ctrl+A to select both objects.

4 In the Settings window for Compose, locate the Compose section.

5 In the Set formula text field, type r1+co1.

6 Right-click Compose 2 (co2) and choose Build Selected.

7 Click the Zoom Extents button on the Graphics toolbar.
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C O E F F I C I E N T  F O R M  P D E  ( C )

Coefficient Form PDE 1
1 In the Model Builder window, expand the Component 1 (comp1)>Coefficient Form PDE (c) 

node, then click Coefficient Form PDE 1.

2 In the Settings window for Coefficient Form PDE, locate the Diffusion Coefficient 
section.

3 In the c text field, type c_In.

4 Locate the Absorption Coefficient section. In the a text field, type c_In*(l/r)^2+V_In.

5 Click to expand the Convection coefficient section. Locate the Convection Coefficient 
section. Specify the β vector as

Coefficient Form PDE 2
1 On the Physics toolbar, click Domains and choose Coefficient Form PDE.

2 Select Domains 1 and 3 only.

3 In the Settings window for Coefficient Form PDE, locate the Diffusion Coefficient 
section.

4 In the c text field, type c_Ga.

5 Locate the Absorption Coefficient section. In the a text field, type c_Ga*(l/r)^2+V_Ga.

6 Click to expand the Convection coefficient section. Locate the Convection Coefficient 
section. Specify the β vector as

Dirichlet Boundary Condition 1
1 On the Physics toolbar, click Boundaries and choose Dirichlet Boundary Condition.

2 Select Boundaries 2 and 9 only.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

-c_In/r r

0 z

-c_Ga/r r

0 z
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2 In the Settings window for Mesh, click Build All.

S T U D Y  1

Step 1: Eigenvalue
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Eigenvalue.

2 In the Settings window for Eigenvalue, locate the Study Settings section.

3 Select the Desired number of eigenvalues check box.

4 In the associated text field, type 4.

5 On the Home toolbar, click Compute.

R E S U L T S

2D Plot Group 1
Follow the instructions below to reproduce the series of plots in Figure 2.

Surface 1
In the Model Builder window, expand the 2D Plot Group 1 node.

Height Expression 1
1 Right-click Surface 1 and choose Height Expression.
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2 Click the Zoom Extents button on the Graphics toolbar.

Compare the result to the upper-left plot in Figure 2.

2D Plot Group 1
1 In the Model Builder window, under Results click 2D Plot Group 1.

2 In the Settings window for 2D Plot Group, locate the Data section.

3 From the Eigenvalue (rad/s) list, choose 0.39307.

4 On the 2D Plot Group 1 toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

Compare the result to the upper-right plot in Figure 2.

6 From the Eigenvalue (rad/s) list, choose 0.4587.

7 On the 2D Plot Group 1 toolbar, click Plot.

8 Click the Zoom Extents button on the Graphics toolbar.

Compare the result to the lower-left plot in Figure 2.

9 From the Eigenvalue (rad/s) list, choose 0.5649.

10 On the 2D Plot Group 1 toolbar, click Plot.

11 Click the Zoom Extents button on the Graphics toolbar.

Compare the result to the lower-right plot in Figure 2.
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Introduction

The flow of fluid behind a blunt body such as an automobile is difficult to compute due 
to the unsteady flows. The wake behind such a body consists of unordered eddies of all 
sizes that create large drag on the body. In contrast, the turbulence in the thin boundary 
layers next to the streamlined bodies of aircraft and fish create only weak disturbances of 
flow.

An exception to this occurs when you place a slender body at right angles to a slow flow 
because the eddies organize. A von Kármán vortex street appears with a predictable 
frequency and involves the shedding of eddies from alternating sides. Everyday examples 
of this phenomenon include singing telephone wires and an automobile radio antenna 
vibrating in an air stream.

From an engineering standpoint, it is important to predict the frequency of vibrations at 
various fluid speeds and thereby avoid undesirable resonances between the vibrations of 
the solid structures and the vortex shedding. To help reduce such effects, plant engineers 
put a spiral on the upper part of high smokestacks; the resulting variation in shape 
prohibits the constructive interference of the vortex elements that the structure sheds from 
different positions.

Model Definition

To illustrate how you can study such effects, the following model examines unsteady, 
incompressible flow past a long cylinder placed in a channel at right angle to the oncoming 
fluid. With a symmetric inlet velocity profile, the flow needs some kind of asymmetry to 
trigger the vortex production. This can be achieved by placing the cylinder with a small 
offset from the center of the flow. In this case, an unstructured mesh is used, and the small 
asymmetry in the mesh proves to be enough to trigger the vortex production.

The simulation time necessary for a periodic flow pattern to appear is difficult to predict. 
A key predictor is the Reynolds number, which is based on cylinder diameter. For low 
values (below 100) the flow is steady. In this simulation, the Reynolds number equals 100, 
which gives a developed von Kármán vortex street, but the flow still is not fully turbulent.

The frequency and amplitude of oscillations are stable features, but flow details are 
extremely sensitive to perturbations. To gain an appreciation for this sensitivity, you can 
compare flow images taken at the same time but with such minor differences as are created 
by different tolerances for the time stepping. It is important to note that this sensitivity is 
a physical reality and not simply a numerical artifact.
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Before calculating the time-varying forces on the cylinder, you can validate the method of 
computation at a lower Reynolds number using the direct nonlinear solver. This saves time 
because you can find and correct simple errors and mistakes before the final 
time-dependent simulation, which requires considerable time.

The viscous forces on the cylinder are proportional to the gradient of the velocity field at 
the cylinder surface. Evaluating the velocity gradient on the boundary by directly 
differentiating the FEM solution is possible but not very accurate. The differentiation 
produces 1st-order polynomials when second-order elements are used for the velocity 
field. A far better approach is to use a pair of reaction force operators to compute the 
integrals of the viscous forces, comparable to second-order accurate integrals of the viscous 
forces. An alternative approach would be to use a pair of weak-constraint variables to 
enforce the no slip condition. Preferably use the reaction force operator instead of weak 
constraints when computing integrals of reaction forces or fluxes in postprocessing.

The drag and lift forces themselves are not as interesting as the dimensionless drag and lift 
coefficients. These depend only on the Reynolds number and an object’s shape, not its 
size. The coefficients are defined as

using the following parameters:

• FD and FL are the drag and lift forces

• ρ is the fluid’s density

• Umean is the mean velocity

• L is the characteristic length, in this case the cylinder’s radius

CD
2FD

ρUmean
2 L

--------------------------=

CL
2FL

ρUmean
2 L

--------------------------=
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Results and Discussion

Figure 1 shows the flow pattern resulting from the geometry.

Figure 1: A plot of the last time step clearly shows the von Kármán path.

The flow around a cylinder is a common benchmark test for CFD algorithms. Various 
research teams have tried their strengths on this problem using different techniques. 
Results from some of these experiments have been collected by Schäfer and Turek (Ref. 
1), who also used them to compute a probable value for the “real” answer.

Figure 2 shows how the lift coefficient develops a periodic variation as the von Kármán 
vortex structure is formed.
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Figure 2: Lift coefficient, CL, as a function of time.

Figure 3: Drag coefficient, CD, as a function of time.
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Reference

1. M. Schäfer and S. Turek, “Benchmark Computations of Laminar Flow Around 
Cylinder,” E.H. Hirschel ed., Flow Simulation with High-Performance Computers II, 
Volume 52 of Notes on Numerical Fluid Mechanics, Vieweg, pp. 547–566, 1996.

Application Library path: COMSOL_Multiphysics/Fluid_Dynamics/cylinder_flow

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Fluid Flow>Single-Phase Flow>Laminar Flow (spf).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Next, create a smoothed step function feature that you will use for ramping up the inflow 
velocity.

Name Expression Value Description

U_mean 1[m/s] 1 m/s Mean inflow velocity
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Step 1 (step1)
1 On the Home toolbar, click Functions and choose Global>Step.

2 In the Settings window for Step, locate the Parameters section.

3 In the Location text field, type 0.1.

G E O M E T R Y  1

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 2.2.

4 In the Height text field, type 0.4.

Circle 1 (c1)
1 Right-click Rectangle 1 (r1) and choose Build Selected.

2 On the Geometry toolbar, click Primitives and choose Circle.

3 In the Settings window for Circle, locate the Position section.

4 In the x text field, type 0.2.

5 In the y text field, type 0.2.

6 Locate the Size and Shape section. In the Radius text field, type 0.05.

Difference 1 (dif1)
1 Right-click Circle 1 (c1) and choose Build Selected.

2 On the Geometry toolbar, click Booleans and Partitions and choose Difference.

3 Select the object r1 only.

4 In the Settings window for Difference, locate the Difference section.

5 Find the Objects to subtract subsection. Select the Active toggle button.

6 Select the object c1 only.

7 On the Geometry toolbar, click Build All.
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8 Click the Zoom Extents button on the Graphics toolbar.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, locate the Material Contents section.

2 In the table, enter the following settings:

L A M I N A R  F L O W  ( S P F )

Inlet 1
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 Select Boundary 1 only.

To define a parabolic velocity profile use the predefined local curve parameter s. Ramp 
up the velocity using the previously defined step function. Append the inverse unit 
bracket [1/s] to the time variable t because the step function expects a dimensionless 
argument.

Property Name Value Unit Property group

Density rho 1 kg/m³ Basic

Dynamic viscosity mu 1e-3 Pa·s Basic
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3 In the Settings window for Inlet, locate the Velocity section.

4 In the U0 text field, type U_mean*6*s*(1-s)*step1(t[1/s]).

Outlet 1
1 On the Physics toolbar, click Boundaries and choose Outlet.

2 Select Boundary 4 only.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Finer.

4 Click Build All.

If you zoom in on the inlet and the cylinder you can see the boundary layers that the 
physics-controlled mesh gives.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,0.2,3.4) range(3.5,0.02,7).
9 |  F L O W  P A S T  A  C Y L I N D E R



Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Study 1>Solver Configurations node.

3 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Time-Dependent Solver 1.

4 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

5 Locate the Time Stepping section. From the Steps taken by solver list, choose 
Intermediate.

6 On the Study toolbar, click Compute.

R E S U L T S

Velocity (spf)
Add a Particle Tracing with Mass node to the first default plot group to reproduce the plot 
in Figure 1.

1 In the Model Builder window, click Velocity (spf).

Particle Tracing with Mass 1
On the Velocity (spf) toolbar, click More Plots and choose Particle Tracing with Mass.

Velocity (spf)
1 In the Settings window for Particle Tracing with Mass, click to expand the Mass and 

velocity section.

2 Locate the Mass and Velocity section. In the Mass text field, type 4*pi/3*1e-9.

3 Find the Initial velocity subsection. In the x component text field, type u.

4 In the y component text field, type v.

5 Locate the Particle Positioning section. In the y text field, type range(0.1,0.05,0.3).

6 In the x text field, type 0.

7 Click to expand the Release section. From the Release particles list, choose At intervals.

8 Select the Start time check box.

9 In the associated text field, type 3.6.

10 In the Time between releases text field, type 0.4.

11 Click to expand the Coloring and style section. Locate the Coloring and Style section. Find 
the Line style subsection. From the Type list, choose None.

12 Find the Point style subsection. From the Type list, choose Point.
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13 Find the Point motion subsection. From the When particle leaves domain list, choose 
Disappear.

14 On the Velocity (spf) toolbar, click Plot.

To reproduce Figure 2 and Figure 3 of the lift and drag coefficients, first add an Integral 
data set for computing the total reaction force on the cylinder.

Integral 1
On the Results toolbar, click More Data Sets and choose Evaluation>Integral.

Selection
1 On the Results toolbar, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundaries 5–8 only.

1D Plot Group 3
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Data set list, choose Integral 1.

Point Graph 1
On the 1D Plot Group 3 toolbar, click Point Graph.

1D Plot Group 3
1 In the Settings window for Point Graph, locate the y-Axis Data section.

2 In the Expression text field, type -reacf(v)*2/(spf.rho*U_mean^2*0.1).

3 Select the Description check box.

4 In the associated text field, type Lift coefficient.

5 On the 1D Plot Group 3 toolbar, click Plot.

Compare the graph with that shown in Figure 2.

Finally, visualize the drag coefficient using the following steps:

1D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Data set list, choose Integral 1.
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Point Graph 1
On the 1D Plot Group 4 toolbar, click Point Graph.

1D Plot Group 4
1 In the Settings window for Point Graph, locate the y-Axis Data section.

2 In the Expression text field, type -reacf(u)*2/(spf.rho*U_mean^2*0.1).

3 Select the Description check box.

4 In the associated text field, type Drag coefficient.

5 On the 1D Plot Group 4 toolbar, click Plot.

Compare with Figure 3.
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Introduction

This example simulates a two-slit interference experiment with water waves or sound. The 
model mimics the plane-wave excitation with two thin waveguides leading to slits in a 
screen and computes the diffraction pattern on the other side of the screen.

Model Definition

Theory predicts amplitude minima along rays where the difference in travel distance is an 
odd multiple of half the wavelength, and maxima at even multiples. For n = 0, ±1, ±2, …:

In this example, the distance D between the slits is 2λ. Maxima should then be present at 
θ = 0° and 30°, while minima should appear at θ = 14.48° and 48.59°.

Equation
For time-harmonic propagation, the wave equation turns into the Helmholtz equation:

Boundary Conditions
The absorbing boundary conditions have the form

where n is the outward boundary normal vector. This follows directly from the assumption 
that the total wave consists of an incident plane wave plus an outgoing plane wave, both 
at normal incidence:

where the first term represents the outgoing wave and the second term the incident wave. 
For example, at the left boundary of a computational domain along the x axis, the normal 
derivative becomes

min,  θsin n 1
2
---+ 

  λ
D
----=

max,  θsin n λ
D
----=









∇– u∇( ) k2u–⋅ 0,       k 2π
λ

------= =

n u∇( )⋅ iku+ 2ik,    inflow=

n u∇( )⋅ iku+ 0,       outflow=

u u1eikx u2e ikx–
+=
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which means that

and for u2 = 1, you get the absorbing boundary condition at the inflow.

Results

The plot in Figure 1 shows the diffraction pattern clearly. The effect of quantization is that 
the numerical wavelength differs from λ, which results in a shift of the angles. You can 
correct for this effect by adjusting the value of k in the Helmholtz equation to the element 
size. These practices are important for modeling the interference effects of 
monochromatic waves.

Figure 1: Diffraction pattern in the simulated two-slit experiment.

n∂
∂u

x∂
∂u

– iku1eikx
– iku2e i– kx

+ ik u 2u2e ikx–
–( )–= = =

n∂
∂u iku+ 2iku2=
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Application Library path: COMSOL_Multiphysics/Equation_Based/
diffraction_patterns

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Mathematics>PDE Interfaces>Coefficient Form PDE (c).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Circle 1 (c1)
1 On the Geometry toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Sector angle text field, type 180.

Name Expression Value Description

l 0.1[m] 0.1 m Wavelength

k 2*pi[rad]/l 62.832 rad/m Wave number
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4 Locate the Position section. In the x text field, type 0.5.

5 Locate the Rotation Angle section. In the Rotation text field, type -90.

Rectangle 1 (r1)
1 Right-click Circle 1 (c1) and choose Build Selected.

2 On the Geometry toolbar, click Primitives and choose Rectangle.

3 In the Settings window for Rectangle, locate the Size and Shape section.

4 In the Width text field, type 0.5.

5 In the Height text field, type 0.03.

6 Locate the Position section. In the y text field, type -0.015-0.1.

Copy 1 (copy1)
1 Right-click Rectangle 1 (r1) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Copy.

3 Select the object r1 only.

4 In the Settings window for Copy, locate the Displacement section.

5 In the y text field, type 0.2.

Union 1 (uni1)
1 Right-click Copy 1 (copy1) and choose Build Selected.

2 On the Geometry toolbar, click Booleans and Partitions and choose Union.

3 Click in the Graphics window and then press Ctrl+A to select all objects.

4 In the Settings window for Union, locate the Union section.

5 Clear the Keep interior boundaries check box.

6 On the Geometry toolbar, click Build All.

The model geometry is now complete. Next, turn to the physics settings.

C O E F F I C I E N T  F O R M  P D E  ( C )

Coefficient Form PDE 1
1 In the Model Builder window, expand the Component 1 (comp1)>Coefficient Form PDE (c) 

node, then click Coefficient Form PDE 1.

2 In the Settings window for Coefficient Form PDE, locate the Absorption Coefficient 
section.

3 In the a text field, type -k^2.

4 Locate the Source Term section. In the f text field, type 0.
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Flux/Source 1
1 On the Physics toolbar, click Boundaries and choose Flux/Source.

2 Select Boundaries 1 and 4 only.

3 In the Settings window for Flux/Source, locate the Boundary Flux/Source section.

4 In the g text field, type 2*i*k-i*k*u.

Flux/Source 2
1 On the Physics toolbar, click Boundaries and choose Flux/Source.

2 Select Boundaries 11 and 12 only.

3 In the Settings window for Flux/Source, locate the Boundary Flux/Source section.

4 In the g text field, type -i*k*u.

M E S H  1

Create a mesh with a maximum element size determined by the wavelength. As a rule of 
thumb, you need 5 elements per wavelength for quadratic elements (the default for the 
PDE interface) to fully resolve the wave.

Size
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

Free Triangular.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. In the Maximum element size text field, type 
l/5.
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5 Click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

2D Plot Group 1
To reproduce the plot shown in Figure 1, just change the color table.

Surface 1
1 In the Model Builder window, expand the 2D Plot Group 1 node, then click Surface 1.

2 In the Settings window for Surface, locate the Coloring and Style section.

3 From the Color table list, choose WaveLight.

4 On the 2D Plot Group 1 toolbar, click Plot.
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This example introduces the concept of effective diffusivity in porous media by comparing 
the transport through an artificial porous structure described in a detailed model with a 
simplified homogeneous porous media approach using effective transport properties.

The exercise consists of two parts. The first part describes how to create the model with a 
detailed geometry. The second part shows how to define a homogeneous model for 
porous media using an effective diffusivity calculated using the detailed model from the 
first part.

Introduction

Transport through porous structures is usually treated using simplified homogeneous 
models with effective transport properties. This is in most cases a necessity, since the typical 
dimensions of the pores and particles making up the porous structure are several orders of 
magnitude smaller than the size of the domain that is to be modeled.

However, it might be interesting to investigate the assumptions and simplifications done 
when homogenizing a porous structure by comparing a homogeneous model with a 
model defined using the detailed structure.

The artificial porous structure used in this example is shown in Figure 1 below.

Figure 1: Artificial porous structure. The domain colored in red is accessible for diffusion.

Model Definition

The model equation in the modeled domain shown in Figure 1 is the time-dependent 
equation

Flux 
boundaries

Concentration 
boundary
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where c denotes concentration (mol/m3 using SI units) and D the diffusion coefficient 
(m2/s) of the solute.

The boundary conditions are of three different types. A concentration boundary condition 
applies at the left vertical boundary in Figure 1. It is expressed as

where c0 is a given concentration.

The right vertical boundary in Figure 1 is set according to

where km is the mass transfer coefficient (m/s), and c1 is the concentration in a bulk 
solution outside of the porous structure.

All other boundaries are insulating boundaries according to

The initial condition is given by a bell-shaped profile along the x-axis with its maximum at 
x = 0 and a corresponding value of c = c0:

Assume a gaseous solution with a solute content of 3 mol/m3 at the concentration 
boundary. The diffusion coefficient is set to 1·10−5 m2/s.

The second part of this exercise uses a homogenized 1D model geometry with effective 
transport properties and an average porosity. The model equation then becomes:

where ε denotes the average porosity and Deff the effective diffusivity. These properties are 
calculated from the results of the detailed structure; see the next section. At the 
boundaries, the concentration and flux conditions described above apply.

∂c
∂t
----- ∇+ D c∇–( )⋅ 0=

c c0=

D c∇–( ) n⋅ km c c1–( )=

D c∇–( ) n⋅ 0=

c t0( ) c0 ax2
–( )exp=

ε∂c
∂t
----- ∇+ Deff c∇–( )⋅ 0=
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Results and Discussion

The simulations are run for t = 0 to 0.1 s, when the simulation reaches steady state. 
Figure 2 below shows the concentration profile after 0.05 s in the porous structure. 
Already at this stage the concentration has almost reached steady state, which is visible by 
the nearly linear concentration profile across the structure.

Figure 2: Concentration profile in the modeled artificial porous structure at t = 0.05 s.

When modeling porous media, the exact concentration in the pore structure is not the 
most important issue because the description of the structure is homogenized and not 
detailed as in Figure 2. The most interesting issue is then the description of the flux. To 
calculate the average flux, integrate over the flux boundary and divide by its length, L0, 
which yields the following expression:

Figure 3 shows the value of this integral as a function of time. If you let the process reach 
steady-state, the average flux becomes 8.051·10−3 mol·m2/s. Considering the almost 
linear profile across the structure, it is natural to replace the porous structure with a 1D 

Naverage
1

L0
------ km c c1–( ) Sd

0

L0

=
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homogenized structure along the x-axis. It is then possible to calculate the effective 
diffusivity according to the following:

where cout is the average concentration (mol/m3) at the flux boundary, and L1 is the 
length of the geometry along the x-axis. The average concentration is obtained by 
integrating according to the expression below:

This gives an average concentration cout = 1.61·10−3 mol/m3. Using L1 = 8·10−4 m, the 
effective diffusivity is:

which yields a value for the effective diffusivity of 2.15·10−6 m2/s compared to the “free” 
diffusivity of 1·10−5 m2/s. The effective and “free” diffusivities are usually related 
according to the equation

where ε is the porosity of the structure and τ the tortuosity, which is a measure of the actual 
length per unit effective length a molecule has to diffuse in a porous structure. To calculate 
the porosity of the modeled structure, you integrate the value 1 over the structure and 
then divide this by the length and width of the structure:

resulting in a value of 0.382. The value of τ can then be calculated to 1.78. In addition, 
the tortuosity is usually expressed as a power of the porosity, resulting in an expression for 
the effective diffusivity according to

Deff c0 cout–( )
L1

-------------------------- Naverage=

cout
1

L0
------ c S.d

0

L0

=

Deff 8.051 10 3– 8.0 10 4–⋅×⋅
3 1.61 10 3–⋅–( )

--------------------------------------------------------------=

Deff Dε
τ
--=

ε 1
L0L1
-------------- 1 xd yd

0

L0


0

L1

=

Deff Dεp
=
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If you use the calculated values for porosity and effective diffusivity, the value for p is 1.60. 
The experimental values for p for porous structures used for transport in catalysts, soils, 
and other porous structures is usually in the range 1.5–2.

Using the value of the effective diffusivity, a simple homogenized 1D model provides the 
possibility to compare the value of the flux using a homogenized model to the value using 
the detailed 2D structure. Figure 3 shows that there is an excellent agreement between the 
model using a detailed geometry and the homogenized model. The difference in the 
time-dependent flux is hardly visible between the two cases in the graph.

Figure 3: Average flux at the flux boundary in the detailed 2D model (solid blue line) and 
the 1D homogenized approximation (dashed green line).

Notes About the COMSOL Implementation

Both models described above are straightforward to define in COMSOL Multiphysics. 
One feature that is of great use in this example is the ability to define integration coupling 
operators to generate the values of the integrals needed to evaluate the results. The 
definition of these integrals is described in detail in the step-by-step instructions below.
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Application Library path: COMSOL_Multiphysics/Diffusion/
effective_diffusivity

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Chemical Species Transport>Transport of Diluted Species 

(tds).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 From the Source list, choose COMSOL Multiphysics file.

4 Click Browse.

5 Browse to the application’s Application Libraries folder and double-click the file 
effective_diffusivity.mphbin.

6 Click Import.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

Variables 1
1 On the Home toolbar, click Variables and choose Global Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

D E F I N I T I O N S

Next, define selections that will be useful when defining the boundary conditions and an 
integration coupling operator, and also during postprocessing.

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Model Builder window, right-click Explicit 1 and choose Rename.

3 In the Rename Explicit dialog box, type Left boundary in the New label text field.

4 Click OK.

5 In the Settings window for Explicit, locate the Input Entities section.

6 From the Geometric entity level list, choose Boundary.

7 Select Boundary 1 only.

Explicit 2
1 On the Definitions toolbar, click Explicit.

2 In the Model Builder window, right-click Explicit 2 and choose Rename.

3 In the Rename Explicit dialog box, type Right boundary in the New label text field.

4 Click OK.

5 In the Settings window for Explicit, locate the Input Entities section.

6 From the Geometric entity level list, choose Boundary.

Name Expression Value Description

D2 1e-5[m^2/s] 1E-5 m²/s Diffusion coefficient

c_max 3[mol/m^3] 3 mol/m³ Peak initial concentration

k_f 5[m/s] 5 m/s Mass transfer coefficient

a 1000 1000 Dimensionless constant

Name Expression Unit Description

c0 c_max*exp(a*(-(x/
0.4[mm])^2))

mol/m³ Initial concentration
8 |  E F F E C T I V E  D I F F U S I V I T Y  I N  P O R O U S  M A T E R I A L S



7 Select Boundary 276 only.

Explicit 3
1 On the Definitions toolbar, click Explicit.

2 In the Model Builder window, right-click Explicit 3 and choose Rename.

3 In the Rename Explicit dialog box, type Top-right vertex in the New label text field.

4 Click OK.

5 In the Settings window for Explicit, locate the Input Entities section.

6 From the Geometric entity level list, choose Point.

7 Select Point 532 only.

TR A N S P O R T  O F  D I L U T E D  S P E C I E S  ( T D S )

1 In the Settings window for Transport of Diluted Species, locate the Transport 

Mechanisms section.

2 Clear the Convection check box.

This setting gives a pure diffusion interface.

Transport Properties 1
1 In the Model Builder window, expand the Transport of Diluted Species (tds) node, then 

click Transport Properties 1.

2 In the Settings window for Transport Properties, locate the Diffusion section.

3 In the Dc text field, type D2.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Transport of Diluted Species 

(tds) click Initial Values 1.

2 In the Settings window for Initial Values, locate the Initial Values section.

3 In the c text field, type c0.

Concentration 1
1 On the Physics toolbar, click Boundaries and choose Concentration.

2 In the Settings window for Concentration, locate the Boundary Selection section.

3 From the Selection list, choose Left boundary.

4 Locate the Concentration section. Select the Species c check box.

5 In the c0,c text field, type c_max.
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Flux 1
1 On the Physics toolbar, click Boundaries and choose Flux.

2 In the Settings window for Flux, locate the Boundary Selection section.

3 From the Selection list, choose Right boundary.

4 Locate the Inward Flux section. From the Flux type list, choose External forced convection.

5 Select the Species c check box.

6 In the kc, c text field, type k_f.

D E F I N I T I O N S

Proceed to define a variable for the average flux through the porous structure. Begin by 
defining an Average coupling operator on the rightmost boundary.

Average 1 (aveop1)
1 On the Definitions toolbar, click Component Couplings and choose Average.

2 In the Settings window for Average, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Right boundary.

Variables 2
1 On the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, click Build All.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 From the Time unit list, choose ms.

Name Expression Unit Description

flux_avg aveop1(k_f*c) mol/(m²·s) Average flux
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4 In the Times text field, type range(0,2,100).

5 On the Home toolbar, click Compute.

R E S U L T S

Concentration (tds)
1 Click the Zoom Extents button on the Graphics toolbar.

The default plot shows concentration at the end time, that is, 0.1 seconds.

You can plot the concentration at different time steps.

2 In the Model Builder window, click Concentration (tds).

3 In the Settings window for 2D Plot Group, locate the Data section.

4 From the Time (ms) list, choose 50.

5 On the Concentration (tds) toolbar, click Plot.

Compare this plot to the one shown in Figure 2.

1D Plot Group 2
Now, plot the average flux.

On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

Point Graph 1
1 On the 1D Plot Group 2 toolbar, click Point Graph.

2 In the Settings window for Point Graph, locate the Selection section.
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3 From the Selection list, choose Top-right vertex.

4 Click Replace Expression in the upper-right corner of the y-axis data section. From the 
menu, choose Model>Component 1>Definitions>Variables>flux_avg - Average flux.

1D Plot Group 2
1 In the Model Builder window, under Results click 1D Plot Group 2.

2 In the Settings window for 1D Plot Group, click to expand the Title section.

3 In the Label text field, type Molar fluxes.

4 Locate the Title section. From the Title type list, choose None.

5 Locate the Plot Settings section. Select the y-axis label check box.

6 In the associated text field, type Average flux (mol/(m*s)).

7 On the Molar fluxes toolbar, click Plot.

To get the porosity of the domain for the 1D model, perform a surface integration.

Surface Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 In the Settings window for Surface Integration, locate the Selection section.

3 From the Selection list, choose All domains.
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4 Locate the Expressions section. In the table, enter the following settings:

The denominator in this expression represents the product of the length and the width 
of the 2D model structure.

5 Click Evaluate.

TA B L E

1 Go to the Table window.

The evaluated value of the integral should be close to 0.383.

R O O T

Now turn to the 1D model.

On the Home toolbar, click Add Component and choose 1D.

G E O M E T R Y  2

In the Model Builder window, under Component 2 (comp2) click Geometry 2.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Chemical Species Transport>Transport of Diluted Species (tds).

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Study 1.

5 Click Add to Component in the window toolbar.

6 On the Home toolbar, click Add Physics to close the Add Physics window.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Transport of Diluted Species (tds) interface.

4 Find the Studies subsection. In the Select Study tree, select Preset Studies>Time 

Dependent.

Expression Unit

1/(0.8[mm])^2 1
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5 Click Add Study in the window toolbar.

6 On the Home toolbar, click Add Study to close the Add Study window.

G E O M E T R Y  2

Interval 1 (i1)
1 On the Geometry toolbar, click Interval.

2 In the Settings window for Interval, locate the Interval section.

3 In the Right endpoint text field, type 8e-4.

4 Right-click Interval 1 (i1) and choose Build Selected.

5 Click the Zoom Extents button on the Graphics toolbar.

G L O B A L  D E F I N I T I O N S

Parameters
Add the following parameters to those you already defined.

1 In the Model Builder window, under Global Definitions click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

TR A N S P O R T  O F  D I L U T E D  S P E C I E S  2  ( T D S 2 )

On the Physics toolbar, click Transport of Diluted Species (tds) and choose Transport of 

Diluted Species 2 (tds2).

1 In the Model Builder window, under Component 2 (comp2) click Transport of Diluted 

Species 2 (tds2).

2 In the Settings window for Transport of Diluted Species, locate the Transport 

Mechanisms section.

3 Clear the Convection check box.

Transport Properties 1
1 In the Model Builder window, expand the Transport of Diluted Species 2 (tds2) node, then 

click Transport Properties 1.

Name Expression Value Description

epsilon 0.383 0.383 Porosity

D1 2.15e-6[m^2/s] 2.15E-6 m²/s Diffusion 
coefficient, 1D
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2 In the Settings window for Transport Properties, locate the Diffusion section.

3 In the Dc2 text field, type D1/epsilon.

Initial Values 1
1 In the Model Builder window, under Component 2 (comp2)>Transport of Diluted Species 

2 (tds2) click Initial Values 1.

2 In the Settings window for Initial Values, locate the Initial Values section.

3 In the c2 text field, type c0.

Concentration 1
1 On the Physics toolbar, click Boundaries and choose Concentration.

2 Select Boundary 1 only.

3 In the Settings window for Concentration, locate the Concentration section.

4 Select the Species c2 check box.

5 In the c0,c2 text field, type c_max.

Flux 1
1 On the Physics toolbar, click Boundaries and choose Flux.

2 Select Boundary 2 only.

3 In the Settings window for Flux, locate the Inward Flux section.

4 From the Flux type list, choose External forced convection.

5 Select the Species c2 check box.

6 In the kc, c2 text field, type k_f/epsilon.

D E F I N I T I O N S

Create a variable for the flux in the homogenized 1D model.

Variables 3
1 On the Home toolbar, click Variables and choose Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

M E S H  2

1 In the Model Builder window, under Component 2 (comp2) click Mesh 2.

Name Expression Unit Description

flux_hom k_f*c2 mol/(m²·s) Flux, 1D model
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2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Extra fine.

4 Click Build All.

S T U D Y  2

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 2 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 From the Time unit list, choose ms.

4 In the Times text field, type range(0,2,100).

5 On the Home toolbar, click Compute.

R E S U L T S

Concentration (tds2)
The default plot for the 1D model shows the concentration for all time steps.

Finally, plot the result for the flux at the flux boundary in the homogenized 1D model in 
the same plot as the 2D result for comparison.
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Molar fluxes
In the Model Builder window, under Results click Molar fluxes.

Point Graph 2
1 On the Molar fluxes toolbar, click Point Graph.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (3) (sol2).

4 Select Boundary 2 only.

5 Click Replace Expression in the upper-right corner of the y-axis data section. From the 
menu, choose Model>Component 2>Definitions>Variables>flux_hom - Flux, 1D model.

6 Click to expand the Coloring and style section. Locate the Coloring and Style section. Find 
the Line style subsection. From the Line list, choose Dashed.

7 On the Molar fluxes toolbar, click Plot.

Compare the result with that shown in Figure 3.
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Introduction

Resonance can at times be a problem in everyday life. The low bass notes from the music 
system or home theater in the living room can shake the windows and make the floor 
vibrate. This happens only for certain frequencies—the eigenfrequencies of the room.

It is only in the low-frequency range that the eigenfrequencies are well separated. In the 
mid- and high-frequency ranges, the eigenfrequencies are packed so closely, with less than 
a halftone between them, that the individual resonances are insignificant for music and 
other natural sounds. Nevertheless, the music experience is affected by the acoustics of the 
room.

When designing a concert hall, it is extremely important to take the resonances into 
account. For a clear and neutral sound, the eigenfrequencies should be evenly spaced. For 
the home theater or music system owner, who cannot change the shape of the living room, 
another question is more relevant: Where should the speakers be located for the best 
sound?

Model Definition

For example, take a room with the dimensions 5 by 4 by 2.6 meters equipped with a 
flat-screen TV, a sideboard, two speakers, and a couch. To illustrate the effects on the 
music, compute a few resonance frequencies in the vicinity of 90 Hz together with the 
corresponding eigenmodes. The eigenmode shows the sound intensity pattern for its 
associated eigenfrequency. From the characteristics of the eigenmodes, you can draw some 
conclusions as to where the speakers should be placed.

D O M A I N  E Q U A T I O N S

Sound propagating in free air is described by the wave equation:

where p is the pressure, and c is the speed of sound. If the air is brought into motion by a 
harmonically oscillating source, for example, a loudspeaker, only one frequency f exists in 
the room. For that reason it makes sense to look for a time-harmonic solution on the form

The wave equation then simplifies to the Helmholtz equation for p, the amplitude of the 
acoustic disturbances:

pΔ–
1

c2
-----

t2

2

∂

∂ p
+ 0=

p p̂e iωt
=
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B O U N D A R Y  C O N D I T I O N S

This model assumes that all boundaries—walls, floor, ceiling, and furniture —are perfectly 
rigid (sound hard boundaries). This means that it returns no information of the damping 
properties of the room, but the distribution of the pressure should still be reasonably 
correct.

A N A L Y T I C  C O M P A R I S O N

It is possible to solve the simpler case of an empty room analytically. Each eigenfrequency 
corresponds to an integer triple (i, l, m):

The eigenmodes can be divided into three distinct classes:

• Eigenfrequencies with only one index different from zero give rise to axial modes, that 
is, plane standing waves between two opposite walls.

• If one index is zero, the mode is tangential.

• If all indices are different from zero, the mode is oblique.

Theoretical resonance frequencies below 100 Hz for a room without furniture are found 
in the following table.

MODE INDEX FREQUENCY MODE INDEX FREQUENCY

0,0,0 0 0,1,1 78.7

1,0,0 34.3 2,1,0 80.9

0,1,0 42.9 0,2,0 85.8

1,1,0 54.9 1,1,1 85.8

0,0,1 66.0 1,2,0 92.4

2,0,0 68.6 2,0,1 95.2

1,0,1 74.3 3,0,0 103

p̂Δ ω2

c2
------p̂+ 0=

fi l m, ,
c
2
--- i

Lx
------ 

  2 l
Ly
------ 

  2 m
Lz
------ 

  2
+ +=
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Results and Discussion

The relevant quantity when it comes to placing the loudspeakers is the amplitude of the 
standing pressure wave. A sound source excites an eigenmode the most if it is placed in 
one of the pressure antinodes for the mode. Conversely, with the source in a pressure node, 
the eigenmode remains silent.

All modes have local maxima in the corners of an empty room so speakers in the corners 
excite all eigenfrequencies. This simulation predicts eigenmodes that strongly resemble 
those of the corresponding empty room. The higher the frequency, the more the placing 
of the furniture matters. For instance, some of the high-frequency eigenmodes are located 
behind the couch.

In the strictest sense, the results of this simulation only apply to a room with perfectly rigid 
walls and nonabsorbing furniture. The prediction that speakers placed in the corners of the 
room excite many eigenmodes and give a fuller and more neutral sound, however, holds 
for real-life rooms.

Figure 1: The sound pressure distribution for an eigenfrequency of 99.5 Hz. The real part of 
the pressure is visualized as an isosurface plot, and the absolute value of the pressure as a 
boundary plot. Note that this mode does not correspond to any of the analytical modes listed 
above.
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Notes About the COMSOL Implementation

When simulating acoustics, or in general any wave phenomenon, it is important to resolve 
the expected wavelength properly. As a rule of thumb, 6 second-order element per 
wavelength is a reasonable trade-off between computational effort and accuracy. For this 
example, where wavelengths of interest are below 100 Hz, this implies a maximum 
element size of 

Therefore, an element size of 57 cm or less, corresponding to at least five elements 
between floor and ceiling, provides sufficient accuracy. The default mesh for this geometry 
meets the requirement. However, in general it is advisable to specify a maximum element 
size explicitly in the mesh settings.

Application Library path: COMSOL_Multiphysics/Acoustics/eigenmodes_of_room

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Acoustics>Pressure Acoustics>Pressure Acoustics, 

Frequency Domain (acpr).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Eigenfrequency.

6 Click Done.

G E O M E T R Y  1

The geometry in this model can be created within COMSOL Multiphysics. Here it is 
imported for convenience.

hmax
λ
6
--- c

6f
----- 343

6 100⋅
-----------------= = =
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Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
eigenmodes_of_room.mphbin.

5 Click Import.

6 Click the Wireframe Rendering button on the Graphics toolbar.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, type Air in the Label text field.

2 Select Domain 1 only.

3 In the Settings window for Material, locate the Material Contents section.

4 In the table, enter the following settings:

P R E S S U R E  A C O U S T I C S ,  F R E Q U E N C Y  D O M A I N  ( A C P R )

The boundary conditions are all Sound hard boundary (wall) by default.

S T U D Y  1

Step 1: Eigenfrequency
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 In the Search for eigenfrequencies around text field, type 90.

This setting will get you at least 6 solutions with eigenfrequencies in the vicinity of 
90 Hz. For this model you typically get additional eigensolutions that the eigenvalue 
solver finds.

4 On the Home toolbar, click Compute.

Property Name Value Unit Property group

Density rho 1.25 kg/m³ Basic

Speed of sound c 343 m/s Basic
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R E S U L T S

Acoustic Pressure (acpr)
The first default plot shows the pressure distribution on the exterior boundaries of the 
geometry. To see what goes on inside the room, you need to suppress some of the 
boundaries. This is most conveniently done by first selecting all boundaries and then 
removing a few of them (number 1, 2, and 4) from the selection.

Study 1/Solution 1 (sol1)
In the Model Builder window, expand the Results>Data Sets node, then click Study 1/Solution 

1 (sol1).

Selection
1 On the Results toolbar, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose All boundaries.

5 Select Boundaries 3 and 5–79 only.

Surface 1
1 In the Model Builder window, expand the Results>Acoustic Pressure (acpr) node, then 

click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Pressure Acoustics, 

Frequency Domain>Pressure and sound pressure level>acpr.absp - Absolute pressure.

3 On the Acoustic Pressure (acpr) toolbar, click Plot.
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4 Click the Zoom Extents button on the Graphics toolbar.

The first plot group now shows the distribution of the absolute value of the pressure for 
the lowest one of the eigenfrequencies, 74.9 Hz. This appears to be the (1,0,1) mode.

Acoustic Pressure, Isosurfaces (acpr)
The third default plot shows the isosurfaces for the same frequency.

Isosurface 1
1 In the Model Builder window, expand the Acoustic Pressure, Isosurfaces (acpr) node, then 

click Isosurface 1.

2 In the Settings window for Isosurface, locate the Levels section.

3 In the Total levels text field, type 5.
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4 On the Acoustic Pressure, Isosurfaces (acpr) toolbar, click Plot.

Modify the third default plot to show the isosurfaces and pressure distribution at 85 Hz; 
this is the (1,1,1) mode.

Acoustic Pressure, Isosurfaces (acpr)
1 In the Model Builder window, under Results click Acoustic Pressure, Isosurfaces (acpr).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Eigenfrequency (Hz) list, choose 85.077.

Surface 1
1 Right-click Results>Acoustic Pressure, Isosurfaces (acpr) and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Pressure Acoustics, 

Frequency Domain>Pressure and sound pressure level>acpr.absp - Absolute pressure.

3 On the Acoustic Pressure, Isosurfaces (acpr) toolbar, click Plot.

Isosurface 1
1 In the Model Builder window, under Results>Acoustic Pressure, Isosurfaces (acpr) click 

Isosurface 1.

2 In the Settings window for Isosurface, locate the Coloring and Style section.
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3 Clear the Color legend check box.

Acoustic Pressure, Isosurfaces (acpr)
Finally, reproduce Figure 1.

1 In the Model Builder window, under Results click Acoustic Pressure, Isosurfaces (acpr).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Eigenfrequency (Hz) list, choose 99.517.
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4 On the Acoustic Pressure, Isosurfaces (acpr) toolbar, click Plot.

This mode looks a little different from what you would find in an empty room. It is 
focused behind the couch.
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Introduction

This example illustrates—in a simplified electrostatic setting—electric impedance 
tomography (EIT), a method used for imaging of the distribution of electrical permittivity 
in an object. The tomography is performed by measuring currents and voltages at the 
object’s surface.

An application of this technique is medical diagnosis. Due to the different electrical 
properties of various organs and parts of the body, it is possible to obtain information on 
their position and movement in a non-invasive way.

This model shows how to determine from the outside the shape and the placement of small 
objects with different material properties inside a box. Applying a potential difference on 
the boundaries of the box creates a surface charge density that varies depending on the 
permittivity distribution inside the box.

Model Definition

This model solves Gauss’ law with ρ = 0:

The box contains air with εr equal to 1. The different objects are made of materials with 
different values of the relative permittivity, εr: 1, 2, and 3.

To get a voltage difference, a ground condition (V = 0) is set on the bottom while the 
condition V = 1 is applied on the top of the box. On the side, the boundary condition used 
is electric insulation: n · D = 0.

Results and Discussion

As seen in Figure 1, the surface charge density is higher in correspondence of materials 
with higher permittivity, as expected. An imaging of the figures inside the box is 
reproduced in the surface charge density plot.

∇ ε0εr∇V( )⋅– ρ=
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Figure 1: Surface charge density (boundary), electric field (streamline density), and electric 
potential (streamline color).

Inside the geometry the streamlines show how the electric field varies. The electric field is 
lower in media with larger value of the permittivity.

Application Library path: COMSOL_Multiphysics/Electromagnetics/
electric_sensor

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.
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2 In the Select Physics tree, select AC/DC>Electrostatics (es).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, locate the Plane Definition section.

3 In the z-coordinate text field, type 0.1.

4 Click Show Work Plane.

Rectangle 1 (r1)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.5.

4 In the Height text field, type 2.

5 Locate the Position section. In the xw text field, type -1.

6 In the yw text field, type 0.5.

7 Right-click Rectangle 1 (r1) and choose Build Selected.

Rectangle 2 (r2)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 1.5.

4 In the Height text field, type 0.25.

5 Locate the Position section. In the xw text field, type -1.5.

6 In the yw text field, type 1.

7 Right-click Rectangle 2 (r2) and choose Build Selected.

Rectangle 3 (r3)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.
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3 In the Width text field, type 1.5.

4 In the Height text field, type 0.25.

5 Locate the Position section. In the xw text field, type -1.5.

6 In the yw text field, type 1.75.

7 Right-click Rectangle 3 (r3) and choose Build Selected.

Union 1 (uni1)
1 On the Work Plane toolbar, click Booleans and Partitions and choose Union.

2 Click in the Graphics window and then press Ctrl+A to select all objects.

3 In the Settings window for Union, locate the Union section.

4 Clear the Keep interior boundaries check box.

5 Right-click Union 1 (uni1) and choose Build Selected.

6 Click the Zoom Extents button on the Graphics toolbar.

Ellipse 1 (e1)
1 On the Work Plane toolbar, click Primitives and choose Ellipse.

2 In the Settings window for Ellipse, locate the Size and Shape section.

3 In the a-semiaxis text field, type 0.5.

4 Locate the Position section. In the xw text field, type 1.5.

5 In the yw text field, type 1.5.

6 Right-click Ellipse 1 (e1) and choose Build Selected.

7 Click the Zoom Extents button on the Graphics toolbar.

Ellipse 2 (e2)
1 On the Work Plane toolbar, click Primitives and choose Ellipse.

2 In the Settings window for Ellipse, locate the Size and Shape section.

3 In the b-semiaxis text field, type 0.5.

4 Locate the Position section. In the xw text field, type 1.5.

5 In the yw text field, type 1.5.

6 Right-click Ellipse 2 (e2) and choose Build Selected.

Compose 1 (co1)
1 On the Work Plane toolbar, click Booleans and Partitions and choose Compose.

2 Select the objects e1 and e2 only.

3 In the Settings window for Compose, locate the Compose section.
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4 Clear the Keep interior boundaries check box.

5 In the Set formula text field, type e1+e2.

6 Right-click Compose 1 (co1) and choose Build Selected.

7 Click the Zoom Extents button on the Graphics toolbar.

Work Plane 1 (wp1)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Work Plane 1 

(wp1).

Extrude 1 (ext1)
1 On the Geometry toolbar, click Extrude.

2 In the Settings window for Extrude, locate the Distances from Plane section.

3 In the table, enter the following settings:

4 Right-click Extrude 1 (ext1) and choose Build Selected.

5 Click the Zoom Extents button on the Graphics toolbar.

Distances (m)

0.8
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Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 5.

4 In the Depth text field, type 3.

5 Locate the Position section. In the x text field, type -2.

6 Click Build All Objects.

7 Click the Zoom Extents button on the Graphics toolbar.

8 Click the Transparency button on the Graphics toolbar.

This completes the model geometry.

E L E C T R O S T A T I C S  ( E S )

Ground 1
1 On the Physics toolbar, click Boundaries and choose Ground.

2 Select Boundary 3 only.

Electric Potential 1
1 On the Physics toolbar, click Boundaries and choose Electric Potential.
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2 Select Boundary 4 only.

3 In the Settings window for Electric Potential, locate the Electric Potential section.

4 In the V0 text field, type 1.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, locate the Material Contents section.

2 In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 Select Domain 2 only.

3 In the Settings window for Material, locate the Material Contents section.

4 In the table, enter the following settings:

Material 3 (mat3)
1 Right-click Materials and choose Blank Material.

2 Select Domain 3 only.

3 In the Settings window for Material, locate the Material Contents section.

4 In the table, enter the following settings:

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

Property Name Value Unit Property 
group

Relative permittivity epsilonr 1 1 Basic

Property Name Value Unit Property 
group

Relative permittivity epsilonr 2 1 Basic

Property Name Value Unit Property 
group

Relative permittivity epsilonr 3 1 Basic
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2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Fine.

4 Click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Electric Potential (es)
To reproduce the plot shown in Figure 1, begin by suppressing some boundaries so that 
the inside of the box becomes visible.

Study 1/Solution 1 (sol1)
In the Model Builder window, expand the Results>Data Sets node, then click Study 1/Solution 

1 (sol1).

Selection
1 On the Results toolbar, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.
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4 From the Selection list, choose All boundaries.

5 Select Boundaries 3–5 and 38 only.

6 Click the Transparency button on the Graphics toolbar.

Remove the default slice plot of the potential.

Electric Potential (es)
1 In the Model Builder window, under Results right-click Electric Potential (es) and choose 

Delete.

2 Click Yes to confirm.

3D Plot Group 1
On the Results toolbar, click 3D Plot Group.

Surface 1
1 In the Model Builder window, right-click 3D Plot Group 1 and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Electrostatics>

Currents and charge>es.nD - Surface charge density.

3 Locate the Expression section. In the Unit field, type pC/m^2.

4 Locate the Coloring and Style section. From the Color table list, choose Cyclic.

5 On the 3D Plot Group 1 toolbar, click Plot.

6 Click the Zoom Extents button on the Graphics toolbar.

3D Plot Group 1
In the Model Builder window, under Results right-click 3D Plot Group 1 and choose 
Streamline.

Streamline 1
1 In the Settings window for Streamline, locate the Streamline Positioning section.

2 From the Positioning list, choose Magnitude controlled.

3 Locate the Coloring and Style section. From the Line type list, choose Tube.

Color Expression 1
1 Right-click Results>3D Plot Group 1>Streamline 1 and choose Color Expression.

2 In the Settings window for Color Expression, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Model>Component 1>

Electrostatics>Electric>es.normE - Electric field norm.
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3 Click to expand the Title section. From the Title type list, choose Automatic.

Compare the resulting plot with that in Figure 1.
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Introduction

This example illustrates the principle of electrochemical polishing. The simplified 2D 
model geometry consists of two electrodes and an intermediate electrolyte domain. The 
positive electrode has a protrusion, representing a surface defect. The purpose of the 
application is to examine how this protrusion and the surrounding electrode material are 
depleted over a period of time.

Model Definition

The potential drop over the electrodes is 30 V, and the electrolyte has a conductivity of 
10 S/m.

Figure 1: Model geometry.

Modeling the depletion of the positive electrode requires a moving boundary because the 
geometry changes and the current density distribution with it. A simple model for the 
depletion is based on the assumption that the depletion rate is proportional to the normal 
current density at the electrode surface. The velocity, U, normal to the mesh at the 
electrode surface then becomes

 (1)

where K is the coefficient of proportionality, and Jn is the normal current density. In this 
example, K = 10−11 m3/As. 

The part of the electrode and electrolyte that the model includes is about 3 mm wide and 
the distance between the electrodes is 0.4 mm.

Electrode material

Electrode material

Ground (0 V)

Electrolyte

30 V

U KJn–=
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Results and Discussion

After a period of 10 s, the protrusion is somewhat smoothed out, and a significant portion 
of the positive electrode has been depleted.

Figure 2: Potential distribution and electrode depletion after 10 s.

Using Equation 1, the expected total depletion increment, d(Δt = 10 s), over the 
simulated time interval can be estimated as

 (2)

This estimate agrees with the maximum value for the y-displacement obtained for the 
model, showing that the approximate formula (which does not take effects from the 
curved boundary into account) is in fact very accurate.

Notes About the COMSOL Implementation

This application uses the Electric Currents and Deformed Geometry interfaces. The 
variable for the normal current density defines the mesh velocity. The dynamics in this 

d Δt( ) U Δt K Jn Δt 10 11–  m
3

As
------- 

  106 A
m
----- 

  101s( )⋅ ⋅ 10 4–  m= = = =
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example is quasi-static in nature, and the time dependence only enters in the depletion 
(removal of material) of the electrode.

Application Library path: COMSOL_Multiphysics/Electromagnetics/
electrochemical_polishing

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Mathematics>Deformed Mesh>Deformed Geometry (dg).

3 Click Add.

4 In the Select Physics tree, select AC/DC>Electric Currents (ec).

5 Click Add.

6 Click Study.

7 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Time 

Dependent.

8 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Description

K 1e-11[m^3/(A*s)] Coefficient of proportionality
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G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 2.8.

4 In the Height text field, type 0.4.

5 Locate the Position section. In the x text field, type -1.4.

Circle 1 (c1)
1 Right-click Rectangle 1 (r1) and choose Build Selected.

2 On the Geometry toolbar, click Primitives and choose Circle.

3 In the Settings window for Circle, locate the Size and Shape section.

4 In the Radius text field, type 0.3.

5 Locate the Position section. In the y text field, type 0.6.

Difference 1 (dif1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Difference.

2 Select the object r1 only to add it to the Objects to add list.

3 In the Settings window for Difference, locate the Difference section.

4 Find the Objects to subtract subsection. Select the Active toggle button.

5 Select the object c1 only.

6 Right-click Difference 1 (dif1) and choose Build Selected.
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7 Click the Zoom Extents button on the Graphics toolbar.

The model geometry is now complete.

Before turning to the Deformed Geometry interface settings, define variables for the local 
displacement components.

D E F I N I T I O N S

Variables 1
1 On the Home toolbar, click Variables and choose Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

Here, Xg and Yg are geometry-frame coordinates corresponding to x and y.

D E F O R M E D  G E O M E T R Y  ( D G )

Free Deformation 1
1 On the Physics toolbar, click Domains and choose Free Deformation.

2 Select Domain 1 only.

Name Expression Unit Description

dx x-Xg m x-displacement

dy y-Yg m y-displacement
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Prescribed Mesh Velocity 1
1 On the Physics toolbar, click Boundaries and choose Prescribed Mesh Velocity.

2 Select Boundaries 1 and 5 only.

3 In the Settings window for Prescribed Mesh Velocity, locate the Prescribed Mesh Velocity 
section.

4 Clear the Prescribed y velocity check box.

Prescribed Normal Mesh Velocity 1
1 On the Physics toolbar, click Boundaries and choose Prescribed Normal Mesh Velocity.

2 Select Boundaries 3, 4, 6, and 7 only.

3 In the Settings window for Prescribed Normal Mesh Velocity, locate the Normal Mesh 

Velocity section.

4 In the vn text field, type -K*(-ec.nJ).

E L E C T R I C  C U R R E N T S  ( E C )

1 In the Model Builder window, under Component 1 (comp1) click Electric Currents (ec).

2 In the Settings window for Electric Currents, click to expand the Equation section.

3 From the Equation form list, choose Stationary.

With this setting you specify that the current distribution can be regarded as stationary 
on the time scale determined by the depletion rate.

Current Conservation 1
1 In the Model Builder window, expand the Electric Currents (ec) node, then click Current 

Conservation 1.

2 In the Settings window for Current Conservation, locate the Conduction Current section.

3 From the σ list, choose User defined. In the associated text field, type 10.

4 In the Model Builder window, click Electric Currents (ec).

Electric Potential 1
1 On the Physics toolbar, click Boundaries and choose Electric Potential.

2 Select Boundaries 3, 4, 6, and 7 only.

3 In the Settings window for Electric Potential, locate the Electric Potential section.

4 In the V0 text field, type 30.

Ground 1
1 On the Physics toolbar, click Boundaries and choose Ground.

2 Select Boundary 2 only.
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Electric Insulation 1
For the left and right boundaries, the default boundary condition is a good approximation 
if you want to simulate that the electrodes are extended indefinitely in both directions.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Finer.

4 Click Build All.

5 Click the Zoom Extents button on the Graphics toolbar.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,10).

4 On the Home toolbar, click Compute.
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R E S U L T S

Electric Potential (ec)
1 Click the Zoom Extents button on the Graphics toolbar.

The default plot shows the potential field at the end of the simulation interval; compare 
with Figure 2.

Next, plot the current distribution.

2D Plot Group 2
On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

Surface 1
1 In the Model Builder window, right-click 2D Plot Group 2 and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Electric Currents>

Currents and charge>ec.normJ - Current density norm.

3 On the 2D Plot Group 2 toolbar, click Plot.

4 Click the Zoom Extents button on the Graphics toolbar.

The maximum current density appears to be of the order of 106 A/m2.
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To see the magnitude of the depletion in the y-direction more easily, plot the y-component 
of the mesh displacement.

2D Plot Group 3
On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

Surface 1
1 In the Model Builder window, right-click 2D Plot Group 3 and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Definitions>

Variables>dy - y-displacement.

3 On the 2D Plot Group 3 toolbar, click Plot.

4 Click the Zoom In button on the Graphics toolbar.

The maximum value for the y-displacement is approximately 0.1 mm, which agrees with 
the value calculated in Equation 2.
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Introduction

This example shows a 2D steady-state thermal analysis including convection to a 
prescribed external (ambient) temperature. The example is taken from a NAFEMS 
benchmark collection (see Ref. 1).

Model Definition

This example considers 0.6 m-by-1.0 m domain. For the boundary conditions:

• The left boundary is insulated.

• The lower boundary is kept at 100 °C.

• The upper and right boundaries are convecting to 0 °C with a heat transfer coefficient 
of 750 W/(m2·°C).

In the domain use the following material property:

• The thermal conductivity is 52 W/(m·°C).
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Results

The plot in Figure 1 shows the temperature field in the modeling domain.

Figure 1: Temperature distribution resulting from convection to a prescribed external 
temperature.

The benchmark result for the target location (x = 0.6 m and y = 0.2 m) is a temperature 
of 18.25 °C. The COMSOL Multiphysics model, using a mapped mesh with 9 × 15 
quadratic elements, gives a temperature of 18.265 °C.

Reference

1. A.D. Cameron, J.A. Casey, and G.B. Simpson, NAFEMS Benchmark Tests for Thermal 
Analysis (Summary), NAFEMS, Glasgow, 1986.

Application Library path: COMSOL_Multiphysics/Heat_Transfer/
heat_convection_2d
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.6.

4 Click Build All Objects.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 2 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type 100[degC].

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 3 and 4 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type 750.
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6 In the Text text field, type 0[degC].

Solid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Solid 1.

2 In the Settings window for Solid, locate the Heat Conduction, Solid section.

3 From the k list, choose User defined. In the associated text field, type 52.

No other material properties enter into the domain equations for this stationary model.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Mapped.

Mapped 1
1 In the Settings window for Mapped, click Build All.

S T U D Y  1

On the Home toolbar, click Compute.
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R E S U L T S

Temperature (ht)
1 Click the Zoom Extents button on the Graphics toolbar.

The first default plot group shows the temperature field; compare with Figure 1.

Data Sets
The benchmark value for the temperature at x = 0.6 m and y = 0.2 m is 18.25 °C. To 
compare this value with that from the simulation, evaluate the temperature in this position.

Cut Point 2D 1
1 On the Results toolbar, click Cut Point 2D.

2 In the Settings window for Cut Point 2D, locate the Point Data section.

3 In the x text field, type 0.6.

4 In the y text field, type 0.2.

Point Evaluation 1
1 On the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Data set list, choose Cut Point 2D 1.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

TA B L E

1 Go to the Table window.

The result should be close to 18.265 °C.

Expression Unit Description

T degC Temperature
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Introduction

This example shows a 1D steady-state thermal analysis including radiation to a prescribed 
ambient temperature. The example is taken from a NAFEMS benchmark collection (Ref. 
1).

Model Definition

This 1D model has a domain of length 0.1 m. The left end is kept at 1000 K, and at the 
right end there is radiation to 300 K. The model uses the following material properties:

• For the radiation, the emissivity, ε, is 0.98.

• The thermal conductivity is 55.563 W/(m·K).

Results

The following plot shows the temperature as a function of position:

Figure 1: Temperature as a function of position.
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The benchmark result for the right end is a temperature of 927.0 K. The COMSOL 
Multiphysics model, using a default mesh with 15 elements, gives a temperature at the end 
as 926.97 K, which is the exact benchmark value to four significant digits.

Reference

1. A.D. Cameron, J.A. Casey, and G.B. Simpson, NAFEMS Benchmark Tests for Thermal 
Analysis (Summary), NAFEMS, Glasgow, 1986.

Application Library path: COMSOL_Multiphysics/Heat_Transfer/
heat_radiation_1d

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 1D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

Interval 1 (i1)
1 On the Geometry toolbar, click Interval.

2 In the Settings window for Interval, locate the Interval section.

3 In the Right endpoint text field, type 0.1.

4 Click Build All Objects.
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H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 1 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type 1000.

Diffuse Surface 1
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 Select Boundary 2 only.

3 In the Settings window for Diffuse Surface, locate the Surface Emissivity section.

4 From the ε list, choose User defined. In the associated text field, type 0.98.

5 Locate the Ambient section. In the Tamb text field, type 300.

Solid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Solid 1.

2 In the Settings window for Solid, locate the Heat Conduction, Solid section.

3 From the k list, choose User defined. In the associated text field, type 55.563.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, type 1000 in the T text field.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Derived Values
The benchmark value for the temperature at the right end is 927.0 K. To compare the 
value from the simulation, evaluate the temperature in that position.
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Point Evaluation 1
1 On the Results toolbar, click Point Evaluation.

2 Select Boundary 2 only.

3 In the Settings window for Point Evaluation, click Evaluate.
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Introduction

This example shows an axisymmetric transient thermal analysis with a step change to 
1000 °C at time 0. The example is taken from a NAFEMS benchmark collection (Ref. 1).

Model Definition

This example considers the 0.3 m-by-0.4 m domain. For the boundary conditions, assume 
the following:

• The left boundary is the symmetry axis.

• The other boundaries have a temperature of 1000 °C. The entire domain is at 0 °C at 
the start, which represents a step change in temperature at the boundaries.

In the domain use the following material properties:

• The density, ρ, is 7850 kg/m3

• The heat capacity is 460 J/(kg·°C)

• The thermal conductivity is 52 W/(m·°C)
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Results

The following revolved surface plot shows the temperature distribution inside the cylinder 
after 190 seconds:

Figure 1: Temperature distribution after 190 seconds.

The benchmark result for the target location (r = 0.1 m and z = 0.3 m) is a temperature of 
186.5 °C. The COMSOL Multiphysics model, using a default mesh with about 720 
elements, gives a temperature of roughly 186.4 °C.

Reference

1. A.D. Cameron, J.A. Casey, and G.B. Simpson, NAFEMS Benchmark Tests for Thermal 
Analysis (Summary), NAFEMS, Glasgow, 1986.

Application Library path: COMSOL_Multiphysics/Heat_Transfer/
heat_transient_axi
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

G E O M E T R Y  1

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.3.

4 In the Height text field, type 0.4.

5 Click Build All Objects.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 In the Settings window for Temperature, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

4 Locate the Temperature section. In the T0 text field, type 1000[degC].

Solid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Solid 1.

2 In the Settings window for Solid, locate the Heat Conduction, Solid section.

3 From the k list, choose User defined. In the associated text field, type 52.
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4 Locate the Thermodynamics, Solid section. From the Cp list, choose User defined. In the 
associated text field, type 460.

5 From the ρ list, choose User defined. In the associated text field, type 7850.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, type 0[degC] in the T text field.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, click Build All.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,10,190).

4 On the Home toolbar, click Compute.

R E S U L T S

Temperature, 3D (ht)
To get the plot shown in Figure 1, just change the unit as follows:

Surface
1 In the Model Builder window, expand the Temperature, 3D (ht) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

4 On the Temperature, 3D (ht) toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.
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Isothermal Contours (ht)
The second default plot group visualizes the temperature field using a contour plot.

Data Sets
The benchmark value for the temperature at r = 0.1 m and z = 0.3 m is 186.5 °C. To 
compare the value from the simulation, evaluate the temperature in that position.

Cut Point 2D 1
1 On the Results toolbar, click Cut Point 2D.

2 In the Settings window for Cut Point 2D, locate the Point Data section.

3 In the r text field, type 0.1.

4 In the z text field, type 0.3.

Point Evaluation 1
1 On the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Data set list, choose Cut Point 2D 1.

4 From the Time selection list, choose Last.
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5 Locate the Expressions section. In the table, enter the following settings:

6 Click Evaluate.

Expression Unit Description

T degC Temperature
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Introduction

The Korteweg-de Vries (KdV) equation, formulated in 1895 by Korteweg and de Vries, 
models water waves. It contrasts sharply to the Burgers equation because it introduces no 
dissipation and the waves travel seemingly forever. In 1965, Zabusky and Kruskal named 
such waves solitons.

The KdV equation with boundary conditions and initial value is formulated as

The equation models the steepening and dispersion of wavefronts but does not support a 
train of simple harmonic waves. Such trains comprise the wave crests normally associated 
with the ocean: simply a momentary constructive interference of contributing waves 
moving at different speeds. However, the equation does support solitons, single “humps” 
that travel without changing shape or speed for unexpectedly long distances.

Indeed, Perry and Schimke (Ref. 2) concluded from shipboard oceanographic 
measurements that bands of choppy water in the Andaman Sea, which lies east of the Bay 
of Bengal and west of Burma (Union of Myanmar) and Thailand, are associated with 
large-amplitude oceanic internal waves. Satellite images have since clarified that these 
waves originate on shallow banks on a layer between warm and cool water. Further, 
Osborne and Burch (Ref. 1) analyzed oceanographic data in an effort to assess the forces 
of underwater current fluctuations associated with such waves on offshore drilling rigs. 
They concluded that the visually observed roughness bands are caused by internal solitons 
that follow the KdV equation (Ref. 3). 

A more recent development is the application of the KdV equation to another type of 
waves—light waves. Today solitons have their primary practical application in optical 
fibers. Specifically, a fiber’s linear dispersion properties level out a wave while the nonlinear 
properties give a focusing effect. The result is a very stable, long-lived pulse (Ref. 3). It is 
amazing that researchers have discovered a formula for such waves:

This equation says that the pulse speed is what determines the pulse amplitude and the 
pulse width. The following simulation illustrates this effect. An initial pulse, which does 
not conform to the formula, immediately breaks down into two pulses of different 

ut uxxx+ 6uux       in Ω 8– 8,[ ]
u 8– t,( ) u 8 t,( ),      periodic
u x 0,( ) 6 x( )sech2–

= =

=

=

u v

2cosh2 1
2
--- v 
  x vt– f–( )

--------------------------------------------------------------------=
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amplitudes and speeds. The two new pulses follow the formula and thus can travel forever. 
While the formula does not reveal how solitons interact, the simulation shows that they 
can collide and reappear, seemingly unchanged, just as linear waves do, another 
counterintuitive observation that is difficult to observe without predictions by computing.

Model Definition

In the model, the term uux describes the focusing of a wave and uxxx refers to its 
dispersion. The balancing of these two terms permits waves to travel with their shape 
unchanged.

Because COMSOL Multiphysics does not evaluate third derivatives directly, you rewrite 
the original equation above as a system of two variables to solve it:

Using the General Form PDE interface, you need to define two dependent variables, u1 
and u2, and identify the da, Γ, and F coefficients in the following equation:

• Only the first equation has a time derivative, and it is with respect to u1, so only da(1,
1) is 1; the other three components are zero.

• The divergence is a space derivative with respect to x. This means that the Γ component 
from the first equation is u2, which you type as u2. The Γ component from the second 
equation is u1x, which you express using COMSOL Multiphysics syntax as u1x.

• The F term components are the right-hand side of the equations: F1 is 6u1u1x (type 6*
u1*u1x), and F2 is u2 (type u2).

The initial condition for u1 uses a hyperbolic cosine function to provide an interesting 
wave form to start with. For u2, you must provide the second space derivative of this 
function to provide consistent initial conditions.

The boundary conditions are periodic boundary conditions: the solution at one end is 
always identical to the one at the other end of the domain.

u1t u2x+ 6u1u1x=

u1xx u2=

da t∂
∂u ∇+ Γ⋅ F=
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Results

The following plot shows how solitons collide and reappear with their shape intact.

Figure 1: Solution visualizing a soliton collision.

References

1. A.R. Osborne and T.L. Burch, “Internal Solitons in the Andaman Sea,” Science, 
vol. 208, no. 4443, pp. 451–460, 1980.

2. R.B. Perry and G.R. Schimke, “Large-Amplitude Internal Waves Observed Off the 
Northwest Coast of Sumatra,” J. Geophys. Res., vol. 70, no. 10, pp. 2319–2324, 1965.

3. G. Strang, Applied Mathematics, Wellesley-Cambridge, 1986.

Application Library path: COMSOL_Multiphysics/Equation_Based/kdv_equation

Modeling Instructions

From the File menu, choose New.
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N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 1D.

2 In the Select Physics tree, select Mathematics>PDE Interfaces>General Form PDE (g).

3 Click Add.

4 In the Number of dependent variables text field, type 2.

5 Click Study.

6 In the Select Study tree, select Preset Studies>Time Dependent.

7 Click Done.

R O O T

1 In the Model Builder window, click the root node.

2 In the root nodes'Settings window, locate the Unit System section.

3 From the Unit system list, choose None.

Keeping track of units is not important in this model; by turning off unit support, you 
avoid the need to specify dimensions for equation coefficients and coordinates to get rid 
of unit warnings.

G E O M E T R Y  1

Interval 1 (i1)
1 On the Geometry toolbar, click Interval.

2 In the Settings window for Interval, locate the Interval section.

3 In the Left endpoint text field, type -8.

4 In the Right endpoint text field, type 8.

G E N E R A L  F O R M  P D E  ( G )

Periodic Condition 1
1 On the Physics toolbar, click Boundaries and choose Periodic Condition.

2 In the Settings window for Periodic Condition, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.
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General Form PDE 1
1 In the Model Builder window, under Component 1 (comp1)>General Form PDE (g) click 

General Form PDE 1.

2 In the Settings window for General Form PDE, locate the Conservative Flux section.

3 In the Γ text-field array, type u2 on the first row.

4 In the Γ text-field array, type u1x on the 2nd row.

5 Locate the Source Term section. In the f text-field array, type 6*u1*u1x on the first row.

6 In the f text-field array, type u2 on the 2nd row.

7 Locate the Damping or Mass Coefficient section. In the da text-field array, type 0 in the 
2nd column of the 2nd row.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>General Form PDE (g) click 

Initial Values 1.

2 In the Settings window for Initial Values, locate the Initial Values section.

3 In the u1 text field, type -6*sech(x)^2.

4 In the u2 text field, type -24*sech(x)^2*tanh(x)^2+12*sech(x)^2*
(1-tanh(x)^2).

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Edge.

Size
1 In the Settings window for Size, locate the Element Size section.

2 Click the Custom button.

3 Locate the Element Size Parameters section. In the Maximum element size text field, type 
0.1.

4 Click Build All.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,0.025,2).
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4 Select the Relative tolerance check box.

5 In the associated text field, type 3e-6.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Study 1>Solver Configurations node.

3 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Time-Dependent Solver 1.

4 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

5 Locate the Time Stepping section. From the Method list, choose Generalized alpha.

The Generalized-alpha time stepper is well suited for wave problems. For an accurate 
solution, use tighter tolerance settings.

6 Click to expand the Absolute tolerance section. Locate the Absolute Tolerance section. In 
the Tolerance text field, type 3e-7.

7 Click to expand the Time stepping section. Locate the Time Stepping section. In the 
Amplification for high frequency text field, type 0.98.

8 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Time-Dependent Solver 1 node, then click Fully Coupled 1.

9 In the Settings window for Fully Coupled, click to expand the Method and termination 
section.

10 Locate the Method and Termination section. In the Tolerance factor text field, type 0.1.

11 On the Study toolbar, click Compute.

R E S U L T S

1D Plot Group 1
1 In the Model Builder window, click 1D Plot Group 1.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Time selection list, choose From list.

4 In the Times (s) list, select 0.25.

5 In the Times (s) list, select 0.25.

6 In the Model Builder window, expand the 1D Plot Group 1 node, then click Line Graph 1.

7 In the Settings window for Line Graph, locate the y-Axis Data section.

8 In the Expression text field, type -u1.
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9 On the 1D Plot Group 1 toolbar, click Plot.

The solution to the KdV equation at 0.25 s.

Data Sets
To visualize the solution, extrude results along the time.

Parametric Extrusion 1D 1
On the Results toolbar, click More Data Sets and choose Parametric Extrusion 1D.

2D Plot Group 2
1 On the Results toolbar, click 2D Plot Group.

2 In the Model Builder window, right-click 2D Plot Group 2 and choose Surface.

3 In the Settings window for Surface, locate the Expression section.

4 In the Expression text field, type -u1.

5 Right-click Results>2D Plot Group 2>Surface 1 and choose Height Expression.

6 Click the Zoom Extents button on the Graphics toolbar.

Compare with the plot shown in Figure 1.
8 |  T H E  K D V  E Q U A T I O N  A N D  S O L I T O N S



Created in COMSOL Multiphysics 5.2a
L a s e r  Hea t i n g  o f  a  S i l i c o n  Wa f e r
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


Introduction

A silicon wafer is heated up by a laser that moves radially in and out over time while the 
wafer itself rotates on its stage. Modeling the incident heat flux from the laser as a spatially 
distributed heat source on the surface, the transient thermal response of the wafer is 
obtained. The peak, average, and minimum temperatures during the heating process are 
computed, as well as the temperature variations across the wafer.

Figure 1: A silicon wafer is heated with a laser that moves back and forth. The wafer is also 
being rotated about its axis.

Model Definition

A 2-inch silicon wafer, as shown in Figure 1, is heated for one minute by a 10 W laser that 
moves radially inwards and outwards, while the wafer rotates on its stage. Assuming good 
thermal isolation from the environment, the only source of heat loss is from the top surface 
via radiation to the processing chamber walls, which are assumed to be at a fixed 
temperature of 20 °C.

The laser beam is modeled as a heat source in the plane with Gaussian profile. To set up 
the heating profile the model uses the built-in Gaussian Pulse functions, which enforce 
that the integral under the curve equals unity. The focal point is moved by using a 

10 W laser

60 RPM
2 |  L A S E R  H E A T I N G  O F  A  S I L I C O N  W A F E R



triangular waveform to define its position along the x-axis over time. The wafer is assigned 
a bulk rotational velocity in the governing heat transfer equation.

The emissivity of the surface of the wafer is approximately 0.8. At the operating 
wavelength of the laser, it is assumed that absorptivity equals emissivity. The heat load due 
to the laser is thus multiplied by the emissivity. Assuming also that the laser is operating at 
a wavelength at which the wafer is opaque, no light is passing through the wafer. 
Therefore, all of the laser heat is deposited at the surface.

The wafer is meshed using a triangular swept mesh. Swept meshing allows for only a single 
thin element through the thickness, and still maintains reasonable element size in the 
plane. A finer mesh would give slightly more accurate predictions of the peak temperature, 
but predictions of average and minimum temperature would not be greatly affected.

Results and Discussion

Figure 2 plots the maximum, minimum, and average temperatures of the wafer, while 
Figure 3 shows the difference between the maximum and minimum temperature. The 
temperature distribution across the wafer is plotted in Figure 4.

The heating profile does introduce some significant temperature variations, because the 
laser deposits the same amount of heat over a larger total swept area when it is focused at 
the outside of the wafer. An interesting modification to this example would be to 
investigate alternative heating profiles for smoother heating.
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Figure 2: Maximum, minimum, and average temperatures of the wafer as functions of time.

Figure 3: Difference between maximum and minimum temperatures on the wafer. 
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Figure 4: Temperature variation across the wafer. The arrow plot describes the velocity of the 
wafer.

Application Library path: COMSOL_Multiphysics/Heat_Transfer/
laser_heating_wafer

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.
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4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Start by defining parameters for use in the geometry, functions, and physics settings.

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Here, the unit ’rpm’ is revolution per minute.

G E O M E T R Y  1

Create a cylinder for the silicon wafer.

Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type r_wafer.

4 In the Height text field, type thickness.

Name Expression Value Description

r_wafer 1[in] 0.0254 m Wafer radius 

thickness 275[um] 2.75E-4 m Wafer thickness 

v_rotation 60[rpm] 1 Hz Rotational speed

angular_v 2*pi*v_rotation 6.2832 Hz Angular velocity

period 10[s] 10 s Time for laser to 
move back and forth 

r_spot 2.5[mm] 0.0025 m Radius of laser spot 
size 

emissivity 0.8 0.8 Surface emissivity 
of wafer

p_laser 10[W] 10 W Laser power
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5 Click Build All Objects.

D E F I N I T I O N S

Define functions for use before setting up the physics.

Gaussian Pulse 1 (gp1)
1 On the Home toolbar, click Functions and choose Local>Gaussian Pulse.

2 In the Settings window for Gaussian Pulse, locate the Parameters section.

3 In the Standard deviation text field, type r_spot/3.

The laser beam radius is equal to three standard deviations of the Gaussian pulse. These 
three standard deviations account for 99.7% of the total laser energy.
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4 Click Plot.

Waveform 1 (wv1)
1 On the Home toolbar, click Functions and choose Local>Waveform.

2 In the Settings window for Waveform, locate the Parameters section.

3 From the Type list, choose Triangle.

4 Clear the Smoothing check box.

5 In the Angular frequency text field, type 2*pi/period.

6 In the Phase text field, type pi/2.

7 In the Amplitude text field, type r_wafer.
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8 Click Plot.

Analytic 1 (an1)
1 On the Home toolbar, click Functions and choose Local>Analytic.

2 In the Settings window for Analytic, type hf in the Function name text field.

3 Locate the Definition section. In the Expression text field, type p_laser[1/W]*
gp1(x-wv1(t))*gp1(y).

4 In the Arguments text field, type x, y, t.

5 Locate the Units section. In the Arguments text field, type m, m, s.

6 In the Function text field, type W/m^2.

7 Locate the Plot Parameters section. In the table, enter the following settings:

Argument Lower limit Upper limit

x -r_spot r_spot

y -r_spot r_spot

t period/4 period/4
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8 Click Plot.

Next, add coupling operators for the result analysis.

Average 1 (aveop1)
1 On the Definitions toolbar, click Component Couplings and choose Average.

2 Select Domain 1 only.

Maximum 1 (maxop1)
1 On the Definitions toolbar, click Component Couplings and choose Maximum.

2 Select Domain 1 only.

Minimum 1 (minop1)
1 On the Definitions toolbar, click Component Couplings and choose Minimum.

2 Select Domain 1 only.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Set up the physics. First, include the wafer’s rotational velocity in the governing heat 
transfer equation.

Solid 1
In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) click 
Solid 1.
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Translational Motion 1
1 On the Physics toolbar, click Attributes and choose Translational Motion.

2 In the Settings window for Translational Motion, locate the Translational Motion section.

3 Specify the utrans vector as

Next, add heat flux and surface-to-ambient radiation on the wafer’s top surface.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundary 4 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 In the q0 text field, type emissivity*hf(x,y,t).

Diffuse Surface 1
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 Select Boundary 4 only.

3 In the Settings window for Diffuse Surface, locate the Surface Emissivity section.

4 From the ε list, choose User defined. In the associated text field, type emissivity.

-y*angular_v x

x*angular_v y

0 z
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A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Silicon.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

M E S H  1

Use a fine triangular swept mesh.

Swept 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

Swept.

2 In the Settings window for Swept, click to expand the Sweep method section.

3 Locate the Sweep Method section. From the Face meshing method list, choose Triangular 

(generate prisms).

Distribution 1
1 Right-click Component 1 (comp1)>Mesh 1>Swept 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 1.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Fine.
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4 Click Build All.

S T U D Y  1

Step 1: Time Dependent
1 In the Settings window for Time Dependent, locate the Study Settings section.

2 In the Times text field, type range(0,0.1,60).

3 On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
The first default plot shows the temperature on the wafer surface. Add an arrow plot for 
the velocity field describing the wafer rotation.

Arrow Surface 1
1 In the Model Builder window, under Results right-click Temperature (ht) and choose 

Arrow Surface.

2 In the Settings window for Arrow Surface, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Model>Component 1>Heat 

Transfer in Solids>ht.ux,ht.uy,ht.uz - Velocity field.
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3 Locate the Coloring and Style section. Select the Scale factor check box.

4 In the associated text field, type 0.036.

5 From the Color list, choose Green.

6 On the Temperature (ht) toolbar, click Plot.

7 Click the Zoom Extents button on the Graphics toolbar.

Compare the temperature variation with that shown in Figure 4.

Isothermal Contours (ht)
The second default plot shows the isosurface temperature.

1D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, click to expand the Legend section.

3 From the Position list, choose Lower right.

Global 1
1 On the 1D Plot Group 3 toolbar, click Global.

2 In the Settings window for Global, locate the y-Axis Data section.
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3 In the table, enter the following settings:

4 On the 1D Plot Group 3 toolbar, click Plot.

Compare the plot showing the maximum, minimum and average temperature with 
Figure 2.

1D Plot Group 4
On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

Global 1
1 On the 1D Plot Group 4 toolbar, click Global.

2 In the Settings window for Global, locate the y-Axis Data section.

3 In the table, enter the following settings:

4 On the 1D Plot Group 4 toolbar, click Plot.

Finish the result analysis by comparing the generated plot with Figure 3.

Expression Unit Description

maxop1(T) degC Maximum temperature

minop1(T) degC Minimum temperature

aveop1(T) degC Average temperature

Expression Unit Description

maxop1(T)-minop1(T) K Temperature difference
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Introduction

In this tutorial example, which demonstrates a more generally applicable method, a 
structural mechanics model of a spring is augmented by a global equation that solves for 
the load required to achieve a desired total extension of the spring.

Figure 1: A three-turn steel spring is fixed at one end, and has a load applied at the other. The 
load is a variable which is solved for to achieve a total displacement.

Model Definition

Figure 1 shows the modeled three-turn steel spring. One end of the spring is fixed rigidly, 
and the other end has a distributed load applied to it, acting in the axial direction of the 
spring. Rather than an input to the model, this load is a variable being solved for; it is 
implicitly specified via a global equation in such a way as to give a total spring extension of 
2 cm. The extension of the spring is computed by using an average operator on the moving 
end of the spring. The average operator evaluates the average z-displacement over the 
boundary at which the load is applied.

The global equation adds one additional degree of freedom to the model, the unknown 
load. Not all available equations solvers are suited for such problems, but the direct solver 
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used as default for structural mechanics can handle it. Because the structure has a uniform 
cross section, use a swept mesh.

Results and Discussion

Figure 2 shows the deformed shape of the spring. The average displacement of the end of 
the spring is 2 cm, as specified by the global equation. The force required to get this 
displacement is 705 N. Although this problem uses a linear elastic material model, this 
approach would work equally well if the material model was nonlinear or if geometric 
nonlinearity was taken into account.

Global equations do have certain restrictions upon their usage. The global equation must 
be continuous and differentiable with respect to all of the unknowns, and it must not 
over-constrain, nor under-constrain, the problem. Each global equation should add one 
constraint and one degree of freedom to the model. Under these conditions, the global 
equations can be used in a variety of ways beyond what is shown here.

Figure 2: The deformed shape of the spring.
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Application Library path: COMSOL_Multiphysics/Structural_Mechanics/
loaded_spring

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose dm.

Create a helix for the spring (Figure 1).

Name Expression Value Description

dh 2[cm] 0.02 m Prescribed extension
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Helix 1 (hel1)
1 On the Geometry toolbar, click Helix.

2 In the Settings window for Helix, locate the Rotation Angle section.

3 In the Rotation text field, type 180.

4 Click Build All Objects.

D E F I N I T I O N S

Next, add an Average operator that you will later use to average the z-directional 
displacement field on the end of the spring.

Average 1 (aveop1)
1 On the Definitions toolbar, click Component Couplings and choose Average.

Choose wireframe rendering to get a better view on some boundaries where you will 
assign boundary conditions.

2 Click the Wireframe Rendering button on the Graphics toolbar.

3 In the Settings window for Average, locate the Source Selection section.

4 From the Geometric entity level list, choose Boundary.

5 Select Boundary 4 only.
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S O L I D  M E C H A N I C S  ( S O L I D )

Next, set up the physics. Add a global equation to compute the appropriate load for the 
prescribed extension. As an advanced feature, the Global Equations entry is not available by 
default in the context menu.

1 In the Model Builder window’s toolbar, click the Show button and select Advanced Physics 

Options in the menu.

Global Equations 1
1 On the Physics toolbar, click Global and choose Global Equations.

2 In the Settings window for Global Equations, locate the Global Equations section.

3 In the table, enter the following settings:

4 Locate the Units section. Find the Dependent variable quantity subsection. From the list, 
choose Force load (N).

5 Find the Source term quantity subsection. From the list, choose Displacement field (m).

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundary 4 only.

Name f(u,ut,utt,t) (1) Initial value (u_0) (1) Initial value (u_t0) (1/s)

Force aveop1(w)-dh 0 0
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3 In the Settings window for Boundary Load, locate the Force section.

4 From the Load type list, choose Total force.

5 Specify the Ftot vector as

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundary 3 only.

M A T E R I A L S

Assign material properties. Use Steel AISI 4340 for all domains.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Steel AISI 4340.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

0 x

0 y

Force z
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M E S H  1

Use swept mesh to generate a uniform mesh over the spring domain. Start by specifying 
the mesh on one end face of the spring.

Free Triangular 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Free Triangular.

2 Select Boundary 4 only.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Coarser.

4 In the Model Builder window, right-click Mesh 1 and choose Swept.

Swept 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Swept 1 and 
choose Distribution.

Distribution 1
1 In the Settings window for Distribution, locate the Distribution section.

2 In the Number of elements text field, type 200.
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3 Click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Stress (solid)
The default plot shows the von Mises stress on the surface of the spring. Compare the plot 
with Figure 2.

Derived Values
Evaluate the force required to get the displacement specified in the global equations.

Global Evaluation 1
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Expressions section.

3 In the table, enter the following settings:

Expression Unit Description

Force N State variable Force
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4 Click Evaluate.

Derived Values
Finish the result analysis by evaluating the average displacement of the end of the spring.

Global Evaluation 2
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Expressions section.

3 In the table, enter the following settings:

4 Click Evaluate.

Expression Unit Description

aveop1(w) dm
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Introduction

Communication masts usually have a framework with a bolted triangular lattice design as 
illustrated in Figure 1. The diagonals of the framework are assembled from several parts 
and welded together.

When operating under a given wind load at a specific location, the antenna’s total rotation 
angle should stay below a certain limit to ensure uninterrupted communications. For the 
type of mast used in this example, the engineers have determined that its torsional stiffness 
is too low, and this effect is due to the geometry of the diagonal mountings. The goal is 
to increase the stiffness of such a diagonal mounting by first analyzing a parameterized 
geometry followed by an update of the geometry and a new analysis.

Figure 1: Mounting detail of a mast diagonal.

Model Definition

The model geometry includes only a short section of the diagonal tubing together with 
the other parts of the mounting as illustrated in Figure 1. Although a symmetry exists in 
both the geometry and load for this problem, this example models the entire assembly for 
illustrative purposes.

After obtaining the stiffness of the diagonal mounting, assume that the geometry has been 
updated to improve the stiffness. Originally 10 mm, the plate thickness and mount 
thickness (see Figure 1) have been changed to 12 mm and 15 mm, respectively.
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M A T E R I A L  P R O P E R T I E S

Assume that the material is a structural steel. This is the default material with a Young’s 
modulus of 2.0·1011 N/m2 and a Poisson’s ratio of 0.33.

B O U N D A R Y  C O N D I T I O N S

Figure 2 shows the boundaries with an applied load and constrained displacements. 
Assume that the diagonal is loaded in tension by a force, F = 30 kN, which is transferred 
through the bolt to the mounting.

Figure 2: Boundaries with constrained displacements and applied loads.

Neglect contact conditions between the bolt and the mounting hole, and also neglect the 
constraint imposed on the mount by the bolt. Assume that the bolt fills out the entire hole 
volume. The load is distributed on the appropriate halves of the hole surfaces by allying a 
pressure, p, according to

Applied load

Fixed displacement

p F

2 A⋅ mh
xy

------------------ 3
2
--- 1 y

rmh
---------- 
  2

– 
 ⋅=

Amh
xy 2 rmhtm⋅=
3 |  S T I F F N E S S  A N A L Y S I S  O F  A  C O M M U N I C A T I O N  M A S T ’ S  D I A G O N A L  M O U N T I N G



where rmh is the mount hole radius, tm is the thickness of the mount, y is the y-coordinate 
and  is the mount hole cross section area projected on the xy-plane.

In current analysis design engineers want to increase the stiffness of the assembly. Since the 
load is transferred through the mount holes it is crucial to compute the displacement of 
the mount holes once the external load is applied. By denoting the average z-displacement 
of the middle plane of the mount holes by δmh, the real stiffness of the assembly is given by 

In an assembly with a constant cross section the relation between the applied force and 
resulting displacement is given by 

where δ is the displacement, A is the cross section area and L is the total length. This 
relation can be rearrange to 

Since the stiffness is defined as applied force divided by resulting displacement, which is 
the left hand side in the above expression, the right hand side can be seen as an ideal 
stiffness, SI, of a body with a constant cross section. In current example that would be a 
tube stretching as far as the mounting hole, to be welded together with the rest of the 
mast. The ideal stiffness can thus be expressed with 

where Lt is the equivalent tube length if the entire assembly was made of a tube only, ht is 
the tube height in the assembly with a mount, tp is the plate thickness and omh is the 
mount hole center offset, measured from the plate surface. Observe that the tube height 
and the equivalent tube length are both measured along the same dimension of the tube. 
The difference is the fact that tube height is used to relate the tube used in the mount 
assembly and tube length is used to define the tube in an assembly consisting of a tube 
only. 

Amh
xy

S F
δmh
---------=

F
A
---- E δ

L
----=

F
δ
---- EA

L
----=

SI E
At
Lt
------=

Lt ht tp omh+ +=
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The variable used as the evaluation parameter is the stiffness ratio between the real stiffness 
of the assembly with a mount and the ideal stiffness. 

If this value equals one, then the stiffens of the assembly with a mount is exactly the same 
as the stiffens of a single tube. 

Results and Discussion

In the original geometry where both the plate thickness and the mount thickness are 
10 mm, the stiffness ratio is 0.38. Then the plate thickness is increased to 12 mm and the 
mount thickness to 15 mm, the stiffness ratio increases to 0.53. Figure 3 shows the 
z-component of the displacement when loading the stiffer geometry.

Figure 3: Deformed shape and boundary plot of the axial displacement for the mounting 
assembly with an end-plate thickness of 12 mm and mount thickness of 15 mm.

SR
S
SI
------=
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Application Library path: COMSOL_Multiphysics/Structural_Mechanics/
mast_diagonal_mounting

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

The model geometry is available as a parameterized geometry sequence in a separate 
MPH-file.

1 On the Geometry toolbar, click Insert Sequence.

2 Browse to the application’s Application Libraries folder and double-click the file 
mast_diagonal_mounting_geom_sequence.mph.

3 Click the Zoom Extents button on the Graphics toolbar.
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4 On the Geometry toolbar, click Build All.

G L O B A L  D E F I N I T I O N S

Parameters
1 In the Model Builder window, under Global Definitions click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

D E F I N I T I O N S

Create an average operator for evaluation of variables across the mid plane of both mount 
holes.

Average 1 (aveop1)
1 On the Definitions toolbar, click Component Couplings and choose Average.

2 In the Settings window for Average, type Mount, mid level in the Label text field.

3 Locate the Source Selection section. From the Geometric entity level list, choose Point.

Name Expression Value Description

F 30[kN] 30000 N Applied force
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4 Select Points 9, 13, 18, 22, 55, 59, 64, and 68 only.

The points along the mid plane are shown in figure below.

5 Click Create Selection.

6 In the Create Selection dialog box, type Mount, mid level in the Selection name text 
field.

7 Click OK.

Variables 1
1 On the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

Name Expression Unit Description

p -(3/2)*F/(2*Axy_mh)*
(1-(Y/r_mh)^2)

N/m² Mount hole stress

fy_mh p*nY N/m² Mount hole force, y 
component

fz_mh p*nZ N/m² Mount hole force, z 
component

d_mh aveop1(w) m Mount hole displacement

L_t h_t+t_p+o_mh m Equivalent tube length
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A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Structural steel.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Structural steel (mat1)
By default, the first material you add applies on all domains so you need not alter any 
settings.

1 On the Home toolbar, click Add Material to close the Add Material window.

S O L I D  M E C H A N I C S  ( S O L I D )

Linear Elastic Material 1
By default, the physics interface takes the required material model properties from the 
domain material.

Next, define the boundary conditions.

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

Axy_mh 2*r_mh*t_m m² Mount hole xy projected 
area

A_t pi*(r_t^2-(r_t-t_t)^2) m² Tube cross section area

S F/d_mh N/m Stiffness of the 
assembly

S_i 200e9[Pa]*A_t/L_t N/m Ideal stiffness

S_R S/S_i Stiffness ratio

Name Expression Unit Description
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2 Select Boundaries 8, 9, 33, and 42 only.

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 20, 22, 51, and 53 only.

Use the force components you defined earlier.

3 In the Settings window for Boundary Load, locate the Force section.
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4 Specify the FA vector as

M E S H  1

This section illustrates how you can mesh different parts of the model individually to get 
a suitable mesh.

Free Tetrahedral 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

Free Tetrahedral.

2 In the Settings window for Free Tetrahedral, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Manual.

5 Select Domains 4 and 7 only.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Tetrahedral 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Fine.

Free Tetrahedral 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Free Tetrahedral 

1.

2 In the Settings window for Free Tetrahedral, click Build Selected.

Free Tetrahedral 2
1 In the Model Builder window, right-click Mesh 1 and choose Free Tetrahedral.

2 In the Settings window for Free Tetrahedral, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Manual.

5 Select Domain 1 only.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Tetrahedral 2 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

0 x

fy_mh y

fz_mh z
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3 From the Predefined list, choose Finer.

Free Tetrahedral 2
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Free Tetrahedral 

2.

2 In the Settings window for Free Tetrahedral, click Build Selected.

Swept 1
1 In the Model Builder window, right-click Mesh 1 and choose Swept.

2 In the Settings window for Swept, click to expand the Source faces section.

3 Locate the Source Faces section. Select the Active toggle button.

4 Select Boundary 4 only.

5 Click to expand the Destination faces section. Locate the Destination Faces section. Select 
the Active toggle button.

6 Select Boundary 3 only.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Swept 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Fine.

Swept 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Swept 1.

2 In the Settings window for Swept, click Build Selected.
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3 Click the Wireframe Rendering button on the Graphics toolbar to restore the default 
state.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Stress (solid)
1 In the Model Builder window, under Results click Stress (solid).

2 In the Settings window for 3D Plot Group, type Displacement in the Label text field.

Displacement
Now, plot the z-displacement and compare the stiffness ratio for the current model 
geometry dimensions with the ideal one.

Surface 1
1 In the Model Builder window, expand the Displacement node, then click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Solid Mechanics>

Displacement>Displacement field (Material)>w - Displacement field, Z component.

3 Locate the Expression section. From the Unit list, choose µm.
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4 On the Displacement toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

Global Evaluation 1
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, click Replace Expression in the upper-right 
corner of the Expressions section. From the menu, choose Model>Component 1>

Definitions>Variables>S_R - Stiffness ratio.

3 Click Evaluate.

TA B L E

1 Go to the Table window.

The stiffness ratio obtained is 0.38, which is less than the desired value.

Proceed to add a parametric sweep feature that varies the mount thickness and plate 
thickness.

S T U D Y  1

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

5 Click Add.

6 In the table, enter the following settings:

7 Locate the Output While Solving section. Select the Plot check box.

8 On the Study toolbar, click Compute.

Parameter name Parameter value list Parameter unit

t_p 10[mm] 12[mm]

Parameter name Parameter value list Parameter unit

t_m 10[mm] 15[mm]
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R E S U L T S

Displacement
To display the results from the parametric sweep, change the data set.

1 In the Model Builder window, under Results click Displacement.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Data set list, choose Study 1/Parametric Solutions 1 (sol2).

The default parameter values correspond to those for the sweep’s last parameter pair.

4 On the Displacement toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

Finally, compare the updated stiffness value for the updated model geometry dimensions 
with the ideal one.

Global Evaluation 2
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Data section.

3 From the Data set list, choose Study 1/Parametric Solutions 1 (sol2).

4 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Definitions>Variables>S_R - Stiffness ratio.

5 Click Evaluate.

TA B L E

1 Go to the Table window.

Observe that the stiffness ratio obtained now is 0.53.
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Introduction

The example Stiffness Analysis of a Communication Mast’s Diagonal Mounting in the 
COMSOL Multiphysics Application Libraries shows how you can modify a 3D CAD 
model to improve its performance. In that case, the applied changes were based solely on 
the analyst’s experience with similar structures. A senior design engineer can sometimes 
reach acceptable performance after analyzing only a handful of designs, while an 
unexperienced analyst may have to spend a lot of time on failed attempts.

Usually, you can indeed improve a design by trial and error, but it is difficult to ensure that 
the price you pay—in this example, added weight and material costs—is as low as possible. 
With sensitivity analysis, you can find the most cost-efficient direction for a small 
modification and estimate the effect it has before attempting an updated design.

Model Definition

The original model simulates the deformation of a part of a communication mast, shown 
in Figure 1, under loads in the linear regime. The ratio of the part’s effective stiffness to 
the stiffness of an equal length of straight pipe is evaluated as a measure of its performance. 
Using sensitivity analysis together with a Deformed Geometry interface, you can predict 
what effect changing the dimensions of the end plate and the mount plates has on the 
part’s relative stiffness.

Figure 1: Mounting detail of a mast diagonal.
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From the designer’s point of view, the material thickness of the end plate, tp, and of the 
mount plates, tm, are the most relevant parameters because they are easy to change both 
in the CAD system and on the production line. These quantities are, however, not directly 
comparable to each other because a unit change of tp incurs a different cost—added weight 
and material use—compared to a unit change in tm.

For a fair analysis, it is therefore more convenient to parameterize the model in terms of 
the masses Δmp and Δmm added to the end plate and mount, respectively. The relation 
between added mass, Δm, and thickness change, Δt, is given by

where A is the area affected by the thickness change (m2) and ρ is the density of the 
material (kg/m3).

As output from a sensitivity analysis using the stiffness ratio, SR, as objective function and 
the differential masses Δmpl and Δmmt as sensitivity variables, you get the partial 
derivatives

For a modified geometry corresponding to small values of Δmp and Δmm you can 
therefore expect to see a change in the stiffness ratio equal to

Note that this relation holds only for a small incremental change from the current 
configuration because the stiffness ratio is clearly a nonlinear function of the thicknesses. 
Now suppose that you want to select the best possible design update for a given added 
mass Δm = Δmp + Δmm with the added condition that both Δmp and Δmm are 
nonnegative. It is not too difficult to realize that the best option is to take Δmp = Δm, 
mm = 0 if Qp > Qm, and Δmpl = 0, mmt = Δm otherwise.

The optimal stiffness for a given total mass of the structure can be sought by relaxing the 
nonnegativity condition for the updates and instead restricting the maximum change in 
Δmpl and Δmmt during one iteration. With the total mass as only constraint, you find the 
optimum design at a point where Qp = Qm. This follows strictly from the 
Karush-Kuhn-Tucker conditions but also from the simple fact that at such a point, the 
increased stiffness from adding mass to the plate is exactly canceled by the decrease in 
stiffness from removing the same mass from the mount.

Δm ρAΔt=

Qp mp∂
∂SR= Qm mm∂

∂SR=

ΔSR QpΔmp QmΔmm+=
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P A R A M E T E R I Z I N G  T H E  G E O M E T R Y

In the Sensitivity interface, you declare sensitivity variables, which can be used to 
parameterize the physics. The sensitivity variables can appear anywhere COMSOL 
Multiphysics accepts an expression containing the dependent variables. However, neither 
dependent variables nor sensitivity variables can be used directly to set dimensions in the 
geometry.

To evaluate the sensitivity of a model with respect to geometrical changes, the geometry 
must first be made an active part of the system of equations. You accomplish this by 
moving all physics onto a deformed configuration controlled by a Deformed Geometry 
interface, described in Deformed Geometry and Moving Mesh in the COMSOL 
Multiphysics Reference Manual. This interface sets up an equation governing the position 
of the mesh nodes inside the domains, while the outer shape of the domain is controlled 
by boundary conditions.

When doing sensitivity analysis, these boundary conditions are quite simple: on fixed 
surfaces, set the mesh displacement to zero; on surfaces that may be modified, specify the 
displacement in terms of the sensitivity variables. In this particular case, where the material 
thickness of the end plate and the mount can change, it is enough to set the normal 
displacement of these surfaces equal to the thickness change calculated from the 
corresponding added mass. For the latter calculation, assume the total undeformed length 
of the part to be fixed and define Δmpl as the net mass added when tpl increases.

On surfaces adjacent to a domain with a parameterized normal displacement, it is 
preferable to restrict the mesh displacement to zero only in the normal direction to avoid 
an inconsistent constraint on the common edge. However, any remaining inconsistencies 
do not invalidate your results completely but only effectively modify the parametrization. 
In cases like this, when the purpose of the analysis is a rough estimate and guidance for a 
manual redesign, such minor errors in the sensitivities are unimportant.

Another potential source of errors must be checked more carefully, though. Changing the 
material thickness of the mount also changes the area where the loading is applied. In the 
Solid Mechanics interface, you specify the load as a given force per area. If you keep this 
number fixed when the thickness of the part changes, the total applied load also changes; 
when evaluating the stiffness ratio of the composite part you must account for this effect. 
Alternatively, you can keep the total force fixed and make sure that the applied force per 
unit area is calculated using a hole area that follows the parametrization of the geometry. 
This is simply done by changing the expression for the mount hole xy-projected area to 

Amh
xy 2 rmh tm δtm+( )⋅=
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where δtm is the increase in the mount thickness. 

C H O O S I N G  F O R W A R D  O R  A D J O I N T  S E N S I T I V I T Y  A N A L Y S I S

By default, the Sensitivity interface uses the adjoint method, which is more efficient than 
the forward method when the number of sensitivity variables is large. When there is only 
a handful of scalar parameters, as in this case, the forward method has the advantage that 
it returns the sensitivity of the entire solution with respect to the sensitivity variables in 
addition to the sensitivity of the objective function. This additional information can 
sometimes be important in itself, but more often it is useful for checking the model setup 
because it is easy to visualize.

Results and Discussion

The analysis shows that when the thickness of the end plate is 12 mm and the material 
thickness in the mount is 15 mm, the sensitivities to adding mass to the two details are 
Qp = 0.25 and Qm = 0.23, respectively. Because, apparently, adding mass to the end plate 
has more effect than adding it to the mount, the next redesign of the part should be fitted 
with a thicker plate. You might even consider decreasing the material thickness of the 
mount while adding to the plate to keep the weight of the part constant.

Note that these conclusions only hold for the current instance of the design. An 
experienced analyst quickly realizes that the stiffness contribution of the plate is due to 
bending action, while the stiffness contribution of the mount is almost pure tensile action. 
A plate’s resistance to bending grows as its thickness cubed, while resistance to tension is 
proportional to the cross-sectional area. Therefore, as the thickness of the plate increases, 
its contribution to the stiffness of the composite part increases rapidly.

If you increase the thickness of the end plate too much, the stiffness of the mount takes 
over as dominant factor in the overall behavior. Using sensitivity analysis, you can easily 
detect when this happens, because it leads to Qm > Qp. As noted above, an optimum 
design for a given total mass is found when Qp = Qm.

Because the sensitivity analysis was performed using the forward method, the derivatives 
of the solution with respect to the parameters Δmp and Δmm have also been stored. You 
can access this data when processing the results by using the syntax sens(expr,var). For 
example, by plotting the expression sens(w,dm_mt), you can directly examine the local 
effect of a unit increase in the mount mass, see Figure 2. 
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Figure 2: The influence of 1 mm mount thickness increase on the overall displacement. 

Application Library path: COMSOL_Multiphysics/Structural_Mechanics/
mast_diagonal_mounting_sensitivity

Modeling Instructions

From the File menu, choose Open.

Browse to the application’s Application Libraries folder and double-click the file 
mast_diagonal_mounting.mph.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Mathematics>Deformed Mesh>Deformed Geometry (dg).
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4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Study 1.

5 Click Add to Component in the window toolbar.

6 On the Home toolbar, click Add Physics to close the Add Physics window.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

G L O B A L  D E F I N I T I O N S

Modify the parameters for the plate thickness and mount thickness to correspond to the 
updated configuration of the original model.

Parameters
1 In the Model Builder window, expand the Global Definitions node, then click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, modify the following settings:

4 Next, define the masses added to the plate and mount that you will use later as global 
control variables.

D E F I N I T I O N S

Create a selection for the domains where the mesh will be allowed to deform.

Union 1
1 On the Definitions toolbar, click Union.

2 In the Settings window for Union, locate the Input Entities section.

Name Expression Value Description

t_p 12[mm] 0.012 m Plate thickness

t_m 15[mm] 0.015 m Mount thickness

Name Expression Value Description

dm_p 0 0 Added mass, plate

dm_m 0 0 Added mass, mount
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3 Under Selections to add, click Add.

4 In the Add dialog box, In the Selections to add list, choose End plate and Mount.

5 Click OK.

6 Right-click Union 1 and choose Rename.

7 In the Rename Union dialog box, type Deformed mesh domains in the New label text 
field.

8 Click OK.

Add component couplings for integrating over the flat surfaces of the plate and mount.

9 Click the Wireframe Rendering button on the Graphics toolbar.

Integration 1 (intop1)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, type dA_mt in the Operator name text field.

3 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

4 Select Boundaries 15 and 56 only.

5 Click Create Selection.
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6 In the Create Selection dialog box, type Outer mount faces in the Selection name text 
field.

7 Click OK.

8 Right-click Integration 1 (intop1) and choose Rename.

9 In the Rename Integration dialog box, type Outer mount faces in the New label text 
field.

10 Click OK.

Integration 2 (intop2)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, type dA_pl in the Operator name text field.

3 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

4 Select Boundary 4 only.

5 Click Create Selection.

6 In the Create Selection dialog box, type Plate surface in the Selection name text field.

7 Click OK.

8 Right-click Integration 2 (intop2) and choose Rename.
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9 In the Rename Integration dialog box, type Plate surface in the New label text field.

10 Click OK.

11 Click the Wireframe Rendering button on the Graphics toolbar to return to the default 
state.

Next, define variables for the displacements as functions of the added masses.

Variables 2
1 On the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

The mass per unit thickness for the plate refers to the area outside the surface where the 
plate connects to the mount; thus, it gives the net added mass when the thickness of the 
plate increases.

4 Right-click Variables 2 and choose Rename.

5 In the Rename Variables dialog box, type Sensitivity Variables in the New label text 
field.

6 Click OK.

Modify variables that are affected by change in plate and mount thickness.

Variables 1
1 In the Model Builder window, expand the Definitions node, then click Variables 1.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

Name Expression Unit Description

mA_pl dA_pl(solid.rho) kg/m Mass per unit thickness, 
plate

mA_mt dA_mt(solid.rho) kg/m Mass per unit thickness, 
mount

dt_p dm_p[kg]/mA_pl m Displacement, plate end 
face

dt_m dm_m[kg]/mA_mt m Displacement, outer 
mount faces

Name Expression Unit Description

Axy_mh 2*r_mh*(t_m+dt_m) m² Mount hole xy projected 
area
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D E F O R M E D  G E O M E T R Y  ( D G )

By default, the mesh is fixed in all domains. Remove this constraint for the mount and 
plates by adding a Free Deformation node:

Free Deformation 1
1 On the Physics toolbar, click Domains and choose Free Deformation.

2 In the Settings window for Free Deformation, locate the Domain Selection section.

3 From the Selection list, choose Deformed mesh domains.

The virtual boundary displacements must be described in a boundary system which does 
not rotate with the deformation.

D E F I N I T I O N S

Boundary System 1 (sys1)
1 In the Model Builder window, expand the Component 1 (comp1)>Definitions node, then 

click Boundary System 1 (sys1).

2 In the Settings window for Boundary System, locate the Settings section.

3 From the Frame list, choose Geometry configuration.

D E F O R M E D  G E O M E T R Y  ( D G )

Prescribed Mesh Displacement 1
1 In the Model Builder window, under Component 1 (comp1)>Deformed Geometry (dg) click 

Prescribed Mesh Displacement 1.

2 In the Settings window for Prescribed Mesh Displacement, locate the Coordinate System 

Selection section.

3 From the Coordinate system list, choose Boundary System 1 (sys1).

4 Locate the Prescribed Mesh Displacement section. Clear the Prescribed t1 displacement 
check box.

5 Clear the Prescribed t2 displacement check box.

This default condition will apply to the boundaries where you do not prescribe nonzero 
displacements.

Prescribed Mesh Displacement 2
1 On the Physics toolbar, click Boundaries and choose Prescribed Mesh Displacement.

2 In the Settings window for Prescribed Mesh Displacement, locate the Boundary Selection 
section.
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3 From the Selection list, choose Outer mount faces.

4 Locate the Coordinate System Selection section. From the Coordinate system list, choose 
Boundary System 1 (sys1).

5 Locate the Prescribed Mesh Displacement section. Clear the Prescribed t1 displacement 
check box.

6 Clear the Prescribed t2 displacement check box.

7 In the dn text field, type dt_m.

Prescribed Mesh Displacement 3
1 On the Physics toolbar, click Boundaries and choose Prescribed Mesh Displacement.

2 In the Settings window for Prescribed Mesh Displacement, locate the Boundary Selection 
section.

3 From the Selection list, choose Plate surface.

4 Locate the Coordinate System Selection section. From the Coordinate system list, choose 
Boundary System 1 (sys1).

5 Locate the Prescribed Mesh Displacement section. Clear the Prescribed t1 displacement 
check box.

6 Clear the Prescribed t2 displacement check box.

7 In the dn text field, type dt_p.

S T U D Y  2

Now, set up the study. In particular, you need to add a Sensitivity node. But first, you must 
enable advanced study options.

1 In the Model Builder window’s toolbar, click the Show button and select Advanced Study 

Options in the menu.

Sensitivity
1 In the Model Builder window, right-click Study 2 and choose Sensitivity.

By using the forward method, you will have access to the derivatives of the solution with 
respect to the sensitivity variables dm_p and dm_m.

2 In the Settings window for Sensitivity, locate the Sensitivity Method section.

3 From the Gradient method list, choose Forward.

The stiffness ratio computed in the original model serves as the objective function.
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4 Click Replace Expression in the upper-right corner of the Objective function section. From 
the menu, choose Model>Component 1 (comp1)>Definitions>Variables>comp1.S_R - 

Stiffness ratio.

5 Locate the Control Variables and Parameters section. Click Add.

6 Click Add.

7 In the table, enter the following settings:

8 On the Home toolbar, click Compute.

R E S U L T S

Derived Values
Begin by evaluating the sensitivities of the stiffness ratio with respect to the two types of 
small additions.

Global Evaluation 3
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Data section.

3 From the Data set list, choose Study 2/Solution 5 (sol5).

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Global Evaluation 4
1 Right-click Global Evaluation 3 and choose Duplicate.

2 In the Settings window for Global Evaluation, locate the Expressions section.

3 In the table, enter the following settings:

4 Click Table 3 - Global Evaluation 3 (fsens(dm_m)).

Parameter name Value Scale Value type

dm_p 0 1 real

dm_m 0 1 real

Expression Unit Description

fsens(dm_m)

Expression Unit Description

fsens(dm_p)
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Create plot for the sensitivity of axial displacement with respect to change in the added 
platemass.

3D Plot Group 4
1 On the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Sensitivity in the Label text field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 5 (sol5).

Surface 1
1 Right-click Sensitivity and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type sens(w,dm_p).

4 Locate the Coloring and Style section. From the Color table list, choose Thermal.

5 On the Sensitivity toolbar, click Plot.

Deformation 1
1 Right-click Results>Sensitivity>Surface 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Expression section.

3 In the X component text field, type u+1[mm]*mA_pl*sens(u,dm_p).

4 In the Y component text field, type v+1[mm]*mA_pl*sens(v,dm_p).

5 In the Z component text field, type w+1[mm]*mA_pl*sens(w,dm_p).

These deformations give a linar approximation of the deformation that would result 
from a 1 mm increase in the plate thickness.

6 On the Sensitivity toolbar, click Plot.

Sensitivity
1 In the Model Builder window, under Results click Sensitivity.

2 In the Settings window for 3D Plot Group, click to expand the Title section.

3 From the Title type list, choose Manual.

4 In the Title text area, type Surface: Sensitivity of w to added plate mass.

5 On the Sensitivity toolbar, click Plot.
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Introduction

The purpose of this example is to demonstrate how to access the batch functionality in 
COMSOL from the COMSOL Desktop and use it on your computer. The model also 
demonstrates how you can measure the speedup of COMSOL on your computer. The 
speedup is defined as the quotient between the total runtime using only one core of the 
machine and the runtime using all cores of the machine.

For detailed information about the model, see Micromixer.

Application Library path: COMSOL_Multiphysics/Tutorials/micromixer_batch

Modeling Instructions

A P P L I C A T I O N  L I B R A R I E S

1 On the Home toolbar, click Application Libraries.

2 In the Application Library tree, select COMSOL Multiphysics>Fluid Dynamics>micromixer.

3 Click Open Application.

S T U D Y  1

1 In the Model Builder window’s toolbar, click the Show button and select Advanced Study 

Options in the menu.

With this setting active, Batch is available from the Study node's context menu.

Batch
1 In the Model Builder window, right-click Study 1 and choose Batch.

2 In the Settings window for Batch, locate the Batch Settings section.

In the Study Settings section of the Settings window for Batch, you specify where to 
store the model for the batch job:

Enter a suitable filename in the Filename text field, and specify a directory by clicking 
Browse and then making a choice in the Batch Directory dialog box or by typing in the 
directory path directly in the Directory text field.

3 On the Home toolbar, click Compute.

When the process has finished, you are automatically transferred to the External Process 
node for the batch job you just ran.
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External Process 1
1 In the External Process settings window, locate the General section.

In the General section, click Open to open the file containing the model generated by 
the batch job associated with this external process in a new COMSOL session.

In the Process Status section, the log shows the total solution time. COMSOL 
automatically takes advantage of all cores; to measure the speedup, set the number of 
cores to 1 and run another batch job.

Batch 1
1 In the Model Builder window, click Study 1>Job Configurations>Batch 1.

2 In the Settings window for Batch, locate the General section.

3 From the Defined by study step list, choose User defined.

4 Select the Number of cores check box.

Verify that the setting in the associated text field is 1.

Next, change the filename to create a new External Process node for the run:

5 Locate the Files section. In the associated text field, enter a name of your choice.

6 Click the Run button.

When the process has finished, compare the total time in the log for the new external 
process with the previous value. The speedup is equal to the previous value divided by 
the new value. The speedup is dependent on the mesh size. To improve the numbers, 
try refining the mesh.
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Introduction

The purpose of this example is to demonstrate how to access the cluster computing 
functionality in COMSOL from the COMSOL Desktop and use it to submit a batch job 
to a cluster through a job scheduler. The model also demonstrates how you can measure 
the speedup of COMSOL on your computer. The speedup is defined as the quotient 
between the total runtime using only one physical node and one core of the cluster and 
the runtime using several physical nodes and all cores of each physical node of the cluster.

For detailed information about the model, see Micromixer. For information about how to 
set up a COMSOL for running on a cluster, see the COMSOL Multiphysics Installation 
Guide.

Note: This application requires a Floating Network License.

Application Library path: COMSOL_Multiphysics/Tutorials/micromixer_cluster

Modeling Instructions

A P P L I C A T I O N  L I B R A R I E S

1 On the Home toolbar, click Application Libraries.

2 In the Application Library tree, select COMSOL Multiphysics>Fluid Dynamics>micromixer.

3 Click Open Application.

S T U D Y  1

1 In the Model Builder window’s toolbar, click the Show button and select Advanced Study 

Options in the menu.

With this setting active, Cluster Computing is available from the Study node's context 
menu.

Cluster Computing
1 In the Model Builder window, right-click Study 1 and choose Cluster Computing.
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2 In the Settings window for Cluster Computing, locate the Batch Settings section.

Choose from one of the following settings the type of job scheduler to use:

General: Use the General scheduler if you intend to submit a job to a job scheduler that 
you have configured COMSOL to run on.

HPCS 2008: Use the HPCS 2008 scheduler if you intend to submit a job to a Windows 
HPC Server 2008 using the Windows HPC Cluster Manager.

WCCS 2003: Use the WCCS 2003 scheduler if you intend to submit a job to a 
Windows Compute Cluster Server 2003.

3 From the Scheduler type list, choose Not distributed.

Not Distributed: Use this setting when you have configured COMSOL to run on job 
scheduler but only intend to run on a single node of the cluster.

Make sure you configure the batch directories and COMSOL installation directories 
correctly. It is good practice to save these values as default once you have good settings.

4 Click the Save as Default button.

Only MUMPS and SPOOLES are distributed so you need to enable the direct solver to 
get distributed speedup.

Solution 1 (sol1)
1 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1(sol1)>

Stationary Solver 1 node.

2 Right-click Direct and choose Enable.

3 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1(sol1)>

Stationary Solver 2 node.

4 Right-click Direct and choose Enable.

5 On the Home toolbar, click Compute.

Batch 1
In the General section, click Open to open the file containing the model generated by 
the batch job associated with this external process in a new COMSOL session.

In the Process Status section, the log shows the total solution time. COMSOL 
automatically takes advantage of all cores; to measure the speedup, set the number of 
cores to 1 and run a new job.

1 In the Model Builder window, click Batch 1.

2 In the Settings window for Batch, locate the General section.

3 From the Defined by study step list, choose User defined.
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4 Select the Number of cores check box.

Verify that the setting in the associated text field is 1.

Next, change the filename to create a new External Process node for the run:

5 Locate the Files section. In the Filename text field, enter a name of your choice.

Cluster Computing 1
If you are not using the cluster type Not distributed, make sure to set the Number of nodes 
to 1.

1 In the Model Builder window, under Study 1>Job Configurations right-click Cluster 

Computing 1 and choose Run.

When the process has finished, compare the total time in the log for the new external 
process with the previous value. The speedup is equal to the previous value divided by 
the new value. The speedup depends on the mesh size. To improve the numbers, try 
refining the mesh.
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Introduction

This example illustrates the use of COMSOL Multiphysics for modeling of ionic current 
distribution problems in electrolytes, in this case in human tissue. The problem is 
exemplified on a pacemaker electrode, but it can be applied in electrochemical cells like 
fuel cells, batteries, corrosion protection, or any other process where ionic conduction 
takes place in the absence of concentration gradients.

The modeled device is a pacemaker electrode that is placed inside the heart and helps the 
patient’s heart to keep a normal rhythm. The device is referred to as an electrode, but it 
actually consists of two electrodes: a cathode and an anode.

Figure 1 shows a schematic drawing of two pair of electrodes placed inside the heart. The 
electrodes are supplied with current from the pulse generator unit, which is also implanted 
in the patient.

Figure 1: Schematic drawing of the heart with two pairs of pacemaker electrodes.

This example deals with the current and potential distribution around one pair of 
electrodes.

Model Definition

The model domain consists of the blood and tissue surrounding the electrode pair. The 
actual electrodes and the electrode support are boundaries to the modeled domain. 
Figure 2 shows the electrode in a darker shade, while the surrounding modeling domain 

Pulse generator

Pacing leads

Left atrium

Left ventricle
Right atrium

Right ventricle
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is shown in a lighter shade.

Figure 2: Modeling domain and boundaries.

The working electrode consists of a a hemisphere placed on the tip of the supporting 
cylindrical structure. The counter electrode is placed in the “waist” of this structure. All 
other surfaces of the supporting structure are insulated. The outer boundaries are placed 
far enough from the electrode to give a small impact on the current and potential 
distribution.

In COMSOL Multiphysics, use the Electric Currents interface for the analysis of the 
electrode. This physics interface is useful for modeling conductive materials where a 
current flows due to an applied electric field.

D O M A I N  E Q U A T I O N S

The current in the domain is controlled by the continuity equation, which follows from 
Maxwell’s equations:

where σ is the conductivity of the human tissue. This equation uses the following relations 
between the electric potential and the fields.

Spherical working electrodeAnnular counter electrode

Outer boundaries of
the domain

Insulated surfaces of 
the device

∇– σ V∇( )⋅ 0=

E V∇–=

J σE=
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B O U N D A R Y  C O N D I T I O N S

Ground potential boundary conditions are applied on the thinner waist of the electrode. 
The tip of the electrode has a fixed potential of 1 V. All other boundaries are electrically 
insulated.

Results and Discussion

This simulation gives the potential distribution on the electrode surface and streamlines of 
the current distribution inside the human heart; see Figure 3.

Figure 3: The plot shows the electrostatic potential distributed on the surface of the electrode. 
The total current density is shown as streamlines.

As expected, the current density is highest at the small hemisphere, which is the one that 
causes the excitation of the heart. The current density is fairly uniform on the working 
electrode. The counter electrode is larger and there are also larger variations in current 
density on its surface. Mainly, the current is lower with increasing distance from the 
working electrode. The model shows that the anchoring arms of the device have little 
influence on the current density distribution.

n J⋅ 0=
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Application Library path: COMSOL_Multiphysics/Electromagnetics/
pacemaker_electrode

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select AC/DC>Electric Currents (ec).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

Although you can readily build the pacemaker geometry from geometric primitives using 
the CAD tools in COMSOL Multiphysics, it is supplied as a COMSOL Multiphysics 
geometry file for convenience.

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
pacemaker_electrode.mphbin.
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5 Click Import.

Next, define the volume surrounding the electrode. The simulation only takes place in this 
volume, where the boundaries of the electrode influence the result.

Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type 0.01.

4 In the Height text field, type 0.04.

5 Locate the Position section. In the z text field, type -0.02.

6 Right-click Cylinder 1 (cyl1) and choose Build Selected.

7 Click the Go to Default 3D View button on the Graphics toolbar.

Difference 1 (dif1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Difference.

2 Select the object cyl1 only.

3 In the Settings window for Difference, locate the Difference section.

4 Find the Objects to subtract subsection. Select the Active toggle button.

5 Select the object imp1 only.
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Form Union (fin)
1 Right-click Difference 1 (dif1) and choose Build Selected.

2 In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click Form 

Union (fin) and choose Build Selected.

The model geometry is now complete.

3 Click the Transparency button on the Graphics toolbar.

M A T E R I A L S

A convenient way to find out which material parameters you need to specify is to add a 
material. COMSOL Multiphysics then indicates any missing parameters for the physics 
interfaces you have added to the model.

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

By default, the first material you add applies to all domains, so you do not need to 
modify the geometric scope.

The electrode is inserted into the human heart, so you must specify the conductivity for 
the heart tissue.

2 In the Settings window for Material, locate the Material Contents section.
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3 In the table, enter the following settings:

4 Right-click Component 1 (comp1)>Materials>Material 1 (mat1) and choose Rename.

5 In the Rename Material dialog box, type Heart Tissue in the New label text field.

6 Click OK.

E L E C T R I C  C U R R E N T S  ( E C )

The only physics settings that remain to specify are the electrode potentials.

Ground 1
1 On the Physics toolbar, click Boundaries and choose Ground.

2 Select Boundaries 29, 30, 58, and 63 only.

The easiest way to do this is by entering these numbers in the dialog box that opens if 
you click the Paste Selection button in the Boundaries section.

Optionally, you can create a named selection for these boundaries as follows:

3 In the Settings window for Ground, locate the Boundary Selection section.

4 Click Create Selection.

5 In the Create Selection dialog box, type Counter Electrode in the Selection name text 
field.

6 Click OK.

Electric Potential 1
1 On the Physics toolbar, click Boundaries and choose Electric Potential.

2 Select Boundaries 31, 32, 59, and 60 only.

3 In the Settings window for Electric Potential, locate the Electric Potential section.

4 In the V0 text field, type 1.

5 Locate the Boundary Selection section. Click Create Selection.

6 In the Create Selection dialog box, type Spherical Electrode in the Selection name 
text field.

7 Click OK.

Property Name Value Unit Property 
group

Electrical conductivity sigma 5000 S/m Basic

Relative permittivity epsilonr 1 1 Basic
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M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, click Build All.

S T U D Y  1

Use the default settings for the stationary solver, which gives the conjugate gradients 
iterative solver with algebraic multigrid as the preconditioner.

1 On the Home toolbar, click Compute.

R E S U L T S

Electric Potential (ec)
The default plot shows the slices of the electrical potential. To reproduce the plot shown 
in Figure 3, start by resetting the transparency state and instead hide the outer boundaries.

1 Click the Transparency button on the Graphics toolbar.

E L E C T R I C  C U R R E N T S  ( E C )

1 Click the Click and Hide button on the Graphics toolbar.

2 Click the Select Boundaries button on the Graphics toolbar.

3 In the Model Builder window, under Component 1 (comp1) click Electric Currents (ec).

4 Select Boundaries 1–4, 45, and 74 only.
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5 Click the Click and Hide button on the Graphics toolbar.

R E S U L T S

3D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, locate the Plot Settings section.

3 Clear the Plot data set edges check box.

4 Right-click 3D Plot Group 2 and choose Surface.

Surface 1
On the 3D Plot Group 2 toolbar, click Plot.

3D Plot Group 2
Combine the surface plot of the potential with streamlines visualizing the total current 
density.

Streamline 1
1 In the Model Builder window, under Results right-click 3D Plot Group 2 and choose 

Streamline.

2 In the Settings window for Streamline, locate the Selection section.

3 Select the Active toggle button.

4 From the Selection list, choose All boundaries.

5 Locate the Streamline Positioning section. From the Positioning list, choose Start point 

controlled.

6 Locate the Coloring and Style section. From the Line type list, choose Tube.

7 In the Tube radius expression text field, type ec.normJ. This is the variable for the 
current density norm.

To get suitably thick streamlines you need to adjust the scale factor.

8 Select the Radius scale factor check box.

9 In the associated text field, type 1e-10.

10 On the 3D Plot Group 2 toolbar, click Plot.

Color Expression 1
1 Right-click Results>3D Plot Group 2>Streamline 1 and choose Color Expression.

Use the default expression. Because it is the same as the surface expression, you can 
disable the color legend:
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2 In the Settings window for Color Expression, locate the Coloring and Style section.

3 Clear the Color legend check box.

After proper rotation and zoom operations, you should see something similar to the 
plot in Figure 3.
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Introduction

In the chemical process industry it is often important to control a specific process. PID 
control (proportional-integral-derivative-control) is one way to achieve that, but it can be 
difficult to optimize the parameters in the PID algorithm. This example illustrates how you 
can implement a PID control algorithm to simulate a process control system and to find 
the optimal PID parameters.

This application is a generic example but could resemble the environment in a combustion 
chamber where the concentration at the ignition point is crucial. Two gas streams with 
different oxygen concentrations are mixed in the combustion chamber. The concentration 
is measured at the ignition point before complete mixing of the streams is reached. The 
control algorithm alters the inlet velocity of the gas with the lower oxygen content to 
achieve the desired total concentration at the ignition point.

Model Definition

The model geometry appears in Figure 1. At the upper inlet, a gas stream with high 
oxygen content enters the reactor at a velocity of 10 mm/s, while a gas with a lower 
oxygen level enters from the left. The oxygen concentration is measured at a measurement 
point, and the inlet velocity of the less concentrated stream is altered by the PID control 
algorithm to achieve the desired concentration at that point.

Figure 1: Model geometry.

Outlet

Upper inlet

Controlled inlet

Measurement point
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The model uses the Laminar Flow interface to describe the fluid flow and the Transport 
of Diluted Species interface for the mass balance. The corresponding equations read 
(assuming incompressible flow and absence of reactions)

To formulate the boundary conditions for the mass-transport equation, begin by assuming 
that you know the two inlet concentrations. In addition, assume that the reactant transport 
at the outlet is mainly driven by convection, that is, neglect diffusion in the main direction 
of the convective flow. A no-flux boundary condition describes all walls. The boundary 
conditions for the mass balance are:

Here c is the concentration; cin,top and cin,inlet are the inlet concentrations (mol/m3) for 
the upper and controlled inlets, respectively; D is the applied diffusivity (m2/s); and N is 
the molar flux (mol/(m2·s)).

The model uses the following boundary conditions for the fluid flow:

Here u is the velocity vector (m/s), vin,top is the inlet velocity at the top inlet, and uin is 
the PID controlled velocity. At the outlet, set the pressure to 0. No Slip boundary 
conditions describe all walls except the inlet sections where slip conditions apply, allowing 
for a smooth transition to a laminar velocity profile.

BOUNDARY CONSTRAINT

Upper inlet c = cin,top

Controlled inlet c = cin,inlet

Outlet n·(−D∇c) = 0

Walls N · n = 0

BOUNDARY CONSTRAINT

Upper inlet u = (0, −vin,top)

Controlled inlet u = (uin, 0)

Outlet p0 = 0

Inlet sections n · u = 0

Walls u = 0

ρ
t∂

∂u ∇ η ∇u ∇u( )T
+( )[ ]⋅– ρu ∇⋅ u ∇p+ + 0=

∇ u⋅ 0=

c∂
t∂

----- ∇ D c∇–( )⋅+ u ∇c⋅–=
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The PID control algorithm used to calculate uin is

 (1)

with the following parameters:

In practice, the derivative constant, kD, is set to 0 in most cases as this parameter can be 
difficult to determine. Moreover, the derivative term may increase the fluctuations in the 
system because it amplifies noise in the error c − cset.

Results and Discussion

The two plots in Figure 2 show the oxygen concentration and the velocity stream lines in 
the chamber after 0.05 s and 2 s, respectively. The figures show that the measured 
concentration depends strongly on the flow field. At start-up, when the inlet velocity of 
the stream entering from the left is very low, the sensor is entirely exposed to the highly 
concentrated stream, and as the left inlet velocity increases the opposite relation occurs.

PARAMETER VALUE

cset 0.5 mol/m3

kP 0.5 m4/(mol·s)

kI 1 m4/(mol·s2)

kD 10-3 m4/mol

uin kP c cset–( ) kI c cset–( )

0

t

 dt kD
∂
∂t
----- c cset–( )+ +=
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Figure 2: Oxygen concentration and velocity streamlines after 0.1 s (top) and 1.5 s (bottom).

Figure 3 shows the inlet velocity and concentration in the measurement point as a function 
of time for two different values for the kP parameter. The solid line represents the results 
for a kP value of 0.5 m4/(mol·s) while the dashed line corresponds to kP equal to 0.1 m4/
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(mol·s). The results evaluated for the smaller kP value oscillate more before stabilizing. 
Thus, it is clear that for this case the higher kP value yields a more stable process control.

Figure 3: PID-controlled inlet velocity (top) and concentration in the measurement point 
(bottom) as a function of time for kP = 0.5 m4/(mol·s) (blue) and kP = 0.1 m4/(mol·s) 
(green).
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Application Library path: COMSOL_Multiphysics/Multiphysics/pid_control

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Fluid Flow>Single-Phase Flow>Laminar Flow (spf).

3 Click Add.

4 In the Select Physics tree, select Chemical Species Transport>Transport of Diluted Species 

(tds).

5 Click Add.

6 In the Select Physics tree, select Mathematics>ODE and DAE Interfaces>Global ODEs and 

DAEs (ge).

7 Click Add.

8 Click Study.

9 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Time 

Dependent.

10 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

G E O M E T R Y  1

Create the geometry. To simplify this step, insert a prepared geometry sequence.

1 On the Geometry toolbar, click Insert Sequence.

2 Browse to the application’s Application Libraries folder and double-click the file 
pid_control_geom_sequence.mph.

3 On the Geometry toolbar, click Build All.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 Select Domain 1 only.

2 In the Settings window for Material, locate the Material Contents section.

Name Expression Value Description

v_in_top 0.01[m/s] 0.01 m/s Velocity, upper 
inlet

c_in_top 1[mol/m^3] 1 mol/m³ Concentration, 
upper inlet

c_in_inlet 0.2[mol/m^3] 0.2 mol/m³ Concentration, 
controlled inlet

c00 0.5[mol/m^3] 0.5 mol/m³ Initial 
concentration, 
chamber interior

D 1e-4[m^2/s] 1E-4 m²/s Diffusivity

c_set 0.5[mol/m^3] 0.5 mol/m³ Setpoint 
concentration

k_P_ctrl 0.5[m^4/(mol*s)] 0.5 m^4/(s·mol) Proportional 
parameter

k_I_ctrl 1[m^4/(mol*s^2)] 1 m^4/(s²·mol) Integral parameter

k_D_ctrl 1e-3[m^4/mol] 0.001 m^4/mol Derivative 
parameter
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3 In the table, enter the following settings:

L A M I N A R  F L O W  ( S P F )

Inlet 1
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 Select Boundary 1 only.

3 In the Settings window for Inlet, locate the Velocity section.

4 In the U0 text field, type u_in_ctrl*(u_in_ctrl>0).

Inlet 2
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 Select Boundary 7 only.

3 In the Settings window for Inlet, locate the Velocity section.

4 In the U0 text field, type v_in_top.

Outlet 1
1 On the Physics toolbar, click Boundaries and choose Outlet.

2 Select Boundary 13 only.

Wall 2
1 On the Physics toolbar, click Boundaries and choose Wall.

2 Select Boundaries 2, 3, 6, and 8 only.

3 In the Settings window for Wall, locate the Boundary Condition section.

4 From the Boundary condition list, choose Slip.

TR A N S P O R T  O F  D I L U T E D  S P E C I E S  ( T D S )

Transport Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Transport of Diluted Species 

(tds) click Transport Properties 1.

2 In the Settings window for Transport Properties, locate the Diffusion section.

3 In the Dc text field, type D.

4 Locate the Model Inputs section. From the u list, choose Velocity field (spf).

Property Name Value Unit Property group

Density rho 1.2[kg/m^3] kg/m³ Basic

Dynamic viscosity mu 3e-5 Pa·s Basic
9 |  P R O C E S S  C O N T R O L  U S I N G  A  P I D  C O N T R O L L E R



Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Transport of Diluted Species 

(tds) click Initial Values 1.

2 In the Settings window for Initial Values, locate the Initial Values section.

3 In the c text field, type c00.

4 In the Model Builder window, click Transport of Diluted Species (tds).

Inflow 1
1 On the Physics toolbar, click Boundaries and choose Inflow.

2 Select Boundary 1 only.

3 In the Settings window for Inflow, locate the Concentration section.

4 In the c0,c text field, type c_in_inlet.

Inflow 2
1 On the Physics toolbar, click Boundaries and choose Inflow.

2 Select Boundary 7 only.

3 In the Settings window for Inflow, locate the Concentration section.

4 In the c0,c text field, type c_in_top.

Outflow 1
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 Select Boundary 13 only.

D E F I N I T I O N S

Next, add a probe to sample the concentration and its time derivative at the point x = 0, 
y =  − 0.002.

Domain Point Probe 1
1 On the Definitions toolbar, click Probes and choose Domain Point Probe.

2 In the Settings window for Domain Point Probe, locate the Point Selection section.

3 In row Coordinates, set y to -0.002.

4 In the Model Builder window, expand the Domain Point Probe 1 node, then click Point 

Probe Expression 1 (ppb1).

5 In the Settings window for Point Probe Expression, type c_mp in the Variable name text 
field.
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6 Click Replace Expression in the upper-right corner of the Expression section. From the 
menu, choose Model>Component 1 (comp1)>Transport of Diluted Species>c - 

Concentration.

7 In the Model Builder window, right-click Domain Point Probe 1 and choose Point Probe 

Expression.

8 In the Settings window for Point Probe Expression, type ct_mp in the Variable name text 
field.

9 Locate the Expression section. In the Expression text field, type ct.

Variables 1
1 On the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

The nojac operator ensures that the above expression gives no Jacobian contribution. 
In practice, this means that the control velocity will always be evaluated based on the 
previous time step. This is necessary to avoid evaluation of an implicit time derivative in 
the inlet condition, which is not supported in the time dependent solver.

Moreover, ’I’ refers to the time integral in Equation 1, which you define next.

G L O B A L  O D E S  A N D  D A E S  ( G E )

Global Equations 1
1 In the Model Builder window, expand the Component 1 (comp1)>Global ODEs and DAEs 

(ge) node, then click Global Equations 1.

2 In the Settings window for Global Equations, locate the Global Equations section.

Name Expression Description

u_in_ctrl nojac(k_P_ctrl*
(c_mp-c_set)+k_I_ctrl*
I[mol*s/m^3]+k_D_ctrl*
ct_mp)

Velocity, controlled inlet
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3 In the table, enter the following settings:

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Finer.

4 Click Build All.

S T U D Y  1

Use a parametric sweep to solve for two different values of the proportional parameter, 
k_P.

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

Step 1: Time Dependent
1 In the Model Builder window, under Study 1 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,0.05,1) range(1.1,0.1,6).

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Time-Dependent Solver 1.

Name f(u,ut,utt,t) 
(1)

Initial value 
(u_0) (1)

Initial value 
(u_t0) (1/s)

Description

I It[s]-(c_
mp[m^3/
mol]-c_se
t[m^3/
mol])

0 0 Time integral term

Parameter name Parameter value list

k_P_ctrl 0.1 0.5
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3 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

4 Locate the Time Stepping section. From the Method list, choose Generalized alpha.

5 From the Steps taken by solver list, choose Intermediate.

This forces the solver to take at least one step in each of the time intervals you specified.

6 Click to expand the Advanced section. Locate the Time Stepping section. Find the 
Algebraic variable settings subsection. From the Error estimation list, choose Exclude 

algebraic.

7 On the Study toolbar, click Compute.

R E S U L T S

Velocity (spf)
The presence of the derivative term leads to a warning message from the solver. As already 
mentioned in the introduction, this term is difficult to determine and also sensitive to 
noise, so it is often set to 0.

Concentration (tds)
Add a streamline plot of the velocity to the default surface plot that shows the 
concentration at the end of the simulated time span (Figure 2). Study the solution at 
t = 0.05 s and t = 2 s.

1 In the Model Builder window, under Results right-click Concentration (tds) and choose 
Streamline.

2 In the Settings window for Streamline, locate the Streamline Positioning section.

3 From the Positioning list, choose Magnitude controlled.

4 In the Density text field, type 10.

5 On the Concentration (tds) toolbar, click Plot.

6 In the Model Builder window, click Concentration (tds).

7 In the Settings window for 2D Plot Group, locate the Data section.

8 From the Time (s) list, choose 0.05.

9 On the Concentration (tds) toolbar, click Plot.

10 Click the Zoom Extents button on the Graphics toolbar.

11 From the Time (s) list, choose 3.

12 On the Concentration (tds) toolbar, click Plot.
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1D Plot Group 4
Plot the PID-controlled inlet velocity (Figure 3).

1 In the Model Builder window, under Results click 1D Plot Group 4.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 Select the y-axis label check box.

4 In the associated text field, type u<sub>in,ctrl</sub> (mm/s).

5 In the Model Builder window, expand the 1D Plot Group 4 node, then click Global 1.

6 In the Settings window for Global, click Replace Expression in the upper-right corner of 
the y-axis data section. From the menu, choose Model>Component 1>Definitions>

Variables>u_in_ctrl - Velocity, controlled inlet.

7 Click to expand the Legends section. Find the Include subsection. Clear the Description 
check box.

8 On the 1D Plot Group 4 toolbar, click Plot.

Proceed to plot the concentration at the measurement point as a function of time 
(Figure 3).

1D Plot Group 6
1 In the Model Builder window, right-click 1D Plot Group 4 and choose Duplicate.

2 In the Settings window for 1D Plot Group, click to expand the Title section.

3 From the Title type list, choose Manual.

4 In the Title text area, type Concentration, measurement point.

5 Locate the Plot Settings section. In the y-axis label text field, type c<sub>mp</sub> 
(mol/m<sup>3</sup>).

6 In the Model Builder window, expand the 1D Plot Group 6 node, then click Global 1.

7 In the Settings window for Global, click Replace Expression in the upper-right corner of 
the y-axis data section. From the menu, choose Model>Component 1>Definitions>c_mp 

- Probe variable c_mp.

8 On the 1D Plot Group 6 toolbar, click Plot.

The resulting plot should look like that in the lower panel of Figure 3.
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Introduction

The free meshing algorithm using tetrahedral elements is the most general meshing 
technique, and does not pose any constraints on the structure of the geometry. Hence you 
can use it to mesh any object. There are nine predefined parameter sets for the mesher, 
ranging from “extremely fine” to “extremely coarse.” These settings result in a good mesh 
for most geometries and simulation problems. In addition you can tune the mesh 
parameters individually, as demonstrated in this tutorial.

Model Definition

Create a tetrahedral mesh for the geometry of an engine piston as shown in the following 
figure.

As you can see the geometry contains small details such as fillets and chamfers. To better 
resolve these details with the mesh you will work with the following mesh parameters:

• Minimum element size

• Curvature factor

• Resolution of narrow regions

• Maximum element growth rate

You will also learn how to use the tools for assessing the mesh quality.
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Application Library path: COMSOL_Multiphysics/Meshing_Tutorials/
piston_mesh

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

Click Done.

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
piston_quarter.mphbin.

5 Click Import.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.
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2 In the Settings window for Mesh, click Build All.

The Messages window indicates that there are roughly 23,000 tetrahedral elements in 
this mesh.

Assume that the current mesh does not resolve details such as fillets and chamfers 
sufficiently for your simulation needs and a finer parameter setting is required. This 
would be the case for a stress analysis of the part.

3 Locate the Mesh Settings section. From the Element size list, choose Finer.
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4 Click Build All.

This mesh consists of approximately 320,000 elements. Many of the finer details of the 
geometry are adequately resolved, but there is a significant increase in the total number 
of elements compared to the Normal mesh setting.

In the following you will test how to tune mesh parameters to refine the mesh only on 
selected boundaries.

M E S H  S T A T I S T I C S

Continue with examining the quality of the mesh.
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1 Right-click Component 1 (comp1)>Mesh 1 and choose Statistics.

The Statistics window contains details about the mesh, including the number and type 
of elements, and a histogram of element quality.

The element quality has a value between 0 and 1, where 1 describes a perfectly 
symmetric element and 0 describes a degenerated, or completely flat, element. For 3D 
meshes in general a minimum quality of about 0.1 means a satisfactory mesh.

However, this depends on the type of geometry and physics application. Note also that 
the quality number is calculated based on the linear elements.

Meshing with predefined parameter sets usually results in a mesh with quite good 
quality. According to the information under the section Domain element statistics, the 
present mesh has an average quality of 0.72 with a minimum quality of 0.12.

The histogram reveals the element quality distribution. In this case, the elements with 
low quality, represented by the tail of the distribution plot, represent a very small 
fraction of the mesh.

Before adjusting individual mesh parameters start by restoring the mesh with the 
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normal size settings.

2 Right-click Component 1 (comp1)>Mesh 1 and choose Settings.

3 In the Model Builder window, click Mesh 1.

4 In the Settings window for Mesh, locate the Mesh Settings section.

5 From the Element size list, choose Normal.

6 Click Build All.

M E S H I N G  S E Q U E N C E

1 Right-click Mesh 1 and choose Edit Physics-Induced Sequence.

You can now access and modify the default meshing sequence that appears under the 
Mesh 1 node.

The first Size feature node in the meshing sequence is a global attribute node, since it 
influences all subsequent operation nodes in the meshing sequence. This first Size node 
cannot be deleted from the sequence.

Instead of editing parameters of the global Size node add a Size node to the Free 
Tetrahedral 1 mesh operation.

Free Tetrahedral 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 

Tetrahedral 1 and choose Size.

The Size 1 node is a local attribute node because it only applies to its parent mesh node.

R E S O L U T I O N  O F  C U R V A T U R E

Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.
7 |  F R E E  TE T R A H E D R A L  M E S H I N G  O F  A  P I S T O N  G E O M E T R Y



3 Select the boundary highlighted in the figure below (Boundary 39).

By selecting only one of the fillets you can save time generating the mesh while testing 
parameter values. You will be able to change the selection of the Size 1 node to all 
boundaries after you have found the right set of parameters.

4 In the Model Builder window, click Size 1.

5 In the Settings window for Size, locate the Element Size section.

6 Click the Custom button.

7 Locate the Element Size Parameters section. Select the Curvature factor check box.

8 In the associated text field, type 0.2.

The Curvature factor parameter determines the size of boundary elements compared to 
the curvature of the geometric boundary. The curvature radius multiplied by the 
curvature factor gives the maximum allowed element size along the boundary. A lower 
value gives a finer mesh along curved boundaries.

Boundary 39
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9 Click Build All.

Zoom in on the selected boundary for a closer look at the mesh.

It seems that reducing the resolution of curvature had almost no effect on the number of 
mesh elements on the fillet. The reason is that another mesh parameter limits the 
minimum element size allowed in the mesh.

M I N I M U M  E L E M E N T  S I Z E

1 In the Model Builder window, under Component 1 (comp 1)> Mesh 1> Free Tetrahedral 1 
click Size 1.

2 In the Size settings window, locate the Element Size Parameters section.

3 Select the Minimum element size check box.

4 In the associated text field, type 0.0002.

The value in the Minimum element size field specifies the minimum allowed element size. 
You can use this value to, for example, prevent the generation of many elements around 
small curved parts of the geometry.
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5 Click Build All.

This time the selected boundary has a much finer mesh. Adjust the mesh again by 
increasing the resolution of curvature.

6 In the Settings window for Size, locate the Element Size Parameters section.

7 In the Curvature factor text field, type 0.45.

8 Click Build All.
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Now assume that you also want a better resolution of narrow regions with no curvature 
such as chamfers.

R E S O L U T I O N  O F  N A R R O W  R E G I O N S

1 Add the face highlighted below to the selection. The selection should now contain both 
boundaries 8 and 39.

2 In the Settings window for Size, locate the Element Size Parameters section.

3 Select the Resolution of narrow regions check box.

4 In the associated text field, type 2.

The Resolution of narrow regions mesh parameter controls the number of element layers 
that are created in narrow regions (approximately). If the value of this parameter is less 
than one, the mesh generator might create elements that are anisotropic in size in 
narrow regions.

Narrow
region

Boundary 8
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5 Click Build All.

Assume that you are happy with the parameter settings for curved and narrow regions. 
Now apply these for all boundaries of the geometry.

6 Locate the Geometric Entity Selection section. From the Selection list, choose All 

boundaries.

7 Click Build All.
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8 Click the Go to Default 3D View button on the Graphics toolbar to get the view in the 
figure below.

The fine details of the geometry are resolved satisfactorily with this mesh of 
approximately 280,000 tetrahedral elements.

Continue with checking the mesh quality.
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9 In the Model Builder window, right-click Mesh 1 and choose Statistics.

Compared to the mesh with the Finer predefined mesh parameter set, the average 
quality is slightly less and the minimum quality is also lower. This is expected because 
the boundaries are finely meshed and the elements are growing toward the inner parts 
of the geometry according to the Normal parameter set specified in the global Size node. 
Allowing even higher element growth will reduce the number of elements further and 
will result in even lower element quality.

M A X I M U M  E L E M E N T  G R O W T H

Reduce the number of mesh elements further by specifying the rate of growth from the 
small elements on the surface to the larger elements inside.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.
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4 Locate the Element Size Parameters section. In the Maximum element growth rate text 
field, type 1.8.

The Maximum element growth rate parameter determines the maximum rate at which 
the element size can grow from a region with small elements to a region with larger 
elements.

5 In the Model Builder window, click Mesh 1.

6 In the Settings window for Mesh, click Build All.

The mesh now consists of approximately 170,000 elements while keeping the fine mesh 
on curved and narrow boundaries.
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7 Right-click Mesh 1 and choose Statistics.

As expected the increase of the growth rate parameter results in even lower quality. The 
histogram reveals that the distribution has a ?thicker tail?, with the low quality elements 
making up a larger than before fraction of the total element number.

A mesh plot can help with localizing the worst quality elements.

M E S H  P L O T

On the Mesh toolbar, click Plot.

3D Plot Group 1
The Mesh 1 plot is added to the 3D Plot Group 1 under the Results section of the Model 

Builder window. The default mesh plot that appears in the Graphics window contains the 
surface elements colored according to quality.

1 In the Model Builder window, under Results>3D Plot Group 1 click Mesh 1.

2 In the Settings window for Mesh, click to expand the Element filter section.

3 Locate the Element Filter section. Select the Enable filter check box.
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4 From the Criterion list, choose Worst quality.

5 In the Fraction text field, type 0.005.

6 Locate the Level section. From the Level list, choose Volume.

7 In the Model Builder window, click 3D Plot Group 1.

8 In the Settings window for 3D Plot Group, locate the Color Legend section.

9 Select the Show maximum and minimum values check box.

10 On the 3D Plot Group 1 toolbar, click Plot.

You can now see 0.5% of the tetrahedral elements with the worst quality. These are 
mostly located in the regions where the elements are growing from the surfaces toward 
the inside of the geometry.
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Introduction

Just like optical lenses focus light, electric and magnetic lenses can focus beams of charged 
particles. Systems of magnetic quadrupole lenses find a common use in focusing both ion 
and particle beams in accelerators at nuclear and particle physics centers such as CERN, 
SLAC, and ISIS. This COMSOL Multiphysics model shows the path of B5+ ions going 
through three consecutive magnetic quadrupole lenses. The model is set up in a cross 
section of the geometry.

Model Definition

The quadrupole consists of an assembly of four permanent magnets, as seen in Figure 1 
below, where the magnets work together to give a good approximation of a quadrupole 
field. To strengthen the field and keep it contained within the system, the magnets are set 
in an iron cylinder.

Figure 1: Cross-sectional view of one of the magnetic quadrupoles used in the lens.

The ions are sent through a system of three consecutive quadrupole assemblies. The 
middle one is twice as long as the other ones, and is rotated by 90 degrees around the 
central axis. This means the polarity of its magnets is reversed. Figure 2 gives a full view of 

M
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the magnetic quadrupole lens.

Figure 2: Cutout of the quadrupole lens. The second quadrupole (Q2) has its polarities reversed 
compared to Q1 and Q3. After traveling through the lens, the ions are left to drift 1 m.

An accelerator feeds the system with ions traveling with the velocity 0.01 c along the 
central axis. To study the focusing effect of the quadrupoles, track a number of ions 
starting out from a distance of 3 cm from the central axis, evenly distributed along the 
circumference of a circle in the transverse plane. They are all assumed to have a zero initial 
transverse velocity. Each quadrupole focuses the ion beam along one of the transverse axes 
and defocuses it along the other one. The net effect after traveling through the system of 
the three quadrupoles and the drift length is focusing in all directions. As the ions exit the 
system, they are all contained within a 1 cm radius in the transverse plane.

The model is set up in a 2D cross section of any of the two identical quadrupoles Q1 and 
Q3. Neglecting fringe fields, the transverse magnetic field at a given point in a transverse 
plane in Q2 automatically has the same magnitude as the corresponding in Q1 and Q3, 
but point in the opposite direction. It is therefore sufficient to model the fields in one of 
the quadrupoles.

D O M A I N  E Q U A T I O N S

The magnetic field is described using the Magnetostatics equation, solving for the z 
component of the magnetic potential A (Wb/m):

Here μ0 = 4π·10−7 H/m denotes the permeability of vacuum, M is the magnetization (A/
m), σ the conductivity (S/m), and v the velocity of the medium (m/s). In this example, 
the medium is not moving. The right-hand side of the equation holds an imposed current, 

Q1 (1 m)

Q2 (2 m)

Q3 (1 m)

Drift (1 m)

∇ μ0
1– ∇ Az× M–( )( )× σv ∇ Az×( )×– Jz

e
=

3 |  Q U A D R U P O L E  L E N S



specified in terms of an external current density Jz
e (A/m2). No currents are imposed. 

The iron domain uses a slightly different formulation of the same equation:

where μr = 4000 is the relative permeability. The magnetic potential is everywhere defined 
so that B = ∇ × A.

B O U N D A R Y  C O N D I T I O N S

The magnetic field is approximately parallel to the exterior boundary of the iron cylinder. 
To enforce this, use the magnetic insulation boundary condition, stating that Az = 0.

Results and Discussion

The magnetic field density and streamlines in a cross section of Q1 or Q3 appear in 
Figure 3 below.

Figure 3: The magnetic field density and flow lines in the center of one of the quadrupole 
magnets.

Each ion passing through the assembly experiences a Maxwell force equal to F = qv × B, 
where v (m/s) is the ion’s velocity. Next, assume that the z component of the velocity is 

∇ 1
μ0μr
------------∇ Az×× 

  σ v ∇ Az×( )×– Jz
e

=
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constant and much larger than the x and y (transverse) components. Thus consider only 
the force contributions from the z component of the velocity. To find the transverse 
position as a function of time, you need to solve Newton’s second law for each ion, 
qv × B = ma, where m is the ion mass (kg), and a denotes its acceleration (m/s2). If the 
computed magnetic flux density in Q1 equals B', and the length of quadrupole i is Li (m), 
the flux density that the ion experiences is given by

B

B' if  t
L1
vz
------<

B– ' if  
L1
vz
------ t

L1 L2+

vz
--------------------< <

B' if  
L1 L2+

vz
-------------------- t

L1 L2 L3+ +

vz
---------------------------------< <

0 if  t
L1 L2 L3+ +

vz
--------------------------------->

















=
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where t (s) is the time of flight. This dependency of the magnetic flux density on the time 
of flight is fed to the particle-tracing algorithm as a logical expression. Figure 4 below 
shows how the ions travel in the transverse plane.

Figure 4: As the ions enter Q1, they start out evenly distributed around the larger circle, 3 cm 
from the z-axis. Q1 focuses along the x-axis and defocuses along the y-axis. The force on each 
ion is approximately proportional to its distance from the z-axis, so as the ions enter Q2, those 
that are far out on the x-axis rapidly turn around and move toward the center. Q3 stabilizes 
the motion and gets all ions on the right track. Finally the ions are left to drift toward a waist 
situated a little bit more than 1 m beyond Q3.

Application Library path: COMSOL_Multiphysics/Electromagnetics/quadrupole

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select AC/DC>Magnetic Fields (mf).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Here, c_const, mp_const and e_const are predefined constants for, respectively, the 
speed of light, the mass of the proton and the elementary charge.

G E O M E T R Y  1

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

Name Expression Value Description

M 11 11 Ion mass number

Z 5 5 Ion charge number

L1 1[m] 1 m Length of first 
quadrupole

L2 2[m] 2 m Length of second 
quadrupole

L3 1[m] 1 m Length of third 
quadrupole

vz 0.01*c_const 2.9979E6 m/s Ion velocity

m M*mp_const 1.8399E-26 kg Ion mass

q Z*e_const 8.0109E-19 C Ion charge

MQ 5.8e3[A/m] 5800 A/m Quadrupole 
magnetization
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3 In the Width text field, type 0.177.

4 In the Height text field, type 0.07.

5 Locate the Position section. In the x text field, type 0.

6 In the y text field, type -0.035.

Rotate 1 (rot1)
1 Right-click Rectangle 1 (r1) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Rotate.

3 Select the object r1 only.

4 In the Settings window for Rotate, locate the Rotation Angle section.

5 In the Rotation text field, type 45.

6 Right-click Rotate 1 (rot1) and choose Build Selected.

7 Click the Zoom Extents button on the Graphics toolbar.

Circle 1 (c1)
1 On the Geometry toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type 0.2.

4 Locate the Position section. In the x text field, type 0.2.

5 In the y text field, type 0.2.

6 Right-click Circle 1 (c1) and choose Build Selected.

7 Click the Zoom Extents button on the Graphics toolbar.

Intersection 1 (int1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Intersection.

2 Click in the Graphics window and then press Ctrl+A to select both objects.

Rotate 2 (rot2)
1 Right-click Intersection 1 (int1) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Rotate.

3 Select the object int1 only.

4 In the Settings window for Rotate, locate the Rotation Angle section.

5 In the Rotation text field, type 90, 180, 270.

6 Locate the Input section. Select the Keep input objects check box.

7 Right-click Rotate 2 (rot2) and choose Build Selected.
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8 Click the Zoom Extents button on the Graphics toolbar.

Now make two circles centered at the origin.

Circle 2 (c2)
1 On the Geometry toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type 0.2.

4 Right-click Circle 2 (c2) and choose Build Selected.

5 Click the Zoom Extents button on the Graphics toolbar.

Circle 3 (c3)
1 On the Geometry toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type 0.12.

4 Right-click Circle 3 (c3) and choose Build Selected.

Create a composite object subtracting the magnets from the union of the two circles. This 
complex operation can be done in one step by using the Compose geometry operation and 
specifying the formula.
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Compose 1 (co1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Compose.

2 Click in the Graphics window and then press Ctrl+A to select all objects.

3 In the Settings window for Compose, locate the Compose section.

4 In the Set formula text field, type c2+c3-(int1+rot2(1)+rot2(2)+rot2(3)).

5 Right-click Compose 1 (co1) and choose Build Selected.

Make one more circle centered at the origin.

Circle 4 (c4)
1 On the Geometry toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type 0.2.

4 Right-click Circle 4 (c4) and choose Build Selected.

5 Click the Zoom Extents button on the Graphics toolbar.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.
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3 In the tree, select Built-In>Iron.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

M A T E R I A L S

Iron (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Iron (mat1).

2 Select Domain 2 only.

M A G N E T I C  F I E L D S  ( M F )

Use the default condition, Magnetic insulation, on all exterior boundaries.

Ampère’s Law 2
1 On the Physics toolbar, click Domains and choose Ampère’s Law.

2 Select Domain 6 only.

3 In the Settings window for Ampère’s Law, locate the Magnetic Field section.

4 From the Constitutive relation list, choose Magnetization.

5 Specify the M vector as

6 Locate the Conduction Current section. From the σ list, choose User defined. Locate the 
Electric Field section. From the εr list, choose User defined.

Ampère’s Law 3
1 On the Physics toolbar, click Domains and choose Ampère’s Law.

2 Select Domain 3 only.

3 In the Settings window for Ampère’s Law, locate the Magnetic Field section.

4 From the Constitutive relation list, choose Magnetization.

5 Specify the M vector as

-MQ/sqrt(2) x

-MQ/sqrt(2) y

0 z

-MQ/sqrt(2) x

MQ/sqrt(2) y

0 z
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6 Locate the Conduction Current section. From the σ list, choose User defined. Locate the 
Electric Field section. From the εr list, choose User defined.

Ampère’s Law 4
1 On the Physics toolbar, click Domains and choose Ampère’s Law.

2 Select Domain 1 only.

3 In the Settings window for Ampère’s Law, locate the Magnetic Field section.

4 From the Constitutive relation list, choose Magnetization.

5 Specify the M vector as

6 Locate the Conduction Current section. From the σ list, choose User defined. Locate the 
Electric Field section. From the εr list, choose User defined.

Ampère’s Law 5
1 On the Physics toolbar, click Domains and choose Ampère’s Law.

2 Select Domain 5 only.

3 In the Settings window for Ampère’s Law, locate the Magnetic Field section.

4 From the Constitutive relation list, choose Magnetization.

5 Specify the M vector as

6 Locate the Conduction Current section. From the σ list, choose User defined. Locate the 
Electric Field section. From the εr list, choose User defined.

Ampère’s Law 6
1 On the Physics toolbar, click Domains and choose Ampère’s Law.

2 Select Domain 4 only.

3 In the Settings window for Ampère’s Law, locate the Magnetic Field section.

4 From the μr list, choose User defined. Locate the Conduction Current section. From the 
σ list, choose User defined. Locate the Electric Field section. From the εr list, choose User 

defined.

MQ/sqrt(2) x

MQ/sqrt(2) y

0 z

MQ/sqrt(2) x

-MQ/sqrt(2) y

0 z
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M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Extra fine.

4 Click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Magnetic Flux Density Norm (mf)
The default plot shows the norm of the magnetic flux density. Follow the instructions 
below to view the magnetic field.

Surface 1
1 In the Model Builder window, expand the Magnetic Flux Density Norm (mf) node, then 

click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Magnetic Fields>

Magnetic>mf.normH - Magnetic field norm.
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3 On the Magnetic Flux Density Norm (mf) toolbar, click Plot.

Magnetic Flux Density Norm (mf)
In the Model Builder window, under Results right-click Magnetic Flux Density Norm (mf) and 
choose Contour.

Contour 1
1 In the Settings window for Contour, click Replace Expression in the upper-right corner 

of the Expression section. From the menu, choose Model>Component 1>Magnetic Fields>

Magnetic>Magnetic vector potential>Az - Magnetic vector potential, z component.

2 On the Magnetic Flux Density Norm (mf) toolbar, click Plot.

3 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

4 From the Color list, choose White.

5 Clear the Color legend check box.

6 Click the Zoom Extents button on the Graphics toolbar.

To see how the ions travel through the system of quadrupoles, do the following:

2D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Ions Trajectories in the Label text 
field.

Surface 1
1 Right-click Ions Trajectories and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Magnetic Fields>

Magnetic>mf.normH - Magnetic field norm.

3 Locate the Coloring and Style section. From the Color table list, choose Thermal.

Ions Trajectories
In the Model Builder window, under Results click Ions Trajectories.

Particle Tracing with Mass 1
1 On the Ions Trajectories toolbar, click More Plots and choose Particle Tracing with Mass.

Enter the expressions for the Lorentz force acting on the particles.

The position of the particle along the z-axis can be computed using the particle time 
variable partt.

2 In the Settings window for Particle Tracing with Mass, locate the Total Force section.
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3 In the Fx text field, type -q*vz*mf.By*(1-2*(partt>L1/vz)+2*(partt>(L1+L2)/
vz)-(partt>(L1+L2+L3)/vz)).

4 In the Fy text field, type q*vz*mf.Bx*(1-2*(partt>L1/vz)+2*(partt>(L1+L2)/
vz)-(partt>(L1+L2+L3)/vz)).

5 Click to expand the Mass and velocity section. Locate the Mass and Velocity section. In 
the Mass text field, type m.

6 Locate the Particle Positioning section. In the x text field, type 0.03*cos(range(0,
0.05*pi,2*pi)).

7 In the y text field, type 0.03*sin(range(0,0.05*pi,2*pi)).

Color Expression 1
1 Right-click Particle Tracing with Mass 1 and choose Color Expression.

2 In the Settings window for Color Expression, locate the Expression section.

3 In the Expression text field, type 1+(partt>L1/vz)+(partt>(L1+L2)/vz)+(partt>
(L1+L2+L3)/vz).

4 Locate the Coloring and Style section. From the Color table list, choose Cyclic.

Particle Tracing with Mass 1
1 In the Model Builder window, under Results>Ions Trajectories click Particle Tracing with 

Mass 1.

2 In the Settings window for Particle Tracing with Mass, click to expand the Release 
section.

3 Click to expand the Coloring and style section. Click to expand the Quality section. Find 
the ODE solver settings subsection. In the Relative tolerance text field, type 1e-6.

4 Click to expand the Advanced section. Find the Termination subsection. Select the 
Maximum number of steps check box.

5 In the associated text field, type 1e5.

6 Find the Instantaneous flow field subsection. Select the End time check box.

7 In the associated text field, type 5/3e6.

8 On the Ions Trajectories toolbar, click Plot.

Ions Trajectories
In the Model Builder window, under Results right-click Ions Trajectories and choose Contour.

Contour 1
1 In the Settings window for Contour, locate the Expression section.

2 In the Expression text field, type sqrt(x^2+y^2).
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3 Locate the Levels section. From the Entry method list, choose Levels.

4 In the Levels text field, type 0.01 0.03.

5 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

6 From the Color list, choose Custom.

7 Clear the Color legend check box.

8 On the Ions Trajectories toolbar, click Plot.

Zoom in on the center of the model geometry.
16 |  Q U A D R U P O L E  L E N S



Created in COMSOL Multiphysics 5.2a
S ubmode l i n g  o f  a  S h a f t
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


Introduction

Submodeling can be used when it is not possible to resolve all details of a complex 
geometry in a global model.

You can cope with this type of problems with a technique known as submodeling. First you 
solve the complete model with a mesh which is sufficient to capture the stiffness of the 
structure. In a second analysis you create a local model (submodel) of the region around 
the stress concentration with a fine mesh, and solve it using the displacements from the 
global model as boundary conditions.

There are some underlying assumptions when using submodels:

• The global model is accurate enough to give correct displacements on the boundary to 
the submodel.

• The improvements introduced in the submodel are so small that they do not introduce 
significant changes in stiffness on the global level. Given this, it could still be possible 
to introduce a nonlinear material locally in the submodel.

In this example this technique is applied to perform an accurate stress evaluation in a 
structural mechanics model, but the same approach is applicable to many physical 
problems. The example geometry as such is not so complicated, so there is nothing to gain 
from a submodeling in this case. The purpose of the example is to show the technique.

Model Definition

The geometry consists of a shaft with a sudden change in diameter. At the location of the 
diameter change, there is a fillet with a small radius. In the fillet, stress concentrations will 
appear. There is also a central hole through the shaft. The geometry and mesh are shown 
in Figure 1.

The shaft is fixed at the thick end. On the thin end, a tensile force of 300 N and a shear 
force of 100 N are applied.
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Figure 1: The full model.

As submodel, a region around the fillet at side giving the highest stress is chosen. The cuts 
where the boundary conditions are applied on the submodel should preferably be placed 
at locations where the stress field is fairly smooth.

The geometry and mesh of the submodel are shown in Figure 2. As can be seen, the fillet 
has a very good mesh resolution since the purpose is to obtain results with high accuracy 
there.
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Figure 2: The submodel.

Results

The general stress distribution is shown in Figure 3. Since the load is unsymmetrical (there 
is both an axial and a bending component), the highest stress occurs at the side with 
positive Z coordinate.

The cut through the model in Figure 4 displays that the stresses are not well resolved. 
There are significant jumps between the neighboring elements.

In the corresponding figures from the submodel, Figure 5 and Figure 6, the stress field is 
smooth and well resolved. 

The computed peak stress for the global model is about 9% different compared to that in 
the submodel, which is expected given the coarse mesh in the global model.
4 |  S U B M O D E L I N G  O F  A  S H A F T



Figure 3: Stress distribution in the global model.

Figure 4: Stress within the full model (cut view).
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Figure 5: Stress distribution in the submodel.

Figure 6: Stress within the submodel (cut view).
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As a verification, it is a good habit to always check the stress state at the cuts where the 
submodel has displacements prescribed by the results in the global model. Such a 
comparison is shown in Figure 7. The results have an almost perfect match, which strongly 
indicates that the submodel has been set up correctly.

Figure 7: Stress distribution over one of the cuts. Global model (left) and submodel (right) are 
compared.

Notes About the COMSOL Implementation

Two different components are used within the same mph file. In the global model, a 
general extrusion feature is introduced in order to describe the mapping of results from 
the global model to the submodel. The prescribed displacements on the cut boundaries in 
the submodel reference the displacements in the global model through this mapping.

In this example, there are no volume forces. If there were, such forces must be applied also 
on the submodel.
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Application Library path: COMSOL_Multiphysics/Structural_Mechanics/
shaft_submodeling

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

C O M P O N E N T  1  ( C O M P 1 )

1 In the Model Builder window, click Component 1 (comp1).

2 In the Settings window for Component, type Full model in the Label text field.

G E O M E T R Y  1

1 In the Model Builder window, under Full model (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
shaft_submodeling.mphbin.

5 Click Import.
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A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Structural steel.

4 Click Add to Global Materials.

The material is now defined as global material so that both the full model and the 
submodel can use the same material definition, defined at one location only in the 
model tree.

M A T E R I A L S

In the Model Builder window, under Full model (comp1) right-click Materials and choose 
Material Link.

S O L I D  M E C H A N I C S  ( S O L I D )

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundary 27 only.

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundary 1 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 From the Load type list, choose Total force.

5 Specify the Ftot vector as

M E S H  1

1 In the Model Builder window, under Full model (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Coarse.

4 Click Build All.

5 Click the Zoom Extents button on the Graphics toolbar.

-300 x

0 y

-100 z
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S T U D Y  1

1 In the Settings window for Study, type Full model in the Label text field.

2 On the Home toolbar, click Compute.

R E S U L T S

Stress (solid)
1 In the Model Builder window, under Results click Stress (solid).

2 In the Settings window for 3D Plot Group, type Stress - Full model in the Label 
text field.

3 Click to expand the Color legend section. Locate the Color Legend section. Select the 
Show maximum and minimum values check box.

Surface 1
1 In the Model Builder window, expand the Results>Stress - Full model node, then click 

Surface 1.

2 In the Settings window for Surface, click to expand the Quality section.

3 From the Resolution list, choose No refinement.

4 From the Smoothing list, choose None.

5 On the Stress - Full model toolbar, click Plot.

6 Click the Zoom Extents button on the Graphics toolbar.

Cut Plane 1
1 On the Results toolbar, click Cut Plane.

2 In the Settings window for Cut Plane, locate the Plane Data section.

3 From the Plane list, choose XZ-planes.

2D Plot Group 2
1 On the Results toolbar, click 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Cut Plane Stress -Full model in 
the Label text field.

3 Click to expand the Color legend section. Locate the Color Legend section. Select the 
Show maximum and minimum values check box.

Surface 1
1 Right-click Cut Plane Stress -Full model and choose Surface.

2 In the Settings window for Surface, locate the Expression section.
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3 In the Expression text field, type solid.mises.

4 Click to expand the Quality section. From the Resolution list, choose No refinement.

5 From the Smoothing list, choose None.

6 On the Cut Plane Stress -Full model toolbar, click Plot.

7 In the Model Builder window, expand the Results>Views node.

Axis
1 In the Model Builder window, expand the Results>Views>View 2D 2 node, then click Axis.

2 In the Settings window for Axis, locate the Axis section.

3 In the x minimum text field, type 25.8.

4 In the x maximum text field, type 34.2.

5 In the y minimum text field, type 1.5.

6 In the y maximum text field, type 7.5.

7 Click Update.

R O O T

On the Home toolbar, click Add Component and choose 3D.

C O M P O N E N T  2  ( C O M P 2 )

1 In the Model Builder window, click Component 2 (comp2).

2 In the Settings window for Component, type Submodel in the Label text field.

G E O M E T R Y  2

1 In the Model Builder window, under Submodel (comp2) click Geometry 2.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
shaft_submodeling.mphbin.

5 Click Import.
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Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type 7.

4 In the Height text field, type 8.

5 Locate the Position section. In the x text field, type 26.

6 Locate the Axis section. From the Axis type list, choose x-axis.

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 10.

4 In the Depth text field, type 14.

5 In the Height text field, type 10.

6 Locate the Position section. In the x text field, type 26.

7 In the y text field, type -7.

Intersection 1 (int1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Intersection.

2 Click in the Graphics window and then press Ctrl+A to select all objects.

3 In the Settings window for Intersection, click Build All Objects.

Ignore Edges 1 (ige1)
1 On the Geometry toolbar, click Virtual Operations and choose Ignore Edges.

2 On the object fin, select Edges 7, 9, 16, and 21 only.

3 Right-click Ignore Edges 1 (ige1) and choose Build Selected.

M A T E R I A L S

In the Model Builder window, under Submodel (comp2) right-click Materials and choose 
Material Link.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Structural Mechanics>Solid Mechanics (solid).
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4 Find the Physics interfaces in study subsection. In the table, enter the following settings:

5 Click Add to Component in the window toolbar.

D E F I N I T I O N S

In the Model Builder window, under Full model (comp1) click Definitions.

General Extrusion 1 (genext1)
1 On the Definitions toolbar, click Component Couplings and choose General Extrusion.

2 Select Domain 1 only.

3 In the Settings window for General Extrusion, locate the Destination Map section.

4 In the x-expression text field, type X.

5 In the y-expression text field, type Y.

6 In the z-expression text field, type Z.

7 Locate the Source section. From the Source frame list, choose Material  (X, Y, Z).

You have now created the coupling operator which will be used for mapping the 
solution from the full model to the submodel.

S O L I D  M E C H A N I C S  2  ( S O L I D 2 )

In the Model Builder window, under Submodel (comp2) click Solid Mechanics 2 (solid2).

Prescribed Displacement 1
1 On the Physics toolbar, click Boundaries and choose Prescribed Displacement.

2 Select Boundaries 1, 2, 5, 7, and 8 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in x direction check box.

5 In the u0x text field, type comp1.genext1(comp1.u).

6 Select the Prescribed in y direction check box.

7 In the u0y text field, type comp1.genext1(comp1.v).

8 Select the Prescribed in z direction check box.

9 In the u0z text field, type comp1.genext1(comp1.w).

Studies Solve

Full model √
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F U L L  M O D E L  ( C O M P 1 )

In the Model Builder window, expand the Full model (comp1) node.

M E S H  2

In the Model Builder window, expand the Full model (comp1)>Definitions node.

Mapped 1
1 Right-click Submodel (comp2)>Mesh 2 and choose More Operations>Mapped.

2 Select Boundary 2 only.

Distribution 1
1 Right-click Submodel (comp2)>Mesh 2>Mapped 1 and choose Distribution.

2 Select Edge 3 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 From the Distribution properties list, choose Predefined distribution type.

5 In the Number of elements text field, type 6.

6 In the Element ratio text field, type 3.

7 Select the Reverse direction check box.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 2
1 Select Edge 1 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 From the Distribution properties list, choose Predefined distribution type.

4 In the Number of elements text field, type 6.

5 In the Element ratio text field, type 3.

6 Select the Reverse direction check box.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 3
1 Select Edge 18 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 6.
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Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 4
1 Select Edge 10 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 From the Distribution properties list, choose Predefined distribution type.

4 In the Number of elements text field, type 10.

5 In the Element ratio text field, type 2.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 5
1 Select Edge 13 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 From the Distribution properties list, choose Predefined distribution type.

4 In the Number of elements text field, type 6.

5 In the Element ratio text field, type 3.

Swept 1
1 In the Model Builder window, right-click Mesh 2 and choose Swept.

2 In the Settings window for Swept, click to expand the Destination faces section.

3 Select Boundary 2 only.

4 Locate the Destination Faces section. Click Clear Selection.

5 Select Boundary 5 only.

6 Click to expand the Source faces section. Select Boundary 2 only.

Distribution 1
1 In the Model Builder window, right-click Swept 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 24.

4 Click Build All.

5 In the Settings window for Mesh, click Build All.

6 Click the Zoom Extents button on the Graphics toolbar.
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A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Solid Mechanics (solid) interface.

5 Click Add Study in the window toolbar.

S T U D Y  2

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Submodel in the Label text field.

S U B M O D E L

Step 1: Stationary
1 In the Model Builder window, under Submodel click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Values of dependent variables 
section.

3 Locate the Values of Dependent Variables section. Find the Values of variables not solved 

for subsection. From the Settings list, choose User controlled.

4 From the Method list, choose Solution.

5 From the Study list, choose Full model, Stationary.

6 On the Home toolbar, click Compute.

R E S U L T S

Stress (solid2)
1 In the Model Builder window, under Results click Stress (solid2).

2 In the Settings window for 3D Plot Group, type Stress - Submodel in the Label text 
field.

3 Locate the Color Legend section. Select the Show maximum and minimum values check 
box.

Surface 1
1 In the Model Builder window, expand the Results>Stress - Submodel node, then click 

Surface 1.

2 In the Settings window for Surface, click to expand the Quality section.
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3 From the Resolution list, choose No refinement.

4 From the Smoothing list, choose None.

5 On the Stress - Submodel toolbar, click Plot.

6 Click the Zoom Extents button on the Graphics toolbar.

Cut Plane 2
1 On the Results toolbar, click Cut Plane.

2 In the Settings window for Cut Plane, locate the Plane Data section.

3 From the Plane list, choose XZ-planes.

4 Locate the Data section. From the Data set list, choose Submodel/Solution 2 (3) (sol2).

2D Plot Group 4
1 On the Results toolbar, click 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Cut Plane Stress - Submodel in 
the Label text field.

3 Locate the Color Legend section. Select the Show maximum and minimum values check 
box.

4 Locate the Data section. From the Data set list, choose Cut Plane 2.

Surface 1
1 Right-click Cut Plane Stress - Submodel and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type solid2.mises.

4 Click to expand the Quality section. From the Resolution list, choose No refinement.

5 From the Smoothing list, choose None.

6 On the Cut Plane Stress - Submodel toolbar, click Plot.

7 Click the Zoom Extents button on the Graphics toolbar.

Now verify that the differences in stress between the full model and the submodel are small 
where the displacements are mapped.

Cut Plane 3
1 On the Results toolbar, click Cut Plane.

2 In the Settings window for Cut Plane, locate the Plane Data section.

3 In the X-coordinate text field, type 26.
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2D Plot Group 5
1 On the Results toolbar, click 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Stress comparison in the Label text 
field.

3 Locate the Data section. From the Data set list, choose None.

Surface 1
1 Right-click Stress comparison and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Data set list, choose Cut Plane 3.

4 Locate the Expression section. In the Expression text field, type solid.mises.

5 Locate the Quality section. From the Resolution list, choose No refinement.

6 From the Smoothing list, choose None.

7 On the Stress comparison toolbar, click Plot.

Data Sets
In the Model Builder window, under Results click Data Sets.

Surface 1
1 On the Results toolbar, click More Data Sets and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Data set list, choose Submodel/Solution 2 (3) (sol2).

4 Select Boundary 1 only.

5 Locate the Parameterization section. From the x- and y-axes list, choose YZ-plane.

Stress comparison
In the Model Builder window, under Results right-click Stress comparison and choose 
Surface.

Surface 2
1 In the Settings window for Surface, locate the Data section.

2 From the Data set list, choose Surface 1.

3 Locate the Expression section. In the Expression text field, type solid2.mises.

4 Locate the Quality section. From the Resolution list, choose No refinement.

5 From the Smoothing list, choose None.

6 Click to expand the Inherit style section. Locate the Inherit Style section. From the Plot 
list, choose Surface 1.
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Deformation 1
1 Right-click Results>Stress comparison>Surface 2 and choose Deformation.

2 In the Settings window for Deformation, locate the Expression section.

3 In the x component text field, type 11.

4 In the y component text field, type 0.

5 Locate the Scale section. Select the Scale factor check box.

6 In the associated text field, type 1.

7 On the Stress comparison toolbar, click Plot.

8 Click the Zoom Extents button on the Graphics toolbar.

The solution is computed, follow the steps below if you want to save and reuse the model 
in the future.

F U L L  M O D E L

Step 1: Stationary
1 In the Model Builder window, under Full model click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 In the table, clear the Solve for check box for the Solid Mechanics 2 (solid 2) interface.
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Introduction

A goal for many applications is to predict physics in thin structures, such as shells, without 
modeling the thickness of the structure. This is because large aspect ratios can cause 
meshing and geometry analysis problems. The model reported here demonstrates how to 
use the tangential derivative variables in COMSOL Multiphysics to solve partial 
differential equations in curved 3D shells and 2D boundaries without modeling their 
thickness.

Model Definition

The steel tank shown below has two pipe connections. One is grounded and the other 
connects to a dead current source. This model calculates the current density in the tank 
shell along with the potential distribution across the surface.

E Q U A T I O N S

The fundamental equation to solve is the current conduction, or charge conservation, 
equation.

 (1)

Here, σ is the electrical conductivity (S/m) and V is the electric potential (V).

The material is a 1 mm thick steel sheet with a conductivity of 4.032·106 S/m. You are 
working with a surface in 3D so there is no thickness in the model. To account for the 
charge conservation in Equation 1 you must multiply the current flux expression with the 
shell thickness d:

 (2)

400 V

0 V

∇ σ ∇V–( )⋅ 0=

∇ σ d∇V–( )⋅ 0=
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Results

Figure 1 shows the potential distribution across the surface.

Figure 1: Electric potential distribution across the surface (V).

Figure 2 adds the current field as an arrow plot, showing clearly how the current collects 
toward the grounded connection.
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Figure 2: Arrow plot of the local current field.

Figure 3: Local magnitude of the electric current density (A/m2).
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The plot of the magnitude of the local current density in Figure 3 is interesting because 
you can use it to calculate the resistive heating in the material as an extension to the model.

Notes About the COMSOL Implementation

Model Equation 2, the current conduction equation, using a Coefficient Form Boundary 
PDE interface, setting the diffusion coefficient c = σd. To define the current field 
components use tangential derivative variables, which you access in COMSOL 
Multiphysics by adding a T suffix to the variable name before specifying the gradient 
component. So, for example, the tangential derivative (∂u/∂x)T is represented by the 
variable uTx.

Application Library path: COMSOL_Multiphysics/Equation_Based/
shell_diffusion

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Mathematics>PDE Interfaces>Lower Dimensions>

Coefficient Form Boundary PDE (cb).

3 Click Add.

4 In the Dependent variables table, enter the following settings:

5 Click Study.

6 In the Select Study tree, select Preset Studies>Stationary.

7 Click Done.

V
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G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Create the geometry. To simplify this step, insert a prepared geometry sequence.

1 On the Geometry toolbar, click Insert Sequence.

2 Browse to the application’s Application Libraries folder and double-click the file 
shell_diffusion_geom_sequence.mph.

3 On the Geometry toolbar, click Build All.

4 Click the Zoom Extents button on the Graphics toolbar.

C O E F F I C I E N T  F O R M  B O U N D A R Y  P D E  ( C B )

1 In the Model Builder window, under Component 1 (comp1) click Coefficient Form Boundary 

PDE (cb).

2 In the Settings window for Coefficient Form Boundary PDE, locate the Units section.

3 Find the Dependent variable quantity subsection. From the list, choose Electric potential 

(V).

4 Find the Source term quantity subsection. In the Unit text field, type A*m^-2.

Coefficient Form PDE 1
1 In the Model Builder window, expand the Coefficient Form Boundary PDE (cb) node, then 

click Coefficient Form PDE 1.

2 In the Settings window for Coefficient Form PDE, locate the Diffusion Coefficient 
section.

3 In the c text field, type sigma*d.

4 Locate the Source Term section. In the f text field, type 0.

These settings specify the charge conservation equation (Equation 2) for the shell 
surface.

Name Expression Value Description

sigma 4.032e6[S/m] 4.032E6 S/m Conductivity

d 1[mm] 0.001 m Shell thickness
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Go on to set the values of the potential at the pipe connections by adding Dirichlet 
boundary conditions.

Dirichlet Boundary Condition 1
1 On the Physics toolbar, click Edges and choose Dirichlet Boundary Condition.

2 Select Edges 14, 15, 25, and 29 only.

3 In the Settings window for Dirichlet Boundary Condition, locate the Dirichlet Boundary 

Condition section.

4 In the r text field, type 400.

Dirichlet Boundary Condition 2
1 On the Physics toolbar, click Edges and choose Dirichlet Boundary Condition.

2 Select Edges 40–43 only.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Finer.

4 Click Build All.
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S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

3D Plot Group 1
The default plot shows the potential distribution.

1 Click the Zoom Extents button on the Graphics toolbar.

Rotate the geometry so that you see both pipe connections. Compare the result with 
the plot in Figure 1.

Add an arrow surface plot of the current field as follows:

Arrow Surface 1
1 In the Model Builder window, right-click 3D Plot Group 1 and choose Arrow Surface.

2 In the Settings window for Arrow Surface, locate the Expression section.

3 In the x component text field, type -sigma*VTx.

4 In the y component text field, type -sigma*VTy.

5 In the z component text field, type -sigma*VTz.

6 Select the Description check box.

7 In the associated text field, type Current field (-sigma*VTx, -sigma*VTy, 
-sigma*VTz).

8 Locate the Coloring and Style section. From the Arrow length list, choose Normalized.

9 On the 3D Plot Group 1 toolbar, click Plot.

The plot in the Graphics window should now look like that in Figure 2.

To visualize the magnitude of the local current density, follow the steps given below.

3D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, click to expand the Title section.

3 From the Title type list, choose Manual.

4 In the Title text area, type Current density (A/m<sup>2</sup>).

Surface 1
1 Right-click 3D Plot Group 2 and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type sigma*sqrt(VTx^2+VTy^2+VTz^2).
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4 On the 3D Plot Group 2 toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.
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Introduction

This example, taken from a NAFEMS benchmark collection (Ref. 1), demonstrates how 
to apply and evaluate different boundary conditions acting on a cantilever beam. 

Model Definition

The cantilever beam has a thickness of 0.1 m, width of 4 m and is 4 m on its long edge 
and 2 m on its short edge. Two cases are considered. In the first one a gravity load, mg, 
acts in the negative y direction with an acceleration of 9.81 m/s2. The left end boundary 
is fully fixed (no displacements). In the second case gravity load is not present and instead 
a uniformly distributed horizontal load, F, of 10 MN/m acts along the right end. At the 
left end there is no displacement in the x direction. Also at a midpoint location the left end 
is fixed in the y direction; see Figure 1.

Figure 1: Schematic description of two load cases.

M A T E R I A L  M O D E L

The model uses the following material properties:

• The material is isotropic.

• The Young’s modulus (elasticity modulus) is 210 GPa.

• The Poisson ratio is 0.3.

• The density is 7000 kg/m3.

Results and Discussion

For the gravity case shear stress is evaluated. The benchmark target value of −0.200 MPa 
at the point (0, 2) is in good agreement with the model results. Using the default Normal 

mg

F
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mesh size, the COMSOL Multiphysics solution gives a value of −0.199 MPa; see Figure 2.

Figure 2: In plane shear stress due to gravity load.

For the load case, the horizontal (x direction) normal stress is evaluated. The benchmark 
target value of 61.3 MPa at the point (0, 2) is in good agreement with the results. Using 
the default mesh size, the COMSOL Multiphysics solution gives a value of 61.4 MPa; see 
Figure 3.
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Figure 3: Counteracting stress due to applied edge load.

Notes About the COMSOL Implementation

Use predefined variables for the acceleration of gravity and density to enter the gravity load 
as a force/volume. COMSOL then computes the load using the thickness of the 
geometry.

Use the Solid Mechanics interface to perform a stress analysis. The finite element model 
uses the default second-order triangular Lagrange elements. To show convergence toward 
the benchmark value, create a finer mesh.

Use the Load Group and Constraint Group features to collect conditions that are enabled 
in different studies. Define a group in Global Definitions and assign its content directly 
from the load or constraint itself. You define load cases in the Study Extensions of a Study 
Type and enable active load and constraint groups; see Figure 4, where lg denotes a load 
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group and cg denotes a constraint group. Weight is used as a multiplication factor for the 
corresponding load group.

Figure 4: Definition of load cases.

Reference

1. D. Hitchings, A. Kamoulakos, and G.A.O. Davies, Linear Statics Benchmarks Vol. 1, 
NAFEMS, Glasgow, 1987.

Application Library path: COMSOL_Multiphysics/Structural_Mechanics/
tapered_cantilever

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

Bézier Polygon 1 (b1)
1 On the Geometry toolbar, click Primitives and choose Bézier Polygon.
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2 In the Settings window for Bézier Polygon, locate the Polygon Segments section.

3 Find the Added segments subsection. Click Add Linear.

4 Find the Control points subsection. In row 2, set x to 4 and y to 1.

5 Find the Added segments subsection. Click Add Linear.

6 Find the Control points subsection. In row 2, set y to 3.

7 Find the Added segments subsection. Click Add Linear.

8 Find the Control points subsection. In row 2, set x to 0 and y to 4.

9 Find the Added segments subsection. Click Add Linear.

10 Find the Control points subsection. Click Close Curve.

Point 1 (pt1)
1 On the Geometry toolbar, click Primitives and choose Point.

2 In the Settings window for Point, locate the Point section.

3 In the y text field, type 2.

Form Union (fin)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click Form 

Union (fin) and choose Build Selected.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, locate the Material Contents section.

2 In the table, enter the following settings:

G L O B A L  D E F I N I T I O N S

1 In the Model Builder window, right-click Global Definitions and choose Load Group.

2 In the Settings window for Load Group, type lgGravity in the Parameter name text 
field.

3 Right-click Global Definitions>Load Group 1 (lg1) and choose Rename.

Property Name Value Unit Property group

Young’s modulus E 210[GPa] Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 7000[kg/m^3] kg/m³ Basic
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4 In the Rename Load Group dialog box, type Load Group Gravity in the New label text 
field.

5 Click OK.

6 In the Model Builder window, right-click Global Definitions and choose Load Group.

7 In the Settings window for Load Group, type lgForce in the Parameter name text field.

8 Right-click Global Definitions>Load Group 2 (lg2) and choose Rename.

9 In the Rename Load Group dialog box, type Load Group Force in the New label text 
field.

10 Click OK.

11 In the Model Builder window, right-click Global Definitions and choose Constraint Group.

12 In the Settings window for Constraint Group, type cgGravity in the Parameter name 
text field.

13 Right-click Global Definitions>Constraint Group 1 (cg1) and choose Rename.

14 In the Rename Constraint Group dialog box, type Constraint Group Gravity in the 
New label text field.

15 Click OK.

16 In the Model Builder window, right-click Global Definitions and choose Constraint Group.

17 In the Settings window for Constraint Group, type cgForce in the Parameter name text 
field.

18 Right-click Global Definitions>Constraint Group 2 (cg2) and choose Rename.

19 In the Rename Constraint Group dialog box, type Constraint Group Force in the New 

label text field.

20 Click OK.

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Settings window for Solid Mechanics, locate the 2D Approximation section.

2 From the list, choose Plane stress.

3 Locate the Thickness section. In the d text field, type 0.1.

First, define all constraints for both load cases and then assign them to different load and 
constraint groups.

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundaries 1 and 3 only.
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3 On the Physics toolbar, click Constraint Group and choose Constraint Group 1.

Body Load 1
1 On the Physics toolbar, click Domains and choose Body Load.

2 Select Domain 1 only.

3 In the Settings window for Body Load, locate the Force section.

4 Specify the FV vector as

5 On the Physics toolbar, click Load Group and choose Load Group Gravity.

Roller 1
1 On the Physics toolbar, click Boundaries and choose Roller.

2 Select Boundaries 1 and 3 only.

3 On the Physics toolbar, click Constraint Group and choose Constraint Group 2.

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundary 5 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 From the Load type list, choose Load defined as force per unit length.

5 Specify the FL vector as

6 On the Physics toolbar, click Load Group and choose Load Group Force.

Fixed Constraint 2
1 On the Physics toolbar, click Points and choose Fixed Constraint.

2 Select Point 2 only.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, click Build All.

0 x

-g_const*solid.rho y

10[MN/m] x

0 y
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S T U D Y  1

Step 1: Stationary
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study extensions section.

3 Locate the Study Extensions section. Select the Define load cases check box.

4 Click Add.

5 In the table, enter the following settings:

6 Click Add.

7 In the table, enter the following settings:

The study extension for the load cases should look like Figure 4.

8 On the Home toolbar, click Compute.

R E S U L T S

Stress (solid)
1 In the Model Builder window, under Results right-click Stress (solid) and choose Rename.

2 In the Rename 2D Plot Group dialog box, type Normal stress in the New label text field.

3 Click OK.

Surface 1
1 In the Model Builder window, expand the Results>Normal stress node, then click Surface 

1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Solid Mechanics>

Stress (Gauss points)>Stress tensor, Gauss-point evaluation (Spatial)>solid.sGpx - Stress 

tensor, Gauss-point evaluation, x component.

3 On the Normal stress toolbar, click Plot.

2D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

Load case lgGravity Weight lgForce Weight cgGravity cgForce

Gravity √ 1.0 1.0 √

Load case lgGravity Weight lgForce Weight cgGravity cgForce

Force 1.0 √ 1.0 √
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2 In the Model Builder window, right-click 2D Plot Group 2 and choose Rename.

3 In the Rename 2D Plot Group dialog box, type Shear stress in the New label text field.

4 Click OK.

5 In the Settings window for 2D Plot Group, locate the Data section.

6 From the Load case list, choose Gravity.

Surface 1
1 Right-click Shear stress and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Solid Mechanics>

Stress (Gauss points)>Stress tensor, Gauss-point evaluation (Spatial)>solid.sGpxy - Stress 

tensor, Gauss-point evaluation, xy component.

3 Right-click Results>Shear stress>Surface 1 and choose Deformation.

Point Evaluation 1
1 On the Results toolbar, click Point Evaluation.

2 In the Model Builder window, right-click Point Evaluation 1 and choose Rename.

3 In the Rename Point Evaluation dialog box, type Point Evaluation - normal stress 
in the New label text field.

4 Click OK.

5 Select Point 2 only.

6 In the Settings window for Point Evaluation, click Replace Expression in the upper-right 
corner of the Expressions section. From the menu, choose Model>Component 1>Solid 

Mechanics>Stress (Gauss points)>Stress tensor, Gauss-point evaluation (Spatial)>solid.sGpx 

- Stress tensor, Gauss-point evaluation, x component.

7 Click Evaluate.

Point Evaluation 2
1 On the Results toolbar, click Point Evaluation.

2 In the Model Builder window, right-click Point Evaluation 2 and choose Rename.

3 In the Rename Point Evaluation dialog box, type Point Evaluation - shear stress 
in the New label text field.

4 Click OK.

5 Select Point 2 only.
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6 In the Settings window for Point Evaluation, click Replace Expression in the upper-right 
corner of the Expressions section. From the menu, choose Model>Component 1>Solid 

Mechanics>Stress (Gauss points)>Stress tensor, Gauss-point evaluation (Spatial)>

solid.sGpxy - Stress tensor, Gauss-point evaluation, xy component.

7 Click Evaluate.
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Introduction

This simple tutorial model simulates the resistive heating—also known as Joule heating—
of a two-hot-arm thermal actuator. The model couples the physics phenomena involved in 
one way only. However, as explained below, you can easily modify it to simulate a two-way 
coupling between the electric current and the heating of the actuator.

Model Definition

Figure 1 shows the actuator’s parts and dimensions as well as its position on top of a 
substrate surface.

Figure 1: The thermal microactuator.

M A T E R I A L  D A T A

This model uses the material properties listed in Table 1 for the Joule Heating Model 
equations. The assumption of constant material properties means that the coupling 
between physics phenomena is one way only: the electric current through the actuator 
heats up the material, but the current itself is not affected by the temperature rise. By 
choosing the linearized resistivity option for the electrical conductivity (available in the 

Hot arms

Cold arm AnchorsDimple

Upper surface

Substrate

3 μm

2 μm

240 μm
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Joule Heating Model node’s settings window) and providing the associated material 
properties you can turn this into a two-way coupling.

B O U N D A R Y  C O N D I T I O N S

An electric potential is applied between the bases of the hot arms’ anchors. The cold arm 
anchor and all other surfaces are electrically insulated.

Figure 2: Electrical boundary conditions.

The temperature of the base of the three anchors and the three dimples is fixed to that of 
the substrate’s constant temperature. Because the structure is sandwiched, all other 
boundaries interact thermally with the surroundings by conduction through thin layers of 
air.

TABLE 1:  MATERIAL DATA

PROPERTY NAME VALUE

Electrical conductivity σ 5·104 S/m

Relative permeability εr 4.5

Thermal conductivity k 40 W/(m·K)

Density ρ 2300 kg/m3

Heat capacity at constant pressure Cp 600 J/(kg·K)

Applied voltage

Ground
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The heat transfer coefficient is given by the thermal conductivity of air divided by the 
distance to the surrounding surfaces for the system. This exercise uses different heat 
transfer coefficients for the actuator’s upper and other surfaces.

Figure 3: Heat-transfer boundary conditions.

Results

Figure 4 shows the temperature distribution on the actuator’s surface. The line graph in 
Figure 5 provides more detailed information about the temperature along a single edge 
facing the substrate plane.

Fixed temperature

Fixed temperature

Fixed temperature

Heat flux⊥= h(T-Tamb)
4 |  J O U L E  H E A T I N G  O F  A  M I C R O A C T U A T O R



Figure 4: The temperature distribution on the actuator surface.

Figure 5: Temperature along the actuators longest edge facing the substrate.
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Application Library path: COMSOL_Multiphysics/Multiphysics/
thermal_actuator_jh

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Electromagnetic Heating>Joule Heating.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

C O M P O N E N T  1  ( C O M P 1 )

1 In the Model Builder window, right-click Component 1 (comp1) and choose Rename.

2 In the Rename Component dialog box, type Thermal Actuator in the New label text 
field.

3 Click OK.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
thermal_actuator.mphbin.

5 Click Build All Objects.

6 Click the Zoom Extents button on the Graphics toolbar.

D E F I N I T I O N S

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Model Builder window, right-click Explicit 1 and choose Rename.

3 In the Rename Explicit dialog box, type Substrate Contact in the New label text field.

4 Click OK.

5 In the Settings window for Explicit, locate the Input Entities section.

6 From the Geometric entity level list, choose Boundary.

7 Select Boundaries 10, 30, 50, 70, 76, and 82 only.

M A T E R I A L S

In the Model Builder window, under Thermal Actuator (comp1) right-click Materials and 
choose Blank Material.

Material 1 (mat1)
By default, the first material you define applies to all domains.

Name Expression Value Description

htc_s 0.04[W/(m*K)]/
2[um]

20000 W/(m²·K) Heat transfer 
coefficient

htc_us 0.04[W/(m*K)]/
100[um]

400 W/(m²·K) Heat transfer 
coefficient, upper 
surface

DV 5[V] 5 V Applied voltage
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1 In the Settings window for Material, locate the Material Contents section.

2 In the table, enter the following settings:

E L E C T R I C  C U R R E N T S  ( E C )

Ground 1
1 On the Physics toolbar, click Boundaries and choose Ground.

2 Select Boundary 10 only.

Electric Potential 1
1 On the Physics toolbar, click Boundaries and choose Electric Potential.

2 Select Boundary 30 only.

3 In the Settings window for Electric Potential, locate the Electric Potential section.

4 In the V0 text field, type DV.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, under Thermal Actuator (comp1) click Heat Transfer in Solids 

(ht).

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

This boundary condition applies to all boundaries except the top-surface boundary and 
those in contact with the substrate. A Temperature condition on the 
substrate_contact boundaries will override this Heat Flux condition so you do not 
explicitly need to exclude those boundaries. In contrast, because the Heat Flux 
boundary condition is additive, you must explicitly exclude the top-surface boundary 
from the selection. Implement this selection as follows:

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

Property Name Value Unit Property 
group

Electrical conductivity sigma 5e4 S/m Basic

Relative permittivity epsilonr 4.5 1 Basic

Thermal conductivity k 40 W/(m·K) Basic

Density rho 2.3e3 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 600 J/(kg·K) Basic
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3 From the Selection list, choose All boundaries. In the Graphics window, click on the top 
surface and then right-click to remove it from the selection.

A convective heat flux is used to model the heat flux through a thin air layer. The heat 
transfer coefficient, htc_s is defined as the ratio of the air thermal conductivity to the 
gap thickness.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type htc_s.

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundary 4 only.

A convective heat flux is used to model the heat flux through a thin air layer. The heat 
transfer coefficient, htc_us is defined as the ratio of the air thermal conductivity to the 
gap thickness.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type htc_us.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 In the Settings window for Temperature, locate the Boundary Selection section.

3 From the Selection list, choose Substrate Contact.

M E S H  1

1 In the Model Builder window, under Thermal Actuator (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Fine.

Free Triangular 1
1 Right-click Thermal Actuator (comp1)>Mesh 1 and choose More Operations>Free 

Triangular.

2 In the Settings window for Free Triangular, locate the Boundary Selection section.

3 From the Selection list, choose Substrate Contact.

4 Click Paste Selection.

5 In the Paste Selection dialog box, type 3 in the Selection text field.

6 Click OK.
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7 In the Settings window for Free Triangular, click Build Selected.

Swept 1
1 In the Model Builder window, right-click Mesh 1 and choose Swept.

2 In the Model Builder window, click Mesh 1.

3 In the Settings window for Mesh, click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Electric Potential (ec)
The first default plot group shows the electric potential distribution.

Temperature (ht)
The second default plot group shows the temperature distribution on the surface (see 
Figure 4).

1 Click the Zoom Extents button on the Graphics toolbar.

Reproduce the plot in Figure 5 by following these steps:
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1D Plot Group 4
On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

Line Graph 1
1 On the 1D Plot Group 4 toolbar, click Line Graph.

2 Select Edge 52 only.

3 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Model>Thermal Actuator>Heat 

Transfer in Solids>Temperature>T - Temperature.

4 Click Replace Expression in the upper-right corner of the x-axis data section. From the 
menu, choose Model>Thermal Actuator>Geometry>Coordinate>x - x-coordinate.

5 Locate the x-Axis Data section. From the Unit list, choose µm.

6 On the 1D Plot Group 4 toolbar, click Plot.
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Introduction

The purpose of this example is to demonstrate how to access the cluster computing 
functionality in COMSOL from the COMSOL Desktop and use it to submit a batch job 
to a cluster through a job scheduler. The model takes advantage of the distributed 
parameter functionality in COMSOL. The model also demonstrates how you can measure 
the speedup of COMSOL on your cluster. The speedup is defined as the quotient between 
the total runtime using only one physical node and one core of the cluster and the runtime 
using several physical nodes and all cores of each physical node of the cluster. For detailed 
information about the model, see Joule Heating of a Microactuator.

Note: This application requires a Floating Network License.

Application Library path: COMSOL_Multiphysics/Tutorials/
thermal_actuator_jh_distributed

Modeling Instructions

A P P L I C A T I O N  L I B R A R I E S

1 On the Home toolbar, click Application Libraries.

2 In the Application Library tree, select COMSOL Multiphysics>Multiphysics>

thermal_actuator_jh.

3 Click Open Application.

S T U D Y  1

1 In the Model Builder window’s toolbar, click the Show button and select Advanced Study 

Options in the menu.

With this setting active, Cluster Computing is available from the Study node's context 
menu.

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.
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3 Click Add.

4 In the table, enter the following settings:

5 Click to expand the Study Extensions section. Select the Distribute parametric sweep 
check box.

Cluster Computing
1 In the Model Builder window, right-click Study 1 and choose Cluster Computing.

2 In the Settings window for Cluster Computing, locate the Batch Settings section.

Set the number of nodes to the number of nodes you want to use. If you are testing 
Cluster Computing, set the number of nodes to 2 or less to make sure everything works.

Choose from one of the following settings the type of job scheduler to use:

General: Use the General scheduler if you intend to submit a job to a job scheduler that 
you have configured COMSOL to run on.

HPCS 2008: Use the HPCS 2008 scheduler if you intend to submit a job to a Windows 
HPC Server 2008 using the Windows HPC Cluster Manager.

WCCS 2003: Use the WCCS 2003 scheduler if you intend to submit a job to a 
Windows Compute Cluster Server 2003.

3 Locate the Batch Settings section. From the Scheduler type list, choose Not distributed.

Not Distributed: Use this setting when you have configured COMSOL to run on job 
scheduler but only intend to run on a single node of the cluster.

Make sure you configure the batch directories and COMSOL installation directories 
correctly. It is good practice to save these values as default once you have good settings.

4 Click the Save as Default button.

Batch 1
1 On the Study toolbar, click Compute.

In the General section, click Open to open the file containing the model generated by 
the batch job associated with this external process in a new COMSOL session.

In the Process Status section, the log shows the total solution time. COMSOL 
automatically takes advantage of all cores; to measure the speedup, set the number of 
cores to 1 and run a new job.

2 In the Model Builder window, click Batch 1.

Parameter name Parameter value list Parameter unit

DV range(5,0.5,15)
3 |  J O U L E  H E A T I N G  O F  A  M I C R O A C T U A T O R — D I S T R I B U T E D  P A R A M E T E R  V E R S I O N



3 In the Settings window for Batch, locate the General section.

4 From the Defined by study step list, choose User defined.

5 Select the Number of cores check box.

6 Locate the Files section. In the Filename text field, enter a name of your choice.

Next, change the filename to create a new External Process node for the run:

7 In the Filename text field, enter a name of your choice.

Cluster Computing 1
If you are not using the cluster type Not distributed, make sure to set the Number of nodes 
to 1.

Batch 1
1 In the Model Builder window, under Study 1>Job Configurations right-click Cluster 

Computing 1 and choose Run.

When the process has finished, compare the total time in the log for the new external 
process with the previous value. The speedup is equal to the previous value divided by 
the new value. The speedup depends on the mesh size. To improve the numbers, try 
refining the mesh.
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Introduction

This example model consists of a two-hot-arm thermal actuator made of polysilicon. The 
actuator is activated through thermal expansion. The temperature increase required to 
deform the two hot arms, and thus displace the actuator, is obtained through Joule heating 
(resistive heating). The greater expansion of the hot arms, compared to the cold arm, 
causes a bending of the actuator.

The material properties of polysilicon are temperature dependent, which means that the 
involved physics phenomena are fully coupled. The electric current through the hot arms 
increases the temperature in the actuator, which in turn causes thermal expansion and 
changes the electrical conductivity of the material.

The actuator’s operation thus involves three coupled physics phenomena: electric current 
conduction, heat conduction with heat generation, and structural stresses and strains due 
to thermal expansion.

In this example the thermal expansion is included manually using the Equation View. 
Furthermore, only linear strains are considered, which is a valid approximation provided 
deformations are small. Using the Structural Mechanics Module or the MEMS Module 
one can directly include the thermal equation in the physics and also take into account 
possible large deformations; see the model Thermal Microactuator in the Structural 
Mechanics Module Application Libraries or the MEMS Module Application Libraries.
2 |  T H E R M A L  M I C R O A C T U A T O R  S I M P L I F I E D



Model Definition

Figure 1 shows the actuator’s parts and dimensions as well as its position on top of a 
substrate surface.

Figure 1: The thermal microactuator.

B O U N D A R Y  C O N D I T I O N S  A N D  C O N S T R A I N T S

An electric potential is applied between the bases of the hot arms’ anchors. The cold arm 
anchor and all other surfaces are electrically insulated.

Figure 2: Electrical boundary conditions.

The temperature of the base of the three anchors and the three dimples is fixed to that of 
the substrate’s constant temperature. Because the structure is sandwiched, all other 

Hot arms
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Upper surface
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Applied voltage
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boundaries interact thermally with the surroundings by conduction through thin layers of 
air.

The heat transfer coefficient is given by the thermal conductivity of air divided by the 
distance to the surrounding surfaces for the system. This exercise uses different heat 
transfer coefficients for the actuator’s upper and other surfaces.

Figure 3: Heat-transfer boundary conditions.

All three arms are mechanically fixed at the base of the three anchors. The dimples can 
move freely in the plane of the substrate (the xy-plane in the figure) but do not move in 
the direction perpendicular to the substrate (the z direction).

Figure 4: Structural boundary conditions and constraints.

G E O M E T R Y  P R O G R A M I N G  O P E R A T I O N

The model geometry is implemented using the geometry programing feature operation 
such as the conditional if statement. The model geometry is implemented using two 
distinct design: a two-arms or a three-arms actuator design. It is possible to switch from 
one design to the other by means of a parameter.

Fixed temperature

Fixed temperature

Fixed temperature

Heat flux⊥= h(T-Tamb)

Fixed

Fixed

Roller
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Results

Figure 5 shows the surface temperature distribution for the actuator design with two arms. 
It also illustrates the displacement field through a deformation plot.

Figure 5: Temperature (surface) and displacement (deformation) in the two-arms actuator 
design.

For the two-arms design, the computed displacement at the tip of the actuator is about 
3.3 μm.
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Figure 6 shows the surface temperature distribution for the actuator design with 3 arms 
only.

Figure 6: Temperature (surface) and displacement (deformation) in the three arms actuator 
design.

For the two-arms design, the computed displacement at the tip of the actuator is about 
1.1 μm.

Notes About the COMSOL Implementation

Enable the Equation View to access the equation level. There one can modify the strain 
definition used by the linear elastic material model. 

The thermal strain to be added is represented below:

Where α is the material thermal expansion coefficient, T the strain temperature and T0 the 
strain reference temperature.

Enable the equation view by clicking the Show button ( ) and select Equation View. You 
can then access the equation view by expanding each node of the model tree.

εth α T T0–( )⋅=
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Application Library path: COMSOL_Multiphysics/Multiphysics/
thermal_actuator_simplified

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Electromagnetic Heating>Joule Heating.

3 Click Add.

4 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

5 Click Add.

6 Click Study.

7 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

8 Click Done.

C O M P O N E N T  1  ( C O M P 1 )

1 In the Model Builder window, right-click Component 1 (comp1) and choose Rename.

2 In the Rename Component dialog box, type Thermal Actuator in the New label text 
field.

3 Click OK.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

G E O M E T R Y  1

1 In the Model Builder window, under Thermal Actuator (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose µm.

If 1 (if1)
1 On the Geometry toolbar, click Programming and choose If + End If.

Name Expression Value Description

d 3[um] 3E-6 m Height of the hot 
arm

dw 15[um] 1.5E-5 m Height of the cold 
arm

gap 3[um] 3E-6 m Gap between arms

wb 10[um] 1E-5 m Width of the base

wv 25[um] 2.5E-5 m Difference in length 
between hot arms

L 240[um] 2.4E-4 m Actuator length

L1 L-wb 2.3E-4 m Length of the 
longest hot arm

L2 L-wb-wv 2.05E-4 m Length of the 
shortest hot arm

L3 L-2*wb-wv-L/48-L/6 1.5E-4 m Length of the cold 
arm, thick part

L4 L/6 4E-5 m Length of the cold 
arm, thin part

htc_s 0.04[W/(m*K)]/
2[um]

20000 W/(m²·K) Heat transfer 
coefficient

htc_us 0.04[W/(m*K)]/
100[um]

400 W/(m²·K) Heat transfer 
coefficient, upper 
surface

DV 5[V] 5 V Applied voltage

alphaps 2.6e-6[1/K] 2.6E-6 1/K Coefficient of 
thermal expansion

T0 293.15[K] 293.15 K Strain reference 
temperature

noa 3 3 Number of arms
8 |  T H E R M A L  M I C R O A C T U A T O R  S I M P L I F I E D



2 In the Settings window for If, locate the If section.

3 In the Condition text field, type (noa==3).

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, click Show Work Plane.

Rectangle 1 (r1)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type L3.

4 In the Height text field, type dw.

5 Locate the Position section. In the xw text field, type L-L3. Leave yw at the default value 
0.

Rectangles 2-9
Proceed to create eight additional rectangles with the following settings:

Union 1 (uni1)
1 On the Work Plane toolbar, click Booleans and Partitions and choose Union.

2 Click in the Graphics window and then press Ctrl+A to select all objects.

3 In the Settings window for Union, locate the Union section.

4 Clear the Keep interior boundaries check box.

Fillet 1 (fil1)
1 On the Work Plane toolbar, click Fillet.

2 On the object uni1, select Points 1, 2, 4–9, 11–14, 16, 17, 19–23, and 28 only.

Name Width Height xw yw

Rectangle 2 (r2) L4 d L-L3-L4 dw-d

Rectangle 3 (r3) wb dw L-L3-L4-wb 0

Rectangle 4 (r4) L2 d L-L2 dw+gap

Rectangle 5 (r5) wb dw+gap+d L-L2-wb 0

Rectangle 6 (r6) L1 d L-L1 dw+d+2*gap

Rectangle 7 (r7) wb dw+gap+d 0 dw+d+2*gap

Rectangle 8 (r8) d gap L-d dw+gap+d

Rectangle 9 (r9) d gap L-d dw
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3 In the Settings window for Fillet, locate the Radius section.

4 In the Radius text field, type d/3.

5 In the Model Builder window, click Geometry 1.

Extrude 1 (ext1)
1 On the Geometry toolbar, click Extrude.

2 In the Settings window for Extrude, locate the Distances from Plane section.

3 In the table, enter the following settings:

Work Plane 2 (wp2)
1 On the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, click Show Work Plane.

Rectangle 1 (r1)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type wb-2*d.

4 In the Height text field, type 2.5*(wb-2*d).

5 Locate the Position section. In the xw text field, type d.

6 In the yw text field, type (dw+d+2*gap)+(dw+gap+d)-2.5*(wb-2*d)-d.

Rectangle 2 (r2)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type wb-2*d.

4 In the Height text field, type 2.5*(wb-2*d).

5 Locate the Position section. In the xw text field, type L-L2-wb+d.

6 In the yw text field, type d.

Rectangle 3 (r3)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type wb-2*d.

4 In the Height text field, type 2.5*(wb-2*d).

Distances (µm)

2
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5 Locate the Position section. In the xw text field, type L-L3-L4-wb+d.

6 In the yw text field, type d.

Fillet 1 (fil1)
1 On the Work Plane toolbar, click Fillet.

2 Click the Zoom Extents button on the Graphics toolbar.

3 On each of the rectangles r1, r2, and r3, in turn, select all four corner points.

4 In the Settings window for Fillet, locate the Radius section.

5 In the Radius text field, type d/3.

Circle 1 (c1)
1 On the Work Plane toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type d/2.

4 Locate the Position section. In the xw text field, type L-L3/4.

5 In the yw text field, type dw/2.

Circle 2 (c2)
1 On the Work Plane toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type d/2.

4 Locate the Position section. In the xw text field, type L-L3/2.

5 In the yw text field, type dw/2.

Circle 3 (c3)
1 On the Work Plane toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type d/2.

4 Locate the Position section. In the xw text field, type L-3*L3/4.

5 In the yw text field, type dw/2.

6 In the Model Builder window, click Geometry 1.

Extrude 2 (ext2)
1 On the Geometry toolbar, click Extrude.

2 In the Settings window for Extrude, locate the Distances from Plane section.
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3 In the table, enter the following settings:

4 Select the Reverse direction check box.

Union 1 (uni1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Union.

2 Click the Select Box button on the Graphics toolbar.

3 Click in the Graphics window and then press Ctrl+A to select both objects.

4 In the Settings window for Union, locate the Union section.

5 Clear the Keep interior boundaries check box.

Explicit Selection 1 (sel1)
1 Right-click Union 1 (uni1) and choose Build Selected.

2 On the Geometry toolbar, click Selections and choose Explicit Selection.

3 In the Settings window for Explicit Selection, locate the Entities to Select section.

4 From the Geometric entity level list, choose Boundary.

5 On the object uni1, select Boundary 10 only.

6 Locate the Resulting Selection section. Click New.

7 Clear the Keep selection check box.

8 In the New Cumulative Selection dialog box, type Ground in the Name text field.

9 Click OK.

Explicit Selection 2 (sel2)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, locate the Entities to Select section.

3 From the Geometric entity level list, choose Boundary.

4 On the object uni1, select Boundary 29 only.

5 Locate the Resulting Selection section. Click New.

6 Clear the Keep selection check box.

7 In the New Cumulative Selection dialog box, type Applied Voltage in the Name text 
field.

8 Click OK.

Distances (µm)

2
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Explicit Selection 3 (sel3)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, locate the Entities to Select section.

3 From the Geometric entity level list, choose Boundary.

4 On the object uni1, select Boundary 48 only.

5 Locate the Resulting Selection section. Click New.

6 Clear the Keep selection check box.

7 In the New Cumulative Selection dialog box, type Third in the Name text field.

8 Click OK.

Explicit Selection 4 (sel4)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, locate the Entities to Select section.

3 From the Geometric entity level list, choose Boundary.

4 On the object uni1, select Boundary 4 only.

5 Locate the Resulting Selection section. Click New.

6 Clear the Keep selection check box.

7 In the New Cumulative Selection dialog box, type Upper Surface in the Name text field.

8 Click OK.

Explicit Selection 5 (sel5)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, locate the Entities to Select section.

3 From the Geometric entity level list, choose Boundary.

4 Click the Select Box button on the Graphics toolbar.

5 On the object uni1, select Boundaries 1–3, 5–9, 11–28, 30–47, and 49–92 only.

6 Locate the Resulting Selection section. Click New.

7 Clear the Keep selection check box.

8 In the New Cumulative Selection dialog box, type Other Surface in the Name text field.

9 Click OK.

Explicit Selection 6 (sel6)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, locate the Entities to Select section.
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3 From the Geometric entity level list, choose Point.

4 Click the Zoom Box button on the Graphics toolbar.

5 On the object uni1, select Point 154 only.

6 Locate the Resulting Selection section. Click New.

7 Clear the Keep selection check box.

8 In the New Cumulative Selection dialog box, type Tip in the Name text field.

9 Click OK.

Explicit Selection 7 (sel7)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, locate the Entities to Select section.

3 From the Geometric entity level list, choose Boundary.

4 On the object uni1, select Boundaries 67, 72, and 77 only.

5 Locate the Resulting Selection section. Click New.

6 Clear the Keep selection check box.

7 In the New Cumulative Selection dialog box, type Dimples in the Name text field.

8 Click OK.

End If 1 (endif1)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 right-click End 

If 1 (endif1) and choose Build Selected.

G L O B A L  D E F I N I T I O N S

Parameters
1 In the Model Builder window, under Global Definitions click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

If 2 (if2)
1 On the Geometry toolbar, click Programming and choose If + End If.

2 In the Settings window for If, locate the If section.

Name Expression Value Description

noa 2 2 Number of arms
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3 In the Condition text field, type (noa==2).

Work Plane 1 (wp1)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 right-click Work 

Plane 1 (wp1) and choose Duplicate.

Work Plane 3 (wp3)
In the Model Builder window, expand the Work Plane 3 (wp3) node.

Plane Geometry
Ctrl-click to select Rectangle 6 (r6), Rectangle 7(r7), and Rectangle 8 (r8) simultaneously, 
then right-click and choose Disable.

Extrude 1 (ext1)
In the Model Builder window, expand the Thermal Actuator (comp1)>Geometry 1>Work 

Plane 3 (wp3)>Plane Geometry node.

Extrude 3 (ext3)
1 Right-click Thermal Actuator (comp1)>Geometry 1>Extrude 1 (ext1) and choose 

Duplicate.

2 In the Settings window for Extrude, locate the General section.

3 From the Work plane list, choose Work Plane 3 (wp3).

4 Find the Input objects subsection. Select the Active toggle button.

5 Select the object wp3 only.

6 Right-click Thermal Actuator (comp1)>Geometry 1>Extrude 3 (ext3) and choose Build 

Selected.

Work Plane 2 (wp2)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 right-click Work 

Plane 2 (wp2) and choose Duplicate.

Work Plane 4 (wp4)
In the Model Builder window, expand the Work Plane 4 (wp4) node.

Rectangle 1 (r1)
1 In the Model Builder window, expand the Thermal Actuator (comp1)>Geometry 1>Work 

Plane 4 (wp4)>Plane Geometry node, then click Rectangle 1 (r1).

2 Right-click Thermal Actuator (comp1)>Geometry 1>Work Plane 4 (wp4)>Plane 

Geometry>Rectangle 1 (r1) and choose Disable.
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Extrude 2 (ext2)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 right-click 
Extrude 2 (ext2) and choose Duplicate.

Extrude 4 (ext4)
1 In the Settings window for Extrude, locate the General section.

2 From the Work plane list, choose Work Plane 4 (wp4).

3 Find the Input objects subsection. Select the Active toggle button.

4 Select the object wp4 only.

5 Right-click Thermal Actuator (comp1)>Geometry 1>Extrude 4 (ext4) and choose Build 

Selected.

Union 1 (uni1)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 right-click Union 

1 (uni1) and choose Duplicate.

Union 2 (uni2)
1 In the Settings window for Union, locate the Union section.

2 Find the Input objects subsection. Select the Active toggle button.

3 Click in the Graphics window and then press Ctrl+A to select both objects.

Explicit Selection 1 (sel1)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 right-click 
Explicit Selection 1 (sel1) and choose Duplicate.

Explicit Selection 8 (sel8)
1 In the Settings window for Explicit Selection, locate the Entities to Select section.

2 Find the Entities to select subsection. Select the Active toggle button.

3 On the object uni2, select Boundary 28 only.

4 Right-click Thermal Actuator (comp1)>Geometry 1>Explicit Selection 8 (sel8) and choose 
Build Selected.

Explicit Selection 2 (sel2)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 right-click 
Explicit Selection 2 (sel2) and choose Duplicate.

Explicit Selection 9 (sel9)
1 In the Settings window for Explicit Selection, locate the Entities to Select section.

2 Find the Entities to select subsection. Select the Active toggle button.
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3 On the object uni2, select Boundary 10 only.

4 Right-click Thermal Actuator (comp1)>Geometry 1>Explicit Selection 9 (sel9) and choose 
Build Selected.

Explicit Selection 4 (sel4)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 right-click 
Explicit Selection 4 (sel4) and choose Duplicate.

Explicit Selection 10 (sel10)
1 On the object uni2, select Boundary 4 only.

2 Right-click Thermal Actuator (comp1)>Geometry 1>Explicit Selection 10 (sel10) and 
choose Build Selected.

Explicit Selection 5 (sel5)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 right-click 
Explicit Selection 5 (sel5) and choose Duplicate.

Explicit Selection 11 (sel11)
1 Click the Select Box button on the Graphics toolbar.

2 On the object uni2, select Boundaries 1–3, 5–9, 11–27, and 29–66 only.

3 Right-click Thermal Actuator (comp1)>Geometry 1>Explicit Selection 11 (sel11) and 
choose Build Selected.

Explicit Selection 6 (sel6)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 right-click 
Explicit Selection 6 (sel6) and choose Duplicate.

Explicit Selection 12 (sel12)
1 On the object uni2, select Point 108 only.

2 Right-click Thermal Actuator (comp1)>Geometry 1>Explicit Selection 12 (sel12) and 
choose Build Selected.

Explicit Selection 7 (sel7)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 right-click 
Explicit Selection 7 (sel7) and choose Duplicate.

Explicit Selection 13 (sel13)
1 On the object uni2, select Boundaries 47, 52, and 57 only.

2 Right-click Thermal Actuator (comp1)>Geometry 1>Explicit Selection 13 (sel13) and 
choose Build Selected.
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Form Union (fin)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 right-click Form 

Union (fin) and choose Build Selected.

D E F I N I T I O N S

Union 1
1 On the Definitions toolbar, click Union.

2 In the Settings window for Union, locate the Geometric Entity Level section.

3 From the Level list, choose Boundary.

4 Locate the Input Entities section. Under Selections to add, click Add.

5 In the Add dialog box, In the Selections to add list, choose Ground, Applied Voltage, and 
Third.

6 Click OK.

7 Right-click Union 1 and choose Rename.

8 In the Rename Union dialog box, type Surface Contact in the New label text field.

9 Click OK.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Polysilicon.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

E L E C T R I C  C U R R E N T S  ( E C )

Electric Potential 1
1 On the Physics toolbar, click Boundaries and choose Electric Potential.

2 In the Settings window for Electric Potential, locate the Boundary Selection section.

3 From the Selection list, choose Applied Voltage.

4 Locate the Electric Potential section. In the V0 text field, type DV.

Ground 1
1 On the Physics toolbar, click Boundaries and choose Ground.

2 In the Settings window for Ground, locate the Boundary Selection section.
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3 From the Selection list, choose Ground.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, under Thermal Actuator (comp1) click Heat Transfer in Solids 

(ht).

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Other Surface.

A convective heat flux is used to model the heat flux through a thin air layer. The heat 
transfer coefficient, htc_s is defined as the ratio of the air thermal conductivity to the 
gap thickness.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type htc_s.

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Upper Surface.

A convective heat flux is used to model the heat flux through a thin air layer. The heat 
transfer coefficient, htc_us is defined as the ratio of the air thermal conductivity to the 
gap thickness.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type htc_us.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 In the Settings window for Temperature, locate the Boundary Selection section.

3 From the Selection list, choose Surface Contact.

S O L I D  M E C H A N I C S  ( S O L I D )

In the Model Builder window, under Thermal Actuator (comp1) click Solid Mechanics (solid).

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 In the Settings window for Fixed Constraint, locate the Boundary Selection section.
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3 From the Selection list, choose Surface Contact.

Roller 1
1 On the Physics toolbar, click Boundaries and choose Roller.

2 In the Settings window for Roller, locate the Boundary Selection section.

3 From the Selection list, choose Dimples.

4 In the Model Builder window’s toolbar, click the Show button and select Equation View 
in the menu.

Linear Elastic Material 1
1 In the Model Builder window, expand the Thermal Actuator (comp1)>Solid Mechanics 

(solid)>Linear Elastic Material 1 node, then click Equation View.

2 In the Settings window for Equation View, locate the Variables section.

3 In the table, enter the following settings:

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Point Evaluation 1
1 On the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, locate the Selection section.

3 From the Selection list, choose Tip.

4 Locate the Expressions section. In the table, enter the following settings:

Name Expression Unit Description Selection Details

solid.eXX uX-alphaps*
(T-T0)

1 Strain tensor, 
XX 
component

Domain 1 + operation

solid.eYY vY-alphaps*
(T-T0)

1 Strain tensor, 
YY 
component

Domain 1 + operation

solid.eZZ wZ-alphaps*
(T-T0)

1 Strain tensor, 
ZZ 
component

Domain 1 + operation

Expression Unit Description

solid.disp µm Total displacement
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5 Click Evaluate.

Volume Maximum 1
1 On the Results toolbar, click More Derived Values and choose Maximum>Volume 

Maximum.

2 In the Settings window for Volume Maximum, locate the Selection section.

3 From the Selection list, choose All domains.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Surface
In the Model Builder window, expand the Temperature (ht) node.

Deformation 1
1 Right-click Surface and choose Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 Select the Scale factor check box.

4 In the associated text field, type 5.

5 On the Temperature (ht) toolbar, click Plot.

G L O B A L  D E F I N I T I O N S

Parameters
Continue by computing the solution for the three arms actuator geometry case.

1 In the Model Builder window, under Global Definitions click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

S T U D Y  1

On the Home toolbar, click Compute.

Expression Unit Description

T K Temperature

Name Expression Value Description

noa 3 3 Number of arms
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R E S U L T S

Point Evaluation 1
1 In the Model Builder window, under Results>Derived Values click Point Evaluation 1.

2 In the Settings window for Point Evaluation, click Evaluate.

Volume Maximum 1
1 In the Model Builder window, under Results>Derived Values click Volume Maximum 1.

2 In the Settings window for Volume Maximum, click Evaluate.
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Introduction

When modeling transport by diffusion or conduction in thin layers, large differences in 
dimensions of the different domains are common. If the model has a sandwich structure, 
you can replace the thinnest layers with a thin-layer approximation, provided that the 
difference in thickness is large.

Model Definition

This study explains the principle of the thin-layer approximation in direct current 
conduction problems. A comparison of a structure with three domains to a simplified 
model that replaces the domain in the middle with a thin-layer approximation shows the 
benefit of this approach (see Figure 1).

Figure 1: Exact domain description (left) and approximation (right). The current flows from 
the base plate to the circular plate on the upper surface of the device.

Equation 1 below describes the current balance in all three domains in the real sandwich 
structure:

 (1)

In this equation, σ represents the conductivity and V the electric potential. In this case, 
there is a substantial difference in conductivity between the thin and thicker layers of the 
structure. The boundary conditions include a current inlet in the base plate of the device 
and a constant potential at the upper circular boundary (see Figure 1). All other 
boundaries are insulated.

The simplified model is based on the assumption that the components of the current 
density vector in the x and y directions are small and that the dominating transport 
through the thin structure is obtained in the z direction. For the middle layer, this implies 

Inlet current

Constant 
potential

z

∇ σ∇V–( )⋅ 0=
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that you can approximate Equation 1 by the one-dimensional equation

 (2)

It is possible to solve this equation analytically if the potential is given at the lower and 
upper surfaces of the middle layer:

 (3)

 (4)

You can integrate Equation 2 analytically to give:

where a and b are integration constants. If you arbitrarily place z = 0 at the lower boundary 
of the middle layer, you get the constants a and b from the boundary conditions in 
Equation 3 and Equation 4:

This gives:

The resulting equation for the potential is thus

 (5)

The current density is defined as

 (6)

Combining Equation 5 and Equation 6 gives

σd2V

dz2
-----------– 0=

Vδ 0= V1=

Vδ δ1= V2=

V az b+=

V1 b=

V2 aδ b+=

b V1=

a
V2 V1–

δ
--------------------=

V
V2 V1–

δ
-------------------- 
  z V1+=

Jz σdV
dz
--------–=
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 (7)

In the thin-film approximation the potential is discontinuous at the film boundary. Use 
the Contact Impedance node on interior boundaries to model a thin layer of resistive 
material.

It is also possible to derive the expression for the current density in Equation 7 by 
approximating the gradient using the potential difference over the thin layer. This example 
includes the previous tedious derivation to show that this is exactly what you obtain from 
the solution of Equation 2.

The approximation presented in this example is not limited to direct current problems: 
You can also use it for modeling of diffusion, heat conduction, flow through porous media 
using Darcy’s law, and other types of physics that the divergence of a gradient flux 
describes.

In general, the application of this simplification is appropriate in cases where the 
differences in thickness are so large that the mesh generator cannot even mesh the domain. 
In some cases, the mesh generator might be able to mesh the domain but then creates a 
very large number of elements.

Results and Discussion

Figure 2 shows a comparison between the exact solution of the problem using three 
conductive layers and the thin-film approximation. The comparison reveals an excellent 
agreement in the potential and current distribution despite that the middle film in this 
study is relatively thick. The approximation becomes even more accurate as the film 
thickness between the upper and lower domain decreases.

Jz σ
V2 V1–

δ
-------------------- 
 –=
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Figure 2: Potential distribution in the modeled device. The value of the potential loss over the 
device at a current of 0.3 A is almost identical in the two models: the full model (left) and 
thin-film approximation (right).

Figure 3 shows a cross-section plot of the potential through the structure’s center for the 
full model and for the approximation. The plots show the excellent agreement obtained 
between the two models.

Figure 3: Potential distribution along the z direction in the middle of the device. Solution for 
the full model (left) and for the thin-film approximation (right).

Application Library path: COMSOL_Multiphysics/Electromagnetics/
thin_film_resistance

Modeling Instructions

From the File menu, choose New.
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N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select AC/DC>Electric Currents (ec).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, locate the Plane Definition section.

3 In the z-coordinate text field, type 0.1.

4 Locate the Unite Objects section. Clear the Unite objects check box.

5 Click Show Work Plane.

Circle 1 (c1)
1 On the Work Plane toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type 0.6.

4 Locate the Position section. In the yw text field, type 1.

5 On the Work Plane toolbar, click Build All.

Square 1 (sq1)
1 On the Work Plane toolbar, click Primitives and choose Square.

2 Click Build All.

3 Click the Zoom Extents button on the Graphics toolbar.

Intersection 1 (int1)
1 On the Work Plane toolbar, click Booleans and Partitions and choose Intersection.

2 Click in the Graphics window and then press Ctrl+A to select both objects.

3 On the Work Plane toolbar, click Build All.
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Square 2 (sq2)
1 On the Work Plane toolbar, click Primitives and choose Square.

2 Click Build All.

3 Click the Zoom Extents button on the Graphics toolbar.

The 2D geometry should now look as in the figure below.

Work Plane 1 (wp1)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Work Plane 1 

(wp1).

Extrude 1 (ext1)
1 On the Geometry toolbar, click Extrude.

2 Select the object wp1.sq2 only.

3 In the Settings window for Extrude, locate the Distances from Plane section.

4 In the table, enter the following settings:

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

Distances (m)

-0.1
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2 In the Settings window for Block, locate the Size and Shape section.

3 In the Height text field, type 0.1.

4 Locate the Position section. In the z text field, type -0.1.

5 Click Build All Objects.

6 Click the Zoom Extents button on the Graphics toolbar.

The final geometry should look as in the figure below.

E L E C T R I C  C U R R E N T S  ( E C )

Current Conservation 1
1 In the Model Builder window, expand the Component 1 (comp1)>Electric Currents (ec) 

node, then click Current Conservation 1.

2 In the Settings window for Current Conservation, locate the Conduction Current section.

3 From the σ list, choose User defined. In the associated text field, type 1.

Normal Current Density 1
1 On the Physics toolbar, click Boundaries and choose Normal Current Density.

2 Select Boundary 3 only.

3 In the Settings window for Normal Current Density, locate the Normal Current Density 
section.
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4 In the Jn text field, type 0.3.

Ground 1
1 On the Physics toolbar, click Boundaries and choose Ground.

2 Select Boundary 8 only.

Contact Impedance 1
1 On the Physics toolbar, click Boundaries and choose Contact Impedance.

2 Click the Wireframe Rendering button on the Graphics toolbar.

3 Select Boundary 6 only.

4 Click the Wireframe Rendering button on the Graphics toolbar to restore the rendering 
setting.

5 In the Settings window for Contact Impedance, locate the Contact Impedance section.

6 In the ds text field, type 0.02.

7 From the σ list, choose User defined. Keep the default value.

8 From the εr list, choose User defined. Again, the default value applies.

S T U D Y  1

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, locate the Study Settings section.

3 Clear the Generate default plots check box, because you will add the desired plots 
manually.

4 On the Home toolbar, click Compute.

R E S U L T S

The following steps show you how to reproduce the surface plot of the potential (right 
panel of Figure 2).

3D Plot Group 1
On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

Surface 1
1 In the Model Builder window, right-click 3D Plot Group 1 and choose Surface.

2 In the Settings window for Surface, locate the Coloring and Style section.

3 Clear the Color legend check box.

4 On the 3D Plot Group 1 toolbar, click Plot.
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Follow the steps below to visualize the potential distribution along the z direction in the 
middle of the device (the right panel of Figure 3).

Cut Line 3D 1
1 On the Results toolbar, click Cut Line 3D.

2 In the Settings window for Cut Line 3D, locate the Line Data section.

3 In row Point 1, set x to 0.5, y to 0.5, and z to -0.1.

4 In row Point 2, set x to 0.5, y to 0.5, and z to 0.1.

1D Plot Group 2
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, click to expand the Axis section.

3 Select the Manual axis limits check box.

4 In the x minimum text field, type -0.1.

5 In the x maximum text field, type 0.1.

6 In the y minimum text field, type 0.2.

7 In the y maximum text field, type 1.

Line Graph 1
1 On the 1D Plot Group 2 toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Data set list, choose Cut Line 3D 1.

4 Click Replace Expression in the upper-right corner of the x-axis data section. From the 
menu, choose Model>Component 1>Geometry>Coordinate>z - z-coordinate.

5 On the 1D Plot Group 2 toolbar, click Plot.

Comparing the Thin-Film Approximation with the Full 3D Model

To reproduce the full 3D model that served as a reference model for comparison in this 
example, proceed with the following steps:

G E O M E T R Y  1

Move 1 (mov1)
1 On the Geometry toolbar, click Transforms and choose Move.

2 Select the object blk1 only.

3 In the Settings window for Move, locate the Displacement section.
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4 In the z text field, type -0.02.

Block 2 (blk2)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Height text field, type 0.02.

4 Locate the Position section. In the z text field, type -0.02.

E L E C T R I C  C U R R E N T S  ( E C )

Current Conservation 2
1 On the Physics toolbar, click Domains and choose Current Conservation.

2 Select Domain 2 only.

3 In the Settings window for Current Conservation, locate the Conduction Current section.

4 From the σ list, choose User defined. In the associated text field, type 0.01.

Contact Impedance 1
In the Model Builder window, under Component 1 (comp1)>Electric Currents (ec) right-click 
Contact Impedance 1 and choose Disable.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

3D Plot Group 1
This plot shows the potential distribution (the left panel of Figure 2).

1D Plot Group 2
This plot reproduces the left panel of Figure 3.

1 In the Model Builder window, under Results click 1D Plot Group 2.

2 On the 1D Plot Group 2 toolbar, click Plot.

Now, follow these steps to reset the model to use the thin-film approximation.

G E O M E T R Y  1

Move 1 (mov1)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click Move 1 

(mov1) and choose Disable.
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Block 2 (blk2)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click Block 2 

(blk2) and choose Disable.

E L E C T R I C  C U R R E N T S  ( E C )

Contact Impedance 1
In the Model Builder window, under Component 1 (comp1)>Electric Currents (ec) right-click 
Contact Impedance 1 and choose Enable.

Current Conservation 2
In the Model Builder window, under Component 1 (comp1)>Electric Currents (ec) right-click 
Current Conservation 2 and choose Disable.

S T U D Y  1

On the Home toolbar, click Compute.
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Introduction

In some problems, the load changes position with time. It can be a train moving over a 
bridge, or a heat source moving along a weld. In this example, intended to show how to 
model traveling loads, a set of load pulses travel along a beam with equally spaced supports.

The model is parametrized, so it is easy to change for example the velocity of the load 
pulses, or the spacing between them. This is used for showing that for some load 
configurations, resonant vibrations will appear in the beam.

M O D E L I N G  T R A V E L I N G  L O A D S

The possibility to enter analytical expressions and use built-in or external functions in the 
input fields for loads and boundary conditions makes it easy model traveling loads in 
COMSOL. A load with a constant distribution moving with a constant velocity v can 
mathematically be written

 (1)

This is the type of load being used in this example. You can however to use completely 
arbitrary functions of space and time too.

When the load is moving during the analysis, it will in general only cover some elements 
partially. This is not a problem, since the load is numerically integrated. The element size 
should however be chosen such that several elements are covered by the load.

Model Definition

G E O M E T R Y

Many aspects of the modeling can be parametrized. The table below shows the values used 
in the analysis.

TABLE 1:  GEOMETRICAL PARAMETERS

PROPERTY PARAMETER VALUE IN MODEL

Number of spans NumSpans 8

Length of individual spans SpanWidth 10[m]

Beam Height BeamHeight 0.3[m]

f x vt–( )
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M A T E R I A L  P R O P E R T I E S  A N D  B O U N D A R Y  C O N D I T I O N S

The material is concrete, with material data taken from the Material Library:

• Young’s modulus E = 25 GPa

• Poisson’s ration ν = 0.33

• Mass density ρ = 2300 kg/m3

The beam is supported on one point at the end of each span.

The load travels along the top. The loading is controlled by the parameters listed in 
Table 2

As can be seen in the table, four different combinations of loads are analyzed:

1 A single load pulse traveling with a speed which is slow compared to the natural 
frequency of the beam.

2 A single loads pulse traveling with a speed which matches the natural frequency of the 
beam.

3 A pulse train traveling with a speed which matches the natural frequency of the beam. 
The distance between the individual load pulses is two span widths.

4 A pulse train traveling with a speed which matches the natural frequency of the beam. 
The distance between the individual load pulses is one span width.

Results

The lowest eigenfrequency of the beam can be computed analytically, and is independent 
of the number of spans. It is actually the same as for a simply supported beam with the 
length of a single span. The expression is

TABLE 2:  LOAD PARAMETERS

PROPERTY PARAMETER VALUES IN MODEL

Pressure under the load LoadIntensity 0.1 MPa

Width of a load pulse PulseWidth 1 m

Spacing between the load pulses PulseSpacing 1: one pulse only
2: one pulse only
3: 2*SpanWidth
4: SpanWidth

Speed with which the load travels LoadSpeed 1: 20 m/s
2: 89.7 m/s
3: 89.7 m/s
4: 89.7 m/s
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 (2)

which with the given parameters can be evaluated to 4.49 Hz. It can thus be expected that 
a load which travels one span Ls during half the period T0 of the lowest natural frequency 
f0 should be able to excite a resonant vibration. This critical velocity is then approximately

 (3)

The effect of changing the velocity of the load, and the spacing between the loads are 
shown in Figure 1. The graphs show how the vertical displacement at the midpoint of the 
first span vary as function of the position of the first load pulse. The horizontal axis can 
also be seen as time, scaled with load velocity.

From the graphs, is can be seen that

• At a low load speed (20 m/s), the solution resembles a stationary solution. As the load 
moves away from the first span, the deflection there decreases.

• When the load speed is such (89.7 m/s) that the load travels two spans in the time T0 
of one period, then the load can actually excite resonances. This can be seen when using 
a very long load spacing (160 m, essentially giving a single load), as well as when using 
a spacing of two spans (20 m). The reason is that the load will always act on a 
downwards motion of the beam, thus giving a positive power input.

• Even if the loads travel with the critical speed, they can counteract each other. This is 
the case in the last analysis, where the spacing between the loads matches the length of 
one span (10 m). In this case, every other load will act against the velocity, and thus limit 
the response.

f0
π
2
--- EI

ρALs
4

---------------=

vc
   Ls  

T0
2

------
--------------- 2Lf0= = 89· .7 m/s≈
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Figure 1: Displacement history at the midpoint of the first span, as function of the location of 
the first load pulse

A snapshot of the state when the loads 
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Figure 2: Displaced shape when loads are traveling to the right with a speed and spacing 
giving an amplification of the response.

Application Library path: COMSOL_Multiphysics/Structural_Mechanics/
traveling_load

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).
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3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
traveling_load_parameters.txt.

G E O M E T R Y  1

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type SpanWidth.

4 In the Height text field, type BeamHeight.

Point 1 (pt1)
1 On the Geometry toolbar, click Primitives and choose Point.

2 In the Settings window for Point, locate the Point section.

3 In the y text field, type BeamHeight/2.

Point 2 (pt2)
1 In the Model Builder window, right-click Point 1 (pt1) and choose Duplicate.

2 In the Settings window for Point, locate the Point section.

3 In the x text field, type SpanWidth.

4 Click Build All Objects.

Union 1 (uni1)
On the Geometry toolbar, click Booleans and Partitions and choose Union.

Array 1 (arr1)
1 In the Model Builder window, right-click Union 1 (uni1) and choose Build Selected.
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2 On the Geometry toolbar, click Transforms and choose Array.

3 Select the object uni1 only.

4 In the Settings window for Array, locate the Size section.

5 In the x size text field, type NumSpans.

6 Locate the Displacement section. In the x text field, type SpanWidth.

7 Click Build All Objects.

8 Click the Zoom Extents button on the Graphics toolbar.

D E F I N I T I O N S

Box 1
1 On the Definitions toolbar, click Box.

2 In the Settings window for Box, type Box: Points on centerline in the Label text 
field.

3 Locate the Geometric Entity Level section. From the Level list, choose Point.

4 Locate the Box Limits section. In the y minimum text field, type BeamHeight/3.

5 In the y maximum text field, type 2*BeamHeight/3.

6 Locate the Output Entities section. From the Include entity if list, choose Entity inside 

box.

Box 2
1 On the Definitions toolbar, click Box.

2 In the Settings window for Box, type Box: Boundaries above in the Label text field.

3 Locate the Geometric Entity Level section. From the Level list, choose Boundary.

4 Locate the Box Limits section. In the y minimum text field, type 2*BeamHeight/2.

5 Locate the Output Entities section. From the Include entity if list, choose Entity inside 

box.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Concrete.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.
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S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the 2D Approximation section.

3 From the list, choose Plane stress.

Linear Elastic Material 1
In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 
Linear Elastic Material 1.

Damping 1
1 On the Physics toolbar, click Attributes and choose Damping.

2 In the Settings window for Damping, locate the Damping Settings section.

3 In the βdK text field, type 0.002.

Fixed Constraint 1
1 On the Physics toolbar, click Points and choose Fixed Constraint.

2 In the Settings window for Fixed Constraint, locate the Point Selection section.

3 From the Selection list, choose Box: Points on centerline.

Create functions describing the load. The distribution is a rectangular load.

D E F I N I T I O N S

Rectangle 1 (rect1)
1 On the Home toolbar, click Functions and choose Global>Rectangle.

2 In the Settings window for Rectangle, locate the Parameters section.

3 In the Lower limit text field, type -0.5*PulseWidth.

4 In the Upper limit text field, type 0.5*PulseWidth.

5 Click to expand the Smoothing section. In the Size of transition zone text field, type 0.1*
PulseWidth.

In order to make the load pulse periodic, call it through an analytical function, which 
has the option of being periodic.

Analytic 1 (an1)
1 On the Home toolbar, click Functions and choose Global>Analytic.

2 In the Settings window for Analytic, type Pulse in the Function name text field.

3 Locate the Definition section. In the Expression text field, type rect1(x).

4 Locate the Units section. In the Arguments text field, type m.
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5 In the Function text field, type 1.

6 Click to expand the Periodic extension section. Locate the Periodic Extension section. 
Select the Make periodic check box.

7 In the Upper limit text field, type PulseSpacing.

8 Right-click Analytic 1 (an1) and choose Variables.

Create a variable for filtering the load, so that it is periodic only behind the first pulse.

Variables 1
1 In the Settings window for Variables, locate the Variables section.

2 In the table, enter the following settings:

Add the load definition to the whole upper boundary. The function call will make the 
load non-zero only at certain traveling positions.

S O L I D  M E C H A N I C S  ( S O L I D )

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 In the Settings window for Boundary Load, locate the Boundary Selection section.

3 From the Selection list, choose Box: Boundaries above.

4 Locate the Force section. Specify the FA vector as

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Mapped.

Name Expression Unit Description

FirstLoadX LoadSpeed*
t+
PulseWidth/
2

m Position of 
the first 
load pulse

BehindFirstLoad X<FirstLoad
X

True if 
behind 
current 
position of 
the first 
load pulse

0 x

if(BehindFirstLoad,-LoadIntensity*Pulse(X-LoadSpeed*t),0) y
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Mapped 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Mapped 1 and 
choose Distribution.

Distribution 1
1 Select Boundaries 1 and 3 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 1.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 2
1 In the Settings window for Distribution, locate the Boundary Selection section.

2 From the Selection list, choose Box: Boundaries above.

3 Locate the Distribution section. In the Number of elements text field, type ElemPerSpan.

4 Click Build All.

Add a parametric sweep to study the four load pulse scenarios.

S T U D Y  1

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 Click Add.

5 In the table, enter the following settings:

Step 1: Time Dependent
1 In the Model Builder window, under Study 1 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,SpanWidth/LoadSpeed/20,Tend).

Parameter name Parameter value list Parameter unit

LoadSpeed 20[m/s] CriticalSpeed 
CriticalSpeed CriticalSpeed

PulseSpacing TotLength*2 TotLength*2 
SpanWidth*2 SpanWidth
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4 Select the Relative tolerance check box.

5 In the associated text field, type 0.0001.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Time-Dependent Solver 1.

3 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

4 Locate the Time Stepping section. Select the Maximum step check box.

5 In the associated text field, type Tstep.

Set a reasonable scale for the displacements, so that the convergence checks in the solver 
will be appropriate.

6 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Dependent Variables 1 node, then click Displacement field (Material) (comp1.u).

7 In the Settings window for Field, locate the Scaling section.

8 In the Scale text field, type 1e-2.

Run the parametric sweep containing four time dependent studies.

9 On the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
1 In the Model Builder window, under Results click Stress (solid).

2 In the Settings window for 2D Plot Group, type Displacement in the Label text field.

Displacement
1 In the Model Builder window, expand the Results>Displacement node, then click Surface 

1.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type v.

4 Locate the Coloring and Style section. From the Color table list, choose Wave.

5 Select the Symmetrize color range check box.

6 In the Model Builder window, expand the Results>Displacement>Surface 1 node, then 
click Deformation.

7 In the Settings window for Deformation, locate the Scale section.
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8 Select the Scale factor check box.

9 In the associated text field, type 50.

Verify that the loads are as intended by displaying arrows.

10 In the Model Builder window, click Displacement.

11 In the Settings window for 2D Plot Group, type Displacement in the Label text field.

12 Right-click Displacement and choose Arrow Line.

13 In the Settings window for Arrow Line, type Load arrows in the Label text field.

14 Click Replace Expression in the upper-right corner of the Expression section. From the 
menu, choose Component 1>Solid Mechanics>Load>solid.FperLengthx,solid.FperLengthy - 

Load (Spatial).

15 Locate the Coloring and Style section. From the Arrow base list, choose Head.

16 In the Number of arrows text field, type 1000.

17 Select the Scale factor check box.

18 In the associated text field, type 1.5E-5.

19 Right-click Displacement and choose Arrow Surface.

Add a visualization of the supports.

20 In the Settings window for Arrow Surface, type Supports in the Label text field.

21 Locate the Expression section. In the X component text field, type 0.

22 In the Y component text field, type 1.

23 Locate the Arrow Positioning section. Find the X grid points subsection. From the Entry 

method list, choose Coordinates.

24 In the Coordinates text field, type range(0,SpanWidth,TotLength).

25 Find the Y grid points subsection. From the Entry method list, choose Coordinates.

26 In the Coordinates text field, type 0.

27 Locate the Coloring and Style section. From the Arrow type list, choose Cone.

28 From the Arrow base list, choose Head.

29 Select the Scale factor check box.

30 In the associated text field, type 2.

31 From the Color list, choose Black.

32 In the Model Builder window, click Displacement.

33 In the Settings window for 2D Plot Group, locate the Data section.

34 From the Time (s) list, choose 0.5296.
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35 On the Displacement toolbar, click Plot.

36 From the Parameter value (LoadSpeed (m/s),PulseSpacing (m)) list, choose 3: 

LoadSpeed=89.7 m/s, PulseSpacing=20 m.

37 On the Displacement toolbar, click Plot.

38 Click the Zoom Extents button on the Graphics toolbar.

Animate the four different cases.

39 Click Animation and choose Player.

Export
1 In the Model Builder window, under Results>Export click Animation 1.

2 In the Settings window for Animation, locate the Animation Editing section.

3 From the Parameter value (LoadSpeed (m/s),PulseSpacing (m)) list, choose 2: 

LoadSpeed=89.7 m/s, PulseSpacing=160 m.

4 Right-click Results>Export>Animation 1 and choose Play.

5 From the Parameter value (LoadSpeed (m/s),PulseSpacing (m)) list, choose 3: 

LoadSpeed=89.7 m/s, PulseSpacing=20 m.

6 Right-click Results>Export>Animation 1 and choose Play.

7 From the Parameter value (LoadSpeed (m/s),PulseSpacing (m)) list, choose 4: 

LoadSpeed=89.7 m/s, PulseSpacing=10 m.

8 Right-click Results>Export>Animation 1 and choose Play.

Create a point at the midpoint of the first span. This is where the vertical displacement 
will be compared between the four cases.

Cut Point 2D 1
On the Results toolbar, click Cut Point 2D.

Data Sets
1 In the Settings window for Cut Point 2D, locate the Point Data section.

2 In the X text field, type SpanWidth/2.

3 In the Y text field, type BeamHeight/2.

4 Locate the Data section. From the Data set list, choose Study 1/Parametric Solutions 1 

(sol2).

1D Plot Group 2
On the Results toolbar, click 1D Plot Group.
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Point Graph 1
On the 1D Plot Group 2 toolbar, click Point Graph.

1D Plot Group 2
1 In the Settings window for Point Graph, locate the Data section.

2 From the Data set list, choose Cut Point 2D 1.

3 Locate the y-Axis Data section. In the Expression text field, type v.

4 On the 1D Plot Group 2 toolbar, click Plot.

Since the time spans are different for different load speeds, it is more informative to 
study the results versus the position of the first load pulse.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type t*LoadSpeed.

7 Click to expand the Coloring and style section. Locate the Coloring and Style section. In 
the Width text field, type 2.

8 Find the Line markers subsection. From the Marker list, choose Cycle.

9 Click to expand the Legends section. Select the Show legends check box.

10 On the 1D Plot Group 2 toolbar, click Plot.

11 In the Model Builder window, click 1D Plot Group 2.

12 In the Settings window for 1D Plot Group, click to expand the Legend section.

13 From the Position list, choose Upper left.

14 Locate the Plot Settings section. Select the x-axis label check box.

15 In the associated text field, type Position of first load pulse [m].

16 On the 1D Plot Group 2 toolbar, click Plot.
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Introduction

This example simulates a tuning fork for tuning musical instruments and, if correctly 
design, should sound the note of A, 440 Hz. It computes the fundamental eigenfrequency 
and eigenmode for the tuning fork. Although the example seems to be somewhat 
academic in nature, the eigenfrequencies and eigenmodes of microscopic tuning forks are 
also used in quartz watches and other electronic devices.

Model Definition

The model geometry is shown in Figure 1. The fundamental frequency of the fork is 
determined by the length of the prongs, the cross-section geometry of the prongs, and the 
material properties of the fork.

Figure 1: Tuning fork geometry.

The following formula gives a theoretical estimation for the fundamental frequency of a 
tuning fork with cylindrical cross section of the prong (Ref. 1):

 (1)

where R2 is the radius of the cross section of the prongs, E denotes Young’s modulus, and 
ρ is the density. The length of the prong can be estimated as

 (2)

L 
R1

f
1.8752R2

4πLp
2
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ρ
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Lp L 1
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where R1 the radius of the base, and L is the length of the straight cylindrical part, see 
Figure 1.

In the fundamental eigenmode, the prongs move according to the figure below. Thus, the 
eigenmode is symmetric with a symmetry plane placed between the prongs.

The advantage with the shape of the fundamental eigenmode is that the relative 
displacements in the handle are very small, which makes it possible to hold the fork 
without damping the vibration. This also allows to make use of the theoretical estimation 
for the frequency Equation 1 which is based on the solution for a cantilever beam 
representing each prong.

The parameters used in the model are: R1 = 7.5 mm and R2 = 2.5 mm. The fork material 
is Steel AISI 4340, for which E = 205 GPa and ρ = 7850 kg/m3.

For the frequency f = 440 Hz, Equation 1 and Equation 2 give the length of the prong 
cylindrical part as L = 7.8 cm. This presents an underestimation because the part of the 
prong near the base has larger bending stiffness compared to that for a straight cantilever 
beam.

To fine-tune the fork, you will use parametrized geometry and gradually increase the 
cylinder length starting from the above given estimation. To achieve this, you set up a 
parametric sweep with respect to parameter L.

Reference

1. Tuning fork, http://en.wikipedia.org/wiki/Tuning_fork

Expected displacement of 
the prongs
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Application Library path: COMSOL_Multiphysics/Structural_Mechanics/
tuning_fork

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Eigenfrequency.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

You can build up the fork geometry efficiently using predefined geometry primitives.

Cone 1 (cone1)
1 On the Geometry toolbar, click Cone.

Name Expression Value Description

L 7.8[cm] 0.078 m Cylinder length

R1 7.5[mm] 0.0075 m Base radius

R2 2.5[mm] 0.0025 m Prong radius
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2 In the Settings window for Cone, locate the Size and Shape section.

3 In the Bottom radius text field, type R2.

4 In the Height text field, type 2e-2.

5 From the Specify top size using list, choose Angle.

6 In the Semi-angle text field, type 2.

7 Locate the Position section. In the x text field, type R1.

8 In the z text field, type -R1.

9 Locate the Axis section. From the Axis type list, choose Cartesian.

10 In the z text field, type -1.

Sphere 1 (sph1)
1 On the Geometry toolbar, click Sphere.

2 In the Settings window for Sphere, locate the Size section.

3 In the Radius text field, type 4e-3.

4 Locate the Position section. In the x text field, type R1.

5 In the z text field, type -(R1+2.25e-2).

Torus 1 (tor1)
1 On the Geometry toolbar, click Torus.

2 In the Settings window for Torus, locate the Size and Shape section.

3 In the Major radius text field, type R1.

4 In the Minor radius text field, type R2.

5 In the Revolution angle text field, type 180.

6 Locate the Position section. In the x text field, type R1.

7 Locate the Axis section. From the Axis type list, choose Cartesian.

8 In the z text field, type 0.

9 In the y text field, type 1.

10 Locate the Rotation Angle section. In the Rotation text field, type -90.

Union 1 (uni1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Union.

2 In the Settings window for Union, locate the Union section.

3 Clear the Keep interior boundaries check box.
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4 Click in the Graphics window and then press Ctrl+A to select all objects.

This completes the handle and base of the fork.

Add two cylinders to represent the prongs.

Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type R2.

4 In the Height text field, type L.

Cylinder 2 (cyl2)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type R2.

4 In the Height text field, type L.

5 Locate the Position section. In the x text field, type 2*R1.

Use virtual geometry operations to avoid short edges and narrow regions. This will 
improve the mesh generation.

Ignore Edges 1 (ige1)
1 On the Geometry toolbar, click Virtual Operations and choose Ignore Edges.

2 On the object fin, select Edges 22, 23, 29, 32, 33, 39, 42, and 43 only.

3 On the Geometry toolbar, click Build All.
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4 Click the Go to Default 3D View button on the Graphics toolbar.

The completed geometry should look as shown in the following figure:

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Steel AISI 4340.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Fine.

Free Triangular 1
1 Right-click Component 1 (comp1)>Mesh 1 and choose More Operations>Free Triangular.

2 Select Boundaries 6 and 24 only.

3 In the Settings window for Free Triangular, click Build Selected.

Swept 1
1 In the Model Builder window, right-click Mesh 1 and choose Swept.
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2 In the Settings window for Swept, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domains 1 and 3 only.

Distribution 1
1 Right-click Component 1 (comp1)>Mesh 1>Swept 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 50.

Swept 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Swept 1.

2 In the Settings window for Swept, click Build Selected.

3 In the Model Builder window, right-click Mesh 1 and choose Free Tetrahedral.

4 In the Settings window for Mesh, click Build All.

The meshed geometry should look like that in the figure below.

S T U D Y  1

Set up a parametric sweep with respect to the cylinder length L and search for an 
eigenfrequency in the vicinity of 440 Hz.

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.
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2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

Step 1: Eigenfrequency
1 In the Model Builder window, under Study 1 click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 Select the Desired number of eigenfrequencies check box.

4 In the associated text field, type 1.

5 In the Search for eigenfrequencies around text field, type 440.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node, then click Eigenvalue 

Solver 1.

3 In the Settings window for Eigenvalue Solver, locate the General section.

4 In the Relative tolerance text field, type 1e-3.

5 On the Study toolbar, click Compute.

R E S U L T S

Mode Shape (solid)
To see all computed eigenfrequencies as a table, follow these steps:

Global Evaluation 1
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Data section.

3 From the Data set list, choose Study 1/Parametric Solutions 1 (sol2).

4 From the Table columns list, choose Inner solutions.

5 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Solid Mechanics>Global>solid.freq - Frequency.

6 Click New Table.

Parameter name Parameter value list

L range(0.078,1e-4,0.0795)
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TA B L E

1 Go to the Table window.

You can see that the eigenfrequency closest to 440 Hz occurs for the cylinder length of 
0.0791 m. Further fine-tuning can be performed if necessary.

To see the eigenmode that corresponds to this frequency, do the following:

R E S U L T S

Mode Shape (solid)
1 In the Model Builder window, under Results click Mode Shape (solid).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Parameter value (L) list, choose 0.0791.

4 On the Mode Shape (solid) toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

In this figure, you can clearly see that mode is symmetric, and the displacements at the 
handle are very small compared to those of the prongs. This means that holding the 
tuning fork at the handle will dampen the vibrations negligibly.
10 |  TU N I N G  F O R K



Created in COMSOL Multiphysics 5.2a
S t r e s s e s  and S t r a i n s  i n  a  Wren ch
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


Introduction

This tutorial demonstrates how to set up a simple static structural analysis. The analysis is 
exemplified on a combination wrench during the application of torque on a bolt.

Despite its simplicity, and the fact that very few engineers would run a structural analysis 
before trying to turn a bolt, the example provides an excellent overview of structural 
analysis in COMSOL Multiphysics.

Model Definition

The model geometry is shown below.

The bolt’s fixed constraint is at the cross section shown below. A load is applied at the box 
end of the combination wrench.

Applied load

Fixed constraint
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Here, assume that there is perfect contact between the wrench and the bolt. A possible 
extension is to apply a contact condition between the wrench and the bolt where the 
friction and the contact pressure determines the position of the contact surface.

Application Library path: COMSOL_Multiphysics/Structural_Mechanics/wrench

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
wrench.mphbin.

5 Click Build All Objects.
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6 Click the Zoom Extents button on the Graphics toolbar.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Structural steel.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

F 150[N] 150 N Applied force
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S O L I D  M E C H A N I C S  ( S O L I D )

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Click the Wireframe Rendering button on the Graphics toolbar.

3 Select Boundary 35 only.

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundary 111 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 From the Load type list, choose Total force.

5 Specify the Ftot vector as

The minus sign means that the force is applied downwards.

M E S H  1

Use finer mesh because the geometry contains small edges and faces.

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Finer.

4 Click Build All.

S T U D Y  1

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 1 node.

4 Right-click Study 1>Solver Configurations>Solution 1 (sol1)>Stationary Solver 1 and 
choose Iterative.

5 In the Settings window for Iterative, locate the General section.

0 x

0 y

-F z
5 |  S T R E S S E S  A N D  S T R A I N S  I N  A  W R E N C H



6 From the Preconditioning list, choose Right.

7 Right-click Study 1>Solver Configurations>Solution 1 (sol1)>Stationary Solver 1>Iterative 

1 and choose Multigrid.

8 On the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
The default plot group shows the von Mises stress in a Surface plot with the displacement 
visualized using a Deformation subnode. Change to a more suitable unit as follows.

Surface 1
1 In the Model Builder window, expand the Stress (solid) node, then click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose MPa.

4 On the Stress (solid) toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

3D Plot Group 2
On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

Surface 1
1 In the Model Builder window, right-click 3D Plot Group 2 and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Solid Mechanics>

Strain>Principal strains>solid.ep1 - First principal strain.

3 On the 3D Plot Group 2 toolbar, click Plot.

3D Plot Group 2
1 In the Model Builder window, under Results right-click 3D Plot Group 2 and choose 

Rename.

2 In the Rename 3D Plot Group dialog box, type First Principal Strain in the New 

label text field.
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3 Click OK.

Notice that the maximum principal strain is lower than 2%, a result that satisfies the 
small strain assumption.
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