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Introduction

Cars need a brakes for obvious reasons, and you do not want these to fail. Brake failure can 
be caused by many things, one of which is the overheating of the brake’s disc. This example 
models the heat generation and dissipation in a disc brake of an ordinary car during panic 
braking and the following release period. When the driver is pressing down on the brakes, 
kinetic energy is transformed into thermal energy. If the brake discs overheat, the brake 
pads cease to function through brake fade where the material properties of the brake 
change due to the temperature overload. Braking power starts to fade already at 
temperatures above 600 K. This is why it is so important during the design-stages to 
simulate the transient heating and convective cooling to figure out what the minimum 
interval between a series of brake engagements is.

In this application, an 1,800 kg car is traveling at 25 m/s (90 km/h or about 56 mph), 
until the driver suddenly panic brakes for 2 seconds. At that point the eight brake pads slow 
the car down at a rate of 10 m/s2 (assuming the wheels do not skid against the road). 
Upon braking for two seconds the driver releases the brake, leaving the car traveling at 
5 m/s for eight seconds without engaging the brakes. The questions to analyze with the 
model are:

• How hot do the brake discs and pads get when the brake is engaged?

• How much do the discs and pads cool down during the rest that follows the braking?
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Model Definition

Model the brake disc as a 3D solid with shape and dimensions as in Figure 1. The disc has 
a radius of 0.14 m and a thickness of 0.013 m.

Figure 1: Model geometry, including disc and pad.

The model also includes heat conduction in the disc and the pad through the transient heat 
transfer equation. The heat dissipation from the disc and pad surfaces to the surrounding 
air is described by both convection and radiation. Table 1 summarizes the thermal 
properties of the materials used in this application (Ref. 1).

After 2 s, contact is made at the interface between the disc and the pad. Neglecting drag 
and other losses outside the brakes, the brakes’ retardation power is given by the negative 
of the time derivative of the car’s kinetic energy:

TABLE 1:  MATERIAL PROPERTIES

PROPERTY DESCRIPTION DISC PAD AIR

ρ (kg/m3) Density 7870 2000 1.170

Cp (J/(kg·K)) Heat capacity at constant pressure 449 935 1100

k (W/(m·K)) Thermal conductivity 82 8.7 0.026

ε Surface emissivity 0.28 0.8 -
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Here m is the car’s mass (1800 kg) and v denotes its speed. Figure 2 shows the profile of 
v and Figure 3 shows the corresponding acceleration profile.

Figure 2: Velocity profile of the disc.
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Figure 3: Acceleration profile of the disc.

At one of the eight brakes, the frictional heat source is:

The contact pressure between the disc and the pad is related to the frictional heat source 
per unit area, Pb, according to:

where the friction coefficient μ is here equal to 0.3.

The disc and pad dissipate the heat produced at the boundary between the brake pad and 
the disc by convection and radiation. This example models the rotation as convection in 
the disc. The local disc velocity vector is

At the end of the computation, produced and dissipated heat can be recovered using the 
relations
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 (1)

Results and Discussion

The surface temperatures of the disc and the pad vary with both time and position. At the 
contact surface between the pad and the disc the temperature increases when the brake is 
engaged and then decreases again as the brake is released. You can best see these results in 
COMSOL Multiphysics by generating an animation. Figure 4 displays the surface 
temperatures just before the end of the braking. A “hot spot” is visible at the contact 
between the brake pad and disc, just at the pad’s edge. This is the area that could overheat 
to the point of brake failure or fade. The figure also shows the temperature decreasing 
along the rotational trace after the pad. During the rest, the temperature becomes 
significantly lower and more uniform in the disc and the pad.

Figure 4: Surface temperature of the brake disc and pad just before releasing the brake 
(t = 3.8 s).
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To investigate the position of the hot spot and the time of the temperature maximum, it 
is helpful to plot temperature versus time along the line from the center to the pad’s edge 
shown in Figure 5. The result is displayed in Figure 6. You can see that the maximum 
temperature is approximately 430 K. The hot spot is positioned close to the radially outer 
edge of the pad. The highest temperature occurs approximately 1 s after engaging the 
brake.
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Figure 5: The radial line probed in the temperature vs. time plot in Figure 6.

Figure 6: Temperature profile along the line indicated in Figure 5 at the disc surface 

r (m)
t
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(z = 0.013 m) as a function of time.

To investigate how much of the generated heat is dissipated to the air, study the surface 
integrals of the produced heat and the dissipated heat. These integrals give the total heat 
rate (W) for heat production, Qprod, and heat dissipation, Qdiss, as functions of time for 
the brake disc. The time integrals of these two quantities, Wprod and Wdiss, give the total 
heat (J) produced and dissipated, respectively, in the brake disc. Figure 7 shows a plot of 
the total produced heat and dissipated heat versus time. Eight seconds after the driver has 
stopped braking, a mere fraction of the produced heat has dissipated. In other words, in 
order to cool down the system sufficiently the brake needs to remain disengaged for a lot 
longer period than these eight seconds (100 seconds, in fact).

Figure 7: Comparison of total produced heat (solid line) and dissipated heat (dashed).

The results of this application can help engineers investigate how much abuse, in terms of 
specific braking sequences, a certain brake-disc design can tolerate before overheating. It 
is also possible to vary the parameters affecting the heat dissipation and investigate their 
influence.
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Reference

1. J.M. Coulson and J.F. Richardson, Chemical Engineering, vol. 1, eq. 9.88; material 
properties from appendix A2.

Application Library path: Heat_Transfer_Module/
Thermal_Contact_and_Friction/brake_disc

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Define the global parameters by loading the corresponding text file provided.

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
brake_disc_parameters.txt.
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G E O M E T R Y  1

Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type 0.14.

4 In the Height text field, type 0.013.

5 On the Geometry toolbar, click Build All.

Cylinder 2 (cyl2)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type 0.08.

4 In the Height text field, type 0.01.

5 Locate the Position section. In the z text field, type 0.013.

6 On the Geometry toolbar, click Build All.

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, locate the Plane Definition section.

3 In the z-coordinate text field, type 0.013.

4 Click Show Work Plane.

Bézier Polygon 1 (b1)
1 On the Work Plane toolbar, click Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the Polygon Segments section.

3 Find the Added segments subsection. Click Add Cubic.

4 Find the Control points subsection. In row 1, set yw to 0.135.

5 In row 2, set xw to 0.02, and yw to 0.135.

6 In row 3, set xw to 0.05, and yw to 0.13.

7 In row 4, set xw to 0.04, and yw to 0.105.

8 Find the Added segments subsection. Click Add Cubic.

9 Find the Control points subsection. In row 2, set xw to 0.03, and yw to 0.08.

10 In row 3, set xw to 0.035, and yw to 0.09.

11 In row 4, set xw to 0, and yw to 0.09.
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12 Find the Added segments subsection. Click Add Cubic.

13 Find the Control points subsection. In row 2, set xw to -0.035.

14 In row 3, set xw to -0.03, and yw to 0.08.

15 In row 4, set xw to -0.04, and yw to 0.105.

16 Find the Added segments subsection. Click Add Cubic.

17 Find the Control points subsection. In row 2, set xw to -0.05, and yw to 0.13.

18 In row 3, set xw to -0.02, and yw to 0.135.

19 Click Close Curve.

To complete the pad cross section, you must make the top-left and top-right corners 
sharper. Do so by changing the weights of the Bézier curves.

20 Find the Added segments subsection. In the Added segments list, select Segment 1 (cubic).

21 Find the Weights subsection. In the 3 text field, type 2.5.

22 Find the Added segments subsection. In the Added segments list, select Segment 4 (cubic).

23 Find the Weights subsection. In the 2 text field, type 2.5.

24 On the Work Plane toolbar, click Build All.

Work Plane 1 (wp1)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Work Plane 1 

(wp1).

Extrude 1 (ext1)
1 On the Geometry toolbar, click Extrude.

2 In the Settings window for Extrude, locate the Distances from Plane section.

3 In the table, enter the following settings:

Distances (m)

0.0065
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4 On the Geometry toolbar, click Build All.

The model geometry is now complete.

Next, define some selections of certain boundaries. You will use them when defining the 
settings for component couplings, boundary conditions, and so on.

D E F I N I T I O N S

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Disc Faces in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 1, 2, 4–6, 8, 13–15, and 18 only.

Explicit 2
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Pad Faces in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 9, 10, 12, 16, and 17 only.

Explicit 3
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Contact Faces in the Label text field.
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3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

To select the contact surface boundary, it is convenient to temporarily switch to 
wireframe rendering.

4 Click the Wireframe Rendering button on the Graphics toolbar.

5 Select Boundary 11 only.

6 Click the Wireframe Rendering button on the Graphics toolbar again to return to the 
original state.

Explicit 4
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type External Surfaces in the Label text field.

3 Locate the Input Entities section. Select the All domains check box.

4 Locate the Output Entities section. From the Output entities list, choose Adjacent 

boundaries.

These instructions make you select the external boundaries of the wheel and the pad.

Integration 1 (intop1)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Contact Faces.

Integration 2 (intop2)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose External Surfaces.

Now, define the velocity and acceleration of the car through these two piecewise and 
analytic functions.

Piecewise 1 (pw1)
1 On the Definitions toolbar, click Piecewise.

2 In the Settings window for Piecewise, type v in the Function name text field.

3 Locate the Definition section. In the Argument text field, type t.

4 From the Smoothing list, choose Continuous second derivative.

5 From the Transition zone list, choose Absolute size.
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6 In the Size of transition zone text field, type 0.2.

The function definition expects nondimensional quantities for the interval starts and 
ends, and the function values. The function definition below uses unit conversions to 
do so.

7 Find the Intervals subsection. In the table, enter the following settings:

8 Locate the Units section. In the Arguments text field, type s.

9 In the Function text field, type m/s.

10 Click Plot.

Analytic 1 (an1)
1 On the Definitions toolbar, click Analytic.

2 In the Settings window for Analytic, type a in the Function name text field.

3 Locate the Definition section. In the Expression text field, type d(v(t),t).

Start End Function

0 t_brake_start[1/s] v0[s/m]

t_brake_start[1/s] t_brake_end[1/s] v0[s/m]+a0*
(t[s]-t_brake_start)[s/
m]

t_brake_end[1/s] 12 v0[s/m]+a0*
(t_brake_end-t_brake_st
art)[s/m]
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4 In the Arguments text field, type t.

5 Locate the Units section. In the Arguments text field, type s.

6 In the Function text field, type m/s^2.

7 Locate the Plot Parameters section. In the table, enter the following settings:

8 Click Plot.

M A T E R I A L S

Material 1 (mat1)
1 On the Materials toolbar, click Blank Material.

2 In the Settings window for Material, type Disc in the Label text field.

3 Locate the Material Contents section. In the table, enter the following settings:

Argument Lower limit Upper limit

t 0 10

Property Name Value Unit Property 
group

Thermal conductivity k 82 W/(m·K) Basic

Density rho 7870 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 449 J/(kg·K) Basic
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Material 2 (mat2)
1 On the Materials toolbar, click Blank Material.

2 In the Settings window for Material, type Pad in the Label text field.

3 Select Domain 3 only.

4 Locate the Material Contents section. In the table, enter the following settings:

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Solid 1
In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) click 
Solid 1.

Translational Motion 1
1 On the Physics toolbar, click Attributes and choose Translational Motion.

2 Select Domains 1 and 2 only.

3 In the Settings window for Translational Motion, locate the Translational Motion section.

4 Specify the utrans vector as

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 From the Heat transfer coefficient list, choose External forced convection.

6 In the L text field, type 0.14.

7 In the U text field, type v(t).

Property Name Value Unit Property 
group

Thermal conductivity k 8.7 W/(m·K) Basic

Density rho 2000 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 935 J/(kg·K) Basic

-y*v(t)/r_wheel x

x*v(t)/r_wheel y

0 z
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8 In the Text text field, type T_air.

Thermal Contact 1
1 On the Physics toolbar, click Boundaries and choose Thermal Contact.

2 Select Boundary 11 only.

3 In the Settings window for Thermal Contact, locate the Contact Surface Properties 
section.

4 In the p text field, type ht.tc1.Qb/(mu*v(t)).

5 In the Hc text field, type 800[MPa].

6 Locate the Thermal Friction section. Click the Heat rate button.

7 In the Pb text field, type -m_car*v(t)*a(t)/8.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, type T_air in the T text field.

Diffuse Surface 1
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 In the Settings window for Diffuse Surface, locate the Boundary Selection section.

3 From the Selection list, choose Disc Faces.

4 Locate the Surface Emissivity section. From the ε list, choose User defined. In the 
associated text field, type 0.28.

5 Locate the Ambient section. In the Tamb text field, type T_air.

Diffuse Surface 2
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 In the Settings window for Diffuse Surface, locate the Boundary Selection section.

3 From the Selection list, choose Pad Faces.

4 Locate the Surface Emissivity section. From the ε list, choose User defined. In the 
associated text field, type 0.8.

5 Locate the Ambient section. In the Tamb text field, type T_air.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.
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2 Select Boundary 3 only.

To compute the produced dissipated heats, integrate the corresponding heat rate 
variables, Q_prod and Q_diss, over time. For this purpose, define two ODEs using a 
Global Equations node.

3 In the Model Builder window’s toolbar, click the Show button and select Advanced Physics 

Options in the menu.

Global Equations 1
1 On the Physics toolbar, click Global and choose Global Equations.

2 In the Settings window for Global Equations, locate the Units section.

3 Find the Dependent variable quantity subsection. From the list, choose Energy (J).

4 Find the Source term quantity subsection. From the list, choose Power (W).

5 Locate the Global Equations section. In the table, enter the following settings:

Here, W_prodt (resp. W_disst) is COMSOL Multiphysics syntax for the time derivative 
of W_prod (resp. W_diss). The quantities intop1(ht.tc1.Qb) and intop2(ht.q0+
ht.rflux) correspond to Q_prod and Q_diss. The table thus defines the first-order 
ODEs corresponding to Equation 1, so that W_prod and W_diss host the produced and 
dissipated heats. The initial values follow from setting t = 0.

M E S H  1

On the Mesh toolbar, click Boundary and choose Free Triangular.

Free Triangular 1
1 Click the Transparency button on the Graphics toolbar.

2 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Free Triangular 1.

3 Select Boundaries 4, 7, and 11 only.

4 Click the Transparency button on the Graphics toolbar again to return to the original 
state.

Name f(u,ut,utt,t) 
(W)

Initial value 
(u_0) (J)

Initial value 
(u_t0) (W)

Description

W_prod W_prodt-int
op1(ht.tc1.
Qb)

0 0 Produced heat

W_diss W_disst+
(intop2(ht.
q0+
ht.rflux))

0 0 Dissipated heat
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Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Extra fine.

4 On the Mesh toolbar, click Swept.

Swept 1
Click Distribution.

Distribution 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1>Swept 1 click 

Distribution 1.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 2.

4 In the Model Builder window, click Mesh 1.

5 In the Settings window for Mesh, click Build All.

The complete mesh consists of roughly 5,700 elements.
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S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,0.5,1.5) range(1.55,0.05,3) range(3.2,
0.2,5) range(6,1,12).

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Study 1>Solver Configurations node.

3 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Time-Dependent Solver 1.

4 In the Settings window for Time-Dependent Solver, click to expand the Absolute 

tolerance section.

5 Locate the Absolute Tolerance section. In the Tolerance text field, type 1e-4.

6 Click to expand the Time stepping section. Locate the Time Stepping section. From the 
Steps taken by solver list, choose Intermediate.

This setting forces the solver to take at least one step in each specified interval.

7 On the Study toolbar, click Compute.

R E S U L T S

Temperature (ht)
The first of the two default plots displays the surface temperature of the brake disc and pad 
at the end of the simulation interval. Modify this plot to show the time just before releasing 
the brake.

1 In the Model Builder window, click Temperature (ht).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Time (s) list, choose 3.8.

4 On the Temperature (ht) toolbar, click Plot.

Compare the result to the plot shown in Figure 4.

To compare the total produced heat and the dissipated heat, as done in Figure 7, follow 
the steps given below.
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1D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Dissipated and Produced Heats in 
the Label text field.

3 Click to expand the Title section. From the Title type list, choose None.

4 Click to collapse the Title section. Locate the Plot Settings section. Select the x-axis label 
check box.

5 In the associated text field, type Time (s).

Point Graph 1
1 On the Dissipated and Produced Heats toolbar, click Point Graph.

2 Select Point 1 only.

3 In the Settings window for Point Graph, locate the y-Axis Data section.

4 In the Expression text field, type log10(W_prod+1).

5 Click to expand the Coloring and style section. Locate the Coloring and Style section. 
From the Color list, choose Blue.

6 Click to expand the Legends section. Select the Show legends check box.

7 From the Legends list, choose Manual.

8 In the table, enter the following settings:

Point Graph 2
1 Right-click Point Graph 1 and choose Duplicate.

2 In the Settings window for Point Graph, locate the y-Axis Data section.

3 In the Expression text field, type log10(W_diss+1).

4 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose Dashed.

5 Locate the Legends section. In the table, enter the following settings:

Dissipated and Produced Heats
Finally, follow the steps below to reproduce the plot in Figure 6.

Legends

log10(W_prod+1), produced heat

Legends

log10(W_diss+1), dissipated heat
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Cut Line 3D 1
1 On the Results toolbar, click Cut Line 3D.

2 In the Settings window for Cut Line 3D, locate the Line Data section.

3 In row Point 1, set z to 0.013.

4 In row Point 2, set x to -0.047, y to 0.1316, and z to 0.013.

5 Click Plot.

Parametric Extrusion 1D 1
1 On the Results toolbar, click More Data Sets and choose Parametric Extrusion 1D.

2 In the Settings window for Parametric Extrusion 1D, locate the Data section.

3 From the Time selection list, choose From list.

4 Click and shift-click in the list to select all time steps from 1.5 s through 5 s.

2D Plot Group 4
1 On the Results toolbar, click 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Temperature Profile vs Time in 
the Label text field.

Surface 1
1 Right-click Temperature Profile vs Time and choose Surface.

2 In the Settings window for Surface, locate the Coloring and Style section.

3 From the Color table list, choose ThermalLight.
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4 Right-click Results>Temperature Profile vs Time>Surface 1 and choose Height Expression.

Height Expression 1
On the Temperature Profile vs Time toolbar, click Plot.
24 |  H E A T  G E N E R A T I O N  I N  A  D I S C  B R A K E



Created in COMSOL Multiphysics 5.2a
Buoyan c y  F l ow i n  Wa t e r
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


Introduction

This example studies the stationary state of free convection in a cavity filled with water and 
bounded by two vertical plates. To generate the buoyancy flow, the plates are heated at 
different temperatures, bringing the regime close to the transition between laminar and 
turbulent.

An important step in setting up a convection model is to assess whether the flow stays 
laminar or becomes turbulent. It is also important to approximate how fine should be the 
mesh needed to resolve velocity and temperature gradients. Both of these approximations 
rely on the velocity scale of the model. This makes the set-up of natural convection 
problems challenging since the resulting velocity is part of the nonlinear solution. There 
are, however, tools to approximate scales for natural convection problems. These tools are 
demonstrated in this application using simple 2D and 3D geometries.

A first 2D model representing a square cavity (see Figure 1) focuses on the convective flow.

Figure 1: Domain geometry and boundary conditions for the 2D model (square cavity).

Thermal insulation

Thermal insulation

Pressure point 
constraint (0 Pa)

Hot temperature (20 °C) 
on the right plate

Square side length (10 cm)

Cold temperature (10 °C) 
on the left plate

Water
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The 3D model (see Figure 2) extends the geometry to a cube. Compared to the 2D 
model, the front and back sides are additional boundaries that may influence the fluid 
behavior.

Figure 2: Domain geometry and boundary conditions for the 3D model (cubic cavity).

Both models calculate and compare the velocity field and the temperature field. The 
predefined Non-Isothermal Flow interface available in the Heat Transfer Module provides 
appropriate tools to fully couple the heat transfer and the fluid dynamics.

Model Definition

2 D  M O D E L

Figure 1 illustrates the 2D model geometry. The fluid fills a square cavity with 
impermeable walls, so the fluid flows freely within the cavity but cannot leak out. The right 
and left edges of the cavity are maintained at high and low temperatures, respectively. The 
upper and lower boundaries are insulated. The temperature differential produces the 
density variation that drives the buoyant flow.

The compressible Navier-Stokes equation contains a buoyancy term on the right-hand side 
to account for the lifting force due to thermal expansion that causes the density variations:

Water

Hot temperature (20 °C) 
on the right plate

Cold temperature (10 °C) 
on the left plate

Pressure point 
constraint (0 Pa)

Cube side length (10 cm)

ρ u ∇⋅( )u ∇p ∇+ μ ∇u ∇u( )T
+( )⋅–=

2
3
--- μ ∇ u⋅( )( )∇– ρg+
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In this expression, the dependent variables for flow are the fluid velocity vector, u, and the 
pressure, p. The constant g denotes the gravitational acceleration, ρ gives the 
temperature-dependent density, and μ is the temperature-dependent dynamic viscosity.

Because the model only contains information about the pressure gradient, it estimates the 
pressure field up to a constant. To define this constant, you arbitrarily fix the pressure at a 
point. No slip boundary conditions apply on all boundaries. The no slip condition results 
in zero velocity at the wall but does not set any constraint on p.

At steady-state, the heat balance for a fluid reduces to the following equation:

Here T represents the temperature, k denotes the thermal conductivity, and Cp is the 
specific heat capacity of the fluid.

The boundary conditions for the heat transfer interface are the fixed high and low 
temperatures on the vertical walls with insulation conditions elsewhere, as shown in 
Figure 1.

3 D  M O D E L

Figure 2 shows the geometry and boundary conditions of the 3D model. The cavity is now 
a cube with high and low temperatures applied respectively at the right and left surfaces. 
The remaining boundaries (top, bottom, front, and back) are thermally insulated.

M O D E L  A N A L Y S I S

Before starting the simulations, it is recommended to estimate the flow regime. To this 
end, four indicators are presented: the Reynolds, Grashof, Rayleigh, and Prandtl numbers. 
They are calculated using the thermophysical properties of water listed in Table 1. The 
thermophysical properties are given at 290 K which is in the range of the temperatures 
observed in the model.

TABLE 1:  THERMOPHYSICAL PROPERTIES FOR WATER AT 290 K

PARAMETER DESCRIPTION VALUE

ρ Density 999 kg/m3

μ Dynamic viscosity 1.08·10-3 N·s/m2

k Thermal conductivity 0.60 W/(m·K)

Cp Heat capacity at constant pressure 4.18 kJ/(kg·K)

αp Coefficient of thermal expansion 0.17·10-3 K-1

ρCpu ∇T⋅ ∇– k T∇( )⋅ 0=
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Prandtl Number

Definition The Prandtl number is the ratio of fluid viscosity to thermal diffusivity. It is 
defined by:

For air at 300 K, Pr = 0.71 (see, for example, A.4 in Ref. 1) and for water at 300 K, 
Pr = 5.8 (see, for example, A.6 in Ref. 1).

Boundary Layers The Prandtl number also indicates the relative thickness of the outer 
boundary layer, δ, and the thermal boundary layer, δT. In the present case, it is reasonable 
to estimate the ratio δ ⁄ δT by the relation (7.32 in Ref. 2)

 (1)

The outer boundary layer is the distance from the wall to the region where the fluid 
stabilizes. It is different from the momentum boundary layer, δM, which measures the 
distance from the wall to the velocity peak.

Application in this Tutorial With the values given in Table 1, the Prandtl number for water 
at 290 K, is found to be of the order 1 or 10. According to Equation 1, δ and δT should 
then be of same order of magnitude.

Reynolds Number

Definition The Reynolds number estimates the ratio of inertial forces to viscous forces. It 
is defined by the formula

where U denotes the typical velocity and L the typical length.

At atmospheric pressure and at 300 K, air and water have the following properties (A.4 
and A.6 in Ref. 1).

TABLE 2:  THERMOPHYSICAL PROPERTIES OF AIR AND WATER AT 300 K AND ATMOSPHERIC PRESSURE

PARAMETER DESCRIPTION AIR WATER

ρ Density 1.16 kg/m3 997 kg/m3

μ Dynamic viscosity 1.85·10-5 N·s/m2 8.55·10-4 N·s/m2

Pr
μCp

k
-----------=

δ
δT
------ Pr=

Re ρUL
μ

------------=
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You can thus approximate the Reynolds number by:

In these relations, U has to be in meters per second and L in meters.

The Reynolds number can be rewritten as the velocity ratio

which compares U to μ ⁄ (ρL). The latter quantity is homogeneous to a velocity and can 
be seen as the typical velocity due to viscous forces.

Flow Regime The value of the Reynolds number is used to predict the flow regime. 
Generally, low values of Re correspond to laminar flow and high values to turbulent flow, 
with a critical value for the transition regime that depends on the geometry.

As an indication, Reynolds’ experiments concerning the flow along a straight and smooth 
pipe showed that the transition regime in this case occurs when Re is between 2000 and 
104 (see chapter 1.3 in Ref. 3).

Momentum Boundary Layer The momentum boundary layer thickness can be evaluated, 
using the Reynolds number, by (5.36 in Ref. 2)

 (2)

Application in this Tutorial The typical length L of the model is equal to 10 cm so the 
Reynolds number is evaluated as

where U is still unknown. Estimates of this typical velocity are provided later.

Grashof Number

Definition The Grashof number gives the ratio of buoyant to viscous forces. It is defined 
by

Reair 6 104UL⋅≈ Rewater 106UL≈

Re U
μ ρL( )⁄
-------------------=

δM
L
Re

-----------≈

Re 105U≈

Gr
ρ2gαp

μ2
----------------ΔTL3

=
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where g is the gravity acceleration (equal to 9.81 m.s-2) and ΔT is the typical temperature 
difference.

At atmospheric pressure and at 300 K, air and water have the following properties (A.4 
and A.6 in Ref. 1).

The value of αp for air was here obtained by the ideal gas approximation:

You can then evaluate the Grashof number by:

In these relations, ΔT is given in kelvin and L in meters.

The Grashof number can also be expressed as the velocity ratio

where U0 is defined by

 (3)

This quantity can be considered as the typical velocity due to buoyancy forces.

Flow Regime When buoyancy forces are large compared to viscous forces, the regime is 
turbulent; otherwise it is laminar. The transition between these two regimes is indicated 
by the critical order of the Grashof number which is 109 (see Figure 7.7 in Ref. 2).

Application in this Tutorial In this tutorial, ΔT is equal to 10 K so the Grashof number is 
about 107 which indicates that a laminar regime is expected.

TABLE 3:  THERMOPHYSICAL PROPERTIES OF AIR AND WATER AT 300 K AND ATMOSPHERIC PRESSURE

Parameter Description Air Water

ρ Density 1.16 kg/m3 997 kg/m3

μ Dynamic viscosity 1.85·10-5 N.s.m-2 8.55·10-4 N·s/m2

αp Coefficient of thermal expansion 3.34·10-3 K-1 2.76·10-4 K-1

αp
1
T
----=

Grair 108ΔTL3≈ Grwater 4 10⋅ 9ΔTL3≈

Gr
U0

2

μ ρL( )⁄( )2
---------------------------=

U0 gαpΔTL=
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Table 4 provides the values of the quantities necessary to calculate U0. This velocity is here 
of order 10 mm/s.

Rayleigh Number

Definition The Rayleigh number is another indicator of the regime. It is defined by

so it is similar to the Grashof number except that it accounts for the thermal diffusivity, k, 
given by

Note: The Rayleigh number can be expressed in terms of the Prandtl and the Grashof 
numbers through the relation Ra = PrGr.

At atmospheric pressure and at 300 K, you can use the approximations of Ra below for air 
and water (A.4 in Ref. 1)

In these relations, ΔT is given in kelvin and L in meters.

Using Equation 3, the Rayleigh number can be rewritten as the velocity ratio

where the ratio κ ⁄ L can be seen as a typical velocity due to thermal diffusion.

Flow Regime Like the Grashof number, a critical Rayleigh value indicates the transition 
between laminar and turbulent flow. For vertical plates, this limit is about 109 (9.23 in Ref. 

TABLE 4:  THERMOPHYSICAL PROPERTIES OF WATER AT 290 K USED IN THE GRASHOF NUMBER

PARAMETER DESCRIPTION VALUE

g Gravitational acceleration 9.81 m/s2

αp Coefficient of thermal expansion 0.17·10-3 K-1

Ra
ρ2gαpCp

μk
------------------------ΔTL3

=

κ k
ρCp
----------=

Raair 108ΔTL3≈ Rawater 2 1010ΔTL3⋅≈

Ra
U0

2

ν L⁄( ) κ L⁄( )
--------------------------------=
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1).

Typical Velocity Because the viscous forces limit the effects of buoyancy, U0 may give an 
overestimated typical velocity. Another approach (see 7.25 in Ref. 2) is to use U1 instead, 
defined by

that is

 (4)

or

This should be a more accurate estimate of U because the fluid’s thermal diffusivity and 
viscosity are used in the calculations. From now on, U1 is the preferred estimate of U.

Thermal Boundary Layer The Rayleigh number can be used to estimate the thermal 
boundary layer thickness, δT. When Pr is of order 1 or greater, it is approximated by the 
formula (7.25c in Ref. 2)

 (5)

Application in this Tutorial Here, Ra is of order 108. The laminar regime is confirmed but 
the Rayleigh number found is near the transition zone. The thermal boundary layer 
thickness is then found to be of order 1 mm and U1 of order 10 mm/s.

Synthesis
To prepare the simulation, it is very useful to follow the steps below that give indications 
of what results to expect. It is important to remember that the quantities computed here 
are only order of magnitude estimates, which should not be considered with more than 
one significant digit.

First evaluate the Grashof and Rayleigh numbers. If they are significantly below the critical 
order of 109, the regime is laminar. In this case, Equation 3 or Equation 4 provide 

U1
κ
L
---- Ra=

U1
k

ρCpL
--------------- Ra=

U1
U0

Pr
----------=

δT
L

Ra4
------------≈
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estimates of the typical velocity U that you can use to validate the model after performing 
the simulation.

According to Equation 1, the Prandtl number determines the relative thickness of the 
thermal boundary layer and the outer layer. Equation 2 and Equation 5 then provide 
orders of magnitude of the thicknesses. When defining the mesh, refinements have to be 
done at the boundary layers by, for instance, inserting three to five elements across the 
estimated thicknesses.

Here, Gr and Ra are 107 and 108, respectively, and thus below the critical value of 109 
for vertical plates. A laminar regime is therefore expected but because these values are not 
significantly below 109, convergence is not straightforward. In this regime, the estimates 
U0 and U1 of the typical velocity are both of the order 10 mm/s.

For water at 290 K, Pr is about 10 so δ and δT are of same orders of magnitude. Here, δT 
is of the order 1 mm.

The Reynolds number calculated with U1 is about 103, which confirms that the model is 
close to the transition regime. Using U1 and Equation 2, the momentum boundary layer 
thickness δM is found to be about 1 mm.
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Results and Discussion

2 D  M O D E L

Figure 3 shows the velocity distribution in the square cavity.

Figure 3: Velocity magnitude for the 2D model.

The regions with faster velocities are located at the lateral boundaries. The maximum 
velocity is 4.20 mm/s which is in agreement with the estimated typical velocity U1 of the 
order 10 mm/s. According to Figure 4, the momentum boundary layer thickness is of 
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order 1 mm, as calculated before.

Figure 4: Velocity profile at the left boundary.
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Figure 5 shows the temperature field (surface) and velocity field (arrows) of the 2D model.

Figure 5: Temperature field (surface plot) and velocity (arrows) for the 2D model.

A large convective cell occupies the whole square. The fluid flow follows the boundaries. 
As seen in Figure 3, it is faster at the vertical plates where the highest variations of 
temperature are located. The thermal boundary layer is of the order 1 mm according to 
Figure 6, which is in agreement with the estimate provided by Equation 5. The outer layer 
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is slightly thicker than the boundary layer.

Figure 6: Temperature profile at the left boundary.
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Figure 7 shows the correlation between density and temperature.

Figure 7: Water density for the 2D model.

As expected, ρ has the same profile as the temperature field. High variations are located at 
the boundaries, especially at lateral walls, and are responsible for the free convection. The 
variations are smoother at the center.
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3 D  M O D E L

Figure 8 illustrates the velocity plot parallel to the heated plates.

Figure 8: Velocity magnitude field for the 3D model, slices parallel to the heated plates.
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A second velocity magnitude field is shown in Figure 9. The plot is close to what was 
obtained in 2D in Figure 3.

Figure 9: Velocity magnitude field for the 3D model, slices perpendicular to the heated plates.
17 |  B U O Y A N C Y  F L O W  I N  W A T E R



In Figure 10, velocity arrows are plotted on temperature surface at the middle vertical 
plane parallel to the plates.

Figure 10: Temperature (surface plot) and velocity (arrows) fields in the cubic cavity, for a 
temperature difference of 10 K between the vertical plates.

New small convective cells appear on the vertical planes perpendicular to the plates at the 
four corners. They are more visible at lower Gr values, that is, far from the transition 
regime. In Figure 11, the temperature difference between the vertical plates is reduced to 
1 K and 0.1 K to decrease the Grashof number to 105 and 106.
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Observe the bigger cells at the four corners of the plane.

Figure 11: Temperature (surface plot) and velocity (arrows) fields in the cubic cavity, with, 
for a temperature difference of 1 K (top) and 0.1 K (bottom) between the vertical plates.
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Notes About the COMSOL Implementation

The material properties for water are available in the Material Library. The density and 
dynamic viscosity are functions of the temperature.

At high Gr values, using a good initial condition becomes important in order to achieve 
convergence. Moreover, a well-tuned mesh is needed to capture the solution, especially 
the temperature and velocity changes near the walls. Use the Stationary study step’s 
continuation option with ΔT as the continuation parameter to get a solver sequence that 
uses previous solutions to estimate the initial condition. For this tutorial, it is appropriate 
to ramp up ΔT from 10-3 K to 10 K, which corresponds to a Grashof number range of 
103–107. At Gr = 103, the model is easy to solve. The regime is dominated by conduction 
and viscous effects. At Gr = 107, the model becomes more difficult to solve. The regime 
is greatly influenced by convection and buoyancy.

To get a well-tuned mesh when Gr reaches 107, the element size near the prescribed 
temperature boundaries has to be smaller than the momentum and thermal boundary layer 
thicknesses, which are of order 1 mm according to Equation 2 and Equation 5. It is 
recommended to have three to five elements across the layers when using P1 elements (the 
default setting for fluid flows).
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Application Library path: Heat_Transfer_Module/Tutorials,
_Forced_and_Natural_Convection/buoyancy_water

Modeling Instructions

From the File menu, choose New.
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N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Fluid Flow>Non-Isothermal Flow>Laminar Flow.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

The Grashof and Rayleigh numbers should be less than 109, indicating that a laminar 
regime is expected.

G E O M E T R Y  1

Square 1 (sq1)
1 On the Geometry toolbar, click Primitives and choose Square.

2 In the Settings window for Square, locate the Size section.

3 In the Side length text field, type L.

Name Expression Value Description

L 10[cm] 0.1 m Square side length

DeltaT 10[K] 10 K Temperature 
difference

Tc 283.15[K] 283.15 K Low temperature

Th Tc+DeltaT 293.15 K High temperature

rho 999[kg/m^3] 999 kg/m³ Density

mu 1.08e-3[N*s/m^2] 0.00108 N·s/(m·m) Dynamic viscosity

k 0.60[W/(m*K)] 0.6 W/(m·K) Thermal conductivity

Cp 4.18[kJ/(kg*K)] 4180 J/(kg·K) Heat capacity

alpha 0.17e-3[1/K] 1.7E-4 1/K Coefficient of 
thermal expansion

U0 sqrt(g_const*
alpha*DeltaT*L)

0.040831 m/s Typical velocity due 
to buoyancy

U1 U0/sqrt(Pr) 0.014885 m/s Typical velocity 
estimation

Pr mu*Cp/k 7.524 Prandtl number

Gr (U0*rho*L/mu)^2 1.4264E7 Grashof number

Ra Pr*Gr 1.0733E8 Rayleigh number

Re0 rho*U0*L/mu 3776.8 Reynolds number 
approximation with U0

Re1 rho*U1*L/mu 1376.9 Reynolds number 
approximation with U1

eps_t L/(Ra)^0.25 9.8248E-4 m Thermal boundary 
layer thickness

eps_m L/sqrt(Re1) 0.0026949 m Momentum boundary 
layer thickness
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4 On the Geometry toolbar, click Build All.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Water, liquid.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Water, liquid (mat1)
On the Home toolbar, click Add Material to close the Add Material window.

L A M I N A R  F L O W  ( S P F )

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

2 In the Settings window for Laminar Flow, locate the Physical Model section.

3 Select the Include gravity check box.

4 Find the Reference values subsection. Specify the rref vector as

Pressure Point Constraint 1
1 On the Physics toolbar, click Points and choose Pressure Point Constraint.

2 Select Point 2 only.

Fixing the pressure at an arbitrary point is necessary to define a well-posed model.

H E A T  TR A N S F E R  I N  F L U I D S  ( H T )

Define the initial temperature as the mean value between the high and low temperature 
values.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Fluids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, type (Tc+Th)/2 in the T text field.

3 In the Model Builder window, click Heat Transfer in Fluids (ht).

0 x

0.1 y
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Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 1 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type Tc.

Temperature 2
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 4 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type Th.

Now, modify the default mesh size settings to ensure that the mesh satisfies the criterion 
discussed in the Introduction section.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Extra fine.

4 Click Build All.

S T U D Y  1

Because the Grashof number is near the critical value of around 109, the model is highly 
nonlinear. To achieve convergence, use continuation to ramp up the temperature 
difference value from 10−3 K to 10 K, which corresponds to a Grashof number from 103 
to 107.

Step 1: Stationary
1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study extensions section.

3 Locate the Study Extensions section. Select the Auxiliary sweep check box.

4 Click Add.

5 In the table, enter the following settings:

Parameter name Parameter value list Parameter unit

DeltaT 1e-3 1e-2 1e-1 1 10 K
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6 In the Model Builder window’s toolbar, click the Show button and select Advanced Physics 

Options in the menu.

The pseudo stepping time option is generally useful to help the convergence of a stationary 
flow model. However, a continuation approach is already used here. In this precise model, 
disabling the pseudo time stepping option improves the convergence. Follow the 
instructions below to do so.

L A M I N A R  F L O W  ( S P F )

On the Physics toolbar, click Heat Transfer in Fluids (ht) and choose Laminar Flow (spf).

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

2 In the Settings window for Laminar Flow, click to expand the Advanced settings section.

3 Locate the Advanced Settings section. Find the Pseudo time stepping subsection. Clear 
the Use pseudo time stepping for stationary equation form check box.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Velocity (spf)
The first default plot group shows the velocity magnitude as in Figure 3. Notice the high 
velocities near the lateral walls due to buoyancy effects.

Temperature (ht)
The third default plot shows the temperature distribution. Add arrows of the velocity field 
to see the correlations between velocity and temperature, as in Figure 5.

1 In the Model Builder window, under Results click Temperature (ht).

2 On the Temperature (ht) toolbar, click Plot.

Arrow Surface 1
1 Right-click Results>Temperature (ht) and choose Arrow Surface.

2 In the Settings window for Arrow Surface, locate the Coloring and Style section.

3 From the Color list, choose Black.

4 On the Temperature (ht) toolbar, click Plot.

To reproduce the plot of Figure 7, follow the steps below.
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2D Plot Group 5
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Density in the Label text field.

Surface 1
1 Right-click Density and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Laminar Flow>

Material properties>spf.rho - Density.

3 On the Density toolbar, click Plot.

In the following steps, the temperature and velocity profiles are plotted near the left 
boundary in order to estimate the boundary layer thicknesses of the solution.

Cut Line 2D 1
1 On the Results toolbar, click Cut Line 2D.

2 In the Settings window for Cut Line 2D, locate the Line Data section.

3 In row Point 1, set y to 5[cm].

4 In row Point 2, set x to 1[cm], and y to 5[cm].

5 Click Plot.

1D Plot Group 6
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Temperature at Boundary Layer in 
the Label text field.

3 Locate the Data section. From the Data set list, choose Cut Line 2D 1.

4 From the Parameter selection (DeltaT) list, choose Last.

Line Graph 1
1 On the Temperature at Boundary Layer toolbar, click Line Graph.

2 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Model>Component 1>Heat Transfer in 

Fluids>Temperature>T - Temperature.

3 On the Temperature at Boundary Layer toolbar, click Plot.

The thermal boundary layer is around 3 mm.

1D Plot Group 7
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.
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2 In the Settings window for 1D Plot Group, type Velocity at Boundary Layer in the 
Label text field.

3 Locate the Data section. From the Data set list, choose Cut Line 2D 1.

4 From the Parameter selection (DeltaT) list, choose Last.

Line Graph 1
1 On the Velocity at Boundary Layer toolbar, click Line Graph.

2 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Model>Component 1>Laminar Flow>

Velocity and pressure>spf.U - Velocity magnitude.

3 On the Velocity at Boundary Layer toolbar, click Plot.

The momentum boundary layer is around 1 mm and the outer layer between 5 mm and 
10 mm.

Now create the 3D version of the model.

R O O T

On the Home toolbar, click Add Component and choose 3D.

G E O M E T R Y  2

In the Model Builder window, under Component 2 (comp2) click Geometry 2.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Recently Used>Laminar Flow.

4 Click Add to Component in the window toolbar.

L A M I N A R  F L O W  2  ( S P F 2 )

On the Home toolbar, click Add Physics to close the Add Physics window.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies.

4 In the Select Study tree, select Preset Studies>Stationary.

5 Click Add Study in the window toolbar.
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S T U D Y  2

Step 1: Stationary
On the Home toolbar, click Add Study to close the Add Study window.

G E O M E T R Y  2

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type L.

4 In the Depth text field, type L/2.

5 In the Height text field, type L.

6 On the Geometry toolbar, click Build All.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Water, liquid.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Water, liquid (mat2)
On the Home toolbar, click Add Material to close the Add Material window.

L A M I N A R  F L O W  2  ( S P F 2 )

1 In the Model Builder window, under Component 2 (comp2) click Laminar Flow 2 (spf2).

2 In the Settings window for Laminar Flow, locate the Physical Model section.

3 Select the Include gravity check box.

4 Find the Reference values subsection. Specify the rref vector as

Pressure Point Constraint 1
1 On the Physics toolbar, click Points and choose Pressure Point Constraint.

0 x

0 y

0.1 z
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2 Select Point 4 only.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundary 2 only.

H E A T  TR A N S F E R  I N  F L U I D S  2  ( H T 2 )

Initial Values 1
1 In the Model Builder window, under Component 2 (comp2)>Heat Transfer in Fluids 2 (ht2) 

click Initial Values 1.

2 In the Settings window for Initial Values, type (Tc+Th)/2 in the T2 text field.

3 In the Model Builder window, click Heat Transfer in Fluids 2 (ht2).

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 1 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type Tc.

Temperature 2
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 6 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type Th.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundary 2 only.

L A M I N A R  F L O W  2  ( S P F 2 )

1 In the Model Builder window, under Component 2 (comp2) click Laminar Flow 2 (spf2).

2 In the Settings window for Laminar Flow, click to expand the Advanced settings section.

3 Locate the Advanced Settings section. Find the Pseudo time stepping subsection. Clear 
the Use pseudo time stepping for stationary equation form check box.
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M E S H  2

To obtain reliable results in a reasonable computational time, create a structured mesh 
according to the steps below.

1 On the Mesh toolbar, click Boundary and choose Mapped.

Mapped 1
1 In the Model Builder window, under Component 2 (comp2)>Mesh 2 click Mapped 1.

2 Select Boundary 2 only.

3 On the Mesh toolbar, click Distribution.

Distribution 1
1 In the Model Builder window, under Component 2 (comp2)>Mesh 2>Mapped 1 click 

Distribution 1.

2 Select Edges 1, 3, 5, and 9 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 From the Distribution properties list, choose Predefined distribution type.

5 In the Number of elements text field, type 16.

6 In the Element ratio text field, type 3.

7 Select the Symmetric distribution check box.
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8 Click Build Selected.

The front face mesh has smaller elements near the edges because large variations in velocity and 
temperature are expected there.

Now extend the front mesh to the remaining structure.

9 On the Mesh toolbar, click Swept.

Swept 1
Click Distribution.

Distribution 1
1 In the Model Builder window, under Component 2 (comp2)>Mesh 2>Swept 1 click 

Distribution 1.

2 In the Settings window for Distribution, locate the Distribution section.

3 From the Distribution properties list, choose Predefined distribution type.

4 In the Number of elements text field, type 8.

5 In the Element ratio text field, type 3.

6 Select the Reverse direction check box.

To resolve the boundary layers, use a Boundary Layers feature to generate smaller mesh 
elements near the walls. The thermal boundary layer for the temperature difference of 
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10 K is approximately 1 mm (see the parameter eps_t defined previously). Use this 
value to define the thickness of the boundary layers.

7 On the Mesh toolbar, click Boundary Layers.

Boundary Layer Properties 1
1 In the Model Builder window, expand the Boundary Layers 1 node, then click Boundary 

Layer Properties 1.

2 Select Boundaries 1 and 3–6 only.

3 In the Settings window for Boundary Layer Properties, locate the Boundary Layer 

Properties section.

4 In the Number of boundary layers text field, type 5.

5 From the Thickness of first layer list, choose Manual.

6 In the Thickness text field, type eps_t/5.

7 Click Build All.

S T U D Y  2

Step 1: Stationary
1 In the Settings window for Stationary, locate the Study Extensions section.

2 Select the Auxiliary sweep check box.

3 Click Add.

4 In the table, enter the following settings:

5 Locate the Physics and Variables Selection section. In the table, clear the Solve for check 
box for Laminar Flow (spf) and Heat Transfer in Fluids (ht).

6 On the Home toolbar, click Compute.

R E S U L T S

Velocity (spf2)
This default plot group shows the fluid velocity magnitude in only half of the cube. To plot 
the other half, proceed as follows.

Mirror 3D 1
1 On the Results toolbar, click More Data Sets and choose Mirror 3D.

Parameter name Parameter value list Parameter unit

DeltaT 1e-3 1e-2 1e-1 1 10 K
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2 In the Settings window for Mirror 3D, locate the Plane Data section.

3 From the Plane list, choose zx-planes.

A new data set containing mirror values is now created. Return to the velocity plot to 
use this data set.

Velocity (spf2)
1 In the Model Builder window, under Results click Velocity (spf2).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Data set list, choose Mirror 3D 1.

4 On the Velocity (spf2) toolbar, click Plot.

Temperature (ht2)
This default plot group shows the temperature distribution. The mirror data set created 
previously can be reused here to plot the entire cube.

3D Plot Group 12
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Velocity, Front Plane in the Label 
text field.

3 Locate the Data section. From the Data set list, choose Mirror 3D 1.

Slice 1
1 Right-click Velocity, Front Plane and choose Slice.

2 In the Settings window for Slice, click Replace Expression in the upper-right corner of the 
Expression section. From the menu, choose Model>Component 2>Laminar Flow 2>

Velocity and pressure>spf2.U - Velocity magnitude.

3 Locate the Plane Data section. From the Plane list, choose zx-planes.

4 On the Velocity, Front Plane toolbar, click Plot.

This slice view shows the velocity magnitude in the same plane as in the 2D model 
(Figure 9).

Next, plot arrows of the tangential velocity field in the vertical plane parallel to the plates 
to reproduce Figure 10.

3D Plot Group 13
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Temperature, 10 K Offset in the 
Label text field.
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3 Locate the Data section. From the Data set list, choose Mirror 3D 1.

Slice 1
1 Right-click Temperature, 10 K Offset and choose Slice.

2 In the Settings window for Slice, click Replace Expression in the upper-right corner of the 
Expression section. From the menu, choose Model>Component 2>Heat Transfer in Fluids 

2>Temperature>T2 - Temperature.

3 Locate the Plane Data section. In the Planes text field, type 1.

4 Locate the Coloring and Style section. From the Color table list, choose ThermalLight.

5 On the Temperature, 10 K Offset toolbar, click Plot.

Temperature, 10 K Offset
In the Model Builder window, under Results right-click Temperature, 10 K Offset and choose 
Arrow Volume.

Arrow Volume 1
1 In the Settings window for Arrow Volume, locate the Expression section.

2 In the x component text field, type 0.

3 Locate the Arrow Positioning section. Find the x grid points subsection. In the Points text 
field, type 1.

4 Find the y grid points subsection. In the Points text field, type 25.

5 Find the z grid points subsection. In the Points text field, type 25.

6 Locate the Coloring and Style section. From the Color list, choose Black.

7 On the Temperature, 10 K Offset toolbar, click Plot.

Temperature, 10 K Offset
The arrows follow convective cells at the four corners for a temperature difference of 10 K. 
Follow the steps below to reproduce Figure 11 and to see these cells when the temperature 
difference is reduced to 1 K and 0.1 K.

Temperature, 10 K Offset 1
1 Right-click Temperature, 10 K Offset and choose Duplicate.

2 In the Settings window for 3D Plot Group, type Temperature, 1 K Offset in the 
Label text field.

3 Locate the Data section. From the Parameter value (DeltaT (K)) list, choose 1.

4 On the Temperature, 1 K Offset toolbar, click Plot.
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Temperature, 1 K Offset 1
1 Right-click Results>Temperature, 1 K Offset and choose Duplicate.

2 In the Settings window for 3D Plot Group, type Temperature, 0.1 K Offset in the 
Label text field.

3 Locate the Data section. From the Parameter value (DeltaT (K)) list, choose 0.1.

4 On the Temperature, 0.1 K Offset toolbar, click Plot.
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Introduction

Composite materials such as carbon-fiber-reinforced polymer (CFRP) have outstanding 
properties. It is a lightweight material with high stiffness and high temperature tolerance 
and therefore used in aerospace industry, civil engineering and also for high-end sports 
goods.

Carbon crystals form flat ribbons. Large numbers of these ribbons are bundled together 
and woven in different structures as required by the application area. The bundles have 
anisotropic material properties. For thermal properties this means that the thermal 
conductivity along the fiber axis is much higher than perpendicular to it.

Figure 1: Model geometry: fibers embedded in an epoxy matrix (hidden) with infinite element 
domain.

In COMSOL Multiphysics, implementing anisotropic properties is straightforward in the 
global coordinate system, which is set by default. However, in the present case, an 
anisotropic thermal conductivity needs to be defined along woven fibers where the global 
coordinate system is inapplicable. The curvilinear coordinate system provides the 
possibility to create a coordinate system following the curves of a geometry in which 
anisotropic material properties or anisotropic physics can be defined.

Infinite domains

Carbon fibers
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This tutorial shows how to use the curvilinear coordinates interface and how to apply it to 
define anisotropic thermal conductivity.

Model Definition

The model represents a cutout of a carbon-fiber-reinforced polymer. The geometry used 
in this case is shown in Figure 1. The fiber bundles have circular cross-sections and are 
embedded in a matrix made of epoxy.

The “infinite domains” truncate the geometry to model a few fibers only. With the Heat 
Transfer Module you can assign them as Infinite Element Domains and thus suppress 
boundary effects. Without the Heat Transfer Module the boundary conditions at the 
outer side affects the solution-in this case the maximum temperature. Increase the number 
of fibers to reduce these effects.

M A T E R I A L  P R O P E R T I E S

The material properties are summarized in Table 1. 

Note the syntax of the thermal conductivity for carbon (core). In the general case of an 
anisotropic thermal conductivity, it is a second order tensor. In the present case, the tensor 
is diagonal.

Note that the conductivity is high in the fibers direction and low in perpendicular 
direction. The coordinate system used for k must then provide an x-component following 
the shape of the fibers. The Curvilinear Coordinates interface provides appropriate tools 
to create such a base vector system. 

TABLE 1:  MATERIAL PROPERTIES

MATERIAL PROPERTY EPOXY CARBON (CORE) CARBON (INFINITE DOMAIN)

Thermal conductivity 0.2 W/(m·K) {60,4,4} W/(m·K) 60 W/(m·K)

Density 1200 kg/m³ 1500 kg/m³ 1500 kg/m³

Heat capacity at 
constant pressure

1000 J/(kg·K) 1000 J/(kg·K) 1000 J/(kg·K)

k

kxx kxy kxz

kyx kyy kyz

kzx kzy kzz 
 
 
 
 
 

60 0 0
0 4 0
0 0 4 

 
 
 
 

= =
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C U R V I L I N E A R  C O O R D I N A T E S

Three predefined methods and a user-defined method are available to set up a curvilinear 
coordinate system. Further details can be found in the COMSOL Multiphysics Reference 
Guide in the “Curvilinear Coordinates interface” section. Here you use the diffusion 
method which solves Laplace’s equation resulting in a scalar potential. It is the same as 
solving the stationary heat transfer equation with temperature boundary conditions 
resulting in a temperature gradient and forming the first base vector of the new coordinate 
system. The second base vector is specified manually and the cross-product of both forms 
the third base vector.

Figure 2 shows the base vector system for a single fiber.

Figure 2: Curvilinear coordinate system from diffusion method.

Alternatively the Flow Method is available, which results in a vector potential. This is 
equivalent to solving Stokes flow (also known as creeping flow) where the obtained 
velocity field forms the first base vector. The third option is to choose the Elasticity 
Method for solving an eigenvalue problem. 

If the Create base vector system option is selected, the new curvilinear system is available 
as input for the Coordinate System Selection drop-down menu and thus providing new (x,
y, z) coordinates.
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B O U N D A R Y  C O N D I T I O N S

For the curvilinear coordinates interface, the inlet and outlet boundaries define the 
direction of the first base vector. The heat transfer analogy consists in setting a high 
temperature at the inlet and a low temperature at the outlet. All other boundaries are 
thermally insulated walls.

For the heat transfer interface, a constant temperature boundary condition is set at the 
outermost walls. A boundary heat source described with a Gaussian pulse in the center of 
the geometry is applied and a convective cooling boundary condition on both sides.

I N F I N I T E  E L E M E N T S

To truncate the geometry the Infinite Element Domain feature can be used. Boundary 
conditions applied to these elements can be imagined as boundary conditions at an infinite 
distance of the modeling domain. So it does not affect the solution of this particular 
problem. This works by scaling the width of the domain to be much larger than the 
original geometry.

Results and Discussion

From the Curvilinear Coordinates interface a new coordinate system is obtained as shown 
in Figure 1. The temperature distribution on the surface shows a high temperature at the 
center where the maximum of the Gaussian function is located and decreases with 
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increasing distance from the center. The temperature drop to 293 K as specified in the 
boundary conditions occurs mainly in the Infinite Element Domains.

Figure 3: Temperature distribution on the surface.
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Figure 4 shows clearly that the heat spreads preferentially along the fiber axis.

Figure 4: Temperature at the center plane and fiber structure (gray).

Notes About the COMSOL Implementation 

This tutorial demonstrates how to use the Curvilinear Coordinates interface for defining 
anisotropic thermal conductivity. Hence, the instructions focus on this part and start with 
loading the file carbon_fiber_geom.mph. The steps needed to create this file are quite 
complex. This document does not go into details but provides a short summary instead.

The geometry sequence calls geometry subsequences depending on the global parameter 
q. The subsequences define different cross-sections and can be found under the Global 

Definitions node. Call the elliptical cross-section with q = 1 and the rectangular 
cross-section with q = 2.

All subsequent geometry features are based on these subsequences. Inside some of the 
features, a selection of geometric entities is created automatically by selecting the Create 

Selections option. Instead of selecting objects manually, these selections are used as input 
in the following geometry node. This approach ensures that all geometry operations adapt 
and produce the desired geometry automatically, even if a geometry parameter changes.
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Selections are also used on the finalized geometry to ensure that physical properties are 
assigned to the intended entities. These selections are defined under Component 1>

Definitions. They are used to automatically set up boundary and domain conditions as well 
as the mesh. The resulting model is consistent for any choice of parameters. The extra time 
needed to set up this kind of geometry sequence and to define selections is regained 
through an accelerated physics modeling and meshing process.

Application Library path: Heat_Transfer_Module/Tutorials,_Conduction/
carbon_fibers_infinite_elements

Modeling Instructions

R O O T

Start with loading the model file that contains the geometry and selections used 
throughout the modeling process.

1 From the File menu, choose Open.

2 Browse to the application’s Application Libraries folder and double-click the file 
carbon_fibers_geom.mph.

3 Click the Zoom Extents button on the Graphics toolbar.

C O M P O N E N T  1  ( C O M P 1 )

Add the Curvilinear Coordinates interface for the fibers.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Mathematics>Curvilinear Coordinates (cc).

4 Click Add to Component in the window toolbar.

C U R V I L I N E A R  C O O R D I N A T E S  ( C C )

1 On the Home toolbar, click Add Physics to close the Add Physics window.

2 In the Model Builder window, under Component 1 (comp1) click Curvilinear Coordinates 

(cc).

3 In the Settings window for Curvilinear Coordinates, locate the Domain Selection section.
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4 From the Selection list, choose Fibers (Core).

5 Locate the Settings section. Select the Create base vector system check box.

According to the Curvilinear Coordinates section, the second basis vector is specified 
manually. The y-direction feels natural.

Coordinate System Settings 1
1 In the Model Builder window, under Component 1 (comp1)>Curvilinear Coordinates (cc) 

click Coordinate System Settings 1.

2 In the Settings window for Coordinate System Settings, locate the Settings section.

3 From the Second basis vector list, choose y-axis.

Diffusion Method 1
1 On the Physics toolbar, click Domains and choose Diffusion Method.

Wall is the default boundary condition where the normal component of the vector field 
is zero. The direction of the first basis vector is specified with inlet and outlet boundary 
conditions.

2 In the Settings window for Diffusion Method, locate the Domain Selection section.

3 From the Selection list, choose Fibers (Core).

Inlet 1
1 On the Physics toolbar, click Attributes and choose Inlet.

2 In the Settings window for Inlet, locate the Boundary Selection section.

3 From the Selection list, choose Inlets.

Diffusion Method 1
In the Model Builder window, under Component 1 (comp1)>Curvilinear Coordinates (cc) click 
Diffusion Method 1.

Outlet 1
1 On the Physics toolbar, click Attributes and choose Outlet.

2 In the Settings window for Outlet, locate the Boundary Selection section.

3 From the Selection list, choose Outlets.

M E S H  1

Now, build a suitable mesh manually. Start with meshing the fibers.

1 On the Mesh toolbar, click Boundary and choose Free Triangular.
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Free Triangular 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Free Triangular 1.

2 In the Settings window for Free Triangular, locate the Boundary Selection section.

3 From the Selection list, choose Inlets.

4 On the Mesh toolbar, click Distribution.

Distribution 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1>Free Triangular 1 click 

Distribution 1.

2 In the Settings window for Distribution, locate the Edge Selection section.

3 From the Selection list, choose Inlet Edges.

4 Locate the Distribution section. In the Number of elements text field, type 2.

5 Click Build Selected.

6 On the Mesh toolbar, click Swept.

Swept 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Swept 1.

2 In the Settings window for Swept, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Fibers (Core).

5 On the Mesh toolbar, click Distribution.

Distribution 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1>Swept 1 click 

Distribution 1.

2 In the Settings window for Distribution, locate the Domain Selection section.

3 From the Selection list, choose Fibers (Core).

4 Locate the Distribution section. In the Number of elements text field, type 6.
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5 Click Build Selected.

Convert now the surface elements into triangles in order to use a free tetrahedral mesh 
for the epoxy domain.

6 On the Mesh toolbar, click Modify and choose Elements>Convert.

Convert 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Convert 1.

2 In the Settings window for Convert, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Fiber Walls.

5 Click Build Selected.

Then, use a triangular mesh at the remaining core boundaries and extrude the resulting 
boundary mesh into the infinite element domains.

6 On the Mesh toolbar, click Boundary and choose Free Triangular.

Free Triangular 2
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Free Triangular 2.

2 In the Settings window for Free Triangular, locate the Boundary Selection section.

3 From the Selection list, choose Epoxy Boundaries (Core).
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Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Triangular 2 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Extra fine.

4 Click Build Selected.

5 On the Mesh toolbar, click Swept.

Swept 2
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Swept 2.

2 In the Settings window for Swept, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Infinite Element Domains.

5 On the Mesh toolbar, click Distribution.

Distribution 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1>Swept 2 click 

Distribution 1.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 3.

4 Click Build Selected.

5 On the Mesh toolbar, click Free Tetrahedral.

Free Tetrahedral 1
Mesh the remaining parts with a free tetrahedral mesh.

1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Free Tetrahedral 

1.
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2 In the Settings window for Free Tetrahedral, click Build All.

The final mesh looks like this.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

Add a stationary study to compute the new coordinate system with the Diffusion Method.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

S T U D Y  1

Step 1: Stationary
1 On the Home toolbar, click Add Study to close the Add Study window.

2 On the Home toolbar, click Compute.
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R E S U L T S

Vector Field (cc)
The default plots show the coordinate system with volume arrows and a streamlines for the 
vector field. To create the plot shown in Figure 3, add a selection to the data set. The plot 
group will then use this subset of the whole geometry only.

Study 1/Solution 1 (sol1)
In the Model Builder window, expand the Results>Data Sets node, then click Study 1/Solution 

1 (sol1).

Selection
1 On the Results toolbar, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 Click Paste Selection.

5 In the Paste Selection dialog box, type 20, 34, 54, 68, 88, 102, 122, 136 in the 
Selection text field.

6 Click OK.

Coordinate System Volume 1
1 In the Model Builder window, expand the Coordinate system (cc) node, then click 

Coordinate System Volume 1.

2 In the Settings window for Coordinate System Volume, locate the Positioning section.

3 Find the x grid points subsection. In the Points text field, type 16.

4 Find the y grid points subsection. In the Points text field, type 2.

5 Find the z grid points subsection. In the Points text field, type 2.

6 On the Coordinate system (cc) toolbar, click Plot.

7 Click the Go to Default 3D View button on the Graphics toolbar.

Now, add the Heat Transfer in Solids interface to the component.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Heat Transfer>Heat Transfer in Solids (ht).

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Study 1.
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5 Click Add to Component in the window toolbar.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

1 On the Home toolbar, click Add Physics to close the Add Physics window.

2 Click the Zoom Extents button on the Graphics toolbar.

Infinite Element Domain 1 (ie1)
On the Definitions toolbar, click Infinite Element Domain.

D E F I N I T I O N S

Infinite Element Domain 1 (ie1)
1 In the Settings window for Infinite Element Domain, locate the Domain Selection 

section.

2 From the Selection list, choose Infinite Element Domains.

In order to apply a heat source right in the center of the model, the Mass Properties 
feature is used. It computes the center of mass, which is automatically the center of the 
geometry.

3 In the Model Builder window, right-click Definitions and choose Mass Properties.

4 In the Settings window for Mass Properties, locate the Source Selection section.

5 From the Selection list, choose Fibers (Core).

Define a heat source via a local variable, which is defined on the boundary only. Use the 
mass properties variable for the center of mass to apply the source term exactly in the 
center.

Variables 1
1 On the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

In the next section, you define the materials according to the Material Properties section.

Name Expression Unit Description

Q_in 1e5[W/m^2]*exp(-5e6[1/
m^2]*((x-mass1.CMx)^2+
(z-mass1.CMz)^2))

W/m² Boundary heat source
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M A T E R I A L S

Material 1 (mat1)
1 On the Materials toolbar, click Blank Material.

2 In the Settings window for Material, type Epoxy in the Label text field.

3 Locate the Material Contents section. In the table, enter the following settings:

Material 2 (mat2)
1 On the Materials toolbar, click Blank Material.

2 In the Settings window for Material, type Carbon in the Label text field.

3 Locate the Geometric Entity Selection section. From the Selection list, choose Fibers.

4 Locate the Material Contents section. In the table, enter the following settings:

Material 3 (mat3)
1 On the Materials toolbar, click Blank Material.

2 In the Settings window for Material, type Carbon (Infinite Element Domain) in the 
Label text field.

3 Locate the Geometric Entity Selection section. From the Selection list, choose Fibers 

(Infinite Element Domain).

Property Name Value Unit Property 
group

Thermal conductivity k 0.2 W/(m·K) Basic

Density rho 1200 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 1000 J/(kg·K) Basic

Property Name Value Unit Property 
group

Thermal conductivity k {60, 4, 
4}

W/(m·K) Basic

Density rho 1500 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 1000 J/(kg·K) Basic
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4 Locate the Material Contents section. In the table, enter the following settings:

Add a second Heat Transfer in Solids node for the fibers and choose the curvilinear system 
as reference system. This way the thermal conductivity is high along the fiber axis and low 
perpendicular to it.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Solid 2
1 On the Physics toolbar, click Domains and choose Solid.

2 In the Settings window for Solid, locate the Domain Selection section.

3 From the Selection list, choose Fibers (Core).

4 Locate the Coordinate System Selection section. From the Coordinate system list, choose 
Curvilinear System (cc) (cc_cs).

Set up the boundary conditions, consisting in a heat source, a convective heat flux 
accounting for cooling, and a fixed temperature at the very outer boundaries of the infinite 
domain.

Boundary Heat Source 1
1 On the Physics toolbar, click Boundaries and choose Boundary Heat Source.

2 In the Settings window for Boundary Heat Source, locate the Boundary Selection section.

3 From the Selection list, choose Heat Source Boundary.

4 Locate the Boundary Heat Source section. In the Qb text field, type Q_in.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Cooling Boundaries.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type 10.

Property Name Value Unit Property 
group

Thermal conductivity k 60 W/(m·K) Basic

Density rho 1500 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 1000 J/(kg·K) Basic
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Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 In the Settings window for Temperature, locate the Boundary Selection section.

3 From the Selection list, choose Temperature Boundaries.

The first study was used to compute the curvilinear system. Add a second study to solve 
for the heat transfer only. Refer to Study 1 in the Values of Dependent Variables section by 
selecting the solution as input for the variables not solved in this second study. This way 
the new coordinate system, which is initially unknown by Study 2, can be used for the heat 
transfer computation.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Curvilinear Coordinates (cc) interface.

5 Click Add Study in the window toolbar.

S T U D Y  2

Step 1: Stationary
1 On the Home toolbar, click Add Study to close the Add Study window.

2 In the Model Builder window, under Study 2 click Step 1: Stationary.

3 In the Settings window for Stationary, click to expand the Values of dependent variables 
section.

4 Locate the Values of Dependent Variables section. Find the Values of variables not solved 

for subsection. From the Settings list, choose User controlled.

5 From the Method list, choose Solution.

6 From the Study list, choose Study 1, Stationary.

7 On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
The default temperature plot shows the temperature distribution on the surface 
(Figure 3).
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To create Figure 4 follow the steps below.

Study 2/Solution 2 (sol2)
In the Model Builder window, under Results>Data Sets right-click Study 2/Solution 2 (sol2) 
and choose Duplicate.

Selection
1 On the Results toolbar, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Core Domains.

Surface 1
1 On the Results toolbar, click More Data Sets and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (2) (sol2).

4 Locate the Selection section. From the Selection list, choose Fiber Walls.

3D Plot Group 5
1 On the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Temperature at Middle Slice in 
the Label text field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 2 (3) (sol2).

4 On the Temperature at Middle Slice toolbar, click Slice.

Slice 1
1 In the Model Builder window, under Results>Temperature at Middle Slice click Slice 1.

2 In the Settings window for Slice, click Replace Expression in the upper-right corner of the 
Expression section. From the menu, choose Model>Component 1>Heat Transfer in Solids>

Temperature>T - Temperature.

3 Locate the Plane Data section. From the Plane list, choose zx-planes.

4 In the Planes text field, type 1.

5 Locate the Coloring and Style section. From the Color table list, choose ThermalLight.

6 On the Temperature at Middle Slice toolbar, click Surface.

Surface 1
1 In the Model Builder window, under Results>Temperature at Middle Slice click Surface 1.

2 In the Settings window for Surface, locate the Expression section.
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3 In the Expression text field, type 1.

4 Locate the Data section. From the Data set list, choose Surface 1.

5 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

6 From the Color list, choose Gray.

7 On the Temperature at Middle Slice toolbar, click Plot.

8 Click the Go to ZX View button on the Graphics toolbar.

9 Click the Zoom Extents button on the Graphics toolbar.
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Introduction

The following example shows how to build and solve a radiative heat transfer problem 
using the Heat Transfer with Surface-to-Surface Radiation interface. This example’s 
simple geometry allows a comparison of results from COMSOL Multiphysics with a 
theoretical solution. 

Model Definition

The geometry consists of three rectangles with lengths 3 m, 4 m, and 5 m, and all have a 
width of 1 m. The rectangles are situated such that they form a triangular cavity (see 
Figure 1).

Figure 1: Three domains form a triangular cavity to study heat radiation.

The rectangles are made of copper, which is a good thermal conductor, and they transfer 
heat internally by conduction. Further, the three inner boundaries that form the cavity can 
exchange heat only by means of surface-to-surface radiation. The surface emissivities are 
ε1 = 0.4 on the bottom boundary, ε2 = 0.6 on the vertical boundary, and ε3 = 0.8 on the 
inclined boundary.

The system holds the temperature on the (outer) lower boundary at T1 = 300 K. Further, 
the system experiences an inward heat flux of q2 = 2000 W/m2 on the outer boundary of 
the vertical rectangle and q3 = 1000 W/m2 on the outer boundary of the tilted one. All 
remaining outer boundaries are insulated.

q3

q2

T1

ε1

ε2ε3
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This example examines the steady state of the cavity’s interior boundaries. Specifically, you 
know the value of the heat flux on the inclined and vertical boundaries, and you want to 
find the temperature along these boundaries. Conversely, you know the temperature of the 
bottom boundary and want to determine the heat flux that leaves through it.

Results and Discussion

Figure 2 shows the temperature field resulting from a simulation. If you run the model as 
described later in this section you can see from the color display that the temperatures are 
fairly constant within the three rectangles. The theoretical results predict that a heat flux 
Q1 = −11,000 W/m leaves the cavity through the bottom boundary, that the vertical 
boundary has a temperature of T2 = 641 K, and that the inclined boundary has a 
temperature of T3 = 600 K. The results obtained are very close to these theoretical values. 
The section Comparing Results with Theory provides more details on the verification of 
these results.

Figure 2: Temperature as a function of position.

Figure 3 details the temperature distribution along the inclined boundary of the cavity. 
Note that while the temperature is not constant, it varies by only a few percent. The lowest 
temperature appears on the bottom left, and the highest temperature is on the right, which 
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seems reasonable because that portion of the boundary is located adjacent to the vertical 
boundary, which has the highest inward heat flux.

Figure 3: Temperature distribution along the inclined boundary of the cavity.
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Figure 3 plots the radiosity along the inclined boundary (in other words, the total heat flux 
that leaves the boundary into the cavity). The radiosity is the sum of the heat flux the 
boundary emits plus the heat flux it reflects.

Figure 4: Radiosity along the inclined boundary of the cavity.

Like temperature, the radiosity is fairly constant along the boundary. The small variations 
have roughly the same distribution as the temperature in Figure 3.

C O M P A R I N G  R E S U L T S  W I T H  T H E O R Y

As mentioned at the start of this section, you can compare the results from this tutorial to 
theoretical values, which are based on the sketch in Figure 5 and whose theory appears in 
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the section “Enclosures with More Than Two Surfaces” in Ref. 1.

Figure 5: Problem sketch for theoretical analysis of radiation in a triangular cavity.

The theoretical model considers only the three boundaries that form the cavity. On these 
boundaries, the model either holds the temperature at a constant value or specifies a heat 
flux. Note that this approach differs somewhat from the model, which sets temperatures 
and heat fluxes on the rectangles’ outer boundaries.

The COMSOL Multiphysics model shows that the temperatures and heat fluxes are nearly 
equal on the inner and outer boundaries of the rectangles. Therefore, the COMSOL 
Multiphysics and the theoretical model show good agreement.

Using the notation from Figure 5 with the same assumptions as for the model, you obtain 
the following lengths and emissivities:

L1 = 4 m, ε1 = 0.4

L2 = 3 m, ε2 = 0.6

L3 = 5 m, ε3 = 0.8

The boundary conditions define either the temperature or the heat flux on each boundary. 
Now apply the same boundary conditions as in the problem where you set values for T1, 
Q2, and Q3. You must, however, make a small adjustment for T1 because the theoretical 
configuration sets it on the outer boundary and not on the cavity side. T1 is therefore 
slightly higher than 300 K in the theoretical analysis:

T1

L1 ε1

Q3

L3ε3

L2
ε2

Q2
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You describe the heat flux from a boundary with the following two equations:

For a triangular cavity, the following equation gives the view factor between surface i and 
surface j:

Substituting this expression for the view factor into the second equation for the heat fluxes 
results in a linear system of six equations. The six unknowns for this particular problem are 
J1, J2, J3, Q1, T2, and T3, and you would like to compare the three last to those from the 
solution. Solving the linear system yields the following values: Q1 = −11,000 W/m, 
T2 = 641 K, and T3 = 600 K.

To compare these results with the model, you must find the total heat flux through the 
cavity’s bottom (horizontal) boundary and also calculate the average temperatures on the 
other two boundaries.

The following table compares the results from COMSOL Multiphysics with the 
theoretical values:

The differences are quite small. Also note that the theoretical model includes some 
simplifications. For example, it assumes that heat fluxes and temperatures are constant 

QUANTITY COMSOL MULTIPHYSICS THEORY

Q1 -10,965 W/m -11,000 W/m

T2 645 K 641 K

T3 601 K 600 K

T1 307 K=

Q2 q2L2 2000 W
m
----- 3 m× 6000 W= = =

Q3 q3L3 1000 W
m
----- 5 m× 5000 W= = =

Qi Li
εi

1 εi–
------------- σTi

4 Ji–( )=

Qi Li Fik Ji Jk–( )
k
=

Fij
Li Lj Lk–+

2Li
------------------------------=
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along each boundary. It also assumes a constant view factor for each pair of boundaries, 
whereas COMSOL Multiphysics computes a local view factor at each point of the cavity.

Reference

1. A. Bejan, Heat Transfer, John Wiley & Sons, 1993.

Application Library path: Heat_Transfer_Module/Verification_Examples/
cavity_radiation

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Heat Transfer>Radiation>Heat Transfer with 

Surface-to-Surface Radiation (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

The geometry consists of three rectangles positioned such that they create a triangular 
cavity.

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 4.

4 Locate the Position section. In the y text field, type -1.
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Rectangle 2 (r2)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Height text field, type 3.

4 Locate the Position section. In the x text field, type 4.

Rectangle 3 (r3)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 5.

4 Locate the Rotation Angle section. In the Rotation text field, type atan(3/4)[rad].

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Form Union 

(fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly 
section.

3 From the Action list, choose Form an assembly.

4 On the Geometry toolbar, click Build All.

5 Click the Zoom Extents button on the Graphics toolbar.

This completes the geometry modeling stage.

M A T E R I A L S

Material 1 (mat1)
1 On the Materials toolbar, click Blank Material.

2 In the Settings window for Material, type Copper in the Label text field.

3 Locate the Material Contents section. In the table, enter the following settings:

Property Name Value Unit Property 
group

Thermal conductivity k 400 W/(m·K) Basic

Density rho 8700 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 385 J/(kg·K) Basic
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H E A T  TR A N S F E R  W I T H  S U R F A C E - T O - S U R F A C E  R A D I A T I O N  ( H T )

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer with 

Surface-to-Surface Radiation (ht) click Initial Values 1.

2 In the Settings window for Initial Values, type 300 in the T text field.

Next, define the boundary conditions.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundary 2 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 In the q0 text field, type 1000.

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundary 12 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 In the q0 text field, type 2000.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 6 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type 300.

Diffuse Surface 1
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 Select Boundary 3 only.

3 In the Settings window for Diffuse Surface, locate the Ambient section.

4 In the Tamb text field, type 300.

5 Locate the Surface Emissivity section. From the ε list, choose User defined. In the 
associated text field, type 0.8.

By default the radiation direction is controlled by the opacity of the domains. The solid 
parts are automatically defined as opaque. You can change this setting by modifying the 
Opacity subnode under the Solid feature.
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Diffuse Surface 2
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 Select Boundary 7 only.

3 In the Settings window for Diffuse Surface, locate the Ambient section.

4 In the Tamb text field, type 300.

5 Locate the Surface Emissivity section. From the ε list, choose User defined. In the 
associated text field, type 0.4.

Diffuse Surface 3
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 Select Boundary 9 only.

3 In the Settings window for Diffuse Surface, locate the Ambient section.

4 In the Tamb text field, type 300.

5 Locate the Surface Emissivity section. From the ε list, choose User defined. In the 
associated text field, type 0.6.

M E S H  1

On the Mesh toolbar, click Edge.

Edge 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Edge 1.

2 In the Settings window for Edge, locate the Boundary Selection section.

3 From the Geometric entity level list, choose Entire geometry.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Edge 1 and choose Size.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundaries 3, 7, and 9 only.

5 Locate the Element Size section. Click the Custom button.

6 Locate the Element Size Parameters section. Select the Maximum element size check box.

7 In the associated text field, type 0.05.

Edge 1
Right-click Edge 1 and choose Size.
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Size 2
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Point.

3 Select Points 2, 4, 6, and 8–10 only.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 0.01.

7 Click Build Selected.

8 On the Mesh toolbar, click Free Triangular.

Free Triangular 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Free Triangular 1.

2 In the Settings window for Free Triangular, click to expand the Tessellation section.

3 From the Method list, choose Advancing front.

4 In the Model Builder window, click Mesh 1.

5 In the Settings window for Mesh, click Build All.

The complete mesh consists of roughly 2,700 elements.
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S T U D Y  1

1 On the Home toolbar, click Compute.

The computation takes around 10 seconds.

R E S U L T S

Temperature (ht)
The first default plot shows the temperature field; compare with Figure 2.

The two additional default plots visualize the temperature field isothermal contours, and 
the radiosity on the boundaries.

Add a 1D plot for the temperature field on the inclined boundary (Figure 3).

1D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Temperature Profile vs Arc 
Length in the Label text field.

Line Graph 1
1 On the Temperature Profile vs Arc Length toolbar, click Line Graph.

2 Select Boundary 3 only.

3 On the Temperature Profile vs Arc Length toolbar, click Plot.

Temperature Profile vs Arc Length
Add another 1D plot showing the radiosity on the inclined boundary (Figure 4).

1 In the Model Builder window, under Results right-click Temperature Profile vs Arc Length 
and choose Duplicate.

Temperature Profile vs Arc Length 1
In the Settings window for 1D Plot Group, type Surface Radiosity Profile vs Arc 
Length in the Label text field.

Line Graph 1
1 In the Model Builder window, expand the Results>Surface Radiosity Profile vs Arc Length 

node, then click Line Graph 1.

2 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Model>Component 1>Heat Transfer 

with Surface-to-Surface Radiation>Radiation>Surface radiosity>ht.J - Surface radiosity.

3 On the Surface Radiosity Profile vs Arc Length toolbar, click Plot.
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Derived Values
Determine the conductive heat flux through the cavity’s bottom boundary as follows.

Line Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Line 

Integration.

2 Select Boundary 7 only.

3 In the Settings window for Line Integration, click Replace Expression in the upper-right 
corner of the Expressions section. From the menu, choose Model>Component 1>Heat 

Transfer with Surface-to-Surface Radiation>Boundary fluxes>ht.ndflux - Normal conductive 

heat flux.

4 Click Evaluate.

TA B L E

1 Go to the Table window.

The result displayed in the Table window should be approximately 11,000 W/m.

Next, find the mean temperature on the vertical boundary of the cavity.

R E S U L T S

Line Integration 2
1 On the Results toolbar, click More Derived Values and choose Integration>Line 

Integration.

2 Select Boundary 9 only.

3 In the Settings window for Line Integration, locate the Expressions section.

4 In the table, enter the following settings:

5 Click Evaluate.

TA B L E

1 Go to the Table window.

The resulting temperature, read from the table, should be approximately 641 K.

Finally, evaluate the mean temperature on inclined boundary of the cavity.

Expression Unit Description

T/3 m*K
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R E S U L T S

Line Integration 3
1 On the Results toolbar, click More Derived Values and choose Integration>Line 

Integration.

2 Select Boundary 3 only.

3 In the Settings window for Line Integration, locate the Expressions section.

4 In the table, enter the following settings:

5 Click Evaluate.

TA B L E

1 Go to the Table window.

The resulting temperature, read from the table, should be approximately 600 K.

Expression Unit Description

T/5 m*K
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Introduction

This example shows how to set up multiple sandwiched thin layers with different thermal 
conductivities in two different ways.

First, the composite is modeled as a 3D object. In the second approach the Thin Layer 
boundary condition is used to avoid resolving the thin domains.

The technique is useful when modeling heat transfer through thermal barriers like 
multilayer coatings. 

Model Definition

This tutorial uses a simple geometry as shown in Figure 1. The cylinder has a radius of 
2 cm and a height of 4 cm.

Figure 1: Geometry.

The composite consists of two layers with different thermal conductivities. The first 
approach resolves each layer as a 3D domain. The height of the layers is about three orders 
of magnitude smaller than the bulk height. This often requires to build a mesh manually 
to accurately resolve the thin structure.

Hot Surface

Cold Surface

Thin Thermally 
Resistive Layer
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COMSOL Multiphysics provides a special boundary condition which is available from the 
Heat Transfer Module. The second approach uses the Thin Layer feature with resistive 
property. It simplifies the geometry and thus the mesh. In complex geometries, this 
boundary condition can reduce the amount of memory and time required for the 
simulation significantly.

The underlying equation assumes the heat flux through the layer proportional to the 
temperature difference between upper and lower bulk. It is based on the assumption that 
the bulk on each side is well stirred so that all resistance against heat transfer is within a 
thin layer near the wall. Due to the additivity of resistance the flux over the composite can 
be lumped to

where the overall thermal conductivity ktot can be calculated as

M A T E R I A L  P R O P E R T I E S

The cylinder is made of steel. The composite consist of two layers of different ceramics.

B O U N D A R Y  C O N D I T I O N S

The temperature at the bottom is fixed to 20 °C whereas one half of the top boundary is 
held at 1220 °C (1493 K). All other outer boundaries are perfectly insulated.

TABLE 1:  CERAMICS MATERIAL PROPERTIES

PROPERTY CERAMIC 1 CERAMIC 2

Thermal conductivity 1 W/(m·K) 0.5 W/(m·K)

Density 6000 kg/m3 5800 kg/m3

Heat capacity at constant pressure 320 J/(kg·K) 280 J/(kg·K)

nd kd∇Td–( )–
ktot
dtot
---------- Tu Td–( )=

nu ku∇Tu–( )–
ktot
dtot
---------- Td Tu–( )=

ktot

dn

n
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Results and Discussion

Figure 2 shows the temperature distribution in the cylinder. The composite acts as a 
thermal barrier resulting in a jump of the temperature over the layer.

Figure 2: Temperature distribution.

Of interest is if the thin layer boundary condition produces reliable results compared to 
resolving the thin layers in 3D. This can be done with a comparative line graph as in 
Figure 3. It shows that the 2D approach, with or without an extra dimension, produces 
accurate results for the bulk temperatures.
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Figure 3: Temperature profile for 3D, 2D and 1D extra dimension approaches.

Another important question for simulating is the influence on the mesh size and on the 
required RAM.

With the default tetrahedral mesh the number of mesh elements is about 130,000 
elements and the meshing algorithm gives some warnings.

With the swept mesh feature you can significantly reduce the number of elements to about 
12,800 elements which is only 10%. In complex geometries the swept mesh algorithm is 
often not applicable. Using the thin layer boundary condition, the number of mesh 
elements reduces from 12,800 to 9,700 which is about 25% less, even in this simple 
geometry. You can see the number of mesh elements used in the messages box on the 
bottom right window.

Notes About the COMSOL Implementation

To compare the results directly, both approaches are handled within one mph-file.
5 |  C O M P O S I T E  T H E R M A L  B A R R I E R



Application Library path: Heat_Transfer_Module/Tutorials,_Thin_Structure/
composite_thermal_barrier

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose cm.

Name Expression Value Description

d_ceram1 50[um] 5E-5 m Thickness of layer 1

d_ceram2 75[um] 7.5E-5 m Thickness of layer 2

T_hot 1220[degC] 1493.2 K Hot temperature
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Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type 2.

4 In the Height text field, type 4.

5 On the Geometry toolbar, click Build All.

Now, create thin cylinders to define the ceramic layers between the two steel domains.

Cylinder 2 (cyl2)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type 2.

4 In the Height text field, type d_ceram1.

5 Locate the Position section. In the z text field, type 2-(d_ceram1+d_ceram2)/2.

6 On the Geometry toolbar, click Build All.

Cylinder 3 (cyl3)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type 2.

4 In the Height text field, type d_ceram2.

5 Locate the Position section. In the z text field, type 2-(d_ceram1+d_ceram2)/2+
d_ceram1.

6 On the Geometry toolbar, click Build All.

Polygon 1 (pol1)
1 On the Geometry toolbar, click More Primitives and choose Polygon.

2 In the Settings window for Polygon, locate the Coordinates section.

3 In the x text field, type 0 0.

4 In the y text field, type -2 2.

5 In the z text field, type 4 4.

6 On the Geometry toolbar, click Build All.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.
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2 Go to the Add Material window.

3 In the tree, select Built-In>Steel AISI 4340.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

On the Home toolbar, click Add Material to close the Add Material window.

Material 2 (mat2)
1 On the Materials toolbar, click Blank Material.

2 In the Settings window for Material, type Ceramic 1 in the Label text field.

3 Select Domain 2 only.

4 Locate the Material Contents section. In the table, enter the following settings:

Material 3 (mat3)
1 On the Materials toolbar, click Blank Material.

2 In the Settings window for Material, type Ceramic 2 in the Label text field.

3 Select Domain 3 only.

4 Locate the Material Contents section. In the table, enter the following settings:

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 3 only.

Property Name Value Unit Property 
group

Thermal conductivity k 1 W/(m·K) Basic

Density rho 6000 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 320 J/(kg·K) Basic

Property Name Value Unit Property 
group

Thermal conductivity k 0.5 W/(m·K) Basic

Density rho 5800 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 280 J/(kg·K) Basic
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Temperature 2
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 13 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type T_hot.

M E S H  1

First, mesh the top surface with a free triangular mesh and extrude it in layers through the 
cylindrical geometry. With a Distribution node, specify how many mesh layers are to be 
created within the domain. Resolve the composite layers with two elements in thickness.

1 On the Mesh toolbar, click Boundary and choose Free Triangular.

Free Triangular 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Free Triangular 1.

2 Select Boundaries 13 and 18 only.

3 In the Settings window for Free Triangular, click Build Selected.

4 On the Mesh toolbar, click Swept.

Swept 1
Click Distribution.

Distribution 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1>Swept 1 click 

Distribution 1.

2 Select Domains 2 and 3 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 2.

5 Click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
The following plots are produced by default: temperature profile on the surface as in 
Figure 2, and isothermal contours.
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Surface
1 In the Model Builder window, expand the Temperature (ht) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

4 On the Temperature (ht) toolbar, click Plot.

Next, create a temperature profile along the height of the cylinder. You will later compare 
the graph with the results of the 2D approach.

1D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Temperature Profile in the Label 
text field.

3 Locate the Plot Settings section. Select the x-axis label check box.

4 In the associated text field, type Height (cm).

5 Click to expand the Title section. From the Title type list, choose Manual.

6 In the Title text area, type Temperature Profile.

7 Click to expand the Legend section. From the Position list, choose Upper left.

Line Graph 1
1 On the Temperature Profile toolbar, click Line Graph.

2 Select Edges 15, 17, 19, and 21 only.

3 In the Settings window for Line Graph, locate the y-Axis Data section.

4 From the Unit list, choose degC.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type z.

7 Click to expand the Coloring and style section. Locate the Coloring and Style section. In 
the Width text field, type 2.

8 Click to expand the Legends section. Select the Show legends check box.

9 From the Legends list, choose Manual.

10 In the table, enter the following settings:

11 On the Temperature Profile toolbar, click Plot.

Legends

Temperature, 3D approach
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Create now the second model which uses the Thin Layer feature and compare the results 
to the first approach.

R O O T

1 On the Home toolbar, click Add Component and choose 3D.

2 In the Model Builder window, click the root node.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Heat Transfer>Heat Transfer in Solids (ht).

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Study 1.

5 Click Add to Component in the window toolbar.

R O O T

On the Home toolbar, click Add Physics to close the Add Physics window.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Heat Transfer in Solids (ht) interface.

5 Click Add Study in the window toolbar.

R O O T

On the Home toolbar, click Add Study to close the Add Study window.

G E O M E T R Y  2

1 In the Model Builder window, under Component 2 (comp2) click Geometry 2.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose cm.

Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.
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3 In the Radius text field, type 2.

4 In the Height text field, type 4.

5 Click to expand the Layers section. In the table, enter the following settings:

6 Clear the Layers on side check box.

7 Select the Layers on bottom check box.

8 On the Geometry toolbar, click Build All.

Polygon 1 (pol1)
1 On the Geometry toolbar, click More Primitives and choose Polygon.

2 In the Settings window for Polygon, locate the Coordinates section.

3 In the x text field, type 0 0.

4 In the y text field, type -2 2.

5 In the z text field, type 4 4.

6 On the Geometry toolbar, click Build All.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Recent Materials>Steel AISI 4340.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

H E A T  TR A N S F E R  I N  S O L I D S  2  ( H T 2 )

Thin Layer 1
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 Select Boundary 6 only.

3 In the Settings window for Thin Layer, locate the Thin Layer section.

4 Select the Multiple layers check box.

5 Locate the Heat Conduction section. From the Number of layers list, choose 2.

6 Find the Layer 1 (upside) subsection. From the list, choose Ceramic 1 (mat2).

7 In the ds1 text field, type d_ceram1.

Layer name Thickness (cm)

Layer 1 2
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8 Find the Layer 2 (downside) subsection. From the list, choose Ceramic 2 (mat3).

9 In the ds2 text field, type d_ceram2.

Thin Layer 2
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 Select Boundary 6 only.

3 In the Settings window for Thin Layer, locate the Thin Layer section.

4 From the Layer type list, choose General.

5 Locate the Heat Conduction section. From the Number of layers list, choose 2.

6 Find the Layer 1 (upside) subsection. From the list, choose Ceramic 1 (mat2).

7 In the ds1 text field, type d_ceram1.

8 Find the Layer 2 (downside) subsection. From the list, choose Ceramic 2 (mat3).

9 In the ds2 text field, type d_ceram2.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 3 only.

Temperature 2
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 7 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type T_hot.

S T U D Y  2

Step 1: Stationary
1 In the Model Builder window, under Study 2 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify physics tree and variables for study step check box.

Disable Thin Layer 2 in this study. First, Thin Layer 1 is used to show the results with the 
Resistive option. Later, another study will use Thin Layer 2 with the General option.

4 In the Physics and variables selection tree, select Component 2 (comp2)>Heat Transfer in 

Solids 2 (ht2)>Thin Layer 2.

5 Click Disable.
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M E S H  2

On the Mesh toolbar, click Boundary and choose Free Triangular.

Free Triangular 1
1 In the Model Builder window, under Component 2 (comp2)>Mesh 2 click Free Triangular 1.

2 Select Boundaries 7 and 10 only.

3 In the Settings window for Free Triangular, click Build Selected.

4 On the Mesh toolbar, click Swept.

5 In the Model Builder window, click Mesh 2.

6 In the Settings window for Mesh, click Build All.

S T U D Y  2

On the Home toolbar, click Compute.

R E S U L T S

Surface
1 In the Model Builder window, expand the Temperature (ht2) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

Temperature Profile
In the Model Builder window, under Results click Temperature Profile.

Line Graph 2
1 On the Temperature Profile toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (3) (sol2).

4 Select Edges 9 and 11 only.

5 Click Replace Expression in the upper-right corner of the y-axis data section. From the 
menu, choose Model>Component 2>Heat Transfer in Solids 2>Temperature>T2 - 

Temperature.

6 Locate the y-Axis Data section. From the Unit list, choose degC.

7 Locate the x-Axis Data section. From the Parameter list, choose Expression.

8 In the Expression text field, type z.

9 Click to expand the Coloring and style section. Locate the Coloring and Style section. Find 
the Line style subsection. From the Line list, choose None.
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10 From the Color list, choose Magenta.

11 Find the Line markers subsection. From the Marker list, choose Cycle.

12 In the Number text field, type 15.

13 Locate the Legends section. Select the Show legends check box.

14 From the Legends list, choose Manual.

15 In the table, enter the following settings:

16 On the Temperature Profile toolbar, click Plot.

Add now a new study to solve Component 2 with Thin Layer 2 instead of Thin Layer 1. The 
Thin Layer 2 feature would use the General option which creates a 1D extra dimension 
formed by two intervals to represent the two ceramic layers.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Heat Transfer in Solids (ht) interface.

5 Click Add Study in the window toolbar.

S T U D Y  3

Step 1: Stationary
1 On the Home toolbar, click Add Study to close the Add Study window.

2 In the Model Builder window, under Study 3 click Step 1: Stationary.

3 In the Settings window for Stationary, locate the Physics and Variables Selection section.

4 Select the Modify physics tree and variables for study step check box.

5 In the Physics and variables selection tree, select Component 2 (comp2)>Heat Transfer in 

Solids 2 (ht2)>Thin Layer 1.

6 Click Disable.

7 On the Home toolbar, click Compute.

Legends

Temperature, 2D approach
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R E S U L T S

Surface
1 In the Model Builder window, expand the Temperature (ht2) 1 node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

Temperature Profile
In the Model Builder window, under Results click Temperature Profile.

Line Graph 3
1 On the Temperature Profile toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Data set list, choose Study 3/Solution 3 (5) (sol3).

4 Select Edges 9 and 11 only.

5 Locate the y-Axis Data section. In the Expression text field, type T2.

6 From the Unit list, choose degC.

7 Locate the x-Axis Data section. From the Parameter list, choose Expression.

8 In the Expression text field, type z.

9 Click to expand the Coloring and style section. Locate the Coloring and Style section. Find 
the Line style subsection. From the Line list, choose None.

10 From the Color list, choose Black.

11 In the Width text field, type 2.

12 Find the Line markers subsection. From the Marker list, choose Triangle.

13 In the Number text field, type 20.

14 Locate the Legends section. Select the Show legends check box.

15 From the Legends list, choose Manual.

16 In the table, enter the following settings:

17 On the Temperature Profile toolbar, click Plot.

The plot should look like that in Figure 3.

Legends

Temperature, 1D extra dimension approach
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Introduction

Many systems, for example electronic devices, risk being damaged if exposed to 
condensation. Given an amount of moisture in the air, condensation occurs when the 
temperature decreases to reach the dew point. Numerical simulations are useful for 
obtaining knowledge relevant for preventing the formation of condensation.

Changes in air properties are the primary cause of condensation in some systems. This 
example simulates the thermodynamical evolution of moist air in an electronic box with 
the aim of detecting whether condensation occurs when the external environment 
properties change. The model uses meteorological data for the air temperature, pressure, 
and relative humidity, measured at New York, JFK station. The property data correspond 
to average conditions of dry bulb temperature and high conditions of dew point 
temperature, observed on the 1st of June.

In this simulation, you assume the water vapor concentration to be homogeneous inside 
the box and equal to the external concentration. Also, the model setup neglects diffusion 
but considers the external concentration changes during the simulation.

Note: An extension of this application solves for an inhomogeneous concentration 
computed from the Transport of Diluted Species interface and takes transport and 
diffusion of the water vapor into account, see Condensation Detection in an Electronic 
Device with Transport and Diffusion. It requires the Chemical Reaction Engineering 
Module.

Model Definition

A box with square cross section of side 5 cm is placed in a moist air environment. It 
contains a heated electronic component and two small slits (1 mm thick) located at the left 
and right sides. The simulation is in a 2D cross section of the box, which is supposed to 
be long enough in the orthogonal direction. It is made of aluminum and the electronic 
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component is made of silicon. Figure 1 shows the model geometry.

Figure 1: Geometry of the model.

The box is placed in a changing environment. This means that during the simulation, 
temperature, pressure, and relativc humidity change. Figure 2 shows the temperature and 
relative humidity as functions of time.

In this simulation, assume the moist air concentration inside the box to be equal to the 
external concentration.

Outside the box, you apply a convective cooling condition with a heat transfer coefficient 
h equal to 10 W/(m2·K) and a time-dependent external temperature equal to the ambient 
temperature. The central component produces a total power of 1 W during the simulation. 
At the slit boundaries, set a condition of open boundary to let external moist air freely 
enter or exit from the box.
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The study computes a simulation over one day and the solution is stored every 30 minutes. 
The goal is to observe if some condensation appears.

Figure 2: Temperature and relative humidity over the course of a day.

Results and Discussion

Figure 3 shows the temperature and relative humidity profiles at the final time step. 
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Figure 3: Temperature and relative humidity profiles after 24 hours.
5 |  C O N D E N S A T I O N  D E T E C T I O N  I N  A N  E L E C T R O N I C  D E V I C E



While the temperature gradient is not very large, the power dissipated from the electronic 
component clearly influences the temperature field: it heats the surrounding air and the 
walls. Cold air enters through the slits by convection. In addition, the air inside the box is 
cooled by conduction through the walls. The relative humidity maximum is located where 
the temperature is the lowest but also where the water vapor concentration is the highest.

Figure 4: Maximum relative humidity over time inside the box.

Figure 4 represents the evolution of the maximum relative humidity inside the box over 
the simulation period. This curve reaches a maximum of 100% several times, meaning that 
condensation occurs. A Boolean condensation indicator is inserted in order to distinguish 
the exact condensation period. The condensation indicator is set to 1 when condensation 
is detected (relative humidity equals 1) and to 0 otherwise.

Application Library path: Heat_Transfer_Module/
Power_Electronics_and_Electronic_Cooling/

condensation_electronic_device
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Heat Transfer>Conjugate Heat Transfer>Laminar Flow.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Time 

Dependent.

6 Click Done.

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
condensation_electronic_device.mphbin.

5 Click Import.

The imported geometry is represented in Figure 1.

M A T E R I A L S

A material is only needed on the solid part as the fluid part is going to be defined at the 
feature level through the moist air functionality.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Aluminum.

4 Click Add to Component in the window toolbar.
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M A T E R I A L S

Aluminum (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Aluminum 

(mat1).

2 Select Domains 1 and 3 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Silica glass.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Silica glass (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Silica glass 

(mat2).

2 Select Domain 4 only.

3 On the Home toolbar, click Add Material to close the Add Material window.

H E A T  TR A N S F E R  ( H T )

1 In the Model Builder window, under Component 1 (comp1) click Heat Transfer (ht).

2 In the Settings window for Heat Transfer, locate the Ambient Settings section.

3 From the Ambient data list, choose Meteorological data (ASHRAE 2013).

4 Find the Time subsection. In the table, enter the following settings:

5 Find the Ambient conditions subsection. From the Temperature list, choose Low.

Fluid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Fluid 

1.

2 Select Domain 2 only.

3 In the Settings window for Fluid, locate the Thermodynamics, Fluid section.

4 From the Fluid type list, choose Moist air.

5 From the Input quantity list, choose Relative humidity.

Hour Minute Second

0 0 0
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6 From the φref list, choose Ambient relative humidity (ht).

7 From the Tref list, choose Ambient temperature (ht).

8 From the pref list, choose Ambient absolute pressure (ht).

9 Locate the Domain Selection section. Click Create Selection.

10 In the Create Selection dialog box, type Moist Air in the Selection name text field.

11 Click OK.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Initial 

Values 1.

2 In the Settings window for Initial Values, choose Ambient temperature (ht) from the T 
list.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 1, 2, 5, 7, 21, and 23 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type 10.

6 From the Text list, choose Ambient temperature (ht).

Heat Source 1
1 On the Physics toolbar, click Domains and choose Heat Source.

2 Select Domain 4 only.

3 In the Settings window for Heat Source, locate the Heat Source section.

4 Click the Heat rate button.

5 In the P0 text field, type 1.

Open Boundary 1
1 On the Physics toolbar, click Boundaries and choose Open Boundary.

2 Select Boundaries 3 and 22 only.

3 In the Settings window for Open Boundary, locate the Open Boundary section.

4 From the T0 list, choose Ambient temperature (ht).

L A M I N A R  F L O W  ( S P F )

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).
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2 In the Settings window for Laminar Flow, locate the Domain Selection section.

3 From the Selection list, choose Moist Air.

Fluid Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Laminar Flow (spf) click Fluid 

Properties 1.

2 In the Settings window for Fluid Properties, locate the Fluid Properties section.

3 From the μ list, choose Dynamic viscosity (ht/fluid1).

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Laminar Flow (spf) click Initial 

Values 1.

2 In the Settings window for Initial Values, locate the Initial Values section.

3 In the p text field, type ht.p_amb-spf.pref.

4 In the Model Builder window, click Laminar Flow (spf).

Open Boundary 1
1 On the Physics toolbar, click Boundaries and choose Open Boundary.

2 Select Boundaries 3 and 22 only.

3 In the Settings window for Open Boundary, locate the Boundary Condition section.

4 In the f0 text field, type ht.p_amb-spf.pref.

D E F I N I T I O N S

Then, two probes are defined in order to get the maximum relative humidity and the 
condensation indicator at the solver time steps.

Domain Probe 1 (dom1)
1 On the Definitions toolbar, click Probes and choose Domain Probe.

2 In the Settings window for Domain Probe, locate the Source Selection section.

3 Click Clear Selection.

4 Select Domain 2 only.

5 Locate the Probe Type section. From the Type list, choose Maximum.

6 Click Replace Expression in the upper-right corner of the Expression section. From the 
menu, choose Model>Component 1 (comp1)>Heat Transfer>Moist air>ht.phi - Relative 

humidity.
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Domain Probe 2 (dom2)
1 On the Definitions toolbar, click Probes and choose Domain Probe.

2 In the Settings window for Domain Probe, locate the Source Selection section.

3 Click Clear Selection.

4 Select Domain 2 only.

5 Locate the Probe Type section. From the Type list, choose Maximum.

6 Click Replace Expression in the upper-right corner of the Expression section. From the 
menu, choose Model>Component 1 (comp1)>Heat Transfer>Moist air>ht.condInd - 

Condensation indicator.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, under Study 1 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 From the Time unit list, choose h.

4 Click Range.

5 In the Range dialog box, type 0.5 in the Step text field.

6 In the Stop text field, type 24.

7 Click Replace.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Time-Dependent Solver 1>Segregated 1 node, then click Velocity u, Pressure p.

4 In the Settings window for Segregated Step, click to expand the Method and termination 
section.

5 Locate the Method and Termination section. From the Jacobian update list, choose On 

every iteration.

Because the problem is nonlinear, updating the Jacobian on every iteration yields faster 
resolution.

6 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1)>

Time-Dependent Solver 1>Segregated 1 click Temperature T.
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7 In the Settings window for Segregated Step, click to expand the Method and termination 
section.

8 Locate the Method and Termination section. From the Jacobian update list, choose On 

every iteration.

9 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1) click 
Time-Dependent Solver 1.

10 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

11 Locate the Time Stepping section. Select the Maximum step check box.

12 In the associated text field, type 0.25.

Because the temperature and pressure variations can be quick, forcing a reduced time 
step helps to capture all curve variations.

13 On the Study toolbar, click Compute.

R E S U L T S

Temperature (ht)
This default plot represents the temperature profile at the last time step, as shown in the 
top panel of Figure 3.

Velocity (spf)
This default plot shows the velocity profile at the last time step.

2D Plot Group 6
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Relative Humidity in the Label text 
field.

3 On the Relative Humidity toolbar, click Surface.

Surface 1
1 In the Model Builder window, under Results>Relative Humidity click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Heat Transfer>

Moist air>ht.phi - Relative humidity.

3 On the Relative Humidity toolbar, click Plot.

Compare with the relative humidity profile in the bottom panel of Figure 3.
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Probe Plot Group 5
Follow the steps below to reproduce the relative humidity evolution shown in Figure 4.

1 In the Model Builder window, under Results click Probe Plot Group 5.

2 In the Settings window for 1D Plot Group, type Maximum Relative Humidity in the 
Label text field.

Probe Table Graph 1
1 In the Model Builder window, expand the Results>Maximum Relative Humidity node, then 

click Probe Table Graph 1.

2 In the Settings window for Table Graph, click to expand the Legends section.

3 Select the Show legends check box.

4 From the Legends list, choose Manual.

5 In the table, enter the following settings:

Maximum Relative Humidity
1 In the Model Builder window, under Results click Maximum Relative Humidity.

2 In the Settings window for 1D Plot Group, click to expand the Legend section.

3 From the Position list, choose Lower right.

4 Click to expand the Window settings section. Locate the Window Settings section. From 
the Plot window list, choose Graphics.

5 On the Maximum Relative Humidity toolbar, click Plot.

Finally, plot the ambient temperature and relative humidity to reproduce Figure 2.

1D Plot Group 7
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Ambient Temperature in the Label 
text field.

3 Click to expand the Title section. From the Title type list, choose Manual.

4 In the Title text area, type ht.T_amb (K).

Point Graph 1
1 On the Ambient Temperature toolbar, click Point Graph.

Legends

Maximum Relative Humidity

Condensation Indicator
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2 Select Point 10 only.

3 In the Settings window for Point Graph, locate the y-Axis Data section.

4 In the Expression text field, type ht.T_amb.

5 On the Ambient Temperature toolbar, click Plot.

This figure should look like the left curve of Figure 2.

1D Plot Group 8
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Ambient Relative Humidity in the 
Label text field.

3 Click to expand the Title section. From the Title type list, choose Manual.

4 In the Title text area, type ht.phi_amb (1).

Point Graph 1
1 On the Ambient Relative Humidity toolbar, click Point Graph.

2 Select Point 10 only.

3 In the Settings window for Point Graph, locate the y-Axis Data section.

4 In the Expression text field, type ht.phi_amb.

5 On the Ambient Relative Humidity toolbar, click Plot.

This figure should look like the right curve of Figure 2.
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Introduction

The response of a millimeter wave with frequencies of 35 GHz and 95 GHz is known to 
be very sensitive to water content. This model utilizes a low-power 35 GHz Ka-band 
millimeter wave and its reflectivity to moisture for non-invasive cancer diagnosis. Since skin 
tumors contain more moisture than healthy skin, it leads to stronger reflections on this 
frequency band. Hence the probe detects abnormalities in terms of S-parameters at the 
tumor locations. A circular waveguide at the dominant mode and a conically tapered 
dielectric probe are quickly analyzed, along with the probe’s radiation characteristics, using 
a 2D axisymmetric model. Temperature variation of the skin and the fraction of necrotic 
tissue analysis are also performed as well.

Figure 1: 3D visualization of the 2D axisymmetric model. The probe consists of a circular 
waveguide and a tapered dielectric rod.

Model Definition

The model consists of a metallic circular waveguide, a tapered PTFE dielectric rod, and a 
phantom of skin chunk shown in Figure 1. The entire model is enclosed by an air domain 
which is truncated at its outermost shell with perfectly matched layers (PML) to absorb 
any radiation directly from the rod or reflected from the skin phantom. One end of the 
waveguide is terminated with a circular port and excited using the dominant TE1m mode, 

Chunk of skin

Circular waveguide

Tapered PTFE probe
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where m is the azimuthal mode number of this 2D axisymmetric model defined as 1 in the 
Electromagnetic Waves, Frequency Domain physics interface settings. The other end is 
connected to a tapered conical PTFE dielectric (εr = 2.1) rod. The shape of the rod is 
symmetrically tapered so the radius is increasing from the inside to the outside of the 
waveguide, then it is decreasing gradually for the impedance matching between the 
waveguide and the air domain. There is a ring structure in the middle to support the rod 
on the rim of the waveguide. The tip of the rod is touching the skin phantom.

The conductivity of the metallic waveguide is assumed to be high enough to neglect any 
loss and is modeled as perfect electric conductor (PEC). With the given radius of the 
waveguide and excited TE mode, the cutoff frequency is around 29.3 GHz, which is 
calculated by

where c0 is the speed of light, p′nm are the roots of the derivative of the Bessel functions 
Jn(x), m and n are the mode indices, and a is the radius of the waveguide. The value of 
p′11 is approximately 1.841. The operating frequency of the probe, 35 GHz, is higher 
than the waveguide cutoff frequency. The excited wave is propagating along the 
waveguide.

The circular port boundary condition is placed on the interior boundary where the 
reflection and transmission characteristics are computed automatically in terms of 
S-parameters. The interior port boundary with PEC backing for one-way excitation 
requires the slit condition. The port orientation is specified to define the inward direction 
for the S-parameter calculation.

First, the electromagnetic properties of the model are analyzed without a phantom to 
check the design validity of the waveguide and dielectric rod. Then, complexity is added, 
first with a healthy phantom, then a phantom with a skin tumor. See Table 1.

TABLE 1:  MATERIAL PROPERTY VARIATION

PROPERTY PROBE ONLY WITH A HEALTHY 
PHANTOM 

TUMOR ADDED

Relative permittivity 
(imaginary part)

0 10 15

Relative permittivity 
(real part)

1 5 8

fcml

c0p'nm

2πa
-----------------=
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Figure 2: Zoomed 3D visualization of the skin tumor area. The entire probe model is simulated 
in a 2D axisymmetric space dimension. The measured S-parameters vary due to the different 
moisture content in each skin phantom.

Though the waveguide excited by low power is expected to be harmless, its effect on 
necrotic tissue is reviewed by studying Bioheat Transfer as well as temperature, over a 
10 minute period.

Healthy skin

Added tumor part
0.7 mm thick
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Results and Discussion 

Figure 3 shows the real part of the electric field Er excited from one end of the waveguide 
without a phantom. Its radiation pattern is visualized in the Modeling Instructions section.

Figure 3: Wave propagation from the dielectric rod plotted with the Er component of the 
E-field (probe-only case without a phantom).

Temperature change on the surface of the phantom with the tumor is plotted in Figure 4. 
Since the input power from the waveguide port is low, 1 mW, the temperature change is 
within 0.06° even after 10 minutes of millimeter wave exposure. The color difference 
shows the relatively hotter spot where the temperature is still very close to the initial 
temperature, 34 °C. Though the temperature analysis for the healthy phantom case is not 
included, it is easily expected that the temperature variation is less than the case with the 
tumor because the resistive loss should be lower due to the smaller imaginary part of the 
permittivity of the healthy skin. So the visualized temperature profile is the worst-case 
scenario of temperature increase among all three cases. The damaged tissue ratio is 
visualized in Figure 5. It shows that the effect of the low-power millimeter wave is 
negligible.
5 |  M O D E L I N G  A  C O N I C A L  D I E L E C T R I C  P R O B E  F O R  S K I N  C A N C E R  D I A G N O S I S



The computed S-parameters indicate more reflection when touching the skin with the 
tumor due to its higher moisture content, and they are approximately summarized below:

Figure 4: The temperature after 10 minutes. The variation compared to the initial 
temperature is negligible in the case where the tumor is added at the center of the center top of 
skin surface.

The modeling instructions show how to access the data plotted in Figure 6 which is not 
the dependent variable of the Electromagnetic Waves, Frequency Domain, by tweaking 
the solver settings.

TABLE 2:  S-PARAMETER RESPONSE OF THE PROBE

PROBE ONLY WITH A HEALTHY 
PHANTOM 

TUMOR ADDED

S11 -29.5 dB -9.84 dB -8.97 dB
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Figure 5: Fraction of necrotic (damaged) tissue is extremely low even after 10 minutes of 
millimeter wave exposure in the case where the tumor is added at the center of the center top 
of skin surface.

Figure 6: The resistive losses in the case where the tumor is added at the center of the center top 
of skin surface.
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Notes About the COMSOL Implementation 

The electromagnetic material properties of skin and tumor at 35 GHz are approximated 
to show the feasibility of the S-parameter method by detecting the areas with higher 
moisture content. For any further research, extracting accurate data in the given frequency 
range is recommended.

Application Library path: Heat_Transfer_Module/Medical_Technology/
conical_dielectric_probe

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Radio Frequency>Electromagnetic Waves, Frequency 

Domain (emw).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Frequency Domain.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Circle 1 (c1)
1 On the Geometry toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type 75.

4 In the Sector angle text field, type 180.

5 Locate the Rotation Angle section. In the Rotation text field, type 270.

6 Click to expand the Layers section. In the table, enter the following settings:

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type r1.

Name Expression Value Description

r1 0.003[m] 0.003 m Waveguide radius

fc 1.841*c_const/2/
pi/r1

2.928E10 1/s Cutoff frequency

f0 35[GHz] 3.5E10 Hz Frequency

lda0 c_const/f0 0.0085655 m Wavelength, free 
space

l_probe 12.8[mm] 0.0128 m Tapered probe 
length

w1_probe 3[mm] 0.003 m Tapered probe 
width1

w2_probe 0.58[mm] 5.8E-4 m Tapered probe 
width2

T0 34[degC] 307.15 K Initial skin 
temperature

Layer name Thickness (mm)

Layer 1 lda0
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4 In the Height text field, type 50.

Rectangle 2 (r2)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Height text field, type 50.

4 Locate the Position section. In the r text field, type 3.

Bézier Polygon 1 (b1)
1 On the Geometry toolbar, click Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the Polygon Segments section.

3 Find the Added segments subsection. Click Add Linear.

4 Find the Control points subsection. In row 1, set z to -l_probe.

5 In row 2, set r to w2_probe and z to -l_probe.

6 Find the Added segments subsection. Click Add Linear.

7 Find the Control points subsection. In row 2, set r to w1_probe and z to 0.

8 Find the Added segments subsection. Click Add Linear.

9 Find the Control points subsection. In row 2, set r to 0.

10 Find the Added segments subsection. Click Add Linear.

11 Find the Control points subsection. In row 2, set z to -l_probe.

Mirror 1 (mir1)
1 Right-click Bézier Polygon 1 (b1) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Mirror.

3 Select the object b1 only.

4 In the Settings window for Mirror, locate the Input section.

5 Select the Keep input objects check box.

6 Locate the Normal Vector to Line of Reflection section. In the r text field, type 0.

7 In the z text field, type 1.

Rectangle 3 (r3)
1 Right-click Mirror 1 (mir1) and choose Build Selected.

2 On the Geometry toolbar, click Primitives and choose Rectangle.

3 In the Settings window for Rectangle, locate the Size and Shape section.

4 In the Width text field, type 4.
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5 In the Height text field, type 1.

6 Locate the Position section. In the z text field, type -1.

Fillet 1 (fil1)
1 On the Geometry toolbar, click Fillet.

2 Click the Select Box button on the Graphics toolbar.

3 On the object r3, select Point 2 only.

4 In the Settings window for Fillet, locate the Radius section.

5 In the Radius text field, type 0.5.

Rectangle 4 (r4)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 35.

4 In the Height text field, type 32.2.

5 Locate the Position section. In the z text field, type -45.

Fillet 2 (fil2)
1 On the Geometry toolbar, click Fillet.

2 Click the Select Box button on the Graphics toolbar.

3 On the object r4, select Points 2 and 3 only.

4 In the Settings window for Fillet, locate the Radius section.

5 In the Radius text field, type 10.

Rectangle 5 (r5)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 6.5.

4 In the Height text field, type 0.7.

5 Locate the Position section. In the z text field, type -13.5.
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6 Click Build All Objects.

D E F I N I T I O N S

Perfectly Matched Layer 1 (pml1)
1 On the Definitions toolbar, click Perfectly Matched Layer.

2 Select Domains 1 and 9 only.
12 |  M O D E L I N G  A  C O N I C A L  D I E L E C T R I C  P R O B E  F O R  S K I N  C A N C E R  D I A G N O S I S



A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Air.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Air (mat1)
On the Home toolbar, click Add Material to close the Add Material window.

Material 2 (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials right-click Air 

(mat1) and choose Blank Material.

2 In the Settings window for Material, type PTFE in the Label text field.

3 Select Domains 5–7 and 10 only.

4 Locate the Material Contents section. In the table, enter the following settings:

Property Name Value Unit Property 
group

Relative permittivity epsilonr 2.1 1 Basic
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E L E C T R O M A G N E T I C  WA V E S ,  F R E Q U E N C Y  D O M A I N  ( E M W )

1 In the Model Builder window, under Component 1 (comp1) click Electromagnetic Waves, 

Frequency Domain (emw).

2 In the Settings window for Electromagnetic Waves, Frequency Domain, locate the 
Out-of-Plane Wave Number section.

3 In the m text field, type 1.

4 Locate the Physics-Controlled Mesh section. Select the Enable check box.

5 In the Maximum element size in free space text field, type lda0/8.

6 Locate the Analysis Methodology section. From the Methodology options list, choose Fast.

Perfect Electric Conductor 2
1 On the Physics toolbar, click Boundaries and choose Perfect Electric Conductor.

2 Click the Select Box button on the Graphics toolbar.

3 Select Boundaries 23–25 and 27 only.

Port 1
1 On the Physics toolbar, click Boundaries and choose Port.

Relative permeability mur 1 1 Basic

Electrical conductivity sigma 0 S/m Basic

Property Name Value Unit Property 
group
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2 Select Boundary 16 only.

3 In the Settings window for Port, locate the Port Properties section.

4 From the Type of port list, choose Circular.

5 From the Wave excitation at this port list, choose On.

6 In the Pin text field, type 1[mW].

The input power is 0 dBm.

7 Select the Activate slit condition on interior port check box.

8 From the Port orientation list, choose Reverse.

Far-Field Domain 1
On the Physics toolbar, click Domains and choose Far-Field Domain.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.
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2 In the Settings window for Mesh, click Build All.

S T U D Y  1

Step 1: Frequency Domain
1 In the Settings window for Frequency Domain, locate the Study Settings section.

2 In the Frequencies text field, type f0.

3 On the Home toolbar, click Compute.

R E S U L T S

Surface
1 In the Model Builder window, expand the Electric Field (emw) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type emw.Er.

4 Locate the Coloring and Style section. From the Color table list, choose Wave.

5 On the Electric Field (emw) toolbar, click Plot.

See Figure 3 for the plot of the real part of Er, showing wave propagation from the 
input port to the air domain via the tapered dielectric probe.
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2D Far Field (emw)
In the Settings window for Polar Plot Group, type Far Field, Polar in the Label text 
field.

Far Field 1
1 In the Model Builder window, expand the 2D Far Field (emw) node, then click Results>Far 

Field, Polar>Far Field 1.

2 In the Settings window for Far Field, locate the Evaluation section.

3 Find the Reference direction subsection. In the y text field, type 1.

4 In the z text field, type 0.

5 Find the Normal subsection. In the x text field, type 1.

6 In the y text field, type 0.

7 On the Far Field, Polar toolbar, click Plot.

The Far-field pattern on the yz-plane shows the radiation from the tapered probe 
toward the bottom side.

3D Far Field (emw)
1 In the Model Builder window, expand the Results>3D Far Field (emw) node, then click 3D 

Far Field (emw).
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2 In the Settings window for 3D Plot Group, type Far Field, 3D in the Label text field.

The 3D far-field pattern is directed along the z-axis.

S-parameter, S11dB (emw)
1 In the Model Builder window, expand the Results>Derived Values node, then click 

S-parameter, S11dB (emw).

2 In the Settings window for Global Evaluation, click Evaluate.

The evaluated S-parameter is the input matching property of the circular waveguide 
without a human body phantom when the dominant mode is excited.

E L E C T R O M A G N E T I C  WA V E S ,  F R E Q U E N C Y  D O M A I N  ( E M W )

Add another Wave Equation which describe the human body phantom in term of dielectric 
loss using a complex permittivity.

Wave Equation, Electric 2
1 On the Physics toolbar, click Domains and choose Wave Equation, Electric.

2 Select Domains 3 and 4 only.

3 In the Settings window for Wave Equation, Electric, locate the Electric Displacement Field 
section.

4 From the Electric displacement field model list, choose Dielectric loss.
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A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Bioheat>Skin.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Skin (mat3)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Skin (mat3).

2 Select Domains 3 and 4 only.

3 In the Model Builder window, click Skin (mat3).

4 In the Settings window for Material, locate the Material Contents section.

5 In the table, enter the following settings:

Property Name Value Unit Property 
group

Relative permittivity 
(imaginary part)

epsilonBis 10 1 Dielectric 
losses

Relative permittivity 
(real part)

epsilonPrim 5 1 Dielectric 
losses
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6 On the Home toolbar, click Add Material to close the Add Material window.

7 On the Home toolbar, click Compute.

R E S U L T S

S-parameter, S11dB (emw)
Evaluate the S-parameter assuming the probe is touching a phantom representing a 
healthy body.

1 In the Model Builder window, under Results>Derived Values click S-parameter, S11dB 

(emw).

2 In the Settings window for Global Evaluation, click Evaluate.

Far Field, 3D
1 Click the Zoom Extents button on the Graphics toolbar.

Due to the body, the radiation is reflected back.

Relative permeability mur 1 1 Basic

Electrical conductivity sigma 0 S/m Basic

Property Name Value Unit Property 
group
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M A T E R I A L S

Skin (mat3)
Now, add a tip of tumor skin.

Skin 1 (mat4)
1 In the Model Builder window, under Component 1 (comp1)>Materials right-click Skin 

(mat3) and choose Duplicate.

2 In the Settings window for Material, type Skin Tumor in the Label text field.

3 Locate the Geometric Entity Selection section. Click Clear Selection.

4 Select Domain 4 only.

5 Locate the Material Contents section. In the table, enter the following settings:

The effect of millimeter wave radiation on a human body will be investigated using the 
Bioheat Transfer physics interface.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Heat Transfer>Bioheat Transfer (ht).

4 Click Add to Component in the window toolbar.

B I O H E A T  TR A N S F E R  ( H T )

1 On the Home toolbar, click Add Physics to close the Add Physics window.

2 In the Model Builder window, under Component 1 (comp1) click Bioheat Transfer (ht).

3 In the Settings window for Bioheat Transfer, locate the Domain Selection section.

4 Click Clear Selection.

5 Select Domains 3 and 4 only.

Property Name Value Unit Property 
group

Relative permittivity 
(imaginary part)

epsilonBis 15 1 Dielectric 
losses

Relative permittivity 
(real part)

epsilonPrim 8 1 Dielectric 
losses
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Biological Tissue 1
1 In the Model Builder window, under Component 1 (comp1)>Bioheat Transfer (ht) click 

Biological Tissue 1.

2 In the Settings window for Biological Tissue, locate the Damaged Tissue section.

3 Select the Include damage integral analysis check box.

4 From the Damage integral form list, choose Energy absorption.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Bioheat Transfer (ht) click 

Initial Values 1.

2 In the Settings window for Initial Values, type T0 in the T text field.

Open Boundary 1
1 On the Physics toolbar, click Boundaries and choose Open Boundary.

2 Select Boundaries 4, 8, 19, 29, 30, 37, and 38 only.

M U L T I P H Y S I C S

Electromagnetic Heat Source 1 (emh1)
1 On the Physics toolbar, click Multiphysics and choose Domain>Electromagnetic Heat 

Source.

2 Select Domains 3 and 4 only.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Custom Studies>Preset Studies 

for Some Physics Interfaces>Frequency Domain.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Bioheat Transfer (ht) interface.

5 Click Add Study in the window toolbar.

S T U D Y  2

Step 1: Frequency Domain
1 On the Home toolbar, click Add Study to close the Add Study window.

2 In the Model Builder window, under Study 2 click Step 1: Frequency Domain.

3 In the Settings window for Frequency Domain, locate the Study Settings section.
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4 In the Frequencies text field, type f0.

Time Dependent
On the Study toolbar, click Study Steps and choose Time Dependent>Time Dependent.

Step 2: Time Dependent
1 In the Settings window for Time Dependent, locate the Study Settings section.

2 From the Time unit list, choose min.

3 In the Times text field, type range(0,15[s],10).

4 Locate the Physics and Variables Selection section. In the table, clear the Solve for check 
box for the Electromagnetic Waves, Frequency Domain (emw) interface.

5 In the Model Builder window, click Study 2.

6 In the Settings window for Study, locate the Study Settings section.

7 Clear the Generate default plots check box.

Solution 2 (sol2)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, right-click Solution 2 (sol2) and choose Other>Solution 

Store.

3 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Solution Store 1 (sol3) and 
choose Move Up, three times, so it locates right below Stationary Solver 1. This allows to 
access the solution more than the dependent variable in Frequency Domain study step.

R E S U L T S

Revolution 2D 2
1 On the Results toolbar, click More Data Sets and choose Revolution 2D.

2 In the Settings window for Revolution 2D, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (sol2).

4 Click to expand the Revolution layers section. Locate the Revolution Layers section. In 
the Start angle text field, type -90.

5 In the Revolution angle text field, type 270.

6 On the Home toolbar, click Compute.

S-parameter, S11dB (emw)
1 In the Model Builder window, expand the Results node, then click Derived Values>

S-parameter, S11dB (emw).
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2 In the Settings window for Global Evaluation, locate the Data section.

3 From the Data set list, choose Study 2/Solution Store 1 (sol3).

4 Click Evaluate.

The computed S-parameter shows more reflection on the probe due to the skin tumor.

3D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Temperature in the Label text field.

3 Locate the Data section. From the Data set list, choose Revolution 2D 2.

4 From the Time (min) list, choose 10.

Surface 1
1 Right-click Temperature and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type T-T0.

4 On the Temperature toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

6 Click the Zoom In button on the Graphics toolbar.

7 Locate the Coloring and Style section. From the Color table list, choose ThermalLight.

The temperature variation in the skin is shown in Figure 4.

2D Plot Group 5
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Fraction of Necrotic Tissue in 
the Label text field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 2 (sol2).

4 From the Time (min) list, choose 10.

Surface 1
1 Right-click Fraction of Necrotic Tissue and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Bioheat Transfer>

Biological tissue>ht.theta_d - Fraction of necrotic tissue.

3 On the Fraction of Necrotic Tissue toolbar, click Plot.

4 Click the Zoom In button on the Graphics toolbar.

The reproduced plot addresses the fraction of necrotic tissue as shown in Figure 5.
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2D Plot Group 6
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Resistive Losses in the Label text 
field.

Resistive Losses
1 Right-click Resistive Losses and choose Surface.

2 In the Settings window for 2D Plot Group, locate the Data section.

3 From the Data set list, choose Study 2/Solution Store 1 (sol3).

Surface 1
1 In the Model Builder window, under Results>Resistive Losses click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Electromagnetic 

Waves, Frequency Domain>Heating and losses>emw.Qrh - Resistive losses.

3 Locate the Coloring and Style section. From the Color table list, choose Thermal.

4 Select the Reverse color table check box.

5 On the Resistive Losses toolbar, click Plot.

Finish the result analysis by regenerating Figure 6, the resistive losses plot.
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Introduction

A contact switch is used to regulate whether or not an electrical current is passing from a 
power source into an electrical device. These switches are found in many types of 
equipment and they are used to control, for example, the power output from a wall socket 
into a device when it is plugged in; the currents passing across the circuit board of a 
computer; or the electricity powering a light bulb when the switch is flipped on. Because 
of their prevalence, simulating contact switches is a fundamental step in designing 
electronic applications.

The working principle behind a contact switch is simple: two conductive pieces of metal 
with an electrical voltage difference across them are brought into contact, allowing a 
current to flow between them. The metallic surfaces of the two components that touch 
one another are called contacts, and when the connection between the two contacts is 
broken, the current stops flowing.

The current flow between the two contacts contributes to an increase in temperature in 
the switch due to the Joule heating effect.

Figure 1: A contact switch.

The heating of the contact switch can change the material properties of the metal as well 
as the surface area of contact, and therefore is an important effect to consider when 
modeling the switch. Letting the temperature become too high can even cause the switch 
to burn out, meaning the switch is no longer functional. Therefore, it is important to 
analyze its current-carrying capability in order to prevent this from happening. It is also 
important to consider that when the two metallic pieces come into contact, the surfaces 
touching each other experience a mechanical pressure or contact pressure. This mechanical 
pressure on the contacts can alter the electrical and thermal properties of the material 
locally around the region surrounding the contacts. Therefore, in order to accurately 
simulate the current-carrying capability and temperature rise in the switch, it is important 
to take a more comprehensive approach in the simulation and incorporate the effect of 
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contact pressure to compute the electrical and thermal conductance of the contact 
surfaces.This tutorial illustrates how to implement a multiphysics contact. It models the 
thermal and electrical behavior of two contacting parts of a switch. The electric current 
and the heat cross from one part to the other only at the contact surface.

The contact switch device has a cylindrical body and plate hook shapes at the contact area 
(see Figure 1). There, the thermal and electrical apparent resistances are coupled to the 
mechanical contact pressure at the interface, which the application solves for.

The initial temperature is equal to the external room temperature. A potential difference 
between the left and right parts leads to heating through the Joule effect.

Model Definition

The geometry of the switch is shown in Figure 2. Only half of the device is represented 
due to symmetry considerations.

Figure 2: Switch geometry.

The switch is made of copper, with two fixed cylindrical elements and a central region 
where the contacts are located. On the end of each contact are plate hooks that enable 

Ground

1 mV
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contact between the two pieces. In the simulation, an electric potential of 1 mV is applied 
to the left side of the switch, while the right side is grounded.

The thermal and electrical contact conductances are assumed to be related only to the 
contact pressure.

The exposed surfaces of the switch lose heat due to their interaction with air via natural 
convection. In the simulation, this is modeled by specifying a heat transfer coefficient and 
the ambient temperature of the surrounding air (a more ambitious simulation might also 
include the fluid flow of the air). The application first solves for structural contact to obtain 
the contact pressure on the contact surfaces. These results are then used to compute the 
electrical and thermal conductance of the contact’s surfaces in a Joule heating simulation.

Results and Discussion

Figure 3 shows the electric potential distribution, ranging from the grounded right side to 
the applied 1 mV on the left.

Figure 3: Electric potential profile.

A potential difference across the two components in the switch creates a current flow, 
which in turn leads to Joule heating. This causes a rise in temperature in the switch. If you 
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leave the switch on for a while, temperature distribution in the switch reaches an 
equilibrium. Figure 4 shows the temperature distribution in the contact switch. In this 
example, Joule heating causes the temperature in the switch to rise about 5 K above room 
temperature, although only a small temperature variation is seen within the switch itself.

Figure 4: Temperature distribution.

The internal temperature distribution is almost constant. Introducing the effect of 
electrical and thermal conductance allows us to predict the temperature rise more 
accurately. The simulation also shows that the switch gets slightly hotter at the contact 
region.
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Finally, Figure 5 plots the temperature distribution at the contact region. Streamlines 
show the current density.

Figure 5: Temperature distribution (volume plot) and current density (streamlines) at the 
contact region.

Application Library path: Heat_Transfer_Module/
Thermal_Contact_and_Friction/contact_switch

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).
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3 Click Add.

4 In the Select Physics tree, select Heat Transfer>Electromagnetic Heating>Joule Heating.

5 Click Add.

6 Click Study.

7 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

8 Click Done.

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
contact_switch.mphbin.

5 Click Import.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Form Union 

(fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly 
section.

3 From the Action list, choose Form an assembly.

4 From the Pair type list, choose Contact pair.

5 Clear the Create pairs check box.

6 On the Home toolbar, click Build All.

D E F I N I T I O N S

Contact Pair 1 (p1)
1 On the Definitions toolbar, click Pairs and choose Contact Pair.

2 Select Boundaries 12 and 15 only.

3 In the Settings window for Pair, locate the Destination Boundaries section.

4 Select the Active toggle button.

5 Select Boundaries 25 and 28 only.
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A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Copper.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Copper (mat1)
On the Home toolbar, click Add Material to close the Add Material window.

S O L I D  M E C H A N I C S  ( S O L I D )

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundaries 4, 5, 34, and 35 only.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 2 and 22 only.

Contact 1
1 On the Physics toolbar, in the Boundary section, click Pairs and choose Contact.

2 In the Settings window for Contact, locate the Pair Selection section.

3 In the Pairs list, select Contact Pair 1 (p1).

4 Locate the Initial Values section. In the Tn text field, type 1e7.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids (ht).

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 3 and 6–33 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type 2.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.
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2 Select Boundaries 2 and 22 only.

Pair Thermal Contact 1
1 On the Physics toolbar, in the Boundary section, click Pairs and choose Pair Thermal 

Contact.

2 In the Settings window for Pair Thermal Contact, locate the Pair Selection section.

3 In the Pairs list, select Contact Pair 1 (p1).

4 Locate the Contact Surface Properties section. From the p list, choose Contact pressure 

(solid/cnt1).

E L E C T R I C  C U R R E N T S  ( E C )

In the Model Builder window, under Component 1 (comp1) click Electric Currents (ec).

Ground 1
1 On the Physics toolbar, click Boundaries and choose Ground.

2 Select Boundary 34 only.

Electric Potential 1
1 On the Physics toolbar, click Boundaries and choose Electric Potential.

2 Select Boundary 5 only.

3 In the Settings window for Electric Potential, locate the Electric Potential section.

4 In the V0 text field, type 1[mV].

Pair Electrical Contact 1
1 On the Physics toolbar, in the Boundary section, click Pairs and choose Pair Electrical 

Contact.

2 In the Settings window for Pair Electrical Contact, locate the Pair Selection section.

3 In the Pairs list, select Contact Pair 1 (p1).

4 Locate the Contact Surface Properties section. From the p list, choose Contact pressure 

(solid/cnt1).

M E S H  1

On the Mesh toolbar, click Free Tetrahedral.

Free Tetrahedral 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Tetrahedral 1 and choose Size.
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Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 Select Boundaries 12, 15, 25, and 28 only.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 5e-4.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Fine.

4 Click Build All.

S T U D Y  1

Solve the model in two steps. The first step only computes for Solid Mechanics while the 
second solves for Joule Heating (Electric Currents and Heat Transfer in Solids).

Step 1: Stationary
1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 In the table, clear the Solve for check box for Electric Currents (ec) and Heat Transfer in 

Solids (ht).

Stationary 2
On the Study toolbar, click Study Steps and choose Stationary>Stationary.

Step 2: Stationary 2
1 In the Settings window for Stationary, locate the Physics and Variables Selection section.

2 In the table, clear the Solve for check box for Solid Mechanics (solid).

3 On the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
In this first default plot, the switch is slightly deformed due to the contact pressure. The 
von Mises stress is located at the switch base and at the contact area.
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Follow the next steps to visualize the second and third default plots as in Figure 3 and 
Figure 4.

Mirror 3D 1
1 On the Results toolbar, click More Data Sets and choose Mirror 3D.

2 In the Settings window for Mirror 3D, locate the Plane Data section.

3 From the Plane list, choose XY-planes.

Electric Potential (ec)
1 In the Model Builder window, under Results click Electric Potential (ec).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Data set list, choose Mirror 3D 1.

4 On the Electric Potential (ec) toolbar, click Plot.

Temperature (ht)
1 In the Model Builder window, under Results click Temperature (ht).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Data set list, choose Mirror 3D 1.

4 On the Temperature (ht) toolbar, click Plot.

Data Sets
To observe the temperature and current density only at the contact region (Figure 5), 
proceed as follows.

Surface 1
1 On the Results toolbar, click More Data Sets and choose Surface.

2 In the Settings window for Surface, locate the Parameterization section.

3 From the x- and y-axes list, choose XY-plane.

4 Select Boundaries 10 and 21 only.

2D Plot Group 5
1 On the Results toolbar, click 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Temperature (Contact Region) in 
the Label text field.

3 On the Temperature (Contact Region) toolbar, click Surface.

Surface 1
1 In the Model Builder window, under Results>Temperature (Contact Region) click Surface 1.
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2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Heat Transfer in 

Solids>Temperature>T - Temperature.

3 Locate the Coloring and Style section. From the Color table list, choose ThermalLight.

Temperature (Contact Region)
1 In the Model Builder window, under Results click Temperature (Contact Region).

2 On the Temperature (Contact Region) toolbar, click Streamline.

Streamline 1
1 In the Model Builder window, under Results>Temperature (Contact Region) click 

Streamline 1.

2 In the Settings window for Streamline, click Replace Expression in the upper-right corner 
of the Expression section. From the menu, choose Model>Component 1>Electric 

Currents>Currents and charge>ec.Jx,ec.Jy - Current density (Spatial).

3 Locate the Streamline Positioning section. From the Positioning list, choose Uniform 

density.

4 In the Separating distance text field, type 0.02.

5 On the Temperature (Contact Region) toolbar, click Plot.
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Introduction

This example simulates the process of continuous casting of a metal rod from a molten 
state (Figure 1). To optimize the casting process in terms of casting rate and cooling, it is 
helpful to model the thermal and fluid dynamic aspects of the process. To get accurate 
results, you must model the melt flow field in combination with the heat transfer and phase 
change. The model includes the phase transition from melt to solid, both in terms of latent 
heat and the varying physical properties.

Figure 1: Continuous metal-casting process with a view of the modeled section.
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This example simplifies the rod’s 3D geometry in Figure 1 to an axisymmetric 2D model 
in the rz-plane. Figure 2 shows the dimensions of the 2D geometry.

Figure 2: 2D axisymmetric model of the casting process.

As the melt cools down in the mold it solidifies. The phase transition releases latent heat, 
which the model includes. Furthermore, for metal alloys, the transition is often spread out 
over a temperature range. As the material solidifies, the material properties change 
considerably. Finally, the model also includes the “mushy” zone—a mixture of solid and 
melted material that occurs due to the rather broad transition temperature of the alloy and 
the solidification kinetics.

This example models the casting process as being stationary using the Heat Transfer in 
Fluids interface combined with the Laminar Flow interface.

Model Definition

The process operates at steady state, because it is a continuous process. The heat transport 
is described by the equation:
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where k, Cp, and Q denote thermal conductivity, specific heat, and heating power per unit 
volume (heat source term), respectively.

As the melt cools down in the mold, it solidifies. During the phase transition, a significant 
amount of latent heat is released. The total amount of heat released per unit mass of alloy 
during the transition is given by the change in enthalpy, ΔH. In addition, the specific heat 
capacity, Cp, also changes considerably during the transition. The difference in specific 
heat before and after transition can be approximated by

As opposed to pure metals, an alloy generally undergoes a broad temperature transition 
zone, over several kelvin, in which a mixture of both solid and molten material co-exist in 
a “mushy” zone. To account for the latent heat related to the phase transition, the 
Apparent Heat capacity method is used through the Heat Transfer with Phase Change 
domain condition. The half-width of the transition interval, ΔT, is set to 10 K in this case, 
and represents half the transition temperature span.

This example models the laminar flow by describing the fluid velocity, u, and the pressure, 
p, according to the equations

where ρ is the density (in this case constant), μ is the viscosity, and κ is the dilatational 
viscosity (here assumed to be zero). Here, the role of the source term, F, is to dampen the 
velocity at the phase-change interface so that it becomes that of the solidified phase after 
the transition. The source term follows from the equation (see Ref. 1)

where α can be seen as the volume fraction of the liquid phase; Amush and ε represent 
arbitrary constants (Amush should be large and ε small to produce a proper damping); and 
ucast is the velocity of the cast rod.
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Table 1 reviews the material properties in this model.

Furthermore, the melting temperature, Tm, and enthalpy, ΔH, are set to 1356 K and 
205 kJ/kg, respectively.

The model uses the parametric solver in combination with adaptive meshing to solve the 
problem efficiently. In particular, using an adaptive mesh makes it possible to resolve the 
steep gradients in the mushy zone at a comparatively low computational cost.

Results and Discussion

The plots in Figure 3 display the temperature and phase distributions, showing that the 
melt cools down and solidifies in the mold region. Interestingly, the transition zone 
stretches out towards the center of the rod because of poorer cooling in that area.

TABLE 1:  MATERIAL PROPERTIES

PROPERTY SYMBOL MELT SOLID

Density ρ (kg/m3) 8500 8500

Heat capacity at constant pressure Cp (J/(kg·K)) 530 380

Thermal conductivity k (W/(m·K)) 200 200

Dynamic viscosity μ (Ns/m2) 0.0434 - 
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Figure 3: Temperature distribution (top) and fraction of liquid phase (bottom) in the lower 
part of the cast at a casting rate of 1.6 mm/s.
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With the modeled casting rate, the rod is fully solidified before leaving the mold (the first 
section after the die). This means that the process engineers can increase the casting rate 
without running into problems, thus increasing the production rate.

The phase transition occurs in a very narrow zone although the model uses a transition 
half width, ΔT, of 10 K. In reality it would be even more distinct if a pure metal were being 
cast but somewhat broader if the cast material were an alloy with a wider ΔT.

It is interesting to study in detail the flow field in the melt as it exits the die.

Figure 4: Velocity field with streamlines in the lower part of the process.

In Figure 4, notice the disturbance in the streamlines close to the die wall resulting in a 
vortex. This eddy flow could create problems with nonuniform surface quality in a real 
process. Process engineers can thus use the model to avoid these problems and find an 
optimal die shape.

To help determine how to optimize process cooling, Figure 5 plots the conductive heat 
flux. It shows that the conductive heat flux is very large in the mold zone. This is a 
consequence of the heat released during the phase transition, which is cooled by the 
water-cooling jacket of the mold. An interesting phenomenon of the process is the peak of 
conductive heat flux appearing in the center of the flow at the transition zone.
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Figure 5: The cooling viewed as conductive heat flux in the domains (top), and through the 
outer boundary (the cooling zones) after the die (bottom).
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Furthermore, by plotting the conductive heat flux at the outer boundary for the process 
as in the lower plot in Figure 5, you can see that a majority of the process cooling occurs 
in the mold. More interestingly, the heat flux varies along the mold wall length. This 
information can help in optimizing the cooling of the mold (that is, the cooling rate and 
choice of cooling method).

You solve the model using a built-in adaptive meshing technique. This is necessary because 
the transition zone—that is, the region where the phase change occurs—requires a fine 
discretization. Figure 6 depicts the final mesh of the model. Notice that the majority of 
the elements are concentrated to the transition zone.

Figure 6: Close-up of the final computational mesh, resulting from the built-in adaptive 
technique.

The adaptive meshing technique allows for fast and accurate calculations even if the 
transition width is brought down to a low value, such as for pure metals.

Reference

1. V.R. Voller and C. Prakash, “A fixed grid numerical modeling methodology for 
convection—diffusion mushy region phase-change problems,” Int.J.Heat Mass Transfer, 
vol. 30, pp. 1709–1719, 1987.
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Application Library path: Heat_Transfer_Module/Thermal_Processing/
continuous_casting

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Fluid Flow>Non-Isothermal Flow>Laminar Flow.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
continuous_casting_parameters.txt.

Note, in particular, the value of the parameter dT, which represents the parameter ΔT 
in the Model Definition section. It will apply when you solve with adaptive mesh 
refinement because that solution stage is not related to a parametric study. It is then 
crucial that the value of dT matches that of the final parameter step for the parametric 
solution that is used as the initial solution.
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D E F I N I T I O N S

Variables 1
1 On the Home toolbar, click Variables and choose Local Variables.

2 In the Settings window for Variables, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose All domains.

Define the variables by loading the corresponding text file provided.

5 Locate the Variables section. Click Load from File.

6 Browse to the application’s Application Libraries folder and double-click the file 
continuous_casting_variables.txt.

G E O M E T R Y  1

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.065.

4 In the Height text field, type 0.1.

5 On the Geometry toolbar, click Build All.

Rectangle 2 (r2)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.0625.

4 In the Height text field, type 0.025.

5 Locate the Position section. In the z text field, type 0.1.

6 On the Geometry toolbar, click Build All.

Rectangle 3 (r3)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.11575.

4 In the Height text field, type 0.04.

5 Locate the Position section. In the z text field, type 0.165.

6 On the Geometry toolbar, click Build All.
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Rectangle 4 (r4)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.11575.

4 In the Height text field, type 0.3675.

5 Locate the Position section. In the z text field, type 0.205.

6 On the Geometry toolbar, click Build All.

Rectangle 5 (r5)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.11575.

4 In the Height text field, type 0.4.

5 Locate the Position section. In the z text field, type 0.5725.

6 On the Geometry toolbar, click Build All.

Rectangle 6 (r6)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.11575.

4 In the Height text field, type 0.6.

5 Locate the Position section. In the z text field, type 0.9725.

6 On the Geometry toolbar, click Build All.

7 Click the Zoom Extents button on the Graphics toolbar.

Polygon 1 (pol1)
1 On the Geometry toolbar, click Primitives and choose Polygon.

2 In the Settings window for Polygon, locate the Coordinates section.

3 In the r text field, type 0 0 0.11575 0.0625 0.

4 In the z text field, type 0.125 0.165 0.165 0.125 0.125.

5 On the Geometry toolbar, click Build All.
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6 Click the Zoom Extents button on the Graphics toolbar.

This completes the geometry modeling stage.

M A T E R I A L S

Now, add the following two materials to the model, labeled Solid Metal Alloy and Liquid 

Metal Alloy. The solid metal alloy is used in the Heat Transfer with Phase Change feature for 
the solid phase, while the liquid metal alloy is used for the liquid phase. The liquid metal 
alloy also defines fluid properties used in the Laminar Flow interface.

Material 1 (mat1)
1 On the Materials toolbar, click Blank Material.

2 In the Settings window for Material, type Solid Metal Alloy in the Label text field.

3 Locate the Material Contents section. In the table, enter the following settings:

Property Name Value Unit Property 
group

Dynamic viscosity mu 0.0434 Pa·s Basic

Thermal conductivity k 200 W/(m·K) Basic

Density rho 8500 kg/m³ Basic
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Material 2 (mat2)
1 On the Materials toolbar, click Blank Material.

2 In the Settings window for Material, type Liquid Metal Alloy in the Label text field.

3 Locate the Geometric Entity Selection section. From the Selection list, choose All domains.

4 Locate the Material Contents section. In the table, enter the following settings:

L A M I N A R  F L O W  ( S P F )

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Laminar Flow (spf) click Initial 

Values 1.

2 In the Settings window for Initial Values, locate the Initial Values section.

3 Specify the u vector as

Inlet 1
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 Select Boundary 2 only.

3 In the Settings window for Inlet, locate the Boundary Condition section.

4 From the list, choose Pressure.

Heat capacity at constant 
pressure

Cp Cp_s J/(kg·K) Basic

Ratio of specific heats gamma 1 1 Basic

Property Name Value Unit Property 
group

Dynamic viscosity mu 0.0434 Pa·s Basic

Thermal conductivity k 200 W/(m·K) Basic

Density rho 8500 kg/m³ Basic

Heat capacity at constant 
pressure

Cp Cp_l J/(kg·K) Basic

Ratio of specific heats gamma 1 1 Basic

0 r

v_cast z

Property Name Value Unit Property 
group
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Outlet 1
1 On the Physics toolbar, click Boundaries and choose Outlet.

2 Select Boundaries 15 and 21–23 only.

3 In the Settings window for Outlet, locate the Boundary Condition section.

4 From the list, choose Velocity.

5 Locate the Velocity section. Click the Velocity field button.

6 Specify the u0 vector as

Volume Force 1
1 On the Physics toolbar, click Domains and choose Volume Force.

2 In the Settings window for Volume Force, locate the Domain Selection section.

3 From the Selection list, choose All domains.

4 Locate the Volume Force section. Specify the F vector as

H E A T  TR A N S F E R  I N  F L U I D S  ( H T )

1 In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Fluids 

(ht).

2 In the Settings window for Heat Transfer in Fluids, locate the Ambient Settings section.

3 In the Tamb text field, type 300[K].

This defines the ambient temperature for heat transfer between the outer surfaces and 
the surroundings.

Phase Change Material 1
1 On the Physics toolbar, click Domains and choose Phase Change Material.

2 In the Settings window for Phase Change Material, locate the Domain Selection section.

3 From the Selection list, choose All domains.

4 Locate the Phase Change section. In the Tpc, 1 → 2 text field, type T_m.

0 r

v_cast z

Fr r

Fz z
15 |  C O N T I N U O U S  C A S T I N G



5 In the ΔT1 → 2 text field, type 2*dT.

The parameter dT is multiplied by 2 because it is only the half width of the phase change 
interval.

6 In the L1 → 2 text field, type dH.

7 Locate the Phase 1 section. From the Material, phase 1 list, choose Solid Metal Alloy 

(mat1).

8 Locate the Phase 2 section. From the Material, phase 2 list, choose Liquid Metal Alloy 

(mat2).

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Fluids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, type T_in in the T text field.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 2 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type T_in.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundary 20 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type h_br.

6 From the Text list, choose Ambient temperature (ht).

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundary 21 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type h_mold.

6 From the Text list, choose Ambient temperature (ht).
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Heat Flux 3
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 22 and 23 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type h_air.

6 From the Text list, choose Ambient temperature (ht).

Outflow 1
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 Select Boundary 15 only.

Diffuse Surface 1
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 Select Boundaries 22 and 23 only.

3 In the Settings window for Diffuse Surface, locate the Surface Emissivity section.

4 From the ε list, choose User defined. In the associated text field, type eps_s.

5 Locate the Ambient section. From the Tamb list, choose Ambient temperature (ht).

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Finer.

4 On the Mesh toolbar, click Edit.

Boundary Layers 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Boundary 

Layers 1 and choose Delete.

2 Click Yes to confirm.

Deleting the boundary layers is necessary in order to use the adaptive mesh 
functionality.

Size 1
1 Select Boundaries 16–21 only.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Fine.
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4 In the Model Builder window, click Mesh 1.

5 In the Settings window for Mesh, click Build All.

S T U D Y  1

Compute the solution using a three-step process. First, solve the problem using dT as a 
continuation parameter with the parametric solver on the default mesh, gradually 
decreasing the value of dT. Then, use the adaptive solver to adapt the mesh. Finally, use 
the parametric solver again to decrease dT further down to a value of 10 K.

1 In the Settings window for Study, locate the Study Settings section.

2 Clear the Generate default plots check box.

The default plots are disabled from this study because they will be added from the last 
study.

Step 1: Stationary
1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study extensions section.

3 Locate the Study Extensions section. Select the Auxiliary sweep check box.

4 Click Add.

5 In the table, enter the following settings:

Stationary 2
On the Study toolbar, click Study Steps and choose Stationary>Stationary.

Step 2: Stationary 2
1 In the Settings window for Stationary, click to expand the Values of dependent variables 

section.

2 Locate the Values of Dependent Variables section. Find the Initial values of variables solved 

for subsection. From the Settings list, choose User controlled.

3 From the Method list, choose Solution.

4 From the Study list, choose Study 1, Stationary.

5 Click to expand the Study extensions section. Locate the Study Extensions section. Select 
the Adaptive mesh refinement check box.

Parameter name Parameter value list Parameter unit

dT 300 100 50 30 K
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Since the fluid flow and heat transfer interfaces are strongly coupled, using a fully coupled 
solver is expected to be faster. In the following steps, alter the default solver sequence into 
using the Fully Coupled attribute.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 Right-click Stationary Solver 1 and choose Fully Coupled.

4 Right-click Study 1>Solver Configurations>Solution 1 (sol1)>Stationary Solver 2 and 
choose Fully Coupled.

5 On the Study toolbar, click Compute.

M E S H  2

Before proceeding with the final solution stage, inspect the adapted mesh. You find it 
under the automatically created Meshes branch in the model tree.

1 In the Model Builder window, expand the Meshes node, then click Mesh 2.

2 Click the Zoom Box button on the Graphics toolbar and then use the mouse to zoom in 
on the transition zone where the mesh is the densest.

The mesh should look like that in Figure 6.

Add a second study for the second parametric study step.

A D D  S T U D Y

1 On the Study toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

5 On the Study toolbar, click Add Study to close the Add Study window.

S T U D Y  2

In order to get faster convergence, you need to use the previous solution as the initial value 
for this study.

Step 1: Stationary
1 In the Model Builder window, expand the Component 1 (comp1)>Meshes node, then click 

Study 2>Step 1: Stationary.
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2 In the Settings window for Stationary, click to expand the Values of dependent variables 
section.

3 Locate the Values of Dependent Variables section. Find the Initial values of variables solved 

for subsection. From the Settings list, choose User controlled.

4 From the Method list, choose Solution.

5 From the Study list, choose Study 1, Stationary 2.

6 Locate the Study Extensions section. Select the Auxiliary sweep check box.

7 Click Add.

8 In the table, enter the following settings:

Notice that Mesh 2, the adapted mesh, is the default selection in the mesh list. Keep this 
setting.

Again, a fully coupled solver is more robust for this model. Tweak the solver sequence 
accordingly with the instructions below.

Solution 4 (sol4)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Study 2>Solver Configurations node.

3 In the Model Builder window, expand the Solution 4 (sol4) node.

4 Right-click Stationary Solver 1 and choose Fully Coupled.

5 On the Study toolbar, click Compute.

R E S U L T S

Velocity (spf)
To reproduce the plot in Figure 4, plot the velocity field as a combined surface and 
streamline plot.

Surface
1 In the Model Builder window, expand the Velocity (spf) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose mm/s.

Velocity (spf)
1 In the Model Builder window, under Results click Velocity (spf).

Parameter name Parameter value list Parameter unit

dT 25 20 16 13 10 K
20 |  C O N T I N U O U S  C A S T I N G



2 On the Velocity (spf) toolbar, click Streamline.

Streamline 1
1 In the Model Builder window, under Results>Velocity (spf) click Streamline 1.

2 In the Settings window for Streamline, locate the Streamline Positioning section.

3 From the Positioning list, choose Magnitude controlled.

4 On the Velocity (spf) toolbar, click Plot.

Pressure (spf)
The second default plot shows the pressure profile in the 2D slice.

Velocity (spf) 1
The third default plot shows the velocity magnitude in 3D obtained by revolution of the 
2D axisymmetric data set.

Temperature, 3D (ht)
This default plot shows the temperature in 3D obtained by revolution of the 2D 
axisymmetric data set.

Proceed to reproduce the lower plot in Figure 3, showing the fraction of liquid phase.

2D Plot Group 6
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Fraction of Liquid Phase in the 
Label text field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 4 (sol4).

4 On the Fraction of Liquid Phase toolbar, click Surface.

Surface 1
1 In the Model Builder window, under Results>Fraction of Liquid Phase click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Definitions>

Variables>alpha - Fraction of liquid phase.

3 On the Fraction of Liquid Phase toolbar, click Plot.

Notice, in particular, the narrow transition zone between the two phases.

To reproduce the upper plot in Figure 3, which visualizes the temperature and velocity 
fields, proceed as follows.

2D Plot Group 7
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.
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2 In the Settings window for 2D Plot Group, type Temperature in the Label text field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 4 (sol4).

4 On the Temperature toolbar, click Surface.

Surface 1
1 In the Model Builder window, under Results>Temperature click Surface 1.

2 In the Settings window for Surface, locate the Coloring and Style section.

3 From the Color table list, choose ThermalLight.

4 On the Temperature toolbar, click Plot.

Temperature
1 In the Model Builder window, under Results click Temperature.

2 Click Arrow Surface.

Arrow Surface 1
1 In the Model Builder window, under Results>Temperature click Arrow Surface 1.

2 In the Settings window for Arrow Surface, locate the Arrow Positioning section.

3 Find the r grid points subsection. In the Points text field, type 8.

4 Locate the Coloring and Style section. From the Color list, choose Black.

5 On the Temperature toolbar, click Plot.

Proceed to reproduce the heat flux plots shown in Figure 5.

2D Plot Group 8
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Conductive Heat Flux in the Label 
text field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 4 (sol4).

4 On the Conductive Heat Flux toolbar, click Surface.

Surface 1
1 In the Model Builder window, under Results>Conductive Heat Flux click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Heat Transfer in 

Fluids>Domain fluxes>ht.dfluxMag - Conductive heat flux magnitude.

3 On the Conductive Heat Flux toolbar, click Plot.
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Conductive Heat Flux
1 In the Model Builder window, under Results click Conductive Heat Flux.

2 Click Arrow Surface.

Arrow Surface 1
1 In the Model Builder window, under Results>Conductive Heat Flux click Arrow Surface 1.

2 In the Settings window for Arrow Surface, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Model>Component 1>Heat 

Transfer in Fluids>Domain fluxes>ht.dfluxr,ht.dfluxz - Conductive heat flux.

3 Locate the Arrow Positioning section. Find the r grid points subsection. In the Points text 
field, type 8.

4 Locate the Coloring and Style section. From the Color list, choose Black.

5 On the Conductive Heat Flux toolbar, click Plot.

The following steps reproduce the lower plot in the same figure, showing the 
conductive heat flux through the outer boundaries.

1D Plot Group 9
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Conductive Heat Flux through 
Outer Boundaries in the Label text field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 4 (sol4).

4 From the Parameter selection (dT) list, choose Last.

5 Click to expand the Title section. From the Title type list, choose Manual.

6 In the Title text area, type Conductive heat flux through outer boundaries.

7 Locate the Plot Settings section. Select the x-axis label check box.

8 In the associated text field, type z-coordinate (m).

9 Select the y-axis label check box.

10 In the associated text field, type Normal conductive heat flux (W/m^2).

Line Graph 1
1 On the Conductive Heat Flux through Outer Boundaries toolbar, click Line Graph.

2 Select Boundaries 20–23 only.

3 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Model>Component 1>Heat Transfer in 

Fluids>Boundary fluxes>ht.ndflux - Normal conductive heat flux.
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4 Click Replace Expression in the upper-right corner of the x-axis data section. From the 
menu, choose Model>Component 1>Geometry>Coordinate>z - z-coordinate.

5 Click to expand the Legends section. Click to collapse the Legends section. Click to 
expand the Quality section. From the Recover list, choose Within domains.

6 Click to collapse the Quality section. On the Conductive Heat Flux through Outer 

Boundaries toolbar, click Plot.

Compare the result with the lower plot of Figure 5.

Data Sets
Finally, verify that the final mesh is sufficiently fine to resolve the temperature-dependence 
of the latent heat.

Cut Line 2D 1
1 On the Results toolbar, click Cut Line 2D.

2 In the Settings window for Cut Line 2D, locate the Line Data section.

3 In row Point 1, set r to 0.045, and z to 0.42.

4 In row Point 2, set r to 0.085, and z to 0.43.

These values are chosen such that the two points are on opposite sides of and 
approximately perpendicular to the transition zone.

Alternatively, you can select the two end points and create the Cut Line 2D data set by 
first clicking the Fraction of Liquid Phase node and then clicking in the Graphics window 
after first selecting, in turn, First Point for Cut Line and Second Point for Cut Line on the 
main toolbar.

5 Locate the Data section. From the Data set list, choose Study 2/Solution 4 (sol4).

1D Plot Group 10
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Temperature Dependence, Latent 
Heat in the Label text field.

3 Locate the Data section. From the Data set list, choose Cut Line 2D 1.

Line Graph 1
1 On the Temperature Dependence, Latent Heat toolbar, click Line Graph.

2 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Model>Component 1>Definitions>

Variables>D - Temperature dependence, latent heat.

3 Click to expand the Legends section. Select the Show legends check box.
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4 On the Temperature Dependence, Latent Heat toolbar, click Plot.

As you can see, the curves for the lower ΔT values, in particular at 10 K, are not entirely 
smooth. Thus, if you were to reduce ΔT further to model the casting of some pure 
metal, you would need to increase the mesh resolution.
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Introduction

Chemical reaction fluids can be cooled using glass flanges. The reaction fluid is passed 
through the flange and the air surrounding the flange then serves as the coolant. Engineers 
looking to optimize the cooling performance of such flanges can look to simulation for 
help.

Figure 1: Operating principle of the cooling flange.

First off, the physics to analyze in this case is heat transfer, involving both convection and 
conduction. Heat transfer occurs via convection to and from the surfaces of the flange, 
while the flange’s interior experiences conduction. In other words, the inside of the tube 
is heated by the process fluid, and the flange then conducts the heat and transfers it into 
the air, in turn causing a convective flow due to buoyancy effects. The cooling 
performance of the flange therefore depends on both convection and conduction.

To simplify the simulation convection cooling is analyzed using the heat transfer 
coefficient, h. Since this describes the fluid-flow field influence and the convective fluxes, 
the flow field doesn’t have to be computed.

This particular example uses external research data (Ref. 1) for the outer surface heat 
transfer coefficient, which was originally obtained through semi-empirical data for natural 

Hot process
fluid

Cooling air
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convection around a cylinder. For the tube-facing surface a coefficient for forced 
convection in a tube is used.

Model Definition

Figure 2 presents a drawing of the modeled geometry.

Figure 2: Drawing of the cooling flange.

The glass flange consists of a 4 mm thick pipe and 4 mm thick and 10 mm tall flanges, with 
a connecting pipe that has a 3 mm thick wall and an inner diameter of 16 mm. Note that 
during the simulation, the pipe diameter varies while the other dimensions remain fixed. 

During operation, the hot process fluid heats the inside of the tube. The flange conducts 
the heat and transfers it to the surrounding air. As the air is heated, buoyancy effects cause 
a convective flow.

The heat transfer within the flange is described by the stationary heat equation

∇ k∇T–( )⋅ 0=
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where k is the thermal conductivity (W/(m·K)), and T is the temperature (K). On the 
flange’s exterior boundaries, which face the air and process fluid, the applicable boundary 
condition is

where n is the normal vector of the boundary, h, is the heat transfer coefficient (W/
(m2·K)), and Tinf is the temperature of the surrounding medium (K). For this simulation, 
set Tinf to 298 K for the cooling air and to 363 K for the process fluid.

You can approximate the value for the heat transfer coefficient, h, on the process fluid side 
with a constant value of 15 W/(m2·K) because the fluid’s velocity is close to constant and 
the model assumes that its temperature decreases only slightly.

The h expression on the air side is more elaborate. Assume that the free-convection process 
around the flange is similar to that around a cylinder. The heat transfer coefficient for a 
cylinder is available in the literature (Ref. 1), and you can use the expression

where k is the thermal conductivity of air (26.2 mW/(m·K) at 298 K); L is the typical 
length, which in this case is the outer diameter of the flange (44 mm); and f(θ) is an 
empirical coefficient tabulated in Table 1 as a function of the incidence angle θ, which is 
shown in Figure 3. Finally, Gr is the Grashof number defined as

where αp is the coefficient of thermal expansion (1/K), which equals that for an ideal gas, 
g is the gravitational acceleration (9.81 m/s2), and ν is the kinematic viscosity 
(18·10−6 m2·s). For the flange material, use silica glass.

TABLE 1:  EMPIRICAL TRANSFER COEFFICIENT VS. INCIDENCE ANGLE.

θ (DEG) f(θ)
0 0.48

90 0.46

100 0.45

110 0.435

120 0.42

130 0.38

n– k∇T–( )⋅ h Tinf T–( )=

h k
L
----f θ( )Gr1 4⁄

=

Gr
gαpΔTL3

ν2
-------------------------=
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Figure 3: Definition of the incidence angle θ.

140 0.35

150 0.28

160 0.22

180 0.15

TABLE 1:  EMPIRICAL TRANSFER COEFFICIENT VS. INCIDENCE ANGLE.

θ (DEG) f(θ)

gravity

θ
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Results and Discussion

Figure 4 shows the flange surface temperature at steady state.

Figure 4: Stationary surface temperature of the flange.

As you can see in the surface temperature plot above to the left, the tube surface 
temperature is about 13 K higher than the flange shoulders. From the results, we can learn 
that the heat transfer from the outer surfaces of the flange is pretty efficient; there is a 
temperature difference of roughly 19 K between the outer flange surface and the air 
stream.
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Figure 5 shows the heat transfer coefficient for the flange’s outer walls.

Figure 5: Heat transfer film coefficient, h, for the flange’s outer walls.

As you can see, the coefficient decreases significantly along the vertical position of the 
flange’s outer boundary.

Calculating the flange’s total cooling power by integrating the normal total heat flux over 
the outer surfaces gives a value of 0.51 W which correspond to 1.02 W for the full 
geometry.

The surface temperature plot shown on Figure 4 further gives light to an inefficiency in 
the current flange design. When it enters the flange the process fluid is 363 K, while the 
inner surface of the pipe is only 32 K lower. Increasing the tube diameter would improve 
the heat transfer here, which is performed in a second stage of the modeling by varying 
the pipe’s diameter, but keeping all other factors constant. By plotting in Figure 6 the 
global cooling power as a function of the inner pipe radius, you can now analyze how 
altering the radius impacts the performance of the cooling flange.
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Figure 6: Total cooling power versus inner pipe radius.

Reference

1. B. Sundén, Kompendium i värmeöverföring [Notes on Heat Transfer], Sec. 10-3, Dept. 
of Heat and Power Engineering, Lund Inst. of Technology, 2003 (in Swedish).

Application Library path: Heat_Transfer_Module/Thermal_Processing/
cooling_flange

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

Define parameters for relevant temperatures, material properties, and geometric 
dimensions. The parameters related to the geometry dimensions make it easier to 
perform parametric studies where you let some of these dimensions vary.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Next, create an interpolation function defined by the data in Table 1.

Name Expression Value Description

k 26.2[mW/(m*K)] 0.0262 W/(m·K) Thermal 
conductivity, air

T_inner 363[K] 363 K Temperature, process 
fluid

Hh 15[W/(m^2*K)] 15 W/(m²·K) Heat transfer 
coefficient

nu 18e-6[m^2/s] 1.8E-5 m²/s Kinematic viscosity

r_inner 8[mm] 0.008 m Inner pipe radius

l1 12[mm] 0.012 m Pipe length 
excluding flanges

t1 3[mm] 0.003 m Pipe thickness

t2 4[mm] 0.004 m Pipe thickness, 
flange section

hf 10[mm] 0.01 m Flange height

wf 4[mm] 0.004 m Flange width

D 2*(r_inner+t2+hf) 0.044 m Outer flange 
diameter
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Interpolation 1 (int1)
1 On the Home toolbar, click Functions and choose Global>Interpolation.

2 In the Settings window for Interpolation, locate the Definition section.

3 In the Function name text field, type f.

4 In the table, enter the following settings:

5 Locate the Units section. In the Arguments text field, type deg.

6 In the Function text field, type 1.

7 Click Plot.

t f(t)

0 0.48

90 0.46

100 0.45

110 0.435

120 0.42

130 0.38

140 0.35

150 0.28

160 0.22

180 0.15
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G E O M E T R Y  1

In a first geometry modeling stage, create a 2D geometry by following the steps below.

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, click Show Work Plane.

Rectangle 1 (r1)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 2*wf.

4 In the Height text field, type t2.

5 Locate the Position section. In the yw text field, type r_inner.

6 On the Work Plane toolbar, click Build All.

7 Click the Zoom Extents button on the Graphics toolbar.

Bézier Polygon 1 (b1)
1 On the Work Plane toolbar, click Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the Polygon Segments section.

3 Find the Added segments subsection. Click Add Quadratic.

4 Find the Control points subsection. In row 1, set yw to r_inner+t2.

5 In row 2, set xw to wf/2, and yw to r_inner+t2.

6 In row 3, set xw to wf/2, and yw to r_inner+t2+wf/2.

7 Find the Added segments subsection. Click Add Linear.

8 Find the Control points subsection. In row 2, set xw to 3*wf/2.

9 Find the Added segments subsection. Click Add Quadratic.

10 Find the Control points subsection. In row 2, set yw to r_inner+t2.

11 In row 3, set xw to 2*wf, and yw to r_inner+t2.

12 On the Work Plane toolbar, click Build All.

13 Click the Zoom Extents button on the Graphics toolbar.

Rectangle 2 (r2)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type wf.
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4 In the Height text field, type hf-wf.

5 Locate the Position section. In the xw text field, type wf/2.

6 In the yw text field, type r_inner+t2+wf/2.

7 On the Work Plane toolbar, click Build All.

8 Click the Zoom Extents button on the Graphics toolbar.

Circle 1 (c1)
1 On the Work Plane toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type wf/2.

4 In the Sector angle text field, type 180.

5 Locate the Position section. In the xw text field, type wf.

6 In the yw text field, type r_inner+t2+hf-wf/2.

7 On the Work Plane toolbar, click Build All.

8 Click the Zoom Extents button on the Graphics toolbar.

Array 1 (arr1)
1 On the Work Plane toolbar, click Transforms and choose Array.

2 Click in the Graphics window and then press Ctrl+A to select all objects.

3 In the Settings window for Array, locate the Size section.

4 From the Array type list, choose Linear.

5 In the Size text field, type 3.

6 Locate the Displacement section. In the xw text field, type 2*wf.

7 On the Work Plane toolbar, click Build All.

8 Click the Zoom Extents button on the Graphics toolbar.

Bézier Polygon 2 (b2)
1 On the Work Plane toolbar, click Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the Polygon Segments section.

3 Find the Added segments subsection. Click Add Linear.

4 Find the Control points subsection. In row 1, set yw to r_inner.

5 In row 2, set xw to -l1, and yw to r_inner.

6 Find the Added segments subsection. Click Add Linear.

7 Find the Control points subsection. In row 2, set yw to r_inner+t1.
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8 Find the Added segments subsection. Click Add Linear.

9 Find the Control points subsection. In row 2, set xw to -2*l1/3.

10 Find the Added segments subsection. Click Add Cubic.

11 Find the Control points subsection. In row 2, set xw to -l1/3.

12 In row 3, set xw to -l1/3, and yw to r_inner+t2.

13 In row 4, set xw to 0, and yw to r_inner+t2.

14 On the Work Plane toolbar, click Build All.

15 Click the Zoom Extents button on the Graphics toolbar.

16 In the Model Builder window, click Geometry 1.

17 On the Home toolbar, click Build All.

You obtain the following 2D geometry.

Next, revolve the embedded 2D geometry to create the 3D model geometry.

Revolve 1 (rev1)
1 On the Geometry toolbar, click Revolve.

2 In the Settings window for Revolve, locate the Revolution Angles section.

3 Click the Angles button.

4 In the End angle text field, type 180.
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5 Locate the Revolution Axis section. Find the Direction of revolution axis subsection. In 
the xw text field, type 1.

6 In the yw text field, type 0.

7 On the Geometry toolbar, click Build All.

8 Click the Go to Default 3D View button on the Graphics toolbar.

D E F I N I T I O N S

Variables 1
1 On the Home toolbar, click Variables and choose Local Variables.

2 In the Settings window for Variables, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.
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4 Select Boundaries 3, 7, 9, 10, 13, 19, 23, 25, 29, 32, 35, 38–42, 45, 51, 55, 57, 61, 
64, 67, 70–74, 77, 83, 87, 89, 93, 96, 99, and 102–106 only.

To do this, first copy the list of boundaries from this text, then use the Paste Selection 
button in the Geometric Entity Selection section, to paste these numbers.

For use when specifying the boundary condition for the flange’s outer surface, create a 
selection.

5 Click Create Selection.

6 In the Create Selection dialog box, type Outer Boundaries in the Selection name text 
field.

7 Click OK.

8 In the Settings window for Variables, locate the Variables section.

9 In the table, enter the following settings:

Name Expression Unit Description

alphap 1/ht.T_amb 1/K Coefficient of thermal 
expansion

Gr g_const*alphap*
(T-ht.T_amb)*D^3/
nu^2

Grashof number

theta atan(y/z)+90[deg] rad Incidence angle

Hc k*f(theta)*Gr^0.25/D W/(m²·K) Heat transfer film 
coefficient
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A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Silica glass.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

1 In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids 

(ht).

2 In the Settings window for Heat Transfer in Solids, locate the Ambient Settings section.

3 In the Tamb text field, type 298[K].

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, type 323.15[K] in the T text field.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Click the Wireframe Rendering button on the Graphics toolbar.
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3 Select Boundaries 2, 8, 12, 15, 21, 22, 24, 27, 33, 34, 44, 47, 53, 54, 56, 59, 65, 66, 
76, 79, 85, 86, 88, 91, 97, and 98 only.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 4, 6, 16, 18, 48, 50, 80, and 82 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.
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4 Click the Convective heat flux button.

5 In the h text field, type Hh.

6 In the Text text field, type T_inner.

7 Click the Wireframe Rendering button on the Graphics toolbar to go back to the original 
view.

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Outer Boundaries.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type Hc.

6 From the Text list, choose Ambient temperature (ht).

M E S H  1

On the Mesh toolbar, click Boundary and choose Mapped.

Mapped 1
1 Click the Go to XY View button on the Graphics toolbar. Do this twice to see the 

boundary mesh.

2 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Mapped 1.
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3 Select Boundaries 8, 21, 22, 33, 53, 54, 65, 85, 86, and 97 only.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Mapped 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Extra fine.

4 Click Build Selected.

5 On the Mesh toolbar, click Boundary and choose Free Triangular.

Free Triangular 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Free Triangular 1.

2 Select Boundaries 34, 66, and 98 only.
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3 In the Settings window for Free Triangular, click Build Selected.

4 Click the Go to Default 3D View button on the Graphics toolbar.

5 On the Mesh toolbar, click Swept.

Swept 1
Click Distribution.

Distribution 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1>Swept 1 click 

Distribution 1.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 30.
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4 Click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
The first default plot group shows the temperature field on the surface; compare with 
Figure 4.

Delete the second plot group to make a new surface plot of the heat transfer film 
coefficient.

Isothermal Contours (ht)
1 In the Model Builder window, under Results right-click Isothermal Contours (ht) and 

choose Delete.

2 Click Yes to confirm.

3D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.
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2 In the Settings window for 3D Plot Group, type Heat Transfer Film Coefficient 
in the Label text field.

3 On the Heat Transfer Film Coefficient toolbar, click Surface.

Surface 1
1 In the Model Builder window, under Results>Heat Transfer Film Coefficient click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Definitions>

Variables>Hc - Heat transfer film coefficient.

3 On the Heat Transfer Film Coefficient toolbar, click Plot.

Compare this plot with that in Figure 5.

Surface Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 In the Settings window for Surface Integration, type Outgoing Heat Flux in the Label 
text field.

3 Locate the Selection section. From the Selection list, choose Outer Boundaries.

4 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Heat Transfer in Solids>Boundary fluxes>ht.ntflux - 

Normal total heat flux.

5 Click Evaluate.

TA B L E

1 Go to the Table window.

The integrated value, approximately 0.51 W, appears in the Table tab below the Graphics 
window. Taking both flange halves into account, the total cooling power of the flange 
is thus roughly 1 W.

Finally, extend the model by performing a parametric sweep over the inner pipe radius. 
Before adding a separate study for this purpose, define a variable for the total cooling 
power.

D E F I N I T I O N S

Integration 1a (intop1)
1 On the Definitions toolbar, click Component Couplings and choose Integration.
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2 In the Settings window for Integration, type Integration, Outer in the Label text 
field.

3 In the Operator name text field, type intop_outer.

4 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

5 From the Selection list, choose Outer Boundaries.

Variables 2
1 On the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

This gives a sweep centered around the original radius value.

5 On the Study toolbar, click Compute.

Name Expression Unit Description

P_cooling 2*intop_outer(ht.q0) W Cooling power

Parameter name Parameter value list Parameter unit

r_inner range(6,1,10) mm
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R E S U L T S

Temperature (ht) 1
You get a new surface plot of the temperature for the parametric solution. From the 
Parameter value list you can choose the radius value for which to display the result.

Surface temperature for an inner radius of 10 mm.

Finally, replace the slice plot in the fourth plot group by a graph of the total cooling power 
versus tube radius.

Isothermal Contours (ht)
1 In the Model Builder window, under Results right-click Isothermal Contours (ht) and 

choose Delete.

2 Click Yes to confirm.

1D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Cooling Power in the Label text field.

3 Locate the Data section. From the Data set list, choose Study 2/Parametric Solutions 1 

(sol3).
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Global 1
1 On the Cooling Power toolbar, click Global.

2 In the Settings window for Global, click Add Expression in the upper-right corner of the 
y-axis data section. From the menu, choose Model>Component 1>Definitions>Variables>

P_cooling - Cooling power.

3 Click to expand the Legends section. Clear the Show legends check box.

Cooling Power
1 In the Model Builder window, under Results click Cooling Power.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 Select the x-axis label check box.

4 In the associated text field, type Inner pipe radius (m).

5 On the Cooling Power toolbar, click Plot.

Compare the result with the graph in Figure 6.
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Introduction

This example is a model of a continuous casting process. Liquid metal is poured into a 
mold of uniform cross section. The outside of the mold is cooled and the metal solidifies 
as it flows through the mold. When the metal leaves the mold, it is completely solidified 
on the outside but still liquid inside. The metal then continues to cool and eventually 
solidify completely, at which point it can be cut into sections. This tutorial simplifies the 
problem somewhat by not computing the flow field of the liquid metal and assuming there 
is no volume change during solidification. It is also assumed that the velocity of the metal 
is constant and uniform throughout the modeling domain. The phase transition from 
molten to solid state is modeled via the apparent heat capacity formulation. Issues of 
convergence and mesh refinement are addressed for this highly nonlinear model.

The Continuous Casting application is similar to this one, except that the velocity is 
computed from the Laminar Flow interface instead of being considered constant and 
uniform. For a detailed description of the application, see Continuous Casting.

Figure 1: A continuous casting process. The section where the metal is solidifying is being 
modeled.

Model Overview

The model simplifies the 3D geometry of the continuous casting to a 2D axisymmetric 
model composed of two rectangular regions: one representing the strand within the mold, 

Modeling region

Solid metal billet

Spray cooling

Tundish

Nozzle

Cooled mold

Molten metal

Saw
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and one the spray cooled region outside of the mold, prior to the saw cutoff. In the second 
section, there is also significant cooling via radiation to the ambient. In this region it is 
assumed that the molten metal is in a hydrostatic state, that the only motion in the fluid is 
due to the bulk downward motion of the strand. This simplification allows the assumption 
of bulk motion throughout the domain. 

Since this is a continuous process, the system can be modeled at steady state. The heat 
transport is described by the equation:

where k and Cp denote thermal conductivity and specific heat, respectively. The velocity, 
u, is the fixed casting speed of the metal in both liquid and solid states.

As the metal cools down in the mold, it solidifies. During the phase transition, a significant 
amount of latent heat is released. The total amount of heat released per unit mass of alloy 
during the transition is given by the change in enthalpy, ΔH. In addition, the specific heat 
capacity, Cp, also changes considerably during the transition. The difference in specific 
heat before and after transition can be approximated by

As opposed to pure metals, an alloy generally undergoes a broad temperature transition 
zone, over several Kelvin, in which a mixture of both solid and molten material coexist in 
a “mushy” zone. To account for the latent heat related to the phase transition, the 
Apparent Heat capacity method is used through the Heat Transfer with Phase Change 
domain condition. The objective of the analysis is to make ΔT, the half-width of the 
transition interval small, such that the solidification front location is well defined.

Table 1 reviews the material properties in this tutorial.

TABLE 1:  MATERIAL PROPERTIES

The melting temperature, Tm, and enthalpy, ΔH, are 1356 K and 205 kJ/kg, respectively.

This example is a highly nonlinear problem and benefits from taking an iterative approach 
to finding the solution. The location of the transition between the molten and solid state 

PROPERTY SYMBOL MELT SOLID

Density ρ (kg/m3) 8500 8500

Heat capacity at constant pressure Cp (J/(kg⋅K)) 531 380

Thermal conductivity k (W/(m⋅K)) 150 300

ρCpu ∇T⋅ ∇ k∇T–( )⋅+ 0=

ΔCp
ΔH
T

---------=
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is a strong function of the casting velocity, the cooling rate in the mold, and the cooling 
rate in the spray cooled region. A fine mesh is needed across the solidification front to 
resolve the change in material properties. However, it is not known where this front will 
be.

By starting with a gradual transition between liquid and solid, it is possible to find a 
solution even on a relatively coarse mesh. This solution can be used as the starting point 
for the next step in the solution procedure, which uses a sharper transition from liquid to 
solid. This is done using the continuation method. Given a monotonic list of values to 
solve for, the continuation method uses the solution to the last case as the starting 
condition for the next. Once a solution is found for the smallest desired ΔT, the adaptive 
mesh refinement algorithm is used to refine the mesh to put more elements around the 
transition region. This finer mesh is then used to find a solution with an even sharper 
transition. This can be repeated as needed to get better and better resolution of the 
location of the solidification front.

In this example, the parameter ΔT is first ramped down from 300 K to 75 K, then the 
adaptive mesh refinement is used such that a finer mesh is used around the solidification 
front. The resultant solution and mesh are then used as starting points for a second study, 
where the parameter ΔT is further ramped down from 50 K to 25 K. The double-dogleg 
solver is used to find the solution to this highly nonlinear problem. Although it takes more 
time, this solver converges better in cases when material properties vary strongly with 
respect to the solution.

Results and Discussion

The solidification front computed with the coarsest mesh, and for ΔT = 75 K, is shown in 
Figure 2. A wide transition between the molten and solid state is observed. The adaptive 
mesh refinement algorithm then refines the mesh along the solidification front because 
this is the region where the results are strongly dependent upon mesh size. This solution, 
and refined mesh, is used as the starting point for the next solution, which ramps the ΔT 
parameter down to 25 K. These results are shown in Figure 3.

The point of complete solidification moves slightly as the transition zone is made smaller. 
As the transition zone becomes smaller, a finer mesh is needed, otherwise the model might 
not converge. If it is desired to get an even better resolution of the solidification front, the 
solution procedure used here should be repeated to get an even finer mesh, and further 
ramp down the ΔT parameter.

The liquid phase fraction is plotted along the r-direction at the line at the bottom of the 
mold in Figure 4, and Figure 5 shows the liquid fraction along the centerline of the strand. 
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For smaller values of ΔT, the transition becomes sharper, and the model gives confidence 
that the metal is completely solidified before the strand is cut.

Figure 2: The fraction of liquid phase for ΔT = 75 K shows a gradual transition between the 
liquid and solid phase.
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Figure 3: The fraction of liquid phase for ΔT = 25 K shows a sharp transition between the 
liquid and solid phase.
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Figure 4: The fraction of liquid phase through the radius for all values of ΔT. For smaller 
values of ΔT, the transition is sharper.
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Figure 5: The fraction of liquid phase along the centerline for all values of ΔT. For smaller 
values of ΔT, the transition is sharper.

Application Library path: Heat_Transfer_Module/Thermal_Processing/
cooling_solidification_metal

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Fluids (ht).

3 Click Add.

4 Click Study.
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5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

First, set up parameters and variables used in the continuous casting process model 
analysis.

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
cooling_solidification_metal_parameters.txt.

G E O M E T R Y  1

Create two rectangles representing the strand within the mold, and spray cooled region 
outside of the mold.

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.1.

4 In the Height text field, type 0.6.

Rectangle 2 (r2)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.1.

4 In the Height text field, type 0.2.

5 Locate the Position section. In the z text field, type 0.6.

6 Click Build All Objects.
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7 Click the Zoom Extents button on the Graphics toolbar.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, type Solid Metal Alloy in the Label text field.

2 Locate the Material Contents section. In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Liquid Metal Alloy in the Label text field.

3 Select Domains 1 and 2 only.

Property Name Value Unit Property 
group

Thermal conductivity k 300 W/(m·K) Basic

Density rho 8500 kg/m³ Basic

Heat capacity at constant 
pressure

Cp Cp_s J/(kg·K) Basic

Ratio of specific heats gamma 1 1 Basic
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4 Locate the Material Contents section. In the table, enter the following settings:

Set up the physics.

H E A T  TR A N S F E R  I N  F L U I D S  ( H T )

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Fluids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, type T_in in the T text field.

Phase Change Material 1
1 On the Physics toolbar, click Domains and choose Phase Change Material.

2 Select Domains 1 and 2 only.

3 In the Settings window for Phase Change Material, locate the Model Inputs section.

4 Specify the u vector as

5 Locate the Phase Change section. In the Tpc, 1 → 2 text field, type T_m.

6 In the ΔT1 → 2 text field, type dT.

7 In the L1 → 2 text field, type dH.

8 Locate the Phase 1 section. From the Material, phase 1 list, choose Solid Metal Alloy 

(mat1).

9 Locate the Phase 2 section. From the Material, phase 2 list, choose Liquid Metal Alloy 

(mat2).

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

Property Name Value Unit Property 
group

Thermal conductivity k 150 W/(m·K) Basic

Density rho 8500 kg/m³ Basic

Heat capacity at constant 
pressure

Cp Cp_l J/(kg·K) Basic

Ratio of specific heats gamma 1 1 Basic

0 r

-v_cast z
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2 Select Boundary 5 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type T_in.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundary 7 only.
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3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type h_mold.

6 In the Text text field, type T0.

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundary 6 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type h_spray.

6 In the Text text field, type T0.

Diffuse Surface 1
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 Select Boundary 6 only.

3 In the Settings window for Diffuse Surface, locate the Surface Emissivity section.

4 From the ε list, choose User defined. In the associated text field, type eps_s.

5 Locate the Ambient section. In the Tamb text field, type T0.
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Outflow 1
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 Select Boundary 2 only.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Extremely fine.

S T U D Y  1

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, locate the Study Settings section.

3 Clear the Generate default plots check box.

Step 1: Stationary
Set up an auxiliary continuation sweep for the dT parameter.

1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study extensions section.

3 Locate the Study Extensions section. Select the Auxiliary sweep check box.

4 Click Add.
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5 In the table, enter the following settings:

6 Select the Adaptive mesh refinement check box.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 1 node, then click Adaptive Mesh Refinement.

4 In the Settings window for Adaptive Mesh Refinement, locate the Mesh Refinement 
section.

5 From the Refinement method list, choose Mesh initialization.

6 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1)>

Stationary Solver 1 click Fully Coupled 1.

7 In the Settings window for Fully Coupled, click to expand the Method and termination 
section.

8 Locate the Method and Termination section. From the Nonlinear method list, choose 
Double dogleg.

9 On the Study toolbar, click Compute.

R E S U L T S

2D Plot Group 1
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Solid and Liquid Phases 
(Adaptive Mesh) in the Label text field.

Surface 1
1 Right-click Solid and Liquid Phases (Adaptive Mesh) and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Heat Transfer in 

Fluids>Phase change>ht.theta1 - Phase indicator, phase 1.

3 On the Solid and Liquid Phases (Adaptive Mesh) toolbar, click Plot.

The reproduced figure describes the fraction of liquid phase for ΔT = 75 K.

Parameter name Parameter value list Parameter unit

dT 300 200 150 100 75 K
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A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies.

4 In the Select Study tree, select Preset Studies>Stationary.

5 Click Add Study in the window toolbar.

S T U D Y  2

Step 1: Stationary
1 On the Home toolbar, click Add Study to close the Add Study window.

2 In the Model Builder window, click Study 2.

3 In the Settings window for Study, locate the Study Settings section.

4 Clear the Generate default plots check box.

5 In the Model Builder window, click Step 1: Stationary.

6 In the Settings window for Stationary, click to expand the Values of dependent variables 
section.

7 Locate the Values of Dependent Variables section. Find the Initial values of variables solved 

for subsection. From the Settings list, choose User controlled.

8 From the Method list, choose Solution.

9 From the Study list, choose Study 1, Stationary.

10 From the Solution list, choose Adaptive Mesh Refinement 1 (sol2).

11 From the Parameter value (dT (K)) list, choose 75.

12 Click to expand the Mesh selection section. Locate the Study Extensions section. Select 
the Auxiliary sweep check box.

13 Click Add.

14 In the table, enter the following settings:

Solution 3 (sol3)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 3 (sol3) node.

Parameter name Parameter value list Parameter unit

dT 50 25 K
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3 In the Model Builder window, expand the Study 2>Solver Configurations>Solution 3 

(sol3)>Stationary Solver 1 node, then click Fully Coupled 1.

4 In the Settings window for Fully Coupled, locate the Method and Termination section.

5 From the Nonlinear method list, choose Double dogleg.

6 On the Study toolbar, click Compute.

R E S U L T S

2D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Solid and Liquid Phases in the 
Label text field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 3 (sol3).

Surface 1
1 Right-click Solid and Liquid Phases and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Heat Transfer in 

Fluids>Phase change>ht.theta1 - Phase indicator, phase 1.

3 On the Solid and Liquid Phases toolbar, click Plot.

This shows the fraction of liquid phase for ΔT = 25 K.

1D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Phase Indicator at Symmetry Axis 
in the Label text field.

Line Graph 1
1 On the Phase Indicator at Symmetry Axis toolbar, click Line Graph.

2 Select Boundaries 1 and 3 only.

3 In the Settings window for Line Graph, locate the y-axis data section.

4 Click ht.theta1 - Phase indicator, phase 1 in the upper-right corner of the section. Locate 
the x-Axis Data section. From the Parameter list, choose Expression.

5 In the Expression text field, type z.

6 Click to expand the Legends section. Select the Show legends check box.
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Line Graph 2
1 Right-click Line Graph 1 and choose Duplicate.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Data set list, choose Study 2/Solution 3 (sol3).

4 On the Phase Indicator at Symmetry Axis toolbar, click Plot.

Compare the resulting plot with Figure 5 showing the fraction of liquid phase through 
the centerline for all values of Δ T.

Phase Indicator at Symmetry Axis
In the Model Builder window, under Results right-click Phase Indicator at Symmetry Axis and 
choose Duplicate.

Phase Indicator at Symmetry Axis 1
In the Settings window for 1D Plot Group, type Phase Indicator through Radius in 
the Label text field.

Line Graph 1
1 In the Model Builder window, expand the Results>Phase Indicator through Radius node, 

then click Line Graph 1.

2 In the Settings window for Line Graph, locate the Selection section.

3 Click Clear Selection.

4 Select Boundary 4 only.

5 Locate the x-Axis Data section. In the Expression text field, type r.

6 On the Phase Indicator through Radius toolbar, click Plot.

Line Graph 2
1 In the Model Builder window, under Results>Phase Indicator through Radius click Line 

Graph 2.

2 In the Settings window for Line Graph, locate the Selection section.

3 Click Clear Selection.

4 Select Boundary 4 only.

5 Locate the x-Axis Data section. In the Expression text field, type r.

Phase Indicator through Radius
1 In the Model Builder window, under Results click Phase Indicator through Radius.

2 In the Settings window for 1D Plot Group, click to expand the Legend section.

3 From the Position list, choose Upper left.
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4 On the Phase Indicator through Radius toolbar, click Plot.

Compare the resulting plot with Figure 4 showing the fraction of liquid phase through 
the radius for all values of Δ T.
19 |  C O O L I N G  A N D  S O L I D I F I C A T I O N  O F  M E T A L



20 |  C O O L I N G  A N D  S O L I D I F I C A T I O N  O F  M E T A L



Created in COMSOL Multiphysics 5.2a
C r o s s - F l ow Hea t  E x c h ang e r
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


Introduction

This application simulates the fluid flow and heat transfer in a micro-heat exchanger of 
cross-flow type made of stainless steel. Heat exchangers of this type are found in 
lab-on-chip devices in biotechnology and microreactors, for example for micro-fuel cells. 
The application takes into account heat transferred through both convection and 
conduction. The geometry and material properties are taken from Ref. 1.

Model Definition

Figure 1 shows the heat exchanger’s geometry. Notice that the fluid channels have a 
square cross section rather than the circular cross section more commonly used in 
micro-heat exchangers. A cross-flow heat exchanger can typically consist of about 20 unit 
cells. However, because the unit cells are identical except for edge effects in the outer cells, 
you can restrict the model to a single unit cell.

Figure 1: Depiction of the modeled part of the micro-heat exchanger.

Because heat is transferred by convection and conduction, the model uses a Conjugate 
Heat Transfer interface in the laminar flow regime.

The boundary conditions are insulating for all outer surfaces except for the inlet and outlet 
boundaries. At the inlets for both cold and hot streams, the temperatures are constant and 
a laminar inflow profile with an average velocity of 2.5 mm/s is defined.

At the outlet, the heat transport is dominated by convection, which makes the outflow 
boundary condition suitable. For the flow field, the model applies the outlet boundary 
condition with a constant pressure.
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As shown in Figure 1, you can take advantage of the model’s symmetries to model only 
half of the channel height. Therefore, the symmetry boundary condition applies to the 
channels.

Results and Discussion

Figure 2 shows the temperature at the channel walls as well as temperature isosurfaces in 
the device, which clearly reveal the influence of the convective term.

Figure 2: Channel wall temperature and isotherms through the cell geometry.
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As can be seen in Figure 3, the temperature differs significantly between the different 
outlets in both hot and cold streams. This implies that the hot stream is not cooled 
uniformly.

Figure 3: Temperature field at the outlet boundaries.
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The flow field in the channels is a typical laminar velocity profile; see Figure 4.

Figure 4: Velocity profile in the channels.

There are several quantities that describe the characteristics and effectiveness of a heat 
exchanger. The mixing-cup temperature of the fluid leaving the heat exchanger is 
calculated according to (1.4 in Ref. 2)

 (1)

COMSOL Multiphysics provides built-in variables to easily calculate T. At the upper 
channels, the outlet mixing-cup temperature is 45 °C. At the lower channels, despite a 
hotter inlet temperature, a lower value of 38.6 °C is found for the outlet mixing-cup 
temperature. The maximum pressure drop in the heat exchanger is 5 Pa.

The overall heat transfer coefficient is another interesting quantity. It is a measure of the 
performance of a heat exchanger design defined as

T 

ρCpTu sd
outlet


ρCpu sd
outlet


-----------------------------------------=
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 (2)

where P is the total exchanged power and A is the surface area through which P flows. In 
this model, the value of heq is about 1500 W/(m2·K).
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Application Library path: Heat_Transfer_Module/Heat_Exchangers/
crossflow_heat_exchanger

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Conjugate Heat Transfer>Laminar Flow.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

heq
P

A Thot Tcold–( )
-----------------------------------------=
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3 In the table, enter the following settings:

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose µm.

First, create the cross-section of one unit cell and extrude it.

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 800.

4 In the Depth text field, type 800.

5 In the Height text field, type 60.

Block 2 (blk2)
1 Right-click Block 1 (blk1) and choose Build Selected.

2 On the Geometry toolbar, click Block.

3 In the Settings window for Block, locate the Size and Shape section.

4 In the Width text field, type 800.

5 In the Depth text field, type 100.

6 In the Height text field, type 40.

7 Locate the Position section. In the y text field, type 200.

Array 1 (arr1)
1 Right-click Block 2 (blk2) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Array.

3 Select the object blk2 only.

4 In the Settings window for Array, locate the Size section.

5 From the Array type list, choose Linear.

Name Expression Value Description

T_cold 300[K] 300 K Temperature, cold stream

T_hot 330[K] 330 K Temperature, hot stream

u_avg 2.5[mm/s] 0.0025 m/s Average inlet velocity
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6 In the Size text field, type 5.

7 Locate the Displacement section. In the y text field, type 120.

8 Locate the Selections of Resulting Entities section. Click New.

9 In the New Cumulative Selection dialog box, type Channels in the Name text field.

10 Click OK.

Rotate 1 (rot1)
1 On the Geometry toolbar, click Transforms and choose Rotate.

2 Click in the Graphics window and then press Ctrl+A to select all objects.

3 In the Settings window for Rotate, locate the Rotation Angle section.

4 In the Rotation text field, type 180.

5 Locate the Point on Axis of Rotation section. In the z text field, type 60.

6 Locate the Axis of Rotation section. From the Axis type list, choose Cartesian.

7 In the x text field, type 1.

8 In the y text field, type 1.

9 In the z text field, type 0.

Keep the existing unit cell by the following step.

10 Locate the Input section. Select the Keep input objects check box.

11 Click Build All Objects.

12 Click the Zoom Extents button on the Graphics toolbar.

Define several selections that help you throughout the model set-up.

D E F I N I T I O N S

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Upper Inlets in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 41, 48, 55, 62, and 69 only.

Explicit 2
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Lower Inlets in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.
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4 Select Boundaries 8, 14, 20, 26, and 32 only.

Explicit 3
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Upper Outlets in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 44, 51, 58, 65, and 72 only.

Explicit 4
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Lower Outlets in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 77–81 only.

Explicit 5
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Symmetry in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.
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4 Select the Group by continuous tangent check box.

Select one of the uppermost and lowermost boundaries, which now automatically will 
select all uppermost and lowermost boundaries thanks to the continuous tangency.

The next selections are needed to evaluate the equivalent heat transfer coefficient.

Union 1
1 On the Definitions toolbar, click Union.

2 In the Settings window for Union, type Outlets in the Label text field.

3 Locate the Geometric Entity Level section. From the Level list, choose Boundary.

4 Locate the Input Entities section. Under Selections to add, click Add.

5 In the Add dialog box, In the Selections to add list, choose Upper Outlets and Lower 

Outlets.

6 Click OK.

M A T E R I A L S

Define the material properties.

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.
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2 In the Settings window for Material, type Stainless Steel in the Label text field.

3 Locate the Material Contents section. In the table, enter the following settings:

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Water, liquid.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Water, liquid (mat2)
1 On the Home toolbar, click Add Material to close the Add Material window.

2 In the Model Builder window, under Component 1 (comp1)>Materials click Water, liquid 

(mat2).

3 In the Settings window for Material, locate the Geometric Entity Selection section.

4 From the Selection list, choose Channels.

H E A T  TR A N S F E R  ( H T )

Fluid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Fluid 

1.

2 In the Settings window for Fluid, locate the Domain Selection section.

3 From the Selection list, choose Channels.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 In the Settings window for Temperature, locate the Boundary Selection section.

3 From the Selection list, choose Upper Inlets.

Property Name Value Unit Property 
group

Thermal conductivity k 15 W/(m·K) Basic

Density rho 7800 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 420 J/(kg·K) Basic
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4 Locate the Temperature section. In the T0 text field, type T_hot.

Temperature 2
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 In the Settings window for Temperature, locate the Boundary Selection section.

3 From the Selection list, choose Lower Inlets.

4 Locate the Temperature section. In the T0 text field, type T_cold.

Outflow 1
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 In the Settings window for Outflow, locate the Boundary Selection section.

3 From the Selection list, choose Upper Outlets.

Outflow 2
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 In the Settings window for Outflow, locate the Boundary Selection section.

3 From the Selection list, choose Lower Outlets.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 In the Settings window for Symmetry, locate the Boundary Selection section.

3 From the Selection list, choose Symmetry.

So far, the boundary conditions for heat transfer have been specified. Continue with the 
set up of the flow equation.

L A M I N A R  F L O W  ( S P F )

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

2 In the Settings window for Laminar Flow, locate the Domain Selection section.

3 From the Selection list, choose Channels.

Because of the different inlet temperatures, the densities for the hot and cold stream vary 
and produce different velocities when the laminar inflow boundary condition is used. In 
order to have the same velocity profile on each inlet, define the laminar inflow boundary 
condition for the hot and cold inlet boundaries separately.

Inlet 1
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 In the Settings window for Inlet, locate the Boundary Selection section.
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3 From the Selection list, choose Upper Inlets.

4 Locate the Boundary Condition section. From the list, choose Laminar inflow.

5 Locate the Laminar Inflow section. In the Uav text field, type u_avg.

The Entrance length value must be large enough so that the flow can reach a laminar 
profile. For a laminar flow, Lentr should be significantly greater than 0.06ReD, where 
Re is the Reynolds number and D is the inlet length scale. In this case, 1 mm is an 
appropriate value.

6 In the Lentr text field, type 1[mm].

Inlet 2
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 In the Settings window for Inlet, locate the Boundary Selection section.

3 From the Selection list, choose Lower Inlets.

4 Locate the Boundary Condition section. From the list, choose Laminar inflow.

5 Locate the Laminar Inflow section. In the Uav text field, type u_avg.

6 In the Lentr text field, type 1[mm].

Outlet 1
1 On the Physics toolbar, click Boundaries and choose Outlet.

2 In the Settings window for Outlet, locate the Boundary Selection section.

3 From the Selection list, choose Upper Outlets.

Outlet 2
1 On the Physics toolbar, click Boundaries and choose Outlet.

2 In the Settings window for Outlet, locate the Boundary Selection section.

3 From the Selection list, choose Lower Outlets.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 In the Settings window for Symmetry, locate the Boundary Selection section.

3 From the Selection list, choose Symmetry.

After solving the model, the equivalent heat transfer coefficient is evaluated according to 
Equation 2. To do so, define the following coupling operator.
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D E F I N I T I O N S

Average 1 (aveop1)
1 On the Definitions toolbar, click Component Couplings and choose Average.

2 In the Settings window for Average, type Average on Upper Channel Walls in the 
Label text field.

3 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

4 Select Boundaries 40, 42, 45, 47, 49, 52, 54, 56, 59, 61, 63, 66, 68, 70, and 73 only.

To select more easily these boundaries, use the Paste button and insert the list of 
numbers above in the Paste Selection dialog box.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
COMSOL Multiphysics automatically creates four default plots: a temperature plot, an 
isothermal contour plot, a slice plot for the velocity field, and contour plot for the pressure 
field. The isothermal contours will be modified, to create the plot shown in Figure 2.

Isothermal Contours (ht)
In the Model Builder window, under Results right-click Isothermal Contours (ht) and choose 
Surface.

Surface 1
1 In the Settings window for Surface, locate the Data section.

2 From the Data set list, choose Exterior Walls.

3 Click Replace Expression in the upper-right corner of the Expression section. From the 
menu, choose Model>Component 1>Heat Transfer>Temperature>T - Temperature.

4 Click to expand the Inherit style section. Locate the Inherit Style section. From the Plot 
list, choose Isosurface.

5 On the Isothermal Contours (ht) toolbar, click Plot.

To visualize the velocity field as in Figure 4, follow the steps below:

Slice
1 In the Model Builder window, expand the Velocity (spf) node.
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2 Right-click Slice and choose Delete.

Velocity (spf)
In the Model Builder window, under Results right-click Velocity (spf) and choose Surface.

Surface 1
1 In the Settings window for Surface, click Replace Expression in the upper-right corner of 

the Expression section. From the menu, choose Model>Component 1>Laminar Flow>

Velocity and pressure>spf.U - Velocity magnitude.

2 Locate the Expression section. From the Unit list, choose mm/s.

3 On the Velocity (spf) toolbar, click Plot.

Data Sets
To show the temperature on the outlet boundaries only, as in Figure 3, first produce a new 
data set for the selection built before. Then use this data set for a surface plot of the 
temperature.

Surface 2
1 On the Results toolbar, click More Data Sets and choose Surface.

2 In the Settings window for Surface, type Outlets in the Label text field.

3 Locate the Selection section. From the Selection list, choose Outlets.

3D Plot Group 5
1 On the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Outlet Temperature in the Label text 
field.

Surface 1
1 Right-click Outlet Temperature and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Data set list, choose Outlets.

4 Locate the Coloring and Style section. From the Color table list, choose ThermalLight.

5 On the Outlet Temperature toolbar, click Plot.

Global Evaluation 1
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, type Mixing-Cup Temperatures in the 
Label text field.
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3 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Heat Transfer>Global>Weighted average 

temperature>ht.ofl1.Tave - Weighted average temperature.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

TA B L E

1 Go to the Table window.

The mixing-cup temperature at upper outlets is about 38.5°C and at the lower outlets 
about 45°C.

R E S U L T S

Derived Values
To calculate the maximum pressure drop proceed as follows:

Surface Maximum 1
1 On the Results toolbar, click More Derived Values and choose Maximum>Surface 

Maximum.

2 In the Settings window for Surface Maximum, locate the Selection section.

3 From the Selection list, choose All boundaries.

4 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Laminar Flow>Velocity and pressure>p - Pressure.

5 In the Label text field, type Maximum Pressure Drop.

6 Locate the Expressions section. In the table, enter the following settings:

7 Click Evaluate.

Expression Unit Description

ht.ofl1.Tave degC Weighted average temperature (Upper Outlets)

ht.ofl2.Tave degC Weighted average temperature (Lower Outlets)

Expression Unit Description

p Pa Maximum pressure drop
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TA B L E

1 Go to the Table window.

The maximum pressure is 5 Pa. The minimum pressure is defined by the outlet 
boundary conditions and is zero. Thus, the maximum pressure drop is also 5 Pa.

Now, evaluate the equivalent heat transfer coefficient as defined in Equation 2. You can 
use the integration operators defined previously in Component 1>Definitions.

R E S U L T S

Global Evaluation 2
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Expressions section.

3 In the table, enter the following settings:

4 In the Label text field, type Heat Transfer Coefficient.

5 Locate the Expressions section. In the table, enter the following settings:

6 Click Evaluate.

TA B L E

1 Go to the Table window.

The equivalent heat transfer coefficient is about 1500W/(m2·K).

Expression Unit Description

aveop1(ht.ntflux)/(T_hot-T_cold) W/(m^2*K)

Expression Unit Description

aveop1(ht.ntflux)/
(T_hot-T_cold)

W/(m^2*K) Heat transfer coefficient
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Introduction

The following example illustrates how to build and solve a conductive heat transfer 
problem using the Heat Transfer interface. The model, taken from a NAFEMS benchmark 
collection, shows an axisymmetric steady-state thermal analysis. As opposed to the 
NAFEMS benchmark model, we use the temperature unit Kelvin instead of degrees 
Celsius for this model.

Model Definition

The modeling domain describes the cross section of a 3D solid as shown in Figure 1.

Figure 1: Model geometry and boundary conditions.

You set three types of boundary conditions:·

• Prescribed heat flux

• Insulation/Symmetry

• Prescribed temperature

The governing equation for this problem is the steady-state heat equation for conduction 
with the volumetric heat source set to zero:

The thermal conductivity k is 52 W/(m·K).

Insulation

Insulation

273.15 K

273.15 K

273.15 K

z = 0.04 m

z = 0.1 m

z = 0 m

z = 1.4 m

5·105W/m2

∇ k– ∇T( )⋅ 0=
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Results

The plot in Figure 2 shows the temperature distribution.

Figure 2: Temperature distribution.

The benchmark result for the target location (r = 0.04 m and z = 0.04 m) is a temperature 
of 59.82 °C (332.97 K). The COMSOL Multiphysics model, using a default mesh with 
about 540 elements, gives a temperature of 332.957 K at the same location.

Reference

1. A.D. Cameron, J.A. Casey, and G.B. Simpson, NAFEMS Benchmark Tests for Thermal 
Analysis (Summary), NAFEMS, 1986.

Application Library path: Heat_Transfer_Module/Tutorials,_Conduction/
cylinder_conduction
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.08.

4 In the Height text field, type 0.14.

5 Locate the Position section. In the r text field, type 0.02.

Point 1 (pt1)
1 On the Geometry toolbar, click Primitives and choose Point.

2 In the Settings window for Point, locate the Point section.

3 In the r text field, type 0.02.

4 In the z text field, type 0.04.

Point 2 (pt2)
1 On the Geometry toolbar, click Primitives and choose Point.

2 In the Settings window for Point, locate the Point section.

3 In the r text field, type 0.02.

4 In the z text field, type 0.1.

5 On the Geometry toolbar, click Build All.
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H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Solid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Solid 1.

2 In the Settings window for Solid, locate the Heat Conduction, Solid section.

3 From the k list, choose User defined. In the associated text field, type 52.

4 Locate the Thermodynamics, Solid section. From the Cp list, choose User defined. From 
the ρ list, choose User defined.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 In the Settings window for Temperature, locate the Temperature section.

3 In the T0 text field, type 273.15[K].

4 Select Boundaries 2, 5, and 6 only.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Heat Flux section.

3 In the q0 text field, type 5e5.

4 Select Boundary 3 only.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Temperature, 3D (ht)
The first default plot is a revolved 3D plot visualizing the temperature field on the surface; 
compare with Figure 2.

1 Click the Zoom Extents button on the Graphics toolbar.
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Isothermal Contours (ht)
The second default plot shows a contour plot of the temperature field.

To obtain the temperature value at any point, just click at that point in the Graphics 
window; The result appears in the Table window at the bottom of the COMSOL Desktop.

Alternatively, you can create a Cut Point data set and Point Evaluation feature as follows.

Cut Point 2D 1
1 On the Results toolbar, click Cut Point 2D.

2 In the Settings window for Cut Point 2D, locate the Point Data section.

3 In the r text field, type 0.04.

4 In the z text field, type 0.04.

Point Evaluation 1
1 On the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Data set list, choose Cut Point 2D 1.

4 Click Evaluate.
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TA B L E

1 Go to the Table window.

The result is approximately 333 K.
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This application uses the discrete ordinates method (DOM) to solve a 3D radiative transfer 
problem in an emitting, absorbing, and linearly anisotropic-scattering finite cylindrical 
medium. Using the S6 quadrature of DOM leads to accurate results, which are needed in 
combined modes of heat transfer. The calculated incident radiation and heat fluxes agree 
well with published results obtained by transformed integral methods (see Ref. 1). In 
addition, the Heat Transfer Module’s DOM formulation easily handles the effects of 
boundary emission and reflection.

Introduction

There are numerous engineering applications of radiative transfer in absorbing, emitting, 
and anisotropically scattering media with variable radiation properties. Examples include, 
among others, coal-fired combustion systems, light-weight fibrous insulations, and heat 
transfer systems containing small scattering particles. Furthermore, the efficiency of 
radiative transfer depends on the boundary conditions, for example, the temperature and 
the emissivity of the surrounding walls, and the target where heat transfer is desired. 
Studies have shown that radiative transfer is highly sensitive to the wall emissivity. In this 
study you build a validation model representing a cylinder with homogeneous walls. Then 
you go on to consider walls with space-dependent emissivity and investigate the effects of 
albedo and scattering.

Model Definition

In this tutorial you validate the DOM formulation in COMSOL Multiphysics by 
examining three benchmark cases. You investigate the method’s efficiency through 
parametric analyses by changing the single-scattering albedo, wall emissivity, and linear 
function. In particular, in the final case, you approximate the scattering phase function by 
a linear function reflecting highly backward, isotropic, and highly forward scattering.

The model geometry, shown in Figure 1, is a cylinder of radius R = 0.5 m and height 
L = 1 m.
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Figure 1: Schematic diagram of the physical model.

These examples use the S6 discrete ordinate method for predicting the heat flux on the 
enclosure side walls and the incident radiation distribution inside the domain.

VE R I F I C A T I O N  C A S E

For the initial study, assume cold boundaries, that is, Ii = 0 where i = 1, 2, 3 refers to the 
surface index in Figure 1. Furthermore, assume that the walls diffusively reflect radiation, 
that is, εi = 0.5 for i = 1, 2, 3. The medium is at a uniform temperature T such that the 
blackbody radiation intensity in an arbitrary direction per unit area and solid angle 
Ib(T) = σT4 ⁄ π equals 1 W/(m2·sr).

WA L L S  W I T H  V A R I A B L E  E M I S S I V I T Y

Two cases are computed for comparison purposes. These 3D cases represent opaque 
partial side wall diffuse emission and/or reflection. In both cases, the radiosity on the side 
walls (Surface 3) varies with the angular coordinate along the full height of the finite 
cylinder according to ε3 = (1 − y ⁄ R) ⁄ 2. Both cases also have cold walls at the cylinder top 
(Surface 1) and bottom (Surface 2).

Surface 2

Surface 1

Su
rf

ac
e 

3
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Case 1 has isotropic scattering function and compares results for different albedos. Case 2 
has constant albedo and compares results with highly forward, isotropic, and highly 
backward scattering function parameterized by the Legendre coefficient a1.

T H E R M A L  A N A L Y S I S

The discrete ordinates method relies on the discrete representation of the directional 
dependence of the radiation intensity. It involves solving the radiative equation for a set of 
directions that span the full solid angle range of 4π around a point in space.

The radiation transport equation (RTE) for this type of configuration can be written as

where

• I(Ω, s) is the radiation intensity at a given position s in the direction Ω

• T is the temperature

• κ, β, and σs are absorption, extinction, and scattering coefficients, respectively

• Ib(T) is the blackbody radiation intensity

• φ(Ω, Ω′) = 1 + a1μ0 where μ0 = Ω ⋅ Ω′ is the cosine of the scattering angle.

The boundary intensities at the cylinder walls are given by the sum of the effective emitted 
intensity and the reflected incident intensities in the given direction:

where

• εw is the surface emissivity, which is in the range [0, 1]

• ρd = 1 − εw is the diffusive reflectivity

• n is the outward normal vector

TABLE 1:  NONSTANDARD TEST CASES

CASE MEDIUM PROPERTIES)

1 albedo = 0.1, 0.5, 0.9

a1 = 0

2 albedo = 0.5

a1 = −0.99, 0, 0.99

Ω I Ω s,( )∇⋅ κIb T( ) βI Ω s,( )–
σs
4π
------ I Ω Ω′,( )φ Ω Ω′,( )∂Ω′

0

4π

+=

Ibnd Ω( ) εwIb T( )
ρd
π
------qout      for all Ω such that n Ω⋅ 0<+=
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• qout is the heat flux striking the wall:

The above equations can be discretized in Cartesian coordinates for monochromatic or 
gray radiation as

The Sn approximation of the RTE in the direction i can be expressed as

For a discrete direction, Ωi, the values of Ωi,1, Ωi,2, and Ωi,3 define the direction cosines 
of Ωi obeying the condition Ωi,1

2 + Ωi,2
2 + Ωi,3

2 = 1. The index j in the above equation 
denotes the direction of incoming radiation contributing to the direction Ωi.

For a diffuse reflecting surface on a wall boundary, the boundary condition equation is 
transformed as

Results and Discussion

The results demonstrate that the DOM procedure for the prediction of radiation is an 
elegant and accurate method for modeling multidimensional radiative heat transfer in 
cylindrical geometries.

VE R I F I C A T I O N  C A S E

This case treats the effects of the scattering albedo on the incident radiation and heat 
fluxes. Figure 2 shows the distribution of the net heat flux qr, net(R, 0, z) versus axial 
optical thickness. There is good overall agreement of the present work with published 
literature results (Ref. 2, Ref. 3, and Ref. 4).

qout n Ω⋅( )I Ω s,( )∂Ω′
n Ωj⋅ 0>
=

Ωi Ii∇⋅ κIb T( ) βIi–
σs
4π
------ I Ω Ω′,( )φ Ω Ω′,( )∂Ω′

0

4π

+=

Ωi Ii∇⋅ κIb T( ) βIi–
σs
4π
------ wjIjφ Ωj Ωi,( )

j 1=

n

+=

Ii bnd, εwIb T( )
ρd
π
------ wjIjn Ωj⋅

n Ωj⋅ 0>
       for all Ωi such that n Ωi⋅ 0<+=
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Figure 2: The effects of the scattering albedo on the radial heat flux qr, net(R, 0, z); for a hot 
cylindrical medium enclosed by cold walls, ε1 = ε2 = ε3 =0.5.

The effects of albedo on the distribution of centerline incident radiation in axial direction 
are shown in Figure 3. The incident radiation is symmetric with respect to z = L ⁄ 2 plane 
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and decrease with increasing scattering albedo. Furthermore, results become more 
uniform with larger scattering albedo.

Figure 3: The effects of the scattering albedo on the distribution of centerline incident 
radiation G(0, 0, z) for a hot cylindrical medium enclosed by cold walls, ε1 = ε2 = ε3 = 0.5.

Figure 4 displays the distributions of the incident radiation across the mid-plan radius G(x,
0, L ⁄ 2) with respect to normalized optical thickness x ⁄ R.
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Figure 4: The effects of the scattering albedo on the distributions of the incident radiation G(x,
0, L ⁄ 2) with respect to normalized optical thickness x ⁄ R for a hot cylindrical medium 

enclosed by cold walls, ε1 = ε2 = ε3 = 0.5.

WA L L S  W I T H  V A R I A B L E  E M I S S I V I T Y

The incident radiation at the mid-plane z = L ⁄ 2 at the radial position R ⁄ 2 is shown in 
Figure 5. At the side surface R ⁄ 2 distance from the cylinder axis, G(R, 0, L ⁄ 2) changes 
with the azimuthal angle. The changes in scattering albedo are also illustrated. The 
smallest albedo makes the biggest change around the azimuthal angle.
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Figure 5: The effects of scattering albedo on the distribution of incident radiation at 
mid-plane z = L ⁄ 2 at R ⁄ 2 distance from the cylinder axis with respect to an azimuthal 
coordinate for Case 1.
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Figure 6 shows the effect of a nonzero linear anisotropic scattering coefficient a1. As 
expected, the differences between isotropic scattering, forward scattering, and backward 
scattering are most accentuated far from the boundary.

Figure 6: The effects of linear anisotropic scattering coefficient a1 on the distribution of 
incident radiation G(0, y, L ⁄ 2) with respect to normalized optical thickness −y ⁄ R for 
Case 2.
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Application Library path: Heat_Transfer_Module/Verification_Examples/
cylinder_participating_media

Modeling Instructions—Validation Case

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Radiation>Radiation in Participating Media 

(rpm).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

T0 (1[W/m^2]*pi/
sigma_const)^(1/4)

86.275 K Body temperature

Tw 0[K] 0 K Wall temperature

ew 0.5 0.5 Wall emissivity
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G E O M E T R Y  1

Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type R.

4 In the Height text field, type L.

5 Click Build All Objects.

M A T E R I A L S

Add a material to specify the absorption and scattering coefficients inside the cylinder.

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Domain in the Label text field.

3 Locate the Material Contents section. In the table, enter the following settings:

Analogously, specify the emissivity of the walls using a material.

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Walls in the Label text field.

omega 0.9 0.9 Single-scattering 
albedo

sigma_s omega 0.9 Scattering 
coefficient

kappa sigma_s*(1/omega-1) 0.1 Absorption 
coefficient

R 0.5[m] 0.5 m Cylinder radius

L 1[m] 1 m Cylinder length

Property Name Value Unit Property 
group

Absorption coefficient kappaR kappa 1/m Basic

Scattering coefficient sigmaS sigma_s 1/m Basic

Name Expression Value Description
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3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose All boundaries.

5 Locate the Material Contents section. In the table, enter the following settings:

R A D I A T I O N  I N  P A R T I C I P A T I N G  M E D I A  ( R P M )

1 In the Model Builder window, under Component 1 (comp1) click Radiation in Participating 

Media (rpm).

2 In the Settings window for Radiation in Participating Media, locate the Participating 

Media Settings section.

3 From the Pindex list, choose 0.3.

With this performance index value, solving the model requires roughly 2GB of RAM. 
If your computer has less available memory than that, try a value in the range 0.5 – 1.

4 From the Discrete ordinates method list, choose S6.

Radiation in Participating Media 1
1 In the Model Builder window, expand the Radiation in Participating Media (rpm) node, 

then click Radiation in Participating Media 1.

2 In the Settings window for Radiation in Participating Media, locate the Model Inputs 
section.

3 In the T text field, type T0.

Opaque Surface 1
1 In the Model Builder window, under Component 1 (comp1)>Radiation in Participating 

Media (rpm) click Opaque Surface 1.

2 In the Settings window for Opaque Surface, locate the Model Inputs section.

3 In the T text field, type Tw.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Coarse.

Property Name Value Unit Property group

Surface emissivity epsilon_rad ew 1 Basic
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Free Triangular 1
1 Right-click Component 1 (comp1)>Mesh 1 and choose More Operations>Free Triangular.

2 Select Boundary 4 only.

3 In the Model Builder window, right-click Mesh 1 and choose Swept.

Swept 1
In the Settings window for Swept, click Build All.

S T U D Y  1

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

Before solving, switch to an iterative solver to reduce memory consumption.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Study 1>Solver Configurations node.

3 In the Model Builder window, expand the Solution 1 (sol1) node.

4 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 1 node.

5 Right-click Iterative 1 and choose Enable.

6 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 1>Iterative 1 node.

7 Right-click Incomplete LU and choose Enable.

8 On the Study toolbar, click Compute.

Parameter name Parameter value list Parameter unit

omega 0.1 0.5 0.9
14 |  R A D I A T I V E  H E A T  TR A N S F E R  I N  F I N I T E  C Y L I N D R I C A L  M E D I A



R E S U L T S

Incident Radiation (rpm)
The first default plot shows the incident radiation distribution in 3D and the second 
default plot represents the net radiative heat flux distribution in 3D, see figure below.

Add a new 1D Plot to represent the net radiative heat flux along the z-coordinate and 
compare with Figure 2.

1D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Net Radiative Heat Flux vs z, 
1D in the Label text field.

Line Graph 1
1 On the Net Radiative Heat Flux vs z, 1D toolbar, click Line Graph.

2 Click the Transparency button on the Graphics toolbar.

3 Select Edge 12 only.

4 Click the Transparency button on the Graphics toolbaragain to return to the original 
state.
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5 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Model>Component 1>Radiation in 

Participating Media>Boundary fluxes>rpm.qr_net - Net radiative heat flux.

6 Click Replace Expression in the upper-right corner of the x-axis data section. From the 
menu, choose Model>Component 1>Geometry>Coordinate>z - z-coordinate.

7 Click to expand the Legends section. Select the Show legends check box.

Finish the plot by adjusting the title and axis labels.

Net Radiative Heat Flux vs z, 1D
1 In the Model Builder window, under Results click Net Radiative Heat Flux vs z, 1D.

2 In the Settings window for 1D Plot Group, click to expand the Title section.

3 From the Title type list, choose None.

4 Locate the Plot Settings section. Select the x-axis label check box.

5 Select the y-axis label check box.

6 On the Net Radiative Heat Flux vs z, 1D toolbar, click Plot.

Cut Line 3D 1
1 On the Results toolbar, click Cut Line 3D.

2 In the Settings window for Cut Line 3D, locate the Line Data section.

3 In row Point 2, set x to 0 and z to L.
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4 Click Plot.

The Graphics window shows the location of the line in the model geometry.

Add a new 1D Plot to represent the incident radiation along the z-coordinate and compare 
with Figure 3.

1D Plot Group 4
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Incident Radiation vs z, 1D in 
the Label text field.

3 Locate the Data section. From the Data set list, choose Cut Line 3D 1.

Line Graph 1
1 On the Incident Radiation vs z, 1D toolbar, click Line Graph.

2 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the x-axis data section. From the menu, choose Model>Component 1>Geometry>

Coordinate>z - z-coordinate.

3 Locate the Legends section. Select the Show legends check box.

Incident Radiation vs z, 1D
1 In the Model Builder window, under Results click Incident Radiation vs z, 1D.

2 In the Settings window for 1D Plot Group, locate the Title section.

3 From the Title type list, choose None.
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4 Locate the Plot Settings section. Select the x-axis label check box.

5 Select the y-axis label check box.

6 On the Incident Radiation vs z, 1D toolbar, click Plot.

Cut Line 3D 2
1 On the Results toolbar, click Cut Line 3D.

2 In the Settings window for Cut Line 3D, locate the Line Data section.

3 In row Point 1, set z to L/2.

4 In row Point 2, set x to R and z to L/2.

5 Click Plot.

Add a new 1D Plot to represent the incident radiation along the x-coordinate and compare 
with Figure 4.

Incident Radiation vs z, 1D
Right-click Incident Radiation vs z, 1D and choose Duplicate.

Incident Radiation vs z, 1D 1
1 In the Settings window for 1D Plot Group, type Incident Radiation vs x, 1D in 

the Label text field.

2 Locate the Data section. From the Data set list, choose Cut Line 3D 2.

3 Locate the Plot Settings section. In the x-axis label text field, type x-coordinate (m).
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Line Graph 1
1 In the Model Builder window, expand the Results>Incident Radiation vs x, 1D node, then 

click Line Graph 1.

2 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the x-axis data section. From the menu, choose Model>Component 1>Geometry>

Coordinate>x - x-coordinate.

3 On the Incident Radiation vs x, 1D toolbar, click Plot.

Modeling Instructions—Case 1

R A D I A T I O N  I N  P A R T I C I P A T I N G  M E D I A  ( R P M )

Opaque Surface 2
1 On the Physics toolbar, click Boundaries and choose Opaque Surface.

2 In the Settings window for Opaque Surface, locate the Model Inputs section.

3 In the T text field, type Tw.

4 Select Boundaries 1, 2, 5, and 6 only.

These are the vertical wall boundaries. To reach all of them, you can rotate the geometry 
or click either the Transparency button or the Wireframe Rendering button on the 
Graphics toolbar.

5 Locate the Wall Settings section. From the ε list, choose User defined. In the associated 
text field, type ew*(1-y/R).

Now, disable Opaque Surface 2 in Study 1 to be able to re run the same Study 1 
configuration.

S T U D Y  1

Step 1: Stationary
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify physics tree and variables for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>Radiation in 

Participating Media (rpm)>Opaque Surface 2.

5 Click Disable.
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A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

S T U D Y  2

Step 1: Stationary
On the Home toolbar, click Add Study to close the Add Study window.

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

Solution 2 (sol2)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Study 2>Solver Configurations node.

3 In the Model Builder window, expand the Solution 2 (sol2) node, then click Dependent 

Variables 1.

4 In the Settings window for Dependent Variables, locate the General section.

5 From the Defined by study step list, choose User defined.

6 Locate the Initial Values of Variables Solved For section. From the Method list, choose 
Solution.

7 From the Solution list, choose Solution 1 (sol1).

8 In the Model Builder window, expand the Study 2>Solver Configurations>Solution 2 

(sol2)>Stationary Solver 1 node.

9 Right-click Iterative 1 and choose Enable.

10 In the Model Builder window, expand the Study 2>Solver Configurations>Solution 2 

(sol2)>Stationary Solver 1>Iterative 1 node.

11 Right-click Incomplete LU and choose Enable.

Parameter name Parameter value list Parameter unit

omega 0.1 0.5 0.9
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12 On the Study toolbar, click Compute.

R E S U L T S

Incident Radiation (rpm) 1
The first default plot shows the incident radiation distribution in 3D and the second 
default plot represents the net radiative heat flux distribution in 3D, see figure below.

Parameterized Curve 3D 1
1 On the Results toolbar, click More Data Sets and choose Parameterized Curve 3D.

2 In the Settings window for Parameterized Curve 3D, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (sol2).

4 Locate the Parameter section. In the Name text field, type phi.

5 In the Maximum text field, type 2*pi.

6 Locate the Expressions section. In the x text field, type R*cos(phi)/2.

7 In the y text field, type R*sin(phi)/2.

8 In the z text field, type L/2.
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9 Click Plot.

Add a new 1D Plot to represent the incident radiation in function of the azimuthal angle 
and compare with Figure 5.

1D Plot Group 8
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Incident Radiation vs Azimuthal 
Angle, 1D in the Label text field.

3 Locate the Data section. From the Data set list, choose Parameterized Curve 3D 1.

Line Graph 1
1 On the Incident Radiation vs Azimuthal Angle, 1D toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Legends section.

3 Select the Show legends check box.

Incident Radiation vs Azimuthal Angle, 1D
1 In the Model Builder window, under Results click Incident Radiation vs Azimuthal Angle, 

1D.

2 In the Settings window for 1D Plot Group, locate the Title section.

3 From the Title type list, choose None.

4 Locate the Plot Settings section. Select the x-axis label check box.

5 In the associated text field, type Azimuthal angle (rad).
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6 Select the y-axis label check box.

7 On the Incident Radiation vs Azimuthal Angle, 1D toolbar, click Plot.

Modeling Instructions—Case 2

G L O B A L  D E F I N I T I O N S

Parameters
For Case 2, you need to modify the value of the single-scattering albedo that you defined 
previously and add a parameter for the Legendre coefficient a1 in the scattering phase 
function.

1 In the Model Builder window, under Global Definitions click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

R A D I A T I O N  I N  P A R T I C I P A T I N G  M E D I A  ( R P M )

Radiation in Participating Media 1
1 In the Model Builder window, under Component 1 (comp1)>Radiation in Participating 

Media (rpm) click Radiation in Participating Media 1.

2 In the Settings window for Radiation in Participating Media, locate the Scattering 
section.

3 From the Scattering type list, choose Linear anisotropic.

4 In the a1 text field, type a1.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

Name Expression Value Description

omega 0.5 0.5 Single-scattering albedo

a1 0.99 0.99 Legendre coefficient
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S T U D Y  3

Step 1: Stationary
On the Home toolbar, click Add Study to close the Add Study window.

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

Note that the value a1 = 0 gives the same solution as for omega = 0.5 in Case 1.

Solution 3 (sol3)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Study 3>Solver Configurations node.

3 In the Model Builder window, expand the Solution 3 (sol3) node, then click Dependent 

Variables 1.

4 In the Settings window for Dependent Variables, locate the General section.

5 From the Defined by study step list, choose User defined.

6 Locate the Initial Values of Variables Solved For section. From the Method list, choose 
Solution.

7 From the Solution list, choose Solution 2 (sol2).

8 In the Model Builder window, expand the Study 3>Solver Configurations>Solution 3 

(sol3)>Stationary Solver 1 node.

9 Right-click Iterative 1 and choose Enable.

10 In the Model Builder window, expand the Study 3>Solver Configurations>Solution 3 

(sol3)>Stationary Solver 1>Iterative 1 node.

11 Right-click Incomplete LU and choose Enable.

12 On the Study toolbar, click Compute.

Parameter name Parameter value list Parameter unit

a1 -0.99 0 0.99
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R E S U L T S

Incident Radiation (rpm) 2
The first default plot shows the incident radiation distribution in 3D and the second 
default plot represents the net radiative heat flux distribution in 3D, see figure below.

Parameterized Curve 3D 2
1 On the Results toolbar, click More Data Sets and choose Parameterized Curve 3D.

2 In the Settings window for Parameterized Curve 3D, locate the Data section.

3 From the Data set list, choose Study 3/Solution 3 (sol3).

4 Locate the Expressions section. In the y text field, type -s*R.

5 In the z text field, type L/2.

With the above definition, s = −y/R equals the optical thickness along the negative 
y-axis for the given constant values of x and z.
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6 Click Plot.

Add a new 1D Plot to represent the incident radiation in function of the normalized 
optical thickness and compare with Figure 6.

1D Plot Group 11
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Incident Radiation vs 
Normalized Optical Thickness, 1D in the Label text field.

3 Locate the Data section. From the Data set list, choose Parameterized Curve 3D 2.

Line Graph 1
1 On the Incident Radiation vs Normalized Optical Thickness, 1D toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the x-Axis Data section.

3 From the Parameter list, choose Expression.

4 In the Expression text field, type s.

5 Locate the Legends section. Select the Show legends check box.

Incident Radiation vs Normalized Optical Thickness, 1D
1 In the Model Builder window, under Results click Incident Radiation vs Normalized Optical 

Thickness, 1D.

2 In the Settings window for 1D Plot Group, locate the Title section.

3 From the Title type list, choose None.
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4 Locate the Plot Settings section. Select the x-axis label check box.

5 In the associated text field, type Normalized optical thickness (y/R).

6 Select the y-axis label check box.

7 On the Incident Radiation vs Normalized Optical Thickness, 1D toolbar, click Plot.
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This application uses the P1 approximation to solve a 3D radiative transfer problem in an 
emitting, absorbing, and linearly anisotropic-scattering finite cylindrical medium. The 
calculated incident radiation and heat fluxes are compared to the results obtained with the 
highly accurate S6 discrete ordinates method (see Radiative Heat Transfer in Finite 
Cylindrical Media). The results obtained with this method show fairly good agreement 
with published results obtained by transformed integral methods (see Ref. 1) for optically 
thick media. 

Introduction

There are numerous engineering applications of radiative transfer in absorbing, emitting, 
and anisotropically scattering media with variable radiation properties. Examples include, 
among others, coal-fired combustion systems, light-weight fibrous insulations, and heat 
transfer systems containing small scattering particles. Furthermore, the efficiency of 
radiative transfer depends on the boundary conditions, for example, the temperature and 
the emissivity of the surrounding walls, and the target where heat transfer is desired. 
Studies have shown that radiative transfer is highly sensitive to the wall emissivity. In this 
study you build a validation model representing a cylinder with homogeneous walls. Then 
you go on to consider walls with space-dependent emissivity and investigate the effects of 
albedo and scattering.

Model Definition

In this tutorial you validate the P1 formulation in COMSOL Multiphysics by examining 
three benchmark cases. You investigate the method’s efficiency through parametric 
analyses by changing the single-scattering albedo, wall emissivity, and linear function. In 
particular, in the final case, you approximate the scattering phase function by a linear 
function reflecting highly backward, isotropic, and highly forward scattering. The results 
are compared to the results obtained with the DOM formulation as shown in Radiative 
Heat Transfer in Finite Cylindrical Media.

The model geometry, shown in Figure 1, is a cylinder of radius R = 0.5 m and height 
L = 1 m.
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Figure 1: Schematic diagram of the physical model.

These examples use the P1 approximation method for predicting the heat flux on the 
enclosure side walls and the incident radiation distribution inside the domain.

VE R I F I C A T I O N  C A S E

For the initial study, assume cold boundaries, that is, T = 0. Furthermore, assume that the 
walls diffusively reflect radiation, that is, ε = 0.5. The medium is at a uniform temperature 
T such that the blackbody radiation intensity Ib(T) = σT4 ⁄ π is equal to 1 W/m2.

WA L L S  W I T H  V A R I A B L E  E M I S S I V I T Y

Two cases are computed for comparison purposes. These 3D cases represent opaque 
partial side wall diffuse emission and/or reflection. In both cases, the radiosity on the side 
walls (Surface 3) varies with the angular coordinate along the full height of the finite 
cylinder according to ε3 = (1 − y ⁄ R) ⁄ 2. Both cases also have cold walls at the cylinder top 
(Surface 1) and bottom (Surface 2).

Surface 2

Surface 1
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Case 1 has isotropic scattering function and compares results for different albedos. Case 2 
has constant albedo and compares results with highly forward, isotropic, and highly 
backward scattering function parameterized by the Legendre coefficient a1.

T H E R M A L  A N A L Y S I S

The P1 approximation method is the simplest form of the method of spherical harmonics 
(PN) to describe radiative transport in participating media. The radiation transport 
equation (RTE) for this type of configuration can be written as

where

• I(Ω, s) is the radiation intensity at a given position s in the direction Ω

• T is the temperature

• κ, β, and σs are absorption, extinction, and scattering coefficients, respectively

• Ib(T) is the blackbody radiation intensity

• φ(Ω, Ω′) = 1 + a1μ0 where μ0 = Ω ⋅ Ω′ is the cosine of the scattering angle.

The RTE (an integro-partial differential equation) is transformed into a set of partial 
differential equations. The remaining task is to solve an additional equation for 

which adds a heat source/sink to account for radiative heat transfer.

where DP1 is a diffusion coefficient and Qr is the radiative heat source. The boundary 
condition for opaque surfaces then is

TABLE 1:  NONSTANDARD TEST CASES

CASE MEDIUM PROPERTIES)

1 albedo = 0.1, 0.5, 0.9

a1 = 0

2 albedo = 0.5

a1 = −0.99, 0, 0.99

Ω I Ω s,( )∇⋅ κIb T( ) βI Ω s,( )–
σs
4π
------ I Ω Ω′,( )φ Ω Ω′,( )∂Ω′

0

4π

+=

G I Ω( ) Ωd

0

4π

=

∇– DP1 G∇( )⋅ Qr=
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Results and Discussion

The results demonstrate that the P1 method provides a fast alternative to the DOM 
method. The solution time is only a few seconds whereas it is about 4 hours for the DOM 
method. The results represent the radiation characteristics well. The numerical values show 
good agreement for small scattering coefficients (omega) and high absorption coefficients 
(kappa). The relation between both values is κ = ω ⁄ (ω − 1).

VE R I F I C A T I O N  C A S E

This case examines the effects of the scattering albedo on the incident radiation and heat 
fluxes. Figure 2 shows the distribution of the net heat flux qr, net(R, 0, z) versus axial 
optical thickness. There is good agreement with the results obtained from the DOM 
model. The results for the net radiative heat flux (Figure 2) shows good agreement with 
distance to the top and bottom boundary. The relative error for small scattering albedo is 
below 10% and increases with increasing scattering albedo.

Figure 2: The effects of the scattering albedo on the radial heat flux qr, net(R, 0, z); for a hot 
cylindrical medium enclosed by cold walls, ε1 = ε2 = ε3 = 0.5.

n– DP1 G∇⋅ qr net,–=
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The effects of albedo on the distribution of centerline incident radiation in axial direction 
are shown in Figure 3. The incident radiation is symmetric with respect to z = L ⁄ 2 plane 
and decrease with increasing scattering albedo. Furthermore, results become more 
uniform with larger scattering albedo.

Figure 3: The effects of the scattering albedo on the distribution of centerline incident 
radiation G(0, 0, z) for a hot cylindrical medium enclosed by cold walls, ε1 = ε2 = ε3 = 0.5.

Figure 4 displays the distributions of the incident radiation across the mid-plane radius 
G(x, 0, L ⁄ 2) with respect to normalized optical thickness x ⁄ R.
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Figure 4: The effects of the scattering albedo on the distributions of the incident radiation G(x,
0, L ⁄ 2) with respect to normalized optical thickness x ⁄ R for a hot cylindrical medium 

enclosed by cold walls, ε1 = ε2 = ε3 = 0.5.

For the validation case the relative error compared to the DOM model is below 20%.

WA L L S  W I T H  V A R I A B L E  E M I S S I V I T Y

The incident radiation at the mid-plane z = L ⁄ 2 at the radial position R ⁄ 2 is shown in 
Figure 5. At the side surface R ⁄ 2 distance from the cylinder axis, G(R, 0, L ⁄ 2) changes 
with the azimuthal angle. The changes in scattering albedo are also illustrated. The 
smallest albedo makes the biggest change around the azimuthal angle. The numerical error 
for small scattering albedo again is low (around 10%).
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Figure 5: The effects of scattering albedo on the distribution of incident radiation at 
mid-plane z = L ⁄ 2 at R ⁄ 2 distance from the cylinder axis with respect to an azimuthal 
coordinate for Case 1.
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Figure 6 shows the effect of a nonzero linear anisotropic scattering coefficient a1. As 
expected, the differences between isotropic scattering, forward scattering, and backward 
scattering are most accentuated far from the boundary.

Figure 6: The effects of linear anisotropic scattering coefficient a1 on the distribution of 
incident radiation G(0, y, L ⁄ 2) with respect to normalized optical thickness − y ⁄ R for 
Case 2.

Unlike the discrete ordinates method, the P1 method is computationally inexpensive and 
gives fast results at the expense of accuracy in most cases. For large optical thickness the 
results show good agreement with the results obtained from the discrete ordinate method 
and hence with the results presented in the literature.
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Modeling Instructions—Validation Case

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Radiation>Radiation in Participating Media 

(rpm).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

G E O M E T R Y  1

Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type R.

4 In the Height text field, type L.

5 Click Build All Objects.

M A T E R I A L S

Add a material to specify the absorption and scattering coefficients inside the cylinder.

Material 1 (mat1)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Domain in the Label text field.

Name Expression Value Description

T0 (1[W/m^2]*pi/
sigma_const)^(1/4)

86.275 K Body temperature

Tw 0[K] 0 K Wall temperature

ew 0.5 0.5 Wall emissivity

omega 0.5 0.5 Single-scattering 
albedo

sigma_s omega 0.5 Scattering 
coefficient

kappa sigma_s*(1/omega-1) 0.5 Absorption 
coefficient

R 0.5[m] 0.5 m Cylinder radius

L 1[m] 1 m Cylinder length
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3 Locate the Material Contents section. In the table, enter the following settings:

Analogously, specify the emissivity of the walls using a material.

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Walls in the Label text field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose All boundaries.

5 Locate the Material Contents section. In the table, enter the following settings:

R A D I A T I O N  I N  P A R T I C I P A T I N G  M E D I A  ( R P M )

1 In the Model Builder window, under Component 1 (comp1) click Radiation in Participating 

Media (rpm).

2 In the Settings window for Radiation in Participating Media, locate the Participating 

Media Settings section.

3 From the Radiation discretization method list, choose P1 approximation.

Radiation in Participating Media 1
1 In the Model Builder window, under Component 1 (comp1)>Radiation in Participating 

Media (rpm) click Radiation in Participating Media 1.

2 In the Settings window for Radiation in Participating Media, locate the Model Inputs 
section.

3 In the T text field, type T0.

Opaque Surface 1
1 In the Model Builder window, under Component 1 (comp1)>Radiation in Participating 

Media (rpm) click Opaque Surface 1.

2 In the Settings window for Opaque Surface, locate the Model Inputs section.

Property Name Value Unit Property 
group

Absorption coefficient kappaR kappa 1/m Basic

Scattering coefficient sigmaS sigma_s 1/m Basic

Property Name Value Unit Property group

Surface emissivity epsilon_rad ew 1 Basic
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3 In the T text field, type Tw.

S T U D Y  1

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

5 On the Study toolbar, click Compute.

R E S U L T S

Incident Radiation (rpm)
The first default plot shows the incident radiation distribution in 3D and the second 
default plot represents the net radiative heat flux distribution in 3D, see figure below.

Parameter name Parameter value list Parameter unit

omega 0.1 0.5 0.9
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Add a new 1D Plot to represent the net radiative heat flux along the z-coordinate and 
compare with Figure 2.

1D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Net Radiative Heat Flux vs z, 
1D in the Label text field.

Line Graph 1
1 On the Net Radiative Heat Flux vs z, 1D toolbar, click Line Graph.

2 Click the Transparency button on the Graphics toolbar.

3 Select Edge 12 only.

4 Click the Transparency button on the Graphics toolbaragain to return to the original 
state.

5 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Model>Component 1>Radiation in 

Participating Media>Boundary fluxes>rpm.qr_net - Net radiative heat flux.

6 Click Replace Expression in the upper-right corner of the x-axis data section. From the 
menu, choose Model>Component 1>Geometry>Coordinate>z - z-coordinate.

7 Click to expand the Legends section. Select the Show legends check box.

Finish the plot by adjusting the title and axis labels.

Net Radiative Heat Flux vs z, 1D
1 In the Model Builder window, under Results click Net Radiative Heat Flux vs z, 1D.

2 In the Settings window for 1D Plot Group, click to expand the Title section.

3 From the Title type list, choose None.

4 Locate the Plot Settings section. Select the x-axis label check box.

5 Select the y-axis label check box.

6 On the Net Radiative Heat Flux vs z, 1D toolbar, click Plot.

Cut Line 3D 1
1 On the Results toolbar, click Cut Line 3D.

2 In the Settings window for Cut Line 3D, locate the Line Data section.

3 In row Point 2, set x to 0, and z to L.
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4 Click Plot.

The Graphics window shows the location of the line in the model geometry.

Add a new 1D Plot to represent the incident radiation along the z-coordinate and 
compare with Figure 3.

1D Plot Group 4
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Incident Radiation vs z, 1D in 
the Label text field.

3 Locate the Data section. From the Data set list, choose Cut Line 3D 1.

Line Graph 1
1 On the Incident Radiation vs z, 1D toolbar, click Line Graph.

2 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the x-axis data section. From the menu, choose Model>Component 1>Geometry>

Coordinate>z - z-coordinate.

3 Locate the Legends section. Select the Show legends check box.

Incident Radiation vs z, 1D
1 In the Model Builder window, under Results click Incident Radiation vs z, 1D.

2 In the Settings window for 1D Plot Group, locate the Title section.

3 From the Title type list, choose None.
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4 Locate the Plot Settings section. Select the x-axis label check box.

5 Select the y-axis label check box.

6 On the Incident Radiation vs z, 1D toolbar, click Plot.

Cut Line 3D 2
1 On the Results toolbar, click Cut Line 3D.

2 In the Settings window for Cut Line 3D, locate the Line Data section.

3 In row Point 1, set z to L/2.

4 In row Point 2, set x to R, and z to L/2.

5 Click Plot.

Add a new 1D Plot to represent the incident radiation along the x-coordinate and compare 
with Figure 4.

Incident Radiation vs z, 1D
Right-click Incident Radiation vs z, 1D and choose Duplicate.

Incident Radiation vs z, 1D 1
1 In the Settings window for 1D Plot Group, type Incident Radiation vs x, 1D in 

the Label text field.

2 Locate the Data section. From the Data set list, choose Cut Line 3D 2.

3 Locate the Plot Settings section. In the x-axis label text field, type x-coordinate (m).
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Line Graph 1
1 In the Model Builder window, expand the Results>Incident Radiation vs x, 1D node, then 

click Line Graph 1.

2 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the x-axis data section. From the menu, choose Model>Component 1>Geometry>

Coordinate>x - x-coordinate.

3 On the Incident Radiation vs x, 1D toolbar, click Plot.

Modeling Instructions—Case 1

R A D I A T I O N  I N  P A R T I C I P A T I N G  M E D I A  ( R P M )

Opaque Surface 2
1 On the Physics toolbar, click Boundaries and choose Opaque Surface.

2 In the Settings window for Opaque Surface, locate the Model Inputs section.

3 In the T text field, type Tw.

4 Select Boundaries 1, 2, 5, and 6 only.

These are the vertical wall boundaries. To reach all of them, you can rotate the geometry 
or click either the Transparency button or the Wireframe Rendering button on the 
Graphics toolbar.

5 Locate the Wall Settings section. From the ε list, choose User defined. In the associated 
text field, type ew*(1-y/R).

Now, disable Opaque Surface 2 in Study 1 to be able to re run the same Study 1 
configuration.

S T U D Y  1

Step 1: Stationary
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify physics tree and variables for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>Radiation in 

Participating Media (rpm)>Opaque Surface 2.

5 Click Disable.
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A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

S T U D Y  2

Step 1: Stationary
On the Home toolbar, click Add Study to close the Add Study window.

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

5 On the Study toolbar, click Compute.

Parameter name Parameter value list Parameter unit

omega 0.1 0.5 0.9
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R E S U L T S

Incident Radiation (rpm) 1
The first default plot shows the incident radiation distribution in 3D and the second 
default plot represents the net radiative heat flux distribution in 3D, see figure below.

Parameterized Curve 3D 1
1 On the Results toolbar, click More Data Sets and choose Parameterized Curve 3D.

2 In the Settings window for Parameterized Curve 3D, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (sol2).

4 Locate the Parameter section. In the Name text field, type phi.

5 In the Maximum text field, type 2*pi.

6 Locate the Expressions section. In the x text field, type R*cos(phi)/2.

7 In the y text field, type R*sin(phi)/2.

8 In the z text field, type L/2.
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9 Click Plot.

Add a new 1D Plot to represent the incident radiation in function of the azimuthal angle 
and compare with Figure 5.

1D Plot Group 8
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Incident Radiation vs Azimuthal 
Angle, 1D in the Label text field.

3 Locate the Data section. From the Data set list, choose Parameterized Curve 3D 1.

Line Graph 1
1 On the Incident Radiation vs Azimuthal Angle, 1D toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Legends section.

3 Select the Show legends check box.

Incident Radiation vs Azimuthal Angle, 1D
1 In the Model Builder window, under Results click Incident Radiation vs Azimuthal Angle, 

1D.

2 In the Settings window for 1D Plot Group, locate the Title section.

3 From the Title type list, choose None.

4 Locate the Plot Settings section. Select the x-axis label check box.

5 In the associated text field, type Azimuthal angle (rad).
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6 Select the y-axis label check box.

7 On the Incident Radiation vs Azimuthal Angle, 1D toolbar, click Plot.

Modeling Instructions—Case 2

G L O B A L  D E F I N I T I O N S

Parameters
For case 2, you need to add a parameter for the Legendre coefficient a1 in the scattering 
phase function.

1 In the Model Builder window, under Global Definitions click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

R A D I A T I O N  I N  P A R T I C I P A T I N G  M E D I A  ( R P M )

Add a new Radiation in Participating Media node for Study 3 only.

Radiation in Participating Media 2
1 On the Physics toolbar, click Domains and choose Radiation in Participating Media.

2 In the Settings window for Radiation in Participating Media, locate the Model Inputs 
section.

3 In the T text field, type T0.

4 Locate the Scattering section. From the Scattering type list, choose Linear anisotropic.

5 In the a1 text field, type a1.

S T U D Y  1

Step 1: Stationary
Now, disable Radiation in Participating Media 2 in Study 1 and Study 2 to be able to re run 
the same configurations for these studies.

1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

Name Expression Value Description

a1 0.99 0.99 Legendre coefficient
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3 In the Physics and variables selection tree, select Component 1 (comp1)>Radiation in 

Participating Media (rpm)>Radiation in Participating Media 2.

4 Click Disable.

S T U D Y  2

Step 1: Stationary
1 In the Model Builder window, under Study 2 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify physics tree and variables for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>Radiation in 

Participating Media (rpm)>Radiation in Participating Media 2.

5 Click Disable.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

S T U D Y  3

Step 1: Stationary
On the Home toolbar, click Add Study to close the Add Study window.

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

Note that the value a1 = 0 gives the same solution as for omega = 0.5 in case 1.

5 On the Study toolbar, click Compute.

Parameter name Parameter value list Parameter unit

a1 -0.99 0 0.99
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R E S U L T S

Incident Radiation (rpm) 2
The first default plot shows the incident radiation distribution in 3D and the second 
default plot represents the net radiative heat flux distribution in 3D, see figure below.

Parameterized Curve 3D 2
1 On the Results toolbar, click More Data Sets and choose Parameterized Curve 3D.

2 In the Settings window for Parameterized Curve 3D, locate the Data section.

3 From the Data set list, choose Study 3/Solution 3 (sol3).

4 Locate the Expressions section. In the y text field, type -s*R.

5 In the z text field, type L/2.

With the above definition, s = −y/R equals the optical thickness along the negative 
y-axis for the given constant values of x and z.
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6 Click Plot.

Add a new 1D Plot to represent the incident radiation as function of the normalized 
optical thickness and compare with Figure 6.

1D Plot Group 11
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Incident Radiation vs 
Normalized Optical Thickness, 1D in the Label text field.

3 Locate the Data section. From the Data set list, choose Parameterized Curve 3D 2.

Line Graph 1
1 On the Incident Radiation vs Normalized Optical Thickness, 1D toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the x-Axis Data section.

3 From the Parameter list, choose Expression.

4 In the Expression text field, type s.

5 Locate the Legends section. Select the Show legends check box.

Incident Radiation vs Normalized Optical Thickness, 1D
1 In the Model Builder window, under Results click Incident Radiation vs Normalized Optical 

Thickness, 1D.

2 In the Settings window for 1D Plot Group, locate the Title section.

3 From the Title type list, choose None.
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4 Locate the Plot Settings section. Select the x-axis label check box.

5 In the associated text field, type Normalized optical thickness (y/R).

6 Select the y-axis label check box.

7 On the Incident Radiation vs Normalized Optical Thickness, 1D toolbar, click Plot.
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Introduction

This example studies the cooling effects of a disk-stack heat sink on an electronic 
component. The heat sink shape (see Figure 1) shows several thin aluminum disks piled 
up around a central hollow column. Such a configuration allows cooling of large surfaces 
of aluminum fins by air at ambient temperature.

Figure 1: Steady-state surface temperature distribution of the electronic device.

To evaluate the efficiency of the heat sink, this tutorial follows a typical preliminary 
board-level thermal analysis. First, a simulation of the board with some Integrated Circuits 
(ICs) is performed. Then, the disk-stack heat sink is added above the main hot electronic 
component to observe cooling effects. The final part adds a copper layer to the bottom of 
the board in order to obtain a more uniform temperature distribution and see how it 
affects the heat transfer in the circuit board.

This exercise highlights a number of important modeling techniques such as combining 
3D solids and shells and using thin layer boundary conditions when replacing 3D thin 
geometries by 2D boundaries.
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Model Definition

G E O M E T R Y

Figure 2 shows that the first studied geometry is made of a circuit board with several ICs 
on it.

Figure 2: First geometry without heat sink.

This typical board-level thermal analysis determines the temperature profile in and around 
a high-power chip. The printed-circuit board usually consists of multiple layers of FR4 
material (Flame Resistant 4) and copper traces along the board. Hence, the thermal 
conductivity along the board is much higher than the conductivity through it. It is possible 
to take several approaches for simulating such a board in COMSOL Multiphysics. This 
example uses a macro-level approach and assumes a homogeneous PC board with 
anisotropic thermal material properties. In this case, the heat diffusion through the board 
and the one lost due to natural convection is insufficient to adequately cool the chip. 
Hence, a disk-stack heat sink is required to increase the effective cooling area for the chip.
3 |  D I S K - S T A C K  H E A T  S I N K



R E G A R D I N G  M A T E R I A L S

The IC packages and the PC board on which they are mounted must be defined. In reality, 
these components have very detailed structures and are made of a variety of materials. For 
a board-level analysis such as the present one, though, it is much simpler to lump all these 
detailed structures into single homogeneous materials for each component, instead of 
accounting for the thermal characteristics of a multi-layer PC board, which typically consist 
of multiple layers of FR4 (insulator) interspersed with layers of copper traces. The thermal 
result of this construction is that the thermal conductivity along the board is considerably 
higher than through it. Physical property values depend on the number of layers, how 
dense the lines are, and how many vias (interconnections between layers) per unit area are 
present. The numbers in an estimate for a highly layered board which are used to create a 
strong difference in conductivity between the printed-circuit board plane (x, y) and the 
orthogonal direction z. Those properties are presented in Table 1. The units are W/(m·K) 
for thermal conductivity, kg/m3 for density and J/(kg·K) for heat capacity.

T H E R M A L  C O N F I G U R A T I O N

In this problem the large central chip dissipates 20 W, the array of smaller chips are 1 W 
each, and the two elongated chips are 2 W each. The volumetric heat source is calculated 
by dividing the heat power by the volume of the considered IC.

In this example, you assume that a fan cools the board, and specify a convective heat 
transfer coefficient for the boundary heat flux. Here, you look for a preliminary sizing 
calculation and simply assume a convective coefficient, h, of 20 W/(m2·K). This 
corresponds to a fan blowing air at approximately 1 m/s on a plate. The air temperature 
is set to T0 = 273.15 K during the whole modeling process.

Without a heat sink, the temperature rise in the main chip is higher than the maximum 
operating temperature. A stacked disk heat sink increases the effective area and therefore 
cools the chip further. This heat sink consists of a series of thin disks supported by a central 
hollow column that is mounted to the chip with an aluminum base corresponding to the 
size of the chip. The heat sink is mounted dry and must therefore account for contact 

TABLE 1:  MATERIALS PROPERTIES

MATERIALS CONDUCTIVITY DENSITY HEAT CAPACITY

Copper 400 8700 385

FR-4 0.3 1900 1369

Aluminum 160 2700 900

IC Packages (Silica Glass) 1.38 2203 703

PC Board (x, y and z directions) {80, 80, 0.3} 1900 1369
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resistance. Figure 3 shows the new geometry with the main chip equipped with the heat 
sink.

Figure 3: Full geometry of the PC board equipped with the heat sink.

Thermal linkage between the IC and the added heat sink is made using the Thermal Contact 
boundary condition. It provides a heat transfer coefficient at the two surfaces in contact 
according to (1.9 in Ref. 1):

This expression involves two parameters related to the surface microscopic asperities: σ, 
the average asperities height, and m, the average asperities slope. In this case, σ and m are 
set to 1 μm and 0.5, respectively. The microhardness of the softer material, Hc, is here the 
hardness of aluminum, equal to 165 MPa. The contact pressure, p, is set to 20 kPa. The 
thermal conductivity kgap is related to the material in the interstitial gap, here assumed to 
be air at atmospheric pressure. It is equal to 0.025 W/(m·K).

A design value of 0.3 mm is chosen for the thickness of the fins and the central hollow 
column.

hinterface hconstriction hgap 1.25ks
m
σ
----- p

Hc
------- 
  0.95 kgap

Y Mgap+
------------------------+=+=
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Finally, the last part explores the possibility of evening out the temperature distribution 
across the PC board. For instance, add a 0.4 mm layer of copper across the board entire 
bottom surface. The previous cross section does not suggest much success for this 
approach. However, it is interesting to check such an analysis for the sake of comparison. 
In COMSOL Multiphysics, this is easily done using the Thin Layer boundary condition.

Results and Discussion

Figure 4 shows the stationary temperature field on the surfaces of the board and chips in 
Kelvin: the central IC becomes rather hot (337 K) and needs extra cooling.

Figure 4: Temperature distribution of the PC board without the heat sink.

As Figure 5 shows, there is a steep thermal gradient between the IC and the heat sink base 
which is caused by the contact resistance and the significant cooling by the heat sink fins. 
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The maximum device temperature has now dropped to 313 K, which is 24 K lower than 
without the heat sink.

Figure 5: Temperature distribution of the PC board with its heat sink.
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Finally, Figure 6 shows that adding a layer of copper at the bottom of the Circuit Board is 
ineffective. This phenomenon agrees with the fact that the Circuit Board material has a 
rather poor thermal conductivity along the vertical z-axis (orthogonal to the PC plane).

Figure 6: Temperature distribution of the PC board with its heat sink and a layer of copper at 
bottom 

Notes About the COMSOL Implementation

In this application, use the Heat Transfer in Thin Shells interface to model thermal 
behavior of fins. The number of elements is significantly reduced because, instead of 
creating a thin 3D geometry, only a 2D layer is meshed.

References

1. A.D. Kraus and A. Bejan, Heat Transfer Handbook, John Wiley & Sons, 2003.

Application Library path: Heat_Transfer_Module/
Thermal_Contact_and_Friction/disk_stack_heat_sink
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
disk_stack_heat_sink_parameters.txt.

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type CB_w.

4 In the Depth text field, type CB_l.

5 In the Height text field, type CB_t.

6 Locate the Position section. In the x text field, type -CB_w/2.
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7 In the y text field, type -CB_l/2.

8 In the z text field, type -CB_t.

Block 2 (blk2)
1 Right-click Block 1 (blk1) and choose Build Selected.

2 On the Geometry toolbar, click Block.

3 In the Settings window for Block, locate the Size and Shape section.

4 In the Width text field, type IC1_w.

5 In the Depth text field, type IC1_l.

6 In the Height text field, type IC1_t.

7 Locate the Position section. In the x text field, type -CB_w/2+IC1_w.

8 In the y text field, type -CB_l/2+IC1_l.

Block 3 (blk3)
1 Right-click Block 2 (blk2) and choose Build Selected.

2 On the Geometry toolbar, click Block.

3 In the Settings window for Block, locate the Size and Shape section.

4 In the Width text field, type IC2_l.

5 In the Depth text field, type IC2_w.

6 In the Height text field, type IC2_t.

7 Locate the Position section. In the x text field, type -60.

8 In the y text field, type -60.

Copy 1 (copy1)
1 Right-click Block 3 (blk3) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Copy.

3 Select the object blk3 only.

4 In the Settings window for Copy, locate the Displacement section.

5 In the x text field, type 0 0 0 0 range(30,30,60) 30.

6 In the y text field, type range(25, 25, 100) 0 0 100.

Block 4 (blk4)
1 Right-click Copy 1 (copy1) and choose Build Selected.

2 On the Geometry toolbar, click Block.

3 In the Settings window for Block, locate the Size and Shape section.
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4 In the Width text field, type IC3_w.

5 In the Depth text field, type IC3_l.

6 In the Height text field, type IC3_t.

7 Locate the Position section. In the x text field, type 40.

8 In the y text field, type -50.

Copy 2 (copy2)
1 Right-click Block 4 (blk4) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Copy.

3 Select the object blk4 only.

4 In the Settings window for Copy, locate the Displacement section.

5 In the y text field, type 50.

6 Click Build All Objects.

D E F I N I T I O N S

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type ICs, Type 1 in the Label text field.

3 Select Domain 9 only.

Explicit 2
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type ICs, Type 2 in the Label text field.

3 Select Domains 2–8 and 10 only.

Explicit 3
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type ICs, Type 3 in the Label text field.

3 Select Domains 11 and 12 only.

Union 1
1 On the Definitions toolbar, click Union.

2 In the Settings window for Union, type ICs in the Label text field.

3 Locate the Input Entities section. Under Selections to add, click Add.

4 In the Add dialog box, select ICs, Type 1 in the Selections to add list.
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5 Click OK.

6 In the Settings window for Union, locate the Input Entities section.

7 Under Selections to add, click Add.

8 In the Add dialog box, select ICs, Type 2 in the Selections to add list.

9 Click OK.

10 In the Settings window for Union, locate the Input Entities section.

11 Under Selections to add, click Add.

12 In the Add dialog box, select ICs, Type 3 in the Selections to add list.

13 Click OK.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Silica glass.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Silica glass (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Silica glass 

(mat1).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose ICs.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>FR4 (Circuit Board).

3 Click Add to Component in the window toolbar.

M A T E R I A L S

FR4 (Circuit Board) (mat2)
1 On the Home toolbar, click Add Material to close the Add Material window.

2 In the Model Builder window, under Component 1 (comp1)>Materials click FR4 (Circuit 

Board) (mat2).
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3 Select Domain 1 only.

Here, the PC board needs to have an orthotropic thermal conductivity to account for 
conduction induced by several copper tracks in the xy-planes of the board.

4 In the Settings window for Material, locate the Material Contents section.

5 In the table, enter the following settings:

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, type T0 in the T text field.

Heat Source 1
1 On the Physics toolbar, click Domains and choose Heat Source.

2 In the Settings window for Heat Source, locate the Domain Selection section.

3 From the Selection list, choose ICs, Type 1.

4 Locate the Heat Source section. Click the Heat rate button.

5 In the P0 text field, type P1.

Heat Source 2
1 On the Physics toolbar, click Domains and choose Heat Source.

2 In the Settings window for Heat Source, locate the Domain Selection section.

3 From the Selection list, choose ICs, Type 2.

4 Locate the Heat Source section. Click the Heat rate button.

5 In the P0 text field, type P2*8.

Heat Source 3
1 On the Physics toolbar, click Domains and choose Heat Source.

2 In the Settings window for Heat Source, locate the Domain Selection section.

3 From the Selection list, choose ICs, Type 3.

4 Locate the Heat Source section. Click the Heat rate button.

Property Name Value Unit Property 
group

Thermal conductivity k {80,80,
0.3}

W/(m·K) Basic
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5 In the P0 text field, type P3*2.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Heat Flux section.

3 Click the Convective heat flux button.

4 In the h text field, type htc.

5 In the Text text field, type T0.

In the followings, select boundaries 1 to 72. For more convenience, use the Paste 

Selection button.

6 Locate the Boundary Selection section. Click Paste Selection.

7 In the Paste Selection dialog box, type 1-72 in the Selection text field.

8 Click OK.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
This is the first temperature distribution. It clearly outlines that the main chip needs more 
efficient cooling. This is the aim of the next part in which a disk-stack heat sink will be 
added on the top of the central chip.

G E O M E T R Y  1

Block 5 (blk5)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type IC1_w.

4 In the Depth text field, type IC1_l.

5 In the Height text field, type IC1_t.

6 Locate the Position section. In the x text field, type -CB_w/2+IC1_w.

7 In the y text field, type -CB_l/2+IC1_l.

8 In the z text field, type IC1_t.
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Cylinder 1 (cyl1)
1 Right-click Block 5 (blk5) and choose Build Selected.

2 On the Geometry toolbar, click Cylinder.

3 In the Settings window for Cylinder, locate the Object Type section.

4 From the Type list, choose Surface.

5 Locate the Size and Shape section. In the Radius text field, type i_radius.

6 In the Height text field, type t_h.

7 Locate the Position section. In the z text field, type IC1_t*2.

8 Locate the Selections of Resulting Entities section. Click New.

9 In the New Cumulative Selection dialog box, type Fins in the Name text field.

10 Click OK.

Work Plane 1 (wp1)
1 Right-click Cylinder 1 (cyl1) and choose Build Selected.

2 On the Geometry toolbar, click Work Plane.

3 In the Settings window for Work Plane, locate the Plane Definition section.

4 From the Plane type list, choose Face parallel.

5 On the object blk5, select Boundary 4 only.

6 In the Offset in normal direction text field, type air_sp.

7 Click Show Work Plane.

Circle 1 (c1)
1 On the Work Plane toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type i_radius.

4 Right-click Circle 1 (c1) and choose Build Selected.

5 Click the Zoom Extents button on the Graphics toolbar.

Circle 2 (c2)
1 On the Work Plane toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type o_radius.

4 Right-click Circle 2 (c2) and choose Build Selected.

5 Click the Zoom Extents button on the Graphics toolbar.
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Difference 1 (dif1)
1 On the Work Plane toolbar, click Booleans and Partitions and choose Difference.

2 Select the object c2 only.

3 In the Settings window for Difference, locate the Difference section.

4 Find the Objects to subtract subsection. Select the Active toggle button.

5 Select the object c1 only.

Work Plane 1 (wp1)
1 Right-click Difference 1 (dif1) and choose Build Selected.

2 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Work Plane 

1 (wp1).

3 In the Settings window for Work Plane, locate the Selections of Resulting Entities section.

4 From the Contribute to list, choose Fins.

5 In the Model Builder window, expand the Work Plane 1 (wp1) node.

Array 1 (arr1)
1 Right-click Component 1 (comp1)>Geometry 1>Work Plane 1 (wp1) and choose Build 

Selected.

2 On the Geometry toolbar, click Transforms and choose Array.

3 Select the object wp1 only.

4 In the Settings window for Array, locate the Size section.

5 From the Array type list, choose Linear.

6 In the Size text field, type n_fins.

7 Locate the Displacement section. In the z text field, type air_sp.

Work Plane 1 (wp1)
1 In the Settings window for Array, locate the Selections of Resulting Entities section.

2 From the Contribute to list, choose Fins.

3 Click Build All Objects.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Aluminum.

4 Click Add to Component in the window toolbar.
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M A T E R I A L S

Aluminum (mat3)
1 In the Model Builder window, expand the Component 1 (comp1)>Geometry 1>Work Plane 

1 (wp1) node, then click Component 1 (comp1)>Materials>Aluminum (mat3).

2 Select Domain 10 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Aluminum.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Aluminum 1 (mat4)
1 On the Home toolbar, click Add Material to close the Add Material window.

2 In the Model Builder window, under Component 1 (comp1)>Materials click Aluminum 1 

(mat4).

3 In the Settings window for Material, locate the Geometric Entity Selection section.

4 From the Geometric entity level list, choose Boundary.

5 From the Selection list, choose Fins.

It is necessary to add a second Aluminum material since the first one is used on a different 
geometry entity level.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Heat Flux 1
Add the newly created external boundaries of the heat sink base.

1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 
click Heat Flux 1.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 Click Paste Selection.

4 In the Paste Selection dialog box, type 49 50 52 64 115 in the Selection text field.

5 Click OK.

Thermal Contact 1
1 On the Physics toolbar, click Boundaries and choose Thermal Contact.
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2 In the Settings window for Thermal Contact, locate the Boundary Selection section.

3 Click Paste Selection.

4 In the Paste Selection dialog box, type 51 in the Selection text field.

5 Click OK.

6 In the Settings window for Thermal Contact, locate the Thermal Contact section.

7 From the hg list, choose Parallel-plate gap gas conductance.

8 Locate the Contact Surface Properties section. In the p text field, type 20[kPa].

9 In the Hc text field, type 165[MPa].

10 Click to expand the Gap properties section. Locate the Gap Properties section. From the 
kgap list, choose User defined.

A D D  P H Y S I C S

1 On the Physics toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Heat Transfer>Thin Structures>Heat Transfer in Thin Shells (htsh).

4 Click to expand the Dependent variables section. Locate the Dependent Variables section. 
In the Temperature text field, type T.

A new physics interface is required here to take into account out-of-plane convective 
cooling. In the physics interface selection, you have to use the same temperature 
variable, T, to couple the two physics interfaces.

5 Click Add to Component in the window toolbar.

H E A T  TR A N S F E R  I N  T H I N  S H E L L S  ( H T S H )

1 On the Physics toolbar, click Add Physics to close the Add Physics window.

2 In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Thin 

Shells (htsh).

3 In the Settings window for Heat Transfer in Thin Shells, locate the Boundary Selection 
section.

4 From the Selection list, choose Fins.

5 Locate the Shell Thickness section. In the ds text field, type e_fins.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Thin Shells 

(htsh) click Initial Values 1.

2 In the Settings window for Initial Values, type T0 in the T text field.
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Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Fins.

4 Locate the Upside Inward Heat Flux section. Click the Convective heat flux button.

5 In the hu text field, type htc.

6 In the Text, u text field, type T0.

7 Locate the Downside Inward Heat Flux section. Click the Convective heat flux button.

8 In the hd text field, type htc.

9 In the Text, d text field, type T0.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
This is the temperature profile once the heat sink has been added. The heat sink 
significantly reduces the average temperature of the main chip.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Copper.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Copper (mat5)
1 On the Home toolbar, click Add Material to close the Add Material window.

2 In the Model Builder window, under Component 1 (comp1)>Materials click Copper (mat5).

3 Select Domain 1 only.

4 In the Settings window for Material, locate the Geometric Entity Selection section.

5 From the Geometric entity level list, choose Boundary.

6 Select Boundary 3 only.
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H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

On the Physics toolbar, click Heat Transfer in Thin Shells (htsh) and choose Heat Transfer in 

Solids (ht).

In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids (ht).

Thin Layer 1
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 Select Boundary 3 only.

3 In the Settings window for Thin Layer, locate the Thin Layer section.

4 From the Layer type list, choose Thermally thin approximation.

5 In the ds text field, type 0.4[mm].

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
This is the temperature profile once the copper layer has been added. No significant effect 
due to this modification can be observed.

Derived Values
Finally, check the maximum temperature over the component.

Volume Maximum 1
1 On the Results toolbar, click More Derived Values and choose Maximum>Volume 

Maximum.

2 In the Settings window for Volume Maximum, type Maximum Temperature in the Label 
text field.

3 Locate the Selection section. From the Selection list, choose All domains.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Expression Unit Description

T K Maximum temperature
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Introduction

This study simulates the thermal behavior of a computer power supply unit (PSU). Such 
electronic enclosures typically include cooling devices to avoid electronic components 
being damaged by excessively high temperatures. In this application, an extracting fan and 
a perforated grille generate an air flow in the enclosure to cool internal heating.

Air extracted from the enclosure is related to the static pressure (the pressure difference 
between outside and inside), information that is generally provided by the fan 
manufacturers as a curve representing fluid velocity as a function of pressure difference.

As shown in Figure 1, the geometry is rather complicated and requires a fine mesh to 
solve. This results in large computational costs in terms of time and memory.

Figure 1: The complete model geometry.

Model Definition

Figure 1 shows the geometry of the PSU. It is composed of a perforated enclosure of 
14 cm-by-15 cm-by-8.6 cm and is made of aluminum 6063-T83. Inside the enclosure, 
only obstacles having a characteristic length of at least 5 mm are represented.
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The bottom of the box represents the printed circuit board (PCB). It has an anisotropic 
thermal conductivity of 10, 10, and 0.36 W/(m·K) along the x-, y-, and z-axes, 
respectively. Its density is 430 kg/m3 and its heat capacity at constant pressure is 1100 J/
(kg·K). Because the thermal conductivity along the z-axis is relatively low, and that the 
PCB and the enclosure sides are separated by a thin air layer, it is not necessary to model 
the bottom wall, nor take into account the cooling on these sides.

The capacitors are approximated by aluminum components. The heat sink fins and the 
enclosure are made of the same aluminum alloy. The inductors are mainly composed of 
steel cores and copper coils. The transformers are made of three materials: copper, steel, 
and plastic. The transistors are modeled as two-domain components: a core made of silicon 
held in a plastic case. The core is in contact with an aluminum heat sink to allow a more 
efficient heat transfer. Air speed is assumed to be slow enough for the flow to be considered 
as laminar.

The simulated PSU consumes a maximum of 230 W. Components have been grouped and 
assigned to various heat sources as listed in Table 1. The overall heat loss is 41 W, which 
is about 82% of efficiency.

The inlet air temperature is set at 30 °C because it is supposed to come from the computer 
case in which air has already cooled other components. The inlet boundary is configured 
with a Grille boundary condition. This pressure must describe head loss caused by air entry 
into the enclosure. The head loss coefficient kgrille is represented by the following 6th 
order polynomial (Ref. 1):

 (1)

TABLE 1:  HEAT SOURCES OF ELECTRONIC COMPONENTS

Components Dissipated heat rate (W)

Transistor cores 25

Large transformer coil 5

Small transformer coils 3

Inductors 2

Large capacitors 2

Medium capacitors 3

Small capacitors 1

kgrille 12084α6 42281α5
– 60989α4 46559α3

–

19963α2 4618.5α– 462.89

+

+ +

=
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where α is the opening ratio of the grille.

Figure 2: Head loss coefficient as a function of the opening ratio.

The head loss, ΔP (Pa), is given by

where ρ is the density (kg/m3), and U is the velocity magnitude (m/s).

The box, the PCB, the inductor surfaces, and the heat sink fins are configured as thin 
conductive layers.

PΔ kgrille
ρU2

2
-----------=
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Results and Discussion

The most interesting aspect of this simulation is to locate which components are subject 
to overheating. Figure 3 clearly shows that the temperature distribution is not 
homogeneous.

Figure 3: Temperature and fluid velocity fields.

The maximum temperature is about 70 °C and is located at one of the transistor cores. 
The components furthest away from the air inlet are subject to the highest temperature. 
Although transistor cores are rather hot, Figure 3 shows that they are significantly cooled 
by the aluminum heat sinks. The printed circuit board has a significant impact as well by 
distributing and draining heat off.

On the flow side, air avoids obstacles and tends to go through the upper space of the 
enclosure. The maximum velocity is about 1.6 m/s.
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Figure 4 shows the head loss created by obstacles encountered by air on its path.

Figure 4: Pressure isosurfaces show the head loss created by electronic components.

As shown in Figure 4, the fluid flow is impacted by obstacles and yields to local head losses.

Notes About the COMSOL Implementation

To model heat sink fins, enclosure walls and circuit board it is strongly recommended to 
use the Thin Layer feature, which is completely adapted for thin geometries and 
significantly reduces the number of degrees of freedom in the model.

COMSOL Multiphysics provides a useful boundary condition for modeling fan behavior. 
You just need to provide a few points of a static pressure curve to configure this boundary 
condition. These data are, most of the time, provided by fan manufacturers.

Reference

1. R.D. Blevins, Applied Fluid Dynamics Handbook, Van Nostrand Reinhold, 1984.
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Application Library path: Heat_Transfer_Module/
Power_Electronics_and_Electronic_Cooling/electronic_enclosure_cooling

Modeling Instructions

R O O T

The file electronic_enclosure_cooling_geom.mph contains a parameterized 
geometry and prepared selections for the model. Start by loading this file.

1 From the File menu, choose Open.

2 Browse to the application’s Application Libraries folder and double-click the file 
electronic_enclosure_cooling_geom.mph.

G L O B A L  D E F I N I T I O N S

Define an analytic function to represent the polynomial expression of the head loss 
coefficient (Equation 1). This coefficient is a function of the open ratio of the grille.
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Analytic 1 (an1)
1 On the Home toolbar, click Functions and choose Global>Analytic.

2 In the Settings window for Analytic, type k_grille in the Function name text field.

3 Locate the Definition section. In the Expression text field, type 12084*OR^6-42281*
OR^5+60989*OR^4-46559*OR^3+19963*OR^2-4618.5*OR+462.89.

4 In the Arguments text field, type OR.

5 Locate the Units section. In the Arguments text field, type 1.

6 In the Function text field, type m^-4.

7 Locate the Plot Parameters section. In the table, enter the following settings:

8 Click Plot.

M A T E R I A L S

In this section, you define the materials of the enclosure and its components. The prepared 
selections make it easier to select the appropriate domains and boundaries.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Air.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Air (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Air (mat1).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Air.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Acrylic plastic.

3 Click Add to Component in the window toolbar.

Argument Lower limit Upper limit

OR 0 0.8
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M A T E R I A L S

Acrylic plastic (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Acrylic plastic 

(mat2).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Plastic.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Aluminum 6063-T83.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Aluminum 6063-T83 (mat3)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Aluminum 

6063-T83 (mat3).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Aluminum Boundaries.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Steel AISI 4340.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Steel AISI 4340 (mat4)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Steel AISI 4340 

(mat4).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Steel Parts.

A D D  M A T E R I A L

1 Go to the Add Material window.
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2 In the tree, select Built-In>Aluminum.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Aluminum (mat5)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Aluminum 

(mat5).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Capacitors.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Copper.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Copper (mat6)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Copper (mat6).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Transformer Coils.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Copper.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Copper 1 (mat7)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Copper 1 

(mat7).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Copper Layers.
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A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>FR4 (Circuit Board).

3 Click Add to Component in the window toolbar.

M A T E R I A L S

FR4 (Circuit Board) (mat8)
1 In the Model Builder window, under Component 1 (comp1)>Materials click FR4 (Circuit 

Board) (mat8).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Circuit Board.

Modify the thermal conductivity of the FR4 material to model the anisotropic 
properties of the printed circuit board.

5 Locate the Material Contents section. In the table, enter the following settings:

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Silicon.

3 Click Add to Component in the window toolbar.

4 On the Home toolbar, click Add Material to close the Add Material window.

M A T E R I A L S

Silicon (mat9)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Silicon (mat9).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Transistors Silicon Cores.

The next steps define the boundary conditions of the model.

Property Name Value Unit Property 
group

Thermal conductivity k {10, 10, 
0.3}

W/(m·K) Basic
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H E A T  TR A N S F E R  ( H T )

Set the ambient temperature to be used in intial values of the Heat Transfer interface.

1 In the Model Builder window, expand the Component 1 (comp1)>Heat Transfer (ht) node, 
then click Heat Transfer (ht).

2 In the Settings window for Heat Transfer, locate the Ambient Settings section.

3 In the Tamb text field, type 30[degC].

Fluid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Fluid 

1.

2 In the Settings window for Fluid, locate the Domain Selection section.

3 From the Selection list, choose Air.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Initial 

Values 1.

2 In the Settings window for Initial Values, choose Ambient temperature (ht) from the T 
list.

Now, define the heat rate produced by the different components. Table 1 summarizes the 
values chosen for each kind of component.

Heat Source 1
1 On the Physics toolbar, click Domains and choose Heat Source.

2 In the Settings window for Heat Source, type Heat Source 1: Transistors in the 
Label text field.

3 Locate the Domain Selection section. From the Selection list, choose Transistors Silicon 

Cores.

4 Locate the Heat Source section. Click the Heat rate button.

5 In the P0 text field, type 25.

Heat Source 2
1 On the Physics toolbar, click Domains and choose Heat Source.

2 In the Settings window for Heat Source, type Heat Source 2: Large Transformer 
Coil in the Label text field.

3 Locate the Domain Selection section. From the Selection list, choose Large Transformer 

Coil.
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4 Locate the Heat Source section. Click the Heat rate button.

5 In the P0 text field, type 5.

Heat Source 3
1 On the Physics toolbar, click Domains and choose Heat Source.

2 In the Settings window for Heat Source, type Heat Source 3: Small Transformer 
Coils in the Label text field.

3 Locate the Heat Source section. Click the Heat rate button.

4 In the P0 text field, type 3.

5 Locate the Domain Selection section. From the Selection list, choose Small Transformer 

Coils.

Heat Source 4
1 On the Physics toolbar, click Domains and choose Heat Source.

2 In the Settings window for Heat Source, type Heat Source 4: Inductor in the Label 
text field.

3 Locate the Domain Selection section. From the Selection list, choose Inductors.

4 Locate the Heat Source section. Click the Heat rate button.

5 In the P0 text field, type 2.

Heat Source 5
1 On the Physics toolbar, click Domains and choose Heat Source.

2 In the Settings window for Heat Source, type Heat Source 5: Large Capacitors in 
the Label text field.

3 Locate the Domain Selection section. From the Selection list, choose Large Capacitors.

4 Locate the Heat Source section. Click the Heat rate button.

5 In the P0 text field, type 2.

Heat Source 6
1 On the Physics toolbar, click Domains and choose Heat Source.

2 In the Settings window for Heat Source, type Heat Source 6: Medium Capacitors 
in the Label text field.

3 Locate the Domain Selection section. From the Selection list, choose Medium Capacitors.

4 Locate the Heat Source section. Click the Heat rate button.

5 In the P0 text field, type 3.
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Heat Source 7
1 On the Physics toolbar, click Domains and choose Heat Source.

2 In the Settings window for Heat Source, type Heat Source 7: Small Capacitors in 
the Label text field.

3 Locate the Domain Selection section. From the Selection list, choose Small Capacitors.

4 Locate the Heat Source section. Click the Heat rate button.

5 In the P0 text field, type 1.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 In the Settings window for Temperature, locate the Boundary Selection section.

3 From the Selection list, choose Grille.

4 Locate the Temperature section. From the T0 list, choose Ambient temperature (ht).

To model heat transfer in thin conductive parts of the enclosure, use the Thin Layer 
boundary condition on thin domains made of aluminum, copper, and FR4.

Thin Layer 1
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 In the Settings window for Thin Layer, locate the Boundary Selection section.

3 From the Selection list, choose Conductive Layers.

4 Locate the Thin Layer section. From the Layer type list, choose Thermally thin 

approximation.

5 In the ds text field, type 2[mm].

Outflow 1
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 In the Settings window for Outflow, locate the Boundary Selection section.

3 From the Selection list, choose Fan.

TU R B U L E N T  F L O W,  A L G E B R A I C  Y P L U S  ( S P F )

1 In the Model Builder window, under Component 1 (comp1) click Turbulent Flow, Algebraic 

yPlus (spf).

2 In the Settings window for Turbulent Flow, Algebraic yPlus, locate the Domain Selection 
section.

3 From the Selection list, choose Air.
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The thin heat sink fins are represented by interior boundaries in the geometry. An interior 
wall condition is used to prevent the fluid from flowing through these boundaries.

Interior Wall 1
1 On the Physics toolbar, click Boundaries and choose Interior Wall.

2 In the Settings window for Interior Wall, locate the Boundary Selection section.

3 From the Selection list, choose Fins.

Fan 1
1 On the Physics toolbar, click Boundaries and choose Fan.

2 In the Settings window for Fan, locate the Boundary Selection section.

3 From the Selection list, choose Fan.

4 Locate the Flow Direction section. From the Flow direction list, choose Outlet.

The Graphics window displays an arrow indicating the orientation of the flow through 
the fan. Compare with the figure below.

Here, the Fan condition is set up by loading a data file for the static pressure curve.

5 Locate the Parameters section. From the Static pressure curve list, choose Static pressure 

curve data.

6 Locate the Static Pressure Curve Data section. Click Load from File.
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7 Browse to the application’s Application Libraries folder and double-click the file 
electronic_enclosure_cooling_fan_curve.txt.

8 Locate the Static Pressure Curve Interpolation section. From the Interpolation function 

type list, choose Piecewise cubic.

The exhaust fan previously defined extracts air entering from an opposite grille. Proceed 
to create the corresponding boundary condition.

Grille 1
1 On the Physics toolbar, click Boundaries and choose Grille.

2 In the Settings window for Grille, locate the Boundary Selection section.

3 From the Selection list, choose Grille.

4 Locate the Parameters section. From the Static pressure curve list, choose Quadratic loss.

5 In the qlc text field, type k_grille(OR)*nitf1.rho/2.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Turbulent Flow, Algebraic 

yPlus (spf) click Initial Values 1.

2 In the Settings window for Initial Values, locate the Initial Values section.

3 Specify the u vector as

M E S H  1

You now configure the meshing part. Start by discretizing the surfaces of key components. 
They would drive the tetrahedral mesh of the whole domain. Boundary layers at walls are 
added at the end.

Mapped 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Mapped.

2 In the Settings window for Mapped, locate the Boundary Selection section.

3 From the Selection list, choose Wire Group Surface.

4 Click to expand the Advanced settings section. Locate the Advanced Settings section. 
Select the Adjust evenly distributed edge mesh check box.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Mapped 1 and choose Size.

1 x
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2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Finer.

4 Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 0.5.

7 Select the Minimum element size check box.

8 In the associated text field, type 0.4.

9 Click Build Selected.

Mapped 2
1 In the Model Builder window, right-click Mesh 1 and choose More Operations>Mapped.

2 In the Settings window for Mapped, locate the Boundary Selection section.

3 From the Selection list, choose Small Wire Surface.

4 Locate the Advanced Settings section. Select the Adjust evenly distributed edge mesh 
check box.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Mapped 2 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Calibrate for list, choose Fluid dynamics.

4 From the Predefined list, choose Extra fine.

5 Click the Custom button.

6 Locate the Element Size Parameters section. Select the Maximum element size check box.

7 In the associated text field, type 0.16.
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8 Click Build Selected.

Convert 1
1 In the Model Builder window, right-click Mesh 1 and choose More Operations>Convert.

2 In the Settings window for Convert, click Build Selected.

This conversion divides the quadrilateral mesh obtained into triangular elements. This 
is necessary to make it compatible with the tetrahedral elements created a few steps later.

Free Triangular 1
1 Right-click Mesh 1 and choose More Operations>Free Triangular.

2 In the Settings window for Free Triangular, locate the Boundary Selection section.

3 From the Selection list, choose Heat Exchange Surface.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. Select the Maximum element size check box.

5 In the associated text field, type 0.5.

6 Select the Minimum element size check box.
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7 In the associated text field, type 0.4.

8 Select the Maximum element growth rate check box.

9 In the associated text field, type 1.05.

10 Select the Curvature factor check box.

11 In the associated text field, type 1.

12 Select the Resolution of narrow regions check box.

13 In the associated text field, type 1.

14 Click Build Selected.

Free Triangular 2
1 In the Model Builder window, right-click Mesh 1 and choose More Operations>Free 

Triangular.

2 In the Settings window for Free Triangular, locate the Boundary Selection section.

3 From the Selection list, choose Curved Area.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Triangular 2 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Calibrate for list, choose Fluid dynamics.

4 Click Build Selected.

5 In the Model Builder window, right-click Mesh 1 and choose Free Tetrahedral.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Coarse.

Boundary Layers 1
1 In the Model Builder window, right-click Mesh 1 and choose Boundary Layers.

2 In the Settings window for Boundary Layers, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Air.

5 Click to expand the Corner settings section. Locate the Corner Settings section. From the 
Handling of sharp edges list, choose Trimming.
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Boundary Layer Properties
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1>Boundary Layers 1 

click Boundary Layer Properties.

2 In the Settings window for Boundary Layer Properties, locate the Boundary Selection 
section.

3 From the Selection list, choose Walls.

4 Locate the Boundary Layer Properties section. In the Number of boundary layers text field, 
type 3.

5 In the Thickness adjustment factor text field, type 5.

6 Click Build All.

S T U D Y  1

Now, edit the solver sequence. The default suggestion is a segregated solver. For more 
robustness, use direct solvers for the temperature group and for the velocity-pressure 
group.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.
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3 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 2>Segregated 1 node, then click Temperature T.

4 In the Settings window for Segregated Step, locate the General section.

5 From the Linear solver list, choose Direct.

6 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1)>

Stationary Solver 2>Segregated 1 click Turbulence variables.

7 In the Settings window for Segregated Step, locate the General section.

8 From the Linear solver list, choose Direct.

9 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 2>Iterative 1 node, then click Multigrid 1.

10 In the Settings window for Multigrid, locate the General section.

11 In the Mesh coarsening factor text field, type 1.5.

You are now ready to launch the simulation. The computation may take a few hours to 
complete.

12 On the Study toolbar, click Compute.

R E S U L T S

Temperature (ht)
The first default plot shows the temperature field. To reproduce the plot in Figure 3 of the 
temperature and the air velocity, proceed as follows.

Surface
1 In the Model Builder window, expand the Temperature (ht) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

Temperature (ht)
In the Model Builder window, under Results right-click Temperature (ht) and choose 
Streamline.

Streamline 1
1 In the Settings window for Streamline, click Replace Expression in the upper-right corner 

of the Expression section. From the menu, choose Component 1>Turbulent Flow, 

Algebraic yPlus>Velocity and pressure>u,v,w - Velocity field.

2 Locate the Selection section. From the Selection list, choose Grille.

3 Locate the Coloring and Style section. From the Line type list, choose Tube.
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Color Expression 1
1 Right-click Results>Temperature (ht)>Streamline 1 and choose Color Expression.

2 In the Settings window for Color Expression, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Component 1>Turbulent Flow, 

Algebraic yPlus>Velocity and pressure>spf.U - Velocity magnitude.

3 On the Temperature (ht) toolbar, click Plot.

Velocity (spf)
The third default plot group shows the air velocity profile in a slice plot.

Pressure (spf)
This last default plot group shows the pressure field plot as in Figure 4.
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Introduction

Evaporation in porous media is an important process in food and paper industry among 
others. Many physical effects must be considered: fluid flow, heat transfer and transport of 
participating fluids and gases. All of these effects are strongly coupled and predefined 
interfaces can be used to model these effects with COMSOL Multiphysics. Considering 
an unsaturated porous medium requires adjustments of the predefined equations.

In this model, the changing water saturation inside the porous medium is computed. In 
contrast to the situation with a stationary liquid phase (see Evaporation in Porous Media 
with Small Evaporation Rates), where the interfaces provided by COMSOL can be used 
as they are, the implementation of a multiphase flow requires some changes.

This model and the instructions are based on the corresponding model and focus on the 
additional steps required to implement multiphase flow in porous media together with 
evaporation from liquid to gaseous phase.

Model Definition

This model describes a laminar dry air flow through a porous medium containing water 
vapor and liquid water. The geometry and principle is shown in Figure 1.
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Figure 1: Geometry and principle of the model.

TW O  P H A S E  F L O W  I N  P O R O U S  M E D I A

The basic principle of modeling two phase flow in porous media is similar for many 
applications. First, to account for different phases, saturation variables are used that fulfill 
the following constraint:

 (1)

where the index g is used for the gaseous phase (which in this model is moist air) and the 
index l is used for the liquid phase (which in this model is water). 

Single-phase flow in porous media is described by the Brinkman Equations. With an 
additional liquid phase, capillary effects also arise and the liquid flow is driven by a pressure 
gradient and capillary pressure . How to deal with the latter one depends on 
the application: sometimes the capillary pressure can be neglected, sometimes it is the 
driving effect and different approaches exist.

The formulation used in this model follows (Ref. 2), where capillary effects are treated by 
an additional diffusion term in the transport equation. The Brinkman Equation is used to 

Air flow

Free flow domain

Porous domain containing wa-
ter vapor and liquid water

Sg Sl+ 1=

pc pg pl–=
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calculate the flow field ug and pressure distribution pg of moist air in the porous medium. 
Therefor the porosity ε must take into account that only a fraction of the void space is 
occupied by the gas phase.

The liquid phase velocity is small compared to the moist air velocity and such Darcy’s Law 
is defined in terms of the gas phase pressure gradient to calculate the water velocity ul 
according to

 (2)

where κl and μl are the permeability and viscosity of the liquid phase. It is not necessary to 
define a second Darcy’s law equation, but an additional transport equation for the liquid 
phase is required.

The boundary conditions for the flow equations and their coupling is the same as in the 
corresponding model (see Flow properties).

L I Q U I D  P H A S E  TR A N S P O R T  I N  P O R O U S  M E D I A

COMSOL provides the Transport of Diluted Species interface, which solves for a 
concentration in the very general form:

 (3)

This interface is used to describe the transport of the liquid phase inside the porous 
domain, following the ideas about mechanistic formulations from (Ref. 1). In this paper 
and the references given there the transport of water vapor, liquid water and dry air by 
convection and diffusion is expressed by flux variables.

It is assumed that no liquid water can leave the porous domain. From now on the index 
w is used to indicate that the properties are water properties and not a general liquid phase 
anymore.

The concentration cw describes the water concentration and is rather an auxiliary variable, 
since the saturation is crucial for this process. The correlation for water concentration cw 
and liquid phase saturation Sl is:

where Mw and ρw are the molar mass and density of water, ε is the porosity.

ul
κl
μl
------ pg∇–=

∂c
∂t
----- ∇ N⋅+ R=

Sl
cwMw

ρwε
----------------=
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The velocity field in Equation 2 must take into account that the pore space is not fully 
saturated with water. Additionally the permeability for the liquid phase κl depends on the 
overall permeability of the porous matrix κ and a relative permeability (see Permeability) 
κrl, thus:

The pressure gradient  is solved with the Brinkman Equation and μw is the viscosity 
of water. The capillary effect is introduced as the diffusion coefficient Dcap which depends 
on the moisture content (Ref. 2):

VA P O R  TR A N S P O R T  I N  P O R O U S  M E D I A

The procedure to derive the transport equation for water vapor is similar to the previous 
section. Starting from the conservation equation (Equation 3) and following the 
description in (Ref. 1), one has to implement the flux due to convection whereas the 
velocity field is already known from the Brinkman equation and needs to be applied to the 
vapor phase. The second transport mechanism is flux due to binary diffusion of water 
vapor and dry air in the gaseous phase. A common correlation for an effective diffusivity 
Deff for two components is the Millington and Quirk equation

with the vapor-air diffusivity .

Both effects provide the velocity field that is applied to the water vapor transport equation:

Mma and ρma refer to the moist air molar mass and density.

E V A P O R A T I O N

To calculate the amount of water that evaporates into air and to account for the reducing 
liquid and increasing moist air proportion, the same correlation as in the Evaporation 
section from Ref. 3 is used:

where K (1/s) is the evaporation rate, csat the vapor concentration under saturation 
conditions and c the current vapor concentration.

ul
κκrl

Slεμw
---------------- pg∇–=

∇pg

Deff Dvaε4 3⁄ Sg
10 3⁄

=

Dva 2,6 10 5– m2

s
--------⋅=

u
ug
Sgε
---------

MaDeff
Mmaρma
---------------------∇ρma–=

mevap K awcsat c–( )=
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H E A T  TR A N S F E R

The free flow domain contains moist air only and the velocity field from the laminar flow 
equation is used to describe the heat transferred by convection.

Inside the porous domain the overall velocity field for liquid and gaseous phase contributes 
to the heat convection term. Averaged thermal properties are required:

 (4)

Then the overall velocity can be expressed as the average of dry air-, water vapor-, and 
liquid water velocity, which is:

 (5)

na, nv, and nw are the flux variables for each component (see Ref. 1 for more details). The 
heat of evaporation is inserted as a source term in the heat transfer equation according to:

 (6)

where Hvap (J/mol) is the latent heat of evaporation.

M O I S T  A I R  P R O P E R T I E S

The properties of moist air are the same as used in the other model (see Thermodynamic 
properties). Inside the porous domain there is the option to define a single fluid type. 
Implementing a two phase flow means that the fluid type has to be defined in a way that 
it accounts for liquid and gaseous phases. Therefore it is necessary to define the moist air 
properties manually. Also all other material properties are defined manually for sake of 
simplicity.

P E R M E A B I L I T Y  

The permeability of the porous matrix κ defines the absolute permeability. When two 
phases are present, the permeability of each phase depends also on the saturation. This is 
defined by the relative permeabilities κrl and κrg for liquid and gaseous phase respectively, 
so that  and . The determination of relative permeability curves is 
often done empirically or experimentally and the form strongly depends on the porous 
material properties and the liquids themselves.The functions that are used in this model 

ρtot Sgρma Slρw+=

Cp,tot
SgρmaCp,ma SlρwCp,w+

ρtot
--------------------------------------------------------------=

ktot Sgkma Slkw+=

umean
naCp,a nvCp,v nwCp,w+ +

ρtotCp,tot
-------------------------------------------------------------------=

Q H– vap mvap⋅=

κl κκrl= κg κκrg=
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(Ref. 2) are defined such that they are always positive:

The variable Sli is the irreducible liquid phase saturation, describing the saturation of the 
liquid phase that will remain inside the porous medium.

Results and Discussion

The temperature (Figure 2) shows significant cooling in the whole domain. 

Figure 2: Temperature field after 1000s.

κrg
1 1,1Sl,– Sl 1 1,1⁄<

eps   , Sl 1 1,1⁄≥






=

κrl

Sl Sli–

1 Sli–
------------------ 
 

3
, Sl Sli>

eps     , Sl Sli≤





=
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The default pressure contour plot (Figure 3) shows that pressure gradients inside the 
porous domain dominate over the pressure losses in the free flow domain. The gradients 
are steepest at the interface which requires a fine mesh resolution.

Figure 3: Pressure distribution. Due to the high pressure gradient contour lines are only visible 
inside the porous domain.

Inside the porous domain the relative humidity is close to 100 % everywhere (Figure 4).
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Figure 4: Relative humidity after 1000 s.

Notes About the COMSOL Implementation

Using a proper mesh size is important to resolve the steep gradients at the interface 
boundaries. Therefore a customized mesh with boundary layers is used. 

To get good convergence of the time dependent behavior, first solve the stationary flow 
equations only. This solution will then be used as initial value for the time dependent study 
step providing smooth initial conditions in the modeling domain. In addition the default 
nonlinear solver is changed to be more stable for this strongly coupled problem.
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3. Heat_Transfer_Module/Phase_Change/evaporation_porous_media_small_rate

Application Library path: Heat_Transfer_Module/Phase_Change/
evaporation_porous_media_large_rate

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 Click Done.

G L O B A L  D E F I N I T I O N S

For this model, many parameters and variables are needed. Start by loading all of them 
from text files. For clarity reasons, the variables are grouped in separate variable sets.

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
evaporation_porous_media_large_rate_parameters.txt.

Variables 1
1 In the Model Builder window, right-click Global Definitions and choose Variables.

2 In the Settings window for Variables, type Air Properties in the Label text field.

3 Locate the Variables section. Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
evaporation_porous_media_large_rate_air.txt.

Variables 2
1 Right-click Global Definitions and choose Variables.
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2 In the Settings window for Variables, type Liquid Water Properties in the Label text 
field.

3 Locate the Variables section. Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
evaporation_porous_media_large_rate_water.txt.

Variables 3
1 Right-click Global Definitions and choose Variables.

2 In the Settings window for Variables, type Water Vapor Properties in the Label text 
field.

3 Locate the Variables section. Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
evaporation_porous_media_large_rate_vapor.txt.

Variables 4
1 Right-click Global Definitions and choose Variables.

2 In the Settings window for Variables, type Porous Matrix Properties in the Label 
text field.

3 Locate the Variables section. Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
evaporation_porous_media_large_rate_porous.txt.

D E F I N I T I O N S

In the Model Builder window, expand the Component 1 (comp1)>Definitions node.

Variables 5
1 Right-click Definitions and choose Variables.

2 In the Settings window for Variables, type Material Properties in the Label text field.

3 Locate the Variables section. Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
evaporation_porous_media_large_rate_matprop.txt.

Variables 6
1 Right-click Definitions and choose Variables.

2 In the Settings window for Variables, type Porous Medium Velocity Variables in 
the Label text field.

3 Locate the Variables section. Click Load from File.
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4 Browse to the application’s Application Libraries folder and double-click the file 
evaporation_porous_media_large_rate_velocities.txt.

Variables 7
1 Right-click Definitions and choose Variables.

2 In the Settings window for Variables, type Variables in the Label text field.

3 Locate the Variables section. Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
evaporation_porous_media_large_rate_variables.txt.

Define the relative permeabilities for water vapor and liquid water as functions of liquid 
water saturation. The advantage of using functions is that they can be plotted immediately.

Piecewise 1 (pw1)
1 On the Home toolbar, click Functions and choose Global>Piecewise.

2 In the Settings window for Piecewise, type Relative Permeability, Moist Air in 
the Label text field.

3 In the Function name text field, type kappa_rma.

4 Locate the Definition section. In the Argument text field, type S_l.

5 Find the Intervals subsection. In the table, enter the following settings:

To force the saturation to be always positive eps is used as minimum value.

Start End Function

0 1/1.1 1-1.1*S_l

1/1.1 1 eps
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6 In the Settings window for Piecewise, click Plot.

Piecewise 2 (pw2)
1 On the Home toolbar, click Functions and choose Global>Piecewise.

2 In the Settings window for Piecewise, type Relative Permeability, Liquid Phase 
in the Label text field.

3 In the Function name text field, type kappa_rl.

4 Locate the Definition section. In the Argument text field, type S_l.

5 Find the Intervals subsection. In the table, enter the following settings:

Start End Function

0 S_il eps

S_il 1 ((S_l-S_il)/(1-S_il))^3
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6 In the Settings window for Piecewise, click Plot.

All variables are defined. Create the geometry.

G E O M E T R Y  1

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.15.

4 In the Height text field, type 0.05.

Rectangle 2 (r2)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.04.

4 In the Height text field, type 0.005.

5 Locate the Position section. In the x text field, type 0.04.

Fillet 1 (fil1)
1 On the Geometry toolbar, click Fillet.
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2 On the object r2, select Points 3 and 4 only.

3 In the Settings window for Fillet, locate the Radius section.

4 In the Radius text field, type 2e-3.

5 Click Build All Objects.

Next, add the physics interfaces and define the domain features that set up the equations 
to be solved in the domains.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Heat Transfer>Heat Transfer in Fluids (ht).

4 Click Add to Component in the window toolbar.

A D D  P H Y S I C S

1 Go to the Add Physics window.

2 In the tree, select Fluid Flow>Porous Media and Subsurface Flow>Free and Porous Media 

Flow (fp).

3 Click Add to Component in the window toolbar.

A D D  P H Y S I C S

1 Go to the Add Physics window.

2 In the tree, select Chemical Species Transport>Transport of Diluted Species (tds).

3 Click Add to Component in the window toolbar.

A D D  P H Y S I C S

1 Go to the Add Physics window.

2 In the tree, select Chemical Species Transport>Transport of Diluted Species (tds).

3 Click Add to Component in the window toolbar.

TR A N S P O R T  O F  D I L U T E D  S P E C I E S  2  ( T D S 2 )

On the Home toolbar, click Add Physics to close the Add Physics window.

H E A T  TR A N S F E R  I N  F L U I D S  ( H T )

On the Physics toolbar, click Transport of Diluted Species 2 (tds2) and choose Heat Transfer 

in Fluids (ht).
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1 In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Fluids 

(ht).

2 In the Settings window for Heat Transfer in Fluids, locate the Physical Model section.

3 Select the Heat transfer in porous media check box.

4 Locate the Ambient Settings section. In the Tamb text field, type T0.

Porous Medium 1
1 On the Physics toolbar, click Domains and choose Porous Medium.

2 Select Domain 2 only.

F R E E  A N D  PO R O U S  M E D I A  F L OW  ( F P )

1 In the Model Builder window, under Component 1 (comp1) click Free and Porous Media 

Flow (fp).

2 In the Settings window for Free and Porous Media Flow, locate the Physical Model 
section.

3 From the Compressibility list, choose Compressible flow (Ma<0.3).

Porous Matrix Properties 1
1 On the Physics toolbar, click Domains and choose Porous Matrix Properties.

2 Select Domain 2 only.

TR A N S P O R T  O F  D I L U T E D  S P E C I E S  ( T D S )

1 In the Model Builder window, under Component 1 (comp1) click Transport of Diluted 

Species (tds).

2 In the Settings window for Transport of Diluted Species, type Transport of Diluted 
Species: Liquid Water in the Label text field.

3 Click to expand the Dependent variables section. Locate the Dependent Variables section. 
In the Concentrations table, enter the following settings:

4 Select Domain 2 only.

TR A N S P O R T  O F  D I L U T E D  S P E C I E S  2  ( T D S 2 )

On the Physics toolbar, click Transport of Diluted Species (tds) and choose Transport of 

Diluted Species 2 (tds2).

1 In the Model Builder window, under Component 1 (comp1) click Transport of Diluted 

Species 2 (tds2).

cl
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2 In the Settings window for Transport of Diluted Species, type Transport of Diluted 
Species 2: Water Vapor in the Label text field.

3 Click to expand the Dependent variables section. Locate the Dependent Variables section. 
In the Concentrations table, enter the following settings:

TR A N S P O R T  O F  D I L U T E D  S P E C I E S  2 :  WA T E R  V A P O R  ( T D S 2 )

Transport Properties 2
1 On the Physics toolbar, click Domains and choose Transport Properties.

2 Select Domain 2 only.

3 In the Settings window for Transport Properties, type Transport Properties 2: 
Porous Medium in the Label text field.

Continue with the Heat Transfer in Fluids interface and set up the multiphysics coupling 
manually. Also add the heat source term due to evaporation.

H E A T  TR A N S F E R  I N  F L U I D S  ( H T )

Fluid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Fluids (ht) 

click Fluid 1.

2 In the Settings window for Fluid, locate the Model Inputs section.

3 From the pA list, choose Absolute pressure (fp).

4 From the u list, choose Velocity field (fp/fp1).

5 Locate the Heat Conduction, Fluid section. From the k list, choose User defined. In the 
associated text field, type k_ma.

This is the equivalent thermal conductivity as defined in the Variables node.

6 Locate the Thermodynamics, Fluid section. From the Fluid type list, choose Ideal gas.

7 From the Gas constant type list, choose Mean molar mass.

8 From the Mn list, choose User defined. In the associated text field, type Mn_ma.

9 From the Cp list, choose User defined. In the associated text field, type cp_ma.

Porous Medium 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Fluids (ht) 

click Porous Medium 1.

2 In the Settings window for Porous Medium, locate the Model Inputs section.

cv
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3 From the pA list, choose Absolute pressure (fp).

4 Specify the u vector as

This is the average velocity for liquid water and water vapor as defined in the Porous 

media velocity variables node.

5 Locate the Heat Conduction, Fluid section. From the k list, choose User defined. In the 
associated text field, type k_tot.

6 Locate the Thermodynamics, Fluid section. From the ρ list, choose User defined. In the 
associated text field, type rho_tot.

7 From the Cp list, choose User defined. In the associated text field, type cp_tot.

8 From the γ list, choose User defined. Locate the Immobile Solids section. In the θp text 
field, type 1-por.

9 Locate the Heat Conduction, Porous Matrix section. From the kp list, choose User defined. 
In the associated text field, type k_p.

10 Locate the Thermodynamics, Porous Matrix section. From the ρp list, choose User defined. 
In the associated text field, type rho_p.

11 From the Cp, p list, choose User defined. In the associated text field, type cp_p.

12 In the Model Builder window, click Heat Transfer in Fluids (ht).

Heat Source 1
1 On the Physics toolbar, click Domains and choose Heat Source.

2 Select Domain 2 only.

3 In the Settings window for Heat Source, locate the Heat Source section.

4 In the Q0 text field, type -H_evap*Mn_l*m_evap.

F R E E  A N D  PO R O U S  M E D I A  F L OW  ( F P )

Continue with the Free and Porous Media Flow interface.

Fluid Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Free and Porous Media Flow 

(fp) click Fluid Properties 1.

2 In the Settings window for Fluid Properties, locate the Fluid Properties section.

3 From the ρ list, choose User defined. In the associated text field, type rho_ma.

u_mean x

v_mean y
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4 From the μ list, choose User defined. In the associated text field, type mu_ma.

Porous Matrix Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Free and Porous Media Flow 

(fp) click Porous Matrix Properties 1.

2 In the Settings window for Porous Matrix Properties, locate the Porous Matrix Properties 
section.

3 From the εp list, choose User defined. In the associated text field, type por*S_ma.

The pore space is partially filled with liquid water, so that the available space for water 
vapor depends on the porosity and the saturation.

4 From the κ list, choose User defined. In the associated text field, type kappa_ma.

5 In the Model Builder window, click Free and Porous Media Flow (fp).

Mass Source 1
1 On the Physics toolbar, click Domains and choose Mass Source.

2 Select Domain 2 only.

3 In the Settings window for Mass Source, locate the Mass Source section.

4 In the Qbr text field, type Mn_l*m_evap.

TR A N S P O R T  O F  D I L U T E D  S P E C I E S :  L I Q U I D  WA T E R  ( T D S )

Transport Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Transport of Diluted Species: 

Liquid Water (tds) click Transport Properties 1.

2 In the Settings window for Transport Properties, locate the Model Inputs section.

3 Specify the u vector as

4 Locate the Diffusion section. In the Dcl text field, type D_cap.

The velocity field for the transport of liquid water can directly be derived from the vapor 
flow velocity and must take into account the available pore space and relative 
permeability.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Transport of Diluted Species: 

Liquid Water (tds) click Initial Values 1.

-px*kappa_l/(S_l*por*mu_l) x

-py*kappa_l/(S_l*por*mu_l) y
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2 In the Settings window for Initial Values, locate the Initial Values section.

3 In the cl text field, type S_l_0*por*rho_l/Mn_l.

4 In the Model Builder window, click Transport of Diluted Species: Liquid Water (tds).

Reactions 1
1 On the Physics toolbar, click Domains and choose Reactions.

2 In the Settings window for Reactions, locate the Reaction Rates section.

3 In the Rcl text field, type -m_evap.

4 Select Domain 2 only.

TR A N S P O R T  O F  D I L U T E D  S P E C I E S  2 :  WA T E R  V A P O R  ( T D S 2 )

Transport Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Transport of Diluted Species 

2: Water Vapor (tds2) click Transport Properties 1.

2 In the Settings window for Transport Properties, locate the Model Inputs section.

3 From the u list, choose Velocity field (fp/fp1).

4 Locate the Diffusion section. In the Dcv text field, type D_va.

Transport Properties 2: Porous Medium
1 In the Model Builder window, under Component 1 (comp1)>Transport of Diluted Species 

2: Water Vapor (tds2) click Transport Properties 2: Porous Medium.

2 In the Settings window for Transport Properties, locate the Model Inputs section.

3 Specify the u vector as

4 Locate the Diffusion section. In the Dcv text field, type D_eff*Mn_a/Mn_ma.

This sets up the water vapor transport according to Vapor Transport in porous media.

5 In the Model Builder window, click Transport of Diluted Species 2: Water Vapor (tds2).

Initial Values 2
1 On the Physics toolbar, click Domains and choose Initial Values.

2 Select Domain 2 only.

3 In the Settings window for Initial Values, locate the Initial Values section.

4 In the cv text field, type cv_sat_0.

u/(por*S_ma)-Mn_a*D_eff*rho_ma*d(Mn_ma/rho_ma,x)/Mn_ma^2 x

v/(por*S_ma)-Mn_a*D_eff*rho_ma*d(Mn_ma/rho_ma,y)/Mn_ma^2 y
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Reactions 1
1 On the Physics toolbar, click Domains and choose Reactions.

2 Select Domain 2 only.

3 In the Settings window for Reactions, locate the Reaction Rates section.

4 In the Rcv text field, type m_evap.

H E A T  TR A N S F E R  I N  F L U I D S  ( H T )

Define the boundary conditions for each interface. Again, start with the Heat Transfer in 

Fluids interface. Fix the temperature at the inlet and define the outflow boundary 
condition.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Fluids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, choose Ambient temperature (ht) from the T 
list.

3 In the Model Builder window, click Heat Transfer in Fluids (ht).

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 1 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 From the T0 list, choose Ambient temperature (ht).

Outflow 1
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 Select Boundary 9 only.

F R E E  A N D  PO R O U S  M E D I A  F L OW  ( F P )

In the Model Builder window, under Component 1 (comp1) click Free and Porous Media Flow 

(fp).

Inlet 1
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 Select Boundary 1 only.

3 In the Settings window for Inlet, locate the Boundary Condition section.

4 From the list, choose Laminar inflow.
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5 Locate the Laminar Inflow section. In the Uav text field, type u0.

Outlet 1
1 On the Physics toolbar, click Boundaries and choose Outlet.

2 Select Boundary 9 only.

TR A N S P O R T  O F  D I L U T E D  S P E C I E S  2 :  WA T E R  V A P O R  ( T D S 2 )

In the Model Builder window, under Component 1 (comp1) click Transport of Diluted Species 

2: Water Vapor (tds2).

Concentration 1
1 On the Physics toolbar, click Boundaries and choose Concentration.

2 Select Boundary 1 only.

3 In the Settings window for Concentration, locate the Concentration section.

4 Select the Species cv check box.

Outflow 1
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 Select Boundary 9 only.

M E S H  1

To resolve all effects and get a better convergence for this highly nonlinear problem, build 
a mesh manually with boundary layers to resolve the interface properly.

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Size.

Size
1 In the Settings window for Size, locate the Element Size section.

2 From the Calibrate for list, choose Fluid dynamics.

3 From the Predefined list, choose Finer.

Size 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size 1.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose All boundaries.

5 Select Boundaries 2–4, 6–8, 10, and 11 only.

6 Locate the Element Size section. From the Calibrate for list, choose Fluid dynamics.
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7 From the Predefined list, choose Extremely fine.

8 In the Model Builder window, right-click Mesh 1 and choose Free Triangular.

Boundary Layer Properties
1 Right-click Mesh 1 and choose Boundary Layers.

2 In the Settings window for Boundary Layer Properties, locate the Boundary Selection 
section.

3 From the Selection list, choose All boundaries.

4 Select Boundaries 2–4, 6–8, 10, and 11 only.

5 Locate the Boundary Layer Properties section. In the Thickness adjustment factor text 
field, type 0.5.

6 Click Build All.

A D D  S T U D Y

Add a stationary study that solves for the fluid flow only without the mass source term. 
This serves as initial value for the time dependent solution of the whole process.

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

In the table, clear the Solve for check box for all interfaces except for the Free and Porous 

Media Flow interface.

4 Click Add Study in the window toolbar.

S T U D Y  1

Step 1: Stationary
1 In the Settings window for Stationary, locate the Physics and Variables Selection section.

2 Select the Modify physics tree and variables for study step check box.

3 In the Physics and variables selection tree, select Component 1 (comp1)>Free and Porous 

Media Flow (fp)>Mass Source 1.

4 Click Disable.

Now the Mass Source condition is disabled for the stationary study.

5 On the Home toolbar, click Add Study to close the Add Study window.

Time Dependent
On the Study toolbar, click Study Steps and choose Time Dependent>Time Dependent.
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Step 2: Time Dependent
1 In the Settings window for Time Dependent, locate the Study Settings section.

2 In the Times text field, type range(0,5,1000).

The problem is highly nonlinear, so tune some solver settings to get a better convergence.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Time-Dependent Solver 1.

3 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

4 Locate the Time Stepping section. Select the Maximum step check box.

5 In the associated text field, type 50.

6 Find the Algebraic variable settings subsection. From the Consistent initialization list, 
choose Off.

7 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Time-Dependent Solver 1 node, then click Fully Coupled 1.

8 In the Settings window for Fully Coupled, click to expand the Method and termination 
section.

9 Locate the Method and Termination section. In the Damping factor text field, type 0.5.

10 From the Jacobian update list, choose On every iteration.

11 In the Maximum number of iterations text field, type 15.

The reduced damping factor forces a smaller hence more stable non-linear solver step. 
The setting of Jacobian update to On every iteration will update the matrix after each 
iteration and hence will also improve stability. This may require more iterations until a 
stable solution is found. That is why the Maximum number of iterations is increased.

12 In the Settings window for Fully Coupled, click Compute.

R E S U L T S

2D Plot Group 7
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Relative Humidity in the Label text 
field.

3 On the Relative Humidity toolbar, click Surface.
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Surface 1
1 In the Model Builder window, under Results>Relative Humidity click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Definitions>

Variables>phi - Relative humidity.

3 On the Relative Humidity toolbar, click Plot.

4 Click the Zoom Extents button on the Graphics toolbar.
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Introduction

Evaporation in porous media is an important process in food and paper industry among 
others. Many physical effects must be considered: fluid flow, heat transfer and transport of 
participating fluids and gases. All of these effects are strongly coupled and can be handled 
by using the predefined interfaces of COMSOL Multiphysics. When having a liquid and a 
gaseous phase inside the porous domain, some adjustments of the predefined equations 
are required. In this tutorial, evaporation is assumed to have a negligible impact on the 
amount of liquid water, making it possible to describe the transport of water vapor with a 
convection-diffusion equation.

Figure 1: Geometry and principle of the model.

Model Definition

This tutorial describes laminar air flow through a humid porous medium. The air is dry at 
the inlet and its moisture content increases as it flows through the porous media.

The flow inside the porous medium is described with Brinkman equation. The flow in the 
surrounding domain is described with the laminar Navier-Stokes equation. The geometry 
and basic set-up is shown in Figure 1.

Porous domain

Free flow domain

Air flow
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T H E R M O D Y N A M I C  P R O P E R T I E S

The thermodynamic properties of air with water vapor can be described using mixture 
laws, based on the amount of water vapor and dry air. This is done automatically when 
choosing Moist air as fluid type and the governing equations can be found in the Heat 
Transfer Module User’s Guide. As input term for water vapor, the concentration c (mol/
m³) from the transport equation is used.

F L O W  P R O P E R T I E S

To model the fluid flow from the air domain, using the laminar Navier-Stokes equation 
into the porous domain using Brinkman equation the Laminar Flow Interface is used and 
extended by enabling porous media domains. This way, the coupling of both flow regimes 
is done automatically. The resulting velocity field then can be used to model convective 
heat and species transport.

TR A N S P O R T  P R O P E R T I E S

The fraction of water vapor is small and the Transport of Diluted Species interface is used 
to describe the transport properties in the free flow and porous domain. In the porous 
domain, the diffusion coefficient for water vapor into air DL (m²/s) needs to be adjusted 
according to

. 

This describes the effective diffusivity inside a porous medium, depending on its structure, 
characterized by the dimensionless numbers porosity εp and tortuosity τL. Here, the 
Bruggeman correction is used, which is 

 (1)

E V A P O R A T I O N

Including the evaporation process is done by adding the mass of water vapor that is 
evaporated as source term in the transport equation. Evaporation takes place, if the 
concentration of water vapor is below the equilibrium concentration, which is determined 
by the saturation concentration csat and water activity aw , with

 (2)

with the saturation pressure psat and the ideal gas constant R = 8.314 J/(mol·K). The 
water activity describes the amount of water that evaporates into air. In general it is a 

De
εp
τL
-----DL=

De εp
3 2⁄ DL=

csat
psat T( )

RT
--------------------=
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function depending on the water content on dry basis of the surrounding air and the 
temperature (see for example Ref. 2), but here an approximate value of aw = 0.9 is used 
because of the moderate variation of water content. Hence the amount of evaporated 
water is defined as:

 (3)

where K (1/s) is the evaporation rate, and c the current concentration. The evaporation 
rate depends on the material properties and the process which causes the evaporation. It 
must be chosen so that the solution is not affected if further increased. This corresponds 
to assuming that vapor is in equilibrium with the liquid or in other words, the time scale 
for evaporation is much smaller than the smallest time scale of the transport equations. 
This is true for pore sizes that are not too large (Ref. 1).

The heat of evaporation is then inserted as source term in the heat transfer equation 
according to:

 (4)

where Hvap (J/mol) is the latent heat of evaporation.

mvap K awcsat c–( )⋅=

Q Hvap mvap⋅=
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Results and Discussion

After one minute the temperature field shows strong cooling due to evaporation. As seen 
below, evaporation mainly occurs at the surface of the porous medium. Inside the domain, 
the temperature gradients remain moderate.

Figure 2: Temperature distribution after 60 s.
5 |  E V A P O R A T I O N  I N  P O R O U S  M E D I A  W I T H  S M A L L  E V A P O R A T I O N  R A T E S



The concentration distribution is shown in the next plot.

Figure 3: Concentration distribution after 60 s
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The pressure field shows steep gradients at the interface boundaries.

Figure 4: Pressure field combining the pressure from the Laminar Flow interface and the 
Darcy’s Law interface.

Notes About the COMSOL Implementation

Using a proper mesh size is important to resolve the steep gradients at the interface 
boundaries. Therefore a customized mesh with boundary layers is used. 

To get good convergence of the time dependent behavior, first solve the stationary flow 
equation only. This solution will then be used as initial value for the time dependent study 
step providing smooth initial conditions in the modeling domain.

Instead of coupling the Transport of Dilutes Species Interface with the flow interface 
manually, the Reacting Flow in Porous Media interface provides a predefined coupling of 
both equations. Then, the coupling to the heat transfer interface is the only coupling that 
has to be done manually. This interface is available with one of the following modules: 
Batteries and Fuel Cells Module, CFD Module or Chemical Reaction Engineering 
Module.
7 |  E V A P O R A T I O N  I N  P O R O U S  M E D I A  W I T H  S M A L L  E V A P O R A T I O N  R A T E S



Reference

1. A. Halder, A. Dhall and A.K. Datta, “Modeling Transport in Porous Media with Phase 
Change: Applications to Food Processing”, J. Heat Transfer, vol. 133, no. 3, 2011.

2. A.K. Datta, “Porous media approaches to studying simultaneous heat and mass transfer 
in food processes. II: Property data and representative results, Journal of Food 
Engineering, Vol. 80, (2007)

Application Library path: Heat_Transfer_Module/Phase_Change/
evaporation_porous_media_small_rate

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Fluids (ht).

3 Click Add.

4 In the Select Physics tree, select Chemical Species Transport>Transport of Diluted Species 

(tds).

5 Click Add.

6 In the Select Physics tree, select Fluid Flow>Single-Phase Flow>Laminar Flow (spf).

7 Click Add.

8 Click Study.

9 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

10 Click Done.

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.
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3 From the Length unit list, choose cm.

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 30.

4 In the Height text field, type 10.

Rectangle 2 (r2)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 8.

4 Locate the Position section. In the x text field, type 6.

Fillet 1 (fil1)
1 On the Geometry toolbar, click Fillet.

2 On the object r2, select Points 3 and 4 only.

3 In the Settings window for Fillet, locate the Radius section.

4 In the Radius text field, type 0.25.

5 On the Geometry toolbar, click Build All.
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6 Click the Zoom Extents button on the Graphics toolbar.

Start with defining some parameters.

Parameters
On the Home toolbar, click Parameters.

G L O B A L  D E F I N I T I O N S

Parameters
1 In the Settings window for Parameters, locate the Parameters section.

2 In the table, enter the following settings:

Name Expression Value Description

p0 1[atm] 1.0133E5 Pa Ambient pressure

T0 20[degC] 293.15 K Ambient temperature

u0 0.1[m/s] 0.1 m/s Free stream velocity

D_wa 2.6e-5[m^2/s] 2.6E-5 m²/s Water-air 
diffusivity

M_w 0.018[kg/mol] 0.018 kg/mol Molar mass of water

H_vap 2.454e6[J/kg]*M_w 44172 J/mol Heat of vaporization
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Set up the different physics interfaces. Start with the heat transfer interface, where you 
define the thermodynamic properties of moist air for the free flow and porous domain.

H E A T  TR A N S F E R  I N  F L U I D S  ( H T )

1 In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Fluids 

(ht).

2 In the Settings window for Heat Transfer in Fluids, locate the Physical Model section.

3 Select the Heat transfer in porous media check box.

Porous Medium 1
1 On the Physics toolbar, click Domains and choose Porous Medium.

Set the ambient temperature to be used in boundary conditions of the Heat Transfer 
interface.

2 In the Settings window for Heat Transfer in Fluids, locate the Ambient Settings section.

3 In the Tamb text field, type T0.

Use the velocity from the Laminar Flow interface as input. Later it is customized to take 
the porous properties into account.

4 In the Model Builder window, click Porous Medium 1.

5 Select Domain 2 only.

6 In the Settings window for Porous Medium, locate the Model Inputs section.

7 From the pA list, choose Absolute pressure (spf).

8 From the u list, choose Velocity field (spf).

Select Moist Air as Fluid type. The moisture content is evaluated using the concentration 
from the Transport of Dilutes Species interface.

9 Locate the Thermodynamics, Fluid section. From the Fluid type list, choose Moist air.

10 From the Input quantity list, choose Concentration.

11 Locate the Model Inputs section. From the c list, choose Concentration (tds).

12 Locate the Immobile Solids section. In the θp text field, type 0.2.

Similar settings apply for the Fluid node.

K_evap 1000[1/s] 1000 1/s Evaporation rate

a_w 0.9 0.9 Water activity

Name Expression Value Description
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Fluid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Fluids (ht) 

click Fluid 1.

2 In the Settings window for Fluid, locate the Model Inputs section.

3 From the pA list, choose Absolute pressure (spf).

4 From the u list, choose Velocity field (spf).

5 Locate the Thermodynamics, Fluid section. From the Fluid type list, choose Moist air.

6 From the Input quantity list, choose Concentration.

7 Locate the Model Inputs section. From the c list, choose Concentration (tds).

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 1 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 From the T0 list, choose Ambient temperature (ht).

Outflow 1
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 Select Boundary 9 only.

The next step is to set up the source term for the heat of vaporization according to 
Equation 4.

Heat Source 1
1 On the Physics toolbar, click Domains and choose Heat Source.

2 Select Domain 2 only.

3 In the Settings window for Heat Source, locate the Heat Source section.

4 In the Q0 text field, type -H_vap*m_evap.

The variable m_evap is defined according to Equation 3 and depends on the saturation 
concentration (Equation 2) and water activity.

D E F I N I T I O N S

In the Model Builder window, under Component 1 (comp1) right-click Definitions and choose 
Variables.

Variables 1
1 In the Settings window for Variables, locate the Variables section.
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2 In the table, enter the following settings:

Continue with the Transport of Diluted Species interface. Water vapor is produced (m_evap) 
and saturation concentration is reached in the porous domain. For water-air diffusivity the 
Bruggeman correction (Equation 1) is used to describe the diffusive transport.

TR A N S P O R T  O F  D I L U T E D  S P E C I E S  ( T D S )

Transport Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Transport of Diluted Species 

(tds) click Transport Properties 1.

2 In the Settings window for Transport Properties, locate the Model Inputs section.

3 From the u list, choose Velocity field (spf).

4 Locate the Diffusion section. In the Dc text field, type D_wa.

At the inlet for the free air flow the concentration is set to zero which implies dry air.

5 In the Model Builder window, click Transport of Diluted Species (tds).

Concentration 1
1 On the Physics toolbar, click Boundaries and choose Concentration.

2 Select Boundary 1 only.

3 In the Settings window for Concentration, locate the Concentration section.

4 Select the Species c check box.

Outflow 1
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 Select Boundary 9 only.

Initial Values 2
1 On the Physics toolbar, click Domains and choose Initial Values.

2 Select Domain 2 only.

3 In the Settings window for Initial Values, locate the Initial Values section.

4 In the c text field, type ht.porous1.fpsat(T0)/(R_const*T0).

Name Expression Unit Description

c_sat ht.fluid1.fpsat(T)
/(R_const*T)

mol/m³ Saturation vapor 
concentration

m_evap K_evap*(a_w*
c_sat-c)

mol/(m³·s) Evaporated mass of 
water vapor
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Reactions 1
1 On the Physics toolbar, click Domains and choose Reactions.

2 Select Domain 2 only.

3 In the Settings window for Reactions, locate the Reaction Rates section.

4 In the Rc text field, type m_evap.

Porous Media Transport Properties 1
1 On the Physics toolbar, click Domains and choose Porous Media Transport Properties.

2 Select Domain 2 only.

3 In the Settings window for Porous Media Transport Properties, locate the Model Inputs 
section.

4 From the u list, choose Velocity field (spf).

5 Locate the Diffusion section. In the DF, c text field, type D_wa.

6 From the Effective diffusivity model list, choose Bruggeman model.

The remaining task is to set up the flow interface for the free and porous domain.

L A M I N A R  F L O W  ( S P F )

The next step enables additional features for the flow interface to account for porous 
domains also.

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

2 In the Settings window for Laminar Flow, locate the Physical Model section.

3 Select the Enable porous media domains check box.

Fluid Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Laminar Flow (spf) click Fluid 

Properties 1.

2 In the Settings window for Fluid Properties, locate the Fluid Properties section.

3 From the ρ list, choose User defined. In the associated text field, type ht.rho.

4 From the μ list, choose Dynamic viscosity (ht).

This step sets the density to the density that is calculated by the moist air feature within 
the Heat Transfer interface.

Set up the porous domain properties.

5 In the Model Builder window, click Laminar Flow (spf).
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Fluid and Matrix Properties 1
1 On the Physics toolbar, click Domains and choose Fluid and Matrix Properties.

2 Select Domain 2 only.

3 In the Settings window for Fluid and Matrix Properties, locate the Fluid Properties 
section.

4 From the ρ list, choose User defined. In the associated text field, type ht.rho.

5 From the μ list, choose Dynamic viscosity (ht).

Inlet 1
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 Select Boundary 1 only.

3 In the Settings window for Inlet, locate the Boundary Condition section.

4 From the list, choose Laminar inflow.

5 Locate the Laminar Inflow section. In the Uav text field, type u0.

The Entrance length value must be large enough so that the flow can reach a laminar 
profile. For a laminar flow, Lentr should be significantly greater than 0.06ReD, where 
Re is the Reynolds number and D is the inlet length scale. In this case, 30 m is an 
appropriate value.

6 In the Lentr text field, type 30.

Outlet 1
1 On the Physics toolbar, click Boundaries and choose Outlet.

2 Select Boundary 9 only.

Specify the porous material properties.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, type Porous Matrix in the Label text field.

2 Select Domain 2 only.
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3 Locate the Material Contents section. In the table, enter the following settings:

Steep gradients are present and the default mesh is adjusted to resolve the flow and 
transport equations with high accuracy.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Triangular.

Free Triangular 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Triangular 1 and choose Size.

Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Domain.

3 Select Domain 1 only.

4 Locate the Element Size section. From the Calibrate for list, choose Fluid dynamics.

5 From the Predefined list, choose Finer.

Free Triangular 1
Right-click Free Triangular 1 and choose Size.

Size 2
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Domain.

3 Select Domain 2 only.

4 Locate the Element Size section. From the Calibrate for list, choose Fluid dynamics.

5 From the Predefined list, choose Extra fine.

Property Name Value Unit Property 
group

Thermal conductivity k 0.21 W/(m·K) Basic

Density rho 1528 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 1650 J/(kg·K) Basic

Porosity epsilon 0.4 1 Basic

Permeability kappa 1e-13 m² Basic
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Boundary Layers 1
1 In the Model Builder window, right-click Mesh 1 and choose Boundary Layers.

2 In the Settings window for Boundary Layers, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose All domains.

Boundary Layer Properties
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1>Boundary Layers 1 

click Boundary Layer Properties.

2 Select Boundaries 2–4, 6–8, 10, and 11 only.

3 In the Settings window for Boundary Layer Properties, locate the Boundary Layer 

Properties section.

4 In the Number of boundary layers text field, type 5.

5 In the Thickness adjustment factor text field, type 2.

6 Click Build All.

First, solve the stationary flow equations only to provide a fully developed flow profile for 
the whole equation system that is solved in a time interval of 1 minute.

S T U D Y  1

Step 1: Stationary
1 In the Settings window for Stationary, locate the Physics and Variables Selection section.

2 In the table, clear the Solve for check box for Heat Transfer in Fluids (ht) and Transport 

of Diluted Species (tds).

Time Dependent
On the Study toolbar, click Study Steps and choose Time Dependent>Time Dependent.

Step 2: Time Dependent
1 In the Settings window for Time Dependent, locate the Study Settings section.

2 Click Range.

3 In the Range dialog box, type 0 in the Start text field.

4 In the Step text field, type 1.

5 In the Stop text field, type 60.

6 Click Replace.

7 On the Study toolbar, click Compute.
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R E S U L T S

Temperature (ht)
Several default plots are created automatically. The first plot group shows the temperature 
field as in Figure 2.

1 Click the Zoom Extents button on the Graphics toolbar.

Concentration (tds)
The concentration distribution (see Figure 3) is computed from the Transport of Diluted 

Species interface.

Pressure (spf)
The last plot group shows the pressure field computed from the Laminar Flow interface 
(Figure 4).
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Introduction

This tutorial shows how to simulate cooling of water including evaporative cooling. As an 
example, a beaker filled with water is used surrounded by an air domain. The airflow 
transports the water vapor which causes the liquid to cool down. The approach used here 
neglects volume change of the water inside the beaker. This is a reasonable assumption for 
problems where the considered time is short compared to the time needed to evaporate a 
noticeable amount of water.

Model Definition

The model geometry is shown in Figure 1. Symmetry is used to reduce the model size.

Figure 1: Model geometry, using symmetry.

The beaker is made of glass and contains hot water at 80 °C. The air has an initial 
temperature of 20 °C and enters the modeling domain with this temperature.

For modeling evaporative cooling, three effects must be taken into account: turbulent flow 
of the air around the beaker, heat transfer in all domains, and transport of water vapor in 
the air. This is a real multiphysics problem and this tutorial shows how to set it up.

Air Domain

Beaker Filled 
with Water

Symmetry Axis
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TU R B U L E N T  F L O W

The air flow is modeled with the Turbulent Flow, Low Re k-ε interface, because the 
Reynolds number is about 1500 and turbulent effects must be considered. In addition 
they must be taken into account in the transport equations correctly. With the Low Re k-ε 
turbulence model, the turbulence variables are solved in the whole domain down to the 
walls and thus provide accurate input values for the transport equations. Assuming that the 
velocity and pressure field are independent of the air temperature and moisture content. 
This allows to calculate the turbulent flow field in advance and then use it as input for the 
heat transfer and species transport equations.

H E A T  TR A N S F E R

The heat transfer inside the beaker and water is due to conduction only. For the air, 
convection dominates the heat transfer and the turbulent flow field is required. The 
material properties are determined by the moist air theory. 

During evaporation, latent heat is released from the water surface which cools down the 
water in addition to convective and conductive cooling by the surrounding. This 
additional heat flux depends on the amount of evaporated water. This means that the 
fraction of convective and diffusive flux normal to the water surface contributes to the 
evaporative heat flux.

 (1)

The latent heat of vaporization Hvap is given in kJ/mol.

TR A N S P O R T  O F  W A T E R  V A P O R

To obtain the correct amount of water which is evaporated from the beaker into the air, 
the Transport of Diluted Species interface is used in the air domain. The initial 
concentration is chosen so that there is an initial relative humidity of 20 %. The source 
term for water vapor at the water surface is given by the ideal gas law at saturation pressure.

 (2)

The transport equation again uses the turbulent flow field as input. Turbulence must also 
be considered for the diffusion coefficient, by adding the following turbulent diffusivity to 
the diffusion tensor:

 (3)

n– k T∇–( )⋅ Hvapn D c uc+∇–( )⋅=

cvap
psat
RgT
-----------=

DT
νT

ScT
----------I=
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where νT is the turbulent kinematic viscosity, ScT is the turbulent Schmidt number and I 
the unit matrix.

Results and Discussion

The image below shows the temperature field after 20 s with streamlines indicating the 
flow field.

Figure 2: Temperature distribution after 20 min and streamlines indicating the flow field.
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Due to convection, conduction, and evaporation the water cools down over time. As 
shown in Figure 3 the average temperature after 20 minutes is about 61 °C.

Figure 3: Average water temperature over time.

Figure 4 shows the concentration and relative humidity at the symmetry plane. Close to 
the water surface, the relative humidity is about 100% as expected. Behind the beaker the 
relative humidity can become even smaller than 20%. Due to the high temperature, air can 
absorb a higher amount of water.
5 |  E V A P O R A T I V E  C O O L I N G  O F  W A T E R



Figure 4: Concentration distribution and contour lines for the relative humidity.

A last study computes for a fictive situation where the evaporation effects are neglected. 
Figure 5 shows the comparison between average water temperatures with and without 
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evaporation to see the its importance in the cooling process. A difference of 6 K can be 
observed.

Figure 5: Average water temperature with and without evaporation accounted.

Application Library path: Heat_Transfer_Module/Phase_Change/
evaporative_cooling

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

The first step is to compute the turbulent flow field. After that, the resulting velocity field 
will be used to compute the transport properties of heat and moisture. To get accurate 
input values for the turbulent transport equations, the Low-Reynolds k-ε turbulence 
model is used here.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Fluid Flow>Single-Phase Flow>Turbulent Flow>Turbulent 

Flow, Low Re k-ε (spf).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary with Initialization.

6 Click Done.

G E O M E T R Y  1

Load the geometry sequence from an existing MPH file.

1 On the Geometry toolbar, click Insert Sequence.

2 Browse to the application’s Application Libraries folder and double-click the file 
evaporative_cooling_geom_sequence.mph.

Cone 1 (cone1)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Cone 1 

(cone1).

2 In the Settings window for Cone, click Build All Objects.

3 Click the Wireframe Rendering button on the Graphics toolbar.

The flow calculation is done for the air domain only. For now, air is the only material 
you need.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Air.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Air (mat1)
On the Home toolbar, click Add Material to close the Add Material window.
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TU R B U L E N T  F L O W,  L O W  R E  K - ε ( S P F )

Since the density variation is not small, the flow can not be regarded as incompressible. 
Therefore set the flow to be compressible.

1 In the Model Builder window, under Component 1 (comp1) click Turbulent Flow, Low Re 

k-ε (spf).

2 In the Settings window for Turbulent Flow, Low Re k-ε, locate the Physical Model 
section.

3 From the Compressibility list, choose Compressible flow (Ma<0.3).

4 Locate the Domain Selection section. Click Clear Selection.

5 Select Domain 1 only.

Create a selection from this domain. It can be used later to create new selections or to 
assign physical properties.

6 Click Create Selection.

7 In the Create Selection dialog box, type Air in the Selection name text field.

8 Click OK.

Now, define the boundary conditions.

Inlet 1
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 Select Boundary 33 only.

3 In the Settings window for Inlet, locate the Velocity section.

4 In the U0 text field, type 2.

Open Boundary 1
1 On the Physics toolbar, click Boundaries and choose Open Boundary.

2 Select Boundary 1 only.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundary 2 only.

The default Physics-controlled mesh is used. It is optimized for flow field calculations using 
a suitable mesh size and boundary layers according to the settings of the flow interface.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.
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2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Extra coarse.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Velocity (spf)
1 Click the Zoom Extents button on the Graphics toolbar.

The resulting velocity field is shown below:

With this velocity field, the transport equations can be computed. The Heat Transfer in 

Fluids interface together with the Transport of Diluted Species interface are used to 
describe the transport of heat and water vapor and the interaction of both processes.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Heat Transfer>Heat Transfer in Fluids (ht).
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4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Study 1.

5 Click Add to Component in the window toolbar.

A D D  P H Y S I C S

1 Go to the Add Physics window.

2 In the tree, select Chemical Species Transport>Transport of Diluted Species (tds).

3 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Study 1.

4 Click Add to Component in the window toolbar.

The transport equation is active in the air domain only, precisely where the flow equation 
was solved.

TR A N S P O R T  O F  D I L U T E D  S P E C I E S  ( T D S )

1 On the Home toolbar, click Add Physics to close the Add Physics window.

2 In the Model Builder window, under Component 1 (comp1) click Transport of Diluted 

Species (tds).

3 In the Settings window for Transport of Diluted Species, locate the Domain Selection 
section.

4 From the Selection list, choose Air.

M A T E R I A L S

Add the materials needed for the heat transfer calculations.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Water, liquid.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Water, liquid (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Water, liquid 

(mat2).

2 Select Domain 3 only.
11 |  E V A P O R A T I V E  C O O L I N G  O F  W A T E R



3 In the Settings window for Material, locate the Geometric Entity Selection section.

4 Click Create Selection.

5 In the Create Selection dialog box, type Water in the Selection name text field.

6 Click OK.

With this selection and the one for the air domain, it is easy to create the selection for the 
glass body.

D E F I N I T I O N S

Complement 1
1 On the Definitions toolbar, click Complement.

2 In the Settings window for Complement, type Glass in the Label text field.

3 Locate the Input Entities section. Under Selections to invert, click Add.

4 In the Add dialog box, In the Selections to invert list, choose Air and Water.

5 Click OK.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Glass (quartz).

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Glass (quartz) (mat3)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Glass (quartz) 

(mat3).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Glass.

4 On the Home toolbar, click Add Material to close the Add Material window.

H E A T  TR A N S F E R  I N  F L U I D S  ( H T )

On the Physics toolbar, click Transport of Diluted Species (tds) and choose Heat Transfer in 

Fluids (ht).

This switches to the Heat Transfer in Fluids interface.

Configure the settings of Heat Transfer in Fluids 1 for the water domain. To save 
computational time, the velocity field driven by natural convection is not computed. 
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Instead, an increased thermal conductivity determined by built-in Nusselt number 
correlations is defined in the next steps to compensate the missing convective heat flux.

Fluid 1
1 In the Model Builder window’s toolbar, click the Show button and select Advanced Physics 

Options in the menu.

2 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Fluids (ht) 
click Fluid 1.

3 In the Settings window for Fluid, click to expand the Equivalent conductivity for 

convection section.

4 Locate the Equivalent Conductivity for Convection section. Select the Equivalent 

conductivity for convection check box.

5 From the Nusselt number correlation list, choose Vertical rectangular cavity.

6 In the H text field, type 7.5[cm].

7 In the L text field, type 3[cm].

8 In the ΔT text field, type 3.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Fluids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, choose Ambient temperature (ht) from the T 
list.

Now, add a second Heat Transfer in Fluids node for the air domain. Here, the 
thermodynamic properties will be determined for moist air. This also enables additional 
postprocessing variables such as relative humidity.

3 In the Model Builder window, click Heat Transfer in Fluids (ht).

Fluid 2
1 On the Physics toolbar, click Domains and choose Fluid.

2 In the Settings window for Fluid, locate the Domain Selection section.

3 From the Selection list, choose Air.

The humidity is obtained from the concentration distribution calculated within the 
Transport of Diluted Species interface.

4 Locate the Thermodynamics, Fluid section. From the Fluid type list, choose Moist air.

5 From the Input quantity list, choose Concentration.
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6 Locate the Model Inputs section. From the c list, choose Concentration (tds).

In the glass body, heat is only transported by conduction.

Then, add a Heat Transfer in Solids node for the glass domain.

Solid 1
1 On the Physics toolbar, click Domains and choose Solid.

2 In the Settings window for Solid, locate the Domain Selection section.

3 From the Selection list, choose Glass.

The air enters the domain at room temperature. At the outlet, heat is transported by 
convection.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 33 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 From the T0 list, choose Ambient temperature (ht).

Open Boundary 1
1 On the Physics toolbar, click Boundaries and choose Open Boundary.

2 Select Boundary 1 only.

3 In the Settings window for Open Boundary, locate the Open Boundary section.

4 From the T0 list, choose Ambient temperature (ht).

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Click the Go to YZ View button on the Graphics toolbar.

3 Click the Select Box button on the Graphics toolbar.

With this tool, draw a box around all symmetry boundaries, which corresponds to:
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4 Select Boundaries 2, 6, 11, 13, 18, 31, and 32 only.

You should see the following in your Graphics window:

The fluid in the beaker has an initial temperature of 80 °C.

Initial Values 2
1 On the Physics toolbar, click Domains and choose Initial Values.

2 Select Domain 3 only.

3 In the Settings window for Initial Values, locate the Domain Selection section.

4 From the Selection list, choose Water.

5 In the T text field, type 80[degC].

The water will cool down over time. To include the heat loss by evaporation, add a heat 
source at appropriate boundaries according to Equation 1.

Boundary Heat Source 1
1 On the Physics toolbar, click Boundaries and choose Boundary Heat Source.

2 Select Boundary 12 only.

3 In the Settings window for Boundary Heat Source, locate the Boundary Heat Source 
section.

4 In the Qb text field, type -H_vap*c_lm[mol/(s*m^2)].
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The two variables H_vap and c_lm in this expression are not defined yet. The Lagrange 
multiplier, c_lm, is the flux corresponding to a prescribed concentration condition at this 
boundary. This variable will hence be defined later in the Transport of Diluted Species 
physics interface yet to be created. For H_vap, use the global parameters to define it 
according to the steps below.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

To couple the flow field in the air domain to the heat transport equation, follow the steps 
below:

M U L T I P H Y S I C S

Non-Isothermal Flow 1 (nitf1)
On the Physics toolbar, click Multiphysics and choose Domain>Non-Isothermal Flow.

The water inside the beaker is assumed to be at rest. To disable the flow coupling there, 
go back to the heat transfer in fluids node and set the velocity field to zero.

H E A T  TR A N S F E R  I N  F L U I D S  ( H T )

Fluid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Fluids (ht) 

click Fluid 1.

2 In the Settings window for Fluid, locate the Model inputs section.

3 Click Make All Model Inputs Editable in the upper-right corner of the section. Locate the 
Model Inputs section. From the T list, choose Temperature (ht).

The next step is to set up the Transport of Diluted Species interface which is active in the air 
domain only. Use the Flow Coupling feature from the Multiphysics node and define the 
diffusion coefficient for water in air.

Name Expression Value Description

M_w 18.015[g/mol] 0.01802 kg/mol Molar mass of water

H_vap 2454[kJ/kg]*M_w 4.421E4 J/mol Heat of vaporization
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M U L T I P H Y S I C S

Flow Coupling 1 (fc1)
1 On the Physics toolbar, click Multiphysics and choose Global>Flow Coupling.

2 In the Settings window for Flow Coupling, locate the Coupled Interfaces section.

3 From the Destination list, choose Transport of Diluted Species (tds).

TR A N S P O R T  O F  D I L U T E D  S P E C I E S  ( T D S )

Define the diffusion coefficient for water vapor taking into account turbulent effects 
according to Equation 3.

Transport Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Transport of Diluted Species 

(tds) click Transport Properties 1.

2 In the Settings window for Transport Properties, locate the Diffusion section.

3 In the Dc text field, type 2.6e-5[m^2/s].

Turbulent Mixing 1
1 On the Physics toolbar, click Attributes and choose Turbulent Mixing.

2 In the Settings window for Turbulent Mixing, locate the Turbulent Mixing Parameters 
section.

3 From the νT list, choose Turbulent kinematic viscosity (spf/fp1).

G L O B A L  D E F I N I T I O N S

Parameters
1 In the Model Builder window, under Global Definitions click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

rho_w_max 0.0172[kg/m^3] 0.0172 kg/m³ Maximum amount of 
water for 100% 
humidity at 20°C

rel_hum 0.2 0.2 Relative humidity

c0 rel_hum*
rho_w_max/M_w

0.191 mol/m³ Initial 
concentration
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TR A N S P O R T  O F  D I L U T E D  S P E C I E S  ( T D S )

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Transport of Diluted Species 

(tds) click Initial Values 1.

2 In the Settings window for Initial Values, locate the Initial Values section.

3 In the c text field, type c0.

Concentration 1
1 On the Physics toolbar, click Boundaries and choose Concentration.

2 Select Boundary 33 only.

3 In the Settings window for Concentration, locate the Concentration section.

4 Select the Species c check box.

5 In the c0,c text field, type c0.

At the water surface the saturation pressure is reached and the saturation concentration is 
applied at that boundary, according to Equation 2. With the moist air feature, the 
saturation pressure is calculated automatically and can be accessed directly.

Concentration 2
1 On the Physics toolbar, click Boundaries and choose Concentration.

2 Select Boundary 12 only.

3 In the Settings window for Concentration, locate the Concentration section.

4 Select the Species c check box.

5 In the c0,c text field, type ht.psat/(R_const*T).

In the following steps, use weak constraints for this boundary condition to create the 
Lagrange multiplier, c_lm, that corresponds to the flux. This variable have been used in 
the expression of the heat source at this same boundary in the Heat Transfer in Fluids 
physics interface.

6 Click to expand the Constraint settings section. Locate the Constraint Settings section. 
Select the Use weak constraints check box.

Outflow 1
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 Select Boundary 1 only.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.
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2 Select Boundary 2 only.

Since the turbulent flow is already solved, the new mesh can be optimized for the transport 
equations. A fine mesh at the water-air interface is required.

C O M P O N E N T  1  ( C O M P 1 )

Mesh 2
On the Mesh toolbar, click Add Mesh.

M E S H  2

In the Model Builder window, under Component 1 (comp1)>Meshes right-click Mesh 2 and 
choose Free Tetrahedral.

Free Tetrahedral 1
1 Click the Zoom Extents button on the Graphics toolbar.

2 Click the Go to Default 3D View button on the Graphics toolbar.

Size 1
1 In the Model Builder window, under Component 1 (comp1)>Meshes>Mesh 2 right-click 

Free Tetrahedral 1 and choose Size.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Locate the Element Size section. From the Predefined list, choose Extremely fine.

5 Select Boundary 12 only.

6 Click the Custom button.

7 Locate the Element Size Parameters section. Select the Maximum element size check box.

8 In the associated text field, type 0.15.

Size
1 In the Model Builder window, under Component 1 (comp1)>Meshes>Mesh 2 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Extremely fine.

4 Click the Custom button.

5 Locate the Element Size Parameters section. In the Resolution of narrow regions text field, 
type 1.5.

6 Click Build All.
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7 Click the Go to Default 3D View button on the Graphics toolbar.

Add a transient study to model the cooling over time.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Turbulent Flow, Low Re k-ε (spf) interface.

5 Find the Studies subsection. In the Select Study tree, select Preset Studies>Time 

Dependent.

6 Click Add Study in the window toolbar.

S T U D Y  2

Step 1: Time Dependent
1 On the Home toolbar, click Add Study to close the Add Study window.

2 In the Model Builder window, under Study 2 click Step 1: Time Dependent.

3 In the Settings window for Time Dependent, locate the Study Settings section.
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4 From the Time unit list, choose min.

5 Click Range.

6 In the Range dialog box, type 12[s] in the Step text field.

7 In the Stop text field, type 20.

8 Click Replace.

The second study requires the result from the first one. To make the data from Study 1 
available for Study 2 follow these steps:

9 In the Settings window for Time Dependent, click to expand the Values of dependent 

variables section.

10 Locate the Values of Dependent Variables section. Find the Values of variables not solved 

for subsection. From the Settings list, choose User controlled.

11 From the Method list, choose Solution.

12 From the Study list, choose Study 1, Stationary.

The heat transfer and transport equations are strongly coupled via the moist air feature 
using the concentration as input. This requires to configure a Direct solver in a Fully 

Coupled approach.

Solution 3 (sol3)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 3 (sol3) node, then click 
Time-Dependent Solver 1.

3 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

4 Locate the Time Stepping section. From the Steps taken by solver list, choose 
Intermediate.

5 Right-click Study 2>Solver Configurations>Solution 3 (sol3)>Time-Dependent Solver 1 and 
choose Fully Coupled.

6 Right-click Study 2>Solver Configurations>Solution 3 (sol3)>Time-Dependent Solver 1>

Direct and choose Enable.

7 On the Study toolbar, click Compute.

R E S U L T S

Temperature (ht)
Create the plot shown in Figure 2.
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Surface 2
1 On the Results toolbar, click More Data Sets and choose Surface.

2 In the Settings window for Surface, locate the Data section.

3 From the Data set list, choose Study 2/Solution 3 (sol3).

4 Locate the Selection section. From the Selection list, choose All boundaries.

5 Remove boundaries 1, 2 and 33 from the list.

Temperature (ht)
1 In the Model Builder window, under Results click Temperature (ht).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Data set list, choose Surface 2.

Surface
1 In the Model Builder window, expand the Temperature (ht) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

4 On the Temperature (ht) toolbar, click Streamline.

Streamline 1
1 In the Model Builder window, under Results>Temperature (ht) click Streamline 1.

2 In the Settings window for Streamline, locate the Data section.

3 From the Data set list, choose Study 2/Solution 3 (sol3).

4 Locate the Coloring and Style section. From the Color list, choose White.

5 Locate the Streamline Positioning section. From the Positioning list, choose On selected 

boundaries.

6 Locate the Selection section. Select the Active toggle button.

7 Select Boundary 33 only.

8 Locate the Streamline Positioning section. In the Number text field, type 40.

9 Click the Zoom Extents button on the Graphics toolbar.

10 On the Temperature (ht) toolbar, click Plot.

Data Sets
To visualize the concentration distribution as in Figure 4, follow the next steps.

Cut Plane 1
1 On the Results toolbar, click Cut Plane.
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2 In the Settings window for Cut Plane, locate the Plane Data section.

3 From the Plane list, choose xz-planes.

4 Locate the Data section. From the Data set list, choose Study 2/Solution 3 (sol3).

2D Plot Group 8
1 On the Results toolbar, click 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Concentration and Relative 
Humidity in the Label text field.

3 Locate the Data section. From the Data set list, choose Cut Plane 1.

4 From the Time (min) list, choose 10.

Surface 1
1 Right-click Concentration and Relative Humidity and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Transport of Diluted 

Species>c - Concentration.

3 On the Concentration and Relative Humidity toolbar, click Plot.

Concentration and Relative Humidity
In the Model Builder window, under Results right-click Concentration and Relative Humidity 
and choose Contour.

Contour 1
1 In the Settings window for Contour, click Replace Expression in the upper-right corner 

of the Expression section. From the menu, choose Component 1>Heat Transfer in Fluids>

Moist air>ht.phi - Relative humidity.

2 Locate the Levels section. In the Total levels text field, type 7.

3 Locate the Coloring and Style section. From the Contour type list, choose Tube.

4 Select the Radius scale factor check box.

5 In the associated text field, type 0.025.

6 Select the Level labels check box.

7 In the Precision text field, type 2.

8 From the Label color list, choose White.

9 On the Concentration and Relative Humidity toolbar, click Plot.

The relative humidity decreases quickly with the distance to the surface. Due to the high 
temperature behind the beaker, the relative humidity becomes even lower than 20%.
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Derived Values
It is interesting to see how the average temperature decreases with time.

Volume Average 1
1 On the Results toolbar, click More Derived Values and choose Average>Volume Average.

2 In the Settings window for Volume Average, type Average Water Temperature in the 
Label text field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 3 (sol3).

4 Select Domain 3 only.

5 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component 1>Heat Transfer in Fluids>Temperature>T - Temperature.

6 Locate the Expressions section. In the table, enter the following settings:

7 Click Evaluate.

TA B L E

1 Go to the Table window.

2 Click Table Graph in the window toolbar.

R E S U L T S

1D Plot Group 9
1 In the Model Builder window, under Results click 1D Plot Group 9.

2 In the Settings window for 1D Plot Group, type Average Water Temperature over 
Time in the Label text field.

Finally, compute how much water is evaporated in the air.

Surface Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 In the Settings window for Surface Integration, type Amount of Evaporated Water 
in the Label text field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 3 (sol3).

4 Select Boundary 12 only.

Expression Unit Description

T degC Temperature
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5 Locate the Expressions section. In the table, enter the following settings:

6 Locate the Data Series Operation section. From the Operation list, choose Integral.

7 Click New Table.

TA B L E

1 Go to the Table window.

The factor 2 in the expression is based on the use of a symmetry condition. Within 
20 minutes, about 2.5 g of water have been evaporated.

R O O T

Repeat now the previous instructions to create a third study that solves for a fictive model 
where evaporation is neglected. A comparison with the results returned by Study 2 would 
then highlight and quantify the cooling effects of evaporation.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Turbulent Flow, Low Re k-ε (spf) interface.

5 Find the Studies subsection. In the Select Study tree, select Preset Studies>Time 

Dependent.

6 Click Add Study in the window toolbar.

S T U D Y  3

Step 1: Time Dependent
1 On the Home toolbar, click Add Study to close the Add Study window.

2 In the Model Builder window, under Study 3 click Step 1: Time Dependent.

3 In the Settings window for Time Dependent, locate the Study Settings section.

4 From the Time unit list, choose min.

5 Click Range.

6 In the Range dialog box, type 12[s] in the Step text field.

Expression Unit Description

2*tds.dflux_cz*M_w kg/s
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7 In the Stop text field, type 20.

8 Click Replace.

9 In the Settings window for Time Dependent, locate the Physics and Variables Selection 
section.

10 Select the Modify physics tree and variables for study step check box.

11 In the Physics and variables selection tree, select Component 1 (comp1)>Heat Transfer in 

Fluids (ht)>Boundary Heat Source 1.

12 Click Disable.

By disabling Boundary Heat Source 1 in this study, evaporation is neglected.

13 Click to expand the Values of dependent variables section. Locate the Values of Dependent 

Variables section. Find the Values of variables not solved for subsection. From the Settings 
list, choose User controlled.

14 From the Method list, choose Solution.

15 From the Study list, choose Study 1, Stationary.

Solution 4 (sol4)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 4 (sol4) node, then click 
Time-Dependent Solver 1.

3 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

4 Locate the Time Stepping section. From the Steps taken by solver list, choose 
Intermediate.

5 Right-click Study 3>Solver Configurations>Solution 4 (sol4)>Time-Dependent Solver 1 and 
choose Fully Coupled.

6 Right-click Study 3>Solver Configurations>Solution 4 (sol4)>Time-Dependent Solver 1>

Direct and choose Enable.

7 On the Study toolbar, click Compute.

R E S U L T S

Derived Values
Compute the average temperature of water when evaporation is neglected.

Volume Average 2
1 On the Results toolbar, click More Derived Values and choose Average>Volume Average.
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2 In the Settings window for Volume Average, type Average Water Temperature, 
Evaporation Neglected in the Label text field.

3 Locate the Data section. From the Data set list, choose Study 3/Solution 4 (sol4).

4 Select Domain 3 only.

5 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component 1>Heat Transfer in Fluids>Temperature>T - Temperature.

6 Locate the Expressions section. In the table, enter the following settings:

7 Click Table 1 - Average Water Temperature (T).

Table Graph 1
1 In the Model Builder window, under Results>Average Water Temperature over Time click 

Table Graph 1.

2 In the Settings window for Table Graph, click to expand the Legends section.

3 Select the Show legends check box.

4 From the Legends list, choose Manual.

5 In the table, enter the following settings:

6 On the Average Water Temperature over Time toolbar, click Plot.

In this model, evaporation accounts for a decrease of about 6 K at the end of the 
simulation (see Figure 5).

Expression Unit Description

T degC Temperature

Legends

Temperature (degC), evaporation accounted

Temperature (degC), evaporation neglected
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Introduction

Fluid dampers are used in military devices for shock isolation and in civil structures for 
suppressing earthquake-induced shaking and wind-induced vibrations, among many other 
applications. Fluid dampers work by dissipating the mechanical energy into heat (Ref. 1). 
This example shows the phenomenon of viscous heating and consequent temperature 
increase in a fluid damper. Viscous heating is also important in microflow devices, where 
a small cross-sectional area and large length of the device can generate significant heating 
and affect the fluid flow consequently (Ref. 2). 

Model Definition

The structural elements of a fluid damper are relatively few. Figure 1 depicts a schematic 
of the fluid damper modeled herein with its main components: damper cylinder housing, 
piston rod, piston head, and viscous fluid in the chamber. There is a small annular space 
between the piston head and the inside wall of the cylinder housing. This acts as an 
effective channel for the fluid. As the piston head moves back and forth inside the damper 
cylinder, fluid is forced to pass through the annular channel with large shear rate, which 
leads to significant heat generation. The heat is transferred in both the axial and radial 
directions. In the radial direction, the heat is conducted through the cylinder house wall 
and convected to the air outside the damper, which is modeled using the Newton’s 
convective cooling law. 

Figure 1: A sketch of a typical fluid damper with its major components

You make use of the axially symmetric nature of the fluid damper and model it in a 
2D-axisymmetric geometry as shown in Figure 2. The geometric dimensions and other 
parameters of the damper are taken according to Ref. 1 to represent the smaller, 15 kip 
damper experimentally studied therein. Thus, the piston head has a diameter of 8.37 cm, 
the piston rod diameter is 2.83 cm, and the gap thickness is about 1/100 of the piston 

Cylinder Fluid

Piston rod

Chamber 1 Chamber 2

Fistor head

Orifice

P(t)
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head diameter. The damper has the maximum stroke U0 of 0.1524 m. The damper solid 
parts are made of steel, and the damping fluid is silicone oil.

Figure 2: Geometry and mesh. The domains (from left to right) represent: piston rod, piston 
head and damping fluid space, the damper outer wall.

F L U I D  F L OW

The fluid flow in the fluid damper is described by the weakly compressible Navier-Stokes 
equations, solving for the velocity field u = (u, w) and the pressure p:

The density is assumed independent of the temperature, while the temperature 
dependence of the fluid viscosity is taken into account as:

 (1)

ρ
t∂

∂u ρu ∇u⋅+ ∇– p ∇ μ ∇u ∇u( )T
+( ) 2

3
---μ ∇ u⋅( )I– 

 ⋅+=

t∂
∂ρ ∇+ ρu( )⋅ 0=

μ μ0 α T T0–( )–=
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The reference material properties of silicone oil are used.

No Slip wall boundary conditions are applied for both ends of the damper cylinder and on 
the inner wall of the damper cylinder house. Moving/sliding wall with the given velocity 
is applied on the boundaries of the piston head and on the piston rod.

C O N J U G A T E  H E A T  T R A N S F E R

The conjugate heat transfer is solved both in the fluid domain and the damper cylinder 
house wall: heat transfer by convection and conduction in the fluid domain, heat transfer 
by conduction only in the solid domain, and the temperature field is continuous between 
the fluid and solid domains. In the fluid domain, the viscous heating is activated and 
pressure work can be included when the slight compressibility of the damper fluid needs 
to be considered:

where the first term and second terms on the right-hand side represent the heat source 
from pressure work and viscous dissipation, respectively. Hence, the problem is a fully 
coupled fluid-thermal interaction problem.

In the solid domain of the cylinder house wall, this equation reduces to conductive heat 
transfer equation without any heating source.

The heat flux boundary condition based on the Newton’s cooling law is applied on the 
outside boundaries of the cylinder house wall. The temperature field is continuous 
between the fluid and solid domains. The ends of the damper connected to the structures 
outside are kept at constant temperature.

The piston head movement is provided as harmonic oscillations with given amplitude and 
frequency, z = a0sin(2πf). The motion is modeled using the arbitrary Lagrangian-Eulerian 
(ALE) deformed mesh. The ALE method handles the dynamics of the deforming 
geometry and the moving boundaries with a moving grid. The Navier-Stokes equations 
for fluid flow and heat equations for temperature variation are formulated in these moving 
coordinates.

Results and Discussion

The modeled loading has the amplitude of 0.127 m, and the excitation frequency is 
0.4 Hz. This represents the long-stroke loading experiment performed in Ref. 1. The 
loading time period is 40 s.

ρCp t∂
∂T ρCpu T∇⋅ ∇ q⋅+ + αpT

t∂
∂p

– μ u∇ u∇( )T 2
3
--- ∇ u⋅( )I–+ : u∇ Q+ +=
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Note that the simulation results for the temperature are presented in degrees Fahrenheit 
for the sake of easier comparison with the experimental measurements.

Figure 3 gives the temperature field in the damper at the end the loading. It also shows a 
typical streamline configuration for the flow induced in the damping fluid.

Figure 3: Temperature field in the damper at the end of simulation.

Figure 4 shows the temperature of the inner wall of the damper at the end-of-stroke 
position z = U0. This corresponds to the internal probe position under experiments 
performed in Ref. 1. The simulation results show very good agreement with the 
experimental measurements (see Fig. 9 in Ref. 1).
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Figure 4: Temperature at the probe position.

Figure 5 shows the temperature variation along the inner wall of the damper after 10 s and 
40 s of loading. It clearly shows that the temperature at the probe position does not 
represent the maximum temperature within the damper. This supports the conclusion 
drawn in Ref. 1, where the choice of the probe positioning was limited by the construction 
of the outer shell of the damper. Figure 5 also shows that the temperature near the center 
of the damper increases by more than 100 degrees already after few loading cycles.
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Figure 5: Temperature of the damper inner wall. The probe position corresponds to z ⁄ U0 = 1.

Notes About the COMSOL Implementation

You decompose the computational domain into several parts and mesh the domains with 
mapped meshes to resolve the very thin annular space. For the moving mesh you prescribe 
the displacement of the mesh in each domain so that their alignment remains unchanged 
with a zero displacement at the top and the bottom of the damper cylinder housing 
connecting to the high-performance seal, and the displacement equal to that of the piston 
head is used for the domain lined up with the piston head. This is achieved by specifying 
the mesh displacement field as a linear function of the deformed mesh frame coordinate 
and the reference (material) frame coordinate. 

The steel material needed for the damper solid parts is available in the built-in material 
library. You create a user-defined material for the silicone oil. Such damping fluids are 
typically characterized by the density, kinematic viscosity at the temperature 25º C, and 
so-called viscosity temperature coefficient, VTC = 1−(viscosity at 98.9º C)/(viscosity at 
37.8º C). Using this parameters, you create the linear correlation for the dynamic viscosity 
given by Equation 1.
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Application Library path: Heat_Transfer_Module/
Buildings_and_Constructions/fluid_damper

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Heat Transfer>Conjugate Heat Transfer>Laminar Flow.

3 Click Add.

4 In the Select Physics tree, select Mathematics>Deformed Mesh>Moving Mesh (ale).

5 Click Add.

6 Click Study.

7 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Time 

Dependent.

8 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.
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4 Browse to the application’s Application Libraries folder and double-click the file 
fluid_damper_parameters.txt.

D E F I N I T I O N S

Variables 1
1 On the Home toolbar, click Variables and choose Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
fluid_damper_variables.txt.

G E O M E T R Y  1

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type Dr/2.

4 In the Height text field, type 2*Ld.

5 Locate the Position section. In the z text field, type -Ld.

Rectangle 2 (r2)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type Dp/2.

4 In the Height text field, type 2*Ld.

5 Locate the Position section. In the z text field, type -Ld.

Rectangle 3 (r3)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type Dd/2-Hw.

4 In the Height text field, type 2*Ld.

5 Locate the Position section. In the z text field, type -Ld.

Rectangle 4 (r4)
1 On the Geometry toolbar, click Primitives and choose Rectangle.
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2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type Dd/2.

4 In the Height text field, type 2*Ld.

5 Locate the Position section. In the z text field, type -Ld.

Rectangle 5 (r5)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type Dd/2.

4 In the Height text field, type 2*Lp.

5 Locate the Position section. In the z text field, type -Lp.

6 On the Geometry toolbar, click Build All.

7 Click the Zoom Extents button on the Graphics toolbar.

The model geometry is now complete.

L A M I N A R  F L O W  ( S P F )

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

2 Select Domains 4 and 6–9 only.

H E A T  TR A N S F E R  ( H T )

On the Physics toolbar, click Laminar Flow (spf) and choose Heat Transfer (ht).

Fluid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Fluid 

1.

2 Select Domains 4 and 6–9 only.

3 In the Settings window for Fluid, locate the Thermodynamics, Fluid section.

4 From the γ list, choose User defined.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Steel AISI 4340.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.
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M A T E R I A L S

In the following steps, you create a new material for the damping fluid, Silicone Oil.

Material 2 (mat2)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Silicon Oil in the Label text field.

3 Select Domains 4 and 6–9 only.

Silicon Oil (mat2)
1 In the Model Builder window, expand the Component 1 (comp1)>Materials>Silicon Oil 

(mat2) node, then click Basic (def).

2 In the Settings window for Property Group, locate the Output Properties and Model 

Inputs section.

3 Find the Quantities subsection. In the tree, select Model Inputs>Temperature.

4 Click Add.

5 Locate the Local Properties section. In the Local properties table, enter the following 
settings:

6 In the Model Builder window, click Silicon Oil (mat2).

7 In the Settings window for Material, locate the Material Contents section.

8 In the table, enter the following settings:

Property Expression Unit

nu_25C 0.0125[m^2/s] m²/s

VTC 0.6[1]

Property Name Value Unit Property 
group

Thermal conductivity k 22.5 W/(m·K) Basic

Density rho 950 kg/m³ Basic
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M OV I N G  M E S H  ( A L E )

On the Physics toolbar, click Heat Transfer (ht) and choose Moving Mesh (ale).

1 In the Model Builder window, under Component 1 (comp1) click Moving Mesh (ale).

2 In the Settings window for Moving Mesh, locate the Frame Settings section.

3 From the Geometry shape order list, choose 1.

Prescribed Deformation 1
1 On the Physics toolbar, click Domains and choose Prescribed Deformation.

2 Select Domains 2, 5, 8, and 11 only.

3 In the Settings window for Prescribed Deformation, locate the Prescribed Mesh 

Displacement section.

4 In the dz text-field array, type zp on the 2nd row.

Prescribed Deformation 2
1 On the Physics toolbar, click Domains and choose Prescribed Deformation.

2 Select Domains 1, 4, 7, and 10 only.

3 In the Settings window for Prescribed Deformation, locate the Prescribed Mesh 

Displacement section.

4 In the dz text-field array, type zlin1 on the 2nd row.

Prescribed Deformation 3
1 On the Physics toolbar, click Domains and choose Prescribed Deformation.

2 Select Domains 3, 6, 9, and 12 only.

3 In the Settings window for Prescribed Deformation, locate the Prescribed Mesh 

Displacement section.

Heat capacity at constant 
pressure

Cp 2e3 J/(kg·K) Basic

Dynamic viscosity mu nu_25C*
rho*
(1-VTC*
(T-311[K]
)/
(61[K]))/
(1+VTC*
0.2107)

Pa·s Basic

Property Name Value Unit Property 
group
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4 In the dz text-field array, type zlin2 on the 2nd row.

L A M I N A R  F L O W  ( S P F )

In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

Wall 2
1 On the Physics toolbar, click Boundaries and choose Wall.

2 Select Boundaries 11 and 13 only.

3 In the Settings window for Wall, locate the Boundary Condition section.

4 From the Boundary condition list, choose Moving wall.

5 Specify the uw vector as

Wall 3
1 On the Physics toolbar, click Boundaries and choose Wall.

2 Select Boundaries 8, 12, and 17 only.

3 In the Settings window for Wall, locate the Boundary Condition section.

4 From the Boundary condition list, choose Sliding wall.

5 In the Uw text field, type d(zp,t).

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Laminar Flow (spf) click Initial 

Values 1.

2 In the Settings window for Initial Values, locate the Initial Values section.

3 In the p text field, type p0.

H E A T  TR A N S F E R  ( H T )

On the Physics toolbar, click Laminar Flow (spf) and choose Heat Transfer (ht).

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Initial 

Values 1.

2 In the Settings window for Initial Values, type T0 in the T text field.

3 In the Model Builder window, click Heat Transfer (ht).

0 r

d(zp,t) z
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Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundaries 2, 7, 9, 14, 16, 21, 23, and 28 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type T0.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 29–31 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the Text text field, type T0.

6 In the h text field, type hwall.

L A M I N A R  F L O W  ( S P F )

Because the damper is a closed container, you need to pin-point the pressure level within. 
To achieve that, use the point constraint as follows.

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

Pressure Point Constraint 1
1 On the Physics toolbar, click Points and choose Pressure Point Constraint.

2 Select Point 12 only.

3 In the Settings window for Pressure Point Constraint, locate the Pressure Constraint 
section.

4 In the p0 text field, type p0.

M U L T I P H Y S I C S

1 In the Model Builder window, under Component 1 (comp1)>Multiphysics click 
Non-Isothermal Flow 1 (nitf1).

2 In the Settings window for Non-Isothermal Flow, locate the Flow Heating section.

3 Select the Include work done by pressure changes check box.

4 Select the Include viscous dissipation check box.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Mapped.
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Mapped 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Mapped 1 and 
choose Distribution.

Distribution 1
1 Select Boundaries 23, 25, 27, and 28 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 From the Distribution properties list, choose Predefined distribution type.

4 In the Number of elements text field, type 4.

5 In the Element ratio text field, type 4.

6 From the Distribution method list, choose Geometric sequence.

7 Select the Reverse direction check box.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 2
1 Select Boundaries 1, 5, 8, 12, 15, 19, 22, 26, 29, and 31 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 From the Distribution properties list, choose Predefined distribution type.

4 In the Number of elements text field, type 32.

5 In the Element ratio text field, type 8.

6 From the Distribution method list, choose Geometric sequence.

7 Select the Symmetric distribution check box.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 3
1 Select Boundaries 9, 11, 13, and 14 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 From the Distribution properties list, choose Predefined distribution type.

4 In the Number of elements text field, type 30.

5 In the Element ratio text field, type 10.

6 From the Distribution method list, choose Geometric sequence.

7 Select the Symmetric distribution check box.
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Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 4
1 Select Boundaries 16, 18, 20, and 21 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 8.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 5
1 Select Boundaries 3, 10, 17, 24, and 30 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 32.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 6
1 Select Boundaries 2, 4, 6, and 7 only.

2 In the Model Builder window, click Mesh 1.

3 In the Settings window for Mesh, click Build All.

The mesh is now complete. It should look similar to that shown in Figure 2.

S T U D Y  1

Step 1: Time Dependent
Start the simulation when the piston is in the lowest position consistent with the steady 
flow initial conditions.

This will not give constant temperature at t = 0, but the overall effect is small.

1 In the Model Builder window, expand the Study 1 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type -0.25/f range(0,tstep,tmax).

4 Click to expand the Results while solving section. Locate the Results While Solving section. 
Select the Plot check box.
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Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Study 1>Solver Configurations node.

3 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Time-Dependent Solver 1.

4 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

To control the time-step manually, use the Generalized alpha time stepping method.

5 Locate the Time Stepping section. From the Method list, choose Generalized alpha.

6 From the Steps taken by solver list, choose Manual.

7 In the Time step text field, type tstep/20.

8 In the Amplification for high frequency text field, type 0.5.

Before computing the solution, set up some plots, including the one to display in the 
Graphics window while solving.

R E S U L T S

Cut Point 2D 1
On the Results toolbar, click Cut Point 2D.

Data Sets
1 In the Settings window for Cut Point 2D, locate the Point Data section.

2 In the r text field, type Dd/2-Hw.

3 In the z text field, type U0.

2D Plot Group 1
1 On the Results toolbar, click 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Temperature Surface and 
Velocity Streamlines, 2D in the Label text field.

Temperature Surface and Velocity Streamlines, 2D
1 Right-click Temperature Surface and Velocity Streamlines, 2D and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degF.

4 In the Expression text field, type T.

5 Right-click Temperature Surface and Velocity Streamlines, 2D and choose Streamline.
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6 In the Settings window for Streamline, click Replace Expression in the upper-right corner 
of the Expression section. From the menu, choose Component 1 (comp1)>Heat Transfer>

ht.ur,ht.uz - Velocity field (Spatial).

7 Locate the Streamline Positioning section. From the Positioning list, choose Start point 

controlled.

1D Plot Group 2
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Temperature along Inner Wall in 
the Label text field.

Line Graph 1
On the Temperature along Inner Wall toolbar, click Line Graph.

Temperature along Inner Wall
1 In the Settings window for Line Graph, locate the y-Axis Data section.

2 In the Expression text field, type T.

3 Select Boundaries 22, 24, and 26 only.

4 From the Unit list, choose degF.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type z/U0.

7 In the Model Builder window, click Temperature along Inner Wall.

8 In the Settings window for 1D Plot Group, click to expand the Title section.

9 From the Title type list, choose Manual.

10 In the Title text area, type Temperature along inner wall.

11 Locate the Plot Settings section. Select the x-axis label check box.

12 In the associated text field, type z/U0.

13 Select the y-axis label check box.

14 In the associated text field, type T (degF).

1D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Inner Wall Temperature at 
End-of-Stroke Position in the Label text field.

Point Graph 1
On the Inner Wall Temperature at End-of-Stroke Position toolbar, click Point Graph.
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Inner Wall Temperature at End-of-Stroke Position
1 In the Settings window for Point Graph, locate the y-Axis Data section.

2 In the Expression text field, type T.

3 Locate the Data section. From the Data set list, choose Cut Point 2D 1.

4 Locate the y-Axis Data section. From the Unit list, choose degF.

5 In the Model Builder window, click Inner Wall Temperature at End-of-Stroke Position.

6 In the Settings window for 1D Plot Group, click to expand the Axis section.

7 Locate the Title section. From the Title type list, choose Manual.

8 In the Title text area, type Temperature of inner wall at end-of-stroke 
position.

9 Locate the Plot Settings section. Select the x-axis label check box.

10 In the associated text field, type time (s).

11 Select the y-axis label check box.

12 In the associated text field, type T (degF).

S T U D Y  1

Now return to the Study 1 branch to compute the solution.

Step 1: Time Dependent
1 In the Model Builder window, under Study 1 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, locate the Results While Solving section.

3 From the Plot group list, choose Inner Wall Temperature at End-of-Stroke Position.

4 On the Home toolbar, click Compute.

R E S U L T S

Temperature Surface and Velocity Streamlines, 2D
During the solution time, a plot of the temperature at the probe position will be displayed 
and updated following the solver time steps.

When the solution is finished, click the Zoom Extents button on the Graphics toolbar. This 
will produce a plot of the temperature field and the flow streamlines within the damper, 
which should appear similar to that shown in Figure 3.

Temperature along Inner Wall
1 In the Model Builder window, under Results click Temperature along Inner Wall.

2 In the Settings window for 1D Plot Group, locate the Data section.
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3 From the Time selection list, choose From list.

4 In the Times (s) list, choose 10 and 40.

5 On the Temperature along Inner Wall toolbar, click Plot.

This will show the temperature distribution along the damper inner wall at times 10 s 
and 40 s, it should look similar to that shown in Figure 5.

Inner Wall Temperature at End-of-Stroke Position
1 In the Model Builder window, under Results click Inner Wall Temperature at End-of-Stroke 

Position.

2 On the Inner Wall Temperature at End-of-Stroke Position toolbar, click Plot.

This will show the temperature variation at the probe position aver the complete loading 
time period, it should look similar to that shown in Figure 4.
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Introduction

In glass production, the glass melt is cooled down mainly by radiation. To avoid stresses it 
is important to evenly cool the glass body.

Numerical treatment of radiative heat transfer helps to optimize this cooling process. The 
governing equation—the Radiative Transfer Equation (RTE)—is an integro-differential 
equation that requires a lot of computational cost to be solved. Therefore, COMSOL 
Multiphysics offers three common methods to solve the RTE along with the heat transfer 
equation.

This tutorial is intended to show the typical set up of all methods computing the heat 
transfer by radiation inside a gray medium.

Figure 1: Cylindrical glass plate.

Model Definition

The model geometry is shown in Figure 1. It is a cylinder with of radius r = 5 cm and 
height h = 1.5 cm. The radiative cooling starts from an initial temperature of 600 °C due 
to radiation into an ambient surrounding at 20° C. Convective cooling is neglected, which 
is reasonable for high temperatures as in this model.
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The material properties for the glass body are summarized in Table 1. 

Scattering effects are neglected. For the absorption coefficient a parametric sweep is used 
to get results for k = 5, 70, 120. The boundaries of the glass body have a surface emissivity, 
ε, equal to 1.

T H E R M A L  A N A L Y S I S

A detailed explanation about the discrete ordinates method and the P1 method can be 
found in Radiative Heat Transfer in Finite Cylindrical Media or Radiative Heat Transfer in 
Finite Cylindrical Media—P1 Method respectively.

The Rosseland approximation is a simplified method that results in an additional nonlinear 
term for the thermal conductivity. Hence, this method has almost no impact on the 
computational cost.

For large optical thickness where the integral of the absorption coefficient along a typical 
path is large, radiation effects only spread at its close surrounding and does not travel far 
through the medium before being absorbed or scattered. This leads to a diffusion-like 
equation for the radiative heat flux (Ref. 1):

For a gray medium (after integration over all wave numbers) the radiative heat flux 
depends on the temperature gradient and can be expressed as:

where kr is a highly nonlinear coefficient, considered as a conductivity, for radiative 
transfer of the form

TABLE 1:  MATERIAL PROPERTIES FOR GLASS

MATERIAL PROPERTY VALUE

Thermal conductivity 1.2 W/(m·K)

Density 2200 kg/m3

Heat capacity at constant pressure 850 J/(kg·K)

Scattering coefficient 0

qr λ,
4π
3βλ
--------- ib λ,∇–=

qr kr T∇–=

kr
16n2σT3

3βr
------------------------=
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with βr, the Rosseland-mean extinction coefficient, σ the scattering coefficient and n the 
refractive index. Thus the Rosseland approximation method is also called the diffusion 
method.

Results and Discussion

The figures below compare the results for low and high absorption coefficient. The P1 
method provides a very good approximation for lower absorption coefficients (Figure 2), 
but with increasing absorption coefficients the results differ increasingly.

Figure 2: Vertical temperature distribution at the center of the cylinder for k = 5.

The Rosseland approximation provides a fast and satisfying solution for the temperature 
field when very high absorption coefficients or rather high optical thickness is present 
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(Figure 3).

Figure 3: Vertical temperature distribution at the center of the cylinder for k = 120.

Both methods need to be used carefully and it is recommended to validate their 
applicability. If they can be used, they provide a very fast solution compared to the highly 
accurate discrete ordinates method.

Reference

1. M.F. Modest, Radiative Heat Transfer, 2nd ed., Academic Press, 2003.

Application Library path: Heat_Transfer_Module/Thermal_Radiation/
glass_plate

Modeling Instructions

From the File menu, choose New.
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N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Radiation>Heat Transfer with Radiation in 

Participating Media (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose cm.

Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type 5.

4 In the Height text field, type 1.5.

5 Click Build All Objects.

Name Expression Value Description

nr 1.45 1.45 Refractive index

T0 600[degC] 873.2 K Initial temperature

T_amb 20[degC] 293.2 K Ambient temperature

k 5 5 Absorption coefficient
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Create a user-defined material for the glass body.

Material 1 (mat1)
On the Materials toolbar, click Blank Material.

M A T E R I A L S

Material 1 (mat1)
1 In the Settings window for Material, type Glass in the Label text field.

2 Locate the Material Contents section. In the table, enter the following settings:

For radiative heat transfer, the absorption and scattering coefficients are also needed. 
Add these properties to the material.

3 Click to expand the Material properties section. Locate the Material Properties section. 
In the Material properties tree, select Basic Properties>Absorption Coefficient.

4 Click Add to Material.

5 Locate the Material Contents section. In the table, enter the following settings:

6 Locate the Material Properties section. In the Material properties tree, select Basic 

Properties>Scattering Coefficient.

7 Click Add to Material.

8 Locate the Material Contents section. In the table, enter the following settings:

The boundary condition for radiative cooling requires a surface emissivity. One way to 
define this coefficient is to add a material for the boundaries.

Property Name Value Unit Property 
group

Thermal conductivity k 1.2 W/(m·K) Basic

Density rho 2200 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 850 J/(kg·K) Basic

Property Name Value Unit Property 
group

Absorption coefficient kappaR k 1/m Basic

Property Name Value Unit Property 
group

Scattering coefficient sigmaS 0 1/m Basic
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Material 2 (mat2)
1 On the Materials toolbar, click Blank Material.

2 In the Settings window for Material, type Glass (Boundaries) in the Label text field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose All boundaries.

5 Click to expand the Material properties section. Locate the Material Properties section. 
In the Material properties tree, select Basic Properties>Surface Emissivity.

6 Click Add to Material.

7 Locate the Material Contents section. In the table, enter the following settings:

Start with the discrete ordinate method to compute the radiative cooling of the glass plate. 
This method provides the most accurate solution for arbitrary radiation models and is 
therefore the default method for radiation in participating media. To reduce the memory 
requirement, you can adjust the performance index for the discrete ordinate method. The 
method computes the radiative intensities for a number of directions (20 directions by 
default) and the segregated solver only computes a few directions at once. The 
performance index determines the number of directions which are calculated at one 
segregated step and the number of segregated steps accordingly.

H E A T  TR A N S F E R  W I T H  R A D I A T I O N  I N  P A R T I C I P A T I N G  M E D I A  ( H T )

1 In the Model Builder window, under Component 1 (comp1) click Heat Transfer with 

Radiation in Participating Media (ht).

2 In the Settings window for Heat Transfer with Radiation in Participating Media, locate 
the Participating Media Settings section.

3 From the Pindex list, choose 0.6.

4 In the nr text field, type nr.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer with Radiation 

in Participating Media (ht) click Initial Values 1.

2 In the Settings window for Initial Values, type T0 in the T text field.

Set the initial temperature to 600 °C.

Property Name Value Unit Property group

Surface emissivity epsilon_rad 1 1 Basic
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Radiation in Participating Media 1
1 On the Physics toolbar, click Domains and choose Radiation in Participating Media.

2 Select Domain 1 only.

Diffuse Surface 1
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 In the Settings window for Diffuse Surface, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

4 Locate the Ambient section. In the Tamb text field, type T_amb.

M E S H  1

Build a suitable mesh manually. First, mesh the surface with a free triangular mesh and then 
add a swept mesh.

Free Triangular 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Free Triangular.

2 Select Boundary 4 only.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Edge.

4 Select Edges 4, 5, 8, and 11 only.

5 Locate the Element Size section. From the Predefined list, choose Extra fine.

Free Triangular 1
Right-click Free Triangular 1 and choose Size.

Size 2
1 In the Settings window for Size, locate the Element Size section.

2 From the Predefined list, choose Fine.

3 Click Build Selected.

4 In the Model Builder window, right-click Mesh 1 and choose Swept.

Swept 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Swept 1 and 
choose Distribution.
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Distribution 1
1 In the Settings window for Distribution, locate the Distribution section.

2 In the Number of elements text field, type 8.

3 Click Build Selected.

The mesh should look like the figure below.

S T U D Y  1

Next, rename the study node to identify the studies and the related solutions easily.

1 In the Settings window for Study, type Study 1: DOM in the Label text field.

S T U D Y  1 :  D O M

Step 1: Time Dependent
The model only compares the results after 10 seconds. To keep the file size small, let 
COMSOL Multiphysics store only this time step in the file. The computational time step 
is chosen automatically.

1 In the Model Builder window, under Study 1: DOM click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type 10.
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Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

5 On the Study toolbar, click Compute.

R E S U L T S

Temperature (ht)
Next, run the same model but with the P1 method. The only modification to do is to 
change the Radiation discretization method in the Heat Transfer with Radiation in 

Participating Media settings window.

H E A T  TR A N S F E R  W I T H  R A D I A T I O N  I N  P A R T I C I P A T I N G  M E D I A  ( H T )

1 In the Model Builder window, under Component 1 (comp1) click Heat Transfer with 

Radiation in Participating Media (ht).

2 In the Settings window for Heat Transfer with Radiation in Participating Media, locate 
the Participating Media Settings section.

3 From the Radiation discretization method list, choose P1 approximation.

To compare the results, a second study is used to compute the same set-up with the P1 
method. Add an empty study and copy the settings from the first one.

A D D  S T U D Y

1 On the Study toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies.

4 In the Select Study tree, select Empty Study.

5 Click Add Study in the window toolbar.

S T U D Y  2

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Study 2: P1 in the Label text field.

Parameter name Parameter value list Parameter unit

k 5 70 120
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3 In the Model Builder window under the Study 1: DOM node, select both the Parametric 

Sweep and Step 1: Time Dependent nodes. Right-click on the selected nodes and choose 
Copy.

S T U D Y  2 :  P 1

1 In the Model Builder window, right-click Study 2: P1 and choose Paste Multiple Items.

2 On the Study toolbar, click Compute.

R E S U L T S

Temperature (ht) 1
The same procedure applies for solving with the Rosseland approximation.

H E A T  TR A N S F E R  W I T H  R A D I A T I O N  I N  P A R T I C I P A T I N G  M E D I A  ( H T )

1 In the Model Builder window, under Component 1 (comp1) click Heat Transfer with 

Radiation in Participating Media (ht).

2 In the Settings window for Heat Transfer with Radiation in Participating Media, locate 
the Participating Media Settings section.

3 From the Radiation discretization method list, choose Rosseland approximation.

A D D  S T U D Y

1 Go to the Add Study window.

2 Find the Studies subsection. In the Select Study tree, select Empty Study.

3 Click Add Study in the window toolbar.

S T U D Y  3

1 In the Model Builder window, click Study 3.

2 In the Settings window for Study, type Study 3: Rosseland in the Label text field.

3 In the Model Builder window under the Study1: DOM node, select both the Parametric 

Sweep and Step 1: Time Dependent nodes. Right-click on the selected nodes and choose 
Copy.

S T U D Y  3 :  R O S S E L A N D

1 In the Model Builder window, right-click Study 3: Rosseland and choose Paste Multiple 

Items.

2 On the Study toolbar, click Compute.
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R E S U L T S

Data Sets
To compare the results, add a temperature plot along the center line of the glass plate. 
Therefore create a cut line data set for each parametric solution.

Cut Line 3D 1
1 On the Results toolbar, click Cut Line 3D.

2 In the Settings window for Cut Line 3D, locate the Data section.

3 From the Data set list, choose Study 1: DOM/Parametric Solutions 1 (sol2).

4 Locate the Line Data section. In row Point 2, set x to 0, and z to 1.5.

5 Click Plot.

Copy the data set twice and assign the solutions from the other studies.

Cut Line 3D 2
1 Right-click Cut Line 3D 1 and choose Duplicate.

2 In the Settings window for Cut Line 3D, locate the Data section.

3 From the Data set list, choose Study 2: P1/Parametric Solutions 2 (sol7).

Cut Line 3D 3
1 Right-click Results>Data Sets>Cut Line 3D 2 and choose Duplicate.
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2 In the Settings window for Cut Line 3D, locate the Data section.

3 From the Data set list, choose Study 3: Rosseland/Parametric Solutions 3 (sol12).

Now, add a 1D plot group for the temperature.

1D Plot Group 9
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Temperature at Central Line for 
k = 5 in the Label text field.

3 Click to expand the Title section. From the Title type list, choose Manual.

4 In the Title text area, type Temperature at Central Line.

Line Graph 1
1 On the Temperature at Central Line for k = 5 toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Data set list, choose Cut Line 3D 1.

4 From the Parameter selection (k) list, choose First.

5 From the Time selection list, choose Last.

6 Click to expand the Legends section. Click to collapse the Legends section. Click to 
expand the Legends section. From the Legends list, choose Manual.

7 Select the Show legends check box.

8 In the table, enter the following settings:

9 On the Temperature at Central Line for k = 5 toolbar, click Plot.

Line Graph 2
1 Right-click Line Graph 1 and choose Duplicate.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Data set list, choose Cut Line 3D 2.

4 Locate the Legends section. In the table, enter the following settings:

Legends

DOM

Legends

P1
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Line Graph 3
1 Right-click Results>Temperature at Central Line for k = 5>Line Graph 2 and choose 

Duplicate.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Data set list, choose Cut Line 3D 3.

4 Locate the Legends section. In the table, enter the following settings:

5 On the Temperature at Central Line for k = 5 toolbar, click Plot.

Temperature at Central Line for k = 5
Duplicate the plot group and change the data set to k = 120.

1 In the Model Builder window, under Results right-click Temperature at Central Line for k 

= 5 and choose Duplicate.

Temperature at Central Line for k = 5.1
In the Settings window for 1D Plot Group, type Temperature at Central Line for k 
= 120 in the Label text field.

Line Graph 1
1 In the Model Builder window, expand the Results>Temperature at Central Line for k = 120 

node, then click Line Graph 1.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Parameter selection (k) list, choose Last.

Line Graph 2
1 In the Model Builder window, under Results>Temperature at Central Line for k = 120 click 

Line Graph 2.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Parameter selection (k) list, choose Last.

Line Graph 3
1 In the Model Builder window, under Results>Temperature at Central Line for k = 120 click 

Line Graph 3.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Parameter selection (k) list, choose Last.

Legends

Rosseland
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4 On the Temperature at Central Line for k = 120 toolbar, click Plot.

The plots are shown in Figure 2 and Figure 3. For high optical thickness, the Rosseland 
approximation better represents the overall temperature distribution, whereas the P1 
approximation is appropriate for lower optical thickness.
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Introduction

This simple example covers the heat conduction in a finite slab, modeling how the 
temperature varies with time. You first set up the problem in COMSOL Multiphysics and 
then compare it to the analytical solution given in Ref. 1.

In addition, this example also shows how to avoid oscillations due to a jump between 
initial and boundary conditions by using a smoothed step function.

Model Definition

The model domain is defined between x = −b and x = b. The initial temperature is 
constant, equal to T0, over the whole domain; see the figure below. At time t = 0, the 
temperature at both boundaries is lowered to T1.

Figure 1: Modeling domain.

To compare the modeling results to the literature (Ref. 1), introduce new dimensionless 
variables according to the following definitions:

The model equation then becomes

with the associated initial condition

and boundary conditions 

The analytical solution of this problem is (see Ref. 1, equation 12.1-31):

T(−b,0) = T1 T(b,0) = T1

Θ
T1 T–

T1 T0–
-------------------= η x

b
---= τ αt

b2
------=

Θ∂
τ∂

------- Θ2∂

η2∂
----------=

τ 0= Θ 1=

η 1±= Θ 0=
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To model the temperature decrease at the boundaries use a smoothed step function of time 
f(τ).

This method is usually more realistic from a physical point of view than the sudden change 
in the temperature, and it is also better from a numerical point of view.

Results and Discussion

Figure 2 shows the temperature as a function of position at the dimensionless times 
τ = 0.01, 0.04, 0.1, 0.2, 0.4, and 0.6. In this plot, the slab’s center is situated at x = 0 with 
its end faces located a x = −1 and x = 1. The temperature profiles shown in the graph are 
identical to the analytical solution given in Ref. 1.

Figure 2: Temperature profiles.
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The plot of the L2 error between the analytical and numerical solutions over time (see 
Figure 3) confirms this conclusion.

Figure 3: L2 error between analytical and numerical solutions over time.

Reference

1. R.B. Bird, W.E. Stewart, and E.N. Lightfoot, Transport Phenomena, 2nd ed., John 
Wiley & Sons, 2007.

Application Library path: Heat_Transfer_Module/Tutorials,_Conduction/
heat_conduction_in_slab

Modeling Instructions

From the File menu, choose New.
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N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 1D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

G E O M E T R Y  1

The Heat Transfer in Solids interface can be used for solving the dimensionless equations. 
You can switch off the dimensions using the following commands:

C O M P O N E N T  1  ( C O M P 1 )

1 In the Model Builder window, click Component 1 (comp1).

2 In the Settings window for Component, locate the General section.

3 From the Unit system list, choose None.

G E O M E T R Y  1

Interval 1 (i1)
1 On the Geometry toolbar, click Interval.

2 In the Settings window for Interval, locate the Interval section.

3 In the Left endpoint text field, type -1.

4 Click Build All Objects.

D E F I N I T I O N S

Add a step function for use in the boundary conditions.

Step 1 (step1)
1 On the Home toolbar, click Functions and choose Local>Step.

2 In the Settings window for Step, locate the Parameters section.

3 In the Location text field, type 5e-5.

4 In the From text field, type 1.

5 In the To text field, type 0.
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6 Click to expand the Smoothing section. In the Size of transition zone text field, type 1e-4.

Optionally, you can inspect the shape of the step function.

7 Click Plot.

Add an integration operator for the computation of the relative L2 error between 
numerical and analytical solutions.

Integration 1 (intop1)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Selection list, choose All domains.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Solid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Solid 1.

2 In the Settings window for Solid, locate the Heat Conduction, Solid section.

3 From the k list, choose User defined. In the associated text field, type 1.

4 Locate the Thermodynamics, Solid section. From the ρ list, choose User defined. In the 
associated text field, type 1.

5 From the Cp list, choose User defined. In the associated text field, type 1.
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Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, type 1 in the T text field.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundaries 1 and 2 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type step1(t).

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Sequence type list, choose User-controlled mesh.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Finer.

Edge 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Edge 1 and 
choose Size.

Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 From the Selection list, choose All boundaries.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 1e-4.

7 Click Build All.

S T U D Y  1

Step 1: Time Dependent
1 In the Settings window for Time Dependent, locate the Study Settings section.
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2 In the Times text field, type range(0,0.01,1).

To make sure that the transition of the boundary temperature from 1 to zero is 
represented correctly by the transient solver, use the initial time step that is smaller than 
the transition zone of the step function.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Time-Dependent Solver 1.

3 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

4 Locate the Time Stepping section. Select the Initial step check box.

5 In the associated text field, type 1e-5.

6 Select the Maximum step check box.

7 In the associated text field, type 1e-3.

8 On the Study toolbar, click Compute.

R E S U L T S

Temperature (ht)
The default plot shows the temperature distribution along the slab for all time steps. You 
can compare the computed solution to that of Ref. 1 by plotting the temperature for a 
given set of output times, as in Figure 2.

1 In the Model Builder window, under Results click Temperature (ht).

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Time selection list, choose From list.

4 In the Times (s) list, choose 0.01, 0.04, 0.1, 0.2, 0.4, and 0.6.

5 On the Temperature (ht) toolbar, click Plot.

Line Graph
1 In the Model Builder window, expand the Temperature (ht) node, then click Line Graph.

2 In the Settings window for Line Graph, click to expand the Legends section.

3 Select the Show legends check box.

4 Click to expand the Coloring and style section. Locate the Coloring and Style section. Find 
the Line markers subsection. From the Marker list, choose Cycle.
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5 On the Temperature (ht) toolbar, click Plot.

Next plot the relative L2 error between the numerical and analytical solutions over time.

1D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Relative L2 Error in the Label text 
field.

Line Graph 1
1 On the Relative L2 Error toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Selection section.

3 From the Selection list, choose All domains.

4 Locate the y-Axis Data section. In the Expression text field, type sqrt(intop1((T-2*
sum((-1)^n/((n+0.5)*pi)*exp(-(n+0.5)^2*pi^2*t)*cos((n+0.5)*pi*x),n,

0,1000))^2))/sqrt(intop1(T^2)).

5 Select the Description check box.

6 In the associated text field, type L2 error from analytical solution.

7 Locate the x-Axis Data section. From the Parameter list, choose Expression.

8 In the Expression text field, type t.

9 Locate the Coloring and Style section. From the Color list, choose Black.

10 On the Relative L2 Error toolbar, click Plot.

As the analytical solution shows oscillations at initial time, change the settings of the 
graph for a better readability, to get the plot of Figure 3.

Relative L2 Error
1 In the Model Builder window, under Results click Relative L2 Error.

2 In the Settings window for 1D Plot Group, locate the Axis section.

3 Select the Manual axis limits check box.

4 In the x minimum text field, type 1e-3.

5 In the x maximum text field, type 1.

6 In the y minimum text field, type 0.

7 In the y maximum text field, type 1e-3.

8 On the Relative L2 Error toolbar, click Plot.
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Introduction

This example is intended as a first introduction to simulations of fluid flow and conjugate 
heat transfer. It shows the following important points:

• How to draw an air box around a device in order to model convective cooling in this 
box.

• How to set a total heat flux on a boundary using automatic area computation.

• How to display results in an efficient way using selections in data sets.

The application is also described in detail in the book Introduction to the Heat Transfer 
Module. An extension of the application that takes surface-to-surface radiation into 
account is also available; see Heat Sink with Surface-to-Surface Radiation.

Figure 1: The application setup including channel and heat sink.

Model Definition

The modeled system consists of an aluminum heat sink for cooling of components in 
electronic circuits mounted inside a channel of rectangular cross section (see Figure 1).

Base surface

Inlet

Outlet
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Such a setup is used to measure the cooling capacity of heat sinks. Air enters the channel 
at the inlet and exits the channel at the outlet. The base surface of the heat sink receives a 
1 W heat flux from an external heat source. All other external faces are thermally insulated.

The cooling capacity of the heat sink can be determined by monitoring the temperature 
of the base surface of the heat sink.

The model solves a thermal balance for the heat sink and the air flowing in the rectangular 
channel. Thermal energy is transported through conduction in the aluminum heat sink 
and through conduction and convection in the cooling air. The temperature field is 
continuous across the internal surfaces between the heat sink and the air in the channel. 
The temperature is set at the inlet of the channel. The base of the heat sink receives a 1 W 
heat flux. The transport of thermal energy at the outlet is dominated by convection.

The flow field is obtained by solving one momentum balance for each space coordinate (x, 
y, and z) and a mass balance. The inlet velocity is defined by a parabolic velocity profile for 
fully developed laminar flow. At the outlet, the normal stress is equal the outlet pressure 
and the tangential stress is canceled. At all solid surfaces, the velocity is set to zero in all 
three spatial directions.

The thermal conductivity of air, the heat capacity of air, and the air density are all 
temperature-dependent material properties.

You can find all of the settings mentioned above in the predefined multiphysics coupling 
for Conjugate Heat Transfer in COMSOL Multiphysics. You also find the material 
properties, including their temperature dependence, in the Material Browser.
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Results

In Figure 2, the hot wake behind the heat sink visible in the plot is a sign of the convective 
cooling effects. The maximum temperature, reached at the heat sink base, is about 380 K.

Figure 2: The surface plot shows the temperature field on the channel walls and the heat sink 
surface, while the arrow plot shows the flow velocity field around the heat sink.

Application Library path: Heat_Transfer_Module/Tutorials,
_Forced_and_Natural_Convection/heat_sink

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Conjugate Heat Transfer>Laminar Flow.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

G E O M E T R Y  1

The model geometry is available as a parameterized geometry sequence in a separate 
MPH-file. If you want to build it from scratch, follow the instructions in the section 
Appendix: Geometry Modeling Instructions. Otherwise load it from file with the 
following steps.

1 On the Geometry toolbar, click Insert Sequence.

2 Browse to the application’s Application Libraries folder and double-click the file 
heat_sink_geom_sequence.mph.

The application’s Application Library folder is shown in the Application Library path 
section immediately before the current section. Note that the path given there is relative 
to the COMSOL Application Library root, which for a standard installation on 
Windows is C:\\Program 
Files\COMSOL\COMSOL52a\Multiphysics\applications.

Import 1 (imp1)
1 Click the Go to Default 3D View button on the Graphics toolbar.

2 On the Geometry toolbar, click Build All.

To facilitate face selection in the next steps, use the Wireframe rendering option (skip this 
step if you followed the instructions in the appendix):
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3 Click the Wireframe Rendering button on the Graphics toolbar.

L A M I N A R  F L O W  ( S P F )

Create a selection for the air domain used the physics interfaces to define the fluid.

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

2 Select Domain 1 only.

3 In the Settings window for Laminar Flow, locate the Domain Selection section.

4 Click Create Selection.

5 In the Create Selection dialog box, type Air in the Selection name text field.

6 Click OK.

H E A T  TR A N S F E R  ( H T )

On the Physics toolbar, click Laminar Flow (spf) and choose Heat Transfer (ht).

Fluid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Fluid 

1.

2 In the Settings window for Fluid, locate the Domain Selection section.

3 From the Selection list, choose Air.
6 |  H E A T  S I N K



M A T E R I A L S

Next, add materials.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Air.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Air (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Air (mat1).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Air.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Aluminum 3003-H18.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Aluminum 3003-H18 (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Aluminum 

3003-H18 (mat2).

2 Select Domain 2 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Silica glass.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Silica glass (mat3)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Silica glass 

(mat3).
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2 Select Domain 3 only.

3 On the Home toolbar, click Add Material to close the Add Material window.

Material 4 (mat4)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Thermal Grease in the Label text field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 Select Boundary 34 only.

5 Click to expand the Material properties section. Locate the Material Properties section. 
In the Material properties tree, select Basic Properties>Thermal Conductivity.

6 Click Add to Material.

7 Locate the Material Contents section. In the table, enter the following settings:

G L O B A L  D E F I N I T I O N S

Parameters
1 In the Model Builder window, expand the Global Definitions node, then click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Now define the physical properties of the model. Start with the fluid domain.

L A M I N A R  F L O W  ( S P F )

On the Physics toolbar, click Heat Transfer (ht) and choose Laminar Flow (spf).

The no-slip condition is the default boundary condition for the fluid. Define the inlet and 
outlet conditions as described below.

Property Name Value Unit Property 
group

Thermal conductivity k 2[W/m/K] W/(m·K) Basic

Name Expression Value Description

U0 5[cm/s] 0.05 m/s Mean inlet velocity

P0 1[W] 1 W Total power dissipated by the 
electronics package
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1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

Inlet 1
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 Select Boundary 121 only.

3 In the Settings window for Inlet, locate the Boundary Condition section.

4 From the list, choose Laminar inflow.

5 Locate the Laminar Inflow section. In the Uav text field, type U0.

Outlet 1
1 On the Physics toolbar, click Boundaries and choose Outlet.

2 Click the Zoom Extents button on the Graphics toolbar.

3 Select Boundary 1 only.

H E A T  TR A N S F E R  ( H T )

Thermal insulation is the default boundary condition for the temperature. Define the inlet 
temperature and the outlet condition as described below.

1 In the Model Builder window, under Component 1 (comp1) click Heat Transfer (ht).

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 121 only.

The ambient temperature is defined in the main node of the Heat Transfer interface. Its 
default value is 293.15 K which corresponds to the inlet temperature used in this model. 
It is possible to edit the ambient temperature value or to define it using the meteorological 
data which gives access to climate data from more than 6000 stations in the world.

3 In the Settings window for Temperature, locate the Temperature section.

4 From the T0 list, choose Ambient temperature (ht).

Outflow 1
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 Select Boundary 1 only.

Next, use the P0 parameter to define the total heat source in the electronics package.

Heat Source 1
1 On the Physics toolbar, click Domains and choose Heat Source.

2 Select Domain 3 only.
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3 In the Settings window for Heat Source, locate the Heat Source section.

4 Click the Heat rate button.

5 In the P0 text field, type P0.

Finally, add the thin thermal grease layer.

Thin Layer 1
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 Select Boundary 34 only.

3 In the Settings window for Thin Layer, locate the Thin Layer section.

4 In the ds text field, type 50[um].

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Extra coarse.

4 Click Build All.

To get a better view of the mesh, hide some of the boundaries.

5 Click the Click and Hide button on the Graphics toolbar.

6 Click the Select Boundaries button on the Graphics toolbar.
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7 Select Boundaries 1, 2, and 4 only.

The finished mesh should look like that in the figure below.

To achieve more accurate numerical results, this mesh can be refined by choosing another 
predefined element size. However, doing so requires more computational time and 
memory.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
Four default plots are generated automatically. The first one shows the temperature on the 
wall boundaries, the third one shows the velocity magnitude on five parallel slices, and the 
last one shows the pressure field. Add an arrow plot to visualize the velocity field with 
temperature field.

Arrow Volume 1
1 In the Model Builder window, under Results right-click Temperature (ht) and choose 

Arrow Volume.
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2 In the Settings window for Arrow Volume, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Model>Component 1>Laminar 

Flow>Velocity and pressure>u,v,w - Velocity field.

3 Locate the Arrow Positioning section. Find the x grid points subsection. In the Points text 
field, type 40.

4 Find the y grid points subsection. In the Points text field, type 20.

5 Find the z grid points subsection. From the Entry method list, choose Coordinates.

6 In the Coordinates text field, type 5[mm].

Color Expression 1
1 Right-click Results>Temperature (ht)>Arrow Volume 1 and choose Color Expression.

2 In the Settings window for Color Expression, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Model>Component 1>Laminar 

Flow>Velocity and pressure>spf.U - Velocity magnitude.

3 On the Temperature (ht) toolbar, click Plot.

Global Evaluation 1
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, type Energy Balance in the Label text 
field.

3 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Heat Transfer>Global>Net powers>ht.ntefluxInt - 

Total net energy rate.

4 Click Add Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Heat Transfer>Global>Heat source powers>ht.QInt - 

Total heat source.

5 Click Evaluate.

TA B L E

1 Go to the Table window.

You can verify that the two values match and are close to 1 W in the Table 1 tab.

Appendix: Geometry Modeling Instructions

R O O T

On the Home toolbar, click Add Component and choose 3D.
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G L O B A L  D E F I N I T I O N S

First define the geometry parameters.

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Build the geometry in three steps. First, import the heat sink geometry from a file.

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
heat_sink.mphbin.

5 Click Import.

6 Click the Wireframe Rendering button on the Graphics toolbar.

Next, define a work plane containing the bottom surface of the heat sink to draw the 
imprints of the chip and of the air channel.

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, locate the Plane Definition section.

3 From the Plane type list, choose Face parallel.

4 Find the Planar face subsection. Select the Active toggle button.

Name Expression Value Description

L_channel 7[cm] 0.07 m Channel length

W_channel 3[cm] 0.03 m Channel width

H_channel 1.5[cm] 0.015 m Channel height

L_chip 1.5[cm] 0.015 m Chip size

H_chip 2[mm] 0.002 m Chip height
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5 Select the surface shown in the figure below.

6 Locate the Unite Objects section. Clear the Unite objects check box.

7 Click Show Work Plane.

Square 1 (sq1)
1 On the Work Plane toolbar, click Primitives and choose Square.

2 In the Settings window for Square, locate the Size section.

3 In the Side length text field, type L_chip.

4 Locate the Position section. From the Base list, choose Center.

5 Right-click Square 1 (sq1) and choose Build Selected.

6 Click the Zoom Extents button on the Graphics toolbar.

Rectangle 1 (r1)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type L_channel.

4 In the Height text field, type W_channel.

5 Locate the Position section. In the xw text field, type -45[mm].

6 In the yw text field, type -W_channel/2.
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7 Right-click Rectangle 1 (r1) and choose Build Selected.

8 In the Model Builder window, click Geometry 1.

Now extrude the chip imprint to define the chip volume.

Extrude 1 (ext1)
1 On the Geometry toolbar, click Extrude.

2 Select the object wp1.sq1 only.

3 In the Settings window for Extrude, locate the Distances from Plane section.

4 In the table, enter the following settings:

5 Right-click Extrude 1 (ext1) and choose Build Selected.

6 Click the Zoom Extents button on the Graphics toolbar.

To finish the geometry, extrude the channel imprint in the opposite direction to define 
the air volume.

Extrude 2 (ext2)
1 On the Geometry toolbar, click Extrude.

2 Select the object wp1.r1 only.

3 In the Settings window for Extrude, locate the Distances from Plane section.

4 In the table, enter the following settings:

5 Select the Reverse direction check box.

6 Click Build All Objects.

7 Click the Zoom Extents button on the Graphics toolbar.

Form Union (fin)
1 On the Geometry toolbar, click Build All.

The model geometry is now complete.

Distances (m)

H_chip

Distances (m)

H_channel
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Introduction

This application extends the Heat Sink model by taking surface-to-surface radiation into 
account. For a detailed description of the application, see Heat Sink. Both applications are 
also described in detail in the book Introduction to the Heat Transfer Module.

Application Library path: Heat_Transfer_Module/Tutorials,
_Forced_and_Natural_Convection/heat_sink_surface_radiation

Modeling Instructions

R O O T

In this second part you modify and solve the model to study the effects of 
surface-to-surface radiation between the heat sink and the channel walls.

1 From the File menu, choose Open.

2 Browse to the application’s Application Libraries folder and double-click the file 
heat_sink.mph.

C O M P O N E N T  1  ( C O M P 1 )

Now modify the model to include surface-to-surface radiation effects. First you need to 
enable the surface-to-surface radiation property.

H E A T  TR A N S F E R  ( H T )

1 In the Model Builder window, expand the Component 1 (comp1) node, then click Heat 

Transfer (ht).

2 In the Settings window for Heat Transfer, locate the Physical Model section.

3 Select the Surface-to-surface radiation check box.

By default, the radiation direction is controlled by the opacity of the domains. The solid 
parts are automatically defined as opaque while the fluid parts are transparent. You can 
change these settings by modifying the Opacity subnode under Solid and Fluid features.

When the Diffuse Surface boundary condition defines the radiation direction as opacity 
controlled (default) the selected boundaries should be located between an opaque and 
a transparent domain. The exterior is defined as transparent by default. Change this 
setting to make the exterior opaque and have the radiation direction automatically 
defined on the channel walls.
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4 Locate the Radiation Settings section. From the Exterior radiation list, choose Exterior is 

opaque.

Now you can add a surface-to-surface boundary condition to the model.

Diffuse Surface 1
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 Select Boundaries 2–7, 9–30, 36–109, and 111–120 only.

3 In the Settings window for Diffuse Surface, locate the Ambient section.

4 From the Tamb list, choose Ambient temperature (ht).

5 Locate the Surface Emissivity section. From the ε list, choose User defined. In the 
associated text field, type 0.85.

C O M P O N E N T  1  ( C O M P 1 )

Hide the boundaries on the top and fronts to see the interior of the channel and the heat 
sink.

1 Click the Click and Hide button on the Graphics toolbar.

2 Click the Select Boundaries button on the Graphics toolbar.

3 In the Model Builder window, click Component 1 (comp1).

4 Select Boundaries 1, 2, and 4 only.

R O O T

In order to keep the previous solution and to be able to compare it with this version of the 
model, create a new stationary study.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

S T U D Y  2

1 On the Home toolbar, click Add Study to close the Add Study window.

2 On the Home toolbar, click Compute.
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R E S U L T S

Temperature (ht) 1
The same default plots as before are generated automatically. Modify the temperature plot 
to compare both cases.

Arrow Volume 1
1 In the Model Builder window, under Results right-click Temperature (ht) 1 and choose 

Arrow Volume.

2 In the Settings window for Arrow Volume, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Model>Component 1>Laminar 

Flow>Velocity and pressure>u,v,w - Velocity field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 2 (sol2).

4 Locate the Arrow Positioning section. Find the x grid points subsection. In the Points text 
field, type 40.

5 Find the y grid points subsection. In the Points text field, type 20.

6 Find the z grid points subsection. From the Entry method list, choose Coordinates.

7 In the Coordinates text field, type 5[mm].

Color Expression 1
1 Right-click Results>Temperature (ht) 1>Arrow Volume 1 and choose Color Expression.

2 In the Settings window for Color Expression, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Model>Component 1>Laminar 

Flow>Velocity and pressure>spf.U - Velocity magnitude.
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3 On the Temperature (ht) 1 toolbar, click Plot.

The plot in the Graphics window should look like that in the figure below.
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Introduction

Small heating circuits find use in many applications. For example, in manufacturing 
processes they heat up reactive fluids. Figure 1 illustrates a typical heating device for this 
application. The device consists of an electrically resistive layer deposited on a glass plate. 
The layer causes Joule heating when a voltage is applied to the circuit. The layer’s 
properties determine the amount of heat produced.

Figure 1: Geometry of a heating device.

In this particular application, you must observe three important design considerations:

• Non-invasive heating

• Minimal deflection of the heating device

• Avoidance of overheating the process fluid

The heater must also work without failure. You achieve the first and second requirements 
by inserting a glass plate between the heating circuit and the fluid; it acts as a conducting 
separator. Glass is an ideal material for both these purposes because it is non-reactive and 
has a low coefficient of thermal expansion. 

You must also avoid overheating due to the risk of self-ignition of the reactive fluid stream. 
Ignition is also the main reason for separating the electrical circuit from direct contact with 
the fluid. The heating device is tailored for each application, making virtual prototyping 
very important for manufacturers.

For heating circuits in general, detachment of the resistive layer often determines the 
failure rate. This is caused by excessive thermally induced interfacial stresses. Once the 
layer has detached, it gets locally overheated, which accelerates the detachment. Finally, in 
the worst case, the circuit might overheat and burn. From this perspective, it is also 
important to study the interfacial tension due to the different thermal-expansion 
coefficients of the resistive layer and the substrate as well as the differences in temperature. 

Heated fluid 
stream

Air

Electric heater

Glass plate
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The geometric shape of the layer is a key parameter to design circuits for proper 
functioning. You can investigate all of the above-mentioned aspects by modeling the 
circuit.

This multiphysics example simulates the electrical heat generation, the heat transfer, and 
the mechanical stresses and deformations of a heating circuit device. The model uses the 
Heat Transfer in Solids interface of the Heat Transfer Module in combination with the 
Electric Currents, Shell interface from the AC/DC Module and the Solid Mechanics and 
Shell interfaces from the Structural Mechanics Module.

Note: This application requires the AC/DC Module, the Heat Transfer Module, and the 
Structural Mechanics Module.

Model Definition

Figure 2 shows a drawing of the modeled heating circuit. 

Figure 2: Drawing of the heating circuit deposited on a glass plate.

The device consists of a serpentine-shaped Nichrome resistive layer, 10 μm thick and 
5 mm wide, deposited on a glass plate. At each end, it has a silver contact pad measuring 
10 mm-by-10 mm-by-10 μm. When the circuit is in use, the deposited side of the glass 
plate is in contact with surrounding air, and the back side is in contact with the heated 
fluid. Assume that the edges and sides of the glass plate are thermally insulated.

Table 1 gives the resistor’s dimensions.

TABLE 1:  DIMENSIONS

OBJECT LENGTH WIDTH THICKNESS

Glass Plate 130 mm 80 mm 2 mm

Pads and Circuit - - 10 µm

Silver Pads

Nichrome Circuit
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During operation the resistive layer produces heat. Model the electrically generated heat 
using the Electric Currents, Shell interface from the AC/DC Module. An electric potential 
of 12 V is applied to the pads. In the model, you achieve this effect by setting the potential 
at one edge of the first pad to 12 V and that of one edge of the other pad to 0 V.

To model the heat transfer in the thin conducting layer, use the Thin Layer feature from 
the Heat Transfer in Solids interface. The heat rate per unit area (measured in W/m2) 
produced inside the thin layer is given by

 (1)

where QDC = J · E = σ|∇tV|2 (W/m3) is the power density. The generated heat appears as 
an inward heat flux at the surface of the glass plate. 

At steady state, the resistive layer dissipates the heat it generates in two ways: on its up side 
to the surrounding air (at 293 K), and on its down side to the glass plate. The glass plate 
is similarly cooled in two ways: on its circuit side by air, and on its back side by a process 
fluid (353 K). You model the heat fluxes to the surroundings using heat transfer 
coefficients, h. For the heat transfer to air, h = 5 W/(m2·K), representing natural 
convection. On the glass plate’s back side, h = 20 W/(m2·K), representing convective heat 
transfer to the fluid. The sides of the glass plate are insulated.

The model simulates thermal expansion using static structural-mechanics analyses. It uses 
the Solid Mechanics interface for the glass plate, and the Shell interface for the circuit layer. 
The equations of these two interfaces are described in the Structural Mechanics Module 
User’s Guide. The stresses are set to zero at 293 K. You determine the boundary 
conditions for the Solid Mechanics interface by fixing one corner with respect to x-, y-, 
and z-displacements and rotation.

Table 2 summarizes the material properties used in the model.

TABLE 2:  MATERIAL PROPERTIES

MATERIAL E [GPa] ν α [1/K] k [W/(m·K)] ρ [kg/m3] Cp [J/(kg·K)]

Silver 83 0.37 1.89e-5 420 10500 230

Nichrome 213 0.33 1e-5 15 9000 20

Glass 73.1 0.17 5.5e-7 1.38 2203 703

qprod d QDC=
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Results and Discussion

Figure 3 shows the heat that the resistive layer generates.

Figure 3: Stationary heat generation in the resistive layer when 12 V is applied.

The highest heating power occurs at the inner corners of the curves due to the higher 
current density at these spots. The total generated heat, as calculated by integration, is 
approximately 13.8 W.
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Figure 4 shows the temperature of the resistive layer and the glass plate at steady state.

Figure 4: Temperature distribution in the heating device at steady state.

The highest temperature is approximately 428 K, and it appears in the central section of 
the circuit layer. It is interesting to see that the differences in temperature between the 
fluid side and the circuit side of the glass plate are quite small because the plate is very thin. 
Using boundary integration, the integral heat flux on the fluid side evaluates to 
approximately 8.5 W. This means that the device transfers the majority of the heat it 
generates—8.5 W out of 13.8 W—to the fluid, which is good from a design perspective, 
although the thermal resistance of the glass plate results in some losses.

The temperature rise also induces thermal stresses due the materials’ different coefficients 
of thermal expansion. As a result, mechanical stresses and deformations arise in the layer 
and in the glass plate. Figure 5 shows the effective stress distribution in the device and the 
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resulting deformations. During operation, the glass plate bends towards the air side.

Figure 5: The thermally induced von Mises effective stress plotted with the deformation.

The highest effective stress, approximately 13 MPa, occurs at the inner corners of the 
curves of the Nichrome circuit. The yield stress for high quality glass is roughly 250 MPa, 
and for Nichrome it is 360 MPa. This means that the individual objects remain structurally 
intact for the simulated heating power loads.

You must also consider stresses in the interface between the resistive layer and the glass 
plate. Assume that the yield stress of the surface adhesion in the interface is in the region 
of 50 MPa—a value significantly lower than the yield stresses of the other materials in the 
device. If the effective stress increases above this value, the resistive layer locally detaches 
from the glass. Once it has detached, heat transfer is locally impeded, which can lead to 
overheating of the resistive layer and eventually cause the device to fail.

Figure 6 displays the effective forces acting on the adhesive layer during heater operation. 
As the figure shows, the device experiences a maximum interfacial stress that is an order of 
magnitude smaller than the yield stress. This means that the device are OK in terms of 
adhesive stress.
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Figure 6: The effective forces in the interface between the resistive layer and the glass plate.

Finally study the device’s deflections, shown in Figure 7.

Figure 7: Total displacement on the fluid side of the glass plate.
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The maximum displacement, located at the center of the plate, is approximately 50 μm. 
For high-precision applications, such as semiconductor processing, this might be a 
significant value that limits the device’s operating temperature.

Application Library path: Heat_Transfer_Module/
Power_Electronics_and_Electronic_Cooling/heating_circuit

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Thermal Stress.

3 Click Add.

4 In the Select Physics tree, select AC/DC>Electric Currents, Shell (ecs).

5 Click Add.

6 In the Select Physics tree, select Structural Mechanics>Membrane (mbrn).

7 Click Add.

8 Click Study.

9 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

10 Click Done.

G E O M E T R Y  1

The Thermal Stress interface includes Heat Transfer in Solids and Solid Mechanics. In the 
volume, these two interfaces solve for temperature and displacement, respectively. In the 
shell representing the circuit, the temperature, the electrical potential and displacement are 
solved by Heat Transfer In Solids, Electric Currents, Shell, and Membrane interfaces, 
respectively.
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G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 80.

4 In the Depth text field, type 130.

5 In the Height text field, type 2.

Work Plane 1 (wp1)
1 Right-click Block 1 (blk1) and choose Build Selected.

2 On the Geometry toolbar, click Work Plane.

Name Expression Value Description

V_in 12[V] 12 V Input voltage

d_layer 10[um] 1E-5 m Layer thickness

sigma_silver 6.3e7[S/m] 6.3E7 S/m Electric 
conductivity of 
silver

sigma_nichrome 9.3e5[S/m] 9.3E5 S/m Electric 
conductivity of 
Nichrome

T_air 20[degC] 293.2 K Air temperature

h_air 5[W/(m^2*K)] 5 W/(m²·K) Heat transfer film 
coefficient, air

T_fluid 353[K] 353 K Fluid temperature

h_fluid 20[W/(m^2*K)] 20 W/(m²·K) Heat transfer film 
coefficient, fluid
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3 In the Settings window for Work Plane, locate the Plane Definition section.

4 In the z-coordinate text field, type 2.

5 Click Show Work Plane.

Plane Geometry
Click the Zoom Extents button on the Graphics toolbar.

Square 1 (sq1)
1 On the Work Plane toolbar, click Primitives and choose Square.

2 In the Settings window for Square, locate the Size section.

3 In the Side length text field, type 10.

4 Locate the Position section. In the xw text field, type 7.

5 In the yw text field, type 10.

6 Right-click Square 1 (sq1) and choose Build Selected.

Square 2 (sq2)
1 Right-click Square 1 (sq1) and choose Duplicate.

2 In the Settings window for Square, locate the Position section.

3 In the xw text field, type 30.

4 In the yw text field, type 8.

Polygon 1 (pol1)
1 Right-click Component 1 (comp1)>Geometry 1>Work Plane 1 (wp1)>Plane Geometry>

Square 2 (sq2) and choose Build Selected.

2 On the Work Plane toolbar, click Primitives and choose Polygon.

3 In the Settings window for Polygon, locate the Coordinates section.

4 From the Data source list, choose File.

5 Click Browse.

6 Browse to the application’s Application Libraries folder and double-click the file 
heating_circuit_polygon.txt.

Fillet 1 (fil1)
1 Right-click Polygon 1 (pol1) and choose Build Selected.

2 On the Work Plane toolbar, click Fillet.

3 On the object pol1, select Points 2–8, 23–29, 34, 36, 37, 41, and 42 only.

4 In the Settings window for Fillet, locate the Radius section.
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5 In the Radius text field, type 10.

Fillet 2 (fil2)
1 Right-click Fillet 1 (fil1) and choose Build Selected.

2 On the Work Plane toolbar, click Fillet.

3 On the object fil1, select Points 6–12, 26–31, 37, 40, 43, 46, 49, and 50 only.

4 In the Settings window for Fillet, locate the Radius section.

5 In the Radius text field, type 5.

6 On the Work Plane toolbar, click Build All.

Form Union (fin)
1 On the Home toolbar, click Build All.

The geometry should look like the figure below.

D E F I N I T I O N S

Add a selection that you can use later when applying boundary conditions and shell physics 
settings.

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Circuit in the Label text field.
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3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 6–8 only.

Before creating the materials for use in this model, it is a good idea to specify which 
boundaries are to be modeled as conducting shells. Using this information, COMSOL 
Multiphysics can detect which material properties are needed.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids (ht).

Thin Layer 1
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 In the Settings window for Thin Layer, locate the Boundary Selection section.

3 From the Selection list, choose Circuit.

4 Locate the Thin Layer section. From the Layer type list, choose Thermally thin 

approximation.

5 In the ds text field, type d_layer.

E L E C T R I C  C U R R E N T S ,  S H E L L  ( E C S )

1 In the Model Builder window, under Component 1 (comp1) click Electric Currents, Shell 

(ecs).

2 In the Settings window for Electric Currents, Shell, locate the Boundary Selection 
section.

3 From the Selection list, choose Circuit.

4 Locate the Shell Thickness section. In the ds text field, type d_layer.

M E M B R A N E  ( M B R N )

On the Physics toolbar, click Electric Currents, Shell (ecs) and choose Membrane (mbrn).

1 In the Model Builder window, under Component 1 (comp1) click Membrane (mbrn).

2 In the Settings window for Membrane, locate the Boundary Selection section.

3 From the Selection list, choose Circuit.

4 Locate the Thickness section. In the d text field, type d_layer.

5 Click to expand the Dependent variables section. Locate the Dependent Variables section. 
In the Displacement field text field, type u.
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Linear Elastic Material 1
In the Model Builder window, under Component 1 (comp1)>Membrane (mbrn) click Linear 

Elastic Material 1.

Thermal Expansion 1
1 On the Physics toolbar, click Attributes and choose Thermal Expansion.

2 In the Settings window for Thermal Expansion, locate the Model Inputs section.

3 From the T list, choose Temperature (ht).

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Silica glass.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

M A T E R I A L S

Silica glass (mat1)
Now set up the materials.

Material 2 (mat2)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Silver in the Label text field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose Circuit.

5 Locate the Material Contents section. In the table, enter the following settings:

Property Name Value Unit Property 
group

Thermal conductivity k 420 W/(m·K) Basic

Density rho 10500 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 230 J/(kg·K) Basic

Electrical conductivity sigma sigma_si
lver

S/m Basic
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Material 3 (mat3)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Nichrome in the Label text field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 Select Boundary 7 only.

5 Locate the Material Contents section. In the table, enter the following settings:

With the materials defined, set up the remaining physics of the model. In the next section, 
the resistive loss within the circuit is defined as a heat source for the thermal stress physics. 
The resistive loss is calculated automatically within the Electric Currents, Shell physics 
interface. Add the coupling feature Boundary Electromagnetic Heat Source to take the 
resistive loss into account.

Relative permittivity epsilonr 1 1 Basic

Young’s modulus E 83e9 Pa Basic

Poisson’s ratio nu 0.37 1 Basic

Coefficient of thermal 
expansion

alpha 18.9e-6 1/K Basic

Property Name Value Unit Property 
group

Thermal conductivity k 15 W/(m·K) Basic

Density rho 9000 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 20 J/(kg·K) Basic

Electrical conductivity sigma sigma_nic
hrome

S/m Basic

Relative permittivity epsilonr 1 1 Basic

Young’s modulus E 213e9 Pa Basic

Poisson’s ratio nu 0.33 1 Basic

Coefficient of thermal 
expansion

alpha 10e-6 1/K Basic

Property Name Value Unit Property 
group
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M U L T I P H Y S I C S

Boundary Electromagnetic Heat Source 1 (bemh1)
1 On the Physics toolbar, click Multiphysics and choose Boundary>Boundary 

Electromagnetic Heat Source.

2 In the Settings window for Boundary Electromagnetic Heat Source, locate the Boundary 

Selection section.

3 From the Selection list, choose Circuit.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids (ht).

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 4 and 6–8 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type h_air.

6 In the Text text field, type T_air.

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundary 3 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type h_fluid.

6 In the Text text field, type T_fluid.

Next, add constraints to restrain the glass plate movements.

S O L I D  M E C H A N I C S  ( S O L I D )

In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

Fixed Constraint 1
1 On the Physics toolbar, click Points and choose Fixed Constraint.

2 Select Point 1 only.
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Prescribed Displacement 1
1 On the Physics toolbar, click Points and choose Prescribed Displacement.

2 Select Point 63 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in y direction check box.

5 Select the Prescribed in z direction check box.

Prescribed Displacement 2
1 On the Physics toolbar, click Points and choose Prescribed Displacement.

2 Select Point 3 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in z direction check box.

Finally, add a voltage and ground.

E L E C T R I C  C U R R E N T S ,  S H E L L  ( E C S )

In the Model Builder window, under Component 1 (comp1) click Electric Currents, Shell (ecs).

Electric Potential 1
1 On the Physics toolbar, click Edges and choose Electric Potential.

2 Select Edge 10 only.

3 In the Settings window for Electric Potential, locate the Electric Potential section.

4 In the V0 text field, type V_in.

Ground 1
1 On the Physics toolbar, click Edges and choose Ground.

2 Select Edge 43 only.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
More Operations>Free Triangular.

Free Triangular 1
Select Boundaries 4 and 6–8 only.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Triangular 1 and choose Size.
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2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Selection list, choose Circuit.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 2.

7 In the Model Builder window, right-click Mesh 1 and choose Swept.

Swept 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Swept 1 and 
choose Distribution.

Distribution 1
1 In the Settings window for Distribution, locate the Distribution section.

2 In the Number of elements text field, type 3.

3 Click Build All.

S T U D Y  1

In order to improve the solver’s performance, set the segregated solver to calculate 
temperature, voltage and displacement separately. The best order is V, T, u.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 1>Segregated 1 node, then click Segregated Step 2.

4 In the Settings window for Segregated Step, type Electric potential V in the Label 
text field.

5 Right-click Study 1>Solver Configurations>Solution 1 (sol1)>Stationary Solver 1>

Segregated 1>Electric potential V and choose Move Up.

6 Locate the General section. In the Variables list, select Displacement field (Material) 

(comp1.u).

7 Under Variables, click Delete.

8 In the Variables list, select Normal strain (comp1.mbrn.unn).

9 Under Variables, click Delete.

10 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1)>

Stationary Solver 1>Segregated 1 click Segregated Step 3.
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11 In the Settings window for Segregated Step, type Displacement u in the Label text 
field.

12 Locate the General section. Under Variables, click Add.

13 In the Add dialog box, select Normal strain (comp1.mbrn.unn) in the Variables list.

14 Click OK.

15 On the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
The default plots show the von Mises stress including the deformation (Figure 5) and the 
temperature (Figure 4) on the surface of the full 3D geometry, and the electric potential 
and the von Mises stress on the circuit layer.

Surface 1
1 In the Model Builder window, expand the Stress (solid) node, then click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose MPa.

4 On the Stress (solid) toolbar, click Plot.

Surface
1 In the Model Builder window, expand the Results>Stress (mbrn) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose MPa.

4 On the Stress (mbrn) toolbar, click Plot.

Study 1/Solution 1 (sol1)
1 In the Model Builder window, expand the Results>Data Sets node.

2 Right-click Study 1/Solution 1 (sol1) and choose Duplicate.

Selection
1 On the Results toolbar, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Circuit.

To generate Figure 3 follow the steps below.
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3D Plot Group 6
1 On the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Surface Losses in the Label text field.

3 Locate the Data section. From the Data set list, choose Study 1/Solution 1 (2) (sol1).

Surface 1
1 Right-click Surface Losses and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Electric Currents, Shell>

Heating and losses>ecs.Qsh - Surface loss density, electromagnetic.

3 On the Surface Losses toolbar, click Plot.

4 Click the Scene Light button on the Graphics toolbar.

5 Click the Zoom Extents button on the Graphics toolbar.

The following steps generate a plot of the norm of the surface traction vector in the surface 
plane (see Figure 6):

3D Plot Group 7
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Interface Stress in the Label text 
field.

3 Locate the Data section. From the Data set list, choose Study 1/Solution 1 (2) (sol1).

Surface 1
1 Right-click Interface Stress and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type sqrt(solid.Tax^2+solid.Tay^2).

4 From the Unit list, choose MPa.

5 On the Interface Stress toolbar, click Plot.

Finally, to obtain Figure 7, proceed as follows:

Surface 1
1 On the Results toolbar, click More Data Sets and choose Surface.

2 Select Boundary 3 only.

2D Plot Group 8
1 On the Results toolbar, click 2D Plot Group.
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2 In the Settings window for 2D Plot Group, type Displacement, Bottom Boundary in 
the Label text field.

Surface 1
1 Right-click Displacement, Bottom Boundary and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>

Displacement>solid.disp - Total displacement.

3 Locate the Expression section. In the Unit field, type um.

4 On the Displacement, Bottom Boundary toolbar, click Plot.

Derived Values
To calculate the values for the total generated heat and the integrated heat flux on the fluid 
side, perform a boundary integration:

Surface Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 Select Boundary 3 only.

3 In the Settings window for Surface Integration, click Replace Expression in the 
upper-right corner of the Expressions section. From the menu, choose Component 1>

Heat Transfer in Solids>Boundary fluxes>ht.q0 - Inward heat flux.

4 Click Evaluate.

TA B L E

1 Go to the Table window.

The result should be close to 8.5 W.

R E S U L T S

Surface Integration 2
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 In the Settings window for Surface Integration, locate the Selection section.

3 From the Selection list, choose Circuit.

4 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component 1>Electric Currents, Shell>Heating and losses>ecs.Qsh - Surface 

loss density, electromagnetic.
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5 Click Evaluate.

TA B L E

1 Go to the Table window.

The result should be close to 13.8 W.
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Introduction

This application simulates the non-isothermal flow of argon gas inside a light bulb. The 
purpose of the model is to show the coupling between energy transport—through 
conduction, radiation, and convection—and momentum transport induced by density 
variations in the argon gas.

All three forms of heat transfer are taken into account. First, you have conduction, when 
a 60 W filament is heated thus transferring heat from the heat source to the light bulb. 
Then there is convection, which drives a flow inside the bulb transferring the heat from 
the filament throughout the bulb via the movement of fluids (in this case, argon gas). 
Finally, there is the radiation portion of the problem, and in this case that includes 
surface-to-surface and surface-to-ambient radiation. The Heat Transfer Module includes 
both of these types of radiation, so that you can account for shading and reflections 
between radiating surfaces, as well as ambient radiation that can be fixed or given by an 
arbitrary function. The light bulb physics involves both heat transfer and gas flow, which 
makes this a multiphysics problem and not “just” a heat transfer example.

Note: This application requires the Heat Transfer Module and the Material Library.

Model Definition

A light bulb contains a tungsten filament that is resistively heated when a current is 
conducted through it. At temperatures around 2000 K the filament starts to emit visible 
light. To prevent the tungsten wire from burning up, the bulb is filled with a gas, usually 
argon. The heat generated in the filament is transported to the surroundings through 
radiation, convection, and conduction. As the gas heats up, density and pressure changes 
induce a flow inside the bulb.
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Figure 1 shows a cross section of the axially symmetric model geometry.

Figure 1: The model geometry.

The filament is approximated with a solid torus, an approximation that implies neglecting 
any internal effects inside the filament wire.

The equations governing the non-isothermal flow are the Navier-Stokes equation with the 
gravity forces (see Gravity in the CFD Module User’s Guide). The density is given by the 
ideal gas law

where M denotes the molar weight (kg/mol), R the universal gas constant (J/(mol·K)), 
and T the temperature (K).

The convective and conductive heat transfer are modeled using the heat transfer interface 
and account for the total light bulb power equal to 60 W.

B O U N D A R Y  C O N D I T I O N S

At the bulb’s inner surfaces, radiation is described by surface-to-surface radiation. This 
means that the mutual irradiation from the surfaces that can be seen from a particular 
surface and radiation to the surroundings are accounted for. At the outer surfaces of the 

Glass

Argon

Filament

ρ Mp
RT
---------=
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bulb, radiation is described by surface-to-ambient radiation, which means that there is no 
reflected radiation from the surroundings (blackbody radiation).

The top part of the bulb, where the bulb is mounted on the cap, is insulated:

Results

The heating inside the bulb has a long and a short time scale from t = 0, when the light is 
turned on. The shorter scale captures the heating of the filament and the gas close to it. 
The following series of pictures shows the temperature distribution inside the bulb at t = 2, 
6, and 10 s.

Figure 2: Temperature distribution at t = 2, 6, and 10 s. The color ranges differ between the 
plots.

When the temperature changes, the density of the gas changes, inducing a gas flow inside 
the bulb. The following series of pictures shows the velocity field inside the bulb after 2, 
6, and 10 s.

Figure 3: Velocity field after 2, 6, and 10 s. The color ranges differ between the plots.

n– k∇T–( )⋅ 0=
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On the longer time scale, the glass on the bulb’s outer side heats up. The following plot 
shows the temperature distribution in the bulb after 5 minutes.

Figure 4: Temperature distribution after 5 minutes.
5 |  F R E E  C O N V E C T I O N  I N  A  L I G H T  B U L B



Figure 5 shows the temperature distribution at a point on the boundary of the bulb at the 
same vertical level as the filament. This plot shows the slow heating of the bulb. After 
5 minutes, the bulb has reached a steady-state temperature of 580 K.

Figure 5: Temperature distribution at a point on the boundary of the bulb at the same vertical 
level as the filament.

Heat is transported from the boundary of the bulb through both convective heat flux and 
radiation. The net radiative heat flux leaving the bulb at t = 300 s is plotted in Figure 6, as 
function of the z-coordinate. The top boundaries of the bulb where the bulb is mounted 
on the cap are excluded from this plot. The distinct bump in the curve occurs at the same 
vertical level as the filament.
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Figure 6: The net radiative heat flux leaving the bulb.

Notes About the COMSOL Implementation

To set up the model, use the Heat Transfer Module’s Conjugate Heat Transfer predefined 
multiphysics coupling. The model uses material from the Material Library to accurately 
account for temperature-dependent properties over a wide range. The model setup is 
straightforward and also shows how to create your own material to treat argon as an ideal 
gas. When working with surface-to-surface radiation in COMSOL, fluid domains are 
considered as transparent and solid domains as opaque by default, which are the expected 
properties for this model. The assumption that the glass on the bulb is opaque might seem 
odd, but it is valid because glass is almost opaque to heat radiation but transparent to 
radiation in the visible spectrum.

Application Library path: Heat_Transfer_Module/Thermal_Radiation/
light_bulb
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Heat Transfer>Conjugate Heat Transfer>Laminar Flow.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Time 

Dependent.

6 Click Done.

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
light_bulb.mphbin.

5 Click Import.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

h0 5[W/(m^2*K)] 5 W/(m²·K) Heat transfer 
coefficient

Qf 60[W] 60 W Heat source in 
filament
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A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Material Library>Elements>Tungsten>Tungsten [solid]>Tungsten [solid,

Ho et al].

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Tungsten [solid,Ho et al] (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Tungsten 

[solid,Ho et al] (mat1).

2 Select Domain 3 only.

To apply the surface emissivity for tungsten as a material property, you also need to define 
tungsten as the material for the filament surface.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Material Library>Elements>Tungsten>Tungsten [solid]>Tungsten [solid,

Ho et al].

3 Click Add to Component in the window toolbar.

4 On the Home toolbar, click Add Material to close the Add Material window.

p0 50[kPa] 5E4 Pa Initial pressure

rho_glass 2595[kg/m^3] 2595 kg/m³ Density, glass

k_glass 1.09[W/(m*K)] 1.09 W/(m·K) Thermal 
conductivity, glass

Cp_glass 750[J/(kg*K)] 750 J/(kg·K) Heat capacity, glass

eps_glass 0.8 0.8 Surface emissivity, 
glass

Mw_a 39.94[g/mol] 0.03994 kg/mol Molar mass, argon

Name Expression Value Description
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M A T E R I A L S

Tungsten [solid,Ho et al] 1 (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Tungsten 

[solid,Ho et al] 1 (mat2).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundaries 15–18 only.

Material 3 (mat3)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Glass in the Label text field.

3 Select Domain 1 only.

4 Locate the Material Contents section. In the table, enter the following settings:

You will return to the Materials branch shortly to specify glass at the boundaries of the 
glass domain and argon as the material for the interior of the bulb. However, first set 
up the physics to let COMSOL Multiphysics flag what properties you need to specify 
manually.

L A M I N A R  F L O W  ( S P F )

Since the density variation is not small, the flow can not be regarded as incompressible. 
Therefore set the flow to be compressible.

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

2 In the Settings window for Laminar Flow, locate the Physical Model section.

3 From the Compressibility list, choose Compressible flow (Ma<0.3).

4 Select Domain 2 only.

Define the pressure reference level in the interface properties.

5 Find the Reference values subsection. In the pref text field, type p0.

Property Name Value Unit Property 
group

Thermal conductivity k k_glass W/(m·K) Basic

Density rho rho_glass kg/m³ Basic

Heat capacity at constant 
pressure

Cp Cp_glass J/(kg·K) Basic
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6 In the Settings window for Laminar Flow, locate the Domain Selection section.

7 Click Create Selection.

8 In the Create Selection dialog box, type Argon in the Selection name text field.

9 Click OK.

H E A T  TR A N S F E R  ( H T )

On the Physics toolbar, click Laminar Flow (spf) and choose Heat Transfer (ht).

Fluid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Fluid 

1.

2 In the Settings window for Fluid, locate the Domain Selection section.

3 From the Selection list, choose Argon.

4 In the Model Builder window, click Heat Transfer (ht).

5 In the Settings window for Heat Transfer, locate the Physical Model section.

6 Select the Surface-to-surface radiation check box.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Initial 

Values 1.

2 In the Settings window for Initial Values, type 25[degC] in the T text field.

Diffuse Surface 1
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 Select Boundaries 8, 9, 12–19, and 21–24 only.

3 In the Settings window for Diffuse Surface, locate the Ambient section.

4 In the Tamb text field, type T.

By default, the radiation direction is controlled by the opacity of the domains. The solid 
parts are automatically defined as opaque while the fluid parts are transparent. You can 
change these settings by modifying the Opacity subnode under the Solid and Fluid 
features. For this model, the default settings apply.

Diffuse Surface 2
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 Select Boundaries 11 and 25 only.

3 In the Settings window for Diffuse Surface, locate the Ambient section.

4 In the Tamb text field, type 25[degC].
11 |  F R E E  C O N V E C T I O N  I N  A  L I G H T  B U L B



Heat Source 1
1 On the Physics toolbar, click Domains and choose Heat Source.

2 Select Domain 3 only.

3 In the Settings window for Heat Source, locate the Heat Source section.

4 Click the Heat rate button.

5 In the P0 text field, type Qf.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 11 and 25 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type h0.

6 In the Text text field, type 25[degC].

L A M I N A R  F L O W  ( S P F )

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

2 In the Settings window for Laminar Flow, locate the Physical Model section.

3 Select the Include gravity check box.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 4 (mat4)
1 In the Settings window for Material, type Glass (Boundaries) in the Label text field.

2 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

3 Select Boundaries 7–14 and 19–25 only.

4 Locate the Material Contents section. In the table, enter the following settings:

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

Property Name Value Unit Property group

Surface emissivity epsilon_rad eps_glass 1 Basic
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2 Go to the Add Material window.

3 In the tree, select Material Library>Elements>Argon>Argon [gas].

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

M A T E R I A L S

Argon [gas] (mat5)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Argon [gas] 

(mat5).

2 Select Domain 2 only.

As you can see, COMSOL Multiphysics warns about required properties that have not 
been defined yet. Define these as follows.

3 In the Settings window for Material, locate the Material Contents section.

4 In the table, enter the following settings:

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Fine.

4 Click Build All.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,0.1,1) range(1.5,0.5,20) range(21,3,
300).

4 Select the Relative tolerance check box.

Property Name Value Unit Property group

Ratio of specific 
heats

gamma 1.6 1 Basic

Density rho ht.pA*Mw_a/
(R_const*T)

kg/m³ Basic
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5 In the associated text field, type 0.001.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Study 1>Solver Configurations node.

3 In the Model Builder window, expand the Solution 1 (sol1) node, then click Dependent 

Variables 1.

4 In the Settings window for Dependent Variables, locate the Scaling section.

5 From the Method list, choose Manual.

For a nonlinear time-dependent problem such as this one, a judicious manual scaling of 
the variables can improve convergence during solving.

6 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Dependent Variables 1 node, then click Velocity field (comp1.u).

7 In the Settings window for Field, locate the Scaling section.

8 From the Method list, choose Manual.

9 In the Scale text field, type 0.1.

10 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1)>

Dependent Variables 1 click Surface radiosity (comp1.ht.J).

11 In the Settings window for Field, locate the Scaling section.

12 From the Method list, choose Manual.

13 In the Scale text field, type 1e5.

14 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1)>

Dependent Variables 1 click Temperature (comp1.T).

15 In the Settings window for Field, locate the Scaling section.

16 From the Method list, choose Manual.

17 In the Scale text field, type 1e3.

18 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1)>

Dependent Variables 1 click Pressure (comp1.p).

19 In the Settings window for Field, locate the Scaling section.

20 From the Method list, choose Manual.

21 In the Scale text field, type 1e4.

22 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1) click 
Time-Dependent Solver 1.
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23 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

24 Locate the Time Stepping section. From the Method list, choose Generalized alpha.

25 From the Steps taken by solver list, choose Manual.

26 In the Time step text field, type 0.02*if(t<10,1,10).

27 Click to expand the Advanced section. On the Study toolbar, click Compute.

R E S U L T S

Temperature, 3D (ht)
The first default 3D plot shows the temperature at the end of the simulation interval 
(Figure 4). Look at the temperature field at different times and compare the resulting 
series of plots with those in Figure 2.

1 Click the Zoom Extents button on the Graphics toolbar.

2 In the Model Builder window, under Results click Temperature, 3D (ht).

3 In the Settings window for 3D Plot Group, locate the Data section.

4 From the Time (s) list, choose 2.

5 On the Temperature, 3D (ht) toolbar, click Plot.

Compare with the left panel in Figure 2.

6 From the Time (s) list, choose 6.

7 On the Temperature, 3D (ht) toolbar, click Plot.

Compare with the middle panel in Figure 2.

8 From the Time (s) list, choose 10.

9 On the Temperature, 3D (ht) toolbar, click Plot.

Compare with the right panel in Figure 2.

Pressure (spf)
This default plot shows the pressure field in a 2D contour plot. Change the unit to kPa as 
follows.

1 In the Model Builder window, expand the Pressure (spf) node, then click Contour.

2 In the Settings window for Contour, locate the Expression section.

3 From the Unit list, choose kPa.

4 On the Pressure (spf) toolbar, click Plot.
15 |  F R E E  C O N V E C T I O N  I N  A  L I G H T  B U L B



Velocity (spf) 1
This default plot shows the velocity magnitude in a 3D plot, obtained by a revolution of 
the 2D axisymmetric data set, at the end of the simulation interval. Now proceed to 
reproduce the velocity field plots in Figure 3.

Because the velocity magnitude is a quadratic expression in the basic velocity variables it 
looks less smooth than the temperature plot. You can easily remedy the situation by 
adjusting the Quality settings.

1 In the Model Builder window, expand the Velocity (spf) 1 node, then click Surface.

2 In the Settings window for Surface, click to expand the Quality section.

3 From the Resolution list, choose Fine.

4 On the Velocity (spf) 1 toolbar, click Plot. This ensures that the resolution is sufficient.

5 In the Model Builder window, click Velocity (spf) 1.

6 In the Settings window for 3D Plot Group, locate the Data section.

7 From the Time (s) list, choose 2.

8 On the Velocity (spf) 1 toolbar, click Plot.

Compare with the left panel in Figure 3.

9 From the Time (s) list, choose 6.

10 On the Velocity (spf) 1 toolbar, click Plot.

Compare with the middle panel in Figure 3.

11 From the Time (s) list, choose 10.

12 On the Velocity (spf) 1 toolbar, click Plot.

Compare with the right panel in Figure 3.

1D Plot Group 7
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

To visualize the heating of the bulbs surface with time by plotting the temperature at a 
point at the same vertical level as the filament, follow the steps below.

2 In the Settings window for 1D Plot Group, type Temperature vs Time in the Label 
text field.

Point Graph 1
On the Temperature vs Time toolbar, click Point Graph.

Temperature vs Time
1 Select Point 24 only.
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2 In the Settings window for Point Graph, click Replace Expression in the upper-right 
corner of the y-axis data section. From the menu, choose Model>Component 1>Heat 

Transfer>Temperature>T - Temperature.

3 On the Temperature vs Time toolbar, click Plot.

Finally, study the radiative heat flux from the bulb. First plot the radiative heat flux versus 
the vertical coordinate, z.

1D Plot Group 8
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Radiative Heat Flux along 
z-Coordinate in the Label text field.

3 Locate the Data section. From the Time selection list, choose Last.

Line Graph 1
On the Radiative Heat Flux along z-Coordinate toolbar, click Line Graph.

Radiative Heat Flux along z-Coordinate
1 Select Boundaries 11 and 25 only.

2 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Model>Component 1>Heat Transfer>

Boundary fluxes>ht.rflux - Radiative heat flux.

3 Click Replace Expression in the upper-right corner of the x-axis data section. From the 
menu, choose Model>Component 1>Geometry>Coordinate>z - z-coordinate.

4 Locate the x-Axis Data section. From the Unit list, choose cm.

5 On the Radiative Heat Flux along z-Coordinate toolbar, click Plot.

Derived Values
You can readily compute the total radiative heat flux from the bulb at steady state as 
follows.

Line Integration 1
On the Results toolbar, click More Derived Values and choose Integration>Line Integration.

Derived Values
1 In the Settings window for Line Integration, locate the Data section.

2 From the Time selection list, choose Last.

3 Select Boundaries 11 and 25 only.
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4 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Heat Transfer>Boundary fluxes>ht.rflux - Radiative 

heat flux.

5 Locate the Integration Settings section. Select the Compute surface integral check box.

6 Click Evaluate.

TA B L E

1 Go to the Table window.

The result should be close to 45 W.
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Introduction

This classical verification example solves the steady-state temperature distribution in a 
plane disk heated by a localized heat source at its center. It shows and compares different 
ways to define a heat source localized on a small domain by representing it either as a 
geometrical point or as a small disk. 

Both modelings have analytical solutions to which the obtained numerical results can be 
compared. The results bring guidelines to select the suitable option depending on the ratio 
of source to surrounding geometry typical size.

Model Definition

The model computes the temperature field on a cork disk of radius Rdisk = 0.1 m. A fixed 
temperature T0 = 300 K is set on the disk boundary, and a heat source of total power 
P = 1 W is applied on a small circular area (radius Rsource = 10-2 m) centered at the origin.

Figure 1: Geometry and boundary conditions.

The model configuration shows an axial symmetry which implies that the temperature 
profile is only a function of the distance to the disks center. In cylindrical coordinates it 
means that the temperature profile is a function of r only: T(r, θ) = T(r, 0). Despite the fact 
that this tutorial can be set up using a 1D axisymmetric geometry, defining it in 2D makes 
its extension to non-axial symmetric cases easier. Recall that Cartesian coordinates (x, ,y) 
and cylindrical coordinates (r, θ) are related by:

Rdisk

Rsource

T0

P0 = 1  W

r2 x2 y2
+=

θ y

x x2 y2
++
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In this document both coordinate systems are used jointly.

P U N C T U A L  H E A T  S O U R C E  M O D E L

In order to simplify the geometry and to avoid high aspect ratio when Rsource is 
significantly smaller than Rdisk, represent the source as a punctual source applied on the 
origin point. This model corresponds to the following equation with a singular source 
term, with the following formal formulation:

where k is the thermal conductivity, Q = P ⁄ dz is the volumetric heat source, dz is the 
out-of-plane thickness and δ is the Dirac distribution centered at the origin. The solution 
of this equation is:

 (1)

According to Equation 1, the temperature goes to ±∞ when approaching the origin 
(r = 0). This singularity is illustrated on Figure 2 where the temperature value increases 
indefinitely when refining the mesh.

∇ k T∇–( )⋅ Qδ= in the disk domain
T T0= on the disk boundary




T r( ) T0
Q

2πk
---------- r

Rdisk
-------------- 
 ln–=
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Figure 2: Distribution of relative temperature on the disk with a point heat source at the 
center.

VO L U M E  H E A T  S O U R C E

You can also model the heat source explicitly and apply it on a disk of radius Rsource around 
the origin. Then, the formulation of the problem to solve is:

where f is a smoothed heat source distribution defined by

The analytical solution in this case is:

∇ k T∇–( )⋅ f= in the disk domain
T T0= on the disk boundary




f r( )
Q

πRsource
2

------------------------

0

if r Rsource<

if r Rsource≥






=

4 |  H E A T  C O N D U C T I O N  W I T H  A  L O C A L I Z E D  H E A T  S O U R C E  O N  A  D I S K



 (2)

The spatial extension of the heat source has a smoothing effect that removes the singularity 
at the origin, as shown on Figure 3 for Rsource = 10-2 m: 

Figure 3: Distribution of relative temperature on the disk with a volume heat source.

Equation 1 and Equation 2 show that the temperature profiles are identical for 
r ≥ Rsource. The only difference is observed inside the source disk (r < Rsource), as shown 
on Figure 4:
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Figure 4: Analytical temperature distribution along a disk radius for punctual vs volume 
source, for a source radius of 10-2 m.

Notes about the COMSOL implementation

COMSOL Multiphysics provides different options to model a localized heat source.

1 The source support can be defined as a geometrical point. In this case, use the Line Heat 

Source (2D and 2D axisymmetric), Point Heat Source on Axis (2D axisymmetric) or Point 

Heat Source (3D) features. This leads to a singularity in the temperature field at the point 
where the source is applied. Numerically, the finer the mesh, the larger the temperature 
variation. In general, the two alternatives described below should be considered instead 
of this option, except for cases where a singular source is needed.

2 The heat source definition described above can be modified so that COMSOL 
Multiphysics accounts for the source size without needing a mesh nor a geometry 
change. In Line Heat Source (2D and 2D axisymmetric), Point Heat Source on Axis (2D 
axisymmetric) or Point Heat Source (3D) features, select the Specify heat source radius 
check-box and set the Heat source radius to Rsource. Then the heat source is 
automatically distributed over a disk in 2D (a torus in 2D axisymmetric or a sphere in 
3D) as illustrated by the black disk on the right image of Figure 5, even if the mesh 
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elements size is larger than Rsource.

3 If the size of the source is not too small compared to the surrounding geometry details, 
then a domain representing the heat source can be drawn (see the disk of radius Rsource 
on the left image of Figure 5) and a Heat Source feature can be defined there. This 
option can be considered when the increase of the number of mesh elements induced 
by the geometry change can be afforded.

Figure 5: Different mesh configurations: elements size smaller (left) and larger (right) than 
the source radius. The source domain is delimited by a black circle at the center.

Results and Discussion

In this section, first take advantage of the simple geometrical configuration to verify the 
accuracy of the different methods by comparing the numerical results with the analytical 
solutions in the Numerical accuracy of the different methods subsection.

However in many practical cases, the use of the Heat Source feature is not an option because 
of the prohibitive computational cost induced by the meshing of the heat source domain. 
The accuracy of the Line Heat Source feature, with or without the Specify heat source radius 
option is analyzed in the Coarse mesh case subsection.

Finally the results are summarized to define Guidelines for modeling a heat source 
localized on a small domain.
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N U M E R I C A L  A C C U R A C Y  O F  T H E  D I F F E R E N T  M E T H O D S

In order to check the accuracy of the Line Heat Source feature for a punctual heat source, 
the mesh is gradually refined around the heat source, by lowering the maximum size mh of 
the elements in the neighborhood of the origin from 10-2 m to 10-6 m.

Figure 6: Relative L2 error (punctual analytical vs numerical solution with Line Heat Source 
feature) as a function of mesh refinement 

Figure 6 shows that the relative L2 error diminishes with mesh refinement, which validates 
the use of the Line Heat Source for this kind of problems.
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The maximum temperature value obtained with different meshes, shown in Figure 7, 
illustrates the temperature amplitude increase as the mesh size decreases. 

Figure 7: Maximum temperature as a function of mesh refinement (numerical solution for a 
punctual heat source)

A model with a volume source (Rsource = 10-2 m) is now considered and the convergence 
of the numerical solution as the mesh is refined is investigated.

First, the Heat Source feature is used on the domain of radius Rsource, which has to be 
explicitly drawn in the geometry. Figure 8 shows the very good agreement between the 
computed temperature and the analytical solution.
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Figure 8: Temperature distribution along a disk radius for a volume source, analytical and 
numerical computations (Heat Source feature)

The accuracy of the Line Heat Source feature with Specify heat source radius checkbox 
selected is verified using comparable mesh configurations on a geometry representing the 
source as a point.
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Figure 9: Temperature distribution along a disk radius for a volume source, analytical and 
numerical solutions (Line Heat Source with Specify heat source radius check-box selected)

Figure 9 shows the very good agreement between the analytical solution and the 
temperature computed using the Line Heat Source feature with Specify heat source radius 

checkbox selected.
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Figure 10: Relative L2 error (volume source analytical vs numerical solution Line Heat 
Source with Specify heat source radius check-box selected) as a function of mesh refinement 

The convergence of the relative L2 error for fine mesh cases (mh ≤ 10-2 m) is shown on 
Figure 10. This validates the accuracy of the Line Heat Source feature with Specify heat 

source radius check-box selected.

C O A R S E  M E S H  C A S E

When the meshing of the heat source domain is not be affordable, the Heat Source feature 
is not applicable any more. Low mesh resolution configurations are now considered to 
compare the accuracy of the Line Heat Source feature, with or without the Specify heat 

source radius. 
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Figure 11: Relative L2 error as a function of mesh size, using Line Heat Source feature with 
Specify heat source radius check-box selected

The case mh = 0.06 m (first point in the top left corner) corresponds to the mesh displayed 
on the right column of Figure 5, for which the circle of radius Rsource is much smaller than 
the mesh element size. Even for this case, the relative L2 error remains in an acceptable 
range (relative error less than 0.03). 
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To go further, the error on this very coarse mesh is compared for the two versions of the 
Line Heat Source feature, namely with and without the Specify heat source radius checkbox 
selected. 

Figure 12: Temperature distribution along a disk radius for the two versions of the Line Heat 
Source feature (with and without specified radius), on a coarse mesh (mh = 0.06 m)

Figure 12 shows that the error close to the heat source is greatly reduced by selecting the 
Specify heat source radius checkbox.

G U I D E L I N E S

This tutorial brings the following conclusions regarding the modeling of localized heat 
sources with COMSOL Multiphysics. 

If the heat source radius is large enough so that it can be drawn and meshed without 
prohibitive computational cost, then the Heat Source feature is the best option. In other 
cases, the Line Heat Source (2D and 2D axisymmetric), Point Heat Source on axis (2D 
axisymmetric) or Point Heat Source (3D) features with Specify heat source radius checkbox 
selected should be preferred. The Specify heat source radius checkbox is left unselected only 
for cases where the source is intended to be singular.
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The Line Heat Source with specified radius option appears therefore as an accurate 
alternative to the punctual approach. In particular the temperature at the heat source 
location converges to a finite value when the mesh is refined. 

Application Library path: Heat_Transfer_Module/Verification_Examples/
localized_heat_source

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

R_disk 0.1[m] 0.1 m Disk radius

R_source 0.01[m] 0.01 m Source radius

T0 300[K] 300 K Disk boundary 
temperature

k_cork 0.042[W/(m*K)] 0.042 W/(m·K) Thermal 
conductivity, cork
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Define an analytic function for the solution of the problem with a punctual heat source.

Analytic 1 (an1)
1 On the Home toolbar, click Functions and choose Global>Analytic.

2 In the Settings window for Analytic, locate the Definition section.

3 In the Expression text field, type -1/(2*pi*k_cork)*log(sqrt(x^2+y^2)/R_disk) 
+ T0.

4 In the Arguments text field, type x,y.

5 Locate the Units section. In the Arguments text field, type m.

6 In the Function text field, type K.

7 Locate the Plot Parameters section. In the table, enter the following settings:

8 Click Plot.

Define an analytic function for the solution of the problem with a volume heat source.

Analytic 2 (an2)
1 On the Home toolbar, click Functions and choose Global>Analytic.

2 In the Settings window for Analytic, locate the Definition section.

3 In the Expression text field, type if(sqrt(x^2+y^2)>R_source, (-1/(2*pi*
k_cork)*log(sqrt(x^2+y^2)/R_disk) + T0), (1/(2*pi*k_cork)*(-(x^2+

y^2)/(2*R_source^2)+0.5-log(R_source/R_disk)) + T0)).

4 In the Arguments text field, type x,y.

cp_cork 1.88[kJ/(kg*K)] 1880 J/(kg·K) Heat capacity at 
constant pressure, 
cork

rho_cork 150[kg/m^3] 150 kg/m³ Density, cork

mh 0.01[m] 0.01 m Mesh size parameter

Argument Lower limit Upper limit

x -R_disk R_disk

y -R_disk R_disk

Name Expression Value Description
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5 Locate the Plot Parameters section. In the table, enter the following settings:

6 Locate the Units section. In the Arguments text field, type m.

7 In the Function text field, type K.

8 Click Plot.

The geometry consists of a circle and a point at the origin of the circle. This geometry 
is suitable for the definition of either a punctual or a volume heat source with the Line 

Heat Source feature.

G E O M E T R Y  1

Circle 1 (c1)
1 On the Geometry toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type R_disk.

Point 1 (pt1)
1 On the Geometry toolbar, click Primitives and choose Point.

2 In the Settings window for Point, click Build All Objects.

Next, create a new material (Cork) for the disk, and define the needed properties.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, type Cork in the Label text field.

2 Locate the Material Contents section. In the table, enter the following settings:

Argument Lower limit Upper limit

x -R_disk R_disk

y -R_disk R_disk

Property Name Value Unit Property 
group

Thermal conductivity k k_cork W/(m·K) Basic
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H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 In the Settings window for Temperature, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

4 Locate the Temperature section. In the T0 text field, type T0.

As a first step, consider the case of a punctual heat source. Use the Line Heat Source feature 
with default settings for that. You will disable this branch later when defining a volume 
heat source.

Line Heat Source 1
1 On the Physics toolbar, click Points and choose Line Heat Source.

2 Select Point 3 only.

3 In the Settings window for Line Heat Source, locate the Line Heat Source section.

4 Click the Heat rate button.

5 In the Pl text field, type 1.

Next, define a parameterized mesh that can be refined around the origin of the disk. This 
way you can study the effect of mesh refinement on the heat source computation without 
increasing too much the mesh size.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Sequence type list, choose User-controlled mesh.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Coarse.

Density rho rho_cork kg/m³ Basic

Heat capacity at constant 
pressure

Cp cp_cork J/(kg·K) Basic

Property Name Value Unit Property 
group
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Free Triangular 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Triangular 1 and choose Size.

Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Point.

3 Select Point 3 only.

4 Locate the Element Size section. From the Predefined list, choose Coarse.

5 Click the Custom button.

6 Locate the Element Size Parameters section. Select the Maximum element size check box.

7 In the associated text field, type mh.

8 Click Build All.

Now, define integration and maximum operators on the whole domain, for 
postprocessing.

D E F I N I T I O N S

Integration 1a (intop1)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Selection list, choose All domains.

Maximum 1 (maxop1)
1 On the Definitions toolbar, click Component Couplings and choose Maximum.

2 In the Settings window for Maximum, locate the Source Selection section.

3 From the Selection list, choose All domains.

S T U D Y  1

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Study 1: Point Source in the Label text field.

Parametric Sweep
On the Study toolbar, click Parametric Sweep.
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S T U D Y  1 :  PO I N T  S O U R C E

Parametric Sweep
Define a parametric sweep on the maximum size of mesh elements in order to study the 
effects of mesh refinement on the heat source computation.

1 In the Settings window for Parametric Sweep, locate the Study Settings section.

2 Click Add.

3 Select mh from the list.

4 Click Range.

5 In the Range dialog box, type -6 in the Start text field.

6 In the Step text field, type 0.5.

7 In the Stop text field, type -2.

8 From the Function to apply to all values list, choose exp10.

9 Click Replace.

10 On the Study toolbar, click Compute.

R E S U L T S

Temperature (ht)
The first default plot shows the temperature distribution in a 2D plot for mh = 10−2m. 
Proceed as follows to reproduce the plot of Figure 2 that corresponds to mh = 10−3m.

1 In the Model Builder window, under Results click Temperature (ht).

2 In the Settings window for 2D Plot Group, type Temperature - Study 1 in the Label 
text field.

3 Locate the Data section. From the Parameter value (mh (m)) list, choose 0.001.

4 On the Temperature - Study 1 toolbar, click Plot.

Surface
1 In the Model Builder window, expand the Results>Temperature - Study 1 node, then click 

Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type T-T0.

Height Expression 1
1 Right-click Results>Temperature - Study 1>Surface and choose Height Expression.

2 On the Temperature - Study 1 toolbar, click Plot.
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3 Click the Zoom Extents button on the Graphics toolbar.

Then, proceed to reproduce the plot of Figure 6, by plotting the relative L2 error 
between numerical and analytical solutions as a function of 1/mh, in order to check 
numerical convergence.

1D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type L2 Error from Analytical 
Solution - Study 1 in the Label text field.

3 Locate the Data section. From the Data set list, choose Study 1: Point Source/Parametric 

Solutions 1 (sol2).

Line Graph 1
1 On the L2 Error from Analytical Solution - Study 1 toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Selection section.

3 From the Selection list, choose All boundaries.

4 Locate the y-Axis Data section. In the Expression text field, type 
sqrt(intop1((T-an1(x,y))^2))/sqrt(intop1((T-T0)^2)).

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type 1/mh.

7 Click to expand the Coloring and style section. Locate the Coloring and Style section. 
From the Color list, choose Blue.

8 In the Width text field, type 5.

9 On the L2 Error from Analytical Solution - Study 1 toolbar, click Plot.

10 Click the x-Axis Log Scale button on the Graphics toolbar.

Next, plot the maximum temperature as a function of 1/mh, as in the plot of Figure 7.

1D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Maximum Temperature - Study 1 in 
the Label text field.

3 Locate the Data section. From the Data set list, choose Study 1: Point Source/Parametric 

Solutions 1 (sol2).

Line Graph 1
1 On the Maximum Temperature - Study 1 toolbar, click Line Graph.
21 |  H E A T  C O N D U C T I O N  W I T H  A  L O C A L I Z E D  H E A T  S O U R C E  O N  A  D I S K



2 In the Settings window for Line Graph, locate the Selection section.

3 From the Selection list, choose All boundaries.

4 Locate the y-Axis Data section. In the Expression text field, type maxop1(T).

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type 1/mh.

7 Locate the Coloring and Style section. From the Color list, choose Blue.

8 In the Width text field, type 5.

9 On the Maximum Temperature - Study 1 toolbar, click Plot.

10 Click the x-Axis Log Scale button on the Graphics toolbar.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

As a second step, consider the case of a volume heat source. Use the Line Heat Source 
feature with the Specify heat source radius option selected, and the Heat source radius set 
to a positive value.

Line Heat Source 2
1 On the Physics toolbar, click Points and choose Line Heat Source.

2 Select Point 3 only.

3 In the Settings window for Line Heat Source, locate the Line Heat Source section.

4 Click the Heat rate button.

5 In the Pl text field, type 1.

6 Locate the Heat Source Radius section. Select the Specify heat source radius check box.

7 In the R text field, type R_source.

In the next steps, configure Study 1 to use Line Heat Source 1 and create a second study that 
uses Line Heat Source 2.

S T U D Y  1 :  PO I N T  S O U R C E

Step 1: Stationary
1 In the Model Builder window, under Study 1: Point Source click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify physics tree and variables for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>Heat Transfer in 

Solids (ht)>Line Heat Source 2.

5 Click Disable.
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A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies.

4 In the Select Study tree, select Preset Studies>Stationary.

5 Click Add Study in the window toolbar.

S T U D Y  2

Step 1: Stationary
1 On the Home toolbar, click Add Study to close the Add Study window.

2 In the Model Builder window, under Study 2 click Step 1: Stationary.

3 In the Settings window for Stationary, locate the Physics and Variables Selection section.

4 Select the Modify physics tree and variables for study step check box.

5 In the Physics and variables selection tree, select Component 1 (comp1)>Heat Transfer in 

Solids (ht)>Line Heat Source 1.

6 Click Disable.

Again, define a parametric sweep on the maximum size of mesh elements in order to 
study the effects of mesh refinement on the heat source computation.

7 In the Model Builder window, click Study 2.

8 In the Settings window for Study, type Study 2: Point Source with Radius in the 
Label text field.

Parametric Sweep
On the Study toolbar, click Parametric Sweep.

S T U D Y  2 :  PO I N T  S O U R C E  W I T H  R A D I U S

Parametric Sweep
1 In the Settings window for Parametric Sweep, locate the Study Settings section.

2 Click Add.

3 Select mh from the list.

4 Click Range.

5 In the Range dialog box, type -6 in the Start text field.

6 In the Step text field, type 0.5.

7 In the Stop text field, type -2.
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8 From the Function to apply to all values list, choose exp10.

9 Click Replace.

10 On the Study toolbar, click Compute.

R E S U L T S

Temperature (ht)
The first default plot shows the temperature distribution in a 2D plot for mh=10−2m. 
Proceed as follows to reproduce the plot in Figure 3.

1 In the Model Builder window, under Results click Temperature (ht).

2 In the Settings window for 2D Plot Group, type Temperature - Study 2 in the Label 
text field.

3 Locate the Data section. From the Parameter value (mh (m)) list, choose 0.001.

4 On the Temperature - Study 2 toolbar, click Plot.

Surface
1 In the Model Builder window, expand the Results>Temperature - Study 2 node, then click 

Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type T-T0.

Height Expression 1
1 Right-click Results>Temperature - Study 2>Surface and choose Height Expression.

2 On the Temperature - Study 2 toolbar, click Plot.

3 Click the Zoom Extents button on the Graphics toolbar.

Plot the analytical solutions of the two problems (punctual and volume heat sources) along 
a disk radius, to reproduce the plot of Figure 4.

Cut Line 2D 1
1 On the Results toolbar, click Cut Line 2D.

2 In the Settings window for Cut Line 2D, locate the Data section.

3 From the Data set list, choose Study 2: Point Source with Radius/Parametric Solutions 2 

(sol13).

4 Locate the Line Data section. In row Point 2, set x to R_disk.

5 Click Plot.
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1D Plot Group 7
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Analytical Solutions, Point 
Source with/without Radius in the Label text field.

3 Locate the Data section. From the Data set list, choose Cut Line 2D 1.

4 From the Parameter selection (mh) list, choose First.

Line Graph 1
1 On the Analytical Solutions, Point Source with/without Radius toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the y-Axis Data section.

3 In the Expression text field, type an1(x,y).

4 Locate the Coloring and Style section. In the Width text field, type 3.

5 Click to expand the Legends section. Select the Show legends check box.

6 From the Legends list, choose Manual.

7 In the table, enter the following settings:

Analytical Solutions, Point Source with/without Radius
In the Model Builder window, under Results click Analytical Solutions, Point Source with/

without Radius.

Line Graph 2
1 On the Analytical Solutions, Point Source with/without Radius toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the y-Axis Data section.

3 In the Expression text field, type an2(x,y).

4 Locate the Coloring and Style section. In the Width text field, type 3.

5 Locate the Legends section. Select the Show legends check box.

6 From the Legends list, choose Manual.

7 In the table, enter the following settings:

8 On the Analytical Solutions, Point Source with/without Radius toolbar, click Plot.

Legends

Temperature, point source

Legends

Temperature, point source with specified radius
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Next, proceed to reproduce the plot of Figure 9, by plotting the temperature distribution 
for numerical and analytical solutions along a disk radius, for mh=10−2m.

1D Plot Group 8
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Temperature vs Radius - Study 2 
in the Label text field.

3 Locate the Data section. From the Data set list, choose Cut Line 2D 1.

4 From the Parameter selection (mh) list, choose Last.

Line Graph 1
1 On the Temperature vs Radius - Study 2 toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Coloring and Style section.

3 Find the Line style subsection. From the Line list, choose None.

4 Find the Line markers subsection. From the Marker list, choose Circle.

5 In the Number text field, type 25.

6 Locate the Legends section. Select the Show legends check box.

7 From the Legends list, choose Manual.

8 In the table, enter the following settings:

Temperature vs Radius - Study 2
In the Model Builder window, under Results click Temperature vs Radius - Study 2.

Line Graph 2
1 On the Temperature vs Radius - Study 2 toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the y-Axis Data section.

3 In the Expression text field, type an2(x,y).

4 Locate the Coloring and Style section. In the Width text field, type 3.

5 Locate the Legends section. Select the Show legends check box.

6 From the Legends list, choose Manual.

7 In the table, enter the following settings:

Legends

Numerical, mh = 0.01

Legends

Analytical
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8 On the Temperature vs Radius - Study 2 toolbar, click Plot.

Proceed to reproduce the plot of Figure 10, by plotting the relative L2 error between 
numerical and analytical solutions as a function of mesh size parameter 1/mh, to check 
numerical convergence.

1D Plot Group 9
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type L2 Error from Analytical 
Solution - Study 2 in the Label text field.

3 Locate the Data section. From the Data set list, choose Study 2: Point Source with Radius/

Parametric Solutions 2 (sol13).

Line Graph 1
1 On the L2 Error from Analytical Solution - Study 2 toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Selection section.

3 From the Selection list, choose All boundaries.

4 Locate the y-Axis Data section. In the Expression text field, type 
sqrt(intop1((T-an2(x,y))^2))/sqrt(intop1((T-T0)^2)).

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type 1/mh.

7 Locate the Coloring and Style section. From the Color list, choose Blue.

8 In the Width text field, type 5.

9 On the L2 Error from Analytical Solution - Study 2 toolbar, click Plot.

10 Click the x-Axis Log Scale button on the Graphics toolbar.

Next, proceed to reproduce the plot of Figure 12, by plotting the absolute value of the 
error along a disk radius between each numerical solution and the analytical one for a 
volume heat source, for mh=10−2m.

Cut Line 2D 2
1 On the Results toolbar, click Cut Line 2D.

2 In the Settings window for Cut Line 2D, locate the Data section.

3 From the Data set list, choose Study 1: Point Source/Parametric Solutions 1 (sol2).

4 Locate the Line Data section. In row Point 2, set x to R_disk.

5 Click Plot.
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1D Plot Group 10
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type L1 Error from Analytical 
Solutions - Study 1 and Study 2 in the Label text field.

3 Locate the Data section. From the Data set list, choose Cut Line 2D 2.

4 From the Parameter selection (mh) list, choose Last.

Line Graph 1
1 On the L1 Error from Analytical Solutions - Study 1 and Study 2 toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the y-Axis Data section.

3 In the Expression text field, type abs(T-an2(x,y)).

4 Locate the Coloring and Style section. In the Width text field, type 3.

5 Locate the Legends section. Select the Show legends check box.

6 From the Legends list, choose Manual.

7 In the table, enter the following settings:

L1 Error from Analytical Solutions - Study 1 and Study 2
In the Model Builder window, under Results click L1 Error from Analytical Solutions - Study 

1 and Study 2.

Line Graph 2
1 On the L1 Error from Analytical Solutions - Study 1 and Study 2 toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Data set list, choose Cut Line 2D 1.

4 From the Parameter selection (mh) list, choose Last.

5 Locate the y-Axis Data section. In the Expression text field, type abs(T-an2(x,y)).

6 Locate the Coloring and Style section. In the Width text field, type 3.

7 Locate the Legends section. Select the Show legends check box.

8 From the Legends list, choose Manual.

9 In the table, enter the following settings:

Legends

Point source without specified radius

Legends

Point source with specified radius
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10 On the L1 Error from Analytical Solutions - Study 1 and Study 2 toolbar, click Plot.

Now, define a new mesh that is not refined any more at the origin of the disk, but is 
parameterized to be coarsened instead, with parameter mh.

C O M P O N E N T  1  ( C O M P 1 )

Mesh 2
On the Mesh toolbar, click Add Mesh.

M E S H  2

1 In the Settings window for Mesh, locate the Mesh Settings section.

2 From the Sequence type list, choose User-controlled mesh.

Use the parameter mh to control the maximum and minimum size of the mesh elements.

Size
1 In the Model Builder window, under Component 1 (comp1)>Meshes>Mesh 2 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. In the Maximum element size text field, type 
mh.

5 In the Minimum element size text field, type mh.

6 Click Build All.

Define a new study corresponding to the problem with a volume source on a coarse mesh.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies.

4 In the Select Study tree, select Preset Studies>Stationary.

5 Click Add Study in the window toolbar.

S T U D Y  3

Step 1: Stationary
1 On the Home toolbar, click Add Study to close the Add Study window.

2 In the Model Builder window, under Study 3 click Step 1: Stationary.
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3 In the Settings window for Stationary, locate the Physics and Variables Selection section.

4 Select the Modify physics tree and variables for study step check box.

5 In the Physics and variables selection tree, select Component 1 (comp1)>Heat Transfer in 

Solids (ht)>Line Heat Source 1.

6 Click Disable.

Define a parametric sweep on the size of mesh elements in order to check that the heat 
source is still well approximated on coarse meshes.

7 In the Model Builder window, click Study 3.

8 In the Settings window for Study, type Study 3: Point Source with Radius, 
Coarse Mesh in the Label text field.

Parametric Sweep
On the Study toolbar, click Parametric Sweep.

S T U D Y  3 :  PO I N T  S O U R C E  W I T H  R A D I U S ,  C O A R S E  M E S H

Parametric Sweep
1 In the Settings window for Parametric Sweep, locate the Study Settings section.

2 Click Add.

3 Select mh from the list.

4 Click Range.

5 In the Range dialog box, type 0.01 in the Start text field.

6 In the Step text field, type 0.012.

7 In the Stop text field, type 0.06.

8 Click Replace.

9 On the Study toolbar, click Compute.

R E S U L T S

Temperature (ht)
The first default plot shows the temperature distribution in a 2D plot for mh=10−2m. 
Proceed as follows to reproduce the plots for mesh configurations in Figure 5.

1 In the Model Builder window, under Results click Temperature (ht).

2 In the Settings window for 2D Plot Group, type Mesh Resolution - Study 3 in the 
Label text field.
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Surface
1 In the Model Builder window, expand the Results>Mesh Resolution - Study 3 node, then 

click Surface.

2 In the Settings window for Surface, locate the Coloring and Style section.

3 From the Coloring list, choose Uniform.

4 Select the Wireframe check box.

Mesh Resolution - Study 3
In the Model Builder window, under Results right-click Mesh Resolution - Study 3 and choose 
Contour.

Contour 1
1 In the Settings window for Contour, locate the Expression section.

2 In the Expression text field, type sqrt(x^2+y^2).

3 Locate the Levels section. From the Entry method list, choose Levels.

4 In the Levels text field, type R_source.

5 Locate the Coloring and Style section. From the Contour type list, choose Tube.

6 From the Coloring list, choose Uniform.

7 From the Color list, choose Black.

8 Clear the Color legend check box.

9 On the Mesh Resolution - Study 3 toolbar, click Plot.

10 Click the Zoom Extents button on the Graphics toolbar.

Now change the mesh resolution to a finer configuration.

Mesh Resolution - Study 3
1 In the Model Builder window, under Results click Mesh Resolution - Study 3.

2 In the Settings window for 2D Plot Group, locate the Data section.

3 From the Parameter value (mh (m)) list, choose 0.01.

4 On the Mesh Resolution - Study 3 toolbar, click Plot.

Next, proceed to reproduce the plot of Figure 11, by plotting the relative L2 error 
between numerical and analytical solutions as a function of 1/mh, to check numerical 
convergence.

1D Plot Group 13
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.
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2 In the Settings window for 1D Plot Group, type L2 Error from Analytical 
Solution - Study 3 in the Label text field.

3 Locate the Data section. From the Data set list, choose Study 3: Point Source with Radius, 

Coarse Mesh/Parametric Solutions 3 (sol24).

Line Graph 1
1 On the L2 Error from Analytical Solution - Study 3 toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Selection section.

3 From the Selection list, choose All boundaries.

4 Locate the y-Axis Data section. In the Expression text field, type 
sqrt(intop1((T-an2(x,y))^2))/sqrt(intop1((T-T0)^2)).

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type 1/mh.

7 Locate the Coloring and Style section. From the Color list, choose Blue.

8 In the Width text field, type 5.

9 On the L2 Error from Analytical Solution - Study 3 toolbar, click Plot.

As a last step, you can check that the computation of a volume heat source can also be 
performed by using the Heat Source feature. In order to do that, you need to include a 
smaller circle of radius R_source into the geometry, and to change the physics branch. 
Define a new component to include these changes and keep this step separated from the 
previous ones.

R O O T

On the Home toolbar, click Add Component and choose 2D.

G E O M E T R Y  2

Import the previously defined geometry, and complete it with the circle of radius 
R_source.

1 In the Model Builder window, under Component 2 (comp2) click Geometry 2.

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 From the Source list, choose Geometry sequence.

4 From the Geometry list, choose Geometry 1.

5 Click Import.
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Circle 1 (c1)
1 On the Geometry toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type R_source.

4 Click Build All Objects.

This time, use the Heat Source feature to apply the source in the domain delimited by the 
circle of radius R_source. This replaces the use of the Line Heat Source feature in previous 
steps.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Heat Transfer>Heat Transfer in Solids (ht).

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the following studies:

5 Click Add to Component in the window toolbar.

H E A T  TR A N S F E R  I N  S O L I D S  2  ( H T 2 )

On the Home toolbar, click Add Physics to close the Add Physics window.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundaries 1, 2, 5, and 8 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type T0.

Heat Source 1
1 On the Physics toolbar, click Domains and choose Heat Source.

2 Select Domain 2 only.

3 In the Settings window for Heat Source, locate the Heat Source section.

Studies

Study 1: Point Source

Study 2: Point Source with Radius

Study 3: Point Source with Radius, Coarse Mesh
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4 Click the Heat rate button.

5 In the P0 text field, type 1.

Define the same material as before.

M A T E R I A L S

In the Model Builder window, under Component 2 (comp2) right-click Materials and choose 
Blank Material.

Material 2 (mat2)
1 In the Settings window for Material, type Cork in the Label text field.

2 Locate the Material Contents section. In the table, enter the following settings:

You can visualize the mesh generated by default for this new geometry.

M E S H  3

1 In the Model Builder window, under Component 2 (comp2) click Mesh 3.

2 In the Settings window for Mesh, click Build All.

Add a new study for the computation of the volume heat source with the Heat Source 
feature.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies.

4 In the Select Study tree, select Preset Studies>Stationary.

5 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Heat Transfer in Solids (ht) interface.

6 Click Add Study in the window toolbar.

Property Name Value Unit Property 
group

Thermal conductivity k k_cork W/(m·K) Basic

Density rho rho_cork kg/m³ Basic

Heat capacity at constant 
pressure

Cp cp_cork J/(kg·K) Basic
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S T U D Y  4

Step 1: Stationary
1 On the Home toolbar, click Add Study to close the Add Study window.

2 In the Model Builder window, click Study 4.

3 In the Settings window for Study, type Study 4: Surface Source in the Label text 
field.

4 On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht2)
1 In the Model Builder window, under Results click Temperature (ht2).

2 In the Settings window for 2D Plot Group, type Temperature - Study 4 in the Label 
text field.

Finally, proceed to reproduce the plot of Figure 8, by plotting the temperature 
distribution for numerical and analytical solutions along a disk radius.

Cut Line 2D 3
1 On the Results toolbar, click Cut Line 2D.

2 In the Settings window for Cut Line 2D, locate the Data section.

3 From the Data set list, choose Study 4: Surface Source/Solution 30 (8) (sol30).

4 Locate the Line Data section. In row Point 2, set x to R_disk.

5 Click Plot.

1D Plot Group 16
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Temperature vs Radius - Study 4 
in the Label text field.

3 Locate the Data section. From the Data set list, choose Cut Line 2D 3.

Line Graph 1
1 On the Temperature vs Radius - Study 4 toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Coloring and Style section.

3 Find the Line style subsection. From the Line list, choose None.

4 Find the Line markers subsection. From the Marker list, choose Cycle.

5 In the Number text field, type 25.
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6 Locate the Legends section. Select the Show legends check box.

7 From the Legends list, choose Manual.

8 In the table, enter the following settings:

Temperature vs Radius - Study 4
In the Model Builder window, under Results click Temperature vs Radius - Study 4.

Line Graph 2
1 On the Temperature vs Radius - Study 4 toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the y-Axis Data section.

3 In the Expression text field, type an2(x,y).

4 Locate the Coloring and Style section. In the Width text field, type 3.

5 Locate the Legends section. Select the Show legends check box.

6 From the Legends list, choose Manual.

7 In the table, enter the following settings:

8 On the Temperature vs Radius - Study 4 toolbar, click Plot.

Legends

Numerical

Legends

Analytical
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Introduction

Marangoni convection occurs when the surface tension of an interface (generally 
liquid-air) depends on the concentration of a species or on the temperature distribution. 
In the case of temperature dependence, the Marangoni effect is also called 
thermo-capillary convection. It is of primary importance in the fields of:

• Welding

• Crystal growth

• Electron beam melting of metals

Direct experimental studies are not easy to carry out in these systems because the materials 
are often metals and temperatures are very high. One possibility is to replace the real 
system with an experimental setup using a transparent liquid at ambient temperatures.

Model Definition

This tutorial describes the 2D stationary behavior of a vessel filled with silicone oil, for 
which the thermo-physical properties are known. The aim of the study is to compute the 
temperature field that induces a flow through the Marangoni effect. The model shows this 
effect using the simple geometry in the figure below.

G OV E R N I N G  E Q U A T I O N S

A stationary momentum balance equation describes the velocity field and the pressure 
distribution (Navier-Stokes equations, see Incompressible Flow). To include the heating 
of the fluid, the fluid flow is coupled to an energy balance.

You can use the Boussinesq approximation to include the effect of temperature on the 
velocity field. In this approximation, variations in temperature produce a buoyancy force 
(or Archimedes’ force) that lifts the fluid as described in Gravity and The Boussinesq 
Approximation sections in the CFD Module User’s Guide.

Free surface

Silicone oil

Insulation

T = 0T = ΔT
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The following equation describes the forces that the Marangoni effect induces on the 
interface (liquid/air):

 (1)

Here γ is the temperature derivative of the surface tension (N/(m·K)). Equation 1 states 
that the shear stress on a surface is proportional to the temperature gradient (Ref. 1).

Notes About the COMSOL Implementation

To solve the momentum and energy balance equations, use the predefined 
Non-Isothermal Flow multiphysics coupling. It automatically couples a Laminar Flow 
interface for the fluid flow to a Heat Transfer in Fluids interface for the heat transfer by 
convection and conduction in each direction:

• The Boussinesq approximation means that an expression including temperature acts as 
a force in the y direction in the momentum balance.

• The convective heat transfer depends on the velocities from the momentum balance.

This means that you must solve the coupled system directly using the nonlinear solver. 

To impose the condition that the shear stress is proportional to the temperature gradient 
on the surface, use the Marangoni Effect multiphysics feature in the Multiphysics node.

η u∂
y∂

------ γ T∂
x∂

-------=
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Results

The Marangoni effect becomes more pronounced as the temperature difference increases:

Figure 1: Marangoni convection with a temperature difference of 0.001 K.

For the very low temperature difference of 0.001 K, the temperature field is almost 
decoupled from the velocity field. Therefore, the temperature decreases almost linearly 
from left to right.
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Figure 2: Marangoni convection with a temperature difference of 0.05 K.

For the temperature difference of 0.05 K notice how the Marangoni convection influences 
the flow of fluid and the distribution of temperature. The temperature is no longer 
decreasing linearly and you can clearly see the advection of the isotherms caused by the 
flow.
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Figure 3: Marangoni convection with a temperature difference of 2 K.

At higher temperature differences (2 K in Figure 3 above), the physical coupling between 
the temperature and the velocity field is clearly visible. The heat conduction is small 
compared to the convection, and at the surface the fluid accelerates where the temperature 
gradient is high.

Reference

1. V.G. Levich, Physicochemical Hydrodynamics, Prentice-Hall, N.J., 1962.

Application Library path: Heat_Transfer_Module/Tutorials,
_Forced_and_Natural_Convection/marangoni_effect

Modeling Instructions

From the File menu, choose New.
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N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Fluid Flow>Non-Isothermal Flow>Laminar Flow.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

G E O M E T R Y  1

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 10[mm].

4 In the Height text field, type 5[mm].

5 Right-click Rectangle 1 (r1) and choose Build Selected.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
marangoni_effect_parameters.txt.

D E F I N I T I O N S

Variables 1
1 On the Home toolbar, click Variables and choose Local Variables.

2 In the Settings window for Variables, locate the Variables section.
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3 In the table, enter the following settings:

This variable is useful when visualizing the model results.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, type Silicone Oil in the Label text field.

2 Locate the Material Contents section. In the table, enter the following settings:

L A M I N A R  F L O W  ( S P F )

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

2 In the Settings window for Laminar Flow, locate the Physical Model section.

3 Select the Include gravity check box.

4 From the Compressibility list, choose Incompressible flow.

5 Find the Reference values subsection. In the Tref text field, type T_ref.

Here, T_ref is the reference temperature at which the material properties are evaluated. 
It is defined in Parameters under Global Definitions.

Wall 2
1 On the Physics toolbar, click Boundaries and choose Wall.

2 Select Boundary 3 only.

3 In the Settings window for Wall, locate the Boundary Condition section.

4 From the Boundary condition list, choose Slip.

Name Expression Unit Description

deltaT T-T_right K Excess temperature in model domain

Property Name Value Unit Property 
group

Dynamic viscosity mu mu1 Pa·s Basic

Thermal conductivity k k1 W/(m·K) Basic

Heat capacity at constant 
pressure

Cp Cp1 J/(kg·K) Basic

Ratio of specific heats gamma 1 1 Basic
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Pressure Point Constraint 1
1 On the Physics toolbar, click Points and choose Pressure Point Constraint.

2 Select Point 1 only.

H E A T  TR A N S F E R  I N  F L U I D S  ( H T )

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Fluids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, type T_right in the T text field.

3 In the Model Builder window, click Heat Transfer in Fluids (ht).

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 4 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type T_right.

Temperature 2
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 1 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type T_right+DeltaT.

M U L T I P H Y S I C S

1 In the Model Builder window, under Component 1 (comp1)>Multiphysics click 
Non-Isothermal Flow 1 (nitf1).

2 In the Settings window for Non-Isothermal Flow, locate the Material Properties section.

3 From the Specify density list, choose Custom, linearized density.

4 In the ρref text field, type rho1.

5 In the αp text field, type alphap1.

Marangoni Effect 1 (me1)
1 On the Physics toolbar, click Multiphysics and choose Boundary>Marangoni Effect.

2 Select Boundary 3 only.

3 In the Settings window for Marangoni Effect, locate the Surface Tension section.

4 In the σ text field, type gamma*T.
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M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Triangular.

Free Triangular 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Triangular 1 and choose Size.

Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 Select Boundary 3 only.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 1e-4.

Free Triangular 1
Right-click Free Triangular 1 and choose Size.

Size 2
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Point.

3 Select Points 2 and 4 only.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 2e-5.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Extra fine.

4 Click the Custom button.

5 Locate the Element Size Parameters section. In the Maximum element growth rate text 
field, type 1.1.

6 Click Build All.
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S T U D Y  1

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

5 On the Study toolbar, click Compute.

R E S U L T S

Velocity (spf)
To show the temperature field as a surface plot along with overlaid temperature contours 
and the velocity field using arrows, follow the steps given below.

Isothermal Contours (ht)
1 In the Model Builder window, under Results click Isothermal Contours (ht).

2 In the Settings window for 2D Plot Group, locate the Data section.

3 From the Parameter value (DeltaT) list, choose 0.001.

Contour
1 In the Model Builder window, expand the Isothermal Contours (ht) node, then click 

Contour.

2 In the Settings window for Contour, click Replace Expression in the upper-right corner 
of the Expression section. From the menu, choose Model>Component 1>Definitions>

Variables>deltaT - Excess temperature in model domain.

3 Locate the Coloring and Style section. From the Coloring list, choose Uniform.

4 Right-click Results>Isothermal Contours (ht)>Contour and choose Arrow Surface.

Isothermal Contours (ht)
In the Model Builder window, under Results right-click Isothermal Contours (ht) and choose 
Surface.

Parameter name Parameter value list Parameter unit

DeltaT 1e-3 0.05 2
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Surface 1
1 In the Settings window for Surface, click Replace Expression in the upper-right corner of 

the Expression section. From the menu, choose Model>Component 1>Definitions>

Variables>deltaT - Excess temperature in model domain.

2 On the Isothermal Contours (ht) toolbar, click Plot.

3 Click the Zoom Extents button on the Graphics toolbar.

Isothermal Contours (ht)
The Marangoni effect becomes more pronounced as the temperature difference increases. 
Visualize this by changing the Parameter value selection.

1 In the Model Builder window, under Results click Isothermal Contours (ht).

2 In the Settings window for 2D Plot Group, locate the Data section.

3 From the Parameter value (DeltaT) list, choose 0.05.

4 On the Isothermal Contours (ht) toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

6 From the Parameter value (DeltaT) list, choose 2.

7 On the Isothermal Contours (ht) toolbar, click Plot.
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Introduction

Electromagnetic heating appears in a wide range of engineering problems and is ideally 
suited for modeling in COMSOL Multiphysics because of its multiphysics capabilities. 
This example comes from the area of hyperthermic oncology and it models the 
electromagnetic field coupled to the bioheat equation. The modeling issues and 
techniques are generally applicable to any problem involving electromagnetic heating.

In hyperthermic oncology, cancer is treated by applying localized heating to the tumor 
tissue, often in combination with chemotherapy or radiotherapy. Some of the challenges 
associated with the selective heating of deep-seated tumors without damaging 
surrounding tissue are:

• Control of heating power and spatial distribution

• Design and placement of temperature sensors

Among possible heating techniques, RF and microwave heating have attracted much 
attention from clinical researchers. Microwave coagulation therapy is one such technique 
where a thin microwave antenna is inserted into the tumor. The microwaves heat up the 
tumor, producing a coagulated region where the cancer cells are killed.

This model computes the temperature field, the radiation field, and the specific absorption 
rate (SAR)—defined as the ratio of absorbed heat power and tissue density—in liver tissue 
when using a thin coaxial slot antenna for microwave coagulation therapy. It closely 
follows the analysis found in Ref. 1. It computes the temperature distribution in the tissue 
using the bioheat equation.

Note: This application requires the RF Module and the Heat Transfer Module.

Model Definition

Figure 1 shows the antenna geometry. It consists of a thin coaxial cable with a ring-shaped 
slot measuring 1 mm cut on the outer conductor 5 mm from the short-circuited tip. For 
hygienic purposes, the antenna is enclosed in a sleeve (catheter) made of PTFE 
(polytetrafluoroethylene). The following tables give the relevant geometrical dimensions 
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and material data. The antenna operates at 2.45 GHz, a frequency widely used in 
microwave coagulation therapy.

Figure 1: Antenna geometry for microwave coagulation therapy. A coaxial cable with a 
ring-shaped slot cut on the outer conductor is short-circuited at the tip. A plastic catheter 
surrounds the antenna.

TABLE 1:  DIMENSIONS OF THE COAXIAL SLOT ANTENNA.

PROPERTY VALUE

Diameter of the central conductor 0.29 mm

Inner diameter of the outer conductor 0.94 mm

Outer diameter of the outer conductor 1.19 mm

Diameter of catheter 1.79 mm

TABLE 2:  MATERIAL PROPERTIES.

PROPERTY INNER DIELECTRIC OF 
COAXIAL CABLE

CATHETER LIVER TISSUE

Relative permittivity 2.03 2.60 43.03

Conductivity 1.69 S/m

Feed

Slot

Liver tissue

Coaxial antenna

2D cross section

1.79 mm

Conductor

Dielectric

Catheter

1.0 mm

5.0 mm
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The model takes advantage of the problem’s rotational symmetry, which allows modeling 
in 2D using cylindrical coordinates as indicated in Figure 2. When modeling in 2D, you 
can select a fine mesh and achieve excellent accuracy. The model uses a frequency-domain 
problem formulation with the complex-valued azimuthal component of the magnetic field 
as the unknown.

Figure 2: The computational domain appears as a rectangle in the rz-plane.

The radial and axial extent of the computational domain is in reality larger than indicated 
in Figure 2. This problem does not model the interior of the metallic conductors, and it 
models metallic parts using boundary conditions, setting the tangential component of the 
electric field to zero.

D O M A I N  A N D  B O U N D A R Y  E Q U A T I O N S — E L E C T R O M A G N E T I C S

An electromagnetic wave propagating in a coaxial cable is characterized by transverse 
electromagnetic fields (TEM). Assuming time-harmonic fields with complex amplitudes 
containing the phase information, the appropriate equations are

Computational domain

z

r

E er
C
r
----ej ωt kz–( )=

H eϕ
C
rZ
-------ej ωt kz–( )=

Pav Re 1
2
---E H*× 
 2πr rd
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= ezπC2

Z
-------

router
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-------------- 
 ln=
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where z is the direction of propagation, and r, ϕ, and z are cylindrical coordinates centered 
on the axis of the coaxial cable. Pav is the time-averaged power flow in the cable, Z is the 
wave impedance in the dielectric of the cable, while rinner and router are the dielectric’s 
inner and outer radii, respectively. Further, ω denotes the angular frequency. The 
propagation constant, k, relates to the wavelength in the medium, λ, as

In the tissue, the electric field also has a finite axial component whereas the magnetic field 
is purely in the azimuthal direction. Thus, you can model the antenna using an 
axisymmetric transverse magnetic (TM) formulation. The wave equation then becomes 
scalar in Hϕ:

The boundary conditions for the metallic surfaces are

The feed point is modeled using a port boundary condition with a power level set to 10 W. 
This is essentially a first-order low-reflecting boundary condition with an input field Hϕ0:

where

for an input power of Pav deduced from the time-average power flow.

The antenna radiates into the tissue where a damped wave propagates. Because you can 
discretize only a finite region, you must truncate the geometry some distance from the 
antenna using a similar absorbing boundary condition without excitation. Apply this 
boundary condition to all exterior boundaries.

D O M A I N  A N D  B O U N D A R Y  E Q U A T I O N S — H E A T  TR A N S F E R

The bioheat equation describes the time-dependent heat transfer problem as
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λ
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∇ εr
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where k is the liver’s thermal conductivity (W/(m·K)), ρb represents the blood density 
(kg/m3), Cb is the blood’s specific heat capacity (J/(kg·K)), ωb denotes the blood 
perfusion rate (1/s), and Tb is the arterial blood temperature (K). Further, Qmet is the 
heat source from metabolism, and Qext is an external heat source, both measured in W/
m3.

The initial temperature equals Tb in all domains.

This model neglects the heat source from metabolism. The external heat source is equal 
to the resistive heat generated by the electromagnetic field:

The model assumes that the blood perfusion rate is ωb = 0.0036 s-1, and that the blood 
enters the liver at the body temperature Tb = 37 °C and is heated to a temperature, T. The 
blood’s specific heat capacity is Cb = 3639 J/(kg·K).

For a more realistic model, you might consider letting ωb be a function of the temperature. 
At least for external body parts such as hands and feet, it is evident that a temperature 
increase results in an increased blood flow.

This example models the heat-transfer problem only in the liver domain. Where this 
domain is truncated, it uses insulation, that is

In addition to the heat transfer equation, this model computes the tissue damage integral. 
This gives an idea about the degree of tissue injury α during the process, based on the 
Arrhenius equation:

where A is the frequency factor (s-1) and dE is the activation energy for irreversible 
damage reaction (J/mol). These two parameters are dependent on the type of tissue. The 
fraction of necrotic tissue, θd, is then expressed by:

ρCp t∂
∂T ∇+ k T∇–( )⋅ ρbCbωb Tb T–( ) Qmet Qext+ +=

Qext
1
2
---Re σ jωε–( )E E*⋅[ ]=

n T∇⋅ 0=

td
dα A dE

RT
--------– 

 exp=

θd 1 α–( )exp–=
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Results and Discussion

Figure 3 shows the resulting steady-state temperature distribution in the liver tissue for an 
input microwave power of 10 W. The temperature is highest near the antenna. It then 
decreases with distance from the antenna and reaches 37 °C closer to the outer boundaries 
of the computational domain. The perfusion of relatively cold blood seems to limit the 
extent of the area that is heated.

Figure 3: Temperature in the liver tissue.

Figure 4 shows the distribution of the microwave heat source. Clearly the temperature 
field follows the heat-source distribution quite well. That is, near the antenna the heat 
source is strong, which leads to high temperatures, while far from the antenna, the heat 
source is weaker and the blood manages to keep the tissue at normal body temperature.
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Figure 4: The computed microwave heat-source density takes on its highest values near the tip 
and the slot. The scale is cut off at 1 W/cm3.

Figure 5 plots the specific absorption rate (SAR) along a line parallel to the antenna and 
at a distance of 2.5 mm from the antenna axis. The results are in good agreement with 
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those found in Ref. 1.

Figure 5: SAR in W/kg along a line parallel to the antenna and at a distance 2.5 mm from 
the antenna axis. The tip of the antenna is located at 70 mm, and the slot is at 65 mm.
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You can visualize the fraction of necrotic tissue in the surface plot of Figure 6.

Figure 6: Fraction of necrotic tissue.
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Figure 7 shows the fraction of necrotic tissue at four different point of the domain. 
Observe that necrosis happens faster at the antenna area.

Figure 7: Fraction of necrotic tissue at four points of the domain.

Reference

1. K. Saito, T. Taniguchi, H. Yoshimura, and K. Ito, “Estimation of SAR Distribution of 
a Tip-Split Array Applicator for Microwave Coagulation Therapy Using the Finite 
Element Method,” IEICE Trans. Electronics, vol. E84-C, 7, pp. 948–954, July 2001.

Application Library path: Heat_Transfer_Module/Medical_Technology/
microwave_cancer_therapy

Modeling Instructions

From the File menu, choose New.
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N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Radio Frequency>Electromagnetic Waves, Frequency 

Domain (emw).

3 Click Add.

4 In the Select Physics tree, select Heat Transfer>Bioheat Transfer (ht).

5 Click Add.

6 Click Study.

7 In the Select Study tree, select Custom Studies>Preset Studies for Some Physics Interfaces>

Frequency Domain.

The frequency domain study is for the electromagnetic part of the model. You add a 
transient analysis for the heat transfer part before solving.

8 Click Done.

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
microwave_cancer_therapy.mphbin.

5 Click Import.

Form Union (fin)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click Form 

Union (fin) and choose Build Selected.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

The relevant material properties and other model data are provided in a text file.

2 In the Settings window for Parameters, locate the Parameters section.
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3 Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
microwave_cancer_therapy_parameters.txt.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Bioheat>Liver (human).

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Liver (human) (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Liver (human) 

(mat1).

2 Select Domain 1 only.

3 In the Settings window for Material, locate the Material Contents section.

4 In the table, enter the following settings:

The remaining materials take part only in the RF simulation, making any definitions of 
their thermal properties redundant.

Material 2 (mat2)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Catheter in the Label text field.

3 Select Domain 2 only.

Property Name Value Unit Property 
group

Relative permittivity epsilonr eps_liv
er

1 Basic

Relative permeability mur 1 1 Basic

Electrical conductivity sigma sigma_l
iver

S/m Basic
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4 Locate the Material Contents section. In the table, enter the following settings:

Material 3 (mat3)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Dielectric in the Label text field.

3 Select Domain 3 only.

4 Locate the Material Contents section. In the table, enter the following settings:

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Air.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Air (mat4)
1 On the Home toolbar, click Add Material to close the Add Material window.

2 In the Model Builder window, under Component 1 (comp1)>Materials click Air (mat4).

3 Select Domain 4 only.

The bioheat equation applies only in the liver tissue.

E L E C T R O M A G N E T I C  WA V E S ,  F R E Q U E N C Y  D O M A I N  ( E M W )

1 In the Model Builder window, under Component 1 (comp1) click Electromagnetic Waves, 

Frequency Domain (emw).

Property Name Value Unit Property 
group

Relative permittivity epsilonr eps_cat 1 Basic

Relative permeability mur 1 1 Basic

Electrical conductivity sigma 0 S/m Basic

Property Name Value Unit Property 
group

Relative permittivity epsilonr eps_diel 1 Basic

Relative permeability mur 1 1 Basic

Electrical conductivity sigma 0 S/m Basic
14 |  M I C R O W A V E  H E A T I N G  O F  A  C A N C E R  TU M O R



2 In the Settings window for Electromagnetic Waves, Frequency Domain, click to expand 
the Equation section.

3 From the Equation form list, choose Frequency domain.

4 From the Frequency list, choose User defined. In the f text field, type f.

Because you will use a study with a Frequency Domain step for a single frequency 
followed by a Time Dependent step, this is a convenient way to define the frequency in 
the second study step.

Port 1
1 On the Physics toolbar, click Boundaries and choose Port.

2 Select Boundary 8 only.

3 In the Settings window for Port, locate the Port Properties section.

4 From the Type of port list, choose Coaxial.

5 From the Wave excitation at this port list, choose On.

6 In the Pin text field, type P_in.

Scattering Boundary Condition 1
1 On the Physics toolbar, click Boundaries and choose Scattering Boundary Condition.

2 Select Boundaries 2, 17, 19, and 20 only.

B I O H E A T  TR A N S F E R  ( H T )

1 In the Model Builder window, under Component 1 (comp1) click Bioheat Transfer (ht).

2 In the Settings window for Bioheat Transfer, locate the Domain Selection section.

3 Click Clear Selection.

4 Select Domain 1 only.

Biological Tissue 1
1 In the Model Builder window, under Component 1 (comp1)>Bioheat Transfer (ht) click 

Biological Tissue 1.

2 In the Settings window for Biological Tissue, locate the Damaged Tissue section.

3 Select the Include damage integral analysis check box.

4 From the Damage integral form list, choose Energy absorption.

Bioheat 1
1 In the Model Builder window, expand the Biological Tissue 1 node, then click Bioheat 1.

2 In the Settings window for Bioheat, locate the Bioheat section.
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3 In the Tb text field, type T_blood.

4 In the ρb text field, type rho_blood.

5 In the Cp, b text field, type Cp_blood.

6 In the ωb text field, type omega_blood.

You have now supplied all the parameters needed for the heat removal by the blood 
perfusion.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Bioheat Transfer (ht) click 

Initial Values 1.

2 In the Settings window for Initial Values, type T_blood in the T text field.

M U L T I P H Y S I C S

Electromagnetic Heat Source 1 (emh1)
1 On the Physics toolbar, click Multiphysics and choose Domain>Electromagnetic Heat 

Source.

2 In the Settings window for Electromagnetic Heat Source, locate the Domain Selection 
section.

3 From the Selection list, choose All domains.

This brings the heat created by the electromagnetic waves to the heat transfer 
simulation.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Triangular.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. In the Maximum element size text field, type 
3[mm].

Free Triangular 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Triangular 1 and choose Size.
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Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Domain.

3 Select Domain 3 only.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 0.15[mm].

7 Click Build All.

The mesh is now reasonably fine everywhere, and especially fine in the coaxial cable, 
where the wave is created.

S T U D Y  1

Step 1: Frequency Domain
1 In the Settings window for Frequency Domain, locate the Study Settings section.

2 In the Frequencies text field, type f.

3 Locate the Physics and Variables Selection section. In the table, clear the Solve for check 
box for the Bioheat Transfer (ht) interface.

Add a transient analysis for the heat transfer problem.

Time Dependent
On the Study toolbar, click Study Steps and choose Time Dependent>Time Dependent.

Step 2: Time Dependent
1 In the Settings window for Time Dependent, locate the Study Settings section.

2 From the Time unit list, choose min.

3 In the Times text field, type range(0,15[s],10).

4 Locate the Physics and Variables Selection section. In the table, clear the Solve for check 
box for the Electromagnetic Waves, Frequency Domain (emw) interface.

5 On the Study toolbar, click Compute.

R E S U L T S

Electric Field (emw)
You have now solved the model first for the electromagnetic wave distribution, then for 
the temperature distribution resulting from the electromagnetic heating. Such a sequential 
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solution is faster and consumes less memory than a fully coupled analysis, but works only 
if the material properties do not depend on the temperature.

Surface
The default plot shows the distribution of the electric field norm. The range is dominated 
by the locally very high values in and in the near vicinity of the coaxial cable. One way to 
get a more useful picture is to plot the logarithm of the field.

1 In the Model Builder window, expand the Electric Field (emw) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type log10(comp1.emw.normE).

4 On the Electric Field (emw) toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

The local heating power density is an important result of this model. As it is proportional 
to the electric field squared, this entity is also going to have a very uneven distribution. 
Manually specifying the range is another option to keep the plot readable.

6 Click Replace Expression in the upper-right corner of the Expression section. From the 
menu, choose Model>Component 1>Electromagnetic Waves, Frequency Domain>Heating 

and losses>emw.Qh - Total power dissipation density.

7 On the Electric Field (emw) toolbar, click Plot.
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8 Click to expand the Range section. Select the Manual color range check box.

9 In the Maximum text field, type 1e6.

10 On the Electric Field (emw) toolbar, click Plot.

11 Click the Zoom Extents button on the Graphics toolbar.

Any values greater than 1 MW/m3 are now displayed as red.

If you divide the power loss density with the density of the liver tissue, you get the SAR. 
Try plotting this on a vertical line some distance away from the antenna. Take the liver 
density to be the same as that of blood.

Cut Line 2D 1
1 On the Results toolbar, click Cut Line 2D.

2 In the Settings window for Cut Line 2D, locate the Line Data section.

3 In row Point 1, set r to 2.5e-3, and z to 0.08.

4 In row Point 2, set r to 2.5e-3.

1D Plot Group 4
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Qh/rho vs Arc Length in the Label 
text field.

3 Locate the Data section. From the Data set list, choose Cut Line 2D 1.

4 From the Time selection list, choose Last.

Line Graph 1
1 On the Qh/rho vs Arc Length toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the y-Axis Data section.

3 In the Expression text field, type emw.Qh/rho_blood.

4 On the Qh/rho vs Arc Length toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

The plot you just created should look like Figure 5.

Derived Values
To evaluate the total deposited power, integrate the power loss in the liver domain.

Surface Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 In the Settings window for Surface Integration, locate the Data section.
19 |  M I C R O W A V E  H E A T I N G  O F  A  C A N C E R  TU M O R



3 From the Time selection list, choose Last.

4 Select Domain 1 only.

5 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Electromagnetic Waves, Frequency Domain>Heating 

and losses>emw.Qh - Total power dissipation density.

6 Locate the Integration Settings section. Select the Compute volume integral check box.

7 Click Evaluate.

TA B L E

1 Go to the Table window.

As shown in the table, the tissue absorbs most of the 10 W input power.

R E S U L T S

Create a new plot group for the surface plot of the temperature in the tissue (Figure 3).

2D Plot Group 5
1 On the Results toolbar, click 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Temperature, 2D in the Label text 
field.

Surface 1
1 Right-click Temperature, 2D and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Bioheat Transfer>

Temperature>T - Temperature.

3 Locate the Expression section. From the Unit list, choose degC.

4 Locate the Coloring and Style section. From the Color table list, choose ThermalLight.

5 On the Temperature, 2D toolbar, click Plot.

6 Click the Zoom Extents button on the Graphics toolbar.

Temperature, 3D (ht)
Click the Zoom Extents button on the Graphics toolbar.

2D Plot Group 6
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

Generate a plot to show the fraction of necrotic tissue in 2D.
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2 In the Settings window for 2D Plot Group, type Damaged Tissue, 2D in the Label text 
field.

Surface 1
1 Right-click Damaged Tissue, 2D and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Bioheat Transfer>

Biological tissue>ht.theta_d - Fraction of necrotic tissue.

3 Click to expand the Quality section. From the Resolution list, choose No refinement.

4 On the Damaged Tissue, 2D toolbar, click Plot.

Cut Point 2D 1
1 On the Results toolbar, click Cut Point 2D.

2 In the Settings window for Cut Point 2D, locate the Point Data section.

3 In the r text field, type ge(0.0050,0.0050,0.02).

4 In the z text field, type 2e-2.

5 In the r text field, type range(0.0050,0.0050,0.02).

6 Click Plot.

1D Plot Group 7
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Temperature, 1D in the Label text 
field.

3 Locate the Data section. From the Data set list, choose Cut Point 2D 1.

Point Graph 1
1 On the Temperature, 1D toolbar, click Point Graph.

2 In the Settings window for Point Graph, click Replace Expression in the upper-right 
corner of the y-axis data section. From the menu, choose Model>Component 1>Bioheat 

Transfer>Temperature>T - Temperature.

3 On the Temperature, 1D toolbar, click Plot.

1D Plot Group 8
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Damaged Tissue, 1D in the Label text 
field.

3 Locate the Data section. From the Data set list, choose Cut Point 2D 1.
21 |  M I C R O W A V E  H E A T I N G  O F  A  C A N C E R  TU M O R



Point Graph 1
1 On the Damaged Tissue, 1D toolbar, click Point Graph.

2 In the Settings window for Point Graph, click Replace Expression in the upper-right 
corner of the y-axis data section. From the menu, choose Model>Component 1>Bioheat 

Transfer>Biological tissue>ht.theta_d - Fraction of necrotic tissue.

3 Click to expand the Coloring and style section. Locate the Coloring and Style section. In 
the Width text field, type 3.

4 On the Damaged Tissue, 1D toolbar, click Plot.
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This tutorial shows how to use the Mathematical Particle Tracing interface to simulate 
radiative heat transfer with mixed diffuse-specular reflection between surfaces in an 
enclosure. This application is separated in two parts. The first part compares the heat fluxes 
computed by the Mathematical Particle Tracing interface with the exact solution for two 
identical infinitely long parallel gray plates under mixed diffuse-specular reflection at 
constant temperature. The second part couples the Mathematical Particle Tracing 
interface with the Heat Transfer in Solids interface for the parallel plate geometry but with 
different characteristics and spatially varying temperatures.

Introduction

Gray surfaces in an enclosure can reflect radiant energy specularly, that is, they reflect light 
like a mirror. This is particularly true for optically smooth surfaces like clean metals and 
glassy materials. For these materials the reflectance of a surface can be adequately 
represented by a combination of a diffuse and a specular component. 

Following Ref. 1, the reflectance ρ of a surface can be expressed as

Where ρs and ρd are respectively the specular and diffusive reflectance of the surface, and 
where the symbols ε and α are the emissivity and absorptivity of the surface.

The heat flux q at surfaces in an enclosure is then defined by:

Where J is the surface radiosity

Eb is the blackbody emissive power

and H is the irradiance

The latter expression depends on the external irradiation  and on the differential 
specular view factor . 
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For more details on the terminology see Ref. 1.

Model Definition

The model uses the Mathematical Particle Tracing interface to model radiative heat 
transfer using a discrete transfer method. The heat flux at each boundary element on the 
surface is computed by sending rays outward from the surface to query the temperatures 
of other surfaces in the geometry. The following three features are used:

The Inlet feature is used to determine the irradiance of a surface by backward ray tracing. 
Particles, which represent rays, are released uniformly on the inlet surfaces using a constant 
velocity. Particles are release uniformly within a hemisphere in velocity space (in 3D) or a 
semicircle (in 2D) centered about the surface normal.

In 2D the irradiance per ray Hij is defined as

where Eb is the blackbody emissive power of the surface at which the ray arrives and θ is 
the acute angle between the initial particle velocity vector and the surface normal. The 
angle Δθ is the plane angle subtended by each ray. The additional factor 1/2 is used for 
normalization purposes and compensates for the use of cos(θ) to assign weights to 
different rays based on their angles of incidence; this is validated by the integral

Similarly in 3D, the irradiance per ray is defined as

where Δθ is the solid angle subtended by each ray. The validity of the correction factor 1/
π is confirmed by the integral

The Nonlocal Accumulator subnode, which can be added to the Inlet node, transmits the 
value of a variable at the particle’s current position and communicates this information 
back to the mesh element from which the particle was released, where it can be used to 
change the value of a dependent variable. With the Nonlocal Accumulator it is possible to 
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map the irradiance per ray to the mesh elements from which the rays are initially released. 
For a mesh element i, the irradiance is

Where N is the number of rays released from the mesh element i.

The Wall node is used to make particles freeze, reflect diffusely, or reflect specularly at 
boundaries. The irradiance per ray is only set to a nonzero value when a ray is frozen to 
the wall, so the study must continue for enough time for all particles to freeze. The time 
a ray (particle) take to be absorbed depends on the emittance and reflectance of the walls.

The following algorithm is implemented to fulfill the first equation above: 

1 Generate a random number rn1 between 0 and 1.

2 If rn1 > ρ the ray is absorbed (Freeze condition).

3 If rn1 ≤ ρ generation of a second random number rn2 between 0 and 1.

4 If rn2 < ρs ⁄ ρ the ray undergoes specular reflection (Bounce condition).

5 If rn2 ≥ ρs ⁄ ρ the ray undergoes diffuse reflection with a probability distribution based 
on Knudsen’s cosine law (Diffuse scattering condition).

The model is separated into two parts.

In the first part, we compare the exact analytical solution to the numerical result obtained 
with the Mathematical Particle Tracing interface. 

This computes the heat flux at the surfaces of two identical infinitely long (out-of-plane 
on Figure 1) parallel plates placed in cold surroundings with mixed diffuse-specular 
radiation at their surfaces.

The geometry is illustrated in Figure 1. For the benchmark model the lower and upper 
plates have the same temperature Tl = Tu = T, the same emittance εl = εu = ε, and the same 
probability of specular reflection γl = γu = γ.

Using symmetries, it is possible to determine the heat flux (ql = qu = q) on the lower and 
upper plates using the following analytical solution see Ref. 1.

Hi Hij

j 1=

N

=
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Where ξ = x ⁄ d, W = w ⁄ d and Ψ = q ⁄ Eb. The heat flux can be computed using numerical 
quadrature; a typical solution is presented on Figure 2.

Figure 1: Schematics of the problem. The width of the plates are w = 10 cm, their thickness 
th = w/20, and the distance between the plates set to d = 10 cm. The temperature, emittance 
and probability of specular reflection are equal for both plates and respectively set to T = 300 
K, ε = 0.6, and γs = 0.8. 

In the second part, we keep the parallel plates arrangement (same geometry) but change 
the surface properties and couple the radiation model developed above to the Heat 
Transfer in Solids interface. Table 1 displays the surface parameters used for this part of the 
application.

TABLE 1:  SURFACE PARAMETERS

Surfaces ε γs
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For this model, the upper plate, made of copper, is heated locally from the top. The lower 
plate, made of quartz, is heated by the radiation emitted from the upper plate and cooled 
by natural convection on the bottom surface. The plates’ surrounding temperature is set 
to 300 K. 

Results and Discussion

Figure 2 shows a comparison of the normalized heat flux at the plate’s surfaces for the 
exact and ray tracing solutions (benchmark model). A good agreement is observed 
between the curves. Because the Diffuse scattering wall condition is stochastic in nature, 
the solutions on the top and bottom surfaces differ slightly from each other and from the 
exact solution.

When the heat source computed using the Mathematical Particle Tracing interface is 
coupled to the Heat Transfer in Solids interface, the temperature field shown in Figure 3 
is obtained. The temperature on the surface of the bottom plate is plotted in Figure 4. 
Figure 5 displays the normalized heat flux at the top of the lower plate (blue) and at the 
bottom of the upper plate (green).

Lower plate 0.9 0.1

Upper plate 0.6 0.8

TABLE 1:  SURFACE PARAMETERS

Surfaces ε γs
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Figure 2: Normalized heat flux at the top of the lower plate (blue) and at the bottom of the 
upper plate (green) for T = 300 K, ε = 0.6, γs = 0.8 and w/d = 1. The black circles represent 
the exact solution (the same for both surfaces) obtained from numerical quadrature see Ref. 1.

Figure 3: Temperature at the surface of the plates for the coupled model.
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Figure 4: Temperature at the surface of the lower plate for the coupled model.

Figure 5: Heat flux at the top of the lower plate (blue) and at the bottom of the upper plate 
(green) for the coupled model.
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Notes About the COMSOL Implementation

This 3D model uses a bounce boundary condition to simulate the effect of infinitely long 
plates (symmetry conditions).

An auxiliary dependent variable is necessary to define the release angle of each ray.

The second study consists of two study steps, a Stationary study step to compute the 
temperature and a Time Dependent study step to compute the particle trajectories and 
radiative heat flux. A self-consistent solution is obtained via an iterative process in which a 
For-End For loop is used to alternate between the stationary and time-dependent solvers. 
The loop should be continued until the change in temperature at each successive iteration 
is negligibly small. For this application, an acceptable self-consistent solution is obtained 
in three iterations.

Reference

1. M. F. Modest, Radiative Heat Transfer, 2nd. ed., Academic Press, 2003.

Application Library path: Heat_Transfer_Module/Thermal_Radiation/
parallel_plates_diffuse_specular

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Mathematics>Mathematical Particle Tracing (pt).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.
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G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 2*w.

4 In the Depth text field, type l.

5 In the Height text field, type 2*w.

6 Locate the Position section. From the Base list, choose Center.

Block 2 (blk2)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type w.

4 In the Depth text field, type l.

5 In the Height text field, type th.

Name Expression Value Description

w 10[cm] 0.1 m Width of the plates

d 10[cm] 0.1 m Distance between the 
plates

l 2*w 0.2 m Length of the plates

th w/20 0.005 m Thickness of the plates

M 20 20 Number of ray bundles 
along the width of the 
plates (number of 
elements)

N 300 300 Number of rays per bundle

Delta_theta 2*pi/N 0.02094 Solid angle subtended per 
ray

T0 300[K] 300 K Room temperature
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6 Locate the Position section. From the Base list, choose Center.

7 In the z text field, type -(d+th)/2.

Block 3 (blk3)
1 Right-click Block 2 (blk2) and choose Duplicate.

2 In the Settings window for Block, locate the Position section.

3 In the z text field, type (d+th)/2.

4 Click the Transparency button on the Graphics toolbar in order to see the entire 
geometry.

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

Partition the lower upper plate in two sections. The lines created by the partition will 
be used to display the heat flux across the plates’ width.

2 In the Settings window for Work Plane, locate the Plane Definition section.

3 From the Plane list, choose xz-plane.

Partition Objects 1 (par1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Partition Objects.

2 Click the Select Box button on the Graphics toolbar.

3 Click in the Graphics window and then press Ctrl+A to select all objects.

4 In the Settings window for Partition Objects, locate the Partition Objects section.

5 From the Partition with list, choose Work plane.

6 Click Build All Objects.

Define a selection list for the surrounding, lower and upper plate.

D E F I N I T I O N S

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Surrounding in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 1–5, 7–9, 32, and 33 only.

Explicit 2
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Lower Plate in the Label text field.
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3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 10–13, 18, 20, 21, 26, 28, and 30 only.

Explicit 3
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Upper Plate in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 14–17, 22, 24, 25, 27, 29, and 31 only.

Define the model variables.

Variables 1
1 In the Model Builder window, right-click Definitions and choose Variables.

2 In the Settings window for Variables, type Definitions in the Label text field.

3 Locate the Variables section. In the table, enter the following settings:

Variables 2
1 Right-click Definitions and choose Variables.

2 In the Settings window for Variables, type Surrounding: Study 1 in the Label text 
field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose Surrounding.

5 Locate the Variables section. In the table, enter the following settings:

Name Expression Unit Description

H_ij nojac(1/pi*sigma_const*
bndenv(Ts)^4*
abs(cos(theta_emit))*
Delta_theta)

Irradiance per ray

Eb sigma_const*Ts^4 Blackbody emissive 
power

rho 1-epsilon Surface reflectance

q -epsilon*
(Eb-pt.inl1.nacc1.rpi)

Heat flux

Name Expression Unit Description

Ts 0[K] K Temperature of the surrounding
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Variables 3
1 Right-click Definitions and choose Variables.

2 In the Settings window for Variables, type Lower Plate: Study 1 in the Label text 
field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose Lower Plate.

5 Locate the Variables section. In the table, enter the following settings:

Variables 4
1 Right-click Definitions and choose Variables.

2 In the Settings window for Variables, type Upper Plate: Study 1 in the Label text 
field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose Upper Plate.

5 Locate the Variables section. In the table, enter the following settings:

Variables 5
1 Right-click Definitions and choose Variables.

2 In the Settings window for Variables, type Surrounding: Study 2 in the Label text 
field.

epsilon 1 Emittance of the surrounding

gamma_s 0 Probability of specular reflection

Name Expression Unit Description

Ts T0 K Temperature of the lower plate

epsilon 0.6 Emittance of the lower plate

gamma_s 0.8 Probability of specular reflection

Name Expression Unit Description

Ts T0 K Temperature of the upper plate

epsilon 0.6 Emittance of the upper plate

gamma_s 0.8 Probability of specular reflection

Name Expression Unit Description
13 |  M I X E D  D I F F U S E - S P E C U L A R  R A D I A T I O N  B E N C H M A R K



3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose Surrounding.

5 Locate the Variables section. In the table, enter the following settings:

Variables 6
1 Right-click Definitions and choose Variables.

2 In the Settings window for Variables, type Lower Plate: Study 2 in the Label text 
field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose Lower Plate.

5 Locate the Variables section. In the table, enter the following settings:

Variables 7
1 Right-click Definitions and choose Variables.

2 In the Settings window for Variables, type Upper Plate: Study 2 in the Label text 
field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose Upper Plate.

Name Expression Unit Description

Ts T0 K Temperature of the surrounding

epsilon 1 Emittance of the surrounding

gamma_s 0 Probability of specular reflection

Name Expression Unit Description

Ts T Temperature of the lower plate

epsilon 0.9 Emittance of the lower plate

gamma_s 0.1 Probability of specular reflection
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5 Locate the Variables section. In the table, enter the following settings:

Now define the mathematical particle tracing model. Set the Maximum number of 

secondary particles to zero and avoid allocating unnecessary degrees of freedom to the 
problem.

M A T H E M A T I C A L  P A R T I C L E  TR A C I N G  ( P T )

1 In the Model Builder window, under Component 1 (comp1) click Mathematical Particle 

Tracing (pt).

2 In the Settings window for Mathematical Particle Tracing, locate the Advanced Settings 
section.

3 In the Maximum number of secondary particles text field, type 0.

4 Locate the Domain Selection section. Click Clear Selection.

5 Select Domains 1 and 2 only.

Auxiliary Dependent Variable 1
1 On the Physics toolbar, click Global and choose Auxiliary Dependent Variable.

Add an auxiliary dependent variable that will be used to compute the released angle of 
the particles.

2 In the Settings window for Auxiliary Dependent Variable, locate the Auxiliary Dependent 

Variable section.

3 In the Field variable name text field, type theta_emit.

4 Locate the Units section. Find the Dependent variable quantity subsection. From the list, 
choose Plane angle (rad).

Add an inlet to the surface to which we want to compute the flux, i.e. the lower and 
upper plate surfaces with the exception of the bottom surface of the lower plate and the 
top surface of the upper plate.

Inlet 1
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 Select Boundaries 10, 13, 14, 16, 18, 21, 22, 24, and 28–31 only.

3 In the Settings window for Inlet, locate the Initial Velocity section.

Name Expression Unit Description

Ts T Temperature of the upper plate

epsilon 0.6 Emittance of the upper plate

gamma_s 0.8 Probability of specular reflection
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4 From the Initial velocity list, choose Constant speed, hemispherical in order to have an 
equidistant distribution of rays.

Enter the number of rays per bundle in the Number of particles in velocity space field.

5 In the Nvel text field, type N.

6 Select the Specify tangential and normal vector components check box.

7 Specify the r vector as

Enter the built-in variable for the release angle in the theta_emit0 field.

8 Locate the Initial Value of Auxiliary Dependent Variables section. In the thetaemit0 text 
field, type pt.inl1.thetarel.

Add a nonlocal accumulator to map the computed irradiance per ray to the constant 
discontinuous Lagrange elements associated to the release sites (in this case at the center 
of the mesh elements).

Nonlocal Accumulator 1
1 On the Physics toolbar, click Attributes and choose Nonlocal Accumulator.

2 In the Settings window for Nonlocal Accumulator, locate the Accumulator Settings 
section.

3 From the Accumulator type list, choose Count.

4 In the R text field, type H_ij.

5 From the Source geometric entity level list, choose Boundaries.

6 Locate the Units section. Find the Dependent variable quantity subsection. From the list, 
choose Radiative intensity (W/(m^2*sr)).

Add the bounce boundary condition at the extremities of the domain (symmetry 
condition). Note that the effect of temperature and emittance of the boundary set in 
the surrounding variables have no effect of the computation as the walls are, here, purely 
specular.

Wall 2
1 On the Physics toolbar, click Boundaries and choose Wall.

2 Select Boundaries 2 and 9 only.

3 In the Settings window for Wall, locate the Wall Condition section.

0 t1

0 t2

1 n
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4 From the Wall condition list, choose Bounce.

Select the remaining wall boundaries and set the probability of diffuse and specular 
reflection as well as the probability of absorption of the rays (rho). This wall boundary 
condition computes the probability of specular reflection (bounce otherwise Knudsen 
cosine law) if the ray hasn’t been absorbed before. The probability of absorption is 
entered as rho in the Probability field of the Primary Particle Condition section.

Wall 3
1 On the Physics toolbar, click Boundaries and choose Wall.

2 Select Boundaries 1, 3–5, 7, 8, 10, 12–14, 16–18, 20–22, 24, 25, and 28–33 only.

3 In the Settings window for Wall, locate the Wall Condition section.

4 From the Wall condition list, choose Mixed diffuse and specular reflection.

5 In the γs text field, type gamma_s.

6 Locate the Primary Particle Condition section. From the Primary particle condition list, 
choose Probability.

7 In the γ text field, type rho.

To save on computation time, create a simple mesh on one extremity of the domain and 
sweep it over the entire domain using the swept mesh feature.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
More Operations>Mapped.

Mapped 1
Select Boundaries 11 and 15 only.

Distribution 1
1 Right-click Component 1 (comp1)>Mesh 1>Mapped 1 and choose Distribution.

2 Select Edges 16, 18, 21, and 23 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type M.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 2
1 Select Edge 19 only.

2 Click the Zoom Box button on the Graphics toolbar.
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3 Select Edges 14, 19, 40, and 43 only.

4 In the Settings window for Distribution, locate the Distribution section.

5 In the Number of elements text field, type 1.

Free Triangular 1
1 In the Model Builder window, right-click Mesh 1 and choose More Operations>Free 

Triangular.

2 Select Boundary 2 only.

3 Click the Zoom Extents button on the Graphics toolbar.

4 Right-click Mesh 1 and choose Swept.

Swept 1
In the Settings window for Swept, click Build All.

S T U D Y  1

Generate the default solver sequence and enter a proper maximum time step for the time 
dependent solver. The particles must travel a distance lower than the distance between the 
walls for a given time step.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Time-Dependent Solver 1.

3 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

4 Locate the Time Stepping section. Select the Maximum step check box.

5 In the associated text field, type 0.01.

Enter 1.5 s as the final time step. This will give enough time for the majority of the 
particle to freeze.

Step 1: Time Dependent
1 In the Model Builder window, under Study 1 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type 0,1.5.

Select the boundary definitions for the first study.

4 In the Model Builder window, click Step 1: Time Dependent.
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5 In the Settings window for Time Dependent, locate the Physics and Variables Selection 
section.

6 Select the Modify physics tree and variables for study step check box.

7 In the Physics and variables selection tree, select Component 1 (comp1)>Definitions>

Surrounding: Study 2.

8 Click Disable.

9 In the Physics and variables selection tree, select Component 1 (comp1)>Definitions>Lower 

Plate: Study 2.

10 Click Disable.

11 In the Physics and variables selection tree, select Component 1 (comp1)>Definitions>Upper 

Plate: Study 2.

12 Click Disable.

13 In the Model Builder window, click Study 1.

14 In the Settings window for Study, locate the Study Settings section.

15 Clear the Generate default plots check box.

16 On the Study toolbar, click Compute.

R E S U L T S

Load the heat flux data computed by Gauss quadrature. These data represent an exact 
solution of the model.

Table 1
1 On the Results toolbar, click Table.

2 In the Settings window for Table, type epsilon=0.6, gamma_s=0.8 in the Label text 
field.

3 Locate the Data section. Click Import.

4 Browse to the application’s Application Libraries folder and double-click the file 
parallel_plates_diffuse_specular_data.txt.

5 Click Update.

1D Plot Group 1
1 On the Results toolbar, click 1D Plot Group.

Generate the heat flux comparison. By symmetry, the heat flux at the upper and lower 
plate should be the same.

2 In the Settings window for 1D Plot Group, type Validation in the Label text field.
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3 Locate the Data section. From the Time selection list, choose Last.

Line Graph 1
On the Validation toolbar, click Line Graph.

Validation
1 In the Settings window for Line Graph, locate the y-Axis Data section.

2 In the Expression text field, type q/(epsilon*Eb).

3 Locate the Selection section. Select the Active toggle button.

4 Select Edge 28 only.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type x/w.

7 Click to expand the Legends section. Select the Show legends check box.

8 From the Legends list, choose Manual.

9 In the table, enter the following settings:

10 Click to expand the Quality section. From the Resolution list, choose No refinement.

11 Right-click Line Graph 1 and choose Duplicate.

12 In the Settings window for Line Graph, locate the Legends section.

13 In the table, enter the following settings:

14 Locate the Selection section. Select the Active toggle button.

15 Click Clear Selection.

16 Select Edge 31 only.

17 In the Model Builder window, click Validation.

Table Graph 1
On the Validation toolbar, click Table Graph.

Validation
1 In the Settings window for Table Graph, locate the Coloring and Style section.

2 Find the Line style subsection. From the Line list, choose None.

Legends

Lower plate

Legends

Upper plate
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3 From the Color list, choose Black.

4 Find the Line markers subsection. From the Marker list, choose Circle.

5 From the Positioning list, choose In data points.

6 Click to expand the Legends section. Select the Show legends check box.

7 From the Legends list, choose Manual.

8 In the table, enter the following settings:

9 On the Validation toolbar, click Plot.

Now add a Heat Transfer in Solids interface to the model. Here we are going to couple 
the radiative heat transfer to the heat transfer in the plates. For this model the top of the 
upper plate (copper) is heated by a local heat source with one side held at a constant 
temperature. The bottom of the lower plate (glass) is cooled by convection.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Heat Transfer>Heat Transfer in Solids (ht).

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Study 1.

5 Click Add to Component in the window toolbar.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

1 In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids 

(ht).

2 In the Settings window for Heat Transfer in Solids, locate the Domain Selection section.

3 In the  list, choose 1 and 2.

4 Click Remove from Selection.

5 Select Domains 3–6 only.

Add the material properties to each plate.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Legends

Gauss quadrature
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Material 1 (mat1)
1 In the Settings window for Material, type Quartz in the Label text field.

2 Locate the Geometric Entity Selection section. Click Clear Selection.

3 Select Domains 3 and 5 only.

4 Locate the Material Contents section. In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Copper in the Label text field.

3 Select Domains 4 and 6 only.

4 Locate the Material Contents section. In the table, enter the following settings:

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, expand the Component 1 (comp1)>Definitions node.

Initial Values 1
1 In the Model Builder window, expand the Heat Transfer in Solids (ht) node, then click 

Initial Values 1.

2 In the Settings window for Initial Values, type T0 in the T text field.

Property Name Value Unit Property 
group

Thermal conductivity k 1.1[W/(m*
K)]

W/(m·K) Basic

Density rho 2200[kg/
m^3]

kg/m³ Basic

Heat capacity at constant 
pressure

Cp 480[J/
(kg*K)]

J/(kg·K) Basic

Property Name Value Unit Property 
group

Thermal conductivity k 400[W/(m*
K)]

W/(m·K) Basic

Density rho 8700[kg/
m^3]

kg/m³ Basic

Heat capacity at constant 
pressure

Cp 385[J/
(kg*K)]

J/(kg·K) Basic
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Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

Add a fixed temperature on one side of the upper plate.

2 Select Boundaries 29 and 31 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type T0.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

Add a localized heat flux on the top of the upper plate.

2 Select Boundaries 17 and 25 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 In the q0 text field, type 5e6[W/m^2]*exp(-((x+0.025[m])^2+y^2)/0.0001[m^2]).

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

Add a convective flux on the bottom of the lower plate.

2 Select Boundaries 12 and 20 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type 10.

6 In the Text text field, type T0.

Heat Flux 3
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

Add the radiative heat flux computed by the Mathematical Particle Tracing interface.

2 Select Boundaries 10, 13, 14, 16, 18, 21, 22, 24, and 28–31 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 In the q0 text field, type q.

Add a second study to solve the coupled model.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies.
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4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Mathematical Particle Tracing (pt) interface.

5 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

6 Click Add Study in the window toolbar.

Start by adding a stationary study for the Heat Transfer in Solids interface only and select 
the boundary conditions associated to the second study.

S T U D Y  2

Step 1: Stationary
1 In the Model Builder window, under Study 2 click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study extensions section.

3 Click to collapse the Study extensions section. Locate the Physics and Variables Selection 
section. Select the Modify physics tree and variables for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>Definitions>

Surrounding: Study 1.

5 Click Disable.

6 In the Physics and variables selection tree, select Component 1 (comp1)>Definitions>Lower 

Plate: Study 1.

7 Click Disable.

8 In the Physics and variables selection tree, select Component 1 (comp1)>Definitions>Upper 

Plate: Study 1.

9 Click Disable.

Then add a time dependent study for the Mathematical Particle Tracing only.

Time Dependent
1 On the Study toolbar, click Study Steps and choose Time Dependent>Time Dependent.

Use the same time steps as in Study 1.

Step 2: Time Dependent
1 In the Settings window for Time Dependent, locate the Physics and Variables Selection 

section.

2 In the table, clear the Solve for check box for the Heat Transfer in Solids (ht) interface.

3 Locate the Study Settings section. In the Times text field, type 0,1.5.

Select the boundary definitions for the second study.

4 In the Model Builder window, click Step 2: Time Dependent.
24 |  M I X E D  D I F F U S E - S P E C U L A R  R A D I A T I O N  B E N C H M A R K



5 In the Settings window for Time Dependent, locate the Physics and Variables Selection 
section.

6 Select the Modify physics tree and variables for study step check box.

7 In the Physics and variables selection tree, select Component 1 (comp1)>Definitions>

Surrounding: Study 1.

8 Click Disable.

9 In the Physics and variables selection tree, select Component 1 (comp1)>Definitions>Lower 

Plate: Study 1.

10 Click Disable.

11 In the Physics and variables selection tree, select Component 1 (comp1)>Definitions>Upper 

Plate: Study 1.

12 Click Disable.

Generate the default study sequence for the two steps defined above.

13 In the Model Builder window, click Study 2.

14 In the Settings window for Study, locate the Study Settings section.

15 Clear the Generate default plots check box.

Solution 2 (sol2)
1 On the Study toolbar, click Show Default Solver.

Add a for loop and move the generated sequence in the loop. The purpose of the for 
loop is to match the temperature given by the Heat Transfer in Solids interface to the 
surface temperature used by the radiative model.

2 In the Model Builder window, expand the Solution 2 (sol2) node.

3 Right-click Solution 2 (sol2) and choose Programming>For.

Three loops are expected to be sufficient to match the radiative flux with the Heat 

Transfer in Solids interface with a negligible error.

4 In the Settings window for For, locate the General section.

5 In the Number of iterations text field, type 3.

Move the For node on top of the study sequence. This will include the sequence in the 
loop.

6 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>For 1 and choose Move Up.

7 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>For 1 and choose Move Up.

8 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>For 1 and choose Move Up.

9 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>For 1 and choose Move Up.
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10 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>For 1 and choose Move Up.

11 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>For 1 and choose Move Up.

12 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>For 1 and choose Move Up.

Generate the initial radiative heat flux for the Heat Transfer in Solids interface 
computation.

13 Right-click Solution 2 (sol2) and choose Compile Equations.

14 In the Settings window for Compile Equations, locate the Study and Step section.

15 From the Use study step list, choose Step 2: Time Dependent.

Move the Compile Equations: Stationary node on top of the sequence above the For node.

16 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Compile Equations: 

Stationary (3) and choose Move Up.

17 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Compile Equations: 

Stationary (3) and choose Move Up.

18 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Compile Equations: 

Stationary (3) and choose Move Up.

19 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Compile Equations: 

Stationary (3) and choose Move Up.

20 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Compile Equations: 

Stationary (3) and choose Move Up.

21 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Compile Equations: 

Stationary (3) and choose Move Up.

22 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Compile Equations: 

Stationary (3) and choose Move Up.

23 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Compile Equations: 

Stationary (3) and choose Move Up.

24 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Compile Equations: 

Stationary (3) and choose Move Up.

25 Right-click Solution 2 (sol2) and choose Dependent Variables.

26 In the Settings window for Dependent Variables, type Dependent Variables 0 in the 
Label text field.

Move the Dependent Variables node in between the Compile Equations node and the For 
node.

27 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Dependent Variables 0 and 
choose Move Up.
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28 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Dependent Variables 0 and 
choose Move Up.

29 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Dependent Variables 0 and 
choose Move Up.

30 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Dependent Variables 0 and 
choose Move Up.

31 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Dependent Variables 0 and 
choose Move Up.

32 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Dependent Variables 0 and 
choose Move Up.

33 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Dependent Variables 0 and 
choose Move Up.

34 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Dependent Variables 0 and 
choose Move Up.

35 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Dependent Variables 0 and 
choose Move Up.

36 Locate the General section. From the Defined by study step list, choose User defined.

37 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2) click 
Compile Equations: Time Dependent (3).

38 In the Settings window for Compile Equations, type Compile Equations: Time 
Dependent 0 in the Label text field.

Use the initial solution given by the Mathematical Particle Tracing interface as Values of 

variables not solved for for the Heat Transfer in Solids interface computation.

39 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2) click 
Dependent Variables 1.

40 In the Settings window for Dependent Variables, locate the General section.

41 From the Defined by study step list, choose User defined.

42 Locate the Values of Variables Not Solved For section. From the Method list, choose 
Solution.

43 From the Solution list, choose Solution 2 (sol2).

Use the solution given by the Heat transfer in solids interface as Values of variables not 

solved for for the Mathematical Particle Tracing interface computation.

44 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2) click 
Dependent Variables 2.
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45 In the Settings window for Dependent Variables, locate the General section.

46 From the Defined by study step list, choose User defined.

47 Locate the Initial Values of Variables Solved For section. From the Method list, choose 
Initial expression.

48 From the Solution list, choose Zero.

49 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2) click 
Time-Dependent Solver 1.

50 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

51 Locate the Time Stepping section. Select the Maximum step check box.

52 In the associated text field, type 0.01.

53 Click Compute.

Generate a plot of the surface temperatures.

R E S U L T S

3D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (sol2).

4 Right-click 3D Plot Group 2 and choose Surface.

5 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Heat Transfer in 

Solids>Temperature>T - Temperature.

6 On the 3D Plot Group 2 toolbar, click Plot.

Create a surface dataset to display the temperature on the top of the lower plate.

Surface 1
On the Results toolbar, click More Data Sets and choose Surface.

Data Sets
1 In the Settings window for Surface, locate the Parameterization section.

2 From the x- and y-axes list, choose xy-plane.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 2 (sol2).

4 Select Boundaries 13 and 21 only.
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2D Plot Group 3
1 On the Results toolbar, click 2D Plot Group.

2 In the Model Builder window, right-click 2D Plot Group 3 and choose Surface.

3 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Heat Transfer in 

Solids>Temperature>T - Temperature.

4 On the 2D Plot Group 3 toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

Generate a figure displaying heat flux across the width of the plates.

1D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (sol2).

4 From the Time selection list, choose Last.

5 Click to expand the Legend section. From the Position list, choose Lower right.

Line Graph 1
On the 1D Plot Group 4 toolbar, click Line Graph.

1D Plot Group 4
1 Select Edge 28 only.

2 In the Settings window for Line Graph, locate the y-Axis Data section.

3 In the Expression text field, type q.

4 Locate the x-Axis Data section. From the Parameter list, choose Expression.

5 In the Expression text field, type x.

6 Click to expand the Legends section. Select the Show legends check box.

7 From the Legends list, choose Manual.

8 In the table, enter the following settings:

9 Click to expand the Quality section. From the Resolution list, choose No refinement.

10 Right-click Line Graph 1 and choose Duplicate.

11 In the Settings window for Line Graph, locate the Legends section.

Legends

Lower plate
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12 In the table, enter the following settings:

13 Locate the Selection section. Select the Active toggle button.

14 Click Clear Selection.

15 Select Edge 31 only.

16 On the 1D Plot Group 4 toolbar, click Plot.

Legends

Upper plate
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Introduction

A warm sunny day at the beach can be more enjoyable with a steady supply of frosty 
beverages. This example considers two Styrofoam coolers containing cold beverage cans 
sitting on a sandy beach. A parasol provides partial shade for one of the coolers over the 
course of the day. The difference in beverage temperature over time is computed. This 
tutorial demonstrates the usage of the external radiation source boundary condition, as 
well as how to model structures exposed to ambient conditions.

Figure 1: A parasol provides shade on the beach. Two Styrofoam coolers contain beverage cans 
that should remain as cold as possible.

Model Definition

A system of a parasol and two coolers is modeled as shown in Figure 1. The coolers, made 
of Styrofoam, contain six beverage cans each. The beverage cans are represented by 
water-filled cylinders with walls modeled as thin thermally resistive layers of aluminum. 
Because a slit is defined for the temperature on the walls, the temperature can differ 
between the inner and outer faces. This is used to define initial conditions that are 
discontinuous between the exterior and interior can surfaces. Because aluminum has 
higher thermal conductivity than the surrounding materials, the thin thermally resistive 
layer condition behaves like a continuity condition as soon as the initial temperature 
difference vanishes. The initial can temperature is 1 °C. The spacing between the cans and 
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the cooler walls is small, so the model neglects free convection inside the cooler for 
simplicity.

The parasol primarily provides shade but otherwise has no significant thermal effect on the 
beverage temperature. For this reason, it is not too important to have a high fidelity model 
of the parasol. It is only the shadow cast by the parasol that contributes to the beverage 
temperature profile. The material used for the parasol is acrylic plastic.

The primary source of heat in this model is the solar irradiation, which is included using 
the External Radiation Source feature. This feature uses the longitude, latitude, time zone, 
time of year, and time of day to compute the direction of the incident solar radiation over 
the simulation time. A sunny location at the equator in the middle of the Pacific ocean is 
chosen for this analysis. Assuming no cloud cover, the solar flux at the surface is about 
1000 W/m2. All of the ambient surfaces of the model are included in the solar loading 
calculation, and shadowing effects are included.

The temperature of the sun is about 5800 K, and it emits primarily short-wavelength 
infrared and visible light at wavelengths shorter than 2.5 microns. The fraction of this 
short-wavelength solar radiation that is absorbed by the various materials is quantified by 
the solar absorptivity. Because the surfaces are at a much lower temperature, they reradiate 
in the long-wavelength infrared band, at wavelengths above 2.5 microns, and the fraction 
of reradiated energy is quantified by the surface emissivity. The solar and ambient 
wavelength dependence of emissivity model is used to account for differing emissivities in 
different wavelength bands.

There are three ambient temperature conditions in this model. First, the ground at 1 m 
below the sand surface is assumed to be at a constant temperature of 27 °C throughout 
the day, corresponding to the average water temperature at this location. 

The second ambient condition is the surrounding air temperature. There exists a 
combination of free and forced convection, due to wind, from all exposed surfaces to the 
ambient air, the temperature of which is assumed to vary sinusoidally through the day. In 
this application, the Convective Heat Flux boundary condition uses a bulk heat transfer 
coefficient of 20 W/(m2·K) for all exposed surfaces.

The third boundary condition is the radiative view factor to ambient. The gray body 
radiative view factors are computed between all exposed faces in the model, and radiative 
heat transfer is computed between these faces. However, these computed view factors do 
not sum to unity. There is a significant view factor to surrounding regions that is not 
modeled; this is the residual view factor. The temperature of the ambient is the same as the 
ambient air temperature.
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Results and Discussion

Figure 2 plots the temperature profile at 4 p.m. Observe the decrease of temperature 
where the parasol shade stands.

Figure 2: Temperature distribution.

Figure 3 plots the temperature of the beverage inside two of the cans. This shows clearly 
the advantage of placing the cooler in the shade. At 2 p.m., the parasol shade starts to leave 
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the cooler corresponding to the green curve, which is responsible for the sudden variation 
in the temperature increase at that moment.

Figure 3: Beverage temperature over time inside of the two coolers at the left side of the parasol 
(blue curve) and at the right side (green curve).
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1. F.P. Incropera, D.P. DeWitt, T.L. Bergman, and A.S. Lavine, Fundamentals of Heat 
and Mass Transfer, 6th ed., John Wiley & Sons, 2006.

Application Library path: Heat_Transfer_Module/Thermal_Radiation/parasol

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Radiation>Heat Transfer with 

Surface-to-Surface Radiation (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

G E O M E T R Y  1

Define an analytic function for the time-dependent ambient temperature.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Analytic 1 (an1)
1 On the Home toolbar, click Functions and choose Global>Analytic.

2 In the Settings window for Analytic, type T_ambient in the Function name text field.

3 Locate the Definition section. In the Expression text field, type Tavg[1/K]+dT[1/K]*
cos(2*pi*(x-14)/24).

4 Locate the Units section. In the Arguments text field, type h.

5 In the Function text field, type K.

Name Expression Value Description

Tavg 27[degC] 300.15 K Average ambient temperature

dT 3[K] 3 K Half diurnal temperature 
variation

dateDay 1 1 Day

dateMonth 1 1 Month

dateYear 2012 2012 Year
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6 Locate the Plot Parameters section. In the table, enter the following settings:

7 Click Plot.

G E O M E T R Y  1

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 6.

4 In the Depth text field, type 6.

5 Locate the Position section. From the Base list, choose Center.

6 In the z text field, type -0.5.

7 Right-click Block 1 (blk1) and choose Build Selected.

This first block corresponds to a large region of sand. The next two blocks are the 
styrofoam coolers on the sand.

Block 2 (blk2)
1 On the Geometry toolbar, click Block.

Argument Lower limit Upper limit

x 0 24*3600
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2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 0.3.

4 In the Depth text field, type 0.22.

5 In the Height text field, type 0.18.

6 Locate the Position section. From the Base list, choose Center.

7 In the x text field, type 0.5.

8 In the z text field, type 0.09.

9 Right-click Block 2 (blk2) and choose Build Selected.

Block 3 (blk3)
1 Right-click Block 2 (blk2) and choose Duplicate.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 0.26.

4 In the Depth text field, type 0.18.

5 In the Height text field, type 0.14.

6 Right-click Component 1 (comp1)>Geometry 1>Block 3 (blk3) and choose Build Selected.

In the next few steps, you create two six-pack cans by building one cylinder that is 
duplicated in two 3x2 arrays. Because the cans are located inside the two styrofoam 
coolers, you need to enable the Wireframe Rendering option to see them.

7 Click the Wireframe Rendering button on the Graphics toolbar.

Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type 0.03.

4 In the Height text field, type 0.125.

5 Locate the Position section. In the x text field, type 0.42.

6 In the y text field, type 0.04.

7 In the z text field, type 0.02.

Array 1 (arr1)
1 Right-click Cylinder 1 (cyl1) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Array.

3 Select the object cyl1 only.
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4 In the Settings window for Array, locate the Size section.

5 In the x size text field, type 3.

6 In the y size text field, type 2.

7 Locate the Displacement section. In the x text field, type 0.08.

8 In the y text field, type -0.08.

Copy 1 (copy1)
1 Right-click Array 1 (arr1) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Copy.

3 Select the objects blk2, arr1(3,2,1), arr1(1,1,1), arr1(2,2,1), arr1(2,1,1), blk3, arr1(3,1,1), 
and arr1(1,2,1) only.

For more convenience, use the Select Box button to select the above-mentioned objects.

4 In the Settings window for Copy, locate the Displacement section.

5 In the x text field, type -1.5.

6 Right-click Copy 1 (copy1) and choose Build Selected.

Now, create the parasol.

Cone 1 (cone1)
1 On the Geometry toolbar, click Cone.

2 In the Settings window for Cone, locate the Size and Shape section.

3 In the Height text field, type 0.3.

4 From the Specify top size using list, choose Angle.

5 In the Semi-angle text field, type 70.

6 Locate the Position section. In the z text field, type 1.5.

7 Right-click Cone 1 (cone1) and choose Build Selected.

Cone 2 (cone2)
1 Right-click Cone 1 (cone1) and choose Duplicate.

2 In the Settings window for Cone, locate the Position section.

3 In the z text field, type 1.4.

Difference 1 (dif1)
1 Right-click Component 1 (comp1)>Geometry 1>Cone 2 (cone2) and choose Build Selected.

2 On the Geometry toolbar, click Booleans and Partitions and choose Difference.

3 Select the object cone1 only.
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4 In the Settings window for Difference, locate the Difference section.

5 Find the Objects to subtract subsection. Select the Active toggle button.

6 Select the object cone2 only.

Cylinder 2 (cyl2)
1 Right-click Difference 1 (dif1) and choose Build Selected.

2 On the Geometry toolbar, click Cylinder.

3 In the Settings window for Cylinder, locate the Size and Shape section.

4 In the Radius text field, type 0.05.

5 In the Height text field, type 1.7.

Form Union (fin)
1 Right-click Cylinder 2 (cyl2) and choose Build Selected.

2 On the Geometry toolbar, click Build All.

3 Click the Zoom Extents button on the Graphics toolbar.

D E F I N I T I O N S

The following selection gathers the boundaries of the twelve cans.

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Beverage Can Walls in the Label text field.

3 Select Domains 4–7, 9, 10, and 14–19 only.

4 Locate the Output Entities section. From the Output entities list, choose Adjacent 

boundaries.

The next selection is for the irradiated surfaces.

Explicit 2
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Irradiated Surfaces in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 4, 6, 7, 9, 10, 38–40, 56–62, 65–72, 74, 75, and 118 only.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.
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3 In the tree, select Built-In>Water, liquid.

4 Click Add to Component in the window toolbar.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Air.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Air (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Air (mat2).

2 Select Domains 3 and 13 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Acrylic plastic.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Acrylic plastic (mat3)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Acrylic plastic 

(mat3).

2 Select Domains 8 and 11 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Aluminum.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Aluminum (mat4)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Aluminum 

(mat4).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.
11 |  S U N ’ S  R A D I A T I O N  E F F E C T  O N  TW O  C O O L E R S  P L A C E D  U N D E R  A  P A R A S O L



4 From the Selection list, choose Beverage Can Walls.

Material 5 (mat5)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Styrofoam in the Label text field.

3 Select Domains 2 and 12 only.

4 Locate the Material Contents section. In the table, enter the following settings:

Material 6 (mat6)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Sand in the Label text field.

3 Select Domain 1 only.

4 Locate the Material Contents section. In the table, enter the following settings:

5 On the Home toolbar, click Add Material to close the Add Material window.

H E A T  TR A N S F E R  W I T H  S U R F A C E - T O - S U R F A C E  R A D I A T I O N  ( H T )

1 In the Model Builder window, under Component 1 (comp1) click Heat Transfer with 

Surface-to-Surface Radiation (ht).

2 In the Settings window for Heat Transfer with Surface-to-Surface Radiation, locate the 
Radiation Settings section.

3 From the Wavelength dependence of emissivity list, choose Solar and ambient.

Property Name Value Unit Property 
group

Thermal conductivity k 0.05 W/(m·K) Basic

Density rho 200 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 1300 J/(kg·K) Basic

Property Name Value Unit Property 
group

Thermal conductivity k 0.3 W/(m·K) Basic

Density rho 1500 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 800 J/(kg·K) Basic
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Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer with 

Surface-to-Surface Radiation (ht) click Initial Values 1.

2 In the Settings window for Initial Values, type T_ambient(t) in the T text field.

Initial Values 2
1 On the Physics toolbar, click Domains and choose Initial Values.

2 Select Domains 2–7, 9, 10, and 12–19 only.

3 In the Settings window for Initial Values, type 1[degC] in the T text field.

External Radiation Source 1
1 On the Physics toolbar, click Global and choose External Radiation Source.

2 In the Settings window for External Radiation Source, locate the External Radiation 

Source section.

3 From the Source position list, choose Solar position.

4 From the Location defined by list, choose City.

5 From the list, choose Caracas, Venezuela.

6 In the Date table, enter the following settings:

7 In the Local time table, enter the following settings:

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 3 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type 27[degC].

Diffuse Surface 1
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 In the Settings window for Diffuse Surface, locate the Boundary Selection section.

3 From the Selection list, choose Irradiated Surfaces.

4 Locate the Ambient section. In the Tamb text field, type T_ambient(t).

Day Month Year

dateDay dateMonth dateYear

Hour Minute Second

0 0 0
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5 Locate the Surface Emissivity section. Find the Solar spectral band subsection. From the 
εB1 list, choose User defined. In the associated text field, type 0.2.

6 Find the Ambient spectral band subsection. From the εB2 list, choose User defined. In the 
associated text field, type 0.8.

Diffuse Surface 2
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 In the Settings window for Diffuse Surface, locate the Ambient section.

3 In the Tamb text field, type T_ambient(t).

4 Locate the Surface Emissivity section. Find the Solar spectral band subsection. From the 
εB1 list, choose User defined. In the associated text field, type 0.94.

5 Find the Ambient spectral band subsection. From the εB2 list, choose User defined. In the 
associated text field, type 0.76.

6 Select Boundary 4 only.

Thin Layer 1
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 In the Settings window for Thin Layer, locate the Boundary Selection section.

3 From the Selection list, choose Beverage Can Walls.

4 Locate the Thin Layer section. In the ds text field, type 300[um].

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Irradiated Surfaces.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type 20.

6 In the Text text field, type T_ambient(t).

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, under Study 1 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 From the Time unit list, choose h.

4 Click Range.
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5 In the Range dialog box, type 10 in the Start text field.

6 In the Step text field, type 10[min].

7 In the Stop text field, type 16.

8 Click Replace.

The study starts at 10:00 a.m. and ends at 4:00 p.m. with timesteps of 10 minutes.

9 On the Home toolbar, click Compute.

R E S U L T S

Surface
1 In the Model Builder window, expand the Temperature (ht) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

4 Click the Zoom Extents button on the Graphics toolbar.

The first default plot shows the temperature distribution as in Figure 2.

Isothermal Contours (ht)
The second default plot shows the isothermal contours.

Radiosity (ht)
This default plot shows the surface radiosity. Proceed to plot the external irradiation at 
2:00 p.m. and see the parasol shade as in Figure 1.

1 In the Model Builder window, under Results click Radiosity (ht).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Time (h) list, choose 12.

Surface
1 In the Model Builder window, expand the Radiosity (ht) node, then click Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Model>Component 1>Heat Transfer with 

Surface-to-Surface Radiation>Radiation>External irradiation>ht.G_extB1u - External 

irradiation, upside.

3 Locate the Coloring and Style section. From the Color table list, choose GrayPrint.

4 On the Radiosity (ht) toolbar, click Plot.

Next, observe the temperature of the beverages as in Figure 3.
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1D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Temperature in the Coolers in the 
Label text field.

Point Graph 1
1 On the Temperature in the Coolers toolbar, click Point Graph.

2 Select Points 41 and 126 only.

For more convenience, you can click the Paste Selection button and paste the point 
numbers.

3 In the Settings window for Point Graph, locate the y-Axis Data section.

4 From the Unit list, choose degC.

5 On the Temperature in the Coolers toolbar, click Plot.
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Introduction

This example demonstrates how to model a phase change and predict its impact on a heat 
transfer analysis. When a material changes phase, for instance from solid to liquid, energy 
is added to the solid. Instead of creating a temperature rise, the energy alters the material’s 
molecular structure. Heat consumed or released by a phase change affects fluid flow, 
magma movement and production, chemical reactions, mineral stability, and many other 
earth-science applications.

Figure 1: Material properties as functions of temperature.

This 1D example uses the Phase Change Material feature from the Heat Transfer Module 
to examine transient temperature transfer in a rod of ice that heats up and changes to 
water. In particular, the model demonstrates how to handle material properties that vary 
as a function of temperature.

This model proceeds as follows. First, estimate the ice-to-water phase change using the 
transient conduction equation with the latent heat of fusion. Next, compare the first 
solution to estimates that neglect latent heat. Finally, run additional simulations to evaluate 
impacts of the temperature interval over which the phase change occurs.
2 |  P H A S E  C H A N G E



Model Definition

This example describes the ice-to-water phase change along a 1-cm rod of ice. At its left 
end the rod is insulated, and at the other temperature is maintained at 80 °C. Values for 
thermal properties depend on the phase. They are presented in Table 1, at 265 K for ice 
and 300 K for water.

The latent heat of fusion, lm, is 333.5 kJ/kg and the rod is initially at –20 °C.

During the ice-to-water phase change, the density is modified, resulting in a volume 
compression. The material coordinates express all transformations in the initial coordinate 
system, when ice occupies all the domain. Assuming that there is no mixing in the liquid 
phase, the conduction equation in material coordinates can be used. It simplifies the model 
since you do not need to calculate the velocity field resulting from density variations 
during phase change. The conduction equation in material coordinates reads

 (1)

where ρ (kg/m3) is the density, Ceq (J/kg·K) is the effective heat capacity at constant 
pressure, keq is the effective thermal conductivity (W/m·K), T is temperature (K), and Q 
is a heat source (W/m3).

The material properties ρ and keq of water must be in material coordinates. Because values 
given in Table 1 come from measurements, they correspond to spatial coordinates. Hence, 
conversion into material coordinates is necessary. In 1D models, you just have to multiply 
by the ratio of densities, ρratio:

TABLE 1:  MATERIAL PROPERTIES OF ICE AND WATER

MATERIAL PROPERTY ICE (AT 265 K) WATER (AT 300 K)

Density 918 kg/m3 997 kg/m3

Heat capacity at constant pressure 2052 J/(kg·K) 4179 J(kg·K)

Thermal conductivity 2.31 W/(m·K) 0.613 W/(m·K)

ρCeq
∂T
∂t
------- ∇ keq∇T–( )⋅+ Q=

ρratio
ρice

ρwater
-----------------=
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Note: With this transformation, the density of water, ρ, in material coordinates is 
ρ = ρwaterρratio = ρice. This is consistent with conservation of mass because the integral 
of ρ over the geometry domain remains constant in time.

The boundary conditions for this model are

• thermal insulation at x = 0;

• fixed temperature at x = 0.01; the fixed temperature creates a temperature discontinuity 
at the starting time. You can thus replace Thot by a smoothed step function Tright that 
increases the temperature from T0 to Thot in 0.1 s.

Results and Discussion

Figure 2 shows images of the temperature distribution in time, predicted with latent heat. 
The system is solid ice at t = 0, and water content increases with time.

Figure 2: Temperature estimates with latent heat at t = 0 s, 15 s, 30 s, 45 s, 60 s, 2 min, 3 min, 
4 min, …, 20 min.
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The distributions all level out around the 0 °C temperature point because not all of the 
energy is going toward a temperature rise; some is being absorbed to change the molecular 
structure and change the phase.

The solution in Figure 3 shows temperature estimates for the simulation without latent 
heat.

Figure 3: Temperature estimates without latent heat at t = 0  s, 15 s, 30 s, 45 s, 60 s, 2 min, 
3 min, 4 min, …, 20 min.

A change of profile also occurs at 0 °C but is less visible. Because latent heat is not 
accounted for, this change is here due to the different thermophysical properties of water 
below and above 0 °C.

Figure 4 shows results for different solid-to-liquid intervals at three times. The smaller the 
interval, the sharper the bend in the temperature profile at zero temperature, T. In the 
simulations, narrowing the temperature interval to a step change, for example, comes at a 
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large computational cost. In the figure, the results for the wide and narrow pulses compare 
closely.

Figure 4: Temperature estimates for different temperature intervals for latent heat 
consumption. Estimates are for dT intervals of 0.5 K (blue), 1 K (green), and 2 K (red) at 
t = 30 s (three curves at bottom), 5 min (three curves at middle), and 10 min (three curves on 
top).
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 1D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Fluids (ht).

The Heat Transfer in Fluids interface with its Phase Change Material feature solves for the 
temperature and automatically calculates the equivalent conductivity and the equivalent 
specific heat capacity.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

G E O M E T R Y  1

Interval 1 (i1)
1 On the Geometry toolbar, click Interval.

2 In the Settings window for Interval, locate the Interval section.

3 In the Right endpoint text field, type 0.01.

Form Union (fin)
1 Right-click Interval 1 (i1) and choose Build Selected.

2 In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click Form 

Union (fin) and choose Build Selected.

3 Click the Zoom Extents button on the Graphics toolbar.

G L O B A L  D E F I N I T I O N S

The following steps describe how the model parameters are defined.

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

Step 1 (step1)
1 On the Home toolbar, click Functions and choose Global>Step.

2 In the Settings window for Step, type T_right in the Function name text field.

3 Locate the Parameters section. In the Location text field, type 0.05.

4 In the From text field, type T_0.

5 In the To text field, type T_hot.

Name Expression Value Description

T_trans 0[degC] 273.15 K Transition 
temperature

dT 1[K] 1 K Transition 
interval

lm 333.5[kJ/kg] 3.335E5 J/kg Latent heat of 
fusion

T_0 -20[degC] 253.15 K Initial 
temperature of the 
rod

T_hot 80[degC] 353.15 K Temperature of hot 
water

rho_ice 918[kg/m^3] 918 kg/m³ Density of ice

rho_water 997[kg/m^3] 997 kg/m³ Density of water

rho_ratio rho_ice/rho_water 0.92076 Ratio of densities
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6 Click to expand the Smoothing section. Click Plot.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, type Ice in the Label text field.

2 Locate the Material Contents section. In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Water in the Label text field.

Property Name Value Unit Property 
group

Thermal conductivity k 2.31 W/(m·K) Basic

Density rho rho_ice kg/m³ Basic

Heat capacity at constant 
pressure

Cp 2052 J/(kg·K) Basic

Ratio of specific heats gamma 1 1 Basic
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3 Select Domain 1 only.

Because the model is solved in material coordinates, the water density and thermal 
conductivity are converted.

4 Locate the Material Contents section. In the table, enter the following settings:

H E A T  TR A N S F E R  I N  F L U I D S  ( H T )

Phase Change Material 1
1 On the Physics toolbar, click Domains and choose Phase Change Material.

2 Select Domain 1 only.

3 In the Settings window for Phase Change Material, locate the Phase Change section.

4 In the ΔT1 → 2 text field, type dT.

5 In the L1 → 2 text field, type lm.

6 Locate the Phase 1 section. From the Material, phase 1 list, choose Ice (mat1).

7 Locate the Phase 2 section. From the Material, phase 2 list, choose Water (mat2).

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Fluids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, type T_0 in the T text field.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 2 only.

Property Name Value Unit Property 
group

Thermal conductivity k 0.613[W
/(m*
K)]*
rho_rat
io

W/(m·K) Basic

Density rho rho_wat
er*
rho_rat
io

kg/m³ Basic

Heat capacity at constant 
pressure

Cp 4179 J/(kg·K) Basic

Ratio of specific heats gamma 1 1 Basic
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3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type T_right(t[1/s]).

M E S H  1

Follow the steps below to generate a relatively fine mesh of 120 elements.

1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Edge.

Edge 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Edge 1 and 
choose Distribution.

Distribution 1
1 In the Settings window for Distribution, locate the Distribution section.

2 In the Number of elements text field, type 120.

3 Click Build Selected.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, under Study 1 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 Click Range.

4 In the Range dialog box, type 15 in the Step text field.

5 In the Stop text field, type 60.

6 Click Replace.

7 In the Settings window for Time Dependent, locate the Study Settings section.

8 Click Range.

9 In the Range dialog box, type 120 in the Start text field.

10 In the Step text field, type 60.

11 In the Stop text field, type 1200.

12 Click Add.

13 In the Settings window for Time Dependent, locate the Study Settings section.

14 Select the Relative tolerance check box.

15 In the associated text field, type 0.001.
11 |  P H A S E  C H A N G E



16 On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
All the parameter values in this model have a time unit of seconds, so the output time you 
enter here gives a total simulation time of 20 minutes. Different output intervals can be 
generated by adding other range commands as it is done above. Within the first minute, 
solution data is stored every 15 seconds, whereas for the remaining simulation period, the 
data is only stored every 60 seconds.

A line plot of the temperature distribution along the rod for all times is automatically 
produced. To generate Figure 2, you only need to change the temperature unit.

Line Graph
1 In the Model Builder window, expand the Temperature (ht) node, then click Line Graph.

2 In the Settings window for Line Graph, locate the y-Axis Data section.

3 From the Unit list, choose degC.

4 On the Temperature (ht) toolbar, click Plot.

Phase Change Without Latent Heat

To analyze the impact of the latent heat terms on the phase change model, it is useful to 
estimate temperatures using the same approach but without the latent heat term. 
Therefore, latent heat lm is just set to zero. To keep the original value of 333.5 kJ/kg, 
introduce the parameter lm_original.

G L O B A L  D E F I N I T I O N S

Parameters
1 In the Model Builder window, under Global Definitions click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

lm 0 0 Latent heat of fusion

lm_original 333.5[kJ/kg] 3.335E5 J/kg Latent heat of 
fusion, original
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A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies.

4 In the Select Study tree, select Preset Studies>Time Dependent.

5 Click Add Study in the window toolbar.

S T U D Y  2

Step 1: Time Dependent
1 On the Home toolbar, click Add Study to close the Add Study window.

2 In the Model Builder window, under Study 2 click Step 1: Time Dependent.

3 In the Settings window for Time Dependent, locate the Study Settings section.

4 Click Range.

5 In the Range dialog box, type 60 in the Stop text field.

6 In the Step text field, type 15.

7 Click Replace.

8 In the Settings window for Time Dependent, locate the Study Settings section.

9 Click Range.

10 In the Range dialog box, type 120 in the Start text field.

11 In the Stop text field, type 1200.

12 In the Step text field, type 60.

13 Click Add.

14 In the Settings window for Time Dependent, locate the Study Settings section.

15 Select the Relative tolerance check box.

16 In the associated text field, type 0.001.

17 On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht) 1
1 In the Model Builder window, under Results click Temperature (ht) 1.

2 In the Settings window for 1D Plot Group, type Temperature, No Latent Heat in 
the Label text field.
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To generate Figure 3, you only need to change the units in the automatically generated 
temperature plot.

Line Graph
1 In the Model Builder window, expand the Results>Temperature, No Latent Heat node, 

then click Line Graph.

2 In the Settings window for Line Graph, locate the y-Axis Data section.

3 From the Unit list, choose degC.

4 On the Temperature, No Latent Heat toolbar, click Plot.

To be able to keep track of the different studies, rename the data sets containing the 
solutions of Study 1 and Study 2.

Study 1/Solution 1 (sol1)
1 In the Model Builder window, expand the Results>Data Sets node, then click Study 1/

Solution 1 (sol1).

2 In the Settings window for Solution, type Solution 1, lm Included in the Label text 
field.

Study 2/Solution 2 (sol2)
1 In the Model Builder window, under Results>Data Sets click Study 2/Solution 2 (sol2).

2 In the Settings window for Solution, type Solution 2, lm Excluded in the Label text 
field.

Phase Change for Varying Transition Intervals

Solutions to the phase change problem vary with the range in temperatures dT over which 
you assume that the phase transition occurs. To visualize the impact of different transition 
widths sample results from the original simulation and compare those estimates to results 
from simulations with varying dT values.

G L O B A L  D E F I N I T I O N S

Parameters
1 In the Model Builder window, under Global Definitions click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies.

4 In the Select Study tree, select Preset Studies>Time Dependent.

5 Click Add Study in the window toolbar.

S T U D Y  3

Step 1: Time Dependent
1 On the Home toolbar, click Add Study to close the Add Study window.

2 In the Model Builder window, under Study 3 click Step 1: Time Dependent.

3 In the Settings window for Time Dependent, locate the Study Settings section.

4 Click Range.

5 In the Range dialog box, type 60 in the Stop text field.

6 In the Step text field, type 15.

7 Click Replace.

8 In the Settings window for Time Dependent, locate the Study Settings section.

9 Click Range.

10 In the Range dialog box, type 120 in the Start text field.

11 In the Stop text field, type 1200.

12 In the Step text field, type 60.

13 Click Add.

14 In the Settings window for Time Dependent, locate the Study Settings section.

15 Select the Relative tolerance check box.

16 In the associated text field, type 0.001.

Follow the steps below to calculate the temperature distribution of the rod for different 
values of the transition interval by just adding a parametric sweep to the study node. In 
this example, use the values 0.1 K, 0.5 K, and 2.5 K for dT.

Name Expression Value Description

lm lm_original 3.335E5 J/kg Latent heat of fusion
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Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

5 On the Study toolbar, click Compute.

R E S U L T S

Temperature (ht) 1
Again, the temperature distribution along the rod for all time steps and dT-values is 
produced automatically. You can modify this plot to generate Figure 4 by following the 
steps below.

1 In the Model Builder window, under Results click Temperature (ht) 1.

2 In the Settings window for 1D Plot Group, click to expand the Title section.

3 From the Title type list, choose Manual.

4 In the Title text area, type Temperature curves at t = 30 s, 300 s, 600 s for 
different values of dT.

Line Graph
1 In the Model Builder window, expand the Temperature (ht) 1 node, then click Line Graph.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Data set list, choose Study 3/Parametric Solutions 1 (sol4).

4 From the Parameter selection (dT) list, choose First.

5 From the Time selection list, choose Interpolated.

6 In the Times (s) text field, type 30 300 600.

7 Locate the y-Axis Data section. From the Unit list, choose degC.

8 Click to expand the Coloring and style section. Locate the Coloring and Style section. 
From the Color list, choose Blue.

Parameter name Parameter value list Parameter unit

dT 0.5 1 2
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9 On the Temperature (ht) 1 toolbar, click Plot.

Line Graph 2
1 Right-click Results>Temperature (ht) 1>Line Graph and choose Duplicate.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Parameter selection (dT) list, choose From list.

4 In the Parameter values (dT) list, select 1.

5 Locate the Coloring and Style section. From the Color list, choose Green.
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6 On the Temperature (ht) 1 toolbar, click Plot.

Line Graph
Right-click Line Graph and choose Duplicate.

Line Graph 3
1 In the Settings window for Line Graph, locate the Data section.

2 From the Parameter selection (dT) list, choose Last.

3 Locate the Coloring and Style section. From the Color list, choose Red.

4 On the Temperature (ht) 1 toolbar, click Plot.

Temperature (ht) 1
1 In the Model Builder window, under Results click Temperature (ht) 1.

2 In the Settings window for 1D Plot Group, type Temperature, Varying dT in the 
Label text field.
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Introduction

Transistors are building blocks of electronic appliances, and can be found in radios, 
computers, and calculators, to name a few. When working with electrical systems you 
typically have to deal with heat transfer; electric heating is often an unwanted result of 
current conduction.

This example simulates a system consisting of a small part of a circuit board containing a 
power transistor and the copper pathways connected to the transistor. The purpose of the 
simulation is to estimate the operating temperature of the transistor, which can be 
substantially higher than room temperature due to undesired electric heating.

Transistors are semiconductor devices used to switch or amplify electronic signals. There 
are different types of transistors, ranging in size depending on how they are packaged. 
Power transistors carry and dissipate more power and therefore come in larger packages. 
These packages can be attached to a heat sink for better cooling and to avoid overheating 
of the system.

The heat sink would then be attached to the transistor via the copper plate located behind 
the ceramic piece (shown in Figure 1 to the left). While it’s often important to construct 
a way to cool electronic systems, such as in the case of components in hybrid cars, each 
system has its own acceptable operating temperature range. What determines the 
maximum and minimum temperature limits include the semiconductor material 
properties, the transistor type, the design of the device, and so forth. There is a 
conventional temperature range, however, which is thought to be between -55 °C and 
125 °C.

Model Definition

Figure 1 shows the model geometry used in the simulation. The power transistor is 
mounted on the circuit board using through-hole technology. The solder in the holes give 
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mechanical support and electronic contact between the copper routes and the transistor 
pins.

Figure 1: Model geometry and position of transistor chip.

The transistor chip itself is a very thin structure represented by an internal surface in 
Figure 1. The chip is connected to the pins but this connections are assumed to have 
negligible effects on heat transfer.

The transistor package front part is made of ceramics while the back part, which could be 
clamped to a heat sink, is made of copper. The transistor chip and the front part of the 
package have matching thermal properties. The copper pins are soldered to the circuit 
board by the solder material 60Sn-40Pb (60 % tin and 40 % lead). The circuit board is 
made of FR4.

Current conduction and Joule heating take place in the copper routes, in the solders, and 
in the pins. In these parts, the physics of heat transfer and heat production due to Joule 
heating are fully coupled to the conduction of electric current. In all other parts of the 
transistor, only heat transfer and heat production take place. 

The transistor chip itself is represented by an internal boundary with an internal 
production of heat corresponding to 0.9 W. Cooling through convection takes place at all 
external boundaries with a heat transfer coefficient of 5.0 W/(m2·K). This value of the 
heat transfer coefficient corresponds to the worst case scenario when the fan is switched 
off. The ambient temperature is 293.15 K.

Current enters the circuit board at the left vertical boundaries of the copper routes 
connected to the base, emitter, and collector in Figure 1. The value of the current at the 
boundary of the route connected to the emitter is 0.12 A. The value of the current at the 
boundary of the route connected to the collector is 0.11988 A. The difference in absolute 

Copper 
routes

Ceramic Copper

Solder

Base

Transistor 
chip

Emitter

Collector
FR4 Applied 

current
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current between the emitter and collector currents corresponds to the current at the 
boundary of the route connected to the base, which is 0.12 mA.

Results and Discussion

Figure 2 below shows the temperature distribution in the device. The maximum 
temperature is about 354 K or 81 °C. This is well within the acceptable operation 
temperature range for the transistor, which implies that attaching it to a heat sink is not 
needed in this case.

Figure 2: Temperature distribution.

Also worth noting is that electric heating, or Joule heating as it is also referred to, hardly 
influences the temperature of the copper routes at the distance from the transistor 
modeled above. That’s most likely due to copper’s high conductivity; some of the heat 
produced in the transistor chip is conducted away from the device via the copper routes. 
Figure 3 shows the temperature along the copper routes connected to the base and the 
collector respectively. The current density in the base is 1/1000 of that in the collector but 
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the temperature in the copper routes connected to the base and collector is almost 
identical.

Figure 3: Temperature along the copper routes connected to the base and collector.

The fact that the Joule heating effect does not increase temperature in the copper routes 
leads to the conclusion that the higher temperature in these routes is due to coppers high 
conductivity. The copper routes conduct some of the heat produced in the transistor chip 
away from this device. The circuit board has a poor thermal conductivity and is therefore 
not heated to the same extent as the copper routes.

Notes About the COMSOL Implementation

You can find all the material properties for this application in COMSOL’s Material Library. 
Furthermore, the ready-made physics interface for Joule heating sets up all model 
formulations that you need for the simulation: Electric Current and Heat Transfer in 
Solids are added with the corresponding Joule Heating coupling features in the 
Multiphysics node.

The Joule heating interface is by default available for all materials in the model. However, 
the circuit board material and the package material do no conduct electric current. For this 
reason, you have to edit the selection of Electric current physics to remove 
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non-conducting domains. On the circuit board material, only heat transfer physics is 
calculated. By removing the non-conductive parts of the device to the list of Electric 
Current physics, Electromagnetic Heat Source and Boundary Electromagnetic Heat 
Source are automatically not applicable on these domains.

Application Library path: Heat_Transfer_Module/
Power_Electronics_and_Electronic_Cooling/power_transistor

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Electromagnetic Heating>Joule Heating.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
power_transistor.mphbin.
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5 Click Build All Objects.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Copper.

4 Click Add to Component in the window toolbar.

Name Expression Value Description

j_CE 1e5[A/m^2] 1E5 A/m² Current density, collector 
and emitter routes

Q_h 1e5[W/m^2] 1E5 W/m² Boundary heat source 
strength

h_coeff 5[W/(m^2*K)] 5 W/(m²·K) Heat transfer coefficient
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A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>FR4 (Circuit Board).

3 Click Add to Component in the window toolbar.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Silica glass.

3 Click Add to Component in the window toolbar.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Solder, 60Sn-40Pb.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Solder, 60Sn-40Pb (mat4)
On the Home toolbar, click Add Material to close the Add Material window.

Copper (mat1)
1 Click the Wireframe Rendering button on the Graphics toolbar.

2 In the Model Builder window, under Component 1 (comp1)>Materials click Copper (mat1).

3 In the Settings window for Material, locate the Geometric Entity Selection section.

4 Click Clear Selection.

5 Select Domains 2–4 and 9–12 only.

FR4 (Circuit Board) (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click FR4 (Circuit 

Board) (mat2).

2 Select Domain 1 only.

Silica glass (mat3)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Silica glass 

(mat3).

2 Select Domain 7 only.
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Solder, 60Sn-40Pb (mat4)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Solder, 

60Sn-40Pb (mat4).

2 Select Domains 5, 6, and 8 only.

3 In the Settings window for Material, locate the Material Contents section.

4 In the table, enter the following settings:

E L E C T R I C  C U R R E N T S  ( E C )

1 In the Model Builder window, under Component 1 (comp1) click Electric Currents (ec).

2 Select Domains 2–6 and 8–11 only.

Ground 1
1 On the Physics toolbar, click Boundaries and choose Ground.

2 Select Boundaries 69, 87, and 105 only.

Normal Current Density 1
1 On the Physics toolbar, click Boundaries and choose Normal Current Density.

2 Select Boundary 10 only.

3 In the Settings window for Normal Current Density, locate the Normal Current Density 
section.

4 In the Jn text field, type (1-1e-3)*j_CE.

Normal Current Density 2
1 On the Physics toolbar, click Boundaries and choose Normal Current Density.

2 Select Boundary 5 only.

3 In the Settings window for Normal Current Density, locate the Normal Current Density 
section.

4 In the Jn text field, type -j_CE.

Normal Current Density 3
1 On the Physics toolbar, click Boundaries and choose Normal Current Density.

2 Select Boundary 15 only.

Property Name Value Unit Property 
group

Relative permittivity epsilonr 1 1 Basic
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3 In the Settings window for Normal Current Density, locate the Normal Current Density 
section.

4 In the Jn text field, type 1e-3*j_CE.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids (ht).

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type h_coeff.

Boundary Heat Source 1
1 On the Physics toolbar, click Boundaries and choose Boundary Heat Source.

2 Select Boundary 142 only.

3 In the Settings window for Boundary Heat Source, locate the Boundary Heat Source 
section.

4 In the Qb text field, type Q_h.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Tetrahedral.
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Free Tetrahedral 1
1 In the Settings window for Free Tetrahedral, click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Multislice 1
1 In the Model Builder window, expand the Electric Potential (ec) node.

2 Right-click Multislice 1 and choose Delete.

Electric Potential (ec)
In the Model Builder window, under Results right-click Electric Potential (ec) and choose 
Surface.

Surface 1
On the Electric Potential (ec) toolbar, click Plot.

Temperature (ht)
The second default plot shows the temperature. Add an arrow plot of the total heat flux.

Arrow Surface 1
1 In the Model Builder window, under Results right-click Temperature (ht) and choose 

Arrow Surface.
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2 In the Settings window for Arrow Surface, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Model>Component 1>Heat 

Transfer in Solids>Domain fluxes>ht.tfluxx,...,ht.tfluxz - Total heat flux.

3 Locate the Coloring and Style section. In the Number of arrows text field, type 5e3.

4 From the Color list, choose Black.

5 On the Temperature (ht) toolbar, click Plot.

6 Click the Zoom In button on the Graphics toolbar.

7 Click the Zoom Extents button on the Graphics toolbar.

Finally, reproduce the plot in Figure 3 by following the steps outlined below.

1D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Temperature along Copper Routes 
in the Label text field.

Line Graph 1
1 On the Temperature along Copper Routes toolbar, click Line Graph.

2 Select Edges 28, 41, and 53 only.
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3 In the Settings window for Line Graph, click Replace Expression in the upper-right corner 
of the y-axis data section. From the menu, choose Model>Component 1>Heat Transfer in 

Solids>Temperature>T - Temperature.

4 Click to expand the Legends section. Select the Show legends check box.

5 From the Legends list, choose Manual.

6 In the table, enter the following settings:

7 On the Temperature along Copper Routes toolbar, click Plot.

Line Graph 2
1 Right-click Line Graph 1 and choose Duplicate.

2 In the Settings window for Line Graph, locate the Selection section.

3 Select the Active toggle button.

4 Select Edges 14, 38, and 50 only.

5 Locate the Legends section. In the table, enter the following settings:

6 On the Temperature along Copper Routes toolbar, click Plot.

Temperature along Copper Routes
1 In the Model Builder window, under Results click Temperature along Copper Routes.

2 In the Settings window for 1D Plot Group, click to expand the Title section.

3 From the Title type list, choose None.

4 Locate the Plot Settings section. Select the x-axis label check box.

5 In the associated text field, type Distance from connector (m).

6 On the Temperature along Copper Routes toolbar, click Plot.

Legends

Base

Legends

Collector
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Introduction

Shell-and-tube heat exchangers are one of the most widely used type of heat exchanger in 
the processing industries (65% of the market according to Ref. 1) and are commonly found 
in oil refineries, nuclear power plants, and other large-scale chemical processes. 
Additionally, they can be found in many engines and are used to cool hydraulic fluid and 
oil. In this application, two separated fluids at different temperatures flow through the heat 
exchanger: one through the tubes (tube side) and the other through the shell around the 
tubes (shell side). Several design parameters and operating conditions influence the 
optimal performance of a shell-and-tube heat exchanger.

The main purpose of this tutorial is to show the basic principles for setting up a heat 
exchanger model. It can also serve as a starting point for more sophisticated applications, 
such as parameter studies or adding additional effects like corrosion, thermal stress, and 
vibration.

Figure 1: Geometry of the shell-and-tube heat exchanger.

Model Definition

The concept used to design a shell-and-tube heat exchanger is examined by exploring the 
working model of a straight, cross-flow, one pass shell-and-tube heat exchanger. The 
geometry of such a model is shown in Figure 1.

Shell

Baffles

Tubes

Inlet, water

Inlet, air

Outlet, air

Outlet, water
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The heat exchanger is made of structural steel. In this example, two fluids pass through 
the heat exchanger. The first fluid, in this case water, flows through the tubes, while the 
second fluid, air, circulates within the shell of the heat exchanger but outside of the tubes. 
Both of these fluids have different starting temperatures when entering the heat 
exchanger, however after circulating within it, the fluids are brought closer to an 
equilibrium temperature. The baffles introduce some cross-flow to the air and such 
increasing the area of heat exchange. Another advantage is that baffles reduce vibration 
due to the fluid motion.

This model uses the Non-Isothermal Flow predefined multiphysics coupling configured 
with the k-ε turbulence model. It takes advantage of symmetries to model only one half of 
the heat exchanger, thereby reducing model size and computational costs.

B O U N D A R Y  C O N D I T I O N S

All heat exchanger walls including the baffles are modeled as shells in 3D. This requires 
special boundary conditions for the flow and heat transport equations.

The interior wall boundary condition for the flow separates the fluids from each other and 
is also used to describe the baffles. On both sides, it applies the wall functions needed for 
simulating walls with the k-ε turbulence model.

To account for the in-plane heat flux in the shell, the Thin Layer boundary condition is 
applied. This boundary condition simulates heat transfer in thin shell structures. Here, the 
shell is supposed made of steel and with a 5 mm thickness.

Water enters the tube side with a velocity of 0.1 m/s and a temperature of 80 °C. Air 
enters the shell side with a velocity of 1 m/s and a temperature of 5 °C. At both inlets, the 
recommended values for the turbulence length scale is 0.07 L, where L is the channel 
radius (see Inlet Values for the Turbulence Length Scale and Turbulent Intensity). For the 
water inlet, this radius is equal to 5 cm and for the air inlet, it is 4.5 cm.

Beside the symmetry plane, all remaining exterior boundaries are thermally insulated walls.

Results and Discussion

An important criterion for estimating the accuracy of a turbulence model is the wall 
resolution. Hence, COMSOL Multiphysics creates a plot of the wall resolution by default. 
The value for δw

+ has to be 11.06, which corresponds to the distance from the wall where 
the logarithmic layer meets the viscous sublayer. Furthermore, the wall lift-off δw has to 
be small compared to the dimension of the geometry. On interior walls you have δw for 
the upside and downside of the wall. To visualize the upside and downside directions, use 
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an arrow surface plot with the components unx, uny, and unz for the up direction and dnx, 
dny, and dnz for the down direction.

Figure 2 shows the upside wall lift-off. This is the wall lift-off inside the tubes where the 
probably most critical area in terms of mesh resolution is located. It is about 10% of the 
tube radius, which is sufficient.

Figure 2: Wall lift-off for the tubes.
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The tube side velocity shows a uniform distribution in the tubes. Before water enters the 
tubes, recirculation zones are present. The streamline colors represent the temperature 
and you can see that the temperatures at both outlets are close to each other.

Figure 3: Velocity streamlines.
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Figure 4 shows the temperature distribution on the heat exchanger boundaries.

Figure 4: Temperature at the heat exchanger boundaries.

There are several quantities that describe the characteristics and effectiveness of a heat 
exchanger. One is the equivalent heat transfer coefficient given by

 (1)

where P is the total exchanged power and A is the surface area through which P flows. In 
this model the value of heq is 5.4 W/(m2·K).

The pressure drop is about 33 Pa on the tube side and 12 Pa on the shell side.

Notes About the COMSOL Implementation

Solve the model using a physics-controlled mesh. For flow applications this means that 
COMSOL Multiphysics automatically generates a mesh sequence where the mesh size 
depends on whether the flow is laminar or turbulent and where a boundary layer mesh is 
applied to all no slip walls. Even if the coarsest mesh size is used, the mesh is still fine 
enough to resolve the flow pattern and thus the temperature distribution well. 

heq
P

A Thot Tcold–( )
-----------------------------------------=
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Nevertheless, this application requires about 10 GB RAM. Alternatively, you can set up a 
coarser mesh manually, but keep in mind that this can lead to lower accuracy.

The first part of the modeling process is the preprocessing. This includes defining 
parameters, preparing the geometry, and defining relevant selections. You can skip this part 
by loading the file shell_and_tube_heat_exchanger_geom.mph. However, we 
recommend that you take a look at these steps at least once. Especially when developing 
models intended for optimization and sophisticated analyses, these steps can significantly 
simplify and accelerate the modeling process.

Defining parameters beforehand enables setting up a parametric study immediately, also 
for multiple parameter sets. In addition, this provides a fast overview of the operating 
conditions. In the Modeling Instructions, several selections are also created. Once defined, 
they are available in every step of the modeling process. If you want to change from 
concurrent to countercurrent heat exchanger, you only need to redefine the selections.

Application Library path: Heat_Transfer_Module/Heat_Exchangers/
shell_and_tube_heat_exchanger

Reference

1. H. S. Lee, Thermal Design, John Wiley & Sons, 2010.

Modeling Instructions

R O O T

The file shell_and_tube_heat_exchanger_geom.mph contains a parameterized 
geometry and prepared selections for the model. Start by loading this file.

1 From the File menu, choose Open.

2 Browse to the application’s Application Library folder and double-click the file 
shell_and_tube_heat_exchanger_geom.mph.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Air.
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4 Click Add to Component in the window toolbar.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Water, liquid.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Water, liquid (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Water, liquid 

(mat2).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Water Domain.

The heat exchanger itself is made of structural steel. Apply this material to the walls of the 
heat exchanger.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Structural steel.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Structural steel (mat3)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Structural steel 

(mat3).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Walls.

5 On the Home toolbar, click Add Material to close the Add Material window.

TU R B U L E N T  F L O W,  K - ε ( S P F )

Since the density variation is not small, the flow can not be regarded as incompressible. 
Therefore set the flow to be compressible.

1 In the Model Builder window, under Component 1 (comp1) click Turbulent Flow, k-ε (spf).
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2 In the Settings window for Turbulent Flow, k-ε, locate the Physical Model section.

3 From the Compressibility list, choose Compressible flow (Ma<0.3).

The next step is to set the boundary conditions. At first the boundary conditions for the 
flow equations are applied. These are the inlet and outlet boundary conditions, symmetry 
as well as the interior walls which separate the air from the water domain. The default wall 
boundary condition then applies to the outer boundaries.

Inlet 1
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 In the Settings window for Inlet, type Inlet 1: Water in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose Inlet, Water.

4 Locate the Turbulence Conditions section. In the LT text field, type 0.07*5[cm].

This is an estimation for the turbulence length scale as explained in the Model 
Definition section.

5 Locate the Velocity section. In the U0 text field, type u_water.

Outlet 1
1 On the Physics toolbar, click Boundaries and choose Outlet.

2 In the Settings window for Outlet, type Outlet 1: Water in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose Outlet, Water.

4 Locate the Pressure Conditions section. Select the Normal flow check box.

Inlet 2
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 In the Settings window for Inlet, type Inlet 2: Air in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose Inlet, Air.

4 Locate the Turbulence Conditions section. In the LT text field, type 0.07*4.5[cm].

This is an estimation for the turbulence length scale as explained in the Model 
Definition section.

5 Locate the Velocity section. In the U0 text field, type u_air.

Outlet 2
1 On the Physics toolbar, click Boundaries and choose Outlet.

2 In the Settings window for Outlet, type Outlet 2: Air in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose Outlet, Air.

4 Locate the Pressure Conditions section. Select the Normal flow check box.
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Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 In the Settings window for Symmetry, locate the Boundary Selection section.

3 From the Selection list, choose Symmetry.

Interior Wall 1
1 On the Physics toolbar, click Boundaries and choose Interior Wall.

2 In the Settings window for Interior Wall, locate the Boundary Selection section.

3 From the Selection list, choose Walls.

The boundary conditions that set up the heat transfer equation are the temperatures at the 
inlets and the outflow at the outlets, the symmetry and for all walls the highly conductive 
layer feature accounts for the heat conduction through the shell.

H E A T  TR A N S F E R  I N  F L U I D S  ( H T )

In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Fluids (ht).

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 In the Settings window for Temperature, type Temperature 1: Water in the Label text 
field.

3 Locate the Boundary Selection section. From the Selection list, choose Inlet, Water.

4 Locate the Temperature section. In the T0 text field, type T_water.

Outflow 1
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 In the Settings window for Outflow, type Outflow 1: Water in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose Outlet, Water.

Temperature 2
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 In the Settings window for Temperature, type Temperature 2: Air in the Label text 
field.

3 Locate the Boundary Selection section. From the Selection list, choose Inlet, Air.

4 Locate the Temperature section. In the T0 text field, type T_air.

Outflow 2
1 On the Physics toolbar, click Boundaries and choose Outflow.
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2 In the Settings window for Outflow, type Outflow 2: Air in the Label text field.

3 Locate the Boundary Selection section. From the Selection list, choose Outlet, Air.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 In the Settings window for Symmetry, locate the Boundary Selection section.

3 From the Selection list, choose Symmetry.

Thin Layer 1
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 In the Settings window for Thin Layer, locate the Boundary Selection section.

3 From the Selection list, choose Walls.

4 Locate the Thin Layer section. From the Layer type list, choose Thermally thin 

approximation.

5 In the ds text field, type 0.005[m].

The physics is now defined. For evaluating the equivalent heat transfer coefficient 
according to Equation 1 directly after solving the model, you need to define the following 
component coupling operator. It can also be defined and evaluated after computing the 
simulation, but in this case you need to choose Update Solution (after right-clicking on the 
Study 1 node) to make this operator available without running the model again.

D E F I N I T I O N S

Average 1 (aveop1)
1 On the Definitions toolbar, click Component Couplings and choose Average.

2 In the Settings window for Average, type Average Operator on Water-Air 
Interface in the Label text field.

3 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose Water-Air Interface.

The heat exchanger properties and operating conditions are well defined and the model is 
ready to solve. For a first estimation of the heat exchanger performance a coarse mesh is 
satisfying. The solution is obtained very fast and provides qualitatively good results. 
Reliable quantitative results require a good resolution especially of the wall regions.

The default physics-controlled mesh is a good starting point and can be customized to 
reduce computational costs. Here you reduce the number of boundary layers and scale the 
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geometry for the meshing sequence in the x-direction. This results in an anisotropic mesh 
that is suitable for the minor changes of the flow field and temperature field in the 
x-direction.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Extremely coarse.

4 Right-click Component 1 (comp1)>Mesh 1 and choose Edit Physics-Induced Sequence.

Free Tetrahedral 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Free Tetrahedral 

1.

2 In the Settings window for Free Tetrahedral, click to expand the Scale geometry section.

3 Locate the Scale Geometry section. In the x-direction scale text field, type 0.5.

Boundary Layer Properties 1
1 In the Model Builder window, expand the Component 1 (comp1)>Mesh 1>Boundary Layers 

1 node, then click Boundary Layer Properties 1.

2 In the Settings window for Boundary Layer Properties, locate the Boundary Layer 

Properties section.

3 In the Number of boundary layers text field, type 3.

4 Click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Velocity (spf)
A slice plot of the velocity field, a surface plot of the wall resolution and a surface plot of 
the temperature are generated by default. You can either customize these plots or create 
new plot groups to visualize the results.

The wall resolution indicates the accuracy of the flow close to the walls where the wall 
functions are applied. The variable spf.d_w_plus should be 11.06 and the wall lift-off 
spf.delta_w needs to be significantly smaller than the dimension of the geometry. On 
interior boundaries, these variables are available for the upside and downside of the wall 
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indicated by spf.d_w_plus_u/d or spf.delta_w_u/d, respectively. The critical regions 
in terms of the wall resolution are in the tubes.

Wall Resolution (spf)
Delete the Upside Wall Lift-Off and Downside Wall Lift-Off from the Wall Resolution (spf) plot 
group.

1 In the Model Builder window, expand the Results>Wall Resolution (spf) node, then click 
Wall Lift-Off.

2 In the Settings window for Surface, locate the Data section.

3 From the Data set list, choose Interior Walls.

4 Locate the Expression section. In the Expression text field, type spf.delta_w_u.

5 On the Wall Resolution (spf) toolbar, click Plot.

Figure 4 shows the temperature distribution on all wall boundaries. The default 
temperature plot uses the Surface 1 data set created automatically and contains exterior 
walls only. It is easy to change it by using the selection created at the beginning.

Data Sets
1 In the Model Builder window, expand the Results>Data Sets node, then click All Walls.

2 In the Settings window for Surface, locate the Selection section.

3 From the Selection list, choose Walls.

Temperature (ht)
1 In the Model Builder window, under Results click Temperature (ht).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Data set list, choose All Walls.

4 In the Model Builder window, expand the Temperature (ht) node, then click Surface.

5 In the Settings window for Surface, locate the Expression section.

6 From the Unit list, choose degC.

7 On the Temperature (ht) toolbar, click Plot.

In Figure 3, the streamlines are plotted for the full 3D geometry. Even if only one half of 
the heat exchanger is modeled the solution can be mirrored to obtain a full 3D view of the 
results. To do so, follow the steps below:

Mirror 3D 1
On the Results toolbar, click More Data Sets and choose Mirror 3D.
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Data Sets
1 In the Settings window for Mirror 3D, locate the Plane Data section.

2 From the Plane list, choose zx-planes.

3D Plot Group 6
1 On the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Velocity, Streamlines in the Label 
text field.

3 Locate the Data section. From the Data set list, choose Mirror 3D 1.

Velocity, Streamlines
1 Right-click Velocity, Streamlines and choose Streamline.

2 In the Settings window for Streamline, locate the Streamline Positioning section.

3 In the Points text field, type 100.

4 Locate the Coloring and Style section. From the Line type list, choose Tube.

5 Right-click Results>Velocity, Streamlines>Streamline 1 and choose Color Expression.

6 In the Settings window for Color Expression, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Model>Component 1>Heat 

Transfer in Fluids>Temperature>T - Temperature.

7 Locate the Coloring and Style section. From the Color table list, choose Thermal.

Evaluate the equivalent heat transfer coefficient by using the component coupling 
operators defined previously.

Global Evaluation 1
On the Results toolbar, click Global Evaluation.

Derived Values
1 In the Settings window for Global Evaluation, type Heat Transfer Coefficient in 

the Label text field.

2 Locate the Expressions section. In the table, enter the following settings:

The variable nitf1.qwf_u efficiently computes the heat flux through the wall 
separating water and air domains, based on the wall function definition.

3 Click Evaluate.

Expression Unit Description

aveop1(nitf1.qwf_u)/(T_water-T_air) W/(m^2*K)
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To evaluate the pressure drop, the average inlet pressures are computed.

Surface Average 1
On the Results toolbar, click More Derived Values and choose Average>Surface Average.

Derived Values
1 In the Settings window for Surface Average, type Inlet Pressure, Water in the Label 

text field.

2 Locate the Selection section. From the Selection list, choose Inlet, Water.

3 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Turbulent Flow, k-ε>Velocity and pressure>p - 

Pressure.

4 Click Evaluate.

Surface Average 2
On the Results toolbar, click More Derived Values and choose Average>Surface Average.

Derived Values
1 In the Settings window for Surface Average, type Inlet Pressure, Air in the Label 

text field.

2 Locate the Selection section. From the Selection list, choose Inlet, Air.

3 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Turbulent Flow, k-ε>Velocity and pressure>p - 

Pressure.

4 Click Evaluate.

TA B L E

1 Go to the Table window.

The tube side pressure drop is 33 Pa and the shell side pressure drop is 12 Pa.
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Introduction

The following example illustrates how to build and solve a model using the Heat Transfer 
in Thin Shells interface. This example is a 2D NAFEMS benchmark (Ref. 1), which was 
transformed to 3D. 

Model Definition

Figure 1 describes the 2D benchmark example.

Figure 1: A 2D benchmark example for a thin conductive shell.

Heat transfer by convection

h = 750 W/(m2·K)

External temperature 
Text = 273.15 K

Material properties: 
k = 52 W/(m·K)

T = 373.15 K
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The 3D model bends this plate so that it becomes a quarter of a cylinder (Figure 2).

Figure 2: The 3D geometry based on the 2D model.

A
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Results

The temperature at point A in Figure 2 (291.40 K) is in agreement with that from the 
NAFEMS benchmark (Ref. 1). Figure 3 shows the temperature distribution.

Figure 3: The resulting temperature field of the 3D model.

Reference

1. J.A. Casey and G.B Simpson, “Two-dimensional Steady State,” Benchmark Tests for 
Thermal Analysis, NAFEMS, Test 10, p. 2.9, 1986.

Application Library path: Heat_Transfer_Module/Tutorials,_Thin_Structure/
shell_conduction

Modeling Instructions

From the File menu, choose New.
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N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Thin Structures>Heat Transfer in Thin Shells 

(htsh).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Object Type section.

3 From the Type list, choose Surface.

4 Locate the Size and Shape section. In the Radius text field, type 2/pi.

5 In the Height text field, type 0.6.

6 Right-click Cylinder 1 (cyl1) and choose Build Selected.

Delete Entities 1 (del1)
1 Right-click Geometry 1 and choose Delete Entities.

Name Expression Value Description

T_edge 373.15[K] 373.15 K Edge temperature

T_ext 273.15[K] 273.15 K External 
temperature

ht 750[W/(m^2*K)] 750 W/(m²·K) Heat transfer 
coefficient
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2 On the object cyl1, select Boundaries 1–3 only.

3 Right-click Component 1 (comp1)>Geometry 1>Delete Entities 1 (del1) and choose Build 

Selected.

4 Click the Zoom Extents button on the Graphics toolbar.

Point 1 (pt1)
1 On the Geometry toolbar, click More Primitives and choose Point.

2 In the Settings window for Point, locate the Point section.

3 In the x text field, type (2/pi)*cos(pi*18/180).

4 In the y text field, type (2/pi)*sin(pi*18/180).

This step embeds the point where you compare the calculated solution with the 
benchmark.

5 Right-click Point 1 (pt1) and choose Build Selected.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, locate the Material Contents section.

2 In the table, enter the following settings:

H E A T  TR A N S F E R  I N  T H I N  S H E L L S  ( H T S H )

Temperature 1
1 On the Physics toolbar, click Edges and choose Temperature.

2 Select Edge 5 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type T_edge.

Property Name Value Unit Property 
group

Thermal conductivity k 52 W/(m·K) Basic

Density rho 8800 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 420 J/(kg·K) Basic
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Heat Flux 1
1 On the Physics toolbar, click Edges and choose Heat Flux.

2 Select Edges 1, 2, and 4 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type ht.

6 In the Text text field, type T_ext.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
More Operations>Mapped.

Mapped 1
1 Select Boundary 1 only.

2 In the Settings window for Mapped, click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Temperature (htsh)
The default plot is the surface plot of the temperature and the arrow plot of the conductive 
heat flux; compare with Figure 3.

1 Click the Zoom Extents button on the Graphics toolbar.

Derived Values
Follow the steps below to obtain the temperature at the benchmark verification point.

Point Evaluation 1
1 On the Results toolbar, click Point Evaluation.

2 Select Point 3 only.

3 In the Settings window for Point Evaluation, click Evaluate.

TA B L E

1 Go to the Table window.

The result shown in the Table window below the Graphics window should be 
approximately 290.4 K.
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Introduction

All integrated circuits—especially high-speed devices—produce heat. In today’s dense 
electronic system layouts heat sources are many times placed close to heat-sensitive ICs. 
Designers of printed-circuit boards often need to consider the relative placement of 
heat-sensitive and heat-producing devices, so that the sensitive ones do not overheat.

One type of heat-generating device is a voltage regulator, which can produce several watts 
of heat and reach a temperature higher than 70 °C. If the board design places such a device 
close to a surface-mounted package that contains a sensitive silicon chip, the regulator’s 
heat could cause reliability problems and failure due to overheating.

Figure 1: Layout of the simulated silicon device, its package, and a voltage regulator. The chip 
and the voltage regulator are connected through a ground plate, a pin, and the interconnect.

This simulation investigates the thermal situation for a silicon chip in a surface-mount 
package placed on a circuit board close to a hot voltage regulator. The chip is subjected to 
heat from the regulator and from internally generated heat.

Model Definition

The model is based on a SMD IC and voltage regulator layout as in Figure 1. The silicon 
chip sits in the center of the package and dissipates its heat to the surrounding 
environments. The chip also connects to a ground plane through an interconnect and one 
of the pins. A heat generating voltage regulator is placed on the same ground plane. This 

Silicon chip

Ground plate

Circuit board

Voltage regulator

Interconnect

Q
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means that the voltage regulator may affect the silicon chip by the conducted heat and this 
may lead to overheating of the chip.

Heat transfers through the mounted package to the surroundings through conduction 
according to:

The heat source, Q, is negligible in the circuit board, pins and package, while in the chip, 
this model sets that parameter to a value equivalent to 20 mW. The conductivities of the 
components are chosen to be similar to:

• silicon, for the chip

• aluminum, for the pins

• FR4, for the PC board

• copper, for the ground plane and interconnect

• an arbitrary plastic, for the chip package

Heat dissipates from all air-exposed surfaces through forced heat convection, which is 
modeled using a heat transfer coefficient, h:

The voltage regulator is simulated by setting a fixed temperature at that surface. The thin 
conducting layers of the ground plane and interconnect within the package is modeled 
using a 2D shell approximation, according to:

where ds is the layer’s thickness, and ∇t represents the nabla operator projected onto the 
direction of the plane. The model uses a Heat Transfer interface to describe the 3D heat 
transfer as well as the 2D shell heat transfer.

∇ k– ∇T( )⋅ Q=

n– q⋅ h Tinf T–( )=

∇t dsk– ∇tT( )⋅ 0=
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Results and Discussions

Figure 2 illustrates the temperature distribution through the thickness. Being a good 
conductor, the interconnect delivers heat to the outer edge of the package, which gives the 
fairly constant temperature distribution around the interconnect.

Figure 2: Slice plot of the temperature through the circuit board, interconnect, chip, and 
package. The effect of the interconnect is evident by its ability to conduct heat from the chip to 
the outer parts of the package.

An alternative view is achieved by using the transparency feature in the visualization tools 
of COMSOL Multiphysics. This results in a transparent 3D view of the temperature 
distribution, as shown in Figure 3. In that figure you can see the temperature distribution 
around the chip and along the interconnect.
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Figure 3: Boundary plot of the temperature created with the assistance of the transparency tool 
in COMSOL Multiphysics. This view also gives the temperature distribution on the chip and 
along the interconnect.
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To get a closer look at the stationary temperature of the silicon chip, plot the temperature 
at the bottom boundary of the chip.

Figure 4: Temperature distribution on the bottom surface of the silicon chip.

The simulation predicts a maximum temperature of the silicon device of 47.7 °C. This 
means that the device does not overheat in the present configuration.

Application Library path: Heat_Transfer_Module/
Power_Electronics_and_Electronic_Cooling/surface_mount_package

Notes About the COMSOL Implementation

This tutorial uses the Heat Transfer interface from the Heat Transfer Module and, in 
particular, its Thin Layer feature. These are thin layers that conduct heat well so you need 
not define them in 3D. The two layers that have this definition are:

• The interconnect between the chip and the grounded pin.

• The ground plate that is also thermally connected to the temperature constraint coming 
from the voltage regulator.
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While the numerical method considers these two modeling domains as interior 
boundaries, the model still includes a thickness to take the 3D heat flux into account.

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

The 3D workspace is now ready. While you can create the 3D geometry with the built-in 
CAD tools of COMSOL Multiphysics, it is still provided here in the form of a CAD-file 
ready to be imported.

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 From the Source list, choose COMSOL Multiphysics file.

4 Click Browse.

5 Browse to the application’s Application Libraries folder and double-click the file 
surface_mount_package.mphtxt.

6 Click Import.
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7 Click the Go to Default 3D View button on the Graphics toolbar.

The geometry in the Graphics window should now look like that in the figure below.

The imported geometry is complete. In particular, it includes the interconnect between 
the pin and the chip as well as the ground plate and the temperature surface resulting 
from the voltage regulator. To see the interconnect and the chip, you need to turn on 
transparency.
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8 Click the Transparency button on the Graphics toolbar.

9 Click the Transparency button on the Graphics toolbar again to remove the transparency.

D E F I N I T I O N S

Define a selection that contains all exterior boundaries. You will use it when defining the 
boundary conditions.

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Exterior Boundaries in the Label text field.

3 Locate the Input Entities section. Select the All domains check box.

4 Locate the Output Entities section. From the Output entities list, choose Adjacent 

boundaries.

Now, define the domain settings including material properties, element order, heat source, 
and initial values.

M A T E R I A L S

To define material properties for the model domains, use three predefined materials from 
the Material Browser and one custom material.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.
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2 Go to the Add Material window.

3 In the tree, select Built-In>Aluminum.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Aluminum (mat1)
The first material you add to a model applies to all domains by default. Keep this setting 
and use overrides for the domains of different materials.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>FR4 (Circuit Board).

3 Click Add to Component in the window toolbar.

M A T E R I A L S

FR4 (Circuit Board) (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click FR4 (Circuit 

Board) (mat2).

2 Select Domain 1 only.

Material 3 (mat3)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Plastic in the Label text field.

3 Select Domain 2 only.

Plastic (mat3)
1 In the Model Builder window, expand the Component 1 (comp1)>Materials>Plastic (mat3) 

node, then click Basic (def).

2 In the Settings window for Property Group, locate the Output Properties and Model 

Inputs section.

3 Find the Quantities subsection. In the tree, select Output Properties>Density.

4 Click Add.
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5 Find the Output properties subsection. In the table, enter the following settings:

6 Find the Quantities subsection. In the tree, select Output Properties>Heat Capacity at 

Constant Pressure.

7 Click Add.

8 Find the Output properties subsection. In the table, enter the following settings:

9 Find the Quantities subsection. In the tree, select Output Properties>Thermal 

Conductivity.

10 Click Add.

11 Find the Output properties subsection. In the table, enter the following settings:

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Silicon.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Silicon (mat4)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Silicon (mat4).

2 Select Domain 11 only.

This completes the materials settings.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Heat Source 1
1 On the Physics toolbar, click Domains and choose Heat Source.

Property Variable Expression Unit Size

Density rho 2700 kg/m³ 1x1

Property Variable Expression Unit Size

Heat capacity at constant 
pressure

Cp 900 J/(kg·K) 1x1

Property Variable Expression Unit Size

Thermal conductivity k ; kii = k, kij 
= 0

0.2 W/(m·K) 3x3
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2 Select Domain 11 only.

3 In the Settings window for Heat Source, locate the Heat Source section.

4 In the Q0 text field, type 2e8.

This completes the domain settings. Now, configure to the boundary conditions.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Exterior Boundaries.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type 50.

6 In the Text text field, type 30[degC].

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 4 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type 50[degC].

Thin Layer 1
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 Select Boundary 7 only.

3 In the Settings window for Thin Layer, locate the Thin Layer section.

4 From the Layer type list, choose Thermally thin approximation.

5 In the ds text field, type 1e-4.

6 Locate the Heat Conduction section. From the ks list, choose User defined. In the 
associated text field, type 400.

Thin Layer 2
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 Select Boundary 31 only.

3 In the Settings window for Thin Layer, locate the Thin Layer section.

4 From the Layer type list, choose Thermally thin approximation.

5 In the ds text field, type 5e-6.
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6 Locate the Heat Conduction section. From the ks list, choose User defined. In the 
associated text field, type 400.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Size.

Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 Select Boundaries 4 and 7 only.

4 Locate the Element Size section. From the Predefined list, choose Extra fine.

5 In the Model Builder window, right-click Mesh 1 and choose Free Tetrahedral.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Fine.

4 Click Build All.

The mesh should consist of around 30,000 elements.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
By default, you get surface and isosurface plots for the temperature. Note that the 
temperature is displayed in kelvin, which is the default temperature unit in the SI system.

To get a surface temperature plot in degrees Celsius, simply change the unit for the first 
default plot group.

Surface
1 In the Model Builder window, expand the Temperature (ht) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

4 On the Temperature (ht) toolbar, click Plot.
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5 Click the Go to Default 3D View button on the Graphics toolbar.

To see the chip as well, turn on transparency.

6 Click the Transparency button on the Graphics toolbar.

Compare the resulting plot to that in Figure 3.

7 Click the Transparency button on the Graphics toolbar again to remove the transparency.

Reproduce the plot in Figure 2 with the following steps.

3D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Temperature, Slices in the Label 
text field.

Slice 1
1 Right-click Temperature, Slices and choose Slice.

2 In the Settings window for Slice, locate the Expression section.

3 From the Unit list, choose degC.

4 Locate the Plane Data section. From the Plane list, choose zx-planes.

5 Locate the Coloring and Style section. From the Color table list, choose ThermalLight.

6 On the Temperature, Slices toolbar, click Plot.

Compare the result to that in Figure 2.
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To visualize the temperature distribution on the silicon chip’s bottom surface, follow the 
steps given below.

Study 1/Solution 1 (2) (sol1)
On the Results toolbar, click More Data Sets and choose Solution.

Selection
1 On the Results toolbar, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundary 137 only.

3D Plot Group 4
1 On the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Temperature, Chip Surface in the 
Label text field.

3 Locate the Data section. From the Data set list, choose Study 1/Solution 1 (2) (sol1).

4 Locate the Plot Settings section. Clear the Plot data set edges check box.

Surface 1
1 Right-click Temperature, Chip Surface and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

4 Locate the Coloring and Style section. From the Color table list, choose ThermalLight.

5 On the Temperature, Chip Surface toolbar, click Plot.

6 Click the Zoom Extents button on the Graphics toolbar.

Compare the resulting plot to that in Figure 4.
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Introduction

The drive for miniaturizing electronic devices has resulted in today’s extensive use of 
surface-mount electronic components. An important aspect in electronics design and the 
choice of materials is a product’s durability and lifetime. For surface-mount resistors and 
other components producing heat it is a well-known problem that temperature cycling can 
lead to cracks propagating through the solder joints, resulting in premature failure (Ref. 
1). For electronics in general there is a strong interest in changing the soldering material 
from lead- or tin-based solder alloys to other mixtures.

The following multiphysics example models the heat transport and structural stresses and 
deformations resulting from the temperature distribution using the Heat Transfer in Solids 
and Solid Mechanics interfaces.

Note: This application requires either the Structural Mechanics Module or the MEMS 
Module.
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Model Definition

Figure 1 shows a photograph of a surface-mount resistor together with a diagram of it on 
a printed circuit board (PCB).

Figure 1: A photo and diagram of a typical surface-mounted resistor soldered to a PCB.

Table 1 shows the dimensions of the resistor and other key components in the model 
including the PCB.

TABLE 1:  COMPONENT DIMENSIONS

COMPONENT LENGTH WIDTH HEIGHT

Resistor (Alumina) 6 mm 3 mm 0.5 mm

PCB (FR4) 16 mm 8 mm 1.6 mm

Cu pad 2 mm 3 mm 35 μm

Termination (Silver) 0.5 mm 3 mm 25 μm

Stand-off (gap to PCB) - - 105 μm

Solder

Copper pad

Termination

Resistor

Printed circuit board
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The simulation makes use of the symmetry so that it needs to include only half of the 
component (Figure 2). The modeling of the PCB is terminated a distance away from the 
resistor, in order to reduce effects of the boundary conditions.

Figure 2: The simulation models only one half of the resistor.

In operation, the resistor dissipates 0.2 W of power as heat. Conduction to the PCB and 
convection to the surrounding air provide cooling. In this model, the heat transfer occurs 
through conduction in the subdomains. The model simplifies the surface cooling and 
describes it using a heat transfer coefficient, h, in this case set to 10 W/(m2·K); the 
surrounding air temperature, Tinf, is at 300 K. The resulting heat transfer equation and 
boundary condition (included in the model using the Heat Transfer interface) are

where k is the thermal conductivity, and Q is the heating power per unit volume of the 
resistor (equal to 22.2 MW/m3 corresponding to 0.2 W in total).

The model handles thermal expansion using a static structural analysis using the Structural 
Mechanics interface (a description of the corresponding equations is available in the 
Structural Mechanics Module User’s Guide). The thermal and mechanical material 

∇ k∇T–( )⋅ Q=

n– k∇T–( )⋅ h Tinf T–( )=
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properties in this model are taken from the material library The data for the solid materials 
are temperature independent, and the reference values are shown in the table below.

Air has temperature-dependent and pressure-dependent properties in the built-in material 
library. Because the temperature is a variable of the problem, it is automatically used. The 
pressure is by default set to 1 atm.

The stresses are zero at room temperature, 293 K. The boundary condition for the Solid 
Mechanics interface is that the cuts in the PCB do not rotate and have no net force normal 
to the cut.

TABLE 2:  MATERIAL PROPERTIES

MATERIAL E (GPa) ν α (ppm) k (W/(m·K)) ρ (kg/m3) Cp (J/(kg·K))

Silver 83 0.37 18.9 420 10500 230

Alumina 300 0.222 8.0 27 3900 900

Cu 110 0.35 17 400 8700 385

Fr4 22 0.28 18 0.3 1900 1369

60Sn-40Pb 10 0.4 21 50 9000 150
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Results and Discussion

The isosurfaces in Figure 3 show the temperature distribution at steady state. The highest 
temperature occurs in the center of the resistor. The circuit board also heats up 
significantly.

Figure 3: Temperature distribution in the resistor and the circuit board at steady state.

Thermal stresses appear as a result of the temperature increase; they arise from the 
materials’ different expansion coefficients and from the bending of the PCB. Figure 4 
plots the effective stress (von Mises) together with the resulting deformation of the 
assembly.
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Figure 4: The thermally induced distribution of von Mises effective stress together with the 
deformation (magnified).

The highest stresses seem to occur in the termination material. It is interesting to compare 
these effective stresses to the yield stress and thereby investigate whether or not the 
material is irreversibly deformed. In that case the solder is the weak point. Figure 5 the 
stress in the solder alone.
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Figure 5: Close-up of the von Mises effective stresses in the solder joints.

The yield stress for solder is approximately 220 MPa. The highest effective stress appears 
to be about 60 percent of this value. The structure does not get permanently deformed 
directly when heated. However, it is possible that the solder displays creep strains over time 
because of the combination of fairly high stress levels and elevated temperatures.

Notes About the COMSOL Implementation

In this example, the Thermal Stress interface automatically adds and couples the Solid 
Mechanics interface and the Heat Transfer interface. This is done by the two predefined 
multiphysics features Thermal Expansion and Temperature Coupling.

Build the geometry as an assembly of the bottom plate and the resistor to make it possible 
to mesh the parts independently. Use continuity conditions for the temperature and the 
displacements to connect the top and bottom parts of the geometry.

It is assumed that the temperature gradient in the normal direction on the cuts in the PCB 
is zero. The mechanical boundary conditions on the cuts must not impose a general state 
of compressive stress due to thermal expansion. At the same time, the restraint from the 
part of the PCB that is not modeled means that there is no rotation of the cross section. 
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To obtain this effect, the entire cut must have the same (but unknown) displacement in 
the direction normal to the cut. 

You can achieve this by using the roller constraint at the left cut of the plate that prevents 
the boundary to move in the direction normal to the cut. For remaining two cuts, 
introduce two new degrees of freedom (named uface and vface) in the model and 
prescribe the displacements of the cut faces to them. 

You solve the problem sequentially using two stationary study steps. The heat transfer 
problem is nonlinear because the air has temperature-dependent properties. The structural 
problem, on the other hand, is linear. For the structural analysis, use a memory-efficient 
iterative solver to make it possible to solve the problem also on computers with limited 
memory. 
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Application Library path: Heat_Transfer_Module/Thermal_Stress/
surface_resistor

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Thermal Stress.

3 Click Add.

4 Click Study.
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5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Create the geometry. To simplify this step, insert a prepared 2D geometry sequence. On 
the Geometry toolbar, point to Import/Export and choose Insert Sequence. Browse to 

Name Expression Value Description

T_air 300[K] 300 K Air temperature

h_air 10[W/(m^2*K)] 10 W/(m²·K) Heat transfer coefficient

Psource 0.2[W]/2 0.1 W Heat dissipated by the 
resistor on the half 
geometry

p0 1[atm] 1.013E5 Pa Air pressure

T0 80[degC] 353.2 K Initial temperature guess
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the application’s Application Library folder and double-click the file 
surface_resistor.mph.

The 2D geometry should now look as in the figure below.

Extrude 1 (ext1)
1 On the Geometry toolbar, click Extrude.

2 Select the object wp1 only.

3 In the Settings window for Extrude, locate the Distances from Plane section.

4 In the table, enter the following settings:

5 Click Build All Objects.

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 4.

4 In the Depth text field, type 16.

Distances (mm)

1.5
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5 In the Height text field, type 1.6.

6 Locate the Position section. In the y text field, type -4.

7 In the z text field, type -1.6.

8 Click Build All Objects.

9 Click the Zoom Extents button on the Graphics toolbar.

Now, create an imprint of the resistor’s bottom boundary on the printed circuit board to 
make a pair with matching parts.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Form Union 

(fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly 
section.

3 From the Action list, choose Form an assembly.

4 Select the Create imprints check box.

5 On the Geometry toolbar, click Build All.

The completed geometry is shown in Figure 2.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>FR4 (Circuit Board).

4 Click Add to Component in the window toolbar.

M A T E R I A L S

FR4 (Circuit Board) (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click FR4 (Circuit 

Board) (mat1).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Manual.

4 Click Clear Selection.

5 Select Domain 1 only.
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A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Alumina.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Alumina (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Alumina 

(mat2).

2 Select Domain 5 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Copper.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Copper (mat3)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Copper (mat3).

2 Select Domains 2 and 7 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Material Library>Elements>Silver>Silver [solid].

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Silver [solid] (mat4)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Silver [solid] 

(mat4).

2 Select Domains 4 and 9 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Solder, 60Sn-40Pb.
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3 Click Add to Component in the window toolbar.

M A T E R I A L S

Solder, 60Sn-40Pb (mat5)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Solder, 

60Sn-40Pb (mat5).

2 Select Domains 3 and 8 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Air.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Air (mat6)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Air (mat6).

2 Select Domain 6 only.

3 On the Home toolbar, click Add Material to close the Add Material window.

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 Select Domains 1–5 and 7–9 only.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 1, 10, 13, 16, 20, 33, 37, and 40 only.

Continuity 1
1 On the Physics toolbar, in the Boundary section, click Pairs and choose Continuity.

2 In the Settings window for Continuity, locate the Pair Selection section.

3 In the Pairs list, select Identity Pair 1 (ap1).

Roller 1
1 On the Physics toolbar, click Boundaries and choose Roller.

2 Select Boundary 8 only.

Create the special boundary conditions on the cuts in the PCB by introducing new 
degrees of freedom, uface and vface, for the normal displacements.
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3 In the Model Builder window’s toolbar, click the Show button and select Advanced Physics 

Options in the menu.

Global Equations 1
1 On the Physics toolbar, click Global and choose Global Equations.

2 In the Settings window for Global Equations, locate the Global Equations section.

3 In the table, enter the following settings:

4 Locate the Units section. Find the Dependent variable quantity subsection. From the list, 
choose Displacement field (m).

Prescribed Displacement 1
1 On the Physics toolbar, click Points and choose Prescribed Displacement.

2 Select Point 1 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in z direction check box.

Prescribed Displacement 2
1 On the Physics toolbar, click Boundaries and choose Prescribed Displacement.

2 Select Boundary 2 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in y direction check box.

5 In the u0y text field, type vface.

Prescribed Displacement 3
1 On the Physics toolbar, click Boundaries and choose Prescribed Displacement.

2 Select Boundary 9 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in x direction check box.

5 In the u0x text field, type uface.

Name f(u,ut,utt,
t) (1)

Initial value 
(u_0) (1)

Initial value 
(u_t0) (1/s)

Description

uface 0 0

vface 0 0
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H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids (ht).

Fluid 1
1 On the Physics toolbar, click Domains and choose Fluid.

2 Select Domain 6 only.

Heat Source 1
1 On the Physics toolbar, click Domains and choose Heat Source.

2 Select Domain 5 only.

3 In the Settings window for Heat Source, locate the Heat Source section.

4 Click the Heat rate button.

5 In the P0 text field, type Psource.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 3, 4, 11, 14, 19, 29, 30, 44, 46, and 49–58 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type h_air.

6 In the Text text field, type T_air.

Next, add the continuity condition on the identity pair to couple the domains together.

Continuity 1
1 On the Physics toolbar, in the Boundary section, click Pairs and choose Continuity.

2 In the Settings window for Continuity, locate the Pair Selection section.

3 In the Pairs list, select Identity Pair 1 (ap1).

Because the material properties are temperature dependent, the solution converges better 
if you supply an initial guess of the temperature.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, type T0 in the T text field.
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M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
More Operations>Free Triangular.

Free Triangular 1
Select Boundaries 10, 13, 16, 20, 24, 33, 37, and 40 only.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Fine.

4 Click the Custom button.

5 Locate the Element Size Parameters section. Select the Minimum element size check box.

6 In the associated text field, type 0.1.

7 Click Build Selected.

Swept 1
1 In the Model Builder window, right-click Mesh 1 and choose Swept.

2 In the Settings window for Swept, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domains 2–9 only.

Distribution 1
1 Right-click Component 1 (comp1)>Mesh 1>Swept 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 10.

4 Click Build All.

5 In the Model Builder window, right-click Mesh 1 and choose Free Tetrahedral.

Free Tetrahedral 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Tetrahedral 1 and choose Size.

Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 Select Boundaries 5–7 only.
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4 Locate the Element Size section. From the Predefined list, choose Extra fine.

5 Click Build All.

S T U D Y  1

Because the heat transfer problem is independent of the displacements, use the first 
stationary study step to find the temperature distribution and the second stationary step 
to solve for the displacements.

Step 1: Stationary
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 In the table, clear the Solve for check box for the Solid Mechanics interface.

Stationary 2
On the Study toolbar, click Study Steps and choose Stationary>Stationary.

Step 2: Stationary 2
1 In the Settings window for Stationary, locate the Physics and Variables Selection section.

2 In the table, clear the Solve for check box for the Heat Transfer in Solids interface.

3 Click to expand the Values of dependent variables section. Locate the Values of Dependent 

Variables section. Find the Values of variables not solved for subsection. From the Settings 
list, choose User controlled.

4 From the Method list, choose Solution.
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5 From the Study list, choose Study 1, Stationary.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 1 node.

4 Right-click Direct and choose Enable.

Set up an iterative solver that can significantly save on the memory needed for the 
computations.

5 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1) click 
Stationary Solver 2.

6 In the Settings window for Stationary Solver, locate the General section.

7 From the Linearity list, choose Linear.

8 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 2 node.

9 Right-click Study 1>Solver Configurations>Solution 1 (sol1)>Stationary Solver 2 and 
choose Iterative.

10 In the Settings window for Iterative, click to expand the Error section.

11 In the Factor in error estimate text field, type 2000.

12 Right-click Study 1>Solver Configurations>Solution 1 (sol1)>Stationary Solver 2>Iterative 

1 and choose Multigrid.

13 On the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
The first plot shows the effective stress together with the resulting deformation. Modify it 
to reproduce Figure 4.

1 In the Model Builder window, expand the Stress (solid) node.

Deformation
1 In the Model Builder window, expand the Results>Stress (solid)>Surface 1 node, then 

click Deformation.

2 In the Settings window for Deformation, locate the Expression section.

3 In the Y component text field, type v-vface.
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4 On the Stress (solid) toolbar, click Plot.

Stress (solid)
Hold down the left mouse button and drag in the Graphics window to rotate the geometry 
so that you see the opposite side of the resistor, which is where the largest stresses occur. 
Similarly, use the right mouse button to translate the geometry and the middle button to 
zoom.

Now, study the stresses in the solder.

Study 1/Solution 1 (3) (sol1)
On the Results toolbar, click More Data Sets and choose Solution.

Selection
1 On the Results toolbar, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domain 3 only.

3D Plot Group 4
1 On the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Stress in Solder Joint in the Label 
text field.

3 Locate the Data section. From the Data set list, choose Study 1/Solution 1 (3) (sol1).

4 Locate the Plot Settings section. Clear the Plot data set edges check box.

Volume 1
1 Right-click Stress in Solder Joint and choose Volume.

2 In the Settings window for Volume, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>Stress>

solid.mises - von Mises stress.

3 Locate the Expression section. From the Unit list, choose MPa.

4 On the Stress in Solder Joint toolbar, click Plot.

5 Click the Go to YZ View button on the Graphics toolbar.

Compare the resulting plot with that in Figure 5.

Temperature (ht)
The second default plot group shows the temperature on the modeled geometry’s surface.
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1 Click the Go to Default 3D View button on the Graphics toolbar.

Isothermal Contours (ht)
The third default plot shows the isosurfaces (Figure 3).
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Introduction

The European standard EN ISO 10211:2007 for thermal bridges in building 
constructions provides four test cases—two 2D and two 3D—for validating a numerical 
method (Ref. 1). If the values obtained by a method conform to the results of all these 
four cases, the method is classified as a three-dimensional steady-state high precision 
method.

COMSOL Multiphysics successfully passes all the test cases described by the standard. This 
document presents an implementation of the second 3D model (Case 4).

This tutorial studies the heat conduction in a thermal bridge made up of an iron bar and 
an insulation layer that separates a hot internal side from a cold external side. The iron bar 
is embedded in the insulation layer as shown in Figure 1. After solving the model, the heat 
flux between the internal and external sides and the maximum temperature on the external 
wall are calculated, and the results are compared to the expected values.

Figure 1: Back side (left) and front side (right) views of the iron bar embedded in an 
insulation layer, ISO 10211:2007 test case 4. Colored regions correspond to internal and 
external boundaries.

Model Definition

The geometry is illustrated above in Figure 1. The square insulation layer, with a low 
thermal conductivity k of 0.1 W/(m·K), has a cold and a hot surface. The iron bar has a 
higher thermal conductivity, 50  W/(m·K). Its boundaries are mainly located in the hot 
environment but one of them reaches the cold side.

Cold and hot surfaces are subject to convective heat flux. The ISO 10211:2007 standard 
specifies the values of the thermal resistance, R, which is related to the heat transfer 
coefficient, h, according to

Cold surface Hot surface

Insulation layer Iron bar
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Notes About the COMSOL Implementation

Compared to the rest of the structure, the dimensions of the intersection between the iron 
bar and the insulation layer are relatively small but the temperature gradients are large. 
Therefore, the element size is reduced in this area to give sufficient accuracy. To save 
computational time, this refinement is not applied on the remaining mesh.

Results and Discussion

In Figure 2, the temperature profile shows the effects of the thermal bridge where the heat 
variations are most pronounced.

Figure 2: Temperature distribution of ISO 10211:2007 test case 4.

h 1
R
----=
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Table 1 compares the numerical results of COMSOL Multiphysics with the expected 
values provided by EN ISO 10211:2007 (Ref. 1).

The maximum permissible differences to pass this test case are 5·10-3 °C for temperature 
and 1% for heat flux. The measured values are completely coherent and meet the validation 
criteria.

Reference

1. European Committee for Standardization, EN ISO 10211, Thermal bridges in 
building construction – Heat flows and surface temperatures – Detailed calculations 
(ISO 10211:2007), Appendix A, pp. 30–36, 2007.

Application Library path: Heat_Transfer_Module/
Buildings_and_Constructions/thermal_bridge_3d_iron_bar

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

TABLE 1:  COMPARISON BETWEEN EXPECTED VALUES AND COMPUTED VALUES

MEASURED QUANTITY EXPECTED 
VALUE

COMPUTED 
VALUE

DIFFERENCE

Highest temperature on external side 0.805 °C 0.8015 °C 4.3·10-3 °C

Heat flux 0.540 W 0.5415 W 0.28%
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G L O B A L  D E F I N I T I O N S

Define the geometrical parameters.

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type w1.

4 In the Depth text field, type d1.

5 In the Height text field, type h1.

6 Right-click Block 1 (blk1) and choose Build Selected.

Create the iron bar at the center of the insulation layer.

Block 2 (blk2)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type w2.

4 In the Depth text field, type d2.

5 In the Height text field, type h2.

6 Locate the Position section. In the x text field, type w1/2-w2/2.

7 In the z text field, type h1/2-h2/2.

Name Expression Value Description

w1 1[m] 1 m Insulation layer width

d1 0.2[m] 0.2 m Insulation layer depth

h1 1[m] 1 m Insulation layer height

w2 0.1[m] 0.1 m Iron bar width

d2 0.6[m] 0.6 m Iron bar depth

h2 50[mm] 0.05 m Iron bar height
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8 Right-click Block 2 (blk2) and choose Build Selected.

9 Click the Wireframe Rendering button on the Graphics toolbar to get a better view of the 
interior parts.

To remove an unnecessary internal boundary proceed as follows.

Ignore Faces 1 (igf1)
1 On the Geometry toolbar, click Virtual Operations and choose Ignore Faces.

2 On the object fin, select Boundary 11 only.

Note that you can create the selection by clicking the Paste Selection button and typing 
the indices in the dialog box that opens.

3 Right-click Ignore Faces 1 (igf1) and choose Build Selected.

4 Click the Zoom Extents button on the Graphics toolbar.

D E F I N I T I O N S

Create a set of selections for use when setting up the physics. First, select the boundaries 
inside the region y ≥ 0.1.

Box 1
1 On the Definitions toolbar, click Box.

2 In the Settings window for Box, type Internal in the Label text field.
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3 Locate the Geometric Entity Level section. From the Level list, choose Boundary.

4 Locate the Box Limits section. In the y minimum text field, type 0.1.

5 Locate the Output Entities section. From the Include entity if list, choose Entity inside 

box.

Next, select all boundaries inside the region y ≤ 0.1.

Box 2
1 On the Definitions toolbar, click Box.

2 In the Settings window for Box, type External in the Label text field.

3 Locate the Geometric Entity Level section. From the Level list, choose Boundary.

4 Locate the Box Limits section. In the y maximum text field, type 0.1.

5 Locate the Output Entities section. From the Include entity if list, choose Entity inside 

box.

6 Click the Wireframe Rendering button on the Graphics toolbar.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, type Insulation in the Label text field.

2 Select Domain 1 only.

3 Locate the Material Contents section. In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Iron in the Label text field.

3 Select Domain 2 only.

Property Name Value Unit Property 
group

Thermal conductivity k 0.1 W/(m·K) Basic

Density rho 500 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 1700 J/(kg·K) Basic
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4 Locate the Material Contents section. In the table, enter the following settings:

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Internal.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type 1/0.10.

6 In the Text text field, type 1[degC].

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose External.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type 1/0.10.

6 In the Text text field, type 0[degC].

M E S H  1

Because the greatest variations of temperature are expected at the iron bar’s external 
boundary, refine the mesh in this region. Use default settings in the remaining domains.

1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Tetrahedral.

Free Tetrahedral 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Tetrahedral 1 and choose Size.

Property Name Value Unit Property 
group

Thermal conductivity k 50 W/(m·K) Basic

Density rho 7800 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 460 J/(kg·K) Basic
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Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Domain.

3 Select Domain 2 only.

4 Locate the Element Size section. From the Predefined list, choose Extremely fine.

5 Click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
The first default plot group shows the temperature distribution; compare with Figure 2.

1 Click the Zoom Extents button on the Graphics toolbar.

Derived Values
Follow the steps below to calculate the maximum temperature on the external surface and 
the heat flux between the internal and external sides. Compare the values with the 
expected results listed in Table 1.

Surface Maximum 1
1 On the Results toolbar, click More Derived Values and choose Maximum>Surface 

Maximum.

2 In the Settings window for Surface Maximum, locate the Selection section.

3 From the Selection list, choose External.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

TA B L E

1 Go to the Table window.

The displayed value should be close to 0.805 °C.

Expression Unit Description

T degC Temperature
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R E S U L T S

Surface Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 In the Settings window for Surface Integration, locate the Selection section.

3 From the Selection list, choose External.

4 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Heat Transfer in Solids>Boundary fluxes>ht.q0 - 

Inward heat flux.

5 Click Evaluate.

TA B L E

1 Go to the Table window.

The measured flux should be close to 0.540 W.
10 |  T H E R M A L  B R I D G E S  I N  B U I L D I N G  C O N S T R U C T I O N — 3 D  I R O N  B A R  T H R O U G H  



Created in COMSOL Multiphysics 5.2a
Th e rma l  B r i d g e s  i n  Bu i l d i n g  Con s t r u c t i o n—3D
S t r u c t u r e  B e twe en Two F l o o r s
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


Introduction

The European standard EN ISO 10211:2007 for thermal bridges in building 
constructions provides four test cases—two 2D and two 3D—for validating a numerical 
method (Ref. 1). If the values obtained by a method conform to the results of all these 
four cases, the method is classified as a three-dimensional steady-state high precision 
method.

COMSOL Multiphysics successfully passes all the test cases described by the standard and 
is hence classified as a three-dimensional steady-state high precision method. This 
document presents an implementation of the first 3D model (Case 3).

Figure 1: Geometry and boundary conditions of ISO 10211:2007 test case 3.

This tutorial studies the heat conduction in a building structure separating two floors from 
the external environment. The structure’s surfaces are divided into four parts:

• the lower level, α;

• the upper level, β;

• the outside, γ;

• and the remaining thermally insulated surfaces, δ.

The values of interest for validation are the lowest temperatures at surfaces α and β, and 
the heat fluxes through α, β, and γ.

External surface γ

Internal surface α

Internal surface β

Thermally insulated surface δ
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Model Definition

Figure 1 illustrates the geometry. The external surface is at 0 °C and the interior surface is 
at 20 °C. Four materials with distinct thermal conductivities k are used in the structure. 
The horizontal block separating the two floors has the highest thermal conductivity 
(2.5 W/(m·K)). It crosses the wall, thereby creating a thermal bridge in the structure.

The surfaces α, β, and γ are subject to convective heat flux. The ISO 10211:2007 standard 
specifies the values of the thermal resistance, R, which is related to the heat transfer 
coefficient, h, according to

Results and Discussion

Figure 2 shows the temperature profile. The heat losses are greater near the thermal bridge 
formed by the horizontal block that crosses the wall.

Figure 2: Temperature distribution of ISO 10211:2007 test case 3.

h 1
R
----=
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The numerical results of COMSOL Multiphysics are compared with the expected values 
provided by ISO 10211:2007 (Ref. 1) in Table 1.

The maximum permissible differences to pass this test case are 0.1 °C for temperature and 
1% for heat flux. The measured values are completely consistent and meet the validation 
criteria.

As shown in Figure 3 and Figure 4, the minimum temperature of the surfaces α and β are 
located at their respective corners.

Figure 3: Minimum and maximum temperatures on surface α, ISO 10211:2007 test case 3.

TABLE 1:  COMPARISON BETWEEN EXPECTED VALUES AND COMPUTED VALUES

MEASURED QUANTITY EXPECTED VALUES COMPUTED VALUES DIFFERENCE

Minimum temperature on α 11.32 °C 11.318 °C 0.002 °C

Minimum temperature on β 11.11 °C 11.107 °C 0.003 °C

Heat flux through α 46.09 W 46.196 W 0.23%

Heat flux through β 13.89 W 13.92 W 0.22%

Heat flux through γ 59.98 W 60.116 W 0.23%
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Figure 4: Minimum and maximum temperatures on surface β, ISO 10211:2007 test case 3.

Reference

1. European Committee for Standardization, EN ISO 10211, Thermal bridges in 
building construction – Heat flows and surface temperatures – Detailed calculations 
(ISO 10211:2007), Appendix A, pp. 30–36, 2007.

Application Library path: Heat_Transfer_Module/
Buildings_and_Constructions/thermal_bridge_3d_two_floors

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Define the geometrical parameters.

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

wall_t1 5[cm] 0.05 m Insulation layer thickness

wall_t2 30[cm] 0.3 m Wall thickness

rect1 1.2[m] 1.2 m Wall first rectangle basis

rect2 1.3[m] 1.3 m Wall second rectangle basis

rect_shift -10[cm] -0.1 m Shift for the rectangles

wall_h 2.15[m] 2.15 m Wall height

blk_w 1.15[m] 1.15 m Rectangle horizontal block 
width

blk_d 1.9[m] 1.9 m Rectangle horizontal block 
depth

blk_h 0.15[m] 0.15 m Rectangle horizontal block 
height

blk_shiftx 5[cm] 0.05 m Rectangle horizontal block 
x-shift

blk_shifty -0.7[m] -0.7 m Rectangle horizontal block 
y-shift

blk_shiftz 1[m] 1 m Rectangle horizontal block 
z-shift

sq_l 1[m] 1 m Square horizontal block side 
length
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G E O M E T R Y  1

To build the walls separating the external and internal surfaces, create the cross section 
geometry and extrude it.

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, click Show Work Plane.

Plane Geometry
The first two rectangles below correspond to the insulation layer of the wall.

Rectangle 1 (r1)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type rect1.

4 In the Height text field, type wall_t1.

5 Right-click Rectangle 1 (r1) and choose Build Selected.

Rectangle 2 (r2)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type wall_t1.

4 In the Height text field, type rect1.

5 Right-click Rectangle 2 (r2) and choose Build Selected.

6 Click the Zoom Extents button on the Graphics toolbar.

Union 1 (uni1)
1 On the Work Plane toolbar, click Booleans and Partitions and choose Union.

2 Click in the Graphics window and then press Ctrl+A to select both objects.

3 In the Settings window for Union, locate the Union section.

4 Clear the Keep interior boundaries check box.

sq_h 5[cm] 0.05 m Square horizontal block height

sq_shift 0.2[m] 0.2 m Square horizontal block shift

Name Expression Value Description
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5 Right-click Union 1 (uni1) and choose Build Selected.

Plane Geometry
Build the remaining layers of the walls in a similar manner.

Rectangle 3 (r3)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type rect2.

4 In the Height text field, type wall_t2.

5 Locate the Position section. In the xw text field, type rect_shift.

6 In the yw text field, type rect_shift.

7 Right-click Rectangle 3 (r3) and choose Build Selected.

Rectangle 4 (r4)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type wall_t2.

4 In the Height text field, type rect2.

5 Locate the Position section. In the xw text field, type rect_shift.
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6 In the yw text field, type rect_shift.

7 Right-click Rectangle 4 (r4) and choose Build Selected.

Union 2 (uni2)
1 On the Work Plane toolbar, click Booleans and Partitions and choose Union.

2 Select the objects r4 and r3 only.

3 In the Settings window for Union, locate the Union section.

4 Clear the Keep interior boundaries check box.

5 Right-click Union 2 (uni2) and choose Build Selected.

6 In the Model Builder window, click Geometry 1.

Extrude 1 (ext1)
1 On the Geometry toolbar, click Extrude.

2 In the Settings window for Extrude, locate the Distances from Plane section.

3 In the table, enter the following settings:

4 Right-click Extrude 1 (ext1) and choose Build Selected.

Distances (m)

wall_h
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5 Click the Zoom Extents button on the Graphics toolbar.

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

This block separates the two floors of the structure.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type blk_w.

4 In the Depth text field, type blk_d.

5 In the Height text field, type blk_h.

6 Locate the Position section. In the x text field, type blk_shiftx.

7 In the y text field, type blk_shifty.

8 In the z text field, type blk_shiftz.

9 Right-click Block 1 (blk1) and choose Build Selected.

To remove unnecessary edges, you need to remove the parts of the walls that intersect 
this block. To do so, use the boolean operation Difference to subtract a copy of the block 
from the walls. Begin by creating the copy.

10 Right-click Block 1 (blk1) and choose Duplicate.
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Difference 1 (dif1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Difference.

2 Select the object ext1 only.

The object labeled ext1 is made up of the walls previously obtained by extrusion.

3 In the Settings window for Difference, locate the Difference section.

4 Find the Objects to subtract subsection. Select the Active toggle button.

5 Select the object blk1 only.

Block 3 (blk3)
1 Right-click Difference 1 (dif1) and choose Build Selected.

2 On the Geometry toolbar, click Block.

This block corresponds to the floor of the inside upper level.

3 In the Settings window for Block, locate the Size and Shape section.

4 In the Width text field, type sq_l.

5 In the Depth text field, type sq_l.

6 In the Height text field, type sq_h.

7 Locate the Position section. In the x text field, type sq_shift.

8 In the y text field, type sq_shift.

9 In the z text field, type blk_shiftz+blk_h.

Ignore Edges 1 (ige1)
1 Right-click Block 3 (blk3) and choose Build Selected.

2 On the Geometry toolbar, click Virtual Operations and choose Ignore Edges.

In the first steps of the geometry sequence, six unused vertical edges were created on 
the walls. They are responsible for unnecessary constraints on the mesh and they 
generate extra boundaries by splitting some faces. For these reasons, follow the 
instructions below to remove them.

3 On the object fin, select Edges 6, 17, 33, 38, 60, and 63 only.

To reach the edges, click the Wireframe Rendering button on the Graphics toolbar. Note 
that you can make the selection by clicking the Paste Selection button and typing the 
indices in the dialog box that opens.
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4 Right-click Ignore Edges 1 (ige1) and choose Build Selected.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, type Interior Wall in the Label text field.

2 Select Domains 4 and 5 only.

3 Locate the Material Contents section. In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Isolation in the Label text field.

Property Name Value Unit Property 
group

Thermal conductivity k 0.7 W/(m·K) Basic

Density rho 1700 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 800 J/(kg·K) Basic
12 |  T H E R M A L  B R I D G E S  I N  B U I L D I N G  C O N S T R U C T I O N — 3 D  S T R U C T U R E  B E T W E E N  



3 Select Domain 2 only.

4 Locate the Material Contents section. In the table, enter the following settings:

Material 3 (mat3)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Exterior Wall in the Label text field.

3 Select Domain 1 only.

4 Locate the Material Contents section. In the table, enter the following settings:

Material 4 (mat4)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Horizontal Structure in the Label text 
field.

3 Select Domain 3 only.

4 Locate the Material Contents section. In the table, enter the following settings:

Property Name Value Unit Property 
group

Thermal conductivity k 0.04 W/(m·K) Basic

Density rho 200 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 1000 J/(kg·K) Basic

Property Name Value Unit Property 
group

Thermal conductivity k 1 W/(m·K) Basic

Density rho 2000 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 1000 J/(kg·K) Basic

Property Name Value Unit Property 
group

Thermal conductivity k 2.5 W/(m·K) Basic

Density rho 5000 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 600 J/(kg·K) Basic
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Material 5 (mat5)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Floor in the Label text field.

3 Select Domain 6 only.

4 Locate the Material Contents section. In the table, enter the following settings:

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 33–35 only.

3 In the Settings window for Heat Flux, locate the Boundary Selection section.

4 Click Create Selection.

5 In the Create Selection dialog box, type alpha in the Selection name text field.

6 Click OK.

7 In the Settings window for Heat Flux, locate the Heat Flux section.

8 Click the Convective heat flux button.

9 In the h text field, type 1/0.2.

10 In the Text text field, type 20[degC].

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 39–41 only.

3 In the Settings window for Heat Flux, locate the Boundary Selection section.

4 Click Create Selection.

5 In the Create Selection dialog box, type beta in the Selection name text field.

6 Click OK.

7 In the Settings window for Heat Flux, locate the Heat Flux section.

Property Name Value Unit Property 
group

Thermal conductivity k 1 W/(m·K) Basic

Density rho 1000 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 800 J/(kg·K) Basic
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8 Click the Convective heat flux button.

9 In the h text field, type 1/0.2.

10 In the Text text field, type 15[degC].

Heat Flux 3
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 1, 2, and 11–14 only.

3 In the Settings window for Heat Flux, locate the Boundary Selection section.

4 Click Create Selection.

5 In the Create Selection dialog box, type gamma in the Selection name text field.

6 Click OK.

7 In the Settings window for Heat Flux, locate the Heat Flux section.

8 Click the Convective heat flux button.

9 In the h text field, type 1/0.05.

10 In the Text text field, type 0[degC].

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
The first default plot group shows the temperature distribution.

Surface
1 In the Model Builder window, expand the Temperature (ht) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

4 On the Temperature (ht) toolbar, click Plot.

Derived Values
Follow the steps below to find the minimum temperatures of α and β as well as the heat 
flux of α, β, and γ.

Surface Minimum 1
1 On the Results toolbar, click More Derived Values and choose Minimum>Surface Minimum.

2 In the Settings window for Surface Minimum, locate the Selection section.
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3 From the Selection list, choose alpha.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Derived Values
The displayed value should be close to 11.32 °C.

Surface Minimum 2
1 On the Results toolbar, click More Derived Values and choose Minimum>Surface Minimum.

2 In the Settings window for Surface Minimum, locate the Selection section.

3 From the Selection list, choose beta.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Derived Values
The displayed value should be close to 11.11 °C.

Surface Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 In the Settings window for Surface Integration, locate the Selection section.

3 From the Selection list, choose alpha.

4 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Heat Transfer in Solids>Boundary fluxes>ht.q0 - 

Inward heat flux.

5 Click Evaluate.

Derived Values
The displayed value should be close to 46.09 W.

Expression Unit Description

T degC Temperature

Expression Unit Description

T degC Temperature
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Surface Integration 2
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 In the Settings window for Surface Integration, locate the Selection section.

3 From the Selection list, choose beta.

4 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Heat Transfer in Solids>Boundary fluxes>ht.q0 - 

Inward heat flux.

5 Click Evaluate.

Derived Values
The displayed value should be close to 13.89 W.

Surface Integration 3
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 In the Settings window for Surface Integration, locate the Selection section.

3 From the Selection list, choose gamma.

4 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Model>Component 1>Heat Transfer in Solids>Boundary fluxes>ht.q0 - 

Inward heat flux.

5 Click Evaluate.

TA B L E

1 Go to the Table window.

The displayed value should be close to 59.98 W.

R E S U L T S

Temperature (ht)
To plot the location of the minimum temperature on α, follow the instructions below.

Study 1/Solution 1 (sol1)
1 In the Model Builder window, expand the Results>Data Sets node.

2 Right-click Study 1/Solution 1 (sol1) and choose Duplicate.

Selection
1 On the Results toolbar, click Selection.
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2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose alpha.

The resulting data set is restricted to the surfaces α.

3D Plot Group 3
1 On the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Minimum Temperature on Alpha in 
the Label text field.

3 Locate the Data section. From the Data set list, choose Study 1/Solution 1 (2) (sol1).

Surface 1
1 Right-click Minimum Temperature on Alpha and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

4 Locate the Coloring and Style section. From the Color table list, choose ThermalLight.

Minimum Temperature on Alpha
In the Model Builder window, under Results click Minimum Temperature on Alpha.

Max/Min Surface 1
1 On the Minimum Temperature on Alpha toolbar, click More Plots and choose Max/Min 

Surface.

2 In the Settings window for Max/Min Surface, locate the Expression section.

3 From the Unit list, choose degC.

4 On the Minimum Temperature on Alpha toolbar, click Plot.

TA B L E

1 Go to the Table window.

As shown in Figure 3, the minimum temperature is at the corner of α.

R E S U L T S

Study 1/Solution 1 (2) (sol1)
Now plot the location of the minimum temperature on β.

1 In the Model Builder window, under Results>Data Sets right-click Study 1/Solution 1 (2) 

(sol1) and choose Duplicate.
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Selection
1 In the Model Builder window, expand the Study 1/Solution 1 (3) (sol1) node, then click 

Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Selection list, choose beta.

The resulting data set is restricted to the surfaces β.

Minimum Temperature on Alpha
In the Model Builder window, under Results right-click Minimum Temperature on Alpha and 
choose Duplicate.

Minimum Temperature on Alpha 1
1 In the Settings window for 3D Plot Group, type Minimum Temperature on Beta in 

the Label text field.

2 Locate the Data section. From the Data set list, choose Study 1/Solution 1 (3) (sol1).

3 On the Minimum Temperature on Beta toolbar, click Plot.
19 |  T H E R M A L  B R I D G E S  I N  B U I L D I N G  C O N S T R U C T I O N — 3 D  S T R U C T U R E  B E T W E E N



20 |  T H E R M A L  B R I D G E S  I N  B U I L D I N G  C O N S T R U C T I O N — 3 D  S T R U C T U R E  B E T W E E N  



Created in COMSOL Multiphysics 5.2a
Th e rmoe l e c t r i c  L e g
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


Introduction

A thermocouple is made of two different conductors (legs) in contact with each other at 
one point (junction). When a temperature difference is established between the two legs, 
then a voltage is established across the junction. Therefore a thermocouple properly 
calibrated is a temperature sensor and can convert temperature gradients into electric 
currents. In this validation example, we verify the response of one leg when a current is 
passed through the device. A cooling effect, known as the Peltier effect, is expected.

Model Definition

The component is 1-by-1-by-6 mm, as shown in Figure 1. The core of the device, the 
thermoelectric part, is made of bismuth telluride (Bi2Te3). It is capped by two thin copper 
electrodes, 0.1 mm thick.

Figure 1: Thermoelectric leg geometry.

The material properties are available in COMSOL Multiphysics Material Library. 
However, since the properties for bismuth telluride slightly differ from these from the 
original benchmark, values from Ref. 1 are used in this application. 

Copper

Copper

Bismuth telluride
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TABLE 1:  MATERIAL PROPERTIES FOR BISMUTH TELLURIDE

In addition Seebeck coefficient for copper, 6.5·10-6 V/K, is also taken from Ref. 1. 

The bottom electrode surface is held at 0 °C while the top electrode and the lateral 
surfaces are thermally insulated.

The bottom electrode is electrically grounded at 0 V. The total inward electric current 
through the top electrode is 0.7 A. The lateral surfaces are electrically insulated.

Results and Discussion

The current circulating in the thermoelectric device is responsible for the cooling effect 
shown in Figure 2. The temperature field is in complete agreement with the results from 
Ref. 1.

Property Value

Thermal conductivity 1.6 W/(m·K)

Density 7740 kg/m³

Heat capacity at constant pressure 154.4 J/(kg·K)

Electrical conductivity 1.1e5 S/m

Relative permittivity 1

Seebeck coefficient 2e-4 V/K
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Figure 2: Temperature field on the thermoelectric leg surface.

Figure 3 shows the isothermal surfaces and the heat flux which is in the same direction as 
the electric current (from the top to the bottom).
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Figure 3: Isothermal surfaces in the thermoelectric leg.

The top level electrode reaches an electric potential of around 49.1 mV due to the inward 
current density set on this boundary. This corresponds to the value presented in Ref. 1.
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Figure 4: Electric potential in the thermoelectric leg.

Reference

1. M. Jaegle, Multiphysics Simulation of Thermoelectric Systems, “Modeling of 
Peltier-Cooling and Thermoelectric Generation,” Proc. COMSOL Conf. 2008 Hanover, 
2008.

Application Library path: Heat_Transfer_Module/Verification_Examples/
thermoelectric_leg

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Thermoelectric Effect.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Height text field, type 6.

4 Click to expand the Layers section. In the table, enter the following settings:

5 Find the Layer position subsection. Select the Top check box.

6 Click Build All Objects.

7 Click the Zoom Extents button on the Graphics toolbar.

Now define the parameters that will be used for the model. The inward current density, 
J0, corresponds to a total current of 0.7 A through a 1x1 mm square.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

Layer name Thickness (mm)

Layer 1 0.1
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3 In the table, enter the following settings:

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, type Bismuth Telluride - Bi2Te3 in the Label 

text field.

2 Locate the Material Contents section. In the table, enter the following settings:

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Copper.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Copper (mat2)
1 On the Home toolbar, click Add Material to close the Add Material window.

2 In the Model Builder window, under Component 1 (comp1)>Materials click Copper (mat2).

3 Select Domains 1 and 3 only.

Name Expression Value Description

T0 0[degC] 273.15 K Temperature reference

J0 0.7[A]/(1[mm])^2 7E5 A/m² Inward current density

Property Name Value Unit Property 
group

Thermal conductivity k 1.6 W/(m·K) Basic

Density rho 7740 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 154.4 J/(kg·K) Basic

Electrical conductivity sigma 1.1e5 S/m Basic

Relative permittivity epsilonr 1 1 Basic

Seebeck coefficient S 2e-4 V/K Basic
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4 In the Settings window for Material, locate the Material Contents section.

5 In the table, enter the following settings:

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Click the Wireframe Rendering button on the Graphics toolbar.

3 Select Boundary 3 only.

4 In the Settings window for Temperature, locate the Temperature section.

5 In the T0 text field, type T0.

E L E C T R I C  C U R R E N T S  ( E C )

In the Model Builder window, under Component 1 (comp1) click Electric Currents (ec).

Ground 1
1 On the Physics toolbar, click Boundaries and choose Ground.

2 Select Boundary 3 only.

Normal Current Density 1
1 On the Physics toolbar, click Boundaries and choose Normal Current Density.

2 Select Boundary 10 only.

3 In the Settings window for Normal Current Density, locate the Normal Current Density 
section.

4 In the Jn text field, type J0.

Due to the geometrical properties, replacing the default tetrahedral mesh by a hexahedral 
sweep mesh is more suited.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Swept.

Swept 1
1 In the Settings window for Swept, click to expand the Source faces section.

Property Name Value Unit Property 
group

Seebeck coefficient S 6.5e-6 V/K Basic
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2 Select Boundary 10 only.

Now visualize the mesh and compare it with the figure below.

3 Click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
The first default plot shows the temperature field; compare with Figure 2.

Surface
1 In the Model Builder window, expand the Temperature (ht) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

4 On the Temperature (ht) toolbar, click Plot.

Isothermal Contours (ht)
The second default plot, corresponding to Figure 3, shows the isothermal surfaces.
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Isosurface
1 In the Model Builder window, expand the Isothermal Contours (ht) node, then click 

Isosurface.

2 In the Settings window for Isosurface, locate the Expression section.

3 From the Unit list, choose degC.

4 On the Isothermal Contours (ht) toolbar, click Plot.

Electric Potential (ec)
The third default plot group shows the electric potential distribution as in Figure 4.
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Introduction

This example demonstrates how to model phase transition by a moving boundary interface 
according to the Stefan problem. It is adapted from the benchmark study in Ref. 1.

A square cavity containing both solid and liquid tin is submitted to a temperature 
difference between left and right boundaries. Fluid and solid parts are solved in separate 
domains sharing a moving melting front (see Figure 1). The position of this boundary 
through time is calculated according to the Stefan energy balance condition.

Figure 1: Square cavity with moving phase interface

In the melt, motion generated by natural convection is expected due to the temperature 
gradient. This motion, in turn, influences the front displacement.

Model Definition

The geometry presented in Figure 2 shows a square of side length 10 cm filled with pure 
tin. The left and right boundaries are maintained at 508 K and 503 K, respectively. 

Liquid

Liquid

Solid

Solid

Convection
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Because the fusion temperature of pure tin is 505 K, both liquid and solid phases co-exist 
in the square.

Figure 2: Geometry and boundary conditions at starting time.

The initial temperature distribution is assumed to vary linearly in the horizontal direction 
as shown in Figure 3.

Figure 3: Initial temperature profile.

SolidLiquid

Thermal insulation

Thermal insulation

Hot temperature 
(508 K)

Cold temperature 
(503 K)

Fusion temperature 
(505 K)
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The melting front is the vertical line located at x = 6 cm where the temperature is 505 K.

The liquid part on the left is governed by the Navier-Stokes equations in the Boussinesq 
approximation as described in Gravity and The Boussinesq Approximation sections in the 
CFD Module User’s Guide, with Tref = Tf the fusion temperature of tin. The reduced 
pressure formulation is used to enhance the accuracy of the buoyancy forces since they are 
relatively small compared to the other terms in the momentum balance.

As the metal melts, the solid-liquid interface moves toward the solid side. The energy 
balance at this front is expressed by

 (1)

where ΔH is the latent heat of fusion, equal to 60 kJ/kg, v (m/s) is the front velocity 
vector, n is the normal vector at the front, and Φl and Φs (W/m2) are the heat fluxes 
coming from the liquid and solid sides, respectively (see Figure 4).

Figure 4: Heat fluxes at the melting front

Table 1 reviews the material properties of tin (Ref. 2) used in this model.

TABLE 1:  MATERIAL PROPERTIES OF TIN

PARAMETER DESCRIPTION VALUE

ρ0 Density 7500 kg/m3

Cp Heat capacity 200 J/(kg·K)

k Thermal conductivity 60 W/(m·K)

αp Coefficient of thermal expansion 2.67·10-4 K-1

ν Kinematic viscosity 8.0·10-7 m2/s

ρ0ΔHv n⋅ Φl Φs–( ) n⋅=

Liquid Solid

Melting front

Φl

Φs

ΔH
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Results and Discussion

Figure 5 shows the velocity profile in the fluid domain. The convective cell due to 
buoyancy increases the melting speed at the upper part of the cavity.

Figure 5: Velocity profile in the fluid at the end of the simulation.

At the end of the simulation, the melting front does not move anymore because balance 
between left and right adjacent fluxes has been reached.

Tf Fusion temperature 505 K

ΔH Latent heat of fusion 60 kJ/kg

TABLE 1:  MATERIAL PROPERTIES OF TIN

PARAMETER DESCRIPTION VALUE
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In Figure 6, the temperature profile is represented jointly by a heat flux arrow plot.

Figure 6: Temperature profile at the end of the simulation.

Notes About the COMSOL Implementation

The quantities Φl and Φs, illustrated in Figure 4, can be computed using the up and down 
operators. The components of Φl − Φs would then be given by 
up(ht.tfluxx)-down(ht.tfluxx) and up(ht.tfluxy)-down(ht.tfluxy). However, 
this method evaluates the temperature gradient which may lead to imprecisions due to the 
mesh discretization. Instead, the quantity (Φl − Φs) ⋅ n, involved in Equation 1, is more 
precisely evaluated through the Lagrange multiplier for temperature, T_lm. This variable 
is available when weak constraints are enabled in the region of interest, as it is the case here 
with the fixed temperature constraint at the melting front. For more information about 
weak constraints, refer to the section Weak Constraint in the COMSOL Multiphysics 
Reference Manual.

To handle the melting front movement, a mesh deformation is necessary. During such a 
transformation, matter from solid tin is removed while the same amount of liquid tin is 
added to the fluid. The appropriate tool for deforming the mesh without reflecting any 
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expansion or contraction effects to the material properties is the Deformed Geometry 
interface.

References

1. F. Wolff and R. Viskanta, “Solidification of a Pure Metal at a Vertical Wall in the 
Presence of Liquid Superheat,” Int.J. Heat and Mass Transfer, vol. 31, no. 8, pp. 1735–
1744, 1988.

2. V. Alexiades, N. Hannoun, and T.Z. Mai, “Tin Melting: Effect of Grid Size and Scheme 
on the Numerical Solution,” Proc. 5th Mississippi State Conf. Differential Equations 
and Computational Simulations, pp. 55–69, 2003.

Application Library path: Heat_Transfer_Module/Phase_Change/
tin_melting_front

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Heat Transfer>Conjugate Heat Transfer>Laminar Flow.

3 Click Add.

4 In the Select Physics tree, select Mathematics>Deformed Mesh>Deformed Geometry (dg).

5 Click Add.

6 Click Study.

7 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Time 

Dependent.

8 Click Done.
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G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Square 1 (sq1)
1 On the Geometry toolbar, click Primitives and choose Square.

2 In the Settings window for Square, locate the Size section.

3 In the Side length text field, type 0.1.

4 Click to expand the Layers section. In the table, enter the following settings:

5 Select the Layers to the left check box.

6 Clear the Layers on bottom check box.

7 Click Build All Objects.

Name Expression Value Description

k_Sn 60[W/(m*K)] 60 W/(m·K) Thermal conductivity

Cp_Sn 200[J/(kg*K)] 200 J/(kg·K) Specific heat capacity

alpha_Sn 2.67e-4[1/K] 2.67E-4 1/K Coefficient of thermal 
expansion

nu_Sn 8e-7[m^2/s] 8E-7 m²/s Kinematic viscosity

rho_Sn 7500[kg/m^3] 7500 kg/m³ Density

DelH 60[kJ/kg] 60000 J/kg Latent heat of fusion

Tf 505[K] 505 K Melting point

Th 508[K] 508 K Hot wall temperature

Tc 503[K] 503 K Cold wall temperature

p_ref 100[Pa] 100 Pa Gauge pressure

Layer name Thickness (m)

Layer 1 0.06
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M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, type Tin (Solid) in the Label text field.

2 Select Domain 2 only.

3 Locate the Material Contents section. In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Tin (Liquid) in the Label text field.

3 Select Domain 1 only.

4 Locate the Geometric Entity Selection section. Click Create Selection.

5 In the Create Selection dialog box, type Tin (liquid) in the Selection name text field.

6 Click OK.

Before defining the material properties of liquid tin, indicate which is the fluid domain to 
let COMSOL Multiphysics flag what properties you need to specify.

L A M I N A R  F L O W  ( S P F )

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

2 In the Settings window for Laminar Flow, locate the Domain Selection section.

3 From the Selection list, choose Tin (liquid).

H E A T  TR A N S F E R  ( H T )

On the Physics toolbar, click Laminar Flow (spf) and choose Heat Transfer (ht).

Fluid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Fluid 

1.

Property Name Value Unit Property 
group

Thermal conductivity k k_Sn W/(m·K) Basic

Density rho rho_Sn kg/m³ Basic

Heat capacity at constant 
pressure

Cp Cp_Sn J/(kg·K) Basic
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2 In the Settings window for Fluid, locate the Domain Selection section.

3 From the Selection list, choose Tin (liquid).

M A T E R I A L S

Tin (Liquid) (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Tin (Liquid) 

(mat2).

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

H E A T  TR A N S F E R  ( H T )

Initial Values 1
Define the initial temperature as a function of Xg, the first coordinate on the undeformed 
geometry.

1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Initial 

Values 1.

2 In the Settings window for Initial Values, type Th-Xg/0.1[m]*(Th-Tc) in the T text 
field.

L A M I N A R  F L O W  ( S P F )

On the Physics toolbar, click Heat Transfer (ht) and choose Laminar Flow (spf).

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Laminar Flow (spf) click Initial 

Values 1.

2 In the Settings window for Initial Values, locate the Initial Values section.

3 In the p text field, type p_ref.

Property Name Value Unit Property 
group

Thermal conductivity k k_Sn W/(m·K) Basic

Heat capacity at constant 
pressure

Cp Cp_Sn J/(kg·K) Basic

Ratio of specific heats gamma 1.4 1 Basic

Dynamic viscosity mu rho_Sn*
nu_Sn

Pa·s Basic
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4 In the Model Builder window, click Laminar Flow (spf).

5 In the Settings window for Laminar Flow, locate the Physical Model section.

6 From the Compressibility list, choose Incompressible flow.

7 Select the Include gravity check box.

8 Select the Use reduced pressure check box.

9 Find the Reference values subsection. In the Tref text field, type Tf.

H E A T  TR A N S F E R  ( H T )

On the Physics toolbar, click Laminar Flow (spf) and choose Heat Transfer (ht).

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 1 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type Th.

Temperature 2
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 4 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type Tf.

Show advanced physics options as follows to enable weak constraints on the melting 
front. This creates the Lagrange multiplier for temperature, which evaluates the heat 
flux jump between the adjacent liquid and solid domains more accurately.

5 In the Model Builder window’s toolbar, click the Show button and select Advanced Physics 

Options in the menu.

6 Click to expand the Constraint settings section. Locate the Constraint Settings section. 
Select the Use weak constraints check box.

Temperature 3
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundary 7 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type Tc.
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L A M I N A R  F L O W  ( S P F )

In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

Pressure Point Constraint 1
1 On the Physics toolbar, click Points and choose Pressure Point Constraint.

2 Select Point 1 only.

3 In the Settings window for Pressure Point Constraint, locate the Pressure Constraint 
section.

4 In the p0 text field, type p_ref.

The model only contains information about the pressure gradient and estimates the 
pressure field up to a constant. To define this constant, you arbitrarily fix the pressure 
at a point.

M U L T I P H Y S I C S

1 In the Model Builder window, under Component 1 (comp1)>Multiphysics click 
Non-Isothermal Flow 1 (nitf1).

2 In the Settings window for Non-Isothermal Flow, locate the Material Properties section.

3 From the Specify density list, choose Custom, linearized density.

4 In the ρref text field, type rho_Sn.

5 In the αp text field, type alpha_Sn.

D E F O R M E D  G E O M E T R Y  ( D G )

On the Physics toolbar, click Laminar Flow (spf) and choose Deformed Geometry (dg).

In the Model Builder window, under Component 1 (comp1) click Deformed Geometry (dg).

Free Deformation 1
1 On the Physics toolbar, click Domains and choose Free Deformation.

2 In the Settings window for Free Deformation, locate the Domain Selection section.

3 From the Selection list, choose All domains.

Prescribed Mesh Displacement 2
1 On the Physics toolbar, click Boundaries and choose Prescribed Mesh Displacement.

2 Select Boundaries 1 and 7 only.

3 In the Settings window for Prescribed Mesh Displacement, locate the Prescribed Mesh 

Displacement section.

4 Clear the Prescribed y displacement check box.
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Prescribed Mesh Displacement 1
1 In the Model Builder window, under Component 1 (comp1)>Deformed Geometry (dg) click 

Prescribed Mesh Displacement 1.

2 In the Settings window for Prescribed Mesh Displacement, locate the Prescribed Mesh 

Displacement section.

3 Clear the Prescribed x displacement check box.

Prescribed Normal Mesh Velocity 1
1 On the Physics toolbar, click Boundaries and choose Prescribed Normal Mesh Velocity.

2 Select Boundary 4 only.

3 In the Settings window for Prescribed Normal Mesh Velocity, locate the Normal Mesh 

Velocity section.

4 In the vn text field, type T_lm[W/m^2]/(rho_Sn*DelH).

The variable T_lm is the Lagrange multiplier for temperature.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Fine.

4 Click Build All.

S T U D Y  1

Step 1: Time Dependent
1 In the Settings window for Time Dependent, locate the Study Settings section.

2 Click Range.

3 In the Range dialog box, type 100 in the Step text field.

4 In the Stop text field, type 10000.

5 Click Replace.

6 In the Settings window for Time Dependent, locate the Study Settings section.

7 Select the Relative tolerance check box.

8 In the associated text field, type 1e-3.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.
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2 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Time-Dependent Solver 1.

3 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

4 Locate the Time Stepping section. From the Steps taken by solver list, choose 
Intermediate.

5 On the Study toolbar, click Compute.

R E S U L T S

Temperature (ht)
This default plot shows the temperature profile. To reproduce Figure 3, add arrows of the 
heat flux field to see the relation between temperature and velocity.

Arrow Surface 1
1 In the Model Builder window, under Results right-click Temperature (ht) and choose 

Arrow Surface.

2 In the Settings window for Arrow Surface, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Model>Component 1>Laminar 

Flow>Velocity and pressure>u,v - Velocity field (Material).

3 Locate the Coloring and Style section. From the Arrow type list, choose Cone.

4 From the Color list, choose Black.

5 On the Temperature (ht) toolbar, click Plot.

Velocity (spf)
This default plot shows the velocity profile in the fluid region. To reproduce Figure 5, add 
arrows of the velocity field to visualize the convective flow direction.

Arrow Surface 1
1 In the Model Builder window, under Results right-click Velocity (spf) and choose Arrow 

Surface.

2 In the Settings window for Arrow Surface, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Model>Component 1>Laminar 

Flow>Velocity and pressure>u,v - Velocity field (Material).

3 Locate the Coloring and Style section. From the Arrow type list, choose Cone.

4 From the Color list, choose Black.

5 On the Velocity (spf) toolbar, click Plot.
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Finally, plot the mesh deformation as follows.

2D Plot Group 5
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Mesh Deformation in the Label text 
field.

Mesh 1
1 Right-click Mesh Deformation and choose Mesh.

2 In the Settings window for Mesh, locate the Color section.

3 From the Element color list, choose None.

4 From the Wireframe color list, choose Blue.

Filter 1
1 Right-click Results>Mesh Deformation>Mesh 1 and choose Filter.

2 In the Settings window for Filter, locate the Element Selection section.

3 In the Logical expression for inclusion text field, type dom==1.

This logical expression restricts the plot to the fluid domain.

4 On the Mesh Deformation toolbar, click Plot.

Mesh 1
Right-click Mesh 1 and choose Duplicate.

Mesh 2
1 In the Settings window for Mesh, locate the Color section.

2 From the Wireframe color list, choose Red.

Filter 1
1 In the Model Builder window, expand the Mesh 2 node, then click Filter 1.

2 In the Settings window for Filter, locate the Element Selection section.

3 In the Logical expression for inclusion text field, type dom==2.

This logical expression filters the solid domain.
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4 On the Mesh Deformation toolbar, click Plot.

The plot should look like that in the figure below.
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Introduction

One method for removing cancerous tumors from healthy tissue is to heat the malignant 
tissue to a critical temperature that kills the cancer cells. This example accomplishes the 
localized heating by inserting a four-armed electric probe through which an electric 
current runs. Equations for the electric field for this case appear in the Electric Currents 
interface, and this example couples them to the bioheat equation, which models the 
temperature field in the tissue. The heat source resulting from the electric field is also 
known as resistive heating or Joule heating. The original model comes from S. 
Tungjitkusolmun and others (Ref. 1), but we have made some simplifications. For 
instance, while the original uses RF heating (with AC currents), the COMSOL 
Multiphysics model approximates the energy with DC currents.

This medical procedure removes the tumorous tissue by heating it above 45 °C to 50 °C. 
Doing so requires a local heat source, which physicians create by inserting a small electric 
probe. The probe is made of a trocar (the main rod) and four electrode arms as shown in 
Figure 1. The trocar is electrically insulated except near the electrode arms.

An electric current through the probe creates an electric field in the tissue. The field is 
strongest in the immediate vicinity of the probe and generates resistive heating, which 
dominates around the probe’s electrode arms because of the strong electric field.

Figure 1: Cylindrical modeling domain with the four-armed electric probe in the middle, 
which is located next to a large blood vessel.

Model Definition

This tutorial uses the Bioheat Transfer interface, the Electric Currents interface and a 
multiphysics feature, Electromagnetic Heat Source, to implement a transient analysis.

Liver tissue

Blood vessel

Electrodes

Trocar tip

Trocar base (coated
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The standard temperature unit in COMSOL Multiphysics is kelvin (K). This tutorial uses 
the Celsius temperature scale, which is more convenient for models involving the bioheat 
equation.

The model approximates the body tissue with a large cylinder and assumes that its 
boundary temperature remains at 37 °C during the entire procedure. The tumor is located 
near the center of the cylinder and has the same thermal properties as the surrounding 
tissue. The model locates the probe along the cylinder’s center line such that its electrodes 
span the region where the tumor is located. The geometry also includes a large blood 
vessel.

H E A T  TR A N S F E R

The bioheat equation governs heat transfer in the tissue

where δts is a time-scaling coefficient; ρ is the tissue density (kg/m3); C is the tissue’s 
specific heat (J/(kg·K)); and k is its thermal conductivity (W/(m·K)). On the right side of 
the equality, ρb gives the blood’s density (kg/m3); Cb is the blood’s specific heat (J/
(kg·K)); ωb is its perfusion rate (1/s); Tb is the arterial blood temperature (Κ); while Qmet 
and Qext are the heat sources from metabolism and spatial heating, respectively (W/m3).

In this example, the bioheat equation also models heat transfer in various parts of the 
probe with the appropriate values for the specific heat, C (J/(kg·K)), and thermal 
conductivity, k (W/(m·K)). For these parts, all terms on the right-hand side are zero.

The model next sets the boundary conditions at the outer boundaries of the cylinder and 
at the walls of the blood vessel to a temperature of 37 °C. Assume heat flux continuity on 
all other boundaries.

The initial temperature equals 37 °C in all domains.

In addition to the heat transfer equation this model provides a calculation of the tissue 
damage integral. This gives an idea about the degree of tissue injury α during the process, 
based on the Arrhenius equation:

where A is the frequency factor (s-1) and dE is the activation energy for irreversible 
damage reaction (J/mol). These two parameters are dependent on the type of tissue. The 
fraction of necrotic tissue, θd, is then expressed by:

δtsρ C
t∂

∂T ∇ k T∇–( )⋅+ ρb Cb ωb Tb T–( ) Qmet Qext+ +=

td
dα A dE

RT
--------– 

 exp=
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E L E C T R I C  C U R R E N T

The governing equation for the Electric Currents interface is

where V is the potential (V), σ the electrical conductivity (S/m), Je an externally 
generated current density (A/m2), Qj the current source (A/m3).

In this model both Je and Qj are zero. The governing equation therefore simplifies into:

.

The boundary conditions at the cylinder’s outer boundaries is ground (0 V potential). At 
the electrode boundaries the potential equals 22 V. Assume continuity for all other 
boundaries.

The boundary conditions for the Electric Currents interface are:

The boundary conditions for the bioheat equation are:

The model solves the above equations with the given boundary conditions to obtain the 
temperature field as a function of time.

Results and Discussion

The model shows how the temperature increases with time in the tissue around the 
electrode.

θd 1 α–( )exp–=

∇– σ V∇ Je
–( )⋅ Qj=

∇– σ V∇( )⋅ 0=

V 0= on the cylinder wall
V V0= on the electrode surfaces

n J1 J2–( )⋅ 0= on all other boundaries

T Tb= on the cylinder wall and blood-vessel wall

n k1 T1∇ k2 T2∇–( )⋅ 0= on all interior boundaries
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The slice plot in Figure 2 illustrates the temperature field at the end of the procedure.

Figure 2: Temperature field at time = 10 minutes.
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Figure 3 shows the temperature at the tip of one of the electrode arms. The temperature 
rises quickly until it reaches a steady-state temperature of about 90 °C.

Figure 3: Temperature versus time at the tip of one of the electrode arms.

It is also interesting to visualize the region where cancer cells die, that is, where the 
temperature has reached at least 50 °C. You can visualize this area with an isosurface for 
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that temperature; Figure 4 shows one after 10 minutes.

Figure 4: Visualization of the region that has reached 50 °C after 10 minutes.
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In addition to the previous figure, you can visualize the fraction of necrotic tissue in the 
slice plot of Figure 5.

Figure 5: Fraction of necrotic tissue.
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Finally, Figure 6 shows the fraction of necrotic tissue at three different points above the 
electrode arm. Observe that necrosis happens faster next to the electrode and the trocar 
tip.

Figure 6: Fraction of necrotic tissue at three points above the electrode arm.

Reference

1. S. Tungjitkusolmun, S. Tyler Staelin, D. Haemmerich, J.Z. Tsai, H. Cao, J.G. Webster, 
F.T. Lee, Jr., D.M. Mahvi, and V.R. Vorperian, “Three-Dimensional Finite Element 
Analyses for Radio-Frequency Hepatic Tumor Ablation,” IEEE Transactions on 
Biomedical Engineering, vol. 49, no. 1, 2002.

Application Library path: Heat_Transfer_Module/Medical_Technology/
tumor_ablation

Modeling Instructions

From the File menu, choose New.
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N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select AC/DC>Electric Currents (ec).

3 Click Add.

4 In the Select Physics tree, select Heat Transfer>Bioheat Transfer (ht).

5 Click Add.

6 Click Study.

7 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Time 

Dependent.

8 Click Done.

G L O B A L  D E F I N I T I O N S

First, define the global parameters of the model and the geometry.

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

rho_b 1000[kg/m^3] 1000 kg/m³ Density, blood

c_b 4180[J/(kg*K)] 4180 J/(kg·K) Heat capacity, 
blood

omega_b 6.4e-3[1/s] 0.0064 1/s Blood perfusion 
rate

T_b 37[degC] 310.15 K Arterial blood 
temperature

T0 37[degC] 310.15 K Initial and 
boundary 
temperature

V0 22[V] 22 V Electric voltage

xc_v 26[mm] 0.026 m Vessel cylinder 
center x coordinate

a_time 10[min] 600 s Ablation time
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G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type 0.9144.

4 In the Height text field, type 60.

5 Locate the Position section. In the z text field, type 60.

6 Click to expand the Layers section. In the table, enter the following settings:

7 Clear the Layers on side check box.

8 Select the Layers on bottom check box.

Torus 1 (tor1)
1 Right-click Cylinder 1 (cyl1) and choose Build Selected.

2 On the Geometry toolbar, click Torus.

3 In the Settings window for Torus, locate the Size and Shape section.

4 In the Major radius text field, type 7.5.

5 In the Minor radius text field, type 0.2667.

6 In the Revolution angle text field, type 180.

7 Locate the Position section. In the x text field, type 8.

8 In the z text field, type 60.

9 Locate the Axis section. From the Axis type list, choose y-axis.

10 Locate the Rotation Angle section. In the Rotation text field, type -90.

Rotate 1 (rot1)
1 Right-click Torus 1 (tor1) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Rotate.

3 Select the object tor1 only.

4 In the Settings window for Rotate, locate the Rotation Angle section.

Layer name Thickness (mm)

Layer 1 10
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5 Click Range.

6 In the Range dialog box, type 0 in the Start text field.

7 In the Step text field, type 90.

8 In the Stop text field, type 270.

9 Click Replace.

10 Right-click Rotate 1 (rot1) and choose Build Selected.

11 Click the Zoom Extents button on the Graphics toolbar.

Cylinder 2 (cyl2)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type 5.

4 In the Height text field, type 120.

5 Locate the Position section. In the x text field, type xc_v.

6 Right-click Cylinder 2 (cyl2) and choose Build Selected.

7 Click the Zoom Extents button on the Graphics toolbar.

Cylinder 3 (cyl3)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type 50.

4 In the Height text field, type 120.

5 On the Geometry toolbar, click Build All.

6 Click the Zoom Extents button on the Graphics toolbar.

D E F I N I T I O N S

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Exterior Boundaries in the Label text field.

3 Locate the Input Entities section. Select the All domains check box.

4 Locate the Output Entities section. From the Output entities list, choose Adjacent 

boundaries.

Explicit 2
1 On the Definitions toolbar, click Explicit.
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2 In the Settings window for Explicit, type Liver Tissue in the Label text field.

3 Select Domain 1 only.

Explicit 3
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Blood Vessel in the Label text field.

3 Select Domain 8 only.

Explicit 4
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Electrodes in the Label text field.

3 Click the Wireframe Rendering button on the Graphics toolbar.

4 Select Domains 2 and 5–7 only.

Explicit 5
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Trocar Tip in the Label text field.

3 Select Domain 3 only.

Explicit 6
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Trocar Base in the Label text field.

3 Select Domain 4 only.

Union 1
1 On the Definitions toolbar, click Union.

2 In the Settings window for Union, type Trocar in the Label text field.

3 Locate the Input Entities section. Under Selections to add, click Add.

4 In the Add dialog box, In the Selections to add list, choose Electrodes, Trocar Tip, and 
Trocar Base.

5 Click OK.

Union 2
1 On the Definitions toolbar, click Union.

2 In the Settings window for Union, type Tissue and Trocar in the Label text field.

3 Locate the Input Entities section. Under Selections to add, click Add.

4 In the Add dialog box, In the Selections to add list, choose Liver Tissue and Trocar.
13 |  H E P A T I C  TU M O R  A B L A T I O N



5 Click OK.

Adjacent 1
1 On the Definitions toolbar, click Adjacent.

2 In the Settings window for Adjacent, type Tissue and Trocar, Exterior 
Boundaries in the Label text field.

3 Locate the Input Entities section. Under Input selections, click Add.

4 In the Add dialog box, select Tissue and Trocar in the Input selections list.

5 Click OK.

Adjacent 2
1 On the Definitions toolbar, click Adjacent.

2 In the Settings window for Adjacent, type Trocar Tip and Electrodes, Exterior 
Boundaries in the Label text field.

3 Locate the Input Entities section. Under Input selections, click Add.

4 In the Add dialog box, In the Input selections list, choose Electrodes and Trocar Tip.

5 Click OK.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Bioheat>Liver (human).

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Liver (human) (mat1)
1 On the Home toolbar, click Add Material to close the Add Material window.

2 In the Model Builder window, under Component 1 (comp1)>Materials click Liver (human) 

(mat1).

3 In the Settings window for Material, locate the Geometric Entity Selection section.

4 From the Selection list, choose Liver Tissue.
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5 Locate the Material Contents section. In the table, enter the following settings:

Material 2 (mat2)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Blood in the Label text field.

3 Locate the Geometric Entity Selection section. From the Selection list, choose Blood 

Vessel.

4 Locate the Material Contents section. In the table, enter the following settings:

Material 3 (mat3)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Electrodes in the Label text field.

3 Locate the Geometric Entity Selection section. From the Selection list, choose Electrodes.

4 Locate the Material Contents section. In the table, enter the following settings:

Property Name Value Unit Property 
group

Electrical conductivity sigma 0.333[S
/m]

S/m Basic

Relative permittivity epsilonr 1 1 Basic

Property Name Value Unit Property 
group

Electrical conductivity sigma 0.667[S
/m]

S/m Basic

Relative permittivity epsilonr 1 1 Basic

Thermal conductivity k 0.543[W
/(m*K)]

W/(m·K) Basic

Density rho rho_b kg/m³ Basic

Heat capacity at constant 
pressure

Cp c_b J/(kg·K) Basic

Property Name Value Unit Property 
group

Electrical conductivity sigma 1e8[S/m] S/m Basic

Relative permittivity epsilonr 1 1 Basic

Thermal conductivity k 18[W/(m*
K)]

W/(m·K) Basic
15 |  H E P A T I C  TU M O R  A B L A T I O N



Material 4 (mat4)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Trocar Tip in the Label text field.

3 Locate the Geometric Entity Selection section. From the Selection list, choose Trocar Tip.

4 Locate the Material Contents section. In the table, enter the following settings:

Material 5 (mat5)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Trocar Base in the Label text field.

3 Locate the Geometric Entity Selection section. From the Selection list, choose Trocar Base.

4 Locate the Material Contents section. In the table, enter the following settings:

Density rho 6450[kg/
m^3]

kg/m³ Basic

Heat capacity at constant 
pressure

Cp 840[J/
(kg*K)]

J/(kg·K) Basic

Property Name Value Unit Property 
group

Electrical conductivity sigma 4e6[S/m] S/m Basic

Relative permittivity epsilonr 1 1 Basic

Thermal conductivity k 71[W/(m*
K)]

W/(m·K) Basic

Density rho 21500[kg/
m^3]

kg/m³ Basic

Heat capacity at constant 
pressure

Cp 132[J/
(kg*K)]

J/(kg·K) Basic

Property Name Value Unit Property 
group

Electrical conductivity sigma 1e-5[S/
m]

S/m Basic

Relative permittivity epsilonr 1 1 Basic

Thermal conductivity k 0.026[W/
(m*K)]

W/(m·K) Basic

Property Name Value Unit Property 
group
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E L E C T R I C  C U R R E N T S  ( E C )

1 In the Model Builder window’s toolbar, click the Show button and select Discretization in 
the menu.

At the time scale of the tumor ablation process, the electric field is stationary. Change 
the equation form accordingly.

2 In the Model Builder window, under Component 1 (comp1) click Electric Currents (ec).

3 In the Settings window for Electric Currents, click to expand the Equation section.

4 From the Equation form list, choose Stationary.

To reduce the size of the computation problem, select a lower element order.

5 Click to expand the Discretization section. From the Electric potential list, choose Linear.

Ground 1
1 On the Physics toolbar, click Boundaries and choose Ground.

2 In the Settings window for Ground, locate the Boundary Selection section.

3 From the Selection list, choose Exterior Boundaries.

Electric Potential 1
1 On the Physics toolbar, click Boundaries and choose Electric Potential.

2 In the Settings window for Electric Potential, locate the Boundary Selection section.

3 From the Selection list, choose Trocar Tip and Electrodes, Exterior Boundaries.

4 Locate the Electric Potential section. In the V0 text field, type V0.

B I O H E A T  TR A N S F E R  ( H T )

1 In the Model Builder window, under Component 1 (comp1) click Bioheat Transfer (ht).

2 In the Settings window for Bioheat Transfer, locate the Domain Selection section.

3 From the Selection list, choose Tissue and Trocar.

Biological Tissue 1
1 In the Model Builder window, under Component 1 (comp1)>Bioheat Transfer (ht) click 

Biological Tissue 1.

Density rho 70[kg/
m^3]

kg/m³ Basic

Heat capacity at constant 
pressure

Cp 1045[J/
(kg*K)]

J/(kg·K) Basic

Property Name Value Unit Property 
group
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2 In the Settings window for Biological Tissue, locate the Damaged Tissue section.

3 Select the Include damage integral analysis check box.

4 From the Damage integral form list, choose Energy absorption.

Bioheat 1
1 In the Model Builder window, expand the Biological Tissue 1 node, then click Bioheat 1.

2 In the Settings window for Bioheat, locate the Bioheat section.

3 In the Tb text field, type T_b.

4 In the Cp, b text field, type c_b.

5 In the ωb text field, type omega_b.

6 In the ρb text field, type rho_b.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Bioheat Transfer (ht) click 

Initial Values 1.

2 In the Settings window for Initial Values, type T0 in the T text field.

3 In the Model Builder window, click Bioheat Transfer (ht).

Solid 1
1 On the Physics toolbar, click Domains and choose Solid.

2 In the Settings window for Solid, locate the Domain Selection section.

3 From the Selection list, choose Trocar.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 In the Settings window for Temperature, locate the Boundary Selection section.

3 From the Selection list, choose Tissue and Trocar, Exterior Boundaries.

4 Locate the Temperature section. In the T0 text field, type T_b.

M U L T I P H Y S I C S

Electromagnetic Heat Source 1 (emh1)
1 On the Physics toolbar, click Multiphysics and choose Domain>Electromagnetic Heat 

Source.

2 In the Settings window for Electromagnetic Heat Source, locate the Domain Selection 
section.

3 From the Selection list, choose All domains.
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M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Tetrahedral.

Free Tetrahedral 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Tetrahedral 1 and choose Size.

Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Domain.

3 Select Domains 2 and 5–7 only.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 0.38.

7 Select the Minimum element size check box.

8 In the associated text field, type 0.35.

Free Tetrahedral 1
Right-click Free Tetrahedral 1 and choose Size.

Size 2
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Domain.

3 Select Domains 3 and 4 only.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 1.3.

7 Select the Minimum element size check box.

8 In the associated text field, type 1.1.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. In the Resolution of narrow regions text field, 
type 0.
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5 Click Build All.

S T U D Y  1

Step 1: Time Dependent
1 In the Settings window for Time Dependent, locate the Study Settings section.

2 From the Time unit list, choose min.

3 In the Times text field, type range(0,a_time/4,a_time).

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Time-Dependent Solver 1.

3 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

4 Locate the Time Stepping section. Select the Initial step check box.

5 In the associated text field, type 0.01[s].

6 Select the Maximum step check box.

7 In the associated text field, type 50[s].

Add probes to save the fraction of necrotic tissue and the temperature over time at some 
specified points.

D E F I N I T I O N S

Domain Point Probe 1
1 On the Definitions toolbar, click Probes and choose Domain Point Probe.

2 In the Settings window for Domain Point Probe, locate the Point Selection section.

3 In row Coordinates, set x to -4.

4 In row Coordinates, set z to 65.

5 In the Model Builder window, expand the Domain Point Probe 1 node, then click Point 

Probe Expression 1 (ppb1).

6 In the Settings window for Point Probe Expression, click Replace Expression in the 
upper-right corner of the Expression section. From the menu, choose Model>Component 

1 (comp1)>Bioheat Transfer>Biological tissue>ht.theta_d - Fraction of necrotic tissue.

7 Click to expand the Table and window settings section. Locate the Table and Window 

Settings section. Click Plot window.
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8 In the Model Builder window, right-click Domain Point Probe 1 and choose Duplicate.

9 In the Settings window for Domain Point Probe, locate the Point Selection section.

10 In row Coordinates, set x to -12.

11 Right-click Domain Point Probe 1 and choose Duplicate.

12 In the Settings window for Domain Point Probe, locate the Point Selection section.

13 In row Coordinates, set x to -20.

Domain Point Probe 4
1 On the Definitions toolbar, click Probes and choose Domain Point Probe.

2 In the Settings window for Domain Point Probe, locate the Point Selection section.

3 In row Coordinates, set x to -0.2667.

4 In row Coordinates, set y to 15.5.

5 In row Coordinates, set z to 60.

6 In the Model Builder window, expand the Domain Point Probe 4 node, then click Point 

Probe Expression 4 (ppb4).

7 In the Settings window for Point Probe Expression, click Replace Expression in the 
upper-right corner of the Expression section. From the menu, choose Model>Component 

1 (comp1)>Bioheat Transfer>Temperature>T - Temperature.

8 Locate the Table and Window Settings section. Click Plot window.

9 Locate the Expression section. From the Table and plot unit list, choose degC.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Electric Potential (ec)
The first default plot shows the electric potential on slices.

Temperature (ht)
The second default plot shows the temperature at the final time.

To reproduce the two-slice plot of the temperature at 10 minutes shown in Figure 2, 
proceed as follows.

Before adding slices, delete the default Surface node.
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Surface
In the Model Builder window, expand the Temperature (ht) node.

Temperature (ht)
1 Right-click Surface and choose Delete.

. Click Yes to confirm.

Slice 1
1 In the Model Builder window, under Results right-click Temperature (ht) and choose Slice.

2 In the Settings window for Slice, click Replace Expression in the upper-right corner of the 
Expression section. From the menu, choose Model>Component 1>Bioheat Transfer>

Temperature>T - Temperature.

3 Locate the Expression section. From the Unit list, choose degC.

4 Locate the Plane Data section. In the Planes text field, type 1.

5 Locate the Coloring and Style section. From the Color table list, choose ThermalLight.

Temperature (ht)
Right-click Temperature (ht) and choose Slice.

Slice 2
1 In the Settings window for Slice, click Replace Expression in the upper-right corner of the 

Expression section. From the menu, choose Model>Component 1>Bioheat Transfer>

Temperature>T - Temperature.

2 Locate the Expression section. From the Unit list, choose degC.

3 Locate the Plane Data section. From the Plane list, choose zx-planes.

4 In the Planes text field, type 1.

5 Locate the Coloring and Style section. From the Color table list, choose ThermalLight.

6 Click to expand the Inherit style section. Locate the Inherit Style section. From the Plot 
list, choose Slice 1.

7 On the Temperature (ht) toolbar, click Plot.

8 Click the Zoom In button on the Graphics toolbar.

Isothermal Contours (ht)
The third default plot shows isothermal contours for the final time.

To reproduce Figure 4, modify this plot group as follows:
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Isosurface
1 In the Model Builder window, expand the Isothermal Contours (ht) node, then click 

Isosurface.

2 In the Settings window for Isosurface, locate the Expression section.

3 From the Unit list, choose degC.

4 Locate the Levels section. From the Entry method list, choose Levels.

5 In the Levels text field, type 50.

Isothermal Contours (ht)
1 In the Model Builder window, under Results click Isothermal Contours (ht).

2 On the Isothermal Contours (ht) toolbar, click Plot.

Probe Plot Group 4
1 In the Model Builder window, under Results click Probe Plot Group 4.

2 In the Settings window for 1D Plot Group, type Damaged Tissue, 1D in the Label text 
field.

3 On the Damaged Tissue, 1D toolbar, click Plot.

Generate plots to show the fraction of necrotic tissue.

Probe Plot Group 5
1 In the Model Builder window, under Results click Probe Plot Group 5.

2 In the Settings window for 1D Plot Group, type Temperature at One Electrode Tip 
in the Label text field.

3 On the Temperature at One Electrode Tip toolbar, click Plot.

3D Plot Group 6
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Damaged Tissue, 3D in the Label text 
field.

Slice 1
1 Right-click Damaged Tissue, 3D and choose Slice.

2 In the Settings window for Slice, click Replace Expression in the upper-right corner of the 
Expression section. From the menu, choose Model>Component 1>Bioheat Transfer>

Biological tissue>ht.theta_d - Fraction of necrotic tissue.

3 Locate the Plane Data section. In the Planes text field, type 1.
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Slice 2
1 Right-click Results>Damaged Tissue, 3D>Slice 1 and choose Duplicate.

2 In the Settings window for Slice, locate the Plane Data section.

3 From the Plane list, choose zx-planes.

4 In the Planes text field, type 1.

5 Click to expand the Inherit style section. Locate the Inherit Style section. From the Plot 
list, choose Slice 1.

6 On the Damaged Tissue, 3D toolbar, click Plot.
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Introduction

This example solves a pure conduction problem and a free-convection problem in which 
a vacuum flask holding hot coffee dissipates thermal energy. The main interest is to 
calculate the flask’s cooling power; that is, how much heat it loses per unit time.

Figure 1: Schematic picture of the flask.

The coffee has an initial temperature of 90 °C and cools down over time. The observation 
period is 10 h. This tutorial compares two different approaches to model natural 
convection cooling:

• Using heat transfer coefficients to describe the thermal dissipation

• Modeling the convective flow of air outside the flask to describe the thermal dissipation

The first approach describes the outside heat flux using a heat transfer coefficient function 
from the Heat Transfer Coefficients library included with the Heat Transfer Module. This 
results in a rather simple model that predicts the stationary cooling well and produces 
accurate results for temperature distribution and cooling power.

The second approach solves for both the total energy balance and the flow equations of 
the outside cooling air. This application produces detailed results for the flow field around 
the flask as well as for the temperature distribution and cooling power. However, it is more 
complex and requires more computational resources than the first version.
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Model Definition

Figure 2 shows the model geometry.

Figure 2: The 2D-axisymmetric representation of the vacuum flask.

C O N T R O L  VO L U M E

For the first approach, the model does not include a control volume around the flask to 
represent the domain of the surrounding air. Instead, it uses a heat transfer coefficient 
correlation for vertical and horizontal plates.

For the second approach, the model uses a control volume around the flask to represent 
the domain of the surrounding air. Choosing an appropriate control volume for natural 
convection models is difficult. Your choice strongly influences the model, the mesh, the 
convergence, and especially the flow behavior. The real-world air domain surrounding the 
flask is the entire room or atmosphere in which the flask is placed. Making the rectangle 
as large as the external room would result in a very large model requiring a supercomputer 
to solve. At the other extreme, if you make the control volume too small, the solution is 
affected by the imposed artificial boundary conditions, and there can also be a truncation 
of flow eddies, making convergence difficult.

An appropriate truncation should resolve the flow field around the flask but avoid 
modeling a large surrounding. One way to approach this task is to start with a small control 
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volume, set up and solve the model, then expand the control volume, solve the model 
again, and see if the results change. This example uses a sufficiently large control volume 
by truncating the air domain at r = 0.1 m and z = 0.5 m. The boundary condition at the 
boundaries that are open to large volumes can handle both entering and leaving fluid. The 
entering fluid has the temperature of the surroundings whereas the leaving fluid has an 
unknown temperature that results from the cooling effects of the flow field.

M A T E R I A L  P R O P E R T I E S

Next consider the materials that make up the flask model. The flask contains coffee that 
has almost exactly the same material properties as water. The screw stopper and insulation 
ring are made of nylon. The flask bottle consists of stainless steel, and the filling material 
between the inner and outer walls is a plastic foam. The material library includes all 
materials used in this model except the foam, which you specify manually. Table 1 provides 
a list of standard foam’s thermal properties.

H E A T  TR A N S F E R  P H Y S I C S

This example assumes the hot liquid (coffee) to have a uniform temperature distribution 
that changes only with time. This is a reasonable approximation since the observation 
period is long and effects of spatially varying temperatures in the liquid are small. The Heat 
Transfer Module provides the isothermal domain feature. It solves only an additional 
ordinary differential equation of the form:

where m is the total mass of the domain, which can be prescribed or is calculated 
automatically from the material properties. The source term Q is calculated from the 
adjacent entities.

The walls of the flask, that are made of steel are modeled as thin conductive layers, so that 
their thickness does not need to be resolved by the mesh.

TABLE 1:  FOAM MATERIAL PROPERTIES

PROPERTY VALUE

Conductivity 0.03 W/(m·K)

Density 60 kg/m3

Heat Capacity 200 J/(kg·K)

mCp
dT
dt
-------- Q=
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Approach 1—Loading a Heat Transfer Coefficient Function

This application uses a simplified approach and solves the time-dependent 
thermal-conduction equation making use of a heat transfer coefficient, h, to describe the 
natural convection cooling on the outside surfaces of the flask. This approach is very 
powerful in many situations, especially if the main interest is not the flow behavior but 
rather its cooling power. By using the appropriate h correlations, you can generally arrive 
at accurate results at a very low computational cost. In addition, many correlations are 
valid for the entire flow regime, from laminar to turbulent flow. This makes it possible to 
approach the problem directly without predicting whether the flow is laminar or turbulent.

B O U N D A R Y  C O N D I T I O N S

Vertical boundaries along the axis of symmetry have a symmetry condition (zero gradients, 
set by COMSOL Multiphysics automatically); the bottom is modeled as perfectly insulated 
(zero flux). The flask surfaces are exposed to air and are cooled by convection. The use of 
a thin layer feature models the thickness of the steel shell.

The only remaining energy-balance boundary condition is for the flask surface. In the first 
approach a convective heat-transfer coefficient together with the ambient temperature, 
25 °C, describes the heat flux.

C O N V E C T I V E  H E A T  TR A N S F E R  C O E F F I C I E N T

The outer surfaces dissipate heat via natural convection. This loss is characterized by the 
convective heat transfer coefficient, h, which in practice you often determine with 
empirical handbook correlations. Because these correlations depend on the surface 
temperature, Tsurface, engineers must estimate Tsurface and then iterate between h and 
Tsurface to obtain a converged value for h. Most of these correlations require tedious 
computations and property interpolations that make this iterative process quite unpleasant 
and labor intensive.

A typical handbook correlation (see Ref. 1) for h for the case of natural convection in air 
on a vertical heated wall RaL ≤ 109 is

h
k NuL⋅

L
-------------------=

NuL 0.68
0.670RaL

1 4/

1 0.492
Pr

--------------- 
  9 16/

+
4 9/

------------------------------------------------------+=
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where RaL and Pr are the Rayleigh and Prandtl dimensionless numbers. A similar relation 
involving Nusselt numbers holds for inclined and horizontal planes (see The Heat Transfer 
Coefficients in the Heat Transfer Module User’s Guide for details).

COMSOL Multiphysics handles these types of nonlinearities internally and adds much 
convenience to such computations, so there is no need to iterate.

The Heat Transfer Module provides heat transfer coefficient functions that you can access 
easily in the Convective Heat Flux feature.

Approach 2—Modeling the External Flow

Another approach for simulating the cooled flask is to produce a model that computes the 
convective velocity field around the flask in detail. Before proceeding with a simulation of 
this kind, it is a good idea to try to estimate the Rayleigh number because that number 
influences the choice between assuming laminar flow and applying a turbulence model.

The Rayleigh number describes the ratio between buoyancy and viscous forces in free 
convection problems. It is defined as

with g as the gravity (SI unit: m/s2), κ the thermal diffusivity (SI unit: m2/s), ΔT the 
Temperature difference (SI unit: K), h the height of the convective object (SI unit: m), αp 
the coefficient of thermal expansion (SI unit: 1/K), and ν the kinematic viscosity (SI unit: 
m2/s).

The model’s length scale is the length of the heated fluid’s flow path, in this example 
0.5 m. Notice that this value increases if the modeled flow domain is extended in the 
direction of the flow. ΔT is about 15 K (assuming that the flask surface temperature is 
15 °C above the ambient temperature). Together with the material properties of air at 
atmospheric pressure and T about 25 °C the result is below 1·109, which indicates that 
the flow is still laminar rather than turbulent. Thus, it makes sense to model the flow using 
a physics interface for laminar flow.

B U O Y A N C Y - D R I V E N  F L O W

To model non-isothermal buoyancy-driven flow, the following example implements a 
buoyancy force in the fluid. It provides a generalized Navier-Stokes formulation that takes 
varying density into account as well as the energy equation.

Ra
gαpΔTh3

κν
-------------------------=
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The buoyancy forces are included using the Gravity feature described in the Gravity section 
in the CFD Module User’s Guide.

B O U N D A R Y  C O N D I T I O N S

When solving flow problems numerically, your engineering intuition is crucial in setting 
good boundary conditions. In this problem, the warm flask drives vertical air currents 
along its walls, and they eventually join in a thermal plume above the top of the flask. Air 
is pulled from the surroundings toward the flask where it eventually feeds into the vertical 
flow.

The open boundary condition is a boundary condition for the heat and flow equation and 
can handle incoming flow with ambient temperature and leaving flow with a-priori 
unknown temperature.

You would expect this flow to be quite weak and therefore do not anticipate any significant 
changes in dynamic pressure.

Flow Boundary Conditions
• On the top and right boundaries, the normal stress is zero as an open boundary with 

ambient temperature of 25 °C.

• On the upper-left boundary, the flow domain coincides with the axis of symmetry where 
the Axial Symmetry condition is applied automatically.

• All other boundaries (the flask surface and the bottom horizontal line) are walls where 
you use the No slip condition.

Thermal Boundary Conditions
• The top and right boundaries are the exit and entrance of the flow domain respectively 

where convection dominates; accordingly, use an open boundary condition.

• Again, the top left is described by axial symmetry, which is set by default.

• Assume that the bottom is perfectly insulated.

All other boundaries (the flask surface) have continuity in temperature and flux by default.
7 |  N A T U R A L  C O N V E C T I O N  C O O L I N G  O F  A  V A C U U M  F L A S K



Results and Discussion

Figure 3 shows the temperature distribution in both the flask and the surrounding air. 
However, the temperature results in the solid parts are close to identical for the case of 
modeling with a heat transfer coefficient.

Figure 3: Temperature results for the model including the fluid flow.

One objective of the model is to predict the coffee temperature over time. The plot below 
shows the results of both approaches and one can see that both results produce almost 
exactly the same curve.
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Figure 4: Isothermal domain temperature over time for both approaches.
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A second question concerns how the cooling power is distributed on the flask surface. The 
heat transfer coefficient represents this property. Figure 5 shows a comparison of the 
predicted distribution of h along the height of the flask between the two models.

Figure 5: Heat transfer coefficient along the vertical flask walls. Blue line: modeling approach 
using the heat transfer coefficient library, green line: modeling approach including the fluid 
flow.

Figure 6 depicts the flow of air around the flask calculated from the flow model. This fluid 
flow model does a better job at describing local cooling power.
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One interesting result is the vortex formed above the lid. It reduces the cooling in this 
region.

Figure 6: Fluid velocity for air around the flask.

C O N C L U S I O N S

Using the Convective Heat Flux feature you can easily obtain simulation results. The 
predicted heat transfer coefficient is in the same range as the results from the model that 
includes the correlations, and the total cooling power is almost identical.

However, the predefined heat transfer coefficients do not predict the local effects of air 
flow surrounding the flask. For this purpose, a flow model is more accurate. This means 
that you can use this type of model to create and calibrate functions for heat transfer 
coefficients for your geometries. Once calibrated, the functions allow you to use the first 
approach when solving large-scale and time-dependent models.

Application Library path: Heat_Transfer_Module/Tutorials,
_Forced_and_Natural_Convection/vacuum_flask
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

G E O M E T R Y  1

The geometry sequence for the model is available in a file. If you want to create it from 
scratch yourself, you can follow the instructions in the Geometry Modeling Instructions 
section. Otherwise, insert the geometry sequence as follows:

1 On the Geometry toolbar, click Insert Sequence.

2 Browse to the application’s Application Libraries folder and double-click the file 
vacuum_flask_geom_sequence.mph.

Bézier Polygon 1 (b1)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Bézier 

Polygon 1 (b1).

2 In the Settings window for Bézier Polygon, click Build All Objects.

You should now see the geometry shown in Figure 2.
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D E F I N I T I O N S

In the following section you define selections which will be needed during the model set 
up, for example the boundaries that represent the steel shell of the flask and the boundaries 
that are convectively cooled by the surrounding air.

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Shell in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 9–12, 14, and 17–22 only.

Explicit 2
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Flask, Vertical Walls in the Label text 
field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.
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4 Select Boundaries 15–17 and 22 only.

G L O B A L  D E F I N I T I O N S

Parameters
1 In the Model Builder window, expand the Global Definitions node, then click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Air.

Name Expression Value Description

T_amb 25[degC] 298.15 K Temperature of surrounding 
air

T_coffee 90[degC] 363.15 K Coffee temperature

d_shell 0.5[mm] 5E-4 m Steel-shell thickness

p_amb 1[atm] 1.0133E5 Pa Ambient pressure
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4 Click Add to Component in the window toolbar.

M A T E R I A L S

Air (mat1)
Leave the default geometric entity selection; subsequent materials that you add will 
override air as the material for the domains where it does not apply.

The properties of coffee are almost the same as for water.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Water, liquid.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Water, liquid (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Water, liquid 

(mat2).

2 Select Domain 2 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Nylon.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Nylon (mat3)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Nylon (mat3).

2 Select Domains 4 and 5 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Steel AISI 4340.

3 Click Add to Component in the window toolbar.
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M A T E R I A L S

Steel AISI 4340 (mat4)
1 On the Home toolbar, click Add Material to close the Add Material window.

2 In the Model Builder window, under Component 1 (comp1)>Materials click Steel AISI 4340 

(mat4).

3 In the Settings window for Material, locate the Geometric Entity Selection section.

4 From the Geometric entity level list, choose Boundary.

5 From the Selection list, choose Shell.

Material 5 (mat5)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Foam in the Label text field.

3 Select Domain 1 only.

4 Locate the Material Contents section. In the table, enter the following settings:

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Assuming that the coffee temperature is uniform and depends on the time only, the 
domain can be defined as isothermal domain with the initial coffee temperature.

1 In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids 

(ht).

2 In the Settings window for Heat Transfer in Solids, locate the Physical Model section.

3 Select the Isothermal domain check box.

Define the ambient temperature used in boundary conditions and intial values.

4 Locate the Ambient Settings section. In the Tamb text field, type T_amb.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Initial Values 1.

Property Name Value Unit Property 
group

Thermal conductivity k 0.03 W/(m·K) Basic

Density rho 60 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 200 J/(kg·K) Basic
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2 In the Settings window for Initial Values, choose Ambient temperature (ht) from the T 
list.

Isothermal Domain 1
1 On the Physics toolbar, click Domains and choose Isothermal Domain.

2 Select Domain 2 only.

For the Isothermal Domain Interface boundary condition use a heat flux condition that 
describes a good heat transmission from the coffee to the thin conductive shell 
boundary.

Isothermal Domain Interface 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Isothermal Domain Interface 1.

2 In the Settings window for Isothermal Domain Interface, locate the Isothermal Domain 

Interface section.

3 From the Interface type list, choose Convective heat flux.

4 In the h text field, type 100.

Initial Values 2
1 On the Physics toolbar, click Domains and choose Initial Values.

2 Select Domain 2 only.

3 In the Settings window for Initial Values, type T_coffee in the T text field.

The steel walls of the flask are represented by a special boundary condition for highly 
conductive layers:

Thin Layer 1
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 In the Settings window for Thin Layer, locate the Boundary Selection section.

3 From the Selection list, choose Shell.

4 Locate the Thin Layer section. From the Layer type list, choose Thermally thin 

approximation.

5 In the ds text field, type d_shell.

To allow for cooling to the surrounding, add heat flux conditions that use appropriate 
heat transfer coefficients from a library.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.
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2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Flask, Vertical Walls.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 From the Heat transfer coefficient list, choose External natural convection.

6 In the L text field, type height.

7 From the Text list, choose Ambient temperature (ht).

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundary 8 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 From the Heat transfer coefficient list, choose External natural convection.

6 From the list, choose Horizontal plate, upside.

7 In the L text field, type radius.

8 From the Text list, choose Ambient temperature (ht).

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Extra fine.

4 Click Build All.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 From the Time unit list, choose h.

4 In the Times text field, type range(0,0.1,10).

Constrict the initial time step to capture the strong gradient between the initial coffee 
temperature and the initial flask temperature.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.
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2 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Time-Dependent Solver 1.

3 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

4 Locate the Time Stepping section. Select the Initial step check box.

5 In the associated text field, type 10[s].

6 On the Study toolbar, click Compute.

R E S U L T S

Temperature, 3D (ht)
A 3D temperature plot and an isothermal contour plot are produced by default. To display 
the temperatures in degrees Celsius, you can edit these existing plots:

Surface
1 In the Model Builder window, expand the Temperature, 3D (ht) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

4 On the Temperature, 3D (ht) toolbar, click Plot.

Contour
1 In the Model Builder window, expand the Isothermal Contours (ht) node, then click 

Contour.

2 In the Settings window for Contour, locate the Expression section.

3 From the Unit list, choose degC.

4 On the Isothermal Contours (ht) toolbar, click Plot.

Approach 2 - Modeling the External Flow

The second modeling approach is done within the same MPH-file. This way the results 
from both approaches can be compared directly. Add a second model as follows:

1 On the Home toolbar, click Add Component and choose 2D Axisymmetric.

G E O M E T R Y  2

In the Model Builder window, under Component 2 (comp2) click Geometry 2.
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A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Heat Transfer>Conjugate Heat Transfer>Laminar Flow.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
Study 1.

5 Click Add to Component in the window toolbar.

H E A T  TR A N S F E R  2  ( H T 2 )

On the Home toolbar, click Add Physics to close the Add Physics window.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies.

4 In the Select Study tree, select Preset Studies>Time Dependent.

5 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Heat Transfer in Solids (ht) interface.

This way, the new study solves for the coupled heat transfer and laminar flow interfaces 
only.

6 Click Add Study in the window toolbar.

S T U D Y  2

Step 1: Time Dependent
On the Home toolbar, click Add Study to close the Add Study window.

G E O M E T R Y  2

The flask’s geometry is already present in Component 1. Import the geometry sequence 
from above as follows:

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 From the Source list, choose Geometry sequence.

4 From the Geometry list, choose Geometry 1.
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5 Click Import.

In this approach, you model the fluid flow explicitly, so you need to add a flow domain 
to the model.

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.1[m].

4 In the Height text field, type 0.5[m].

5 Click Build All Objects.

6 Click the Zoom Extents button on the Graphics toolbar.

D E F I N I T I O N S

Define the same selections as before, which you can use during the model setup and for 
comparing the results of this approach to the first one.

Explicit 3
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Shell in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 11–14, 16, 19, and 22–26 only.

Explicit 4
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Flask, Vertical Walls in the Label text 
field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 17–19 and 26 only.

M A T E R I A L S

You have added the materials in Model 1 already, you can now choose them from the 
Recent Materials folder in the Add Material window easily.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Recent Materials>Air.
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4 Click Add to Component in the window toolbar.

C O M P O N E N T  1  ( C O M P 1 )

In the Model Builder window, expand the Component 1 (comp1) node.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Recent Materials>Water, liquid.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Water, liquid (mat7)
1 In the Model Builder window, expand the Component 1 (comp1)>Materials node, then 

click Component 2 (comp2)>Materials>Water, liquid (mat7).

2 Select Domain 2 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Recent Materials>Nylon.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Nylon (mat8)
1 In the Model Builder window, under Component 2 (comp2)>Materials click Nylon (mat8).

2 Select Domains 4 and 6 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Recent Materials>Steel AISI 4340.

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Steel AISI 4340 (mat9)
1 On the Home toolbar, click Add Material to close the Add Material window.
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2 In the Model Builder window, under Component 2 (comp2)>Materials click Steel AISI 4340 

(mat9).

3 In the Settings window for Material, locate the Geometric Entity Selection section.

4 From the Geometric entity level list, choose Boundary.

5 From the Selection list, choose Shell.

Material 10 (mat10)
1 In the Model Builder window, under Component 2 (comp2) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Foam in the Label text field.

3 Select Domain 1 only.

4 Locate the Material Contents section. In the table, enter the following settings:

After setting up the physics interfaces, the warning for missing material, marked with 
red crosses in the materials node, will disappear.

L A M I N A R  F L O W  ( S P F )

1 In the Model Builder window, under Component 2 (comp2) click Laminar Flow (spf).

2 Select Domain 5 only.

3 In the Settings window for Laminar Flow, locate the Physical Model section.

4 From the Compressibility list, choose Weakly compressible flow.

5 Select the Include gravity check box.

6 Locate the Domain Selection section. Click Create Selection.

7 Locate the Physical Model section. Find the Reference values subsection. In the Tref text 
field, type T_amb.

8 In the Create Selection dialog box, type Air in the Selection name text field.

9 Click OK.

Property Name Value Unit Property 
group

Thermal conductivity k 0.03 W/(m·K) Basic

Density rho 60 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 200 J/(kg·K) Basic
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H E A T  TR A N S F E R  2  ( H T 2 )

On the Physics toolbar, click Laminar Flow (spf) and choose Heat Transfer 2 (ht2).

1 In the Model Builder window, under Component 2 (comp2) click Heat Transfer 2 (ht2).

2 In the Settings window for Heat Transfer, locate the Ambient Settings section.

3 In the Tamb text field, type T_amb.

Fluid 1
The interface provides nodes for the solid and fluid domain by default and the remaining 
step is to assign the surrounding air domain to the Fluid Properties node. Because the 
density depends on the temperature and the pressure, choose the calculated pressure as 
input for this material property.

1 In the Model Builder window, under Component 2 (comp2)>Heat Transfer 2 (ht2) click 
Fluid 1.

2 In the Settings window for Fluid, locate the Domain Selection section.

3 From the Selection list, choose Air.

To get a good initial guess for the solver, set the initial value for the temperature to the 
ambient temperature.

Initial Values 1
1 In the Model Builder window, under Component 2 (comp2)>Heat Transfer 2 (ht2) click 

Initial Values 1.

2 In the Settings window for Initial Values, choose Ambient temperature (ht2) from the T2 
list.

L A M I N A R  F L O W  ( S P F )

On the Physics toolbar, click Heat Transfer 2 (ht2) and choose Laminar Flow (spf).

In the Model Builder window, under Component 2 (comp2) click Laminar Flow (spf).

Open Boundary 1
1 On the Physics toolbar, click Boundaries and choose Open Boundary.

2 Select Boundaries 10 and 21 only.

H E A T  TR A N S F E R  2  ( H T 2 )

1 In the Model Builder window, under Component 2 (comp2) click Heat Transfer 2 (ht2).

2 In the Settings window for Heat Transfer, locate the Physical Model section.

3 Select the Isothermal domain check box.
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Isothermal Domain 1
1 On the Physics toolbar, click Domains and choose Isothermal Domain.

2 Select Domain 2 only.

Isothermal Domain Interface 1
1 In the Model Builder window, under Component 2 (comp2)>Heat Transfer 2 (ht2) click 

Isothermal Domain Interface 1.

2 In the Settings window for Isothermal Domain Interface, locate the Isothermal Domain 

Interface section.

3 From the Interface type list, choose Convective heat flux.

4 In the h text field, type 100.

Initial Values 2
1 On the Physics toolbar, click Domains and choose Initial Values.

2 Select Domain 2 only.

3 In the Settings window for Initial Values, type T_coffee in the T2 text field.

Solid 1
1 In the Model Builder window, under Component 2 (comp2)>Heat Transfer 2 (ht2) click 

Solid 1.

2 In the Settings window for Solid, locate the Model inputs section.

3 Click Make All Model Inputs Editable in the upper-right corner of the section. Locate the 
Model Inputs section. From the T list, choose Temperature (ht2).

Thin Layer 1
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 In the Settings window for Thin Layer, locate the Boundary Selection section.

3 From the Selection list, choose Shell.

4 Locate the Thin Layer section. From the Layer type list, choose Thermally thin 

approximation.

5 In the ds text field, type d_shell.

Open Boundary 1
1 On the Physics toolbar, click Boundaries and choose Open Boundary.

2 Select Boundaries 10 and 21 only.

3 In the Settings window for Open Boundary, locate the Open Boundary section.

4 In the T0 text field, type T_amb.
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M E S H  2

Use a finer mesh to get a good resolution of the flow field.

1 In the Model Builder window, under Component 2 (comp2) click Mesh 2.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Finer.

4 Click Build All.

S T U D Y  2

Large differences of the initial values T_coffee and T_amb can cause numerical instabilities 
if time steps become too large. Forcing the solver to use small time steps in the beginning 
until the strong gradients are blurred out helps to overcome this problem. To do so, add 
two time dependent solver steps in one study. Set up the time intervals as follows:

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 2 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 From the Time unit list, choose h.

4 In the Times text field, type range(0,0.1,10)[s] range(0.1,0.1,10).

Solution 2 (sol2)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 2 (sol2) node, then click 
Time-Dependent Solver 1.

3 In the Settings window for Time-Dependent Solver, locate the Time Stepping section.

4 From the Steps taken by solver list, choose Strict.

5 On the Study toolbar, click Compute.

R E S U L T S

Temperature, 3D (ht2)
Change the default temperature plot to use degrees Celsius as quantity unit (as in 
Figure 3).

Surface
1 In the Model Builder window, expand the Temperature, 3D (ht2) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.
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3 From the Unit list, choose degC.

4 Click the Zoom Extents button on the Graphics toolbar.

Velocity (spf) 1
The velocity field is automatically shown in its dedicated plot group (see Figure 6).

Create a 2D plot of the velocity streamlines.

2D Plot Group 8
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Velocity, Streamlines in the Label 
text field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 2 (3) (sol2).

4 From the Time (h) list, choose 10.

Streamline 1
1 Right-click Velocity, Streamlines and choose Streamline.

2 In the Settings window for Streamline, click Replace Expression in the upper-right corner 
of the Expression section. From the menu, choose Model>Component 2>Laminar Flow>

Velocity and pressure>u,w - Velocity field.

3 Locate the Streamline Positioning section. From the Positioning list, choose Magnitude 

controlled.

Color Expression 1
1 Right-click Results>Velocity, Streamlines>Streamline 1 and choose Color Expression.

2 In the Settings window for Color Expression, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Model>Component 2>Laminar 

Flow>Velocity and pressure>spf.U - Velocity magnitude.

3 On the Velocity, Streamlines toolbar, click Plot.
27 |  N A T U R A L  C O N V E C T I O N  C O O L I N G  O F  A  V A C U U M  F L A S K



4 Click the Zoom Extents button on the Graphics toolbar.

To compare both approaches, evaluate the coffee temperature over time and use a 1D 
Plot to visualize the results. The solutions are stored under the Data Sets node and for 
each plot you can choose which data set should be used.

1D Plot Group 9
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Coffee Temperature vs Time in the 
Label text field.

Global 1
1 On the Coffee Temperature vs Time toolbar, click Global.

2 In the Settings window for Global, click Replace Expression in the upper-right corner of 
the y-axis data section. From the menu, choose Model>Component 1>Heat Transfer in 

Solids>Temperature>ht.id1.T - Isothermal domain temperature.

3 Locate the y-Axis Data section. In the table, enter the following settings:

Expression Unit Description

ht.id1.T degC Isothermal domain temperature - flow not 
computed
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4 Click to expand the Coloring and style section. Locate the Coloring and Style section. Find 
the Line markers subsection. From the Marker list, choose Cycle.

5 From the Positioning list, choose In data points.

Coffee Temperature vs Time
In the Model Builder window, under Results click Coffee Temperature vs Time.

Global 2
1 On the Coffee Temperature vs Time toolbar, click Global.

2 In the Settings window for Global, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (3) (sol2).

4 Click Replace Expression in the upper-right corner of the y-axis data section. From the 
menu, choose Model>Component 2>Heat Transfer 2>Temperature>ht2.id1.T - Isothermal 

domain temperature.

5 Locate the y-Axis Data section. In the table, enter the following settings:

6 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose None.

7 Find the Line markers subsection. From the Marker list, choose Cycle.

8 From the Positioning list, choose In data points.

9 On the Coffee Temperature vs Time toolbar, click Plot.

To compare the heat transfer coefficients for the two modeling approaches (Figure 4), 
do the following:

1D Plot Group 10
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Heat Transfer Coefficient in the 
Label text field.

3 Locate the Data section. From the Time selection list, choose Last.

4 Click to expand the Legend section. From the Position list, choose Upper left.

Line Graph 1
1 On the Heat Transfer Coefficient toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Selection section.

3 From the Selection list, choose Flask, Vertical Walls.

Expression Unit Description

ht2.id1.T degC Isothermal domain temperature - flow computed
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4 Locate the y-Axis Data section. In the Expression text field, type ht.hf1.h.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type z.

7 Click to expand the Legends section. Select the Show legends check box.

8 From the Legends list, choose Manual.

9 In the table, enter the following settings:

Heat Transfer Coefficient
In the Model Builder window, under Results click Heat Transfer Coefficient.

Line Graph 2
1 On the Heat Transfer Coefficient toolbar, click Line Graph.

2 In the Settings window for Line Graph, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (3) (sol2).

4 From the Time selection list, choose Last.

5 Locate the Selection section. From the Selection list, choose Flask, Vertical Walls.

6 Locate the y-Axis Data section. In the Expression text field, type abs(ht2.ntflux)/
(T2-T_amb).

7 Locate the x-Axis Data section. From the Parameter list, choose Expression.

8 In the Expression text field, type z.

9 Locate the Legends section. Select the Show legends check box.

10 From the Legends list, choose Manual.

11 In the table, enter the following settings:

Heat Transfer Coefficient
1 In the Model Builder window, under Results click Heat Transfer Coefficient.

2 On the Heat Transfer Coefficient toolbar, click Plot.

Legends

Heat transfer coefficient, no flow

Legends

Calculated heat transfer coefficient, with flow
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Geometry Modeling Instructions

If you wish to create the geometry yourself, follow these steps.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Bézier Polygon 1 (b1)
1 On the Geometry toolbar, click Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the Polygon Segments section.

3 Find the Added segments subsection. Click Add Linear.

4 Find the Control points subsection. In row 2, set r to 1.5*radius.

5 Find the Added segments subsection. Click Add Linear.

6 Find the Control points subsection. In row 2, set z to 0.68*height.

7 Find the Added segments subsection. Click Add Quadratic.

8 Find the Control points subsection. In row 2, set z to 0.751*height.

9 In row 3, set r to 1.04*radius.

10 In row 3, set z to 0.80*height.

11 Find the Added segments subsection. Click Add Quadratic.

12 Find the Control points subsection. In row 2, set r to 0.88*radius.

13 In row 2, set z to 0.82*height.

14 In row 3, set r to 0.66*radius.

15 In row 3, set z to 0.84*height.

16 Find the Added segments subsection. Click Add Linear.

17 Find the Control points subsection. In row 2, set z to 0.96*height.

Name Expression Value Description

height 380[mm] 0.38 m Flask height

radius 40[mm] 0.04 m Bottleneck radius
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18 Find the Added segments subsection. Click Add Linear.

19 Find the Control points subsection. In row 2, set r to 0.3*radius.

20 Find the Added segments subsection. Click Add Linear.

21 Find the Control points subsection. In row 2, set z to 0.83*height.

22 Find the Added segments subsection. Click Add Linear.

23 Find the Control points subsection. In row 2, set z to 0.79*height.

24 Find the Added segments subsection. Click Add Quadratic.

25 Find the Control points subsection. In row 2, set r to 0.56*radius.

26 In row 2, set z to 0.78*height.

27 In row 3, set r to 0.73*radius.

28 In row 3, set z to 0.75*height.

29 Find the Added segments subsection. Click Add Quadratic.

30 Find the Control points subsection. In row 2, set r to 0.93*radius.

31 In row 2, set z to 0.72*height.

32 In row 3, set r to 0.93*radius.

33 In row 3, set z to 0.68*height.

34 Find the Added segments subsection. Click Add Linear.

35 Find the Control points subsection. In row 2, set z to 0.12*height.

36 Find the Added segments subsection. Click Add Quadratic.

37 Find the Control points subsection. In row 2, set z to 0.036*height.

38 In row 3, set r to 0*radius.

39 In row 3, set z to 0.036*height.

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 1.04*radius.

4 In the Height text field, type 0.16*height.

5 Locate the Position section. In the z text field, type 0.83*height.

Rectangle 2 (r2)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.
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3 In the Width text field, type 0.74*radius.

4 In the Height text field, type 0.13*height.

5 Locate the Position section. In the r text field, type 0.3*radius.

6 In the z text field, type 0.83*height.

Difference 1 (dif1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Difference.

2 Select the object r1 only.

3 In the Settings window for Difference, locate the Difference section.

4 Find the Objects to subtract subsection. Select the Active toggle button.

5 Select the object r2 only.

Bézier Polygon 2 (b2)
1 On the Geometry toolbar, click Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the Polygon Segments section.

3 Find the Added segments subsection. Click Add Quadratic.

4 Find the Control points subsection. In row 1, set r to 1.04*radius.

5 In row 1, set z to 0.80*height.

6 In row 2, set r to 0.88*radius.

7 In row 2, set z to 0.82*height.

8 In row 3, set r to 0.66*radius.

9 In row 3, set z to 0.84*height.

10 Find the Added segments subsection. Click Add Linear.

11 Find the Control points subsection. In row 2, set z to 0.96*height.

12 Find the Added segments subsection. Click Add Linear.

13 Find the Control points subsection. In row 2, set r to 1.04*radius.

14 Find the Added segments subsection. Click Add Linear.

15 Find the Control points subsection. In row 2, set z to 0.80*height.

Bézier Polygon 3 (b3)
1 On the Geometry toolbar, click Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the Polygon Segments section.

3 Find the Added segments subsection. Click Add Linear.

4 Find the Control points subsection. In row 1, set r to 0.3*radius.
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5 In row 1, set z to 0.83*height.

6 In row 2, set r to 0.3*radius.

7 In row 2, set z to 0.79*height.

8 Find the Added segments subsection. Click Add Quadratic.

9 Find the Control points subsection. In row 2, set r to 0.56*radius.

10 In row 2, set z to 0.78*height.

11 In row 3, set r to 0.73*radius.

12 In row 3, set z to 0.75*height.

13 Find the Added segments subsection. Click Add Linear.

14 Find the Control points subsection. In row 2, set r to 0*radius.

15 Find the Added segments subsection. Click Add Linear.

16 Find the Control points subsection. In row 2, set z to 0.83*height.

Bézier Polygon 4 (b4)
1 On the Geometry toolbar, click Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the Polygon Segments section.

3 Find the Added segments subsection. Click Add Linear.

4 Find the Control points subsection. In row 1, set z to 0.75*height.

5 In row 2, set z to 0.036*height.

Convert to Solid 1 (csol1)
On the Geometry toolbar, click Conversions and choose Convert to Solid.

Form Union (fin)
Click Build All.
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The computation of view factors is central when performing heat transfer simulations 
using the radiosity method to account for surface-to-surface radiation. This benchmark 
demonstrates how to compute geometrical view factors for two concentric spheres that 
emit and receive radiation from each other. It compares simulation results to exact 
analytical values.

Introduction

The surface-to-surface radiation method in the Heat Transfer module relies on the 
radiosity method. When surface-to-surface radiation is activated, operators are available to 
compute the view factors between diffuse surfaces that irradiate each other. For some 
standard configurations one can determine the view factors analytically, but in engineering 
applications this is rarely possible. A benchmark example that compares exact analytical 
values with simulation results shows the accuracy of the numerical method. Here, two 
concentric spheres are used, for which the analytical view factors are known.

Figure 1: Model geometry.
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Model Definition

The model consists of two concentric radiating spheres (Figure 1) acting as perfect 
emitters (surface emissivities both equal to 1). The radiation direction of each sphere is 
such that they irradiate each other.

A N A L Y T I C A L  V I E W  F A C T O R S

A detailed introduction on view factors is given in (Ref. 1). An arbitrary view factor F1 → 2 
is defined as the proportion of radiation leaving surface S1 and intercepting surface S2, 
that is

If the radiosity is the same on each surface, it only depends on the geometrical 
configuration and thus can be calculated from geometrical properties. For two concentric 
spheres, labeled ext for the outer sphere and int for the inner sphere, the view factors are:

Refer to Table 1 for numerical values of these quantities.

V I E W  F A C T O R  C O M P U T A T I O N  I N  C O M S O L  M U L T I P H Y S I C S

The view factor computation is performed at each evaluation point on the boundaries. A 
boundary has an up and a down side and both can be exposed to radiation. In this model 
the outer sphere radiates inwards, which is the downward direction and the inner sphere 
radiates outwards which is the upward direction. Two operators are available for evaluation 
of the mutual surface irradiation. These are:

• radopu(expression_upside,expression_downside)

• radopd(expression_upside,expression_downside)

Both are available on all boundaries where surface-to-surface features are active. The 
radopu(,) and radopd(,) operators perform the computation on the upside and 

F1 2→
Radiation leaving S1 and intercepting S2

Total radiation leaving S1
----------------------------------------------------------------------------------------------------------=

Fext ext→ 1
Rint
Rext
------------ 
 

2
–=

Fext int→
Rint
Rext
------------ 
 

2
=

Fint int→ 0=

Fint ext→ 1=
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downside of the boundary where they are evaluated. The expression_upside and 
expression_downside arguments are the radiosity expression on the upside and 
downside of the boundaries that irradiate the boundary where the operators are evaluated.

To compute the geometrical view factor, e.g. Fext → int, in COMSOL Multiphysics, the 
following integration needs to be defined:

where Sint and Sext denote interior and exterior surfaces, Aint and Aext are corresponding 
surface areas.

The integration at the numerator is defined over the inner sphere, which radiates only on 
the upside of its surface. Hence, radopd(,) evaluates to zero and the integrand reduces 
to radopu(0,expression_upside). Moreover since the outer sphere radiates only on 
the downside of its surface the expression_downside argument should be ext.

Results and Discussion

The view factors computed with COMSOL Multiphysics are listed in Table 1 together 
with analytical values and absolute errors.

In this table, analytical and computed values are slightly different but rounded to 
hundredths. The very small errors are listed in the last column and reflect accurate results 
of the view factors provided by the simulation.

Reference

1. Michael F. Modest, Radiative Heat Transfer, 3rd ed., Academic Press, 2013

TABLE 1:  VIEW FACTOR COMPUTATION

VIEW FACTOR ANALYTICAL VALUE COMPUTED VALUE ERROR

Fint → int 0 0 0

Fint → ext 1 1 3.25·10-5

Fext → ext 0.91 0.91 2.93·10-6

Fext → int 0.09 0.09 5.35·10-10

Fext int→

radopu 0 ext,( ) sd
Sint


Aext
-------------------------------------------------------------=
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Application Library path: Heat_Transfer_Module/Verification_Examples/
view_factor

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

You are only interested in the view factors, hence Surface-to-Surface Radiation is the 
only needed interface.

2 In the Select Physics tree, select Heat Transfer>Radiation>Surface-to-Surface Radiation 

(rad).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Define the radii of the spheres and the analytical values for the view factors as parameters.

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

r_int 0.3[m] 0.3 m Radius, interior 
sphere

r_ext 1[m] 1 m Radius, exterior 
sphere
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G E O M E T R Y  1

No domain information are required, define the geometry as surface objects.

Sphere 1 (sph1)
1 On the Geometry toolbar, click Sphere.

2 In the Settings window for Sphere, locate the Object Type section.

3 From the Type list, choose Surface.

4 Locate the Size section. In the Radius text field, type r_int.

Create a selection of this sphere to easily access its entities throughout the modeling 
process.

5 Locate the Selections of Resulting Entities section. Click New.

6 In the New Cumulative Selection dialog box, type Inner sphere in the Name text field.

7 Click OK.

Sphere 2 (sph2)
1 On the Geometry toolbar, click Sphere.

2 In the Settings window for Sphere, locate the Object Type section.

3 From the Type list, choose Surface.

4 Locate the Size section. In the Radius text field, type r_ext.

5 Locate the Selections of Resulting Entities section. Click New.

6 In the New Cumulative Selection dialog box, type Outer sphere in the Name text field.

F_ext_ext 1-(r_int/r_ext)^2 0.91 Analytical view 
factor from exterior 
sphere to exterior 
sphere

F_ext_int (r_int/r_ext)^2 0.09 Analytical view 
factor from exterior 
sphere to interior 
sphere

F_int_int 0 0 Analytical view 
factor from interior 
sphere to interior 
sphere

F_int_ext 1 1 Analytical view 
factor from interior 
sphere to exterior 
sphere

Name Expression Value Description
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7 Click OK.

8 In the Settings window for Sphere, click Build All Objects.

9 Click the Go to Default 3D View button on the Graphics toolbar.

Create a new view which hides one of the front boundaries so that you can look inside the 
outer sphere.

D E F I N I T I O N S

In the Model Builder window, under Component 1 (comp1) right-click Definitions and choose 
View.

Hide for Geometry 1
On the View 2 toolbar, click Hide for Geometry.

View 2
1 In the Settings window for Hide for Geometry, locate the Selection section.

2 From the Geometric entity level list, choose Boundary.

3 On the object sph2, select Boundary 2 only.

G E O M E T R Y  1

Add a material to the boundaries to define their emissivities.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, type Blackbody in the Label text field.

2 Click to expand the Material properties section. Locate the Material Properties section. 
In the Material properties tree, select Basic Properties>Surface Emissivity.

3 Click Add to Material.

4 Locate the Material Contents section. In the table, enter the following settings:

S U R F A C E - T O - S U R F A C E  R A D I A T I O N  ( R A D )

Diffuse Surface 1
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

Property Name Value Unit Property group

Surface emissivity epsilon_rad 1 1 Basic
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2 In the Settings window for Diffuse Surface, locate the Boundary Selection section.

3 From the Selection list, choose Inner sphere.

4 Locate the Radiation Settings section. From the Radiation direction list, choose Positive 

normal direction.

Diffuse Surface 2
1 On the Physics toolbar, click Boundaries and choose Diffuse Surface.

2 In the Settings window for Diffuse Surface, locate the Boundary Selection section.

3 From the Selection list, choose Outer sphere.

4 Locate the Radiation Settings section. From the Radiation direction list, choose Negative 

normal direction.

Define new variables and integration operators to evaluate the view factors directly after 
running the study. First, define variables that are used to identify the surfaces.

D E F I N I T I O N S

In the Model Builder window, under Component 1 (comp1) right-click Definitions and choose 
Variables.

Variables 1
1 In the Settings window for Variables, type Identifiers, Inner Sphere in the Label 

text field.

2 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

3 From the Selection list, choose Inner sphere.

4 Locate the Variables section. In the table, enter the following settings:

Variables 2
1 In the Model Builder window, right-click Definitions and choose Variables.

2 In the Settings window for Variables, type Identifiers, Outer Sphere in the Label 
text field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose Outer sphere.

Name Expression Unit Description

ext 0 Exterior surface indicator

int 1 Interior surface indicator
8 |  V I E W  F A C T O R  C O M P U T A T I O N



5 Locate the Variables section. In the table, enter the following settings:

Now, define integration coupling operators for both spheres.

Integration 1 (intop1)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, type Integration, Inner Sphere in the Label 
text field.

3 In the Operator name text field, type intop_int.

4 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

5 From the Selection list, choose Inner sphere.

Integration 2 (intop2)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, type Integration, Outer Sphere in the Label 
text field.

3 In the Operator name text field, type intop_ext.

4 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

5 From the Selection list, choose Outer sphere.

Adjust the mesh size for both spheres manually to get approximately the same number of 
elements on each sphere. This is an efficient mesh for view factor computation.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
More Operations>Free Triangular.

Free Triangular 1
1 In the Settings window for Free Triangular, locate the Boundary Selection section.

2 From the Selection list, choose All boundaries.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Triangular 1 and choose Size.

Name Expression Unit Description

ext 1 Exterior surface indicator

int 0 Interior surface indicator
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2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Selection list, choose Inner sphere.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type r_int/5.

Free Triangular 1
Right-click Free Triangular 1 and choose Size.

Size 2
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Selection list, choose Outer sphere.

3 Locate the Element Size section. Click the Custom button.

4 Locate the Element Size Parameters section. Select the Maximum element size check box.

5 In the associated text field, type r_ext/5.

6 Click Build All.

The view factors are computed automatically, before the actual study runs. To evaluate the 
geometrical view factors, it is sufficient to obtain the initial values.
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S T U D Y  1

1 In the Settings window for Study, locate the Study Settings section.

2 Clear the Generate default plots check box.

Study 1
On the Study toolbar, click Get Initial Value.

R E S U L T S

Global Evaluation 1
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, type View Factors in the Label text field.

3 Locate the Expressions section. In the table, enter the following settings:

Global Evaluation 2
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, type Absolute Error, View Factors 
in the Label text field.

3 Locate the Expressions section. In the table, enter the following settings:

Expression Unit Description

intop_int(comp1.rad.radopu(i
nt,0))/intop_int(1)

1 Interior to interior view 
factor

intop_ext(comp1.rad.radopd(i
nt,0))/intop_int(1)

1 Interior to exterior view 
factor

intop_ext(comp1.rad.radopd(0
,ext))/intop_ext(1)

1 Exterior to exterior view 
factor

intop_int(comp1.rad.radopu(0
,ext))/intop_ext(1)

1 Exterior to interior view 
factor

Expression Unit Description

abs(intop_int(comp1.rad.rado
pu(int,0))/
intop_int(1)-F_int_int)

1 Absolute error, interior to 
interior view factor

abs(intop_ext(comp1.rad.rado
pd(int,0))/
intop_int(1)-F_int_ext)

1 Absolute error, interior to 
exterior view factor
11 |  V I E W  F A C T O R  C O M P U T A T I O N



4 On the Results toolbar, click Evaluate All.

TA B L E

1 Go to the Table window.

The results are displayed in the Table window.

abs(intop_ext(comp1.rad.rado
pd(0,ext))/
intop_ext(1)-F_ext_ext)

1 Absolute error, exterior to 
exterior view factor

abs(intop_int(comp1.rad.rado
pu(0,ext))/
intop_ext(1)-F_ext_int)

1 Absolute error, exterior to 
interior view factor

Expression Unit Description
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Introduction

During the design of a building, environmental issues have gained considerable influence 
in the entire project. One of the first concerns is to improve thermal performances. In this 
process, simulation software provide key tools for modeling thermal losses and 
performances in the building

The international standard ISO 10077-2:2012 (Ref. 1) deals with thermal performances 
of windows, doors, and shutters. It provides computed values of the thermal characteristics 
of frame profiles in order to validate a simulation software.

COMSOL Multiphysics successfully passes the entire benchmark. This document 
describes two test cases of ISO 10077-2:2012 related to the glazing influence on thermal 
performances of a window. Other test cases from this standard are available in the 
following applications:

• Thermal Performances of Windows

• Thermal Performances of Roller Shutters

Figure 1: Geometry of the window and cross-section view.

Model Definition

On each test case, a window section separates a hot internal side from a cold external side. 
The window frame is the same but in the first application, an insulation panel replaces the 
traditional glazing. This traditional glazing is tackled in the second application. After 
solving a model, two quantities are calculated and compared to the normative values:

• The thermal conductance between internal and external sides

• The thermal transmittance of the frame is calculated
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A I R  C A V I T I E S

A window frame contains many cavities. The purpose is to ensure thermal insulation. 
According to the standard, cavities are modeled in different ways depending on their 
shapes.

The heat flow rate in cavities is represented by an equivalent thermal conductivity keq, 
which includes the heat flow by conduction, convection, and radiation. It also depends on 
the geometry of the cavity and on the adjacent materials. The definition of keq is detailed 
in the next paragraphs.

Cavities are divided into three types:

• unventilated cavities, completely closed or connected either to the exterior or to the 
interior by a slit with a width not exceeding 2 mm;

• slightly ventilated cavities, connected either to the exterior or to the interior by a slit 
greater than 2 mm but not exceeding 10 mm;

• well-ventilated cavities, corresponding to a configuration not covered by one of the 
two preceding types, it is assumed that the whole surface is exposed to the environment 
so that boundary conditions are applied to (see the Boundary conditions section below 
for more information).

Unventilated Rectangular Cavity
For an unventilated rectangular cavity, the equivalent thermal conductivity is defined by:

where d is the cavity dimension in the heat flow rate direction, and R is the cavity thermal 
resistance given by:

Here, ha is the convective heat transfer coefficient, and hr is the radiative heat transfer 
coefficient. These coefficients are defined by:

keq
d
R
----=

R 1
ha hr+
------------------=

ha

C1
d

------- if b 5 mm≤

max
C1
d

------- C2 TΔ 1K( )⁄( )1 3⁄, 
  otherwise









=
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where:

• C1 = 0.025 W/(m·K)

• C2 = 0.73 W/(m2·K)

• ΔT is the maximum surface temperature difference in the cavity

• σ = 5.67·10-8 W/(m2·K4) is the Stefan-Boltzmann constant

• Tm is the average temperature on the boundaries of the cavity

• E is the intersurface emittance, defined by:

• ε1 and ε2 are the surface emissivities (both are equal to 0.90 in this model)

• F is the view factor of the rectangular section, defined by:

• d is the cavity dimension in the heat flow rate direction

• b is the cavity dimension perpendicular to the heat flow rate direction

Slightly Ventilated Rectangular Cavities
For a slightly ventilated cavity, the equivalent thermal conductivity is twice that of an 
unventilated cavity of the same size.

B O U N D A R Y  C O N D I T I O N S

The heat flux conditions for internal and external sides are given by the Newton’s law of 
cooling:

where Text is the exterior temperature (Text = Ti = 20 °C for the internal side and 
Text = Te = 0 °C for the external side). The standard defines thermal surface resistance, Rs, 
which is related to the heat transfer coefficient, h, by:

hr 4σTm
3 EF=

E 1
1
ε1
----- 1

ε2
----- 1–+

---------------------------=

F 1
2
--- 1 d

b
---– 1 d

b
--- 
  2

++ 
 =

n k– T∇( )⋅– h Text T–( )=

h 1
Rs
------=
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Internal and external thermal surface resistances are not equal. Moreover, on boundaries 
linked to the internal side, an increased thermal resistance is used for the edges. Figure 2 
explains how to determine boundaries where it should be applied.

Figure 2: Protected boundaries.

If d is greater than 30 mm, b is set to 30 mm. Otherwise, b = d is chosen. Furthermore, 
two boundaries are considered as adiabatic: the boundary in contact with the wall and the 
end of the insulation panel or glazing.

D E S C R I P T I O N  O F  T H E  T W O  A P P L I C A T I O N S

Figure 3 and Figure 4 depict the geometry of each application but only a part of the 
insulation panel or glazing is represented. Unventilated cavities are red-numbered while 
slightly ventilated cavities are green-numbered. Boundaries with an increased thermal 
resistance are represented with bold black lines. Adiabatic boundaries in contact with the 
wall are represented with a striped rectangle.

Application 1: Wood Frame with an Insulation Panel
The first application studies the heat conduction in the wood frame section with an 
insulation panel. The frame section is made of two wood blocks with a low thermal 
conductivity of 0.13 W/(m·K). In order to make the contact between these two blocks 
and to waterproof the window, two ethylene propylene diene monomer (EPDM) gaskets 
are used. Two other EPDM blocks are arranged on both sides of the insulation panel. The 
insulation panel has a very low thermal conductivity of 0.035 W/(m·K).

b = d

d < 30 mm

b = 30 mm

d > 30 mm
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Two cavities are completely closed and are considered as unventilated. The third one is 
considered as slightly ventilated.

Figure 3: Geometry of the wood frame with an insulation panel.

Application 2: Wood Frame with a Traditional Glazing
The glazing is made of two glass panels with a thermal conductivity of 1.00 W/(m·K). On 
the frame side of the glazing, a structure made of aluminum, polysulfide, and silica gel is 
used to block the glass blocks. Their thermal conductivities are 160 W/(m·K), 0.40 W/
(m·K), and 0.13 W/(m·K), respectively. The space between the glass panels is filled with 
a gas whose thermal conductivity is 0.034 W/(m·K) (so this space is not considered as a 
traditional air cavity).

Interior

Exterior

Soft wood

EPDM

Insulation panel
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Figure 4: Geometry of the wood frame with a glazing.

Results and Discussion

TE M P E R A T U R E  P R O F I L E S

Figure 5 and Figure 6 show the temperature profiles for each application.

Interior

Exterior

Soft wood

EPDM

Filling gas

Polysulfide

Aluminum

Glass

Silica gel

Polyamide
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Figure 5: Temperature profile with the insulation panel.

Figure 6: Temperature distribution with glazing.
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Q U A N T I T I E S  O F  I N T E R E S T

The quantities of interest are the following:

• The thermal conductance of the entire section L2D given by:

where φ is the heat flow rate through the window (in W/m), Te = 0 °C is the external 
temperature and Ti = 20 °C is the internal temperature.

• The thermal transmittance of the frame Uf defined by:

where bp is the visible width of the panel expressed in meters, bf is the projected width 
of the frame section expressed in meters and Up is the thermal transmittance of the 
central area of the panel expressed in W/(m2·K).

• The linear thermal transmittance of the frame Ψ defined by:

where bg is the visible width of the glazing expressed in meters, Ug is the thermal 
transmittance of the central area of the glazing expressed in W/(m2·K).

Here, Ψ describes the additional heat flow caused by the interaction of the frame and the 
glass edge, including the effect of the spacer. The thermal transmittance Ug is provided, 
equal to 1.3 W/(m2·K).

Table 1 and Table 2 compare the numerical results of COMSOL Multiphysics with the 
expected values provided by ISO 10077-2:2012.

TABLE 1:  COMPARISON BETWEEN EXPECTED AND COMPUTED VALUES OF QUANTITIES IN APPLICATION 1

TABLE 2:  COMPARISON BETWEEN EXPECTED AND COMPUTED VALUES OF QUANTITIES IN APPLICATION 2

QUANTITY EXPECTED VALUE COMPUTED VALUE RELATIVE ERROR

L2D (W/(m·K)) 0.346 0.345 0.29%

Uf (W/(m2·K)) 1.36 1.38 1.47%

QUANTITY EXPECTED VALUE COMPUTED VALUE RELATIVE ERROR

L2D (W/(m·K)) 0.481 0.483 0.42%

Ψ (W/(m2·K)) 0.084 0.085 1.19%

L2D φ
Te Ti–
------------------=

Uf
L2D Upbp–

bf
-------------------------------=

Ψ L2D Ufbf– Ugbg–=
9 |  G L A Z I N G  I N F L U E N C E  O N  T H E R M A L  P E R F O R M A N C E S  O F  A W I N D O W



The maximum permissible differences to pass this test case are 3% for the thermal 
conductance and 5% for the (linear) thermal transmittance. The measured values are 
completely coherent and meet the validation criteria.

Reference

1. European Committee for Standardization, ISO 10077-2:2012, Thermal performance 
of windows, doors and shutters – Calculation of thermal transmittance – Part 2: 
Numerical method for frames, 2012.

Application Library path: Heat_Transfer_Module/
Buildings_and_Constructions/window_and_glazing_thermal_performances

Modeling Instructions

R O O T

Start by opening the following prepared file. It already contains global definitions, 
geometries, local variables, selections, operators and material properties.

1 From the File menu, choose Open.

2 Browse to the application’s Application Libraries folder and double-click the file 
window_and_glazing_thermal_performances_preset.mph.

Window with Insulation Panel

W I N D O W  W I T H  I N S U L A T I O N  P A N E L  ( C O M P 1 )

In the Model Builder window, expand the Window with Insulation Panel (comp1) node.

D E F I N I T I O N S

Variables 1
Define the thermal conductance of the section for the postprocessing part as follows.

1 In the Model Builder window, expand the Window with Insulation Panel (comp1)>

Definitions node, then click Variables 1.

2 In the Settings window for Variables, locate the Variables section.
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3 In the table, enter the following settings:

Note that the heat flow rate through the internal and through the external boundaries 
are equal (in absolute value) because other boundaries are considered adiabatic.

4 In the Model Builder window, collapse the Definitions node.

D E F I N I T I O N S

In the Model Builder window, collapse the Window with Insulation Panel (comp1)>Definitions 
node.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

Fluid 1
1 On the Physics toolbar, click Domains and choose Fluid.

2 Select Domains 4, 6, and 7 only.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Exterior Side.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type 1/Rse.

6 In the Text text field, type Te.

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Interior Side (Flat Area).

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type 1/Rsi_n.

6 In the Text text field, type Ti.

Heat Flux 3
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

Name Expression Unit Description

L2D int_internal(ht.ntflux
/(Te-Ti))

W/(m·K) Thermal conductance of 
the frame
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2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Interior Side (Corner Area).

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type 1/Rsi_p.

6 In the Text text field, type Ti.

Open Boundary 1
1 On the Physics toolbar, click Boundaries and choose Open Boundary.

2 Select Boundary 19 only.

3 In the Settings window for Open Boundary, locate the Open Boundary section.

4 In the T0 text field, type Te.

5 In the Model Builder window, collapse the Heat Transfer in Solids (ht) node.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, collapse the Window with Insulation Panel (comp1)>Heat 

Transfer in Solids (ht) node.

S T U D Y  1

The heat flow rate through the interior (or exterior) side of the section needs to be 
determined to calculate the thermal conductance of the section. In order to have enough 
precision in this value, the default relative tolerance of the solver has already been modified 
to 10−6. To access to this value, expand the Solver 1 node and click on the Stationary Solver 

1 node. In the Stationary Solver settings window, locate the General section.

1 On the Home toolbar, click Compute.

R E S U L T S

Derived Values
A Global Evaluation node is added in order to calculate the thermal conductance of the 
section and the thermal transmittance of the frame.

Global Evaluation 1
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, type Thermal Properties, Window 
with Insulation Panel in the Label text field.
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3 Locate the Expressions section. In the table, enter the following settings:

4 Click Evaluate.

TA B L E

1 Go to the Table window.

The results should be close to the expected values in Table 1.

R E S U L T S

Surface
1 In the Model Builder window, expand the Results>Temperature (ht) node, then click 

Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

4 On the Temperature (ht) toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

The current plot group shows the temperature distribution; compare with Figure 5.

The same simulation method is applied to the other benchmark. The instructions below 
describe the steps to achieve the calculations.

W I N D O W  W I T H  I N S U L A T I O N  P A N E L  ( C O M P 1 )

In the Model Builder window, collapse the Window with Insulation Panel (comp1) node.

Window with Glazing

W I N D O W  W I T H  G L A Z I N G  ( C O M P 2 )

In the Model Builder window, expand the Window with Glazing (comp2) node.

Expression Unit Description

L2D W/(m*K) Thermal Conductance of the Section 
(L2D)

(L2D-Up*bp)/bf W/(m^2*K) Thermal Transmittance of the Frame 
(Uf)
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D E F I N I T I O N S

Variables 2
1 In the Model Builder window, expand the Window with Glazing (comp2)>Definitions node, 

then click Variables 2.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

4 In the Model Builder window, collapse the Definitions node.

D E F I N I T I O N S

In the Model Builder window, collapse the Window with Glazing (comp2)>Definitions node.

H E A T  TR A N S F E R  I N  S O L I D S  2  ( H T 2 )

On the Physics toolbar, click Heat Transfer in Solids (ht) and choose Heat Transfer in Solids 

2 (ht2).

In the Model Builder window, under Window with Glazing (comp2) click Heat Transfer in 

Solids 2 (ht2).

Fluid 1
1 On the Physics toolbar, click Domains and choose Fluid.

2 Select Domains 4, 6, 7, and 16 only.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Exterior Side.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type 1/Rse.

6 In the Text text field, type Te.

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

Name Expression Unit Description

L2D int_internal(ht2.ntflu
x/(Te-Ti))

W/(m·K) Thermal conductance of 
the frame
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3 From the Selection list, choose Interior Side (Flat Area).

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type 1/Rsi_n.

6 In the Text text field, type Ti.

Heat Flux 3
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Interior Side (Corner Area).

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type 1/Rsi_p.

6 In the Text text field, type Ti.

Open Boundary 1
1 On the Physics toolbar, click Boundaries and choose Open Boundary.

2 Select Boundary 19 only.

3 In the Settings window for Open Boundary, locate the Open Boundary section.

4 In the T0 text field, type Te.

5 In the Model Builder window, collapse the Heat Transfer in Solids 2 (ht2) node.

H E A T  TR A N S F E R  I N  S O L I D S  2  ( H T 2 )

In the Model Builder window, collapse the Window with Glazing (comp2)>Heat Transfer in 

Solids 2 (ht2) node.

S T U D Y  2

On the Home toolbar, click Compute.

R E S U L T S

Derived Values
A Global Evaluation node is added in order to calculate the thermal conductance of the 
section and the linear thermal transmittance of the frame.

Global Evaluation 2
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, type Thermal Properties, Window 
with Glazing in the Label text field.
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3 Locate the Data section. From the Data set list, choose Study 2/Solution 2 (4) (sol2).

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

TA B L E

1 Go to the Table window.

The results should be close to the expected values in Table 2.

R E S U L T S

Surface
1 In the Model Builder window, expand the Results>Temperature (ht2) node, then click 

Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose degC.

4 On the Temperature (ht2) toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

The current plot group shows the temperature distribution; compare with Figure 6.

Expression Unit Description

L2D W/(m*K) Thermal Conductance of the Section 
(L2D)

L2D-Uf*bf-Ug*bg W/(m*K) Linear Thermal Transmittance of the 
Frame (psi)
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