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Introduction

Out of all metals, the most frequently extruded is aluminum. Aluminum extrusion entails 
using a hydraulic ram to squeeze an aluminum bar through a die. This process will form 
the metal into a particular shape. Extruded aluminum is used in many manufacturing 
applications, such as building components for example. In massive forming processes like 
rolling or extrusion, metal alloys are deformed in a hot solid state with material flowing 
under ideally plastic conditions. Such processes can be simulated effectively using 
computational fluid dynamics, where the material is considered as a fluid with a very high 
viscosity that depends on velocity and temperature. Internal friction of the moving 
material acts as a heat source, so that the heat transfer equations are fully coupled with 
those ruling the fluid dynamics part. This approach is especially advantageous when large 
deformations are involved.

This model is adapted from a benchmark study in Ref. 1. The original benchmark solves a 
thermal-structural coupling, because it is common practice in the simulation of such 
processes to use specific finite element codes that have the capability to couple the 
structural equations with heat transfer. The alternative scheme discussed here couples 
non-Newtonian flow with heat transfer equations. In addition, because it is useful to know 
the stress in the die due to fluid pressure and thermal loads, the model adds a structural 
mechanics analysis.

The die design is courtesy of Compes S.p.A., while the die geometry, boundary 
conditions, and experimental data are taken from Ref. 1.

Note: This application requires the Heat Transfer Module and the Structural Mechanics 
Module. In addition, it uses the Material Library.

Model Definition

The model considers steady-state conditions, assuming a billet of infinite length flowing 
through the die. In the actual process, the billet is pushed by the ram through the die and 
its volume is continuously reducing.

Figure 1 shows the original complete geometry with four different profiles. To have a 
model with reasonable dimensions, consider only a quarter of the original geometry. The 
simplification involved in neglecting the differences between the four profiles does not 
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affect the numerical scheme proposed. Figure 2 shows the resulting model geometry.

Figure 1: Original benchmark geometry.

Figure 2: Quarter of the original geometry considered in the model.

M A T E R I A L  P R O P E R T I E S

The documentation for the benchmark model (Ref. 1) serves as the data source for 
properties of the two main materials: AISI steel for the die and the container (the ram is 
not considered here) and aluminum for the billet.
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Structural Analysis
Because only the steel part is active in the structural analysis, consider a simple linear elastic 
behavior where the elastic properties are those of the material H11 mod (AISI 610) that 
can be found in the COMSOL Multiphysics Material Library. 

Heat Transfer Analysis
The benchmark model uses the following properties for aluminum and steel:

Non-Newtonian Flow
The properties of the aluminum were experimentally determined and then checked using 
literature data for the same alloy and surface state. However the benchmark proposes an 
experimental constitutive law, suited for the structural mechanics codes usually used to 
simulate such processes, in the form of the flow stress data. For this model this requires a 
recalculation of the constitutive law to derive a general expression for the viscosity. The 
equivalent von Mises stress, σeqv, can be defined in terms of the total contraction of the 
deviatoric stress tensor as

or, using  where  is the strain rate and η is the viscosity, as

 (1)

Introducing the equivalent strain rate

Equation 1 can be expressed as 

ALUMINUM VALUE DESCRIPTION

kal 210 N/(s·K) Thermal conductivity

ρal 2700 kg/m3 Density

Cpal 2.94 N/(mm2·K)/ρal Heat capacity at constant pressure

STEEL VALUE DESCRIPTION

kfe 24.33 N/(s·K) Thermal conductivity

ρfe 7850 kg/m3 Density

Cpfe 4.63 N/(mm2·K)/ρfe Heat capacity at constant pressure

σeqv
3
2
---τ:τ=

τ 2ηε·= ε·

σeqv 6η2ε· :ε·=

φ· eqv
2
3
---ε· :ε·≡
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The strain rate tensor is defined as (Ref. 2)

The shear rate  is defined as

so that

The flow rule

states that plastic yielding occurs if the equivalent stress, σeqv, reaches the flow stress, κf. 
The viscosity is defined as (see Ref. 2 for further details)

The organizers of the benchmark propose specific flow-stress data expressed in terms of a 
generalized Zener-Hollomon function

where A = 2.39·108 s−1, n = 2.976, α = 0.052 MPa−1, and

with Q = 153 kJ/mol and R = 8.314 J/(K·mol).

σeqv 3ηφ· eqv=

ε· u∇ u∇( )T
+

2
------------------------------- 1

2
---γ·= =
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γ· γ· 1
2
---γ· :γ·= =

φeqv
1
3
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S O U R C E S ,  I N I T I A L  C O N D I T I O N S ,  A N D  B O U N D A R Y  C O N D I T I O N S

Structural Analysis
Because the model geometry is a quarter of the actual geometry, use symmetric boundary 
conditions for the two orthogonal planes. On the external surfaces of the die, apply roller 
boundary conditions because in reality other dies, not considered here, are present to 
increase the system’s stiffness.

The main loads are the thermal loads from the heat transfer analysis and pressures from the 
fluid dynamics analysis.

Heat Transfer Analysis
For the billet, use a volumetric heat source related to the viscous heating effect.

The external temperature of the ram and the die is held constant at 450 °C (723 K). The 
ambient temperature is 25 °C (298 K). For the heat exchange between aluminum and 
steel, use the heat transfer coefficient of 11 N/(s·mm·K). Also consider convective heat 
exchange with air outside the profiles with a fixed convective heat transfer coefficient of 
15 W/(m2·K).

Apply initial temperatures as given in the following table:

Non-Newtonian Flow
At the inlet, the ram moves with a constant velocity of 0.5 mm/s. Impose this boundary 
condition by simply applying a constant inlet velocity. At the outlet, a normal stress 
condition with zero external pressure applies. On the surfaces placed on the two symmetry 
planes, use symmetric conditions. Finally, apply slip boundary conditions on the 
boundaries placed outside the profile.

Results and Discussion

The general response of the proposed numerical scheme, especially in the zone of the 
profile, is in good accordance with the experience of the designers. A comparison between 
the available experimental data and the numerical results of the simulation shows good 
agreement.

PART VALUE

Ram 380 °C (653 K)

Container 450 °C (723 K)

Billet 460 °C (733 K)

Die 404 °C (677 K)
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On the basis of the results from the simulation, the engineer can improve the preliminary 
die design by adjusting relevant physical parameters and operating conditions. For this 
purpose, the volume plot in Figure 3 showing the temperature field inside the profile gives 
important information. Furthermore, the combined streamline and slice plot in Figure 4 
reveals any imbalances in the velocity field that could result in a crooked profile. A proper 
design should also ensure that different parts of the profile travel at the same speed. 
Figure 5 shows the von Mises equivalent stress in the steel part considering the thermal 
load and the pressure load due to the presence of the fluid.

Figure 3: Temperature distribution in the billet.
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Figure 4: Velocity field and streamlines at the profile section.

Figure 5: Equivalent von Mises stress distribution in the container.
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Application Library path: Structural_Mechanics_Module/
Fluid-Structure_Interaction/aluminum_extrusion_fsi

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Heat Transfer>Conjugate Heat Transfer>Laminar Flow.

3 Click Add.

4 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

5 Click Add.

6 Click Study.

7 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

8 Click Done.

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.
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4 Browse to the application’s Application Libraries folder and double-click the file 
aluminum_extrusion_fsi.mphbin.

5 Click Import.

6 Click the Zoom Extents button on the Graphics toolbar.

You should now see the following geometry.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

D_alfe 1[mm] 0.001 m Thickness of the 
high conductive 
layer

Heat_alfe 11[N/(s*mm*K)] 11000 W/(m²·K) Aluminum-steel heat 
exchange 
coefficient

T_billet 460[degC] 733.15 K Billet temperature
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D E F I N I T I O N S

Variables 1
1 On the Home toolbar, click Variables and choose Local Variables.

2 In the Settings window for Variables, locate the Variables section.

T_container 450[degC] 723.15 K Container 
temperature

T_ram 380[degC] 653.15 K Ram temperature

T_pd1 404[degC] 677.15 K Initial temperature 
around thermocouple 
at point PD1

V_ram 0.5[mm/s] 5E-4 m/s Ram velocity

P_init 0[bar] 0 Pa External reference 
pressure

T_air 25[degC] 298.15 K Ambient temperature

Q_eta 153000[J/mol] 1.53E5 J/mol Parameter Q for the 
generalized 
Zener-Hollomon 
function

n_eta 2.976 2.976 Parameter n for the 
generalized 
Zener-Hollomon 
function

A_eta 2.39e8[1/s] 2.39E8 1/s Parameter A for the 
generalized 
Zener-Hollomon 
function

alpha_eta 0.0521[1/MPa] 5.21E-8 1/Pa Parameter alpha for 
the generalized 
Zener-Hollomon 
function

H_conv 15 15 Convective heat 
exchange 
coefficient with 
air

F sqrt(1/3) 0.57735 Factor for the 
conversion of the 
shear rate to 
COMSOL’s definition

Name Expression Value Description
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3 In the table, enter the following settings:

Create the selections to simplify the model specification.

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Outside in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 35–38, 42, 43, 48, 49, 51, 53, 68, 69, 76–79, 84, 85, 91, 93, 100, 
101, 103, and 105 only.

For more convenience in selecting these boundaries, you can click the Paste Selection 
button and paste the above numbers.

Explicit 2
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Interior in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 8, 11, 14, 15, 19, 20, 24, 29–34, 41, 47, 50, 56–58, 62, 67, 70, 71, 
74, 75, 83, 86–90, 99, 102, 106, and 107 only.

Before creating the materials for the model, specify the fluid and solid domains. Using this 
information, the software can detect which material properties are needed.

H E A T  TR A N S F E R  ( H T )

Fluid 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Fluid 

1.

2 Select Domains 3 and 4 only.

3 In the Settings window for Fluid, locate the Domain Selection section.

4 Click Create Selection.

5 In the Create Selection dialog box, type Billet in the Selection name text field.

Name Expression Unit Description

Z_eta F*spf.sr*exp(Q_eta/
(R_const*T))

1/s Zener-Hollomon parameter

mu_al asinh((Z_eta/A_eta)^(1/
n_eta))/(3*alpha_eta*F*
spf.sr+sqrt(eps))

Pa·s Viscosity of aluminum
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6 Click OK.

L A M I N A R  F L O W  ( S P F )

On the Physics toolbar, click Heat Transfer (ht) and choose Laminar Flow (spf).

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

2 In the Settings window for Laminar Flow, locate the Physical Model section.

3 From the Compressibility list, choose Incompressible flow.

4 Locate the Domain Selection section. From the Selection list, choose Billet.

S O L I D  M E C H A N I C S  ( S O L I D )

On the Physics toolbar, click Laminar Flow (spf) and choose Solid Mechanics (solid).

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the Domain Selection section.

3 Click Clear Selection.

4 Select Domains 1 and 2 only.

Now, define the material for each domain.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Material Library>Tool Steels>H11 mod (AISI 610)>H11 mod (AISI 610) 

[solid]>H11 mod (AISI 610) [solid,triple tempered].

4 Click Add to Component in the window toolbar.

M A T E R I A L S

H11 mod (AISI 610) [solid,triple tempered] (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click H11 mod (AISI 

610) [solid,triple tempered] (mat1).

2 Select Domains 1 and 2 only.

3 In the Settings window for Material, locate the Material Contents section.
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4 In the table, enter the following settings:

Because the heat capacity only enters the transient heat transfer equation, this setting 
does not affect the steady-state simulation described here; it is provided for 
completeness in case you want to extend the model to perform transient simulations.

Material 2 (mat2)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Billet in the Label text field.

3 Locate the Geometric Entity Selection section. From the Selection list, choose Billet.

4 Locate the Material Contents section. In the table, enter the following settings:

5 On the Home toolbar, click Add Material to close the Add Material window.

With the materials defined, you can set up the remaining physics of the model.

L A M I N A R  F L O W  ( S P F )

In the current model the viscosity in the fluid flow part is large, which implies that the 
model is diffusion dominated. Pseudo time stepping works poorly for this model because 
it is based on the scale of the convective flux.

1 In the Model Builder window’s toolbar, click the Show button and select Advanced Physics 

Options in the menu.

2 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

3 In the Settings window for Laminar Flow, click to expand the Advanced settings section.

Property Name Value Unit Property group

Heat capacity at 
constant pressure

Cp 4.63[N/(mm^2*
K)]/rho(T[1/
K])[kg/m^3]

J/(kg·K) Basic

Property Name Value Unit Property 
group

Thermal conductivity k 210 W/(m·K) Basic

Density rho 2700 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 2.94[N/
(mm^2*
K)]/rho

J/(kg·K) Basic

Ratio of specific heats gamma 1 1 Basic

Dynamic viscosity mu mu_al Pa·s Basic
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4 Locate the Advanced Settings section. Find the Pseudo time stepping subsection. Clear 
the Use pseudo time stepping for stationary equation form check box.

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Laminar Flow (spf) click Initial 

Values 1.

2 In the Settings window for Initial Values, locate the Initial Values section.

3 In the p text field, type P_init.

4 In the Model Builder window, click Laminar Flow (spf).

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 9 and 112 only.

Inlet 1
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 Select Boundary 10 only.

3 In the Settings window for Inlet, locate the Velocity section.

4 Click the Velocity field button.

5 Specify the u0 vector as

Wall 2
1 On the Physics toolbar, click Boundaries and choose Wall.

2 In the Settings window for Wall, locate the Boundary Selection section.

3 From the Selection list, choose Outside.

4 Locate the Boundary Condition section. From the Boundary condition list, choose Slip.

Outlet 1
1 On the Physics toolbar, click Boundaries and choose Outlet.

2 Select Boundary 40 only.

3 In the Settings window for Outlet, locate the Pressure Conditions section.

4 In the p0 text field, type P_init.

0 x

0 y

V_ram z
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H E A T  TR A N S F E R  ( H T )

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer (ht) click Initial 

Values 1.

2 In the Settings window for Initial Values, type T_container in the T text field.

3 In the Model Builder window, click Heat Transfer (ht).

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundaries 2, 5, and 7 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type T_container.

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundary 10 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type Heat_alfe.

6 In the Text text field, type T_ram.

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Outside.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type H_conv.

6 In the Text text field, type T_air.

Outflow 1
1 On the Physics toolbar, click Boundaries and choose Outflow.

2 Select Boundary 40 only.

Thin Layer 1
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 In the Settings window for Thin Layer, locate the Boundary Selection section.
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3 From the Selection list, choose Interior.

4 Locate the Thin Layer section. From the Specify list, choose Thermal resistance.

5 In the Rs text field, type 1/Heat_alfe.

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 Select Domains 1 and 2 only.

For faster convergence use linear elements. You can always refine the solution using the 
default quadratic elements.

3 In the Model Builder window’s toolbar, click the Show button and select Discretization in 
the menu.

4 In the Settings window for Solid Mechanics, click to expand the Discretization section.

5 From the Displacement field list, choose Linear.

Roller 1
1 On the Physics toolbar, click Boundaries and choose Roller.

2 Select Boundaries 2, 5, and 7 only.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 1, 4, 110, and 111 only.

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 8, 11, 14, 15, 19, 20, 24, 29–34, 41, 47, 50, 56–58, 62, 67, 70, 71, 
74, 75, 83, 86–90, 99, 102, 106, and 107 only.

3 In the Settings window for Boundary Load, locate the Coordinate System Selection 
section.

4 From the Coordinate system list, choose Boundary System 1 (sys1).

5 Locate the Force section. Specify the FA vector as

0 t1

0 t2

-p n
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M U L T I P H Y S I C S

1 In the Model Builder window, under Component 1 (comp1)>Multiphysics click 
Non-Isothermal Flow 1 (nitf1).

2 In the Settings window for Non-Isothermal Flow, locate the Flow Heating section.

3 Select the Include viscous dissipation check box.

Thermal Expansion 1 (te1)
1 On the Physics toolbar, click Multiphysics and choose Domain>Thermal Expansion.

2 Select Domain 1 only.

3 In the Settings window for Thermal Expansion, locate the Thermal Expansion Properties 
section.

4 In the Tref text field, type T_container.

Thermal Expansion 2 (te2)
1 On the Physics toolbar, click Multiphysics and choose Domain>Thermal Expansion.

2 Select Domains 2–4 only.

3 In the Settings window for Thermal Expansion, locate the Thermal Expansion Properties 
section.

4 In the Tref text field, type T_pd1.

M E S H  1

On the Mesh toolbar, click Boundary and choose Free Triangular.

Free Triangular 1
1 Click the Zoom Box button on the Graphics toolbar.

2 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Free Triangular 1.

3 Select Boundary 40 only.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. Select the Maximum element size check box.

5 In the associated text field, type 0.0014.

6 Select the Curvature factor check box.

7 In the associated text field, type 0.2.
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8 Click Build Selected.

9 On the Mesh toolbar, click Swept.

Swept 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Swept 1.

2 In the Settings window for Swept, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domain 4 only.

5 On the Mesh toolbar, click Distribution.

Distribution 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1>Swept 1 click 

Distribution 1.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 24.

4 Click Build All.

5 On the Mesh toolbar, click Free Tetrahedral.

Free Tetrahedral 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Tetrahedral 1 and choose Size.

Size 1
1 In the Settings window for Size, locate the Element Size section.

2 Click the Custom button.

3 Locate the Element Size Parameters section. Select the Maximum element size check box.

4 In the associated text field, type 0.0085.

Free Tetrahedral 1
Right-click Free Tetrahedral 1 and choose Size.

Size 2
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 Select Boundaries 12 and 13 only.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.
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6 In the associated text field, type 0.002.

Free Tetrahedral 1
Right-click Free Tetrahedral 1 and choose Size.

Size 3
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 Select Boundaries 24, 31, 32, 70, 88, and 106 only.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Minimum element size check box.

6 In the associated text field, type 1e-5.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Finer.

4 Click Build All.

You should now see the following meshed geometry.
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S T U D Y  1

Step 1: Stationary
Use two stationary study steps. Solve first for the fluid dynamics and heat transfer to 
determine the thermal load and the pressure load and then for the structural mechanics.

1 In the Model Builder window, expand the Study 1 node, then click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 In the table, clear the Solve for check box for the Solid Mechanics interface.

Stationary 2
On the Study toolbar, click Study Steps and choose Stationary>Stationary.

Step 2: Stationary 2
1 In the Settings window for Stationary, locate the Physics and Variables Selection section.

2 Select the Modify physics tree and variables for study step check box.

3 In the Physics and variables selection tree, select Component 1 (comp1)>Laminar Flow 

(spf).

4 Click Disable in Solvers.

5 In the Physics and variables selection tree, select Component 1 (comp1)>Heat Transfer (ht).

6 Click Disable in Solvers.

7 In the Physics and variables selection tree, select Component 1 (comp1)>Multiphysics>

Non-Isothermal Flow 1 (nitf1).

8 Click Disable in Solvers.

For the structural analysis, use a memory efficient iterative solver to make it possible to 
solve the problem also on computers with limited memory.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Study 1>Solver Configurations node.

3 In the Model Builder window, expand the Solution 1 (sol1) node.

4 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 2 node.

5 Right-click Study 1>Solver Configurations>Solution 1 (sol1)>Stationary Solver 2 and 
choose Iterative.

6 On the Study toolbar, click Compute.
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R E S U L T S

Temperature (ht)
The first default plot shows the temperature (Figure 3).

1 In the Model Builder window, under Results click Temperature (ht).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Data set list, choose Exterior Walls.

4 On the Temperature (ht) toolbar, click Plot.

Data Sets
Modify the third default plot to see the velocity field and streamlines at the profile section 
(Figure 4).

Study 1/Solution Store 1 (sol2)
In the Model Builder window, expand the Data Sets node, then click Study 1/Solution Store 

1 (sol2).

Selection
1 On the Results toolbar, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Billet.

Velocity (spf)
1 In the Model Builder window, under Results click Velocity (spf).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Data set list, choose Study 1/Solution Store 1 (sol2).

Slice
1 In the Model Builder window, expand the Velocity (spf) node, then click Slice.

2 In the Settings window for Slice, locate the Plane Data section.

3 From the Plane list, choose XY-planes.

4 From the Entry method list, choose Coordinates.

5 In the Z-coordinates text field, type 0.0151.

6 On the Velocity (spf) toolbar, click Plot.

Velocity (spf)
In the Model Builder window, under Results right-click Velocity (spf) and choose Streamline.
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Streamline 1
1 In the Settings window for Streamline, click Replace Expression in the upper-right corner 

of the Expression section. From the menu, choose Model>Component 1>Laminar Flow>

Velocity and pressure>u,v,w - Velocity field (Spatial).

2 Locate the Streamline Positioning section. From the Positioning list, choose Start point 

controlled.

3 Locate the Coloring and Style section. From the Line type list, choose Tube.

4 Click to expand the Inherit style section. Locate the Inherit Style section. From the Plot 
list, choose Slice.

Color Expression 1
1 Right-click Results>Velocity (spf)>Streamline 1 and choose Color Expression.

2 In the Settings window for Color Expression, click Replace Expression in the upper-right 
corner of the Expression section. From the menu, choose Model>Component 1>Laminar 

Flow>Velocity and pressure>spf.U - Velocity magnitude.

3 On the Velocity (spf) toolbar, click Plot.

To get a better view, rotate the geometry in the Graphics window and use the Zoom Box 
tool to obtain a close-up. You can preserve a view for a plot by creating a View feature 
node as follows:

4 In the Model Builder window’s toolbar, click the Show button and select Advanced Results 

Options in the menu.

Streamline 1
In the Model Builder window, expand the Results>Velocity (spf)>Streamline 1 node.

View 3D 2
1 Right-click Results>Views and choose View 3D.

2 Use the Graphics toolbox to get a satisfying view.

3 In the Settings window for View 3D, locate the View section.

4 Select the Lock camera check box.

Next, apply the view to the velocity plot.

Velocity (spf)
1 In the Model Builder window, under Results click Velocity (spf).

2 In the Settings window for 3D Plot Group, locate the Plot Settings section.

3 From the View list, choose View 3D 2.

4 On the Velocity (spf) toolbar, click Plot.
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Stress (solid)
The last plot shows the von Mises stress and deformation distribution in the container. To 
reproduce the Figure 5, apply the View 3D 2.

1 In the Model Builder window, under Results click Stress (solid).

2 In the Settings window for 3D Plot Group, locate the Plot Settings section.

3 From the View list, choose View 3D 2.

4 On the Stress (solid) toolbar, click Plot.

Velocity (spf)
1 In the Settings window for 3D Plot Group, locate the Data section.

2 From the Data set list, choose Study 1/Solution 1 (sol1).

3 On the Velocity (spf) toolbar, click Plot.
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Introduction

This example studies a portion of the vascular system, in particular the upper part of the 
aorta (Figure 1). The aorta and its ramified blood vessels are embedded in biological 
tissue, specifically the cardiac muscle. The flowing blood applies pressure to the artery’s 
internal surfaces and its branches, thereby deforming the tissue. The analysis consists of 
two distinct but coupled procedures: first, a fluid-dynamics analysis including a calculation 
of the velocity field and pressure distribution in the blood (variable in time and in space); 
second, a mechanical analysis of the deformation of the tissue and artery. Any change in 
the shape of the vessel walls does not influence the fluid domain, which implies that there 
is only a one-way fluid-structural coupling.

Figure 1: The model domain consists of part of the aorta, its branches, and the surrounding 
tissue.

Model Definition

Figure 2 shows two views of the model domain, one with and one without the cardiac 
muscle. The mechanical analysis must consider the cardiac muscle because it presents a 
stiffness that resists artery deformation due to the applied pressure. 
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Figure 2: A view of the aorta and its ramification (branching vessels) with blood contained, 
shown both with (left) and without (right) the cardiac muscle.

The main characteristics of the analyses are:

• Fluid dynamics analysis

Here the Navier-Stokes equations are solved in the blood domain. At each surface 
where the model brings a vessel to an abrupt end, it represents the load with a known 
pressure distribution.

• Mechanical analysis

Only the domains related to the biological tissues are active in this analysis. The model 
represents the load with the total stress distribution it computes during the 
fluid-dynamics analysis.

A N A L Y S I S  O F  R U B B E R - L I K E  T I S S U E  A N D  A R T E R Y  M A T E R I A L  M O D E L S

Generally, the modeling of biological tissue is an advanced subject for several reasons:

• The material can undergo very large strains (finite deformations).

• The stress-strain relationship is generally nonlinear.

• Many hyperelastic materials are almost incompressible. You must then revise standard 
displacement-based finite element formulations in order to arrive at correct results 
(mixed formulations).

You must pay particular attention to the definition of stress and strain measures. In a 
geometrically nonlinear analysis the assumptions about infinitesimal displacements are no 
longer valid. It is necessary to consider geometrical nonlinearity in a model when:

• Significant rigid-body rotations occur (finite rotations).
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• The strains are no longer small (larger than a few percent).

• The loading of the body depends on the deformation.

All of these issues are dealt with in the hyperelastic material model built-in the Nonlinear 
Structural Materials Module.

In this case, the displacements and strains are so small that it is sufficient to use a linear 
elastic material model. The material data is given for a neo-Hookean hyperelastic material, 
but in the small strain limit the interpretation of the material constants is the same for a 
linear elastic material. 

M A T E R I A L S

The following material properties are used:

• Blood

- density = 1060 kg/m3

- dynamic viscosity = 0.005 Ns/m2

• Artery

- density = 960 kg/m3

- Neo-Hookean hyperelastic behavior: the coefficient μ equals 6.20·106 N/m2, while 
the bulk modulus equals 20μ and corresponds to a value for Poisson’s ratio, ν, of 
0.45. An equivalent elastic modulus equals 1.0·107 N/m2.

• Cardiac muscle

- density = 1200 kg/m3

- Neo-Hookean hyperelastic behavior: the coefficient μ equals 7.20·106 N/m2, while 
the bulk modulus equals 20μ and corresponds to a value for Poisson’s ratio, ν, of 
0.45. An equivalent elastic modulus equals 1.16·106 N/m2.

F L U I D  D Y N A M I C S  A N A L Y S I S

The fluid dynamics analysis considers the solution of the 3D Navier-Stokes equations. You 
can do so in both a stationary case or in the time domain. To establish the boundary 
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conditions, six pressure conditions are applied with the configuration shown in Figure 3.

Figure 3: Boundary conditions for the fluid-flow analysis.

The pressure conditions are:

• Section 1: 126.09 mmHg

• Section 2: 125.91 mmHg

• Section 3: 125.415 mmHg

• Section 4: 125.415 mmHg

• Section 5: 125.415 mmHg

• Section 6: 125.1 mmHg

Those pressure values are the mean values over a heart beating cycle. During a cycle the 
pressure varies between a minimal and a maximal values which are calculated thanks to a 
relative amplitude α. For the time-dependent analysis, a simple trigonometric function is 
used for varying the pressure distribution over time:

The first piece of function between 0 and 0.5 s has no physical significance, it is just a ramp 
that enable to calculate the initial state. The second piece of function makes the pressure 
vary between its minimal and maximal value during a 1 s cycle.

You implement this effect in COMSOL Multiphysics using Piecewise function.

1. P

2. P

3. P
4. P

5. P

6. P

P = Pressure

f t( )
1 α–( ) πt( )sin

1 α 2π t 0.5–( )( )cos–



=
0 t 0,5s≤ ≤
0,5s t 1,5s≤ ≤
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Results and Discussion

The flow field at the time t=1 s is displayed in Figure 4 as a slice plot.

Figure 4: Velocity field in the aorta and its ramification (branching).

Figure 5 shows the total displacement at the peak load (after 1 s). The displacements are 
in the order of 4 μm, which suggests that the one-way multiphysics coupling is a 
reasonable approximation.
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Figure 5: Displacements in the blood vessel.

Notes About the COMSOL Implementation

In this example, and many other cases, an analysis which is time dependent for one physics 
can be treated as quasi-static from the structural mechanics point of view. You can handle 
this by running the structural analysis as a parametric sweep over a number of static load 
cases, where the time is used as the parameter. This method is used here. 

Application Library path: Structural_Mechanics_Module/Bioengineering/
blood_vessel

Modeling Instructions

From the File menu, choose New.
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N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Fluid Flow>Fluid-Structure Interaction, Fixed Geometry.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Time 

Dependent.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Piecewise 1 (pw1)
1 On the Home toolbar, click Functions and choose Global>Piecewise.

2 In the Settings window for Piecewise, type f in the Function name text field.

3 Locate the Definition section. In the Argument text field, type t.

4 Find the Intervals subsection. In the table, enter the following settings:

5 Locate the Units section. In the Arguments text field, type s.

6 In the Function text field, type 1.

7 Click Plot.

Name Expression Value Description

t 0[s] 0 s Time continuation parameter

alpha 1/3 0.3333 Relative pressure amplitude 
during heart’s beating

Start End Function

0 0.5 (1-alpha)*sin(pi*t)

0.5 1.5 1-alpha*cos(2*pi*(t-0.5))
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G E O M E T R Y  1

The geometry for this model is available as an MPHBIN-file. Import this file as follows.

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
blood_vessel.mphbin.

5 Click Import.

The length unit in the imported geometry is centimeters, while the default length unit 
in COMSOL Multiphysics is meters. Therefore, you need to rescale the geometry.

Scale 1 (sca1)
1 On the Geometry toolbar, click Transforms and choose Scale.

2 In the Settings window for Scale, locate the Scale Factor section.

3 In the Factor text field, type 0.01.

4 Select the object imp1 only.

5 Right-click Scale 1 (sca1) and choose Build Selected.

6 Click the Go to Default 3D View button on the Graphics toolbar.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click Form 

Union (fin) and choose Build Selected.
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2 Click the Transparency button on the Graphics toolbar to see the interior.

D E F I N I T I O N S

Next, define a number of selections as sets of geometric entities for use in setting up the 
model.

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Blood in the Label text field.

3 Select Domain 3 only.
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Explicit 2-10
1 Proceed to create nine explicit selections with the following settings:

The roller boundaries are the free boundaries of muscle and artery that are neither in 
contact with each other nor with blood.

Explicit 11
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Loaded boundaries in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 10, 20, 36, 42, and 68 only.

5 Select the Group by continuous tangent check box. The selection should now contains 
boundaries 10-11, 16-17, 20-21, 23-24, 36-37, 39-40, 42-43, 45-46, 50-53, 58-59, 
61-62, 68-69, 75-76, 79-80, 82-83.

The loaded boundaries are the inner artery boundaries that are in contact with blood.

Explicit 12
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Artery walls in the Label text field.

3 Select Domain 2 only.

4 Locate the Output Entities section. From the Output entities list, choose Adjacent 

boundaries.

5 Select the Interior boundaries check box.

Label Geometric entity level Selection

Artery Domain 2

Muscle Domain 1

Inlet Boundary 38

Outlet 1 Boundary 19

Outlet 2 Boundary 9

Outlet 3 Boundary 41

Outlet 4 Boundary 70

Outlet 5 Boundary 86

Roller boundaries Boundary 1-6,12,26,27,30,33,64,
67,85,87
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L A M I N A R  F L O W  ( S P F )

1 In the Model Builder window, under Component 1 (comp1) click Laminar Flow (spf).

2 In the Settings window for Laminar Flow, locate the Domain Selection section.

3 From the Selection list, choose Blood.

Inlet 1
1 On the Physics toolbar, click Boundaries and choose Inlet.

2 In the Settings window for Inlet, locate the Boundary Selection section.

3 From the Selection list, choose Inlet.

4 Locate the Boundary Condition section. From the list, choose Pressure.

5 Locate the Pressure Conditions section. In the p0 text field, type 126.09[mmHg]*f(t).

Outlet 1
1 On the Physics toolbar, click Boundaries and choose Outlet.

2 In the Settings window for Outlet, locate the Boundary Selection section.

3 From the Selection list, choose Outlet 1.

4 Locate the Pressure Conditions section. In the p0 text field, type 125.91[mmHg]*f(t).

Outlet 2-5
Proceed to add four outlet boundary nodes with the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 Select Domains 1 and 2 only.

Linear Elastic Material 1
1 In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 

Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the Specify list, choose Lamé parameters.

Boundary Selection p0

Outlet 2 125.415[mmHg]*f(t)

Outlet 3 125.415[mmHg]*f(t)

Outlet 4 125.415[mmHg]*f(t)

Outlet 2 125.1[mmHg]*f(t)
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4 In the Model Builder window, click Solid Mechanics (solid).

Roller 1
1 On the Physics toolbar, click Boundaries and choose Roller.

2 In the Settings window for Roller, locate the Boundary Selection section.

3 From the Selection list, choose Roller boundaries.

M U L T I P H Y S I C S

1 In the Model Builder window, under Component 1 (comp1)>Multiphysics click 
Fluid-Structure Interaction, Fixed Geometry 1 (fsifg1).

2 In the Settings window for Fluid-Structure Interaction, Fixed Geometry, locate the 
Coupling Type section.

3 From the list, choose Fluid loading on structure to ensure a one way coupling, from the 
fluid to the solid.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, type Blood in the Label text field.

2 Locate the Geometric Entity Selection section. From the Selection list, choose Blood.

3 Locate the Material Contents section. In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Artery in the Label text field.

3 Locate the Geometric Entity Selection section. From the Selection list, choose Artery.

4 Locate the Material Contents section. In the table, enter the following settings:

Property Name Value Unit Property group

Density rho 1060 kg/m³ Basic

Dynamic viscosity mu 0.005 Pa·s Basic

Property Name Value Unit Property group

Lamé parameter λ lambLame 20*muLame-2*
muLame/3

N/m² Lamé parameters
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Material 3 (mat3)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Muscle in the Label text field.

3 Locate the Geometric Entity Selection section. From the Selection list, choose Muscle.

4 Locate the Material Contents section. In the table, enter the following settings:

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Tetrahedral.

Free Tetrahedral 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Tetrahedral 1 and choose Size.

Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Domain.

3 From the Selection list, choose Blood.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 1e-3.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Fine.

Lamé parameter μ muLame 6.20e6 N/m² Lamé parameters

Density rho 960 kg/m³ Basic

Property Name Value Unit Property group

Lamé parameter λ lambLame 20*muLame-2*
muLame/3

N/m² Lamé parameters

Lamé parameter μ muLame 7.20e6 N/m² Lamé parameters

Density rho 1200 kg/m³ Basic

Property Name Value Unit Property group
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4 Click Build All.

S T U D Y  1

The structural problem is quasi-static, so you can use the time just as a parameter for the 
parametric solver, together with a stationary solver. Thus the whole study can be divided 
into two steps. First run the transient study for the fluid-mechanics part of the problem 
and then use the stationary solver to solve the structural part using the solution from first 
transient study.

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,0.05,1.5).

4 Locate the Physics and Variables Selection section. In the table, clear the Solve for check 
box for the Solid Mechanics interface.

Stationary
On the Study toolbar, click Study Steps and choose Stationary>Stationary.
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Step 2: Stationary
1 In the Settings window for Stationary, locate the Physics and Variables Selection section.

2 In the table, clear the Solve for check box for the Laminar Flow interface.

3 Click to expand the Study extensions section. Locate the Study Extensions section. Select 
the Auxiliary sweep check box.

4 Click Add.

5 In the table, enter the following settings:

6 Click to expand the Values of dependent variables section. Locate the Values of Dependent 

Variables section. Find the Values of variables not solved for subsection. From the Settings 
list, choose User controlled.

7 From the Method list, choose Solution.

8 From the Study list, choose Study 1, Time Dependent.

9 From the Selection list, choose All.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node, then click 
Time-Dependent Solver 1.

3 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

4 Locate the Time Stepping section. From the Steps taken by solver list, choose 
Intermediate. This way the solver computes at least once between each output time step 
in order to reduce possible interpolation error in the fluid load evaluation.

5 On the Study toolbar, click Compute.

R E S U L T S

Velocity (spf)
1 Click the Transparency button on the Graphics toolbar to restore the original 

transparency state.

By default, you get a slice plot of the velocity and a contour plot of the fluid pressure 
on the wall surface.The plot in Figure 4 corresponds to the first default plot.

2 In the Model Builder window, click Velocity (spf).

Parameter name Parameter value list Parameter unit

t range(0,0.05,1.5) s
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3 In the Settings window for 3D Plot Group, locate the Data section.

4 From the Time (s) list, choose 1.

Slice
1 In the Model Builder window, under Results>Velocity (spf) click Slice.

2 In the Settings window for Slice, locate the Plane Data section.

3 From the Plane list, choose ZX-planes.

4 In the Planes text field, type 1.

5 On the Velocity (spf) toolbar, click Plot.

6 Click the Go to Default 3D View button on the Graphics toolbar.

Pressure (spf)
The default unit for pressure plot is Pascal. As the mmHg unit is not available in the selection 
list, type it directly in the text field.

1 In the Model Builder window, under Results click Pressure (spf).

2 In the Settings window for 3D Plot Group, click to expand the Title section.

Pressure
1 In the Model Builder window, expand the Pressure (spf) node, then click Pressure.

2 In the Settings window for Contour, locate the Expression section.

3 In the Unit field, type mmHg.

4 On the Pressure (spf) toolbar, click Plot.

Data Sets
To reproduce the plot shown in Figure 5, begin by defining a selection for the solution 
data set to make interior boundaries visible in the plot.

Study 1/Solution 1 (3) (sol1)
On the Results toolbar, click More Data Sets and choose Solution.

Selection
1 On the Results toolbar, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Artery walls.

Stress (solid)
1 In the Model Builder window, under Results click Stress (solid).
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2 In the Settings window for 3D Plot Group, type Displacement (solid) in the Label 
text field.

3 Locate the Data section. From the Data set list, choose Study 1/Solution 1 (3) (sol1).

4 From the Time (s) list, choose 1.

Surface 1
1 In the Model Builder window, expand the Results>Displacement (solid) node, then click 

Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>

Displacement>solid.disp - Total displacement.

3 Locate the Expression section. From the Unit list, choose µm.

Deformation
1 In the Model Builder window, expand the Surface 1 node, then click Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 Select the Scale factor check box.

4 In the associated text field, type 300.

5 On the Displacement (solid) toolbar, click Plot.

6 Click the Go to Default 3D View button on the Graphics toolbar.
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Created in COMSOL Multiphysics 5.2a
B r a c k e t  Geome t r y
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.
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This is a template MPH-file containing the bracket geometry. For a description of this 
model, including detailed step-by-step instructions showing how to build it, see the 
section “The Fundamentals: A Static Linear Analysis” in the book Introduction to the 
Structural Mechanics Module.

Application Library path: Structural_Mechanics_Module/Tutorials/
bracket_basic
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Introduction

The various examples of a bracket form a suite of tutorials which summarizes the 
fundamentals when modeling structural mechanics problems in COMSOL Multiphysics 
and the Structural Mechanics Module. 

This example illustrates how to solve a structural contact problem between two elastic 
bodies. You learn how to manually add a Contact pair node and define the boundaries to 
be in contact, then add the Contact boundary condition to enable the structural contact 
between the two parts of the assembly. It also shows how to compute the pre-tension in a 
bolt.

It is recommended that you review the Introduction to the Structural Mechanics 
Module, which includes background information and discusses the bracket_basic.mph 
model relevant to this example. 

Model Definition

This tutorial is an extension to the model example described in the section “The 
Fundamentals: A Static Linear Analysis” in the Introduction to the Structural Mechanics 
Module. In the original model, a displacement constraint is used to represent the 
mounting bolts, while in the current model the bolts and the fixation plate are modeled 
(see Figure 1). The contact pressures between the bracket, the bolts and the plate are 
computed. In the first study, the bolts are assumed to be bonded to the bracket and the 
bolt, and the pre-tension in the bolts is computed. In a second study an external load is 
applied to the bracket arm and contact forces including friction is computed between all 
parts of the assembly.
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Figure 1: The geometry of the bracket, the bolts and the mounting plate.

Results and Discussion

Figure 2 shows the displacement with only the pre-tension in bolt. The bolts are assumed 
to be bonded with the plate and the bracket. The maximum displacement in the bracket 
is around the bolt region. 
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Figure 2: Total displacement under bolt pre-tension load case.

Figure 3 shows the contact pressure distribution between the bracket and the plate under 
bolt pre-tension load case. The contact pressure is computed using the penalty method.
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Figure 3: Contact pressure distribution between the bracket and the plate under bolt 
pre-tension load case.

Figure 4 shows the displacement when the contact pressure is computed between each 
part of the assembly under external load and bolt pre-tension.
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Figure 4: Total displacement of the assembly under external load and bolt pre-tension.

Figure 5 shows the contact pressure distribution between the bracket and the plate under 
external load and bolt pre-tension load case. The contact pressure is computed using the 
augmented lagrangian method.
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Figure 5: Contact pressure distribution between the bracket and the plate under external load 
and bolt pre-tension.

Figure 6 shows the contact pressure distribution under the bold heads with external load 
and bolt pre-tension load case. The contact pressure is computed using the augmented 
Lagrangian method.
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Figure 6: Contact pressure distribution under the bolt heads with external load and bolt 
pre-tension.

Figure 7 shows the friction force distribution between under the bolt heads with external 
load and bolt pre-tension load case.
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Figure 7: Contact pressure distribution under the bolt heads with external load and bolt 
pre-tension.

Notes About the COMSOL Implementation

In COMSOL Multiphysics, the contact pressure is evaluated as a function of the gap 
distance between the parts that are set to be in contact. This gap value is evaluated in the 
Contact pair node, where you define the source and destination boundaries. 

When modeling contact, it is recommended to use a finer mesh on the destination contact 
boundary than on the source contact boundary. 

In contact problems, it is common that some components are not sufficiently constrained 
in the initial configuration. There are then possible rigid body motions, and it is not 
possible to find a converged solution. Also, when modeling a frictionless contact, sliding 
may be unconstrained even after contact is established.

In this example, bonded contact with the bolts is assumed in the first study. Bonded 
contact can be implemented using identity pairs and a continuity boundary condition. 
This way the displacements in all directions are continuous between the pair boundaries.

In the second study, weak springs are used to suppress the initial singularity. This is a 
common approach. It is often possible to stabilize a problem with springs that are so weak 
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that the forces they generate in the converged state are negligible. It is also possible to 
remove the springs gradually during the solution, or in a separate study step.

To compute the contact pressure you can either choose the penalty method or the 
augmented Lagrangian method. The penalty provides a faster and more stable solution, 
while the augmented Lagrangian method ensures minimal penetration between the parts 
in contact and accurate contact stresses.

Read more about how to set contact problem in the Contact Modeling in the Structural 
Mechanics User’s Guide.

Application Library path: Structural_Mechanics_Module/Tutorials/
bracket_contact

Modeling Instructions

From the File menu, choose Open.

Browse to the application’s Application Libraries folder and double-click the file 
bracket_basic.mph.

G E O M E T R Y  1

Import 2 (imp2)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
bracket_bolt_and_support.mphbin.

5 Click Import.

Explicit Selection 1 (sel1)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Bolts in the Label text field.

3 Locate the Entities to Select section. From the Geometric entity level list, choose Object.

4 Select the object imp2(2) only.
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Form Union (fin)
The Form Union/Assembly node determines how the parts of the assembly are considered 
in the analysis. By using the default setting, Form a union, the parts of the assembly are 
considered to be one unique object. The mounting bolts are automatically bonded to the 
bracket and the support plate. Select Form an assembly to consider each part of the 
assembly as a separate object. The mounting bolts are not connected to the bracket or the 
support plate. You need to include pairs to connect assembly parts with each other.

1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Form Union 

(fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly 
section.

3 From the Action list, choose Form an assembly.

4 From the Pair type list, choose Contact pair.

5 From the Repair tolerance list, choose Relative.

6 In the Relative repair tolerance text field, type 1E-3.

7 Right-click Component 1 (comp1)>Geometry 1>Form Union (fin) and choose Build 

Selected.

8 Click the Zoom Extents button on the Graphics toolbar.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Titanium beta-21S.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

M A T E R I A L S

Titanium beta-21S (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Titanium 

beta-21S (mat2).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Bolts.
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S O L I D  M E C H A N I C S  ( S O L I D )

Bolt Pre-Tension 1
1 On the Physics toolbar, click Global and choose Bolt Pre-Tension.

2 In the Settings window for Bolt Pre-Tension, locate the Bolt Pre-Tension section.

3 From the Pre-tension type list, choose Pre-tension stress.

4 In the σp text field, type 400[MPa].

Bolt Selection 1
1 In the Model Builder window, expand the Bolt Pre-Tension 1 node, then click Bolt 

Selection 1.

2 Select Boundary 87 only.

Bolt Pre-Tension 1
In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click Bolt 

Pre-Tension 1.

Bolt Selection 2
1 On the Physics toolbar, click Attributes and choose Bolt Selection.

2 Select Boundary 92 only.

3 In the Settings window for Bolt Selection, locate the Bolt Selection section.

4 In the Bolt label text field, type Bolt_2.

Bolt Pre-Tension 1
In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click Bolt 

Pre-Tension 1.

Bolt Selection 3
1 On the Physics toolbar, click Attributes and choose Bolt Selection.

2 Select Boundary 129 only.

3 In the Settings window for Bolt Selection, locate the Bolt Selection section.

4 In the Bolt label text field, type Bolt_3.

Bolt Pre-Tension 1
In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click Bolt 

Pre-Tension 1.

Bolt Selection 4
1 On the Physics toolbar, click Attributes and choose Bolt Selection.
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2 Select Boundary 134 only.

3 In the Settings window for Bolt Selection, locate the Bolt Selection section.

4 In the Bolt label text field, type Bolt_4.

Fixed Constraint 1
1 In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 

Fixed Constraint 1.

2 In the Settings window for Fixed Constraint, locate the Boundary Selection section.

3 Click Clear Selection.

4 Select Boundary 5 only.

Continuity 1
On the Physics toolbar, in the Boundary section, click Pairs and choose Continuity.

D E F I N I T I O N S

1 In the Model Builder window, expand the Component 1 (comp1)>Definitions node, then 
click Contact Pair 2 (ap2).

2 In the Settings window for Pair, locate the Pair Type section.

3 From the Pair type list, choose Identity pair.

4 In the Model Builder window, under Component 1 (comp1)>Definitions click Contact Pair 

3 (ap3).

5 In the Settings window for Pair, locate the Pair Type section.

6 From the Pair type list, choose Identity pair.

S O L I D  M E C H A N I C S  ( S O L I D )

Continuity 1
1 In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 

Continuity 1.

2 In the Settings window for Continuity, locate the Pair Selection section.

3 In the Pairs list, choose Identity Pair 2 (ap2) and Identity Pair 3 (ap3).

Contact 1
1 On the Physics toolbar, in the Boundary section, click Pairs and choose Contact.

2 In the Settings window for Contact, locate the Pair Selection section.

3 In the Pairs list, select Contact Pair 1 (ap1).

4 Locate the Contact Pressure Method section. From the list, choose Penalty.
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A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  1

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node, then click Stationary 

Solver 1.

3 In the Settings window for Stationary Solver, locate the General section.

4 In the Relative tolerance text field, type 1e-4.

5 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Dependent Variables 1 node, then click Displacement field (Material) (comp1.u).

6 In the Settings window for Field, locate the Scaling section.

7 In the Scale text field, type 1e-4.

8 On the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
Click the Zoom Extents button on the Graphics toolbar.

Surface 1
1 In the Model Builder window, expand the Results>Stress (solid) node, then click Surface 1.

2 In the Settings window for Surface, type Displacement, bolt bonded in the Label text 
field.

3 Locate the Expression section. In the Expression text field, type solid.disp.

4 On the Stress (solid) toolbar, click Plot.

3D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Contact pressure, penalty in the 
Label text field.
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Surface 1
1 Right-click Contact pressure, penalty and choose Surface.

2 On the Contact pressure, penalty toolbar, click Plot.

3 In the Model Builder window, under Results>Contact pressure, penalty click Surface 1.

4 In the Settings window for Surface, locate the Expression section.

5 In the Expression text field, type solid.Tn_ap1.

6 On the Contact pressure, penalty toolbar, click Plot.

D E F I N I T I O N S

Contact Pair 4 (p4)
1 On the Definitions toolbar, click Pairs and choose Contact Pair.

2 Select Boundary 4 only.

3 In the Settings window for Pair, locate the Destination Boundaries section.

4 Select the Active toggle button.

5 Select Boundaries 73, 81, 115, and 123 only.

Contact Pair 5 (p5)
1 On the Definitions toolbar, click Pairs and choose Contact Pair.

2 Select Boundaries 39 and 49 only.

3 In the Settings window for Pair, locate the Destination Boundaries section.

4 Select the Active toggle button.

5 Select Boundaries 70, 78, 112, and 120 only.

S O L I D  M E C H A N I C S  ( S O L I D )

Contact 2
1 On the Physics toolbar, in the Boundary section, click Pairs and choose Contact.

2 In the Settings window for Contact, locate the Pair Selection section.

3 In the Pairs list, choose Contact Pair 4 (p4) and Contact Pair 5 (p5).

4 Locate the Penalty Factor section. From the Tuned for list, choose Speed.

5 Locate the Initial Values section. In the Tn text field, type 10[MPa].

Friction 1
1 On the Physics toolbar, click Attributes and choose Friction.

2 In the Settings window for Friction, locate the Friction section.
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3 In the μstat text field, type 0.2.

4 Locate the Initial Values section. From the Previous contact state list, choose In contact.

Contact 1
1 In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 

Contact 1.

2 In the Settings window for Contact, locate the Contact Pressure Method section.

3 From the list, choose Augmented Lagrangian.

4 Locate the Penalty Factor section. From the Tuned for list, choose Speed.

5 Locate the Initial Values section. In the Tn text field, type solid.Tn_ap1.

Friction 1
1 On the Physics toolbar, click Attributes and choose Friction.

2 In the Settings window for Friction, locate the Friction section.

3 In the μstat text field, type 0.1.

4 Locate the Initial Values section. From the Previous contact state list, choose In contact.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

D E F I N I T I O N S

Analytic 1 (an1)
1 On the Home toolbar, click Functions and choose Local>Analytic.

2 In the Settings window for Analytic, type load in the Function name text field.

3 Locate the Definition section. In the Expression text field, type F*cos(atan2(py,
abs(px))).

4 In the Arguments text field, type F, py, px.

Name Expression Value Description

P0 2.5[MPa] 2.5E6 Pa Peak load intensity

YC -300[mm] -0.3 m Y coordinate of hole center

para 1 1 Control parameter
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5 Locate the Units section. In the Arguments text field, type Pa, m, m.

6 In the Function text field, type Pa.

Step 1 (step1)
1 On the Home toolbar, click Functions and choose Local>Step.

2 In the Settings window for Step, locate the Parameters section.

3 In the Location text field, type 0.25.

4 Click to expand the Smoothing section. In the Size of transition zone text field, type 0.5.

Step 2 (step2)
1 On the Home toolbar, click Functions and choose Local>Step.

2 In the Settings window for Step, locate the Parameters section.

3 In the Location text field, type 0.75.

4 In the From text field, type 1.

5 In the To text field, type 0.

6 Locate the Smoothing section. In the Size of transition zone text field, type 0.5.

S O L I D  M E C H A N I C S  ( S O L I D )

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 26 and 65 only.

3 In the Settings window for Boundary Load, locate the Coordinate System Selection 
section.

4 From the Coordinate system list, choose Boundary System 1 (sys1).

5 Locate the Force section. Specify the FA vector as

Spring Foundation 1
1 On the Physics toolbar, click Domains and choose Spring Foundation.

2 Select Domains 2–10 only.

3 In the Settings window for Spring Foundation, locate the Spring section.

4 In the kV text field, type 1e12*step2(para).

0 t1

0 t2

load(-P0,Y-YC,Z)*step1(para) n
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A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

Step 1: Stationary
Disable the continuity condition.

1 In the Model Builder window, under Study 2 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify physics tree and variables for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>Solid Mechanics 

(solid)>Continuity 1.

5 Click Disable.

6 Click to expand the Study extensions section. Locate the Study Extensions section. Select 
the Auxiliary sweep check box.

7 Click Add.

8 In the table, enter the following settings:

9 Click to expand the Values of dependent variables section. Locate the Values of Dependent 

Variables section. Find the Initial values of variables solved for subsection. From the 
Settings list, choose User controlled.

10 From the Method list, choose Solution.

11 From the Study list, choose Study 1, Stationary.

12 Find the Values of variables not solved for subsection. From the Settings list, choose User 

controlled.

13 From the Method list, choose Solution.

14 From the Study list, choose Study 1, Stationary.

Parameter name Parameter value list Parameter unit

para range(0,0.25,1)
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Solution 2 (sol2)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 2 (sol2) node, then click Dependent 

Variables 1.

3 In the Settings window for Dependent Variables, locate the General section.

4 From the Defined by study step list, choose User defined.

5 In the Model Builder window, expand the Study 2>Solver Configurations>Solution 2 

(sol2)>Dependent Variables 1 node, then click Contact pressure (comp1.solid.Tn_ap1).

6 In the Settings window for Field, locate the Scaling section.

7 In the Scale text field, type 2e8.

8 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2)>

Dependent Variables 1 click Contact pressure (comp1.solid.Tn_p4).

9 In the Settings window for Field, locate the Scaling section.

10 In the Scale text field, type 2e8.

11 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2)>

Dependent Variables 1 click Contact pressure (comp1.solid.Tn_p5).

12 In the Settings window for Field, locate the Scaling section.

13 In the Scale text field, type 2e8.

14 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2)>

Dependent Variables 1 click Friction force (Spatial) (comp1.solid.Tt_ap1).

15 In the Settings window for Field, locate the Scaling section.

16 In the Scale text field, type 2e7.

17 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2)>

Dependent Variables 1 click Friction force (Spatial) (comp1.solid.Tt_p4).

18 In the Settings window for Field, locate the Scaling section.

19 In the Scale text field, type 2e7.

20 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2)>

Dependent Variables 1 click Friction force (Spatial) (comp1.solid.Tt_p5).

21 In the Settings window for Field, locate the Scaling section.

22 In the Scale text field, type 2e7.

23 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2)>

Dependent Variables 1 click Pre-deformation (comp1.solid.pblt1.sblt1.d_pre).

24 In the Settings window for State, locate the General section.
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25 Clear the Solve for this state check box.

26 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2)>

Dependent Variables 1 click Pre-deformation (comp1.solid.pblt1.sblt2.d_pre).

27 In the Settings window for State, locate the General section.

28 Clear the Solve for this state check box.

29 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2)>

Dependent Variables 1 click Pre-deformation (comp1.solid.pblt1.sblt3.d_pre).

30 In the Settings window for State, locate the General section.

31 Clear the Solve for this state check box.

32 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2)>

Dependent Variables 1 click Pre-deformation (comp1.solid.pblt1.sblt4.d_pre).

33 In the Settings window for State, locate the General section.

34 Clear the Solve for this state check box.

35 On the Study toolbar, click Compute.

R E S U L T S

Stress (solid) 1
1 In the Model Builder window, under Results click Stress (solid) 1.

2 In the Settings window for 3D Plot Group, type Displacement in the Label text field.

Surface 1
1 In the Model Builder window, expand the Results>Displacement node, then click Surface 

1.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type solid.disp.

4 On the Displacement toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

Contact pressure, penalty
In the Model Builder window, under Results right-click Contact pressure, penalty and choose 
Duplicate.

Contact pressure, penalty 1
1 In the Settings window for 3D Plot Group, type Contact pressure, augmented 

Lagrange in the Label text field.

2 Locate the Data section. From the Data set list, choose Study 2/Solution 2 (sol2).
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3 On the Contact pressure, augmented Lagrange toolbar, click Plot.

Contact pressure, augmented Lagrange
In the Model Builder window, under Results right-click Contact pressure, augmented 

Lagrange and choose Duplicate.

Contact pressure, augmented Lagrange 1
In the Settings window for 3D Plot Group, type Contact pressure, bolts in the Label 
text field.

Surface 1
1 In the Model Builder window, expand the Results>Contact pressure, bolts node, then click 

Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type solid.Tn_p4.

Surface 2
1 Right-click Results>Contact pressure, bolts>Surface 1 and choose Duplicate.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type solid.Tn_p5.

4 Click to expand the Inherit style section. Locate the Inherit Style section. From the Plot 
list, choose Surface 1.

5 On the Contact pressure, bolts toolbar, click Plot.

Contact pressure, bolts
In the Model Builder window, under Results right-click Contact pressure, bolts and choose 
Duplicate.

Contact pressure, bolts 1
In the Settings window for 3D Plot Group, type Friction force norm in the Label text 
field.

Surface 1
1 In the Model Builder window, expand the Results>Friction force norm node, then click 

Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type solid.cnt2.fric1.Ttnorm_p4.

Surface 2
1 In the Model Builder window, under Results>Friction force norm click Surface 2.
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2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type solid.cnt2.fric1.Ttnorm_p5.

4 On the Friction force norm toolbar, click Plot.

If you want to generate a model which is identical to the one in the model library, follow 
the instructions below. Otherwise, the modeling is complete.

Displacement
Click the Zoom Extents button on the Graphics toolbar.

S T U D Y  1

Step 1: Stationary
1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 Select the Modify physics tree and variables for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>Solid Mechanics 

(solid)>Contact 1>Friction 1.

5 Click Disable.

6 In the Physics and variables selection tree, select Component 1 (comp1)>Solid Mechanics 

(solid)>Contact 2.

7 Click Disable.

8 In the Physics and variables selection tree, select Component 1 (comp1)>Solid Mechanics 

(solid)>Boundary Load 1.

9 Click Disable.

10 In the Physics and variables selection tree, select Component 1 (comp1)>Solid Mechanics 

(solid)>Spring Foundation 1.

11 Click Disable.
22 |  B R A C K E T — C O N T A C T  A N A L Y S I S



Created in COMSOL Multiphysics 5.2a
B r a c k e t—Eig en f r e qu en c y  Ana l y s i s
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


Introduction

In this example you learn how to perform an eigenfrequency analysis for both an unloaded 
structure and a prestressed structure.

In the case when the structure is subjected to a constant external load, the stiffness 
generated by the stress may affect the natural frequencies of the structure. Tensile stresses 
tend to increase the natural frequencies, while compressive stresses tend to decrease them.

It is recommended you review the Introduction to the Structural Mechanics Module, 
which includes background information and discusses the bracket_basic.mph model 
relevant to this example.

Model Definition

This tutorial is an extension to the example described in the section “The Fundamentals: 
A Static Linear Analysis” in the Introduction to the Structural Mechanics Module. 

The model geometry is represented in Figure 1.

Figure 1: Geometry of the bracket.
2 |  B R A C K E T — E I G E N F R E Q U E N C Y  A N A L Y S I S



The first case studies the natural frequency of the unloaded bracket, while in the second 
case the study considers how the natural frequencies are affected by an external load 
applied at the bracket holes. The left arm is under a pure tensile load while the right arm 
is under pure compressive load.

Results and Discussion

Figure 2 and Figure 3 show the first sixth eigenmode for both the unloaded and the 
prestressed case, respectively. The mode shape are listed in order from left to right and top 
to bottom. One can noticed the difference in the two first mode shape between the two 
load case. 

The two first mode shapes correspond to the bending mode in x-direction in the bracket 
arm, for the unloaded case these are expected to about the same. For the prestressed load 
case however one expect a difference because of stress stiffening (left arm) and stress 
softening (right arm).

Figure 2: Six first eigenmode shapes for the unloaded case.
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Figure 3: Six first eigenmode shapes for the prestressed case.
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In Figure 4 below one can see the frequency shift in the two first eigenmode.

Figure 4: Six first eigenfrequencies for the unlaoaded case (star marker) and for the prestressed 
case (round marker).

For the unloaded case the two first eigenfrequency are about 115 Hz and correspond to 
the bending mode in the x-direction for both bracket arms. For the prestressed load case, 
the bending mode in both bracket arms are about 108 Hz for the right arm and 128 Hz 
for the left arm. Such a frequency shift are expected as a tensile load causes stress stiffening 
while a compressive load causes stress softening. The other mode shape are not 
significantly affected by the prestress load case.

Notes About the COMSOL Implementation

For a structural mechanics application in COMSOL Multiphysics, there are two 
predefined study types available for eigenfrequency analysis: Eigenfrequency and Prestressed 

Analysis, Eigenfrequency.

The eigenfrequency analysis compute the natural frequencies of the unloaded structure. 
The contribution of any load boundary condition is disregarded and the Prescribed 

displacement constraints are considered as having the value zero.
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The prestressed eigenfrequency analysis, however first performs a stationary analysis to 
take into account the different loads and non-zero displacement constraints. The stress is 
then added automatically to the stiffness used in the eigenfrequency calculation.

Application Library path: Structural_Mechanics_Module/Tutorials/
bracket_eigenfrequency

Modeling Instructions

From the File menu, choose Open.

Browse to the application’s Application Libraries folder and double-click the file 
bracket_basic.mph.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Eigenfrequency.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  1

Step 1: Eigenfrequency
In the Eigenfrequency study node you have the possibility to define the number of 
eigenfrequencies to compute, and the frequency around which you would like to search 
for the these frequencies. By default, the eigenvalue solver computes for the six lowest 
frequencies.

1 In the Model Builder window, under Study 1 click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 Select the Desired number of eigenfrequencies check box.

4 In the associated text field, type 10.

5 On the Home toolbar, click Compute.
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R E S U L T S

Mode Shape (solid)
Click the Zoom Extents button on the Graphics toolbar.

Global Evaluation 1
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Expressions section.

3 In the table, enter the following settings:

4 Click Evaluate.

You can access the different eigenfrequency solutions in the 3D Plot Group Settings. Here 
you can see that, due to the symmetry, the eigenfrequency solver finds a frequency for each 
of the bracket arms, which is why every frequency is repeated in the solution list.

Note that the displacement values are normalized and have no physical significance. The 
normalization method can be changed in the Eigenvalue Solver node, available under the 
Solver Configuration node.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

D E F I N I T I O N S

Analytic 1 (an1)
1 On the Home toolbar, click Functions and choose Local>Analytic.

2 In the Settings window for Analytic, type load in the Function name text field.

3 Locate the Definition section. In the Expression text field, type F*cos(atan2(py,
abs(px))).

Expression Unit Description

freq 1/s Frequency

Name Expression Value Description

P0 30[MPa] 3E7 Pa Peak load intensity

YC -300[mm] -0.3 m Y coordinate of hole center
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4 In the Arguments text field, type F, py, px.

5 Locate the Units section. In the Arguments text field, type Pa, m, m.

6 In the Function text field, type Pa.

S O L I D  M E C H A N I C S  ( S O L I D )

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

Apply a boundary load to the bracket holes.

2 In the Settings window for Boundary Load, locate the Boundary Selection section.

3 From the Selection list, choose Right hole.

4 Locate the Coordinate System Selection section. From the Coordinate system list, choose 
Boundary System 1 (sys1).

5 Locate the Force section. Specify the FA vector as

Boundary Load 2
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 In the Settings window for Boundary Load, locate the Boundary Selection section.

3 From the Selection list, choose Left hole.

4 Locate the Coordinate System Selection section. From the Coordinate system list, choose 
Boundary System 1 (sys1).

5 Locate the Force section. Specify the FA vector as

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

The prestressed eigenfrequency analysis is available as a predefined study.

0 t1

0 t2

load(-P0,Z,Y-YC)*(Y>YC) n

0 t1

0 t2

load(-P0,Z,Y-YC)*(Y<YC) n
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3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Prestressed 

Analysis, Eigenfrequency.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

Step 1: Stationary
Note that the newly generated study combines one stationary analysis and one 
eigenfrequency analysis.

Step 2: Eigenfrequency
1 In the Model Builder window, under Study 2 click Step 2: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 Select the Desired number of eigenfrequencies check box.

4 In the associated text field, type 10.

5 In the Search for eigenfrequencies around text field, type 100.

6 On the Home toolbar, click Compute.

R E S U L T S

Mode Shape (solid) 1
1 Click the Zoom Extents button on the Graphics toolbar.

In the settings for the second plot group you can see the list of the new 
eigenfrequencies.

Global Evaluation 1
1 In the Model Builder window, under Results>Derived Values click Global Evaluation 1.

2 In the Settings window for Global Evaluation, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (sol2).

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

3D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

Expression Unit Description

freq 1/s Frequency, Prestress
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2 In the Settings window for 3D Plot Group, type Prestress in the Label text field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution Store 1 (sol3).

Surface 1
1 Right-click Prestress and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type solid.mises.

4 Right-click Results>Prestress>Surface 1 and choose Deformation.

Deformation 1
On the Prestress toolbar, click Plot.

1D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Eigenfrequency in the Label text field.

3 Locate the Plot Settings section. Select the y-axis label check box.

4 In the associated text field, type Frequency [Hz].

5 Locate the Grid section. Select the Manual spacing check box.

6 Click to expand the Legend section. From the Position list, choose Upper left.

Table Graph 1
1 On the Eigenfrequency toolbar, click Table Graph.

2 In the Settings window for Table Graph, locate the Data section.

3 From the x-axis data list, choose Row index.

4 From the Plot columns list, choose Manual.

5 In the Columns list, choose Frequency (1/s) and Frequency, Prestress (1/s).

6 Click to expand the Legends section. Select the Show legends check box.

7 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose None.

8 Find the Line markers subsection. From the Marker list, choose Cycle.

9 From the Positioning list, choose In data points.

10 On the Eigenfrequency toolbar, click Plot.

11 Click the y-Axis Log Scale button on the Graphics toolbar.
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Introduction

The frequency response analysis solves for the linear steady-state response of a structure 
from harmonic loads. The problem is solved in the frequency domain and you can set a 
range of frequencies at which to compute the structural displacements.

In this example you learn how to perform a frequency response analysis of a structure 
under harmonic load but also how to perform a frequency response analysis of a 
prestressed structure.

It is recommended you review the Introduction to the Structural Mechanics Module, 
which includes background information and discusses the bracket_basic.mph model 
relevant to this example.

Model Definition

This model is an extension to the model example described in the section “The 
Fundamentals: A Static Linear Analysis” in the Introduction to the Structural Mechanics 
Module. 

The model geometry is represented in Figure 1.
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Figure 1: Bracket geometry

You study two load cases, the first one consists of a fully harmonic load case with an 
external load of 100 kPa applied to the bracket arms, the second load case consists of a 
combination of a static load and a harmonic perturbation.

An eigenfrequency analysis of this problem is performed in the tutorial Bracket—
Eigenfrequency Analysis. It shows that the first resonance frequency is about 115 Hz. For 
the loaded case, the eigenfrequency solver shows that the first resonance frequency is 
about 108 Hz when the arm is under compressive load and about 128 Hz when the arm 
is under tensile load. In order to capture the resonance peak properly, you can refine the 
frequency step around these values.
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Results and Discussion

Figure 2 shows the root mean square of the displacement at the tip of the left arm of the 
bracket for both the fully harmonic load case and the combined harmonic and static load 
cases.

Figure 2: Root mean square of the displacement at the tip of the left (red) and right (blue) 
arms for both fully harmonic loaded case (solid) and a combined static and harmonic loaded 
case (dashed).

The curves show resonance peaks around 115  Hz for the unloaded structure in both 
bracket arms and the frequency shift for the loaded structure. These results are in 
agreement with the values predicted by solving with the eigenfrequency solver. 

You can also verify that the deformation remains small even around the resonance 
frequency.
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Figure 3 shows the phase of the x-displacement at the tip of the bracket right arm.

Figure 3: Phase of x-displacement at the tip of the bracket right arm.

Note the smooth transition around the resonance frequency which results from the 
damping using a 5% loss factor. The prestressed load case solution show a double phase 
change corresponding to the two resonance modes.

Notes About the COMSOL Implementation

For a structural mechanics application in COMSOL Multiphysics, there are three 
predefined study types available for frequency response analysis: Frequency Domain, 
Frequency-Domain Modal and Prestressed Analysis, Frequency Domain.

The frequency domain analysis computes for the structural response of an harmonic load. 
All loads and boundary conditions are assumed to be harmonic. 

The frequency-domain modal analysis uses the modal solver to compute the frequency 
response. This analysis type significantly speed up the computation compare to the regular 
frequency domain analysis.
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Use the prestressed frequency response analysis when a structure is subjected to both static 
and harmonic loads, and the stiffness induced by the static load case can affect the 
structural response to the harmonic load.

Application Library path: Structural_Mechanics_Module/Tutorials/
bracket_frequency

Modeling Instructions

From the File menu, choose Open.

Browse to the application’s Application Library folder and double-click the file 
bracket_basic.mph.

S O L I D  M E C H A N I C S  ( S O L I D )

Fixed Constraint 1
In the Model Builder window, expand the Component 1 (comp1)>Solid Mechanics (solid) 
node.

Linear Elastic Material 1
In the Model Builder window, expand the Solid Mechanics (solid) node, then click Linear 

Elastic Material 1.

Damping 1
1 On the Physics toolbar, click Attributes and choose Damping.

In the frequency domain you can use loss factor damping or Rayleigh damping. For this 
example use loss factor damping.

2 In the Settings window for Damping, locate the Damping Settings section.

3 From the Damping type list, choose Isotropic loss factor.

M A T E R I A L S

Structural steel (mat1)
1 In the Model Builder window, expand the Component 1 (comp1)>Materials node, then 

click Structural steel (mat1).

2 In the Settings window for Material, locate the Material Contents section.
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3 In the table, enter the following settings:

You can now apply an external harmonic load to the bracket arms.

S O L I D  M E C H A N I C S  ( S O L I D )

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 4, 5, 42, and 43 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the FA vector as

In the frequency domain modal analysis, to define a harmonic load you need to mark the 
load as being a harmonic perturbation.

5 In the Model Builder window, right-click Boundary Load 1 and choose Harmonic 

Perturbation.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select study tree, select Preset Studies>

Frequency-Domain Modal.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  1

Step 1: Eigenfrequency
1 In the Model Builder window, under Study 1 click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

Property Name Value Unit Property group

Isotropic structural loss 
factor

eta_s 0.05 1 Basic

10[kPa] x

0 y

0 z
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3 Select the Desired number of eigenfrequencies check box.

4 In the associated text field, type 2.

Step 2: Frequency-Domain Modal
The frequency range will be 50 Hz-190 Hz with a refined frequency sweep step between 
100 Hz and 130 Hz.

1 In the Model Builder window, under Study 1 click Step 2: Frequency-Domain Modal.

2 In the Settings window for Frequency-Domain Modal, locate the Study Settings section.

3 In the Frequencies text field, type 50 70 90 range(100,1,130) 150 170 190.

4 On the Home toolbar, click Compute.

R E S U L T S

Stress (solid)
1 Click the Zoom Extents button on the Graphics toolbar.

The default plot group shows the stress distribution on a deformed geometry for the 
final frequency. You can change the frequency for the plot evaluation in the Parameter 

value list in the settings for the plot group.

Plot the root mean square of the displacement at the tip of the left arm of the bracket.

1D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Displacement, RMS in the Label text 
field.

3 Locate the Plot Settings section. Select the x-axis label check box.

4 In the associated text field, type Frequency (Hz).

Point Graph 1
On the Displacement, RMS toolbar, click Point Graph.

Displacement, RMS
1 Select Point 1 only.

2 In the Settings window for Point Graph, locate the y-Axis Data section.

3 In the Expression text field, type solid.disp_rms.

4 Click to expand the Coloring and style section. Locate the Coloring and Style section. 
From the Color list, choose Blue.

5 Find the Line markers subsection. From the Marker list, choose Point.
8 |  B R A C K E T — F R E Q U E N C Y - R E S P O N S E  A N A L Y S I S



6 From the Positioning list, choose In data points.

7 Click to expand the Legends section. Select the Show legends check box.

8 From the Legends list, choose Manual.

9 In the table, enter the following settings:

10 In the Model Builder window, click Displacement, RMS.

11 In the Settings window for 1D Plot Group, click to expand the Title section.

12 From the Title type list, choose None.

Point Graph 2
On the Displacement, RMS toolbar, click Point Graph.

Displacement, RMS
1 Select Point 75 only.

2 In the Settings window for Point Graph, locate the y-Axis Data section.

3 In the Expression text field, type solid.disp_rms.

4 Locate the Coloring and Style section. From the Color list, choose Red.

5 Find the Line markers subsection. From the Marker list, choose Square.

6 From the Positioning list, choose In data points.

7 Locate the Legends section. Select the Show legends check box.

8 From the Legends list, choose Manual.

9 In the table, enter the following settings:

10 On the Displacement, RMS toolbar, click Plot.

Now plot the phase shift with respect to the applied load at a specified point location.

Cut Point 3D 1
On the Results toolbar, click Cut Point 3D.

Data Sets
1 In the Settings window for Cut Point 3D, locate the Point Data section.

2 In the X text field, type 0.

Legends

full harmonic, right arm

Legends

full harmonic, left arm
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3 In the Y text field, type -50e-3.

4 In the Z text field, type -50e-3.

5 Select the Snap to closest boundary check box.

1D Plot Group 3
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Displacement phase, X component 
in the Label text field.

3 Locate the Title section. From the Title type list, choose None.

4 Locate the Plot Settings section. Select the x-axis label check box.

5 In the associated text field, type Frequency (Hz).

Point Graph 1
On the Displacement phase, X component toolbar, click Point Graph.

Displacement phase, X component
1 In the Settings window for Point Graph, locate the Data section.

2 From the Data set list, choose Cut Point 3D 1.

3 Locate the y-axis data section. Click solid.uPhaseX - Displacement phase, X component in 
the upper-right corner of the section. Locate the y-Axis Data section. From the Unit list, 
choose °.

4 Locate the Legends section. Select the Show legends check box.

5 From the Legends list, choose Manual.

6 In the table, enter the following settings:

7 On the Displacement phase, X component toolbar, click Plot.

In the solution data set feature, one can change the phase used to display the solution.

You will now consider a static load applied to the bracket and compute the prestressed 
frequency domain analysis.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

Legends

full harmonic
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3 Find the Studies subsection. In the Select study tree, select Preset Studies>Prestressed 

Analysis, Frequency Domain.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

D E F I N I T I O N S

Analytic 1 (an1)
1 On the Home toolbar, click Functions and choose Local>Analytic.

2 In the Settings window for Analytic, type load in the Function name text field.

3 Locate the Definition section. In the Expression text field, type F*cos(atan2(py,
abs(px))).

4 In the Arguments text field, type F, py, px.

5 Locate the Units section. In the Arguments text field, type Pa, m, m.

6 In the Function text field, type Pa.

S O L I D  M E C H A N I C S  ( S O L I D )

Boundary Load 2
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

Apply a boundary load to the bracket holes.

2 In the Settings window for Boundary Load, locate the Boundary Selection section.

3 From the Selection list, choose Right hole.

4 Locate the Coordinate System Selection section. From the Coordinate system list, choose 
Boundary System 1 (sys1).

Name Expression Value Description

P0 30[MPa] 3E7 Pa Peak load intensity

YC -300[mm] -0.3 m Y coordinate of hole 
center
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5 Locate the Force section. Specify the FA vector as

Boundary Load 3
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 In the Settings window for Boundary Load, locate the Boundary Selection section.

3 From the Selection list, choose Left hole.

4 Locate the Coordinate System Selection section. From the Coordinate system list, choose 
Boundary System 1 (sys1).

5 Locate the Force section. Specify the FA vector as

S T U D Y  2

Step 2: Frequency-Domain Perturbation
1 In the Model Builder window, under Study 2 click Step 2: Frequency-Domain Perturbation.

2 In the Settings window for Frequency-Domain Perturbation, locate the Study Settings 
section.

3 In the Frequencies text field, type 50 70 90 range(100,2,140) 150 170 190.

4 On the Home toolbar, click Compute.

R E S U L T S

Click the Zoom Extents button on the Graphics toolbar.

You have previously created a point graph plot for the unloaded case. Add a new point 
graph plot to the same figure but use the data set of the second load case.

Displacement, RMS
1 In the Model Builder window, under Results>Displacement, RMS select Point Graph 1 and 

Point Graph 2, right click on any one of them and choose Duplicate.

2 In the Model Builder window, under Results>Displacement, RMS click Point Graph 3.

0 t1

0 t2

load(-P0,Z,Y-YC)*(Y>YC) n

0 t1

0 t2

load(-P0,Z,Y-YC)*(Y<YC) n
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3 In the Settings window for Point Graph, locate the Data section.

4 From the Data set list, choose Study 2/Solution 3 (sol3).

5 Locate the y-Axis Data section. Clear the Compute differential check box.

6 Click to expand the Coloring and style section. Locate the Coloring and Style section. Find 
the Line style subsection. From the Line list, choose Dashed.

7 Locate the Legends section. In the table, enter the following settings:

8 In the Model Builder window, under Results>Displacement, RMS click Point Graph 4.

9 In the Settings window for Point Graph, locate the Data section.

10 From the Data set list, choose Study 2/Solution 3 (sol3).

11 Locate the y-Axis Data section. Clear the Compute differential check box.

12 Locate the Coloring and Style section. Find the Line style subsection. From the Line list, 
choose Dashed.

13 Locate the Legends section. In the table, enter the following settings:

14 On the Displacement, RMS toolbar, click Plot.

Data Sets
1 In the Model Builder window, under Results>Data Sets right-click Cut Point 3D 1 and 

choose Duplicate.

2 In the Settings window for Cut Point 3D, locate the Data section.

3 From the Data set list, choose Study 2/Solution 3 (sol3).

Displacement phase, X component
1 In the Model Builder window, under Results>Displacement phase, X component right-click 

Point Graph 1 and choose Duplicate.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Data set list, choose Cut Point 3D 2.

4 On the Displacement phase, X component toolbar, click Plot.

5 Locate the y-Axis Data section. Clear the Compute differential check box.

Legends

prestressed harmonic, right arm

Legends

prestressed harmonic, left arm
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6 Locate the Legends section. In the table, enter the following settings:

7 On the Displacement phase, X component toolbar, click Plot.

Stress (solid) 1
1 In the Model Builder window, under Results click Stress (solid) 1.

2 In the Settings window for 3D Plot Group, type Stress (solid), prestressed in 
the Label text field.

Legends

prestressed harmonic
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Introduction

The various examples of a bracket form a suite of tutorials which summarizes the 
fundamentals when modeling structural mechanics problems in COMSOL Multiphysics 
and the Structural Mechanics Module. 

In this example you learn how to introduce a prestrain to structure and investigate how it 
affects the assembly. 

It is recommended you review the Introduction to the Structural Mechanics Module, 
which includes background information.

Model Definition

This tutorial is an extension to the example described in the section “The Fundamentals: 
A Static Linear Analysis” in the Introduction to the Structural Mechanics Module. The 
same model is also available as a stand alone model in the Application Libraries as Bracket 
- Static Analysis.

In the previous example, the pin was only considered as giving a load, whereas in this 
example the pin is actually modeled as shown in Figure 1.

Figure 1: Bracket geometry.
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An initial strain simulates that the pin is 1 mm too short in the axial direction. This could 
for example happen if there was a mismatch in dimensions due to manufacturing 
tolerances.

Results

Figure 2 shows how the pin compresses the bracket arms, and that the largest stresses are 
found in the region where the bracket arms are joined to the bolt supports.

Figure 2: Von Mises stress distribution in the bracket.

Figure 3 shows the third principal strain to visualize the total strain in the structure. As the 
pin is stiff in comparison to the bracket, the total strain in the pin is almost the same as the 
initial strain given in the example.
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Figure 3: Strain distribution in the bracket.

Notes About the COMSOL Implementation

Initial stresses and strains can be specified in a subnode to a material model. Think of the 
strain or stress that you introduce as an inelastic contribution, which is not necessarily 
constant over the simulation. You can define a stress/strain distribution with constant 
values or as an expression which can, for example, be space- or time-dependent. The initial 
stresses and strains can also be results from another study, or even from another physics 
interface in the same study.

Application Library path: Structural_Mechanics_Module/Tutorials/
bracket_initial_strain

Modeling Instructions

From the File menu, choose Open.

Browse to the application’s Application Libraries folder and double-click the file 
bracket_basic.mph.
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G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

In the Parameters table, define a strain value that corresponds to a reduction of the pin 
length from 215 mm to 214 mm.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Add the pin geometry to the bracket assembly by importing it into the existing geometry.

Import 2 (imp2)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 From the Source list, choose COMSOL Multiphysics file.

4 Click Browse.

5 Browse to the application’s Application Libraries folder and double-click the file 
bracket_pin.mphbin.

6 Click Import.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Form Union 

(fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly 
section.

3 From the Repair tolerance list, choose Relative.

4 In the Relative repair tolerance text field, type 1E-4.

5 Right-click Component 1 (comp1)>Geometry 1>Form Union (fin) and choose Build 

Selected.

Name Expression Value Description

L0 215[mm] 0.215 m Initial pin length

L 214[mm] 0.214 m Current pin length

InitStrain (L-L0)/L0 -0.004651 Pin strain
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S O L I D  M E C H A N I C S  ( S O L I D )

Adding Initial Stress and Strain
Specify the initial strain under the Linear Elastic Material node.

1 In the Model Builder window, expand the Component 1 (comp1)>Solid Mechanics (solid) 
node, then click Linear Elastic Material 1.

Initial Stress and Strain 1
1 On the Physics toolbar, click Attributes and choose Initial Stress and Strain.

2 In the Settings window for Initial Stress and Strain, locate the Domain Selection section.

3 From the Selection list, choose Manual.

4 Select Domain 3 only.

The prestrain direction is the axial direction of the bolt, which coincides with the global 
x direction.

5 Locate the Initial Stress and Strain section. In the ε0 table, enter the following settings:

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  1

Step 1: Stationary
On the Home toolbar, click Compute.

R E S U L T S

Stress (solid)
Click the Zoom Extents button on the Graphics toolbar.

InitStrain 0 0

0 0 0

0 0 0
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3D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Third principal strain in the Label 
text field.

Surface 1
1 Right-click Third principal strain and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>Strain>

Principal strains>solid.ep3 - Third principal strain.

3 On the Third principal strain toolbar, click Plot.
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Introduction

Buckling analysis is an important study type in structural analysis because it provides an 
estimate of the critical load that can cause sudden collapse of the structure. In this example 
you first learn how to perform a linear buckling analysis to compute for the critical 
buckling load, you also see in a second study how to compute the nonlinear deformation 
while increasing the applied load until the buckling is reached.

It is recommended you review the Introduction to the Structural Mechanics Module, 
which includes background information and discusses the bracket_basic.mph model 
relevant to this example.

Model Definition

This model is an extension to the example described in the section “The Fundamentals: A 
Static Linear Analysis” in the Introduction to the Structural Mechanics Module. 

Due to nonlinearity in the numerical problem, it is recommended to refine the mesh in the 
area of interest. In this example, the geometry is subdivided in order to refine the mesh in 
the bracket right arm (see Figure 1) where the buckling load is applied.

Figure 1: Refined mesh.
2 |  B R A C K E T — L I N E A R  B U C K L I N G  A N A L Y S I S



The analysis computes the critical compressive load with load vector resultant oriented in 
the positive y-direction. The loads are projected on the y-axis in order to avoid torsion 
modes due to the z-component of load.

Results and Discussion

Figure 2 shows the first buckling mode for the bracket geometry. The critical load factor 
is about 6e4, which correspond to the critical buckling load given in Newton.

Figure 2: First buckling mode and critical load factor value.

Figure 3 shows the nonlinear displacement in the bracket right arm with respect to the 
increasing applied load (blue). You can see how the displacement deviates strongly from 
the linear response as the applied load gets closer to the critical buckling load computed 
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with the linear buckling analysis. A deviation of 20% is obtained with an applied load force 
of 57 kN.

Figure 3: Bracket right arm y-displacement versus applied load.

Notes About the COMSOL Implementation

A linear buckling analysis consists of the following operations:

• Perform a static analysis using a unit load.

• Compute the eigenvalue problem including the stresses from the static load. The first 
eigenvalue corresponds to the value of the critical buckling load.

COMSOL Multiphysics runs automatically the sequence described above and the returns 
the value of the critical buckling load.

To perform a nonlinear buckling analysis, use the continuation solver to ramp up the load 
smoothly. You can use a stop condition to automatically stop the solver once a criteria is 
reached. In this example, the stop criterion is the deviation in the y-displacement of 
bracket right arm with respect to the linear displacement. The linear displacement response 
is predicted by using the solution computed under a unit load case for the linear buckling.
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Application Library path: Structural_Mechanics_Module/Tutorials/
bracket_linear_buckling

Modeling Instructions

From the File menu, choose Open.

Browse to the application’s Application Libraries folder and double-click the file 
bracket_basic.mph.

C O M P O N E N T  1  ( C O M P 1 )

Prepare the geometry for a finer mesh on the arm which will buckle in this example.

G E O M E T R Y  1

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, locate the Plane Definition section.

3 From the Plane list, choose zx-plane.

4 From the Offset type list, choose Through vertex.

5 Find the Offset vertex subsection. Select the Active toggle button.

6 On the object imp1, select Point 17 only.

Partition Objects 1 (par1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Partition Objects.

2 Select the object imp1 only.

3 In the Settings window for Partition Objects, locate the Partition Objects section.

4 From the Partition with list, choose Work plane.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

D E F I N I T I O N S

Analytic 1 (an1)
1 On the Home toolbar, click Functions and choose Local>Analytic.

2 In the Settings window for Analytic, type load in the Function name text field.

3 Locate the Definition section. In the Expression text field, type F*cos(atan2(py,
abs(px))).

4 In the Arguments text field, type F, py, px.

5 Locate the Units section. In the Arguments text field, type Pa, m, m.

6 In the Function text field, type Pa.

Boundary System 1 (sys1)
The load direction does not change with deformation.

1 In the Model Builder window, under Component 1 (comp1)>Definitions click Boundary 

System 1 (sys1).

2 In the Settings window for Boundary System, locate the Settings section.

3 From the Frame list, choose Reference configuration.

S O L I D  M E C H A N I C S  ( S O L I D )

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 In the Settings window for Boundary Load, locate the Boundary Selection section.

3 From the Selection list, choose Right hole.

4 Locate the Coordinate System Selection section. From the Coordinate system list, choose 
Boundary System 1 (sys1).

Name Expression Value Description

F0 1[N] 1 N Applied force

R 25[mm] 0.025 m Hole radius

YC -300[mm] -0.3 m Y coordinate of hole 
center

thick 8[mm] 0.008 m Bracket arm thickness

P0 2/(thick*pi*R)*F0 3183 N/m² Peak load intensity
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5 Locate the Force section. Specify the FA vector as

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Tetrahedral.

Free Tetrahedral 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Tetrahedral 1 and choose Size.

Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Domain.

3 Select Domain 1 only.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 6e-3.

7 In the Model Builder window, click Mesh 1.

8 In the Settings window for Mesh, click Build All.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Linear 

Buckling.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  1

Step 1: Stationary
On the Home toolbar, click Compute.

0 t1

0 t2

load(-P0,Z,Y-YC)*(Y>YC) n
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R E S U L T S

Mode Shape (solid)
1 Click the Zoom Extents button on the Graphics toolbar.

The default plot shows the mode shape of the first buckling mode.

Derived Values
Evaluate the y-displacement corresponding to the applied unit load.

Point Evaluation 1
1 On the Results toolbar, click Point Evaluation.

2 In the Settings window for Point Evaluation, locate the Data section.

3 From the Data set list, choose Study 1/Solution Store 1 (sol2).

4 Select Point 5 only.

5 Locate the Expressions section. In the table, enter the following settings:

6 Click Evaluate.

You can now predict the linear relation between displacement and applied load. This can 
be used in the later analysis to predict when the nonlinear solution deviates from the linear 
one.

D E F I N I T I O N S

Integration 1 (intop1)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Geometric entity level list, choose Point.

4 Select Point 5 only.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

Expression Unit Description

v m Displacement field, Y component
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S T U D Y  2

Step 1: Stationary
1 In the Model Builder window, under Study 2 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Study Settings section.

3 Select the Include geometric nonlinearity check box.

4 Click to expand the Study extensions section. Locate the Study Extensions section. Select 
the Auxiliary sweep check box.

5 Click Add.

6 In the table, enter the following settings:

Solution 3 (sol3)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 3 (sol3) node.

3 In the Model Builder window, expand the Study 2>Solver Configurations>Solution 3 

(sol3)>Stationary Solver 1 node.

4 Right-click Parametric 1 and choose Stop Condition.

5 In the Settings window for Stop Condition, locate the Stop Expressions section.

6 Click Add.

7 In the table, enter the following settings:

8 Locate the Output at Stop section. From the Add solution list, choose Step after stop.

9 Clear the Add warning check box.

10 On the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
Click the Zoom Extents button on the Graphics toolbar.

Parameter 
name

Parameter value list

F0 1 1e3 5e3 1e4 2e4 5.924e4*log10(({range(2,1,10)}+1)/
1.1)^(1/5)

Stop expression Stop if Active Description

comp1.intop1(comp1.v)/
(F0*1.11E-8)/1.2

true √ Stop expression 1
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Create Figure 3.

1D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Data set list, choose Study 2/Solution 3 (sol3).

Point Graph 1
1 On the 1D Plot Group 3 toolbar, click Point Graph.

2 Select Point 5 only.

3 In the Settings window for Point Graph, locate the y-Axis Data section.

4 In the Expression text field, type v.

5 From the Unit list, choose mm.

1D Plot Group 3
1 In the Model Builder window, under Results click 1D Plot Group 3.

2 In the Settings window for 1D Plot Group, type Displacement in the Label text field.

3 Locate the Plot Settings section. Select the x-axis label check box.

4 In the associated text field, type Applied force [N].

5 Select the y-axis label check box.

6 In the associated text field, type y displacement [mm].

Point Graph 2
1 On the Displacement toolbar, click Point Graph.

2 Select Point 5 only.

3 In the Settings window for Point Graph, locate the y-Axis Data section.

4 In the Expression text field, type F0*1.11E-8[m/N].

5 From the Unit list, choose mm.

6 Click to expand the Coloring and style section. Locate the Coloring and Style section. Find 
the Line style subsection. From the Line list, choose Dashed.

7 On the Displacement toolbar, click Plot.
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Introduction

The various examples of a bracket form a suite of tutorials which summarizes the 
fundamentals when modeling structural mechanics problems in COMSOL Multiphysics 
and the Structural Mechanics Module. 

This example includes computing the solution to a case where the direction of the load is 
changed using a parametric sweep over a set of angles.

It is recommended you review the Introduction to the Structural Mechanics Module, 
which includes background information.

Model Definition

This model is an extension to the example described in the section “The Fundamentals: A 
Static Linear Analysis” in the Introduction to the Structural Mechanics Module. The 
same model is also available as a stand alone model in the Application Libraries as Bracket 
- Static Analysis.

The geometry is shown in Figure 1.

Figure 1: Bracket geometry.
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In this analysis, the mounting bolts are assumed to be fixed and securely bonded to the 
bracket. To model the external load from the pin, you specify a surface load p with a 
trigonometric distribution on the inner surfaces of the two holes:

where P0 is the peak load intensity. The main direction of the load is defined by , the 
angle from the y-axis. The load on the two holes act in opposite directions. The orientation 
of the load is controlled by a local coordinate system with axis directions generated using 
the sweep parameter theta0.

Results

Figure 2 shows the von Mises stress distribution corresponding to a bending load case, 
where the load acts in the positive z-direction in the left arm and in the negative 
z-direction in the right arm.

Figure 2: Von Mises stress under bending load case.

Figure 3 shows the von Mises stress distribution corresponding of a tensile load in the 
right arm and a compressive load in the left arm. The maximum von Mises stress value is 

p P0 α θ0–( )         π
2
---– α θ0–

π
2
---< <cos=

θ0
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lower in this case. A stress concentration can be seed also around the hole in the arm which 
is in tension.

Figure 3: Von Mises stress under tensile and compressive load case.
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Figure 4 shows the von Mises stress distribution corresponding of a load orientation of 
130°.

Figure 4: Von Mises stress for parameter theta0 = 130°.

Figure 5 shows that the x-component of the reaction force in all bolts for all load cases.

Figure 5: Reaction forces (x-component) as a function of angle.
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Figure 6 shows the y-component and Figure 7 shows the z-component of the of the 
reaction force in all bolts for all load cases.

Figure 6: Reaction forces (y-component) as a function of angle.

Figure 7: Reaction forces (z-component) as a function of load angle.
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Notes About the COMSOL Implementation

COMSOL Multiphysics has two ways to perform parametric studies—using either a 
Parametric Sweep node or the Auxiliary sweep from the Stationary Solver node. In this 
example, either method can be used. and the continuation feature in the Solver node is 
used. An Auxiliary sweep is used here, but the continuation solver is not used. The 
continuation solver uses the solution from the previous parameter as an initial guess to 
calculate the current parameter value, and is the preferred option for nonlinear problems. 
Using the Parametric Sweep node is preferable for applications requiring, for example, 
geometric parametrization.

Application Library path: Structural_Mechanics_Module/Tutorials/
bracket_parametric

Parametric studies can be set up from scratch or, as in this example, added to an existing 
study.

From the File menu, choose Open.

Browse to the application’s Application Libraries folder and double-click the file 
bracket_static.mph.

Click the Zoom Extents button on the Graphics toolbar.

G L O B A L  D E F I N I T I O N S

In this model, the stress in the bracket is computed for different load orientations. First 
add a parameter to set the load direction angle.

Parameters
1 In the Model Builder window, expand the Global Definitions node, then click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

D E F I N I T I O N S

Create a selection for the right hole carrying the load.

Name Expression Value Description

theta0 0[deg] 0 rad Load direction angle
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Explicit 5
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Right hole in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundary 4 only.

5 Select the Group by continuous tangent check box.

Create a selection for the left hole carrying the load.

Explicit 6
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Left hole in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundary 42 only.

5 Select the Group by continuous tangent check box.

You will now create a local coordinate system that will rotate with the load orientation.

Cylindrical System 2 (sys2)
1 On the Definitions toolbar, click Coordinate Systems and choose Cylindrical System.

2 In the Settings window for Cylindrical System, locate the Settings section.

3 Find the Origin subsection. In the table, enter the following settings:

4 Find the Longitudinal axis subsection. In the table, enter the following settings:

5 Find the Direction of axis φ=0 subsection. In the table, enter the following settings:

Analytic 1 (load)
Change the expression of the load distribution.

1 In the Model Builder window, under Component 1 (comp1)>Definitions click Analytic 1 

(load).

x (m) y (m) z (m)

0 YC 0

x y z

1 0 0

x y z

0 sin(theta0) cos(theta0)
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2 In the Settings window for Analytic, locate the Definition section.

3 In the Expression text field, type F*cos(p).

4 In the Arguments text field, type F, p.

5 Locate the Units section. In the Arguments text field, type Pa, rad.

S O L I D  M E C H A N I C S  ( S O L I D )

Change the boundary load to consider the parameterized direction.

Boundary Load 1
1 In the Model Builder window, expand the Component 1 (comp1)>Solid Mechanics (solid) 

node, then click Boundary Load 1.

2 In the Settings window for Boundary Load, locate the Boundary Selection section.

3 From the Selection list, choose Right hole.

4 Locate the Coordinate System Selection section. From the Coordinate system list, choose 
Cylindrical System 2 (sys2).

5 Locate the Force section. Specify the FA vector as

Boundary Load 2
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 In the Settings window for Boundary Load, locate the Boundary Selection section.

3 From the Selection list, choose Left hole.

4 Locate the Coordinate System Selection section. From the Coordinate system list, choose 
Cylindrical System 2 (sys2).

5 Locate the Force section. Specify the FA vector as

S T U D Y  1

Add an auxiliary sweep parameter, and compute the results.

load(-P0,sys2.phi)*(abs(sys2.phi)>pi/2) r

0 phi

0 a

load(P0,sys2.phi)*(abs(sys2.phi)<pi/2) r

0 phi

0 a
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Step 1: Stationary
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study extensions section.

3 Locate the Study Extensions section. Select the Auxiliary sweep check box.

4 Click Add.

5 In the table, enter the following settings:

6 From the Run continuation for list, choose No parameter.

7 On the Home toolbar, click Compute.

The default plot shows the solution for the last parameter value (160[deg]). You can easily 
change the parameter value to display the plot and then compare solutions for different 
load cases.

The following instructions reproduce Figure 2 to Figure 4.

R E S U L T S

Stress (solid)
1 In the Model Builder window, under Results click Stress (solid).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Parameter value (theta0 (deg)) list, choose 0.

4 On the Stress (solid) toolbar, click Plot.

5 From the Parameter value (theta0 (deg)) list, choose 90.

6 On the Stress (solid) toolbar, click Plot.

7 From the Parameter value (theta0 (deg)) list, choose 130.

8 On the Stress (solid) toolbar, click Plot.

9 Click the Zoom Extents button on the Graphics toolbar.

Derived Values
You will now create a plot showing how the reaction forces vary with the load angle.

1 In the Model Builder window, under Results right-click Derived Values and choose Clear 

All.

2 On the Results toolbar, click Evaluate All.

Parameter name Parameter value list Parameter unit

theta0 range(0,10,160) deg
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1D Plot Group 4
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Reaction force, x component in 
the Label text field.

Table Graph 1
1 On the Reaction force, x component toolbar, click Table Graph.

2 In the Settings window for Table Graph, locate the Data section.

3 From the Plot columns list, choose Manual.

4 In the Columns list, select Reaction force, x component (N).

5 Locate the Coloring and Style section. In the Width text field, type 3.

6 Find the Line markers subsection. From the Marker list, choose Asterisk.

7 Click to expand the Legends section. Select the Show legends check box.

8 From the Legends list, choose Manual.

9 In the table, enter the following settings:

Table Graph 2
1 Right-click Table Graph 1 and choose Duplicate.

2 In the Settings window for Table Graph, locate the Data section.

3 From the Table list, choose Reaction force, bolt 2.

4 Locate the Coloring and Style section. Find the Line markers subsection. From the Marker 
list, choose Circle.

5 In the Number text field, type 7.

6 Locate the Legends section. In the table, enter the following settings:

7 Repeat the steps above to add two more table graphs, with the following properties:

Legends

Bolt 1

Legends

Bolt 2

Table Marker style Number of markers Legend

Reaction force, bolt 3 Diamond 9 Bolt 3

Reaction force, bolt 4 Triangle 10 Bolt 4
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8 On the Reaction force, x component toolbar, click Plot to show Figure 5.

Reaction force, x component
In the Model Builder window, under Results right-click Reaction force, x component and 
choose Duplicate.

Reaction force, x component 1
In the Settings window for 1D Plot Group, type Reaction force, y component in the 
Label text field.

Table Graph 1
1 In the Model Builder window, expand the Results>Reaction force, y component node, then 

click Table Graph 1.

2 In the Settings window for Table Graph, locate the Data section.

3 In the Columns list, select Reaction force, y component (N).

4 Make the same change in the next three table graphs.

5 On the Reaction force, y component toolbar, click Plot to show Figure 6.

Reaction force, y component
In the Model Builder window, under Results right-click Reaction force, y component and 
choose Duplicate.

Reaction force, y component 1
In the Settings window for 1D Plot Group, type Reaction force, z component in the 
Label text field.

Table Graph 1
1 In the Model Builder window, expand the Results>Reaction force, z component node, then 

click Table Graph 1.

2 In the Settings window for Table Graph, locate the Data section.

3 In the Columns list, select Reaction force, z component (N).

4 Make the same change in the next three table graphs.

5 On the Reaction force, z component toolbar, click Plot to show Figure 7.
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Introduction

Rigid connectors provides an alternative way for modeling of geometrical parts that are of 
low interest in the analysis and have a negligible deformation. Such parts can be replaced 
with virtual rigid bodies with appropriate boundary condition. This saves computational 
time and memory. 

In this example, you study the stress in a bracket connected to a pin where a load is applied. 
The pin is simulated as a rigid connector.

It is recommended you review the Introduction to the Structural Mechanics Module, 
which includes background information and discusses the bracket_basic.mph model 
relevant to this example.

Model Definition

This model is an extension to the example described in the section “The Fundamentals: A 
Static Linear Analysis” in the Introduction to the Structural Mechanics Module. 

The model geometry is represented in Figure 1.

Figure 1: Bracket geometry.

A pin is connected between the bracket hole where a load is applied. The pin is assumed 
to be perfectly rigid and modeled with a rigid connector. Thus the pin is not represented 
in the model geometry. Figure 2 below shows the boundaries connected to the rigid 
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connector and the position of its center of rotation.

Figure 2: Center of rotation of the rigid connector applied to the bracket geometry.
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Results and Discussion

Figure 3 shows the von Mises stress on a deformed geometry. You can see the effect that 
the pin’s rotation and applied force has on the bracket arms.

Figure 3: Von Mises stress distribution.

Notes About the COMSOL Implementation

The rigid connector has the translational and rotational degrees of freedom of a rigid body. 
Options for this feature include applying an external load or moment to the rigid body, or 
defining mass and moments of inertia in dynamic analyses. The rigid connector can also 
be used to apply loads and constraints at points so that these are distributed and thereby 
preventing singularities.

To visualize the position of the center of rotation you need to enable the physics symbols. 
This is done in the File menu, where you select Preferences. In the Preferences window, click 
Graphics and Plot Windows. In the Visualization section select Show physics symbols.
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Application Library path: Structural_Mechanics_Module/Tutorials/
bracket_rigid_connector

Modeling Instructions

From the File menu, choose Open.

Browse to the application’s Application Libraries folder and double-click the file 
bracket_basic.mph.

S O L I D  M E C H A N I C S  ( S O L I D )

Rigid Connector 1
1 On the Physics toolbar, click Boundaries and choose Rigid Connector.

Now add a rigid connector that connects the holes in the bracket arms to simulate the 
presence of the pin.

2 Select Boundaries 4, 5, 42, and 43 only.

By default the location of the center of rotation is computed automatically. You can also 
manually specify its location.

3 In the Settings window for Rigid Connector, locate the Center of Rotation section.

4 From the list, choose User defined.

5 Specify the Xc vector as

To visualize its position you need to enable the physics symbols. This is done in the 
Options menu, where you select Preferences. In the Preferences window, click Graphics. 
In the Visualization section select Show physics symbols.

The displacements of the rigid connector are constrained in the x and z directions at its 
center of rotation.

6 Locate the Prescribed Displacement at Center of Rotation section. Select the Prescribed in 

x direction check box.

7 Select the Prescribed in z direction check box.

0 X

-0.40 Y

-0.10 Z
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8 Locate the Prescribed Rotation section. From the By list, choose Prescribed rotation.

Apply a prescribed rotation of the rigid body of 0.05 degrees around the y-axis.

9 Specify the Ω vector as

10 In the φ0 text field, type 0.05[deg].

Applied Force 1
1 Right-click Rigid Connector 1 and choose Applied Force.

Apply an external load of 10 kN at the center of rotation of the rigid body.

2 In the Settings window for Applied Force, locate the Applied Force section.

3 Specify the F vector as

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  1

Step 1: Stationary
On the Home toolbar, click Compute.

R E S U L T S

Stress (solid)
1 Click the Zoom Extents button on the Graphics toolbar.

The default plot shows the von Mises stress on a deformed geometry.

0 x

1 y

0 z

0 x

-10[kN] y

0 z
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Introduction

The various examples of a bracket form a suite of tutorials which summarizes the 
fundamentals when modeling structural mechanics problems in COMSOL Multiphysics 
and the Structural Mechanics Module. 

In this example you study the stress in a bracket subjected to external loads. The thin parts 
with constant thickness are modeled with the Shell interface and the transition regions 
where 3D effects are important are modeled using the Solid Mechanics interface. This 
example also shows how to connect shell elements with solid elements.

For thin geometries it can be more efficient to use shell elements instead of solid elements, 
thus saving computational time and memory. The Shell interface in the Structural 
Mechanics Module can be used to model structures approximated by thin and thick shells. 
There is also a similar Plate interface for 2D problems. The thickness of the shell or plate 
is taken into account in the equations instead of being explicitly modeled in the geometry. 

It is recommended that you review the Introduction to the Structural Mechanics 
Module, which includes background information and discusses the bracket_basic.mph 
model relevant to this example.

Model Definition

The various models described in the section “The Fundamentals: A Static Linear Analysis” 
in the Introduction to the Structural Mechanics Module. 

The parts of the geometry modeled with shells is shown in Figure 1 and the parts modeled 
with solids are shown in Figure 2. The shell surfaces are obtained from the 3D geometry 
using a partition operation.
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Figure 1: Shell domains in the bracket geometry.

Figure 2: Solid domains in the bracket geometry.
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The load is applied along the edge at the bracket holes.

Results and Discussion

The Shell interface generates a default plot which indicates the physical location of top and 
bottom surfaces, as well as the local coordinate system used for material input and stress 
output. Especially when working with offsets, this is an excellent tool for checking that the 
input data is correct. This plot is shown in Figure 3.

Figure 3: The shell geometry plot. Gray indicates top surface and yellow indicates bottom 
surface.

Figure 4 shows the first principal strain on a deformed geometry in the solid domain and 
at the top shell surfaces. The continuity over the transition between the shell and the solid 
is very good.
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Figure 4: First principal strain distribution in the solid and at the top of the shell.

Figure 5 shows the principal stress at the bottom shell surfaces.

Figure 5: Principal stress at the bottom shell surface.
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The table below lists the reaction force in the x, y and z directions in each bolts.

You can compare the results obtained with the Shell interface and the initial model that 
used the Solid Mechanics interface (see the Results section in the tutorial Bracket—Static 
Analysis).

Notes About the COMSOL Implementation

You can specify an offset in the shell definition if the meshed surface is not the same as the 
midsurface of the real geometry.

The Shell connection and Solid connection nodes are used for connecting shell surfaces and 
edges to solid boundaries.

Application Library path: Structural_Mechanics_Module/Tutorials/
bracket_shell

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Shell (shell).

3 Click Add.

4 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

5 Click Add.

6 Click Study.

TABLE 1:  REACTION FORCE IN BOLT

REACTION FORCE, 
X-DIRECTION (KN)

REACTION FORCE, 
Y-DIRECTION (KN)

REACTION FORCE, 
Z-DIRECTION (KN)

Bolt 1 0.45 0.30 2.52

Bolt 2 -0.45 0.08 -1.69

Bolt 3 0.45 -0.30 -2.52

Bolt 4 -0.45 -0.08 1.69
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7 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

8 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 From the Source list, choose COMSOL Multiphysics file.

4 Click Browse.

5 Browse to the application’s Application Libraries folder and double-click the file 
bracket.mphbin.

6 Click Import.

Model the flat parts of the bracket with shell elements and the connections with solid 
elements.

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, locate the Plane Definition section.

3 From the Plane type list, choose Face parallel.

4 On the object imp1, select Boundary 8 only.

5 Click to expand the Local coordinate system section. Locate the Local Coordinate System 
section. From the Origin list, choose Vertex projection.

6 Find the Vertex for origin subsection. Select the Active toggle button.

7 On the object imp1, select Point 80 only.

Name Expression Value Description

P0 2.5[MPa] 2.5E6 Pa Peak load intensity

YC -300[mm] -0.3 m Y coordinate of hole center
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8 Click Show Work Plane.

Rectangle 1 (r1)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 22[mm].

4 In the Height text field, type 22[mm].

Move 1 (mov1)
1 On the Work Plane toolbar, click Transforms and choose Move.

2 Select the object r1 only.

3 In the Settings window for Move, locate the Input section.

4 Select the Keep input objects check box.

5 Locate the Displacement section. In the yw text field, type 0.1-22e-3.

Move 2 (mov2)
1 On the Work Plane toolbar, click Transforms and choose Move.

2 Click in the Graphics window and then press Ctrl+A to select both objects.

3 In the Settings window for Move, locate the Input section.

4 Select the Keep input objects check box.

5 Locate the Displacement section. In the xw text field, type 0.215-0.022.

Work Plane 1 (wp1)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Work Plane 1 

(wp1).

Extrude 1 (ext1)
1 Right-click Component 1 (comp1)>Geometry 1>Work Plane 1 (wp1) and choose Build 

Selected.

2 On the Geometry toolbar, click Extrude.

3 In the Settings window for Extrude, locate the Distances from Plane section.

4 In the table, enter the following settings:

5 Select the Reverse direction check box.

Distances (m)

0.112
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Partition Objects 1 (par1)
1 Right-click Extrude 1 (ext1) and choose Build Selected.

2 On the Geometry toolbar, click Booleans and Partitions and choose Partition Objects.

3 Select the object imp1 only.

4 In the Settings window for Partition Objects, locate the Partition Objects section.

5 Find the Tool objects subsection. Select the Active toggle button.

6 Select the object ext1 only.

7 Right-click Partition Objects 1 (par1) and choose Build Selected.

D E F I N I T I O N S

Cylindrical System 2 (sys2)
1 On the Definitions toolbar, click Coordinate Systems and choose Cylindrical System.

2 In the Settings window for Cylindrical System, locate the Settings section.

3 Find the Origin subsection. In the table, enter the following settings:

4 Find the Longitudinal axis subsection. In the table, enter the following settings:

5 Find the Direction of axis φ=0 subsection. In the table, enter the following settings:

Now define the load distribution to be applied on the bracket holes.

Analytic 1 (an1)
1 On the Definitions toolbar, click Analytic.

2 In the Settings window for Analytic, type load in the Function name text field.

3 Locate the Definition section. In the Expression text field, type F*abs(cos(p)).

4 In the Arguments text field, type F, p.

5 Locate the Units section. In the Arguments text field, type Pa, rad.

6 In the Function text field, type Pa.

x (m) y (m) z (m)

0 YC 0

x y z

1 0 0

x y z

0 0 1
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Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Shell in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Click the Wireframe Rendering button on the Graphics toolbar.

5 Select Boundaries 1, 32, 37, 50, and 86 only.

6 Click the Zoom Extents button on the Graphics toolbar.

Explicit 2
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Solid in the Label text field.

3 Select Domains 2, 3, 7, and 8 only.

Explicit 3
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Bolt holes in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Edge.

4 Select Edges 84, 85, 89, 90, 120, 121, 125, and 126 only.

5 Select the Group by continuous tangent check box.

M A T E R I A L S

Add structural steel material properties to both domains and boundaries.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Structural steel.

4 Click Add to Component in the window toolbar.

5 In the tree, select Built-In>Structural steel.

6 Click Add to Component in the window toolbar.

7 On the Home toolbar, click Add Material to close the Add Material window.
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M A T E R I A L S

Structural steel (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Structural steel 

(mat1).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Shell.

Structural steel 1 (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Structural steel 

1 (mat2).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Solid.

S H E L L  ( S H E L L )

1 In the Model Builder window, under Component 1 (comp1) click Shell (shell).

2 In the Settings window for Shell, locate the Boundary Selection section.

3 From the Selection list, choose Shell.

4 Locate the Thickness section. In the d text field, type 8[mm].

5 From the Offset definition list, choose Physical offset.

6 In the zoffset text field, type -4[mm].

Fixed Constraint 1
1 On the Physics toolbar, click Edges and choose Fixed Constraint.

2 In the Settings window for Fixed Constraint, locate the Edge Selection section.

3 From the Selection list, choose Bolt holes.

Edge Load 1
1 On the Physics toolbar, click Edges and choose Edge Load.

2 Select Edges 4 and 188 only.

3 In the Settings window for Edge Load, locate the Coordinate System Selection section.

4 From the Coordinate system list, choose Cylindrical System 2 (sys2).

5 Locate the Force section. From the Load type list, choose Load defined as force per unit 

area.
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6 Specify the FA vector as

You will now define shell edges connected to the solid boundaries.

Solid Connection 1
1 On the Physics toolbar, click Edges and choose Solid Connection.

2 Select Edges 12, 15, 17, 18, 66, 73, 130, 137, 191, and 193–195 only.

3 In the Settings window for Solid Connection, locate the Solid Connection section.

4 From the Connection type list, choose Simplified.

S O L I D  M E C H A N I C S  ( S O L I D )

Define the shell connection on the solid boundaries.

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the Domain Selection section.

3 From the Selection list, choose Solid.

Shell Connection 1
1 On the Physics toolbar, click Boundaries and choose Shell Connection.

2 Select Boundaries 9, 11, 13, 14, 30, 34, 58, 62, 80, 81, 83, and 84 only.

3 In the Settings window for Shell Connection, locate the Shell Connection section.

4 From the list, choose Solid Connection 1 (shell).

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Tetrahedral.

Free Tetrahedral 1
1 In the Settings window for Free Tetrahedral, locate the Domain Selection section.

2 From the Geometric entity level list, choose Domain.

3 From the Selection list, choose Solid.

Free Triangular 1
1 In the Model Builder window, right-click Mesh 1 and choose More Operations>Free 

Triangular.

load(P0,sys2.phi) r

0 phi

0 a
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2 In the Settings window for Free Triangular, locate the Boundary Selection section.

3 From the Selection list, choose Shell.

4 Click Build All.

Size
1 In the Settings window for Size, locate the Element Size section.

2 From the Predefined list, choose Finer.

3 Click Build All.

S T U D Y  1

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 Right-click Stationary Solver 1 and choose Fully Coupled.

4 In the Model Builder window, click Solution 1 (sol1).

5 In the Settings window for Solution, click Compute.

R E S U L T S

Stress (shell)
1 In the Model Builder window, under Results click Stress (shell).

2 On the Stress (shell) toolbar, click Plot.

3 Click the Zoom Extents button on the Graphics toolbar.

The first default plot shows the maximum stress in the shell.

Undeformed Geometry (shell)
1 In the Model Builder window, under Results click Undeformed Geometry (shell).

2 On the Undeformed Geometry (shell) toolbar, click Plot.

3 Click the Zoom Extents button on the Graphics toolbar.

The second default plot shows the shell geometry, and the directions of the local 
coordinate axes.

3D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Principal Stress Bottom in the 
Label text field.
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Principal Stress Surface 1
1 On the Principal Stress Bottom toolbar, click More Plots and choose Principal Stress 

Surface.

2 In the Settings window for Principal Stress Surface, locate the Coloring and Style section.

3 From the Arrow length list, choose Logarithmic.

You can also manually define where in the thickness direction of the shell you want to 
plot the results. Do this by changing the location in the Surface Settings window under 
the Parameters section. There the parameter shell.z defines the height of evaluation 
in shell: 1 for the top surface, 0 for the mid-plane, and -1 for the bottom surface.

4 Locate the Principal Components section. Find the Parameters subsection. In the table, 
enter the following settings:

5 Locate the Coloring and Style section. In the Number of arrows text field, type 500.

6 On the Principal Stress Bottom toolbar, click Plot.

To plot shell and solid results in the same figure as in Figure 3, follow the steps below.

3D Plot Group 5
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Principal Strain in the Label text 
field.

3 Click to expand the Title section. From the Title type list, choose Manual.

4 In the Title text area, type First principal strain.

Surface 1
1 Right-click Principal Strain and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type shell.ep1.

4 Click to expand the Range section. Select the Manual color range check box.

5 In the Maximum text field, type 2.0E-4.

6 On the Principal Strain toolbar, click Plot.

7 Right-click Results>Principal Strain>Surface 1 and choose Deformation.

Name Value Unit Description

shell.z -1 Height of evaluation in shell, 
[-1,1]

Local z-coordinate [-1,1] for 
thickness-dependent results
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Surface 1
1 In the Model Builder window, expand the Results>Stress (solid) node.

2 Right-click Surface 1 and choose Copy.

Principal Strain
In the Model Builder window, under Results right-click Principal Strain and choose Paste 

Surface.

Surface 2
1 In the Settings window for Surface, locate the Expression section.

2 In the Expression text field, type solid.ep1.

3 Click to expand the Inherit style section. Locate the Inherit Style section. From the Plot 
list, choose Surface 1.

4 On the Principal Strain toolbar, click Plot.

Derived Values
The last step is to evaluate the reaction forces at the edges which represent the mounting 
bolts.

Line Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Line 

Integration.

2 Click the Zoom Box button on the Graphics toolbar.

3 Select Edges 84 and 85 only.

4 In the Settings window for Line Integration, click Replace Expression in the upper-right 
corner of the Expressions section. From the menu, choose Component 1>Shell>

Reactions>Reaction force (Spatial)>shell.RFx - Reaction force, x component.

5 Locate the Expressions section. In the table, enter the following settings:

6 Click Evaluate.

7 In the Settings window for Line Integration, locate the Expressions section.

8 In the table, enter the following settings:

Expression Unit Description

shell.RFx kN Reaction force, x component

Expression Unit Description

shell.RFy kN Reaction force, y component
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9 Click Evaluate.

10 In the Settings window for Line Integration, locate the Expressions section.

11 In the table, enter the following settings:

12 Click Evaluate.

Table 1
1 In the Model Builder window, expand the Results>Tables node, then click Table 1.

2 In the Settings window for Table, type Reaction force bolt 1 in the Label text field.

Reaction Forces for the Remaining Bolts.
1 Compute the bolt forces for the remaining three bolts. Repeat the above instructions 

for Line integration and Table by adjusting for the data from the table below.

2 In the table, enter the following settings:

Expression Unit Description

shell.RFz kN Reaction force, z component

Line integration Select edges Default table 
name

New table label

Line integration 2 89, 90 Table 2 Reaction force bolt 
2

Line integration 3 120, 121 Table 2 Reaction force bolt 
3

Line integration 4 125, 126 Table 2 Reaction force bolt 
4
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Introduction

A fixed, fully constrained, boundary condition contains the assumption that the analyzed 
structure is attached to an infinitely stiff support. While in many cases this is a good 
approximation, sometimes you may need to consider the stiffness of the supporting 
structure in your model. In COMSOL Multiphysics you can do this by using the Spring 
Foundation boundary condition. 

In this example, you study the stress in a bracket subjected to external loads. The stiffness 
of the mounted bolts connecting support is modeled with spring foundations.

It is recommended you review the Introduction to the Structural Mechanics Module, 
which includes background information and discusses the bracket_basic.mph model 
relevant to this example.

Model Definition

This model is an extension to the model example described in the section “The 
Fundamentals: A Static Linear Analysis” in the Introduction to the Structural Mechanics 
Module. 

The model geometry is represented in Figure 1.
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Figure 1: Bracket geometry.

The load is applied in the positive z-direction in the bracket left arm and in the negative 
z-direction in the bracket right arm.

The bolts are assumed to be elastic, defined with spring foundations.

Results and Discussion

Figure 2 shows the von Mises stress on a deformed geometry. 
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Figure 2: The Von Mises stress distribution.

The maximum stress in the bracket when connected using spring connection is about 
124 MPa. This is slightly lower as compared to the case using rigidly mounted bolts (see 
the Results section in the tutorial Bracket - Static analysis) that give a maximum stress 
about 175 MPa. The difference in the stress is caused by the structural flexibility that a 
spring connection provides. 

Application Library path: Structural_Mechanics_Module/Tutorials/
bracket_spring

Modeling Instructions

From the File menu, choose Open.

Browse to the application’s Application Libraries folder and double-click the file 
bracket_basic.mph.
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C O M P O N E N T  1  ( C O M P 1 )

In the Model Builder window, expand the Component 1 (comp1) node.

G L O B A L  D E F I N I T I O N S

Add the two new parameters for the spring coefficients of the external structure to the 
table.

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

D E F I N I T I O N S

Analytic 1 (an1)
1 On the Home toolbar, click Functions and choose Local>Analytic.

2 In the Settings window for Analytic, type load in the Function name text field.

3 Locate the Definition section. In the Expression text field, type F*cos(atan2(py,
abs(px))).

4 In the Arguments text field, type F, py, px.

5 Locate the Units section. In the Arguments text field, type Pa, m, m.

6 In the Function text field, type Pa.

S O L I D  M E C H A N I C S  ( S O L I D )

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

Apply a boundary load to the bracket holes.

2 Select Boundaries 4 and 43 only.

3 In the Settings window for Boundary Load, locate the Coordinate System Selection 
section.

Name Expression Value Description

P0 2.5[MPa] 2.5E6 Pa Peak load intensity

YC -300[mm] -0.3 m Y coordinate of hole center

kxy 1e6[N/m] 1E6 N/m Spring coefficient in x and y 
direction

kz 1e8[N/m] 1E8 N/m Spring coefficient in z direction
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4 From the Coordinate system list, choose Boundary System 1 (sys1).

5 Locate the Force section. Specify the FA vector as

Fixed Constraint 1
In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) 
right-click Fixed Constraint 1 and choose Disable.

Spring Foundation 1
1 On the Physics toolbar, click Boundaries and choose Spring Foundation.

2 In the Settings window for Spring Foundation, locate the Boundary Selection section.

3 From the Selection list, choose Bolt holes.

4 Locate the Spring section. From the Spring type list, choose Total spring constant.

5 From the list, choose Diagonal.

6 In the ktot table, enter the following settings:

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  1

Step 1: Stationary
On the Home toolbar, click Compute.

0 t1

0 t2

load(-P0,Y-YC,Z) n

kxy 0 0

0 kxy 0

0 0 kz
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R E S U L T S

Stress (solid)
1 Click the Zoom Extents button on the Graphics toolbar.

The default plot shows the von Mises effective stress distribution.
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Introduction

The various examples of a bracket form a suite of tutorials which summarizes the 
fundamentals when modeling structural mechanics problems in COMSOL Multiphysics 
and the Structural Mechanics Module. 

This is the most fundamental model in the suite, and includes the definition of material 
properties and boundary conditions. After the solution is computed, you learn how to 
analyze results and check the reaction forces. 

Model Definition

The model used in this guide is a bracket made of steel. This type of bracket can be used 
to install an actuator that is mounted on a pin placed between the two holes in the bracket 
arms. The geometry is shown in Figure 1.

Figure 1: Bracket geometry.

In this analysis, the mounting bolts are assumed to be fixed and securely bonded to the 
bracket. One of the arms is loaded upwards, and the other downwards. The loads are 
applied on the normal of the inner surfaces of the holes, and their intensity is P0 cos(α), 
where α is the angle from the direction of the loads. Figure 2 below shows the loads 
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applied to the bracket.

Figure 2: Load distribution in the bracket arms.

Results

Figure 3 shows the von Mises stress distribution together with an exaggerated 
(automatically scaled) picture of the deformation. The high stress values are located in the 
vicinity of the mounting bolts and at the transition between the plates. The maximum von 
Mises stress remains below the yield stress value for structural steel, which validates the 
choice of a linear elastic material.
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Figure 3: Von Mises stress distribution in the bracket under bending load in z-axis direction.

In Figure 4 you can see that the bracket base remains fixed while only the arms are 
deformed. The maximum total displacement is about 0.2 mm, which is in agreement with 
the assumption of small deformations.
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Figure 4: Bracket total displacement.

Figure 5 shows the principal stresses in the bracket. The largest principal stress is shown 
with red arrows, the intermediate principal stress with green arrows, and the smallest 
principal stress with blue arrows.
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Figure 5: Principal stress in the bracket left arm.

In Table 1 you can see the reaction force in the x, y, and z directions in each bolt. In all 
directions they sum is zero, which is a good check, since in this model there are no 
resultant forces. The slight asymmetry can be attributed to that the mesh is not perfectly 
symmetric.

Application Library path: Structural_Mechanics_Module/Tutorials/
bracket_static

TABLE 1:  REACTION FORCE IN BOLT

REACTION FORCE, 
X-DIRECTION (N)

REACTION FORCE, 
Y-DIRECTION (N)

REACTION FORCE, 
Z-DIRECTION (N)

Bolt 1 451 300 2555

Bolt 2 -451 78 -1723

Bolt 3 453 -304 -2554

Bolt 4 -454 -75 1721
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

The first step to build a model is to open COMSOL and then specify the type of analysis 
you want to do - in this case, a stationary, solid mechanics analysis.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

It is good modeling practice to gather the constants and parameters in one place so that 
you can change them easily. Using parameters will also improve the readability of your 
input data.

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

The next step is to create your geometry, which also can be imported from an external 
program. COMSOL Multiphysics supports a multitude of CAD programs and file 
formats. In this example, import a file in the COMSOL Multiphysics geometry file format 
(.mphbin).

Name Expression Value Description

P0 2.5[MPa] 2.5E6 Pa Peak load intensity

YC -300[mm] -0.3 m Y coordinate of hole center
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Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 From the Source list, choose COMSOL Multiphysics file.

4 Click Browse.

5 Browse to the application’s Application Libraries folder and double-click the file 
bracket.mphbin.

6 Click Import.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click Form 

Union (fin) and choose Build Selected.

2 Click the Zoom Extents button on the Graphics toolbar.

D E F I N I T I O N S

Here you want to define an expression for the load applied to the load-carrying holes. 
Assume the load distribution to be defined with a trigonometric function.

Analytic 1 (an1)
1 On the Home toolbar, click Functions and choose Local>Analytic.

2 In the Settings window for Analytic, type load in the Function name text field.

3 Locate the Definition section. In the Expression text field, type F*cos(atan2(py,
abs(px))).

4 In the Arguments text field, type F, py, px.

5 Locate the Units section. In the Arguments text field, type Pa, m, m.

6 In the Function text field, type Pa.

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Bolt 1 in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundary 18 only.

5 Select the Group by continuous tangent check box.
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6 Repeat the steps above to add three more explicit selections, with the following 
properties:

Union 1
1 On the Definitions toolbar, click Union.

2 In the Settings window for Union, type Bolt holes in the Label text field.

3 Locate the Geometric Entity Level section. From the Level list, choose Boundary.

4 Locate the Input Entities section. Under Selections to add, click Add.

5 In the Add dialog box, In the Selections to add list, choose Bolt 1, Bolt 2, Bolt 3, and Bolt 

4.

6 Click OK.

M A T E R I A L S

COMSOL Multiphysics is equipped with built-in material properties for a number of 
common materials. Here, choose structural steel. The material is automatically assigned to 
all domains.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Structural steel.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

S O L I D  M E C H A N I C S  ( S O L I D )

By default, the Solid Mechanics interface assumes that the participating material models 
are linear elastic, which is appropriate for this example. All that is left to do is to set the 
constraints and loads.

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 In the Settings window for Fixed Constraint, locate the Boundary Selection section.

Default node label New node label Select this boundary

Explicit 2 Bolt 2 20

Explicit 3 Bolt 3 31

Explicit 4 Bolt 4 33
9 |  B R A C K E T — S T A T I C  A N A L Y S I S



3 From the Selection list, choose Bolt holes.

Apply a boundary load to the bracket holes. The predefined boundary system is used for 
orienting the load in the normal direction.

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 4 and 43 only.

3 In the Settings window for Boundary Load, locate the Coordinate System Selection 
section.

4 From the Coordinate system list, choose Boundary System 1 (sys1).

5 Locate the Force section. Specify the FA vector as

M E S H  1

Set the mesh size to be slightly finer than the default size.

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Fine.

The steps below show how to visualize the load distribution in the current geometry 
before computing the solution.

S T U D Y  1

Stress (solid)
On the Study toolbar, click Get Initial Value.

Note that the Study node automatically defines a solver sequence for the simulation based 
on the selected physics (Solid Mechanics) and study type (Stationary).

Since a mesh is required, and it has not been created yet, the Study node automatically 
generates this at the same time as the solver sequence. In practice, do not rely only on the 
standard mesh settings. For most real problems, suitable meshing parameters should be set 
up from the Mesh toolbar.

0 t1

0 t2

load(-P0,Y-YC,Z) n
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R E S U L T S

Stress (solid)
In the Model Builder window, under Results right-click Stress (solid) and choose Arrow 

Surface.

Arrow Surface 1
1 In the Settings window for Arrow Surface, locate the Expression section.

2 In the X component text field, type solid.FperAreax.

3 In the Y component text field, type solid.FperAreay.

4 In the Z component text field, type solid.FperAreaz.

5 Locate the Coloring and Style section. From the Placement list, choose Mesh nodes.

6 On the Stress (solid) toolbar, click Plot.

Now, solve the model.

S T U D Y  1

On the Home toolbar, click Compute.

The default plot shows the von Mises stress distribution, together with an exaggerated 
(automatically scaled) picture of the deformation.

Add a plot group to display the displacement of the bracket.

R E S U L T S

3D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Total displacement in the Label text 
field.

Surface 1
1 Right-click Total displacement and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose mm.

4 On the Total displacement toolbar, click Plot.

Create another plot to display the principal stresses.

3D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.
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2 In the Settings window for 3D Plot Group, type Principal stress in the Label text 
field.

Principal Stress Volume 1
1 On the Principal stress toolbar, click More Plots and choose Principal Stress Volume.

2 In the Settings window for Principal Stress Volume, locate the Positioning section.

3 Find the X grid points subsection. In the Points text field, type 30.

4 Find the Y grid points subsection. In the Points text field, type 60.

5 Find the Z grid points subsection. In the Points text field, type 15.

6 Locate the Coloring and Style section. From the Arrow length list, choose Logarithmic.

7 On the Principal stress toolbar, click Plot.

A final check is to compute the total reaction force along the x, y, and z directions. Use a 
surface integration over the constrained boundaries.

Surface Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 In the Settings window for Surface Integration, locate the Selection section.

3 From the Selection list, choose Bolt 1.

4 Locate the Expressions section. In the table, enter the following settings:

5 Click Evaluate.

Table 1
1 In the Model Builder window, expand the Results>Tables node, then click Table 1.

2 In the Settings window for Table, type Reaction force, bolt 1 in the Label text field.

3 Repeat the previous steps three times to evaluate the reaction forces in all four bolts, 
using the information in the table below.

Expression Unit Description

solid.RFx N Reaction force, x component

solid.RFy N Reaction force, y component

solid.RFz N Reaction force, z component

Node label Choose selection New table node name

Surface integration 2 Bolt 2 Reaction force, bolt 2
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Surface integration 3 Bolt 3 Reaction force, bolt 3

Surface integration 4 Bolt 4 Reaction force, bolt 4

Node label Choose selection New table node name
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Introduction

The various examples of a bracket form a suite of tutorials which summarizes the 
fundamentals when modeling structural mechanics problems in COMSOL Multiphysics 
and the Structural Mechanics Module. 

In this example you learn how to perform a thermal stress analysis.

Model Definition

The model used in this guide is an assembly of a bracket and its mounting bolts, which are 
all made of steel. This type of bracket can be used to install an actuator that is mounted on 
a pin placed between the two holes in the bracket arms. The geometry is shown in 
Figure 1.

In this example, a temperature distribution is computed in the bracket and the resulting 
thermal stresses are determined.
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Results

Figure 1shows the temperature distribution in the bracket. The temperature is highest 
where the inward heat flux is prescribed, and decreases as heat is removed by convection 
from all other boundaries.

Figure 1: Temperature distribution in the bracket.

Figure 2 shows the von Mises stress distribution in the bracket. You can see how the 
bracket is deformed through thermal expansion. Due to the boundary conditions and the 
non-uniform temperature distribution, thermal stresses develop in the structure.
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Figure 2: Von Mises stress distribution in the bracket.

Notes About the COMSOL Implementation

COMSOL Multiphysics contains physics interfaces for structural analysis as well as thermal 
analysis. You can set up the coupled analysis for thermal-structure interaction using three 
different methods:

1 Add a Thermal Stress interface as in this example. The coupling is predefined and appears 
in the Thermal Expansion and Temperature Coupling nodes under Multiphysics. This is the 
easiest approach.

2 Add separate Solid Mechanics and Thermal Stress interfaces. Then add Thermal Expansion 
and Temperature Coupling nodes under Multiphysics, and check the settings in them.

3 Add separate Solid Mechanics and Thermal Stress interfaces. Add a Thermal Expansion 
subnode under Linear Elastic Material, and do the appropriate settings there.

Application Library path: Structural_Mechanics_Module/Tutorials/
bracket_thermal
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Thermal Stress.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

G E O M E T R Y  1

The Thermal Stress interface is a multiphysics interface that combines a Solid Mechanics 
interface with a Heat Transfer in Solids interface. You can see the coupling between the 
physics interfaces under the Multiphysics node.

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 From the Source list, choose COMSOL Multiphysics file.

4 Click Browse.

5 Browse to the application’s Application Libraries folder and double-click the file 
bracket.mphbin.

6 Click Import.

7 Click the Zoom Extents button on the Graphics toolbar.

Form Union (fin)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click Form 

Union (fin) and choose Build Selected.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.
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3 In the tree, select Built-In>Structural steel.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

S O L I D  M E C H A N I C S  ( S O L I D )

Now specify the boundary conditions for the Solid Mechanics interface.

Roller 1
1 On the Physics toolbar, click Boundaries and choose Roller.

2 Select Boundaries 17 and 27 only.

Spring Foundation 1
1 On the Physics toolbar, click Boundaries and choose Spring Foundation.

2 Select Boundaries 18–21 and 31–34 only.

3 In the Settings window for Spring Foundation, locate the Spring section.

4 From the list, choose Diagonal.

5 In the kA table, enter the following settings:

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids (ht).

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 From the Selection list, choose All boundaries. Then remove boundaries 17 and 27.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type 10.

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 17 and 27 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 In the q0 text field, type 1e4.

1e7 0 0

0 1e7 0

0 0 0
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S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Stress (solid)
Under the Results node, three plot groups are automatically added to show the default 
results for the structural and thermal analyses. The first plot group, Stress (solid), 
shows the von Mises stresses on a scaled deformed geometry, as shown in Figure 2.

Temperature (ht)
The second plot group, Temperature (ht), displays the temperature distribution as 
shown in Figure 1.
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Introduction

Transient analyses provide the time domain response of a structure subjected to 
time-dependent loads. A transient analysis can be important when the time scale of the 
load is such that inertial or damping effects might have a significant influence on the 
behavior of the structure.

In this example you learn how to add damping properties to the material, define external 
loads varying with time, set up time-stepping data for the study, and generate animations.

It is recommended you review the Introduction to the Structural Mechanics Module, 
which includes background information and discusses the bracket_basic.mph models 
relevant to this example.

Model Definition

This model is an extension to the example described in the section “The Fundamentals: A 
Static Linear Analysis” in the Introduction to the Structural Mechanics Module. 

The model geometry is represented in Figure 1.
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Figure 1: Bracket geometry.

A rigid body is assumed to be connected to the arms of the bracket on which the 
time-varying load is applied.
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Results and Discussion

Figure 2 shows the rigid connector’s displacements at the center of rotation versus the 
time.

Figure 2: Displacement of the pin center of rotation vs time.

Notes About the COMSOL Implementation

To accurately model the physical problem, you need to apply damping in a dynamic 
analysis. In COMSOL you have the possibility to add damping of several type: isotropic 
loss factor, anisotropic loss factor or Rayleigh damping.

To implement time-dependent components you can enter expressions using the variable 
t, the time variable in COMSOL Multiphysics.

The scaling of the displacement variables can be changed to correspond to the expected 
deformations. Manual scaling is the default for the displacement variables. The default 
manual scaling used for the structural displacement is 1/100th of the geometry size, 
which in this example is about 200 mm. In this case the expected deformations are in the 
order of 0.1 mm. The manual scaling factor should thus be changed to 10-4.
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Application Library path: Structural_Mechanics_Module/Tutorials/
bracket_transient

Modeling Instructions

From the File menu, choose Open.

Browse to the application’s Application Libraries folder and double-click the file 
bracket_basic.mph.

S O L I D  M E C H A N I C S  ( S O L I D )

Linear Elastic Material 1
In the Model Builder window, expand the Component 1 (comp1)>Solid Mechanics (solid) 
node, then click Linear Elastic Material 1.

Damping 1
1 On the Physics toolbar, click Attributes and choose Damping.

In this example, you will use Rayleigh damping.

2 In the Settings window for Damping, locate the Damping Settings section.

3 In the αdM text field, type 50.

4 In the βdK text field, type 1e-4.

To represent the pin between the arms of the bracket you can use a rigid connector, to 
which a load can be applied.

Rigid Connector 1
1 On the Physics toolbar, click Boundaries and choose Rigid Connector.

2 Select Boundaries 4, 5, 42, and 43 only.

Applied Force 1
1 Right-click Rigid Connector 1 and choose Applied Force.

2 In the Settings window for Applied Force, locate the Applied Force section.

3 Specify the F vector as

100*sin(2*pi*t*200[1/s]) x
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A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Time 

Dependent.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  1

Step 1: Time Dependent
1 In the Settings window for Time Dependent, locate the Study Settings section.

2 From the Time unit list, choose ms.

3 In the Times text field, type range(0,0.25,25).

With this time stepping, the solver automatically stores the solution every 0.25 ms from 
0 to 25 ms.

The time-dependent solver adapts its time stepping based on a tolerance criterion. This 
ensures that the solver takes small enough time steps if large variations occur between 
the specified output times.

4 Select the Relative tolerance check box.

5 In the associated text field, type 0.001.

6 Click to expand the Results while solving section. Locate the Results While Solving section. 
Select the Plot check box.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Dependent Variables 1 node, then click Displacement field (Material) (comp1.u).

4 In the Settings window for Field, locate the Scaling section.

-11000 y

700*sin(2*pi*t*100[1/s]) z
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5 In the Scale text field, type 1e-4.

The computation can be speed up for a small model by disabling the convergence plot. 
To do this, go to the Options menu and select Preferences. Under Results, click to clear 
the Generate convergence plots check box.

6 On the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
1 Click the Zoom Extents button on the Graphics toolbar.

The default plot shows the stress distribution at the final time. You can change the time 
for the plot display in the Time list of the plot group settings.

Plot the displacement of the center of rotation of the rigid body versus the time.

1D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, click to expand the Title section.

3 From the Title type list, choose Manual.

4 In the Title text area, type Pin center of rotation displacement.

5 Click to expand the Legend section. From the Position list, choose Upper left.

Global 1
1 On the 1D Plot Group 2 toolbar, click Global.

2 In the Settings window for Global, locate the y-Axis Data section.

3 In the table, enter the following settings:

4 Click to expand the Legends section. Select the Show legends check box.

5 Click to expand the Coloring and style section. Locate the Coloring and Style section. Find 
the Line markers subsection. From the Marker list, choose Cycle.

6 In the Width text field, type 3.

7 On the 1D Plot Group 2 toolbar, click Plot.

Expression Unit Description

solid.rig1.u mm Rigid body displacement, x component

solid.rig1.v mm Rigid body displacement, y component

solid.rig1.w mm Rigid body displacement, z component
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1D Plot Group 2
1 In the Model Builder window, under Results click 1D Plot Group 2.

2 In the Settings window for 1D Plot Group, click to expand the Legend section.

3 From the Position list, choose Upper right.

4 On the 1D Plot Group 2 toolbar, click Plot.

To visualize the results in an animation, create a player.

Animation 1
1 On the Results toolbar, click Animation and choose File.

2 In the Settings window for Animation, locate the Target section.

3 From the Target list, choose Player.

4 Locate the Frames section. From the Frame selection list, choose All.

5 Click Show Frame.

COMSOL Multiphysics generates the movie and then plays it. To replay the movie, 
click the Play button on the Graphics toolbar.

If you want to export a movie in GIF, Flash, or AVI format, right-click Export and create 
an Animation feature.
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Introduction

The vibration modes of a thin or thick circular disc are well known, and it is possible to 
compute the corresponding eigenfrequencies with an arbitrary precision from a series 
solution. The same is true for the acoustic modes of an air-filled cylinder with perfectly 
rigid walls. A more interesting question to ask is: What happens if the cylinder is sealed in 
one end not by a rigid wall but by a thin disc? This is the question you address in this 
tutorial.

The application uses the Structural Mechanics Module’s Shell interface and the Pressure 
Acoustics interface from COMSOL Multiphysics. If you have a license for the Acoustics 
Module, see Vibrations of a Disk Backed by an Air-Filled Cylinder in the Acoustics Module 
Application Libraries for a model version that uses the Acoustic-Shell Interaction, 
Frequency Domain multiphysics interface.

Model Definition

The geometry is a rigid steel cylinder with a height of 255 mm and a radius of 38 mm. 
One end is welded to a heavy slab, while the other is sealed with a steel disc only 0.38 mm 
thick. The disc is modeled using shell elements with the outer edge of the disc fixed. The 
acoustics in the cylinder is described in terms of the acoustic (differential) pressure. The 
eigenvalue equation for the pressure is

where c is the speed of sound and ω = 2πf defines the eigenfrequency, f.

A first step is to calculate the eigenfrequencies for the disc and the cylinder separately and 
compare them with theoretical values. This way you can verify the basic components of the 
model and assess the accuracy of the finite-element solution before modeling the coupled 
system. In a second step you simulate a decoupled problem, where the acoustic domain is 
completely surrounded by sound hard boundaries. In the third step you perform a coupled 
analysis where the boundary at the disc instead has the accelerations of the disc as 
boundary conditions. At the same time, the acoustic pressure supplies a load on the disc.

Δ p–
ω2

c2
------ p=
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Results and Discussion

To be able to study the effects of the coupling, we first look at the solution of the 
uncoupled problem. Figure  through Figure 4 show the two first uncoupled structural and 
acoustic modes.

Figure 1: First uncoupled structural mode represented with vertical displacement.
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Figure 2: Second uncoupled structural mode represented with vertical displacement.

Figure 3: First uncoupled acoustic mode represented with pressure isosurfaces.
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Figure 4: Second uncoupled acoustic mode represented with pressure isosurfaces.

In Ref. 1, D.G. Gorman and others have thoroughly investigated the model at hand, and 
they have developed a semi-analytical solution verified by experiments. Their results for the 
coupled problem are presented in Table 1, together with the computed results from the 
COMSOL Multiphysics analysis..

TABLE 1:  RESULTS FROM SEMI-ANALYTICAL AND COMSOL MULTIPHYSICS ANALYSIS AND EXPERIMENTAL DATA

Dominated by Semi-analytical (Hz) Computed (Hz) Experimental (Hz)

str/ac 636.9 637.2 630

str/ac 707.7 707.7 685

ac 1347 1347 1348

str 1394 1396/1397 1376

ac 2018 2018 2040

str 2289 2295/2307 2170

str/ac 2607 2628 2596

ac 2645 2646 –

str/ac 2697 2698 2689

ac 2730 2730 2756

ac 2968 2968 2971
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As the table shows, the computed eigenfrequencies are in good agreement with both the 
theoretical predictions and the experimentally measured values. The table also states 
whether the mode is structurally dominated (str), acoustically dominated (ac), or tightly 
coupled (str/ac).The eigenfrequency precision is generally better for the acoustically 
dominated modes.

Most of the modes show rather weak coupling between the structural bending of the disc 
and the pressure field in the cylinder. It is, however, interesting to note that some of the 
uncoupled modes have been split into one covibrating and one contravibrating mode with 
distinct eigenfrequencies. This is, for example, the case for modes 1 and 2 in the FEM 
solution.

In Figure 5 the first coupled mode is shown in terms of disc displacements and air pressure. 
The coupling effect can be clearly displayed using a plot of pressure gradients, as in 
Figure 6.

Figure 5: Disc deformation and pressure contours for the first coupled mode.
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Figure 6: Disc deformation and pressure gradient contours for the first coupled mode.

Reference

1. D.G. Gorman, J.M. Reese, J. Horacek, and D. Dedouch, “Vibration Analysis of a 
Circular Disk Backed by a Cylindrical Cavity,” Proc. Instn. Mech. Engrs., Part C, vol. 215, 
no 11, pp 1303-1311, 2001.

Notes About the COMSOL Implementation

You specify the part of the physics for which to compute the uncoupled eigenvalues by 
selecting the variables for the eigenvalue solver.

When coupling the two types of physics, be careful when selecting the sign of the coupling 
terms, so that they act in the intended direction. You should specify the acceleration in the 
inward normal direction for the pressure acoustics domain, which in this case is the positive 
z-acceleration of the disc. The acceleration is denoted wtt as it is the second 
time-derivative of the variable w. The pressure on the shell can be given using global 
directions, so that a positive pressure acts as a face load in the negative z-direction. This is 
handled automatically by COMSOL in the setup in this example.
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Application Library path: Structural_Mechanics_Module/
Acoustic-Structure_Interaction/coupled_vibrations_manual

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Shell (shell).

3 Click Add.

4 In the Select Physics tree, select Acoustics>Pressure Acoustics>Pressure Acoustics, 

Frequency Domain (acpr).

5 Click Add.

6 Click Study.

7 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>

Eigenfrequency.

8 Click Done.

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Cylinder 1 (cyl1)
1 On the Geometry toolbar, click Cylinder.

2 In the Settings window for Cylinder, locate the Size and Shape section.

3 In the Radius text field, type 38.

4 In the Height text field, type 255.

5 Right-click Cylinder 1 (cyl1) and choose Build Selected.
8 |  V I B R A T I O N S  O F  A  D I S K  B A C K E D  B Y  A N  A I R - F I L L E D  C Y L I N D E R



Form Union (fin)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click Form 

Union (fin) and choose Build Selected.

S H E L L  ( S H E L L )

1 In the Model Builder window, under Component 1 (comp1) click Shell (shell).

2 Select Boundary 3 only.

3 In the Settings window for Shell, locate the Thickness section.

4 In the d text field, type 0.38[mm].

Fixed Constraint 1
1 On the Physics toolbar, click Edges and choose Fixed Constraint.

2 Select Edges 2, 3, 7, and 10 only.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, locate the Material Contents section.

2 In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundary 3 only.

5 Locate the Material Contents section. In the table, enter the following settings:

Property Name Value Unit Property group

Density rho 1.2 kg/m³ Basic

Speed of sound c 343 m/s Basic

Property Name Value Unit Property group

Young’s modulus E 2.1e11 Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 7800 kg/m³ Basic
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M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
More Operations>Free Quad.

Free Quad 1
Select Boundary 3 only.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. In the Maximum element size text field, type 
10.

Free Quad 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Free Quad 1.

2 In the Settings window for Free Quad, click Build Selected.

3 In the Model Builder window, right-click Mesh 1 and choose Swept.

Swept 1
In the Settings window for Swept, click Build Selected.

S T U D Y  1

In the first study, you solve the structural problem only.

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Structural Analysis in the Label text field.

S T R U C T U R A L  A N A L Y S I S

Step 1: Eigenfrequency
1 In the Model Builder window, under Structural Analysis click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 Select the Desired number of eigenfrequencies check box.

4 In the associated text field, type 20.

5 In the Search for eigenfrequencies around text field, type 500.

Exclude the Pressure Acoustics interface.

6 Locate the Physics and Variables Selection section. In the table, clear the Solve for check 
box for the Pressure Acoustics, Frequency Domain (acpr) interface.
10 |  V I B R A T I O N S  O F  A  D I S K  B A C K E D  B Y  A N  A I R - F I L L E D  C Y L I N D E R



7 On the Home toolbar, click Compute.

R E S U L T S

Mode Shape (shell)
1 In the Model Builder window, under Results click Mode Shape (shell).

2 In the Settings window for 3D Plot Group, type Mode Shape, Structural Analysis 
in the Label text field.

Surface 1
1 In the Model Builder window, expand the Results>Mode Shape, Structural Analysis node, 

then click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Shell>Displacement>

Displacement field>w - Displacement field, z component.

3 On the Mode Shape, Structural Analysis toolbar, click Plot.

4 Click the Go to XY View button on the Graphics toolbar.

5 Click the Scene Light button on the Graphics toolbar.

Mode Shape, Structural Analysis
1 In the Model Builder window, under Results click Mode Shape, Structural Analysis.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Eigenfrequency (Hz) list, choose 1401 (1).

4 On the Mode Shape, Structural Analysis toolbar, click Plot.

Undeformed Geometry (shell)
1 In the Model Builder window, under Results click Undeformed Geometry (shell).

2 In the Settings window for 3D Plot Group, type Undeformed Geometry, Structural 
Analysis in the Label text field.

R O O T

Add the second study to solve the pure acoustics problem.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Eigenfrequency.

For this study, exclude the Shell interface.
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4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Shell (shell) interface.

5 Click Add Study in the window toolbar.

6 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Acoustics Analysis in the Label text field.

A C O U S T I C S  A N A L Y S I S

Step 1: Eigenfrequency
1 In the Model Builder window, under Acoustics Analysis click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 Select the Desired number of eigenfrequencies check box.

4 In the associated text field, type 20.

5 In the Search for eigenfrequencies around text field, type 500.

6 On the Home toolbar, click Compute.

R E S U L T S

Acoustic Pressure (acpr)
1 In the Model Builder window, under Results click Acoustic Pressure (acpr).

2 In the Settings window for 3D Plot Group, type Acoustic Pressure, Acoustics 
Analysis in the Label text field.

Sound Pressure Level (acpr)
1 In the Model Builder window, under Results click Sound Pressure Level (acpr).

2 In the Settings window for 3D Plot Group, type Sound Pressure Level, Acoustics 
Analysis in the Label text field.

Acoustic Pressure, Isosurfaces (acpr)
1 In the Model Builder window, under Results click Acoustic Pressure, Isosurfaces (acpr).

2 In the Settings window for 3D Plot Group, type Acoustic Pressure, Acoustics 
Analysis, Isosurfaces in the Label text field.

3 Locate the Data section. From the Eigenfrequency (Hz) list, choose 672.5.
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Isosurface 1
1 In the Model Builder window, expand the Results>Acoustic Pressure, Acoustics Analysis, 

Isosurfaces node, then click Isosurface 1.

2 In the Settings window for Isosurface, locate the Coloring and Style section.

3 From the Color table list, choose WaveLight.

4 Select the Symmetrize color range check box.

5 On the Acoustic Pressure, Acoustics Analysis, Isosurfaces toolbar, click Plot.

6 Click the Go to Default 3D View button on the Graphics toolbar.

Acoustic Pressure, Acoustics Analysis, Isosurfaces
1 In the Model Builder window, under Results click Acoustic Pressure, Acoustics Analysis, 

Isosurfaces.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Eigenfrequency (Hz) list, choose 1345.

4 On the Acoustic Pressure, Acoustics Analysis, Isosurfaces toolbar, click Plot.

Add the boundary conditions that couple the Pressure Acoustics and Shell interfaces.

S H E L L  ( S H E L L )

Face Load 1
1 On the Physics toolbar, click Boundaries and choose Face Load.

2 Select Boundary 3 only.

The acoustic pressure exerts a normal load on the plate.

3 In the Settings window for Face Load, locate the Force section.

4 From the FA list, choose Acoustic load per unit area (acpr/fpam1).

P R E S S U R E  A C O U S T I C S ,  F R E Q U E N C Y  D O M A I N  ( A C P R )

In the Model Builder window, under Component 1 (comp1) click Pressure Acoustics, 

Frequency Domain (acpr).

Normal Acceleration 1
1 On the Physics toolbar, click Boundaries and choose Normal Acceleration.

2 Select Boundary 3 only.

The inward normal acceleration at the plate equals the second time derivative of the 
vertical displacement.

3 In the Settings window for Normal Acceleration, locate the Normal Acceleration section.
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4 From the Type list, choose Acceleration.

5 From the a0 list, choose Acceleration (shell/emm1).

Add the third study for the coupled problem.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Eigenfrequency.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  3

1 In the Model Builder window, click Study 3.

2 In the Settings window for Study, type Coupled Analysis in the Label text field.

C O U P L E D  A N A L Y S I S

Step 1: Eigenfrequency
1 In the Model Builder window, under Coupled Analysis click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 Select the Desired number of eigenfrequencies check box.

4 In the associated text field, type 20.

5 In the Search for eigenfrequencies around text field, type 500.

6 On the Home toolbar, click Compute.

R E S U L T S

Mode Shape (shell)
1 In the Model Builder window, click Mode Shape (shell).

2 In the Settings window for 3D Plot Group, type Mode Shape, Coupled Analysis in 
the Label text field.

3 Locate the Data section. From the Eigenfrequency (Hz) list, choose 637.2.

Surface 1
1 In the Model Builder window, expand the Results>Mode Shape, Coupled Analysis node, 

then click Surface 1.
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2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose w - Displacement field, z component.

Mode Shape, Coupled Analysis
In the Model Builder window, under Results right-click Mode Shape, Coupled Analysis and 
choose Slice.

Slice 1
1 In the Settings window for Slice, locate the Plane Data section.

2 In the Planes text field, type 1.

3 Locate the Coloring and Style section. From the Color table list, choose WaveLight.

4 On the Mode Shape, Coupled Analysis toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

Plot the pressure gradient to display the connection to the disk shape.

6 Locate the Expression section. In the Expression text field, type pz.

7 In the Unit field, type Pa/m.

8 On the Mode Shape, Coupled Analysis toolbar, click Plot.

Undeformed Geometry (shell)
1 In the Model Builder window, under Results click Undeformed Geometry (shell).

2 In the Settings window for 3D Plot Group, type Undeformed Geometry, Coupled 
Analysis in the Label text field.

Acoustic Pressure (acpr)
1 In the Model Builder window, under Results click Acoustic Pressure (acpr).

2 In the Settings window for 3D Plot Group, type Acoustic Pressure, Coupled 
Analysis in the Label text field.

Sound Pressure Level (acpr)
1 In the Model Builder window, under Results click Sound Pressure Level (acpr).

2 In the Settings window for 3D Plot Group, type Sound Pressure Level, Coupled 
Analysis in the Label text field.

Acoustic Pressure, Isosurfaces (acpr)
1 In the Model Builder window, under Results click Acoustic Pressure, Isosurfaces (acpr).

2 In the Settings window for 3D Plot Group, type Acoustic Pressure, Coupled 
Analysis, Isosurfaces in the Label text field.
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Introduction

The component shown in Figure 1 is part of a support mechanism and is subjected to both 
mechanical loads and thermal loads. This tutorial model takes you through the steps to 
carry out a detailed analysis of the part using the Structural Mechanics Module.

Figure 1: Geometry of the elbow bracket.

In the various parts of the example you are introduced to using the available basic analysis 
types, together with numerous postprocessing possibilities. These analysis types are: 

• Static analysis

• Eigenfrequency analysis

• Damped eigenfrequency analysis

In an extended version of this model, also the following study types are covered:

• Transient analysis

• Modal based transient analysis

• Frequency response analysis

• Modal based frequency response analysis

• Parametric analysis

• Linear buckling analysis

This tutorial model comes in two versions:

• A short version, elbow_bracket_brief, treating the three first analysis types in the 
above list.

• A complete version, elbow_bracket, treating all nine analysis types.

Each of the listed analysis types corresponds to a study type; the available studies are 
described in the section Available Study Types in the Structural Mechanics Module User’s 
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Guide. The chapter Structural Mechanics Modeling in the same manual provides further 
assistance.

Model Definition

The geometry for this part, see Figure 1, has been created with a CAD software, and it is 
available for you to import into COMSOL Multiphysics.

Material
Structural steel, as taken from the material library, with Young’s modulus of 200 GPa, 
Poisson’s ratio of 0.33, and coefficient of thermal expansion 12.3·10-6 K−1.

Damping
The Structural Mechanics Module supports Rayleigh damping and loss factor damping. 
You can also use no damping, which is the default option.

In some of the studies Rayleigh damping is used. Then you specify damping parameters 
that are proportional to the mass (αdM) and stiffness (βdK) in the following way:

where C is the damping matrix, M is the mass matrix, and K is the stiffness matrix. The 
damping is specified locally in each domain; this means that you can specify different 
damping parameters in different parts of the model.

To find the values for the Rayleigh damping, you can use the relations between the critical 
damping ratio and the Rayleigh damping parameters. It is often easier to interpret the 
critical damping ratios, which are given by

where ξi is the critical damping ratio at a specific angular frequency ωi. Knowing two pairs 
of corresponding ξi and ωi results in a system of equations

with the damping parameters as the unknown variables.

C αdMM βdKK+=

ξi

αdM
ωi

----------- βdK ωi⋅+ 
 

2
--------------------------------------------=

1
2 ω1⋅( )

-------------------
ω1
2
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1
2 ω2⋅( )
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ω2
2
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=
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Assume that the structure has a constant damping ratio of 0.1. Select two frequencies near 
the excitation frequency, 400 Hz and 600 Hz. Solving the system of equations above gives 
the result is αdM = 300 and βdK = 3.2·10−5.

For more information see the section about modeling damping and losses in the 
Structural Mechanics Module User’s Guide.

If modal-based dynamic response studies are performed it is usually easier to give the 
critical damping ratios directly. This also gives more detailed control over the damping 
properties over a large frequency range.

Loads and Constraints
The displacement are fixed in all directions on the face shown in Figure 2. The load is 
described under each study, but in all cases it is distributed over the face shown in this 
figure.

Figure 2: Constraint and loading of the bracket.

The Application Libraries note immediately below appears in the discussion of every 
model. The path indicates the location of the example file in the Application Libraries root 
directory. The most convenient way to open it is from the Application Libraries window in 
the COMSOL Desktop, which you can open from the File menu.

Application Library path: Structural_Mechanics_Module/Tutorials/
elbow_bracket_brief

Loaded face

Fixed face
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 From the Source list, choose COMSOL Multiphysics file.

4 Click Browse.

5 Browse to the application’s Application Libraries folder and double-click the file 
elbow_bracket.mphbin.

6 Click Import.
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7 Click the Wireframe Rendering button on the Graphics toolbar.

The view in the Graphics window should look like that in the image below.

8 Click the Wireframe Rendering button on the Graphics toolbar to return to the default 
surface rendering.

Suppress some edges during meshing, in order to avoid generation of unnecessary small 
elements.

Ignore Edges 1 (ige1)
1 On the Geometry toolbar, click Virtual Operations and choose Ignore Edges.

2 On the object fin, select Edges 17, 21, 23, 27, 38, 40, 42, and 44 only.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Tetrahedral.

Size
The default free mesher has nine predefined combinations of mesh parameter settings. 
They range from Extremely fine to Extremely coarse, with Normal as the default setting. 
Unless any other mesh parameters are set, this is the setting that is used if you use Build All 
or Build Selected to generate the mesh.

1 In the Settings window for Size, locate the Element Size section.

2 From the Predefined list, choose Coarse.
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As a stress concentration can be expected in the corner of the bracket, put a finer mesh 
there.

Free Tetrahedral 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Tetrahedral 1 and choose Size.

Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 Locate the Element Size section. From the Predefined list, choose Extra fine.

4 Select Boundaries 13 and 14 only.

5 In the Model Builder window, click Mesh 1.

6 In the Settings window for Mesh, click Build All.

M A T E R I A L S

Next, specify the material properties. You can do this either by explicitly typing them in or 
by selecting a library material in the Material Browser. For this model, use a library 
material.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Structural steel.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

Static Analysis

A static analysis has no explicit or implicit time dependencies. This situation corresponds 
to the steady state with constant (in time) boundary conditions and material properties.

The purpose of such analysis can be to find the maximum stress level and compare it with 
the material’s yield strength, as well as to check that the deformation of the component is 
within the limits of the design criteria.
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Results and Discussion

The analysis shows that the von Mises effective stress has a maximum value of about 
190 MPa, which, compared with the material’s yield strength of 350 MPa, results in a 
utilization factor of 54%.

The analysis also gives the maximum static displacements as 1.14 mm

Three different representations of the stress state are shown in Figure 3 through Figure 5.

Figure 3: Effective stresses on the boundary of the domain.
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Figure 4: Isosurface plot of the effective stress.

Figure 5: Arrow plot of the principal stresses.
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Modeling Instructions

S O L I D  M E C H A N I C S  ( S O L I D )

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundary 1 only.

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundary 21 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the FA vector as

S T U D Y  1

In this model, where there are many different studies, it is a good idea to assign manual 
names to some nodes in the model tree.

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Study 1 (Static) in the Label text field.

The default settings in the generated solver are OK for this model, so it can be run 
directly.

3 On the Home toolbar, click Compute.

Before moving on to analyzing the solution, rename the solver.

S T U D Y  1  ( S T A T I C )

In the Model Builder window, expand the Study 1 (Static) node.

Solution 1 (sol1)
1 In the Model Builder window, expand the Study 1 (Static)>Solver Configurations node, 

then click Solution 1 (sol1).

2 In the Settings window for Solution, type Solution, Static in the Label text field.

3[MPa] x

0 y

3[MPa] z
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R E S U L T S

Similarly, rename the solution data set.

Data Sets
1 In the Model Builder window, expand the Results>Data Sets node, then click Study 1 

(Static)/Solution, Static (sol1).

2 In the Settings window for Solution, type Static Solution in the Label text field.

In the Results branch, you can create various plot types, evaluate expressions, or animate 
the results. The result features can visualize any expression containing, for example, the 
solution variables, their derivatives, and the space coordinates. Many frequently used 
expressions are predefined as postprocessing variables, and they are directly available in 
the Expression section menus for the various plot types.

When the solver finishes, a default plot appears. It shows a surface plot of the von Mises 
stress with the deformed shape of the component. For future reference, you can rename 
it.

Stress (solid)
1 In the Model Builder window, under Results click Stress (solid).

2 In the Settings window for 3D Plot Group, type Static Stress Contour in the Label 
text field.

3 Click the Zoom Extents button on the Graphics toolbar.

To evaluate the maximum displacement, use a maximum coupling operator.

D E F I N I T I O N S

Maximum 1 (maxop1)
1 On the Definitions toolbar, click Component Couplings and choose Maximum.

2 In the Settings window for Maximum, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose All boundaries.

Variables 1
1 On the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.
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3 In the table, enter the following settings:

S T U D Y  1  ( S T A T I C )

Solution, Static (sol1)
1 In the Model Builder window, under Study 1 (Static)>Solver Configurations right-click 

Solution, Static (sol1) and choose Solution>Update.

This step is necessary in order to access variables that were created after the solution was 
performed.

R E S U L T S

Global Evaluation 1
On the Results toolbar, click Global Evaluation.

Derived Values
1 In the Settings window for Global Evaluation, click Replace Expression in the upper-right 

corner of the Expressions section. From the menu, choose Component 1>Definitions>

Variables>U_max - Maximum deflection.

2 Locate the Expressions section. In the table, enter the following settings:

3 Click Evaluate.

The result, approximately 1.1 mm appears in the Table window.

Next, add a second plot group and create an isosurface plot. The resulting plot should 
resemble that in Figure 4.

3D Plot Group 2
1 On the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Static Stress Isosurface in the 
Label text field.

Static Stress Isosurface
1 Right-click Static Stress Isosurface and choose Isosurface.

Name Expression Unit Description

U_max maxop1(solid.disp) m Maximum deflection

Expression Unit Description

U_max mm Maximum deflection
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2 In the Settings window for Isosurface, click Replace Expression in the upper-right corner 
of the Expression section. From the menu, choose Component 1>Solid Mechanics>Stress>

solid.mises - von Mises stress.

3 Right-click Results>Static Stress Isosurface>Isosurface 1 and choose Deformation.

4 Click the Go to Default 3D View button on the Graphics toolbar.

With the following steps you can reproduce the principal stress arrow plot shown in 
Figure 5:

3D Plot Group 3
1 On the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Static Principal Stress Arrow 
Plot in the Label text field.

Principal Stress Volume 1
On the Static Principal Stress Arrow Plot toolbar, click More Plots and choose Principal Stress 

Volume.

Static Principal Stress Arrow Plot
1 In the Settings window for Principal Stress Volume, locate the Positioning section.

2 Find the X grid points subsection. In the Points text field, type 10.

3 Find the Y grid points subsection. In the Points text field, type 15.

4 Find the Z grid points subsection. In the Points text field, type 10.

5 On the Static Principal Stress Arrow Plot toolbar, click Plot.

Eigenfrequency Analysis

An eigenfrequency analysis finds the eigenfrequencies and modes of deformation of a 
component. The eigenfrequencies f in the structural mechanics field are related to the 
eigenvalues λ returned by the solvers through

In COMSOL Multiphysics you can choose between working with eigenfrequencies and 
working with eigenvalues according to your preferences. Eigenfrequencies is the default 
option for all physics interfaces in the Structural Mechanics Module.

If no damping is included in the material, the undamped natural frequencies are 
computed.

f λ–
2πi
---------=
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The purpose of the following eigenfrequency analysis is to find the six lowest 
eigenfrequencies and corresponding mode shapes.

Results and Discussion

The first six eigenfrequencies, rounded to three digits, are:

The mode shapes corresponding to the two lowest eigenfrequencies are shown in 
Figure 6. The deformed plot indicates an oscillation in the xy-plane for the lowest 
eigenfrequency, while the second lowest eigenmode shows an oscillation in the yz-plane.

Figure 6: Eigenmodes of the two lowest eigenfrequencies.

Notes About the COMSOL Implementation

Any loads present on the model, such as the load from the static load case above, are 
ignored in the default eigenfrequency analysis. It is also possible to include effects from 
prestress. You can find an example of such an analysis in the example Vibrating String.

EIGENFREQUENCY FREQUENCY

f1 417 Hz

f2 571 Hz

f3 1927 Hz

f4 2455 Hz

f5 3111 Hz

f6 3933 Hz
14 |  S T A T I C  A N D  E I G E N F R E Q U E N C Y  A N A L Y S E S  O F  A N  E L B O W  B R A C K E T



Modeling Instructions

Add a new study to your model.

Add a new study to your model.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Eigenfrequency.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Study 2 (Eigenfrequency) in the Label text 
field.

3 On the Home toolbar, click Compute.

S T U D Y  2  ( E I G E N F R E Q U E N C Y )

Solution 2 (sol2)
1 In the Model Builder window, expand the Study 2 (Eigenfrequency)>Solver Configurations 

node, then click Solution 2 (sol2).

2 In the Settings window for Solution, type Solution, Eigenfrequency in the Label 
text field.

R E S U L T S

Data Sets
1 In the Model Builder window, under Results>Data Sets click Study 2 (Eigenfrequency)/

Solution, Eigenfrequency (sol2).

2 In the Settings window for Solution, type Eigenfrequency Solution in the Label text 
field.

Mode Shape (solid)
As a default, the first eigenmode is shown. Follow these steps to reproduce the plot in the 
left panel of Figure 6.

1 In the Model Builder window, expand the Mode Shape (solid) node, then click Surface 1.
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2 In the Settings window for Surface, locate the Coloring and Style section.

3 Clear the Color legend check box.

The displacement values do not have any real significance for an eigenmode plot such 
as this one.

Take a look at the second mode as well.

4 In the Model Builder window, click Mode Shape (solid).

5 In the Settings window for 3D Plot Group, locate the Data section.

6 From the Eigenfrequency (Hz) list, choose 573.5.

7 On the Mode Shape (solid) toolbar, click Plot.

Compare the resulting plot to that to the right in Figure 6.

You can give the plot a more descriptive name:

8 In the Label text field, type Undamped Mode Shapes.

9 On the Undamped Mode Shapes toolbar, click Animation and choose Player.

Export
This creates an animation showing how the elbow bracket would deform if subjected to a 
harmonic load with a frequency near the selected eigenfrequency, in this case 571 Hz. To 
play the movie again, click the Play button on the Graphics toolbar.

The default animation sequence type when you add a player this way is Dynamic data 

extension. If you set the Sequence type to Stored solutions and then click the Generate Frame 
button, you get an animation where each frame corresponds to an eigenmode in the 
Eigenfrequency list. By using the Frame number slider in the Frames section you can then 
easily browse the eigenmodes.

Rename the player:

1 In the Model Builder window, under Results>Export click Animation 1.

2 In the Settings window for Animation, type Mode Shape Animation in the Label text 
field.

Damped Eigenfrequency Analysis

If the material has damping, the eigenvalue solver automatically switches to computation 
of the damped eigenfrequencies. The damped eigenfrequencies and eigenmodes are 
complex. The real part of the eigenfrequency corresponds to the frequency and the 
imaginary part is the damping.
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Results and Discussion

The first six eigenfrequencies (rounded to three digits) are given below, and can be 
compared with the results from the undamped model.:

The relative damping of a certain mode is the ratio between the imaginary and the real 
part. It can be seen that the relative damping increases rapidly as the natural frequency 
increases. This is an effect of the Rayleigh damping model.

Notes About the COMSOL Implementation

As the eigenvalues exist as complex conjugate pairs, the first six damped eigenfrequencies 
correspond to the first three undamped eigenfrequencies. For this reason, twelve 
computed frequencies are requested.

Modeling Instructions

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Eigenfrequency.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S O L I D  M E C H A N I C S  ( S O L I D )

Add damping and specify the mass and stiffness parameters.

EIGENFREQUENCY FREQUENCY UNDAMPED 
FREQUENCY

f1 415+41.3i Hz 417 Hz

f2 568+56.6i Hz 571 Hz

f3 1885+397i Hz 1927 Hz

f4 2372+630i Hz 2454 Hz

f5 2947+997i Hz 3111 Hz

f6 3602+1579i Hz 3933 Hz
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Linear Elastic Material 1
In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 
Linear Elastic Material 1.

Damping 1
1 On the Physics toolbar, click Attributes and choose Damping.

2 In the Settings window for Damping, locate the Damping Settings section.

3 In the αdM text field, type 300.

4 In the βdK text field, type 3.2e-5.

S T U D Y  3

1 In the Model Builder window, click Study 3.

2 In the Settings window for Study, type Study 3 (Damped Eigenfrequency) in the 
Label text field.

3 On the Home toolbar, click Compute.

S T U D Y  3  ( D A M P E D  E I G E N F R E Q U E N C Y )

Solution 3 (sol3)
1 In the Model Builder window, expand the Study 3 (Damped Eigenfrequency)>Solver 

Configurations node, then click Solution 3 (sol3).

2 In the Settings window for Solution, type Solution, Damped Eigenfrequency in the 
Label text field.

R E S U L T S

Data Sets
1 In the Model Builder window, under Results>Data Sets click Study 3 (Damped 

Eigenfrequency)/Solution, Damped Eigenfrequency (sol3).

2 In the Settings window for Solution, type Damped Eigenfrequency Solution in the 
Label text field.

Mode Shape (solid)
1 In the Model Builder window, under Results click Mode Shape (solid).

2 In the Settings window for 3D Plot Group, type Damped Mode Shapes in the Label text 
field.

The mode shape identical to the one obtained when solving the undamped problem. 
Only the frequency has changed.
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Damped Mode Shapes
1 In the Model Builder window, expand the Results>Damped Mode Shapes node, then click 

Surface 1.

2 In the Settings window for Surface, locate the Coloring and Style section.

3 Clear the Color legend check box.

The second study should still produce undamped eigenfrequencies when it is run next 
time, so you must make sure that the newly added Damping node is ignored.

S T U D Y  2  ( E I G E N F R E Q U E N C Y )

Step 1: Eigenfrequency
1 In the Model Builder window, expand the Study 2 (Eigenfrequency) node, then click Step 

1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Physics and Variables Selection 
section.

3 Select the Modify physics tree and variables for study step check box.

4 In the Physics and variables selection tree, select Component 1 (comp1)>Solid Mechanics 

(solid)>Linear Elastic Material 1>Damping 1.

5 Click Disable.
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Introduction

Small heating circuits find use in many applications. For example, in manufacturing 
processes they heat up reactive fluids. Figure 1 illustrates a typical heating device for this 
application. The device consists of an electrically resistive layer deposited on a glass plate. 
The layer causes Joule heating when a voltage is applied to the circuit. The layer’s 
properties determine the amount of heat produced.

Figure 1: Geometry of a heating device.

In this particular application, you must observe three important design considerations:

• Non-invasive heating

• Minimal deflection of the heating device

• Avoidance of overheating the process fluid

The heater must also work without failure. You achieve the first and second requirements 
by inserting a glass plate between the heating circuit and the fluid; it acts as a conducting 
separator. Glass is an ideal material for both these purposes because it is non-reactive and 
has a low coefficient of thermal expansion. 

You must also avoid overheating due to the risk of self-ignition of the reactive fluid stream. 
Ignition is also the main reason for separating the electrical circuit from direct contact with 
the fluid. The heating device is tailored for each application, making virtual prototyping 
very important for manufacturers.

For heating circuits in general, detachment of the resistive layer often determines the 
failure rate. This is caused by excessive thermally induced interfacial stresses. Once the 
layer has detached, it gets locally overheated, which accelerates the detachment. Finally, in 
the worst case, the circuit might overheat and burn. From this perspective, it is also 
important to study the interfacial tension due to the different thermal-expansion 
coefficients of the resistive layer and the substrate as well as the differences in temperature. 

Heated fluid 
stream

Air

Electric heater

Glass plate
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The geometric shape of the layer is a key parameter to design circuits for proper 
functioning. You can investigate all of the above-mentioned aspects by modeling the 
circuit.

This multiphysics example simulates the electrical heat generation, the heat transfer, and 
the mechanical stresses and deformations of a heating circuit device. The model uses the 
Heat Transfer in Solids interface of the Heat Transfer Module in combination with the 
Electric Currents, Shell interface from the AC/DC Module and the Solid Mechanics and 
Shell interfaces from the Structural Mechanics Module.

Note: This application requires the AC/DC Module, the Heat Transfer Module, and the 
Structural Mechanics Module.

Model Definition

Figure 2 shows a drawing of the modeled heating circuit. 

Figure 2: Drawing of the heating circuit deposited on a glass plate.

The device consists of a serpentine-shaped Nichrome resistive layer, 10 μm thick and 
5 mm wide, deposited on a glass plate. At each end, it has a silver contact pad measuring 
10 mm-by-10 mm-by-10 μm. When the circuit is in use, the deposited side of the glass 
plate is in contact with surrounding air, and the back side is in contact with the heated 
fluid. Assume that the edges and sides of the glass plate are thermally insulated.

Table 1 gives the resistor’s dimensions.

TABLE 1:  DIMENSIONS

OBJECT LENGTH WIDTH THICKNESS

Glass Plate 130 mm 80 mm 2 mm

Pads and Circuit - - 10 µm

Silver Pads

Nichrome Circuit
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During operation the resistive layer produces heat. Model the electrically generated heat 
using the Electric Currents, Shell interface from the AC/DC Module. An electric potential 
of 12 V is applied to the pads. In the model, you achieve this effect by setting the potential 
at one edge of the first pad to 12 V and that of one edge of the other pad to 0 V.

To model the heat transfer in the thin conducting layer, use the Thin Layer feature from 
the Heat Transfer in Solids interface. The heat rate per unit area (measured in W/m2) 
produced inside the thin layer is given by

 (1)

where QDC = J · E = σ|∇tV|2 (W/m3) is the power density. The generated heat appears as 
an inward heat flux at the surface of the glass plate. 

At steady state, the resistive layer dissipates the heat it generates in two ways: on its up side 
to the surrounding air (at 293 K), and on its down side to the glass plate. The glass plate 
is similarly cooled in two ways: on its circuit side by air, and on its back side by a process 
fluid (353 K). You model the heat fluxes to the surroundings using heat transfer 
coefficients, h. For the heat transfer to air, h = 5 W/(m2·K), representing natural 
convection. On the glass plate’s back side, h = 20 W/(m2·K), representing convective heat 
transfer to the fluid. The sides of the glass plate are insulated.

The model simulates thermal expansion using static structural-mechanics analyses. It uses 
the Solid Mechanics interface for the glass plate, and the Shell interface for the circuit layer. 
The equations of these two interfaces are described in the Structural Mechanics Module 
User’s Guide. The stresses are set to zero at 293 K. You determine the boundary 
conditions for the Solid Mechanics interface by fixing one corner with respect to x-, y-, 
and z-displacements and rotation.

Table 2 summarizes the material properties used in the model.

TABLE 2:  MATERIAL PROPERTIES

MATERIAL E [GPa] ν α [1/K] k [W/(m·K)] ρ [kg/m3] Cp [J/(kg·K)]

Silver 83 0.37 1.89e-5 420 10500 230

Nichrome 213 0.33 1e-5 15 9000 20

Glass 73.1 0.17 5.5e-7 1.38 2203 703

qprod d QDC=
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Results and Discussion

Figure 3 shows the heat that the resistive layer generates.

Figure 3: Stationary heat generation in the resistive layer when 12 V is applied.

The highest heating power occurs at the inner corners of the curves due to the higher 
current density at these spots. The total generated heat, as calculated by integration, is 
approximately 13.8 W.
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Figure 4 shows the temperature of the resistive layer and the glass plate at steady state.

Figure 4: Temperature distribution in the heating device at steady state.

The highest temperature is approximately 428 K, and it appears in the central section of 
the circuit layer. It is interesting to see that the differences in temperature between the 
fluid side and the circuit side of the glass plate are quite small because the plate is very thin. 
Using boundary integration, the integral heat flux on the fluid side evaluates to 
approximately 8.5 W. This means that the device transfers the majority of the heat it 
generates—8.5 W out of 13.8 W—to the fluid, which is good from a design perspective, 
although the thermal resistance of the glass plate results in some losses.

The temperature rise also induces thermal stresses due the materials’ different coefficients 
of thermal expansion. As a result, mechanical stresses and deformations arise in the layer 
and in the glass plate. Figure 5 shows the effective stress distribution in the device and the 
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resulting deformations. During operation, the glass plate bends towards the air side.

Figure 5: The thermally induced von Mises effective stress plotted with the deformation.

The highest effective stress, approximately 13 MPa, occurs at the inner corners of the 
curves of the Nichrome circuit. The yield stress for high quality glass is roughly 250 MPa, 
and for Nichrome it is 360 MPa. This means that the individual objects remain structurally 
intact for the simulated heating power loads.

You must also consider stresses in the interface between the resistive layer and the glass 
plate. Assume that the yield stress of the surface adhesion in the interface is in the region 
of 50 MPa—a value significantly lower than the yield stresses of the other materials in the 
device. If the effective stress increases above this value, the resistive layer locally detaches 
from the glass. Once it has detached, heat transfer is locally impeded, which can lead to 
overheating of the resistive layer and eventually cause the device to fail.

Figure 6 displays the effective forces acting on the adhesive layer during heater operation. 
As the figure shows, the device experiences a maximum interfacial stress that is an order of 
magnitude smaller than the yield stress. This means that the device are OK in terms of 
adhesive stress.
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Figure 6: The effective forces in the interface between the resistive layer and the glass plate.

Finally study the device’s deflections, shown in Figure 7.

Figure 7: Total displacement on the fluid side of the glass plate.
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The maximum displacement, located at the center of the plate, is approximately 50 μm. 
For high-precision applications, such as semiconductor processing, this might be a 
significant value that limits the device’s operating temperature.

Application Library path: Structural_Mechanics_Module/
Thermal-Structure_Interaction/heating_circuit

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Thermal Stress.

3 Click Add.

4 In the Select Physics tree, select AC/DC>Electric Currents, Shell (ecs).

5 Click Add.

6 In the Select Physics tree, select Structural Mechanics>Membrane (mbrn).

7 Click Add.

8 Click Study.

9 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

10 Click Done.

G E O M E T R Y  1

The Thermal Stress interface includes Heat Transfer in Solids and Solid Mechanics. In the 
volume, these two interfaces solve for temperature and displacement, respectively. In the 
shell representing the circuit, the temperature, the electrical potential and displacement are 
solved by Heat Transfer In Solids, Electric Currents, Shell, and Membrane interfaces, 
respectively.
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G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 80.

4 In the Depth text field, type 130.

5 In the Height text field, type 2.

Work Plane 1 (wp1)
1 Right-click Block 1 (blk1) and choose Build Selected.

2 On the Geometry toolbar, click Work Plane.

Name Expression Value Description

V_in 12[V] 12 V Input voltage

d_layer 10[um] 1E-5 m Layer thickness

sigma_silver 6.3e7[S/m] 6.3E7 S/m Electric 
conductivity of 
silver

sigma_nichrome 9.3e5[S/m] 9.3E5 S/m Electric 
conductivity of 
Nichrome

T_air 20[degC] 293.2 K Air temperature

h_air 5[W/(m^2*K)] 5 W/(m²·K) Heat transfer film 
coefficient, air

T_fluid 353[K] 353 K Fluid temperature

h_fluid 20[W/(m^2*K)] 20 W/(m²·K) Heat transfer film 
coefficient, fluid
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3 In the Settings window for Work Plane, locate the Plane Definition section.

4 In the z-coordinate text field, type 2.

5 Click Show Work Plane.

Plane Geometry
Click the Zoom Extents button on the Graphics toolbar.

Square 1 (sq1)
1 On the Work Plane toolbar, click Primitives and choose Square.

2 In the Settings window for Square, locate the Size section.

3 In the Side length text field, type 10.

4 Locate the Position section. In the xw text field, type 7.

5 In the yw text field, type 10.

6 Right-click Square 1 (sq1) and choose Build Selected.

Square 2 (sq2)
1 Right-click Square 1 (sq1) and choose Duplicate.

2 In the Settings window for Square, locate the Position section.

3 In the xw text field, type 30.

4 In the yw text field, type 8.

Polygon 1 (pol1)
1 Right-click Component 1 (comp1)>Geometry 1>Work Plane 1 (wp1)>Plane Geometry>

Square 2 (sq2) and choose Build Selected.

2 On the Work Plane toolbar, click Primitives and choose Polygon.

3 In the Settings window for Polygon, locate the Coordinates section.

4 From the Data source list, choose File.

5 Click Browse.

6 Browse to the application’s Application Libraries folder and double-click the file 
heating_circuit_polygon.txt.

Fillet 1 (fil1)
1 Right-click Polygon 1 (pol1) and choose Build Selected.

2 On the Work Plane toolbar, click Fillet.

3 On the object pol1, select Points 2–8, 23–29, 34, 36, 37, 41, and 42 only.

4 In the Settings window for Fillet, locate the Radius section.
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5 In the Radius text field, type 10.

Fillet 2 (fil2)
1 Right-click Fillet 1 (fil1) and choose Build Selected.

2 On the Work Plane toolbar, click Fillet.

3 On the object fil1, select Points 6–12, 26–31, 37, 40, 43, 46, 49, and 50 only.

4 In the Settings window for Fillet, locate the Radius section.

5 In the Radius text field, type 5.

6 On the Work Plane toolbar, click Build All.

Form Union (fin)
1 On the Home toolbar, click Build All.

The geometry should look like the figure below.

D E F I N I T I O N S

Add a selection that you can use later when applying boundary conditions and shell physics 
settings.

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Circuit in the Label text field.
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3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 6–8 only.

Before creating the materials for use in this model, it is a good idea to specify which 
boundaries are to be modeled as conducting shells. Using this information, COMSOL 
Multiphysics can detect which material properties are needed.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids (ht).

Thin Layer 1
1 On the Physics toolbar, click Boundaries and choose Thin Layer.

2 In the Settings window for Thin Layer, locate the Boundary Selection section.

3 From the Selection list, choose Circuit.

4 Locate the Thin Layer section. From the Layer type list, choose Thermally thin 

approximation.

5 In the ds text field, type d_layer.

E L E C T R I C  C U R R E N T S ,  S H E L L  ( E C S )

1 In the Model Builder window, under Component 1 (comp1) click Electric Currents, Shell 

(ecs).

2 In the Settings window for Electric Currents, Shell, locate the Boundary Selection 
section.

3 From the Selection list, choose Circuit.

4 Locate the Shell Thickness section. In the ds text field, type d_layer.

M E M B R A N E  ( M B R N )

On the Physics toolbar, click Electric Currents, Shell (ecs) and choose Membrane (mbrn).

1 In the Model Builder window, under Component 1 (comp1) click Membrane (mbrn).

2 In the Settings window for Membrane, locate the Boundary Selection section.

3 From the Selection list, choose Circuit.

4 Locate the Thickness section. In the d text field, type d_layer.

5 Click to expand the Dependent variables section. Locate the Dependent Variables section. 
In the Displacement field text field, type u.
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Linear Elastic Material 1
In the Model Builder window, under Component 1 (comp1)>Membrane (mbrn) click Linear 

Elastic Material 1.

Thermal Expansion 1
1 On the Physics toolbar, click Attributes and choose Thermal Expansion.

2 In the Settings window for Thermal Expansion, locate the Model Inputs section.

3 From the T list, choose Temperature (ht).

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Silica glass.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

M A T E R I A L S

Silica glass (mat1)
Now set up the materials.

Material 2 (mat2)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Silver in the Label text field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose Circuit.

5 Locate the Material Contents section. In the table, enter the following settings:

Property Name Value Unit Property 
group

Thermal conductivity k 420 W/(m·K) Basic

Density rho 10500 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 230 J/(kg·K) Basic

Electrical conductivity sigma sigma_si
lver

S/m Basic
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Material 3 (mat3)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Nichrome in the Label text field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 Select Boundary 7 only.

5 Locate the Material Contents section. In the table, enter the following settings:

With the materials defined, set up the remaining physics of the model. In the next section, 
the resistive loss within the circuit is defined as a heat source for the thermal stress physics. 
The resistive loss is calculated automatically within the Electric Currents, Shell physics 
interface. Add the coupling feature Boundary Electromagnetic Heat Source to take the 
resistive loss into account.

Relative permittivity epsilonr 1 1 Basic

Young’s modulus E 83e9 Pa Basic

Poisson’s ratio nu 0.37 1 Basic

Coefficient of thermal 
expansion

alpha 18.9e-6 1/K Basic

Property Name Value Unit Property 
group

Thermal conductivity k 15 W/(m·K) Basic

Density rho 9000 kg/m³ Basic

Heat capacity at constant 
pressure

Cp 20 J/(kg·K) Basic

Electrical conductivity sigma sigma_nic
hrome

S/m Basic

Relative permittivity epsilonr 1 1 Basic

Young’s modulus E 213e9 Pa Basic

Poisson’s ratio nu 0.33 1 Basic

Coefficient of thermal 
expansion

alpha 10e-6 1/K Basic

Property Name Value Unit Property 
group
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M U L T I P H Y S I C S

Boundary Electromagnetic Heat Source 1 (bemh1)
1 On the Physics toolbar, click Multiphysics and choose Boundary>Boundary 

Electromagnetic Heat Source.

2 In the Settings window for Boundary Electromagnetic Heat Source, locate the Boundary 

Selection section.

3 From the Selection list, choose Circuit.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids (ht).

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 4 and 6–8 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type h_air.

6 In the Text text field, type T_air.

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundary 3 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type h_fluid.

6 In the Text text field, type T_fluid.

Next, add constraints to restrain the glass plate movements.

S O L I D  M E C H A N I C S  ( S O L I D )

In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

Fixed Constraint 1
1 On the Physics toolbar, click Points and choose Fixed Constraint.

2 Select Point 1 only.
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Prescribed Displacement 1
1 On the Physics toolbar, click Points and choose Prescribed Displacement.

2 Select Point 63 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in y direction check box.

5 Select the Prescribed in z direction check box.

Prescribed Displacement 2
1 On the Physics toolbar, click Points and choose Prescribed Displacement.

2 Select Point 3 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in z direction check box.

Finally, add a voltage and ground.

E L E C T R I C  C U R R E N T S ,  S H E L L  ( E C S )

In the Model Builder window, under Component 1 (comp1) click Electric Currents, Shell (ecs).

Electric Potential 1
1 On the Physics toolbar, click Edges and choose Electric Potential.

2 Select Edge 10 only.

3 In the Settings window for Electric Potential, locate the Electric Potential section.

4 In the V0 text field, type V_in.

Ground 1
1 On the Physics toolbar, click Edges and choose Ground.

2 Select Edge 43 only.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
More Operations>Free Triangular.

Free Triangular 1
Select Boundaries 4 and 6–8 only.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Triangular 1 and choose Size.
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2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Selection list, choose Circuit.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 2.

7 In the Model Builder window, right-click Mesh 1 and choose Swept.

Swept 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Swept 1 and 
choose Distribution.

Distribution 1
1 In the Settings window for Distribution, locate the Distribution section.

2 In the Number of elements text field, type 3.

3 Click Build All.

S T U D Y  1

In order to improve the solver’s performance, set the segregated solver to calculate 
temperature, voltage and displacement separately. The best order is V, T, u.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 1>Segregated 1 node, then click Segregated Step 2.

4 In the Settings window for Segregated Step, type Electric potential V in the Label 
text field.

5 Right-click Study 1>Solver Configurations>Solution 1 (sol1)>Stationary Solver 1>

Segregated 1>Electric potential V and choose Move Up.

6 Locate the General section. In the Variables list, select Displacement field (Material) 

(comp1.u).

7 Under Variables, click Delete.

8 In the Variables list, select Normal strain (comp1.mbrn.unn).

9 Under Variables, click Delete.

10 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1)>

Stationary Solver 1>Segregated 1 click Segregated Step 3.
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11 In the Settings window for Segregated Step, type Displacement u in the Label text 
field.

12 Locate the General section. Under Variables, click Add.

13 In the Add dialog box, select Normal strain (comp1.mbrn.unn) in the Variables list.

14 Click OK.

15 On the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
The default plots show the von Mises stress including the deformation (Figure 5) and the 
temperature (Figure 4) on the surface of the full 3D geometry, and the electric potential 
and the von Mises stress on the circuit layer.

Surface 1
1 In the Model Builder window, expand the Stress (solid) node, then click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose MPa.

4 On the Stress (solid) toolbar, click Plot.

Surface
1 In the Model Builder window, expand the Results>Stress (mbrn) node, then click Surface.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose MPa.

4 On the Stress (mbrn) toolbar, click Plot.

Study 1/Solution 1 (sol1)
1 In the Model Builder window, expand the Results>Data Sets node.

2 Right-click Study 1/Solution 1 (sol1) and choose Duplicate.

Selection
1 On the Results toolbar, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Circuit.

To generate Figure 3 follow the steps below.
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3D Plot Group 6
1 On the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Surface Losses in the Label text field.

3 Locate the Data section. From the Data set list, choose Study 1/Solution 1 (2) (sol1).

Surface 1
1 Right-click Surface Losses and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Electric Currents, Shell>

Heating and losses>ecs.Qsh - Surface loss density, electromagnetic.

3 On the Surface Losses toolbar, click Plot.

4 Click the Scene Light button on the Graphics toolbar.

5 Click the Zoom Extents button on the Graphics toolbar.

The following steps generate a plot of the norm of the surface traction vector in the surface 
plane (see Figure 6):

3D Plot Group 7
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Interface Stress in the Label text 
field.

3 Locate the Data section. From the Data set list, choose Study 1/Solution 1 (2) (sol1).

Surface 1
1 Right-click Interface Stress and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type sqrt(solid.Tax^2+solid.Tay^2).

4 From the Unit list, choose MPa.

5 On the Interface Stress toolbar, click Plot.

Finally, to obtain Figure 7, proceed as follows:

Surface 1
1 On the Results toolbar, click More Data Sets and choose Surface.

2 Select Boundary 3 only.

2D Plot Group 8
1 On the Results toolbar, click 2D Plot Group.
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2 In the Settings window for 2D Plot Group, type Displacement, Bottom Boundary in 
the Label text field.

Surface 1
1 Right-click Displacement, Bottom Boundary and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>

Displacement>solid.disp - Total displacement.

3 Locate the Expression section. In the Unit field, type um.

4 On the Displacement, Bottom Boundary toolbar, click Plot.

Derived Values
To calculate the values for the total generated heat and the integrated heat flux on the fluid 
side, perform a boundary integration:

Surface Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 Select Boundary 3 only.

3 In the Settings window for Surface Integration, click Replace Expression in the 
upper-right corner of the Expressions section. From the menu, choose Component 1>

Heat Transfer in Solids>Boundary fluxes>ht.q0 - Inward heat flux.

4 Click Evaluate.

TA B L E

1 Go to the Table window.

The result should be close to 8.5 W.

R E S U L T S

Surface Integration 2
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 In the Settings window for Surface Integration, locate the Selection section.

3 From the Selection list, choose Circuit.

4 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Component 1>Electric Currents, Shell>Heating and losses>ecs.Qsh - Surface 

loss density, electromagnetic.
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5 Click Evaluate.

TA B L E

1 Go to the Table window.

The result should be close to 13.8 W.
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Introduction

In mechanical assemblies, parts are sometimes connected so that they are free to move 
relative to each other in one or more degrees of freedom. Examples of such connections 
are ball joints, hinges, and different types of bearings. If the details of the connection are 
not the subjects of the analysis, it is often possible to model the connection using the Rigid 
Connector feature in COMSOL Multiphysics.

The current example illustrates how to model a barrel hinge connecting two solid objects 
in an assembly.

Model Definition

Figure 1 shows the model geometry.

Figure 1: Model geometry.

The two parts of the assembly are connected through a barrel hinge that allows relative 
rotation only along the axis of the pin hole. All other degrees of freedom are common 
between the two parts.

The two holes of the forked bottom part are bolted, and can be considered as fully 
constrained.

The pin hole of the top part is constrained in the x direction so that it can slide in the y-z 
plane. 
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A force of 1 kN is applied in z direction at a 10 cm distance in the negative y direction 
from the center of the upper pin hole. The offset of the load thus introduces both tension 
and bending of the member.

Results and Discussion

The default plot shown in Figure 2 shows the von Mises stress in the model. You can see 
the bending of the top part due to the offset of the load. You can also see the stress that is 
transmitted around the hinge.

In Figure 3 the color gradient in the x displacement indicates that the lower part of the 
assembly undergoes bending around y axis. With a constraint rotation in y direction 
bending from one part would progress to the second part. The upper part however shows 
a fairly constant displacement through the height, which indicates that is not being bent 
in y direction and thus it has a free rotation in y direction in the connection point. 
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Figure 2: von Mises stress distribution in the hinge assembly.

Figure 3: x-displacement.
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Notes About the COMSOL Implementation

The approach when modeling mechanism is to attach rigid connectors to both parts, make 
sure that they have a common center of rotation, and then couple relevant degrees of 
freedom between them in order to obtain the desired function.

When you model a hinge, all translations and two rotations should be equal in the two 
parts. As in this case the displacement and the rotation in the hinge remain small, the 
procedure simply consists of linking the displacement in all directions as well as the 
rotation around the x and z directions. You connect the displacements of the rigid 
connectors directly using the prescribed displacement setting available in the rigid 
connector feature. In order to constrain the rotation directions independently, you need 
however to add two global constraints, one for each rotational degree of freedom. The 
rigid connector uses a quaternion representation of the rotation. For details, see the 
description in the Structural Mechanics User’s Guide. In this specific example both the 
b and the d rotation variables are coupled between the two rigid connectors, because they 
directly correspond to the intended rotation angles for small rotations.

Another rigid connector is also used for applying the force to the upper pin hole.

Application Library path: Structural_Mechanics_Module/
Connectors_and_Mechanisms/hinge_assembly

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.
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G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
hinge_assembly.mphbin.

5 Click Import.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Form Union 

(fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly 
section.

3 From the Action list, choose Form an assembly.

4 Clear the Create pairs check box.

5 Right-click Component 1 (comp1)>Geometry 1>Form Union (fin) and choose Build 

Selected.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Structural steel.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

Name Expression Value Description

F 1e3[N] 1000 N Applied load
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S O L I D  M E C H A N I C S  ( S O L I D )

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundaries 133–136 only.

Rigid Connector 1
1 On the Physics toolbar, click Boundaries and choose Rigid Connector.

2 Select Boundaries 67 and 68 only.

3 In the Settings window for Rigid Connector, locate the Prescribed Displacement at Center 

of Rotation section.

4 Select the Prescribed in x direction check box.

Applied Force 1
1 Right-click Rigid Connector 1 and choose Applied Force.

2 In the Settings window for Applied Force, locate the Location section.

3 From the list, choose User defined (absolute).

The center of rotation for a rigid connector is available in the variables xcX_rig1, 
xcY_rig1 and xcZ_rig1. The default position is the center of gravity of the attached 
boundaries, which in this case will be the center of the hole.

4 Specify the Xp vector as

5 Specify the F vector as

Rigid Connector 2
1 On the Physics toolbar, click Boundaries and choose Rigid Connector.

2 Select Boundaries 75 and 76 only.

Rigid Connector 3
1 On the Physics toolbar, click Boundaries and choose Rigid Connector.

solid.xcX_rig1 X

solid.xcY_rig1-0.1 Y

solid.xcZ_rig1 Z

0 x

0 y

F z
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2 Select Boundaries 16–19 only.

Set the translations of this rigid connector equal to the translations of the second rigid 
connector.

3 In the Settings window for Rigid Connector, locate the Prescribed Displacement at Center 

of Rotation section.

4 Select the Prescribed in x direction check box.

5 In the u0x text field, type solid.rig2.u.

6 Select the Prescribed in y direction check box.

7 In the u0y text field, type solid.rig2.v.

8 Select the Prescribed in z direction check box.

9 In the u0z text field, type solid.rig2.w.

10 In the Model Builder window’s toolbar, click the Show button and select Advanced Physics 

Options in the menu.

Connect the rotations around the x and z directions, using the quaternion degrees of 
freedom ’b’ and ’d’.

Global Constraint 1
1 On the Physics toolbar, click Global and choose Global Constraint.

2 In the Settings window for Global Constraint, locate the Global Constraint section.

3 In the Constraint expression text field, type 
comp1.solid.rig2.b-comp1.solid.rig3.b.

Global Constraint 2
1 On the Physics toolbar, click Global and choose Global Constraint.

2 In the Settings window for Global Constraint, locate the Global Constraint section.

3 In the Constraint expression text field, type 
comp1.solid.rig2.d-comp1.solid.rig3.d.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Tetrahedral.

Free Tetrahedral 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Tetrahedral 1 and choose Size.
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Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 Select Boundaries 41, 42, and 53 only.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 0.002.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Fine.

4 Click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Stress (solid)
The default plot shows the von Mises stress distribution on the surface of the assembly. 
Compare with Figure 2.

Finally, reproduce the x-displacement plot shown in Figure 3 with the following steps:

1 In the Model Builder window, under Results right-click Stress (solid) and choose 
Duplicate.

Surface 1
1 In the Model Builder window, expand the Stress (solid) 1 node, then click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>

Displacement>Displacement field (Material)>u - Displacement field, X component.

3 On the Stress (solid) 1 toolbar, click Plot.

Stress (solid) 1
1 In the Model Builder window, under Results click Stress (solid) 1.

2 In the Settings window for 3D Plot Group, type x-Displacement in the Label text field.
9 |  A S S E M B L Y  W I T H  A  H I N G E



10 |  A S S E M B L Y  W I T H  A  H I N G E



Created in COMSOL Multiphysics 5.2a
V i b r a t i o n s  o f  an Impe l l e r
This model is licensed under the COMSOL Software License Agreement 5.2a.
All trademarks are the property of their respective owners. See www.comsol.com/trademarks.

http://www.comsol.com/sla
http://www.comsol.com/trademarks/


Introduction

This tutorial model demonstrates the use of dynamic cyclic symmetry with postprocessing 
on the full geometry. A 3D impeller with eight identical blades can be divided into eight 
sectors of symmetry. The model computes the fundamental frequencies for the full 
impeller geometry and compares them to the values computed for a single sector with the 
cyclic symmetry boundary conditions applied on two sector boundaries. It also 
demonstrates how to set up a frequency response analysis for one sector of symmetry, and 
how to postprocess the results into the full geometry by using the sector data sets. The 
results for one sector are in very good agreement with the computations on the full 
geometry, while both the computational time and memory requirements are significantly 
reduced.

Model Definition

Figure 1 shows the impeller geometry. The problem is solved using the Cartesian 
coordinate system in 3D.

Figure 1: Impeller geometry.
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The geometry can be divided into eight identical parts, each represented by a sector with 
an angle θ = π/4 with respect to rotation around the z-axis; see Figure 2. 

Figure 2: Sector of periodicity.

The impeller is made of aluminum, and is supposed to be mounted on a shaft. The 
mounting boundary is modeled via a fixed constraint, and all possible effects of the shaft 
rotation are neglected.

The analysis is based on the Floquet theory which can be applied to the problem of 
small-amplitude vibrations of spatially periodic structures, Ref. 1. This includes the case of 
cyclic symmetry studied in this example.

For an eigenfrequency study, one can show that all the eigenmodes of the full problem can 
be found by performing the analysis on one sector of symmetry only and imposing the 
cyclic symmetry of the eigenmodes with an angle of periodicity , where the cyclic 
symmetry mode number m can vary from 0 to N/2, with N being the total number of 
sectors so that θ = 2π/N.

Results and Discussion

In the first part of the analysis, you perform an eigenfrequency analysis of a single sector 
of periodicity, and then of the full geometry. A sweep over all required values of the cyclic 
symmetry parameter recovers all the eigenfrequencies of the full model with decent 

ϕ mθ=
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accuracy. See the Modeling Instructions section for in-detail comparison of the results and 
discussion of the performance gains.

In the second part, you perform a frequency-response analysis. Again, first of the sector of 
periodicity, and then of the full impeller geometry. The excitation is a pressure load applied 
to all free boundaries of the impeller. You enter it as a normal component of the boundary 
load using the expression

using the magnitude of p0 = 104 Pa and cyclic symmetry parameter m = 3. The excitation 
frequency is 200 Hz. Figure 3 and Figure 4 show very good agreement between the 
results computed on the full and reduced geometry.

Fn p0 jm Y X⁄( )atan–[ ]exp–=
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Figure 3: Frequency response computed on the sector of periodicity only, and then visualized 
over the full geometry.

Figure 4: Frequency response computed for the full geometry.
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Notes About the COMSOL Implementation

M E S H I N G

You use an unstructured mesh with the same size of the mesh elements for both 
calculations on one sector of symmetry and on the full geometry, see Figure 5. This helps 
to compare the results for this tutorial model. In practice, the mesh used for computations 
on the sector could be much finer, so that the results obtained via such geometry reduction 
would provide significantly better resolution of the results under the same memory 
requirements as for the full geometry (with a coarser mesh).

Figure 5: Meshed geometry.

C Y C L I C  S Y M M E T RY  C O N D I T I O N S  A N D  PO S T P R O C E S S I N G

To set up the cyclic symmetry conditions, you use the predefined functionality available in 
COMSOL Multiphysics within the Solid Mechanics interface under the Periodic 
Condition boundary feature. This imposes the proper boundary coupling condition on 
the sector boundaries.

You visualize the results computed for one sector over the full geometry by making use of 
the predefined type of derived dataset called Sector 3D, which is available under the 
Results in COMSOL Multiphysics. 
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Reference

1. B. Lalanne and M. Touratier, “Aeroelastic Vibrations and Stability in Cyclic Symmetric 
Domains,” Int. J. Rotating Machinery, vol. 6, no. 6, pp 445–452, 2000.

Application Library path: Structural_Mechanics_Module/
Dynamics_and_Vibration/impeller

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Eigenfrequency.

6 Click Done.

G E O M E T R Y  1

Import the pre-built geometry for the impeller from a file.

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
impeller.mphbin.

5 Click Import.

6 Click the Go to Default 3D View button on the Graphics toolbar.

7 On the Home toolbar, click Build All.
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8 Click the Go to Default 3D View button on the Graphics toolbar.

9 Click the Go to XY View button on the Graphics toolbar.

The complete geometry should look similar to that shown in Figure 1 and Figure 2.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

C O M P O N E N T  1  ( C O M P 1 )

Add a second Solid Mechanics interface to use for the computations on the reduced 
geometry only.

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Structural Mechanics>Solid Mechanics (solid).

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Physics to close the Add Physics window.

S O L I D  M E C H A N I C S  2  ( S O L I D 2 )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics 2 (solid2).

2 Select Domain 8 only.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Aluminum.

Name Expression Value Description

N 8 8 Number of sectors

theta 2*pi/N 0.7854 Unit sector angle

m 3 3 Azimuthal mode number

p0 1e4[Pa] 1E4 Pa Load magnitude
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4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

S O L I D  M E C H A N I C S  ( S O L I D )

In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundaries 54, 55, 67, 68, 85, 87, 109, and 113 only.

S O L I D  M E C H A N I C S  2  ( S O L I D 2 )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics 2 (solid2).

2 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

3 Select Boundary 113 only.

For a reduced geometry, you set up the Cyclic symmetry condition on the sector 
boundaries.

Periodic Condition 1
1 On the Physics toolbar, click Boundaries and choose Periodic Condition.

2 Select Boundaries 112 and 134 only.

3 In the Settings window for Periodic Condition, locate the Periodicity Settings section.

4 From the Type of periodicity list, choose Cyclic symmetry.

5 In the m text field, type m.

Destination Selection 1
1 Right-click Periodic Condition 1 and choose Destination Selection.

2 In the Settings window for Destination Selection, locate the Boundary Selection section.

3 Click Clear Selection.

4 Select Boundary 112 only.

Follow these steps to create a free unstructured mesh that will be identical in all eight 
sectors.

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Fine.
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Free Triangular 1
1 Right-click Component 1 (comp1)>Mesh 1 and choose More Operations>Free Triangular.

2 Select Boundary 134 only.

Copy Face 1
1 In the Model Builder window, right-click Mesh 1 and choose More Operations>Copy Face.

2 Select Boundary 134 only.

3 In the Settings window for Copy Face, locate the Destination Boundaries section.

4 Select the Active toggle button.

5 Select Boundary 112 only.

Free Tetrahedral 1
1 Right-click Mesh 1 and choose Free Tetrahedral.

2 In the Settings window for Free Tetrahedral, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domain 8 only.

5 Click Build Selected.

Copy Domain 1
1 Right-click Mesh 1 and choose More Operations>Copy Domain.

2 Select Domain 8 only.

3 In the Settings window for Copy Domain, locate the Destination Domains section.

4 Select the Active toggle button.

5 Select Domains 1–5 only.

6 Click Build Selected.

Copy Domain 2
1 Right-click Mesh 1 and choose More Operations>Copy Domain.

2 Select Domain 1 only.

3 In the Settings window for Copy Domain, locate the Destination Domains section.

4 Select the Active toggle button.

5 Select Domains 6 and 7 only.

6 In the Model Builder window, click Mesh 1.

7 In the Settings window for Mesh, click Build All.
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8 Click the Go to Default 3D View button on the Graphics toolbar.

The resulting mesh should look similar to that shown in Figure 5.

S T U D Y  1

Step 1: Eigenfrequency
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Physics and Variables Selection 
section.

3 In the table, clear the Solve for check box for the Solid Mechanics 2 interface.

4 Locate the Study Settings section. Select the Desired number of eigenfrequencies check 
box.

5 In the associated text field, type 32.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Dependent Variables 1 node, then click Displacement field (Material) (comp1.u2).

4 In the Settings window for Field, locate the General section.

5 Clear the Store in output check box.

6 On the Study toolbar, click Compute.

A D D  S T U D Y

1 On the Study toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Eigenfrequency.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Solid Mechanics (solid) interface.

5 Click Add Study in the window toolbar.

6 On the Study toolbar, click Add Study to close the Add Study window.

S T U D Y  2

Step 1: Eigenfrequency
1 In the Model Builder window, under Study 2 click Step 1: Eigenfrequency.
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2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 Select the Desired number of eigenfrequencies check box.

4 In the associated text field, type 4.

To capture all possible eigenfrequencies, set up a sweep over the cyclic symmetry mode 
number m in the range from 0 to N/2, where N is the total number of sectors

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

5 Click Range.

6 In the Range dialog box, type 0 in the Start text field.

7 In the Stop text field, type N/2.

8 In the Step text field, type 1.

9 Click Add.

Solution 2 (sol2)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 2 (sol2) node.

3 In the Model Builder window, expand the Study 2>Solver Configurations>Solution 2 

(sol2)>Dependent Variables 1 node, then click Displacement field (Material) (comp1.u).

4 In the Settings window for Field, locate the General section.

5 Clear the Store in output check box.

6 On the Study toolbar, click Compute.

R E S U L T S

Mode Shape (solid2)
Note a nearly eight times reduction in the number of degrees of freedom, and thus of the 
memory required to compute the reduced model.

Parameter name Parameter value list Parameter unit

m
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However, the computational time is approximately the same because you need to perform 
a sweep over all values of the periodicity parameter.

Add a new dataset to visualize over the full geometry the eigenmode shape for the reduced 
model.

Sector 3D 1
1 On the Results toolbar, click More Data Sets and choose Sector 3D.

2 In the Settings window for Sector 3D, locate the Data section.

3 From the Data set list, choose Study 2/Parametric Solutions 1 (sol3).

4 Locate the Symmetry section. In the Number of sectors text field, type 8.

5 Click to expand the Advanced section. In the Azimuthal mode number text field, type 4.

Mode Shape (solid2)
1 In the Model Builder window, under Results click Mode Shape (solid2).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Data set list, choose Sector 3D 1.

4 On the Mode Shape (solid2) toolbar, click Plot.

Derived Values
Collect all the computed eigenfrequencies into tables.

Global Evaluation 1
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Expressions section.

3 In the table, enter the following settings:

4 Click New Table.

TA B L E

1 Go to the Table window.

Note that the eigenfrequencies for the full geometry present groups of values very close 
to each other, eight frequencies in each group. This shows that vibrations of each of the 
eight blades of the impeller are only weakly coupled to the remaining structure, which 
is because the central part has significantly larger effective bending stiffness compared 

Expression Unit Description

freq 1/s Frequency
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to that of each blade. Hence, the eigenfrequencies in each group are close to the natural 
frequencies of a single blade (if computed assuming a fully fixed footing).

R E S U L T S

Global Evaluation 2
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Data section.

3 From the Data set list, choose Study 2/Parametric Solutions 1 (sol3).

4 From the Table columns list, choose Inner solutions.

5 Locate the Expressions section. In the table, enter the following settings:

6 Click New Table.

TA B L E

1 Go to the Table window.

Compare the values of the egenfrequencies computed by using the periodicity 
conditions to those found for the full geometry.

Next, add a load representing a periodic pressure perturbation in the stream, and thus on 
all the external boundaries of the impeller.

S O L I D  M E C H A N I C S  ( S O L I D )

In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 In the Settings window for Boundary Load, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

4 Select Boundaries 1–3, 5–18, 20, 21, 23–53, 56–66, 69–75, 77–84, 88–107, 110, 111, 
114–133, and 135–152 only.

You can do this by selecting all boundaries first, and then removing from the selection 
all the constraint boundaries and all the internal boundaries of the periodicity sectors.

5 Locate the Coordinate System Selection section. From the Coordinate system list, choose 
Boundary System 1 (sys1).

Expression Unit Description

freq 1/s Frequency
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6 Locate the Force section. Specify the FA vector as

S O L I D  M E C H A N I C S  2  ( S O L I D 2 )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics 2 (solid2).

2 On the Physics toolbar, click Boundaries and choose Boundary Load.

3 Select Boundaries 114, 115, 119, 123, 125, 130, 131, 133, 136, 137, 142–146, 150, 
and 151 only.

4 In the Settings window for Boundary Load, locate the Coordinate System Selection 
section.

5 From the Coordinate system list, choose Boundary System 1 (sys1).

6 Locate the Force section. Specify the FA vector as

R O O T

Set up and perform the frequency-response analysis, first for the full model, and then for 
a sector of periodicity.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Frequency 

Domain.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Solid Mechanics 2 (solid2) interface.

5 Click Add Study in the window toolbar.

6 On the Home toolbar, click Add Study to close the Add Study window.

0 t1

0 t2

-p0*exp(-j*m*atan2(Y,X)) n

0 t1

0 t2

-p0*exp(-j*m*atan2(Y,X)) n
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S T U D Y  3

Step 1: Frequency Domain
1 In the Model Builder window, under Study 3 click Step 1: Frequency Domain.

2 In the Settings window for Frequency Domain, locate the Study Settings section.

3 In the Frequencies text field, type 200.

Switch off the generation of the default plot as that would be a plot of the von Mises 
stress, while you will be comparing the full and reduced structure responses in terms of 
displacements.

4 In the Model Builder window, click Study 3.

5 In the Settings window for Study, locate the Study Settings section.

6 Clear the Generate default plots check box.

Solution 9 (sol9)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 9 (sol9) node.

3 In the Model Builder window, expand the Study 3>Solver Configurations>Solution 9 

(sol9)>Dependent Variables 1 node, then click Displacement field (Material) (comp1.u2).

4 In the Settings window for Field, locate the General section.

5 Clear the Store in output check box.

6 On the Study toolbar, click Compute.

R E S U L T S

3D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Displacement (solid) in the Label 
text field.

3 Locate the Data section. From the Data set list, choose Study 3/Solution 9 (sol9).

4 Right-click Displacement (solid) and choose Surface.

Surface 1
In the Model Builder window, under Results>Displacement (solid) right-click Surface 1 and 
choose Deformation.

Deformation 1
1 In the Settings window for Deformation, locate the Scale section.
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2 Select the Scale factor check box.

3 In the associated text field, type 25.

4 On the Displacement (solid) toolbar, click Plot.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Frequency 

Domain.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Solid Mechanics (solid) interface.

5 Click Add Study in the window toolbar.

6 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  4

Step 1: Frequency Domain
1 In the Model Builder window, under Study 4 click Step 1: Frequency Domain.

2 In the Settings window for Frequency Domain, locate the Study Settings section.

3 In the Frequencies text field, type 200.

4 In the Model Builder window, click Study 4.

5 In the Settings window for Study, locate the Study Settings section.

6 Clear the Generate default plots check box.

Solution 10 (sol10)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 10 (sol10) node.

3 In the Model Builder window, expand the Study 4>Solver Configurations>Solution 10 

(sol10)>Dependent Variables 1 node, then click Displacement field (Material) (comp1.u).

4 In the Settings window for Field, locate the General section.

5 Clear the Store in output check box.

6 On the Study toolbar, click Compute.

For a frequency-response analysis, use of the reduced geometry gives significant gains 
in both the memory required and computational time needed.
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R E S U L T S

Set up a displacement plot for the reduced geometry and compare it to that for the full 
geometry.

Sector 3D 2
1 On the Results toolbar, click More Data Sets and choose Sector 3D.

2 In the Settings window for Sector 3D, locate the Data section.

3 From the Data set list, choose Study 4/Solution 10 (sol10).

4 Locate the Symmetry section. In the Number of sectors text field, type 8.

5 Locate the Advanced section. In the Azimuthal mode number text field, type 3.

3D Plot Group 4
1 On the Results toolbar, click 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Displacement (solid2) in the Label 
text field.

3 Locate the Data section. From the Data set list, choose Sector 3D 2.

Surface 1
1 Right-click Displacement (solid2) and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type solid2.disp.

Deformation 1
1 Right-click Results>Displacement (solid2)>Surface 1 and choose Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 Select the Scale factor check box.

4 In the associated text field, type 25.

5 Locate the Expression section. In the X component text field, type u2.

6 In the Y component text field, type v2.

7 In the Z component text field, type w2.

8 On the Displacement (solid2) toolbar, click Plot.
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Introduction

This example contains an analysis of the thermal stress in a layered plate. The plate consists 
of three layers: the coating, the substrate, and the carrier. The coating is deposited on the 
substrate at a temperature of 800 °C. At this temperature both the coating and the 
substrate are stress-free. The temperature of the plate is then lowered to 150 °C, which 
induces thermal stresses in the coating/substrate assembly. At this temperature the 
coating/substrate assembly is epoxied to a carrier plate so that the coating/substrate has 
initial stresses when it is bonded to the carrier. Finally, the temperature is lowered to 20 °C.

Model Definition

The plate is restrained from moving in the z direction. This makes it possible to use the 
plane strain approximation in the 2D Solid Mechanics interface with. The assumption is 
then that the z-component of the strain is zero.

This model contains only thermal loads, which are introduced into the constitutive 
equations according to the following equations:

and

where σ is the stress vector, D is the elasticity matrix, εx, εy, εz, γxy, γyz, γxz are the strain 
components, αvec is the coefficient of thermal expansion, T is the actual temperature, and 
Tref is the reference temperature. 

σ Dεel σ0+ D ε εth– ε0–( ) σ0+= =

εth

εx

εy

εz

γxy

γyz

γxz th

αvec T Tref–( )= =
2 |  T H E R M A L  S T R E S S E S  I N  A  L A Y E R E D  P L A T E



The geometry of the plate is shown in Figure 1. The top layer in the geometry is the 
coating, the middle layer is the substrate, and the bottom layer is the carrier.

Figure 1: The plate geometry.

The analysis uses two steps:

S T E P  1

In the first step you lower the temperature from 800 °C to 150 °C, which affects the 
coating layer and the substrate layer. The carrier layer is not active in this step.

In both steps the upper-left corner of the coating is fixed, and the upper-right corner of 
the coating is constrained in the y direction. This prevents rigid-body movements but does 
not affect the stress distribution.

S T E P  2

In this step all three layers are active and you drop the temperature from 150 °C to room 
temperature, 20 °C. This step includes the initial stresses from Step 1.
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Results and Discussion

Figure 2 depicts the normal stress in the x direction from the first analysis step. The 
substrate material has a higher coefficient of thermal expansion than the coating material. 
This means that the substrate shrinks more than the coating, causing tensile stresses in the 
substrate area next to the coating and compressive stresses in the coating.

Figure 2: Normal stress in the x direction for the first analysis step.

Figure 3 shows the residual thermal x-stress in the final step where the temperature is 
lowered to 20 °C. The tensile stress levels have increased somewhat in the substrate area 
next to the coating, as have the compressive stress in the coating compared to the first 
process step. The main stress contribution is clearly the added initial stress from the first 
process step.
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Figure 3: Residual thermal stress at room temperature.

Application Library path: Structural_Mechanics_Module/
Thermal-Structure_Interaction/layered_plate

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

Add two different solid interfaces, one for the structure before adding the carrier, and 
one for the complete structure.
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3 Click Add.

4 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

5 Click Add.

6 Click Study.

7 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

8 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Height text field, type 0.002.

4 In the Width text field, type 0.02.

5 Click Build All Objects.

Rectangle 2 (r2)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.02.

4 In the Height text field, type 0.01.

5 Locate the Position section. In the y text field, type 0.002.

Name Expression Value Description

Ttop 800[degC] 1073 K Coating deposition temperature

Tbot 150[degC] 423.2 K Temperature when the coating/
substrate is epoxied to the 
carrier

Troom 20[degC] 293.2 K Room temperature
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6 Click Build All Objects.

Rectangle 3 (r3)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.02.

4 In the Height text field, type 0.002.

5 Locate the Position section. In the y text field, type 0.012.

6 Click Build All Objects.

7 Click the Zoom Extents button on the Graphics toolbar.

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, type Two Layers in the Label text field.

3 Select Domains 2 and 3 only.

TW O  L A Y E R S  ( S O L I D )

On the Physics toolbar, click Solid Mechanics (solid) and choose Two Layers (solid).

Linear Elastic Material 1
In the Model Builder window, expand the Component 1 (comp1)>Two Layers (solid) node, 
then click Linear Elastic Material 1.

Thermal Expansion 1
1 On the Physics toolbar, click Attributes and choose Thermal Expansion.

2 In the Settings window for Thermal Expansion, locate the Thermal Expansion Properties 
section.

3 In the Tref text field, type Ttop.

4 Locate the Model Inputs section. In the T text field, type Tbot.

Fixed Constraint 1
1 On the Physics toolbar, click Points and choose Fixed Constraint.

2 Select Point 4 only.

Prescribed Displacement 1
1 On the Physics toolbar, click Points and choose Prescribed Displacement.

2 Select Point 8 only.
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3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in y direction check box.

S O L I D  M E C H A N I C S  2  ( S O L I D 2 )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics 2 (solid2).

2 In the Settings window for Solid Mechanics, type Three Layers in the Label text field.

T H R E E  L A Y E R S  ( S O L I D 2 )

On the Physics toolbar, click Solid Mechanics 2 (solid2) and choose Three Layers (solid2).

Linear Elastic Material 1
In the Model Builder window, under Component 1 (comp1)>Three Layers (solid2) click Linear 

Elastic Material 1.

Thermal Expansion 1
1 On the Physics toolbar, click Attributes and choose Thermal Expansion.

2 In the Settings window for Thermal Expansion, locate the Thermal Expansion Properties 
section.

3 In the Tref text field, type Tbot.

4 Locate the Model Inputs section. In the T text field, type Troom.

Fixed Constraint 1
1 On the Physics toolbar, click Points and choose Fixed Constraint.

2 Select Point 4 only.

Prescribed Displacement 1
1 On the Physics toolbar, click Points and choose Prescribed Displacement.

2 Select Point 8 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in y direction check box.

Linear Elastic Material 1
Use the stresses from the two layer model as initial stresses for the three layer model.

1 In the Model Builder window, under Component 1 (comp1)>Three Layers (solid2) click 
Linear Elastic Material 1.
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Initial Stress and Strain 1
1 On the Physics toolbar, click Attributes and choose Initial Stress and Strain.

2 Select Domains 2 and 3 only.

3 In the Settings window for Initial Stress and Strain, locate the Initial Stress and Strain 
section.

4 In the S0 table, enter the following settings:

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, type Carrier in the Label text field.

2 Locate the Geometric Entity Selection section. From the Selection list, choose Manual.

3 Click Clear Selection.

4 Select Domain 1 only.

5 Locate the Material Contents section. In the table, enter the following settings:

Material 2 (mat2)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Substrate in the Label text field.

3 Select Domain 2 only.

solid.sx solid.sxy 0

solid.sxy solid.sy 0

0 0 solid.sz

Property Name Value Unit Property 
group

Young’s modulus E 2.15e11 Pa Basic

Poisson’s ratio nu 0.3 1 Basic

Density rho 1000 kg/m³ Basic

Coefficient of thermal expansion alpha 6e-6 1/K Basic
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4 Locate the Material Contents section. In the table, enter the following settings:

Material 3 (mat3)
1 Right-click Materials and choose Blank Material.

2 In the Settings window for Material, type Coating in the Label text field.

3 Select Domain 3 only.

4 Locate the Material Contents section. In the table, enter the following settings:

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Mapped.

Size
1 In the Settings window for Size, locate the Element Size section.

2 From the Predefined list, choose Extra fine.

3 Click Build All.

S T U D Y  1

Add a static solution for the case with three layers.

Stationary 2
On the Study toolbar, click Study Steps and choose Stationary>Stationary.

Step 2: Stationary 2
Use only one Solid Mechanics interface per solution by deactivating the other one.

Property Name Value Unit Property 
group

Young’s modulus E 1.3e11 Pa Basic

Poisson’s ratio nu 0.28 1 Basic

Density rho 1000 kg/m³ Basic

Coefficient of thermal expansion alpha 3e-6 1/K Basic

Property Name Value Unit Property 
group

Young’s modulus E 7e10 Pa Basic

Poisson’s ratio nu 0.17 1 Basic

Density rho 1000 kg/m³ Basic

Coefficient of thermal expansion alpha 5e-7 1/K Basic
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Step 1: Stationary
1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 In the table, clear the Solve for check box for Three Layers.

Step 2: Stationary 2
1 In the Model Builder window, under Study 1 click Step 2: Stationary 2.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 In the table, clear the Solve for check box for Two Layers.

4 On the Study toolbar, click Compute.

R E S U L T S

Surface 1
1 In the Model Builder window, expand the Stress (solid) node, then click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Two Layers>Stress>Stress 

tensor (Spatial)>solid.sx - Stress tensor, x component.

3 On the Stress (solid) toolbar, click Plot.

4 Click the Zoom Extents button on the Graphics toolbar.

Surface 1
1 In the Model Builder window, expand the Results>Stress (solid2) node, then click Surface 

1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Three Layers>Stress>Stress 

tensor (Spatial)>solid2.sx - Stress tensor, x component.

3 On the Stress (solid2) toolbar, click Plot.
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Introduction

Magnetostriction describes the change in dimensions of a material due to a change in its 
magnetization. This phenomenon is a manifestation of magnetoelastic coupling, which is 
exhibited by all magnetic materials to some extent. The effects related to magnetoelastic 
coupling are described by various names. The Joule effect describes the change in length 
due to a change in the magnetization state of the material. This magnetostrictive effect is 
used in transducers for applications in sonars, acoustic devices, active vibration control, 
position control, and fuel injection systems.

Magnetostriction has a quantum-mechanical origin. The magneto-mechanical coupling 
takes place at the atomic level due to spin-orbit coupling. From a system level, the material 
can be assumed to consist of a number of tiny ellipsoidal magnets which rotate due to the 
torque produced by the externally applied magnetic field. The rotation of these elemental 
magnets produces a dimensional change leading to free strain in the material. The strain 
(or magnetostriction) has a nonlinear dependence on the magnetic field and the 
mechanical stress in the material.

This tutorial demonstrates how to model the nonlinear response of a magnetostrictive 
material.
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Model Definition

A typical magnetostrictive transducer shown in Figure 1 has a steel housing enclosing a 
drive coil. A magnetostrictive material is placed in the core that works as an actuator when 
a magnetic field is applied by passing a current through the drive coil. 

Figure 1: Sectional view of a cylindrical transducer.

Due to the symmetric nature of the geometry, the problem is solved as a 2D axisymmetric 
model, which leads to reduced computation time. The corresponding 2D axisymmetric 

Steel housing

Drive coil

Magnetostrictive rod
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geometry is shown in Figure 2.

Figure 2: 2D axisymmetric view of a magnetostrictive transducer surrounded by an air 
domain. The geometric dimensions are in millimeters.

It is assumed that the current in the coil is DC, and hence it can be solved as a stationary 
problem. The first study performed considers a constant current density of 106 A/m2 in 
the coil. A second study is set up where the current density in the drive coil is varied from 
0 to 107 A/m2 using the parametric sweep feature in COMSOL. The solution from this 
parametric sweep is then used to generate the characteristic nonlinear magnetostriction (λ) 
vs. magnetic field (H) curve. The ramping of current density using the parametric sweep 
option is performed under the assumption that the current in the coil changes 
quasi-statically without producing any inductive effect.

N O T E S  O N  T H E  M A G N E T I C  A N D  M A G N E T O E L A S T I C  P R O B L E M S

An air domain is created around the transducer to realistically model the magnetic flux 
path. The boundaries of this air domain are magnetically insulated which ensures that flux 
does not diverge out of the modeling domain. An alternate technique of implementing 
this air domain in COMSOL involves the use of Infinite Elements. For more information 
on Infinite Elements, please refer to the AC/DC Module User’s Guide.

The drive coil is modeled as a homogenized current carrying domain. Individual wires and 
their electrical conductivity are not resolved. It is assumed that the externally applied 
current density in the coil is known a priori. In a 2D axisymmetric model, the external 
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current density is the total current through the coil divided by the longitudinal 
cross-section area (coil length times coil thickness). The coil can also be modeled 
alternately using the Multiturn Coil Domain feature available in the AC/DC Module. 
Please refer to the AC/DC Module User’s Guide for more details on using this alternative 
technique.

Traditionally, the magnetic flux density (also called the B-field) is obtained as a function 
of the applied magnetic field (the H-field). Such relationship is usually called a BH curve. 
However, in COMSOL you need to specify the other way round while working with the 
built-in Magnetic Fields interface. The reason why you need an HB curve rather than a BH 
curve is that the formulation of the magnetic problem in COMSOL Multiphysics solves 
for the magnetic vector potential A whose curl yields the vector B-field. The H-field is 
then obtained as a function of the B-field. In order to avoid circular dependency, it is 
necessary to specify the H-field in terms of the B-field.

The steel housing used in this example is designed to create a closed magnetic flux path 
thereby minimizing flux leakage. The nonlinear magnetic behavior of the steel housing is 
modeled by using an HB curve to specify the magnetic constitutive relation in the steel 
housing. The nonlinear HB curve is obtained by choosing the material Soft iron without 
losses from AC/DC materials in COMSOL’s Material Library. Incorporation of a 
nonlinear HB curve helps in modeling magnetic saturation effects at sufficiently high 
magnetic field. Furthermore, you can examine the results of the model to find out specific 
locations in a material where magnetic saturation has taken place whereas other regions of 
that material have remained unsaturated. 

The stress in the magnetostrictive material is modeled as

The material is assumed to be isotropic, so that the stiffness matrix  can be represented 
in terms of two parameters, the Young’s modulus and Poisson’s ration.

The magnetostrictive strain is modeled as the following quadratic isotropic function of the 
magnetization field M:

where the tensor product of two vectors is defined as

S CH εel εme M( )–[ ]=

CH

εme
3
2
---

λs

Ms
2

--------dev M M⊗( )=

M M⊗( )ij MiMj=
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and  is the saturation magnetostriction, which is the maximum magnetostrictive strain 
reached at the saturation magnetization Ms.

Note that the magnetostrictive strain is represented by a deviatoric tensor. This is because 
the deformation can be related to the magnetic domain rotation associated with the 
magnetization of the material; such process should not change the material volume.

Nonlinear magnetization in the magnetostrictive material is found from the following 
nonlinear relation:

where L is the Langevin function

with  being the magnetic susceptibility in the initial linear region, and the effective 
magnetic field in the material is given by

The second term in the above relation represents the mechanical stress contribution to the 
effective field, and thus to the material magnetization, which is called the Villari effect. 
The deviatoric elastic stress tensor is related to the elastic strain  in the material as

In addition, the magnetization and magnetic field are related to each other and to the 
B-field by

The material properties used to describe the magnetostrictive material are shown in .

TABLE 1:  MATERIAL PROPERTIES OF THE MAGNETOSTRICTIVE MATERIAL

MATERIAL PROPERTY VALUE DESCRIPTION

E 60 x 109 Pa Young’s modulus

ν 0.45 Poisson’s ratio

ρ 7870 kg/m3 Density

λs

M MsL Heff( )
Heff
Heff
--------------=

L
3χm Heff

Ms
-------------------------- 
 coth

Ms

3χm Heff
--------------------------–=

χm

Heff H
3λs

μ0Ms
2

---------------SedM+=

εel

Sed dev CHεel( )=

B μ0 H M+( )=
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C O U P L I N G  T H E  M A G N E T I C  A N D  S T R U C T U R A L  P R O B L E M S

The implementation is straightforwards as you make use of a predefined multiphysics 
coupling interface available in COMSOL and called Magnetostriction. 

Selecting such interface in the model wizard will add Structural Mechanics and Magnetic 

Fields interfaces together with the corresponding multiphysics coupling feature 
Magnetostriction.

Most of the settings you need to access in order to configure the coupling can be found 
under the Magnetostrictive Material feature added under the Structural Mechanics interface. 

Results and Discussion

The results obtained from the first study, where a constant external current density of 
106 A/m2 is applied to the coil. Figure 3 shows the von Mises stress in the 
magnetostrictive material as a surface plot. This plot indicates that the stress due to 
magnetostriction is uniformly zero everywhere except the region near the bottom surface 
of the rod due to the fixed constraint boundary condition that was applied to this end of 
the rod. This is because the free strain due to magnetostriction should not produce any 
stress unless the material is mechanically constrained. Figure 4 shows that the 

σ 5.96 x 106 S/m Electric conductivity

εr 1 Relative permittivity

λs 2 x 10-4 Saturation magnetostriction

Ms 1.5 x 106 A/m Saturation magnetization

TABLE 1:  MATERIAL PROPERTIES OF THE MAGNETOSTRICTIVE MATERIAL

MATERIAL PROPERTY VALUE DESCRIPTION
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corresponding strain field caused by the magnetostriction is also fairly uniform in the 
material except at the fixed end of the rod.

Figure 3: Surface plot of the von Mises stress and a scaled deformation plot of the displacement.

Figure 4: Surface plot of the axial strain component.
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Figure 5 shows the magnetic the flux concentration in the magnetostrictive core due to 
the closed magnetic path provided by the steel housing. The magnetic flux density in the 
rod is mostly uniform. Fringe effects can be seen at both ends of the rod where majority 
of the magnetic flux is forced to curl into the steel housing.

Figure 5: Surface plot of the norm of the magnetic flux density and a normalized arrow plot 
of its r and z-components showing the closed flux path in the model.

Figure 6 shows an interesting postprocessing feature in COMSOL. The solution obtained 
from the 2D axisymmetric model has been revolved by 225 degrees for 3D visualization 
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of the solution. On solving a 2D axisymmetry model, COMSOL automatically creates a 
3D solution data set by revolving the solution which is then plotted as a 3D plot.

Figure 6: A 225 degree sectional view in 3D of the norm of the magnetic flux density in the 
magnetostrictive rod, steel housing and in the region within the housing. The solution in the 
outer air domain has been suppressed to get a better view. The normalized arrow plot shows the 
direction of the magnetic flux density.

Figure 7 shows the magnetostriction curve of the material obtained from the parametric 
study that simulated a quasi-static ramping up of the current density in the coil. The 
corresponding BH curve is shown in Figure 8. Because the magnetic field is oriented 
mostly along the axial direction, only the Z-components of the corresponding vectors are 
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plotted. Note the significantly nonlinear behavior in the region where the magnetic field 
Hz varies between 5 to 20 kA/m. 

Figure 7: Magnetostriction versus magnetic field (at a point on the magnetostrictive material.

Figure 8: Magnetic flux density versus magnetic field at a point on the magnetostrictive 
material.
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Reference

1. S. Chikazumi, Physics of Ferromagnetism, Oxford University Press, New York, 1997.

Application Library path: Structural_Mechanics_Module/
Magnetostrictive_Devices/nonlinear_magnetostriction

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Structural Mechanics>Magnetostriction.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 3.

4 In the Height text field, type 50.

5 Locate the Position section. In the z text field, type -25.
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Copy 1 (copy1)
1 Right-click Rectangle 1 (r1) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Copy.

3 Select the object r1 only.

4 In the Settings window for Copy, locate the Displacement section.

5 In the r text field, type 7.5.

Rectangle 2 (r2)
1 Right-click Copy 1 (copy1) and choose Build Selected.

2 On the Geometry toolbar, click Primitives and choose Rectangle.

3 In the Settings window for Rectangle, locate the Size and Shape section.

4 In the Width text field, type 20.

5 In the Height text field, type 5.

6 Locate the Position section. In the z text field, type -30.

Copy 2 (copy2)
1 Right-click Rectangle 2 (r2) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Copy.

3 Select the object r2 only.

4 In the Settings window for Copy, locate the Displacement section.

5 In the z text field, type 55.

Rectangle 3 (r3)
1 Right-click Copy 2 (copy2) and choose Build Selected.

2 On the Geometry toolbar, click Primitives and choose Rectangle.

3 In the Settings window for Rectangle, locate the Size and Shape section.

4 In the Width text field, type 5.

5 In the Height text field, type 50.

6 Locate the Position section. In the r text field, type 15.

7 In the z text field, type -25.

Rectangle 4 (r4)
1 Right-click Rectangle 3 (r3) and choose Build Selected.

2 On the Geometry toolbar, click Primitives and choose Rectangle.

3 In the Settings window for Rectangle, locate the Size and Shape section.
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4 In the Width text field, type 90.

5 In the Height text field, type 180.

6 Locate the Position section. In the z text field, type -90.

7 Right-click Rectangle 4 (r4) and choose Build Selected.

8 Click the Zoom Extents button on the Graphics toolbar.

Union 1 (uni1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Union.

See the figure below for the objects that need to be selected in the next step.

2 Select the objects r3, r2, and copy2 only.

3 In the Settings window for Union, locate the Union section.

4 Clear the Keep interior boundaries check box.

Point 1 (pt1)
1 On the Geometry toolbar, click Primitives and choose Point.

2 Click Build All Objects.

3 Click the Zoom Extents button on the Graphics toolbar.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.
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2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the Domain Selection section.

3 Click Clear Selection.

4 Select Domain 3 only.

The solid mechanics equations will be solved only in the magnetostrictive material.

M A G N E T I C  F I E L D S  ( M F )

On the Physics toolbar, click Solid Mechanics (solid) and choose Magnetic Fields (mf).

In the Model Builder window, under Component 1 (comp1) click Magnetic Fields (mf).

Ampère’s Law 2
1 On the Physics toolbar, click Domains and choose Ampère’s Law.

2 Select Domain 2 only.

3 In the Settings window for Ampère’s Law, locate the Material Type section.

4 From the Material type list, choose Solid.

5 Locate the Magnetic Field section. From the Constitutive relation list, choose HB curve.

S O L I D  M E C H A N I C S  ( S O L I D )

Magnetostrictive Material 1
1 In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 

Magnetostrictive Material 1.

2 In the Settings window for Magnetostrictive Material, click to collapse the Model inputs 
section.

3 Locate the Magnetoelastic Properties section. From the Magnetostriction model list, 
choose Nonlinear isotropic.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

Name Expression Value Description

J0 1e6[A/m^2] 1E6 A/m² Current density
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2 Go to the Add Material window.

3 In the tree, select Built-In>Air.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Air (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Air (mat1).

2 Select Domains 1 and 4–6 only.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select AC/DC>Soft Iron (without losses).

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Soft Iron (without losses) (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Soft Iron 

(without losses) (mat2).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 Click Paste Selection.

4 In the Paste Selection dialog box, type 2 in the Selection text field.

5 Click OK.

6 On the Home toolbar, click Add Material to close the Add Material window.

Material 3 (mat3)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Magnetostrictive in the Label text field.

3 Select Domain 3 only.

4 Locate the Material Contents section. In the table, enter the following settings:

Property Name Value Unit Property group

Density rho 7870 kg/m³ Basic

Saturation 
magnetization

Ms 1.5e6 A/m Magnetostrictive
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M A G N E T I C  F I E L D S  ( M F )

In the Model Builder window, under Component 1 (comp1) click Magnetic Fields (mf).

External Current Density 1
1 On the Physics toolbar, click Domains and choose External Current Density.

2 Select Domain 5 only.

3 In the Settings window for External Current Density, locate the External Current Density 
section.

4 Specify the Je vector as

Ampère’s Law, Magnetostrictive 1
1 In the Model Builder window, under Component 1 (comp1)>Magnetic Fields (mf) click 

Ampère’s Law, Magnetostrictive 1.

2 In the Settings window for Ampère’s Law, Magnetostrictive, locate the Domain Selection 
section.

3 From the Selection list, choose Manual.

4 Click Clear Selection.

5 Select Domain 3 only.

S O L I D  M E C H A N I C S  ( S O L I D )

On the Physics toolbar, click Magnetic Fields (mf) and choose Solid Mechanics (solid).

In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

Initial magnetic 
susceptibility

chi 200 1 Magnetostrictive

Saturation 
magnetostriction

lambdas 2e-4 1 Magnetostrictive

Young’s modulus E 60e9 Pa Basic

Poisson’s ratio nu 0.45 1 Basic

Electrical conductivity sigma 5.96e6 S/m Basic

Relative permittivity epsilonr 1 1 Basic

0 r

J0 phi

0 z

Property Name Value Unit Property group
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Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundary 6 only.

This boundary condition simulates that the lower surface of the magnetostrictive rod is 
fixed to the base of the transducer housing.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Quad.

Free Quad 1
1 In the Settings window for Free Quad, locate the Domain Selection section.

2 From the Geometric entity level list, choose Domain.

3 Select Domains 2 and 3 only.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Quad 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. Select the Maximum element size check box.

5 In the associated text field, type 0.75.

6 In the Model Builder window, right-click Mesh 1 and choose Free Triangular.

Free Triangular 1
In the Settings window for Free Triangular, click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

D E F I N I T I O N S

View 1
In the Model Builder window, expand the Component 1 (comp1)>Definitions node.

Axis
1 In the Model Builder window, expand the View 1 node, then click Axis.

2 In the Settings window for Axis, locate the Axis section.

3 In the r maximum text field, type 60.
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4 In the r minimum text field, type -52.

5 In the z minimum text field, type -45.

6 In the z maximum text field, type 45.

7 Click Update.

R E S U L T S

Stress (solid)
The first default plot shows the von Mises stress in the magnetostrictive core along with a 
scaled deformation plot, which should be similar to that shown in Figure 3.

Follow the steps outlined below to create Figure 4.

2D Plot Group 5
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, type Strain (solid) in the Label text field.

Surface 1
1 Right-click Strain (solid) and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>Strain>

Strain tensor (Material)>solid.eZZ - Strain tensor, ZZ component.

3 On the Strain (solid) toolbar, click Plot.

Compare the resulting plot with that in Figure 4.

Follow the steps outlined below to create Figure 5.

Magnetic Flux Density Norm (mf)
In the Model Builder window, under Results right-click Magnetic Flux Density Norm (mf) and 
choose Arrow Surface.

Arrow Surface 1
1 In the Settings window for Arrow Surface, locate the Expression section.

2 In the R component text field, type mf.Br.

3 In the Z component text field, type mf.Bz.

4 Locate the Arrow Positioning section. Find the R grid points subsection. In the Points text 
field, type 20.

5 Locate the Coloring and Style section. From the Arrow length list, choose Normalized.

6 From the Color list, choose White.
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7 On the Magnetic Flux Density Norm (mf) toolbar, click Plot.

Compare the resulting plot with that in Figure 5.

Follow the steps outlined below to create Figure 6.

Surface 1
1 In the Model Builder window, expand the Magnetic Flux Density Norm, Revolved Geometry 

(mf) node.

2 Right-click Surface 1 and choose Delete.

Click Yes to confirm.

Magnetic Flux Density Norm, Revolved Geometry (mf)
In the Model Builder window, under Results right-click Magnetic Flux Density Norm, Revolved 

Geometry (mf) and choose Volume.

Volume 1
1 In the Model Builder window, click Volume 1.

2 In the Settings window for Volume, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Magnetic Fields>Magnetic>

mf.normB - Magnetic flux density norm.

Filter 1
1 Right-click Volume 1 and choose Filter.

2 In the Settings window for Filter, locate the Element Selection section.

3 In the Logical expression for inclusion text field, type dom!=1.

This excludes the outer air domain from the plot.

Magnetic Flux Density Norm, Revolved Geometry (mf)
In the Model Builder window, under Results right-click Magnetic Flux Density Norm, Revolved 

Geometry (mf) and choose Arrow Volume.

Arrow Volume 1
1 In the Settings window for Arrow Volume, locate the Expression section.

2 In the X component text field, type mf.Br*cos(rev2phi)- mf.Bphi*sin(rev2phi).

3 In the Y component text field, type mf.Br*sin(rev2phi)+ mf.Bphi*cos(rev2phi).

4 In the Z component text field, type mf.Bz.

5 Locate the Arrow Positioning section. Find the X grid points subsection. From the Entry 

method list, choose Coordinates.

6 In the Coordinates text field, type range(-20,4,20).
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7 Find the Y grid points subsection. From the Entry method list, choose Coordinates.

8 In the Coordinates text field, type range(-20,4,20).

9 Find the Z grid points subsection. From the Entry method list, choose Coordinates.

10 In the Coordinates text field, type range(-30,2.5,30).

11 Locate the Coloring and Style section. From the Arrow length list, choose Normalized.

12 Select the Scale factor check box.

13 In the associated text field, type 5.

14 On the Magnetic Flux Density Norm, Revolved Geometry (mf) toolbar, click Plot.

15 Click the Zoom Extents button on the Graphics toolbar.

16 Click the Zoom In button on the Graphics toolbar.

17 Click the Zoom In button on the Graphics toolbar.

Next, perform a auxiliary continuation sweep on the external current density and plot the 
solution to view the saturation effect in the magnetostrictive core.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, locate the Study Settings section.

3 Clear the Generate default plots check box.

Step 1: Stationary
1 In the Model Builder window, under Study 2 click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study extensions section.

3 Locate the Study Extensions section. Select the Auxiliary sweep check box.

4 Click Add.
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5 In the table, enter the following settings:

6 Click Range.

7 In the Range dialog box, type 0 in the Start text field.

8 In the Step text field, type 0.1.

9 In the Stop text field, type 7.3.

10 From the Function to apply to all values list, choose exp10.

11 Click Add.

Running the entire parametric study based on the settings above will take few minutes. 
The exact solution time will vary depending on the specification of the computer being 
used.

12 On the Home toolbar, click Compute.

R E S U L T S

Follow the instructions below to create Figure 7 and Figure 8.

1D Plot Group 6
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Magnetostriction in the Label text 
field.

3 Locate the Data section. From the Data set list, choose Study 2/Solution 2 (sol2).

4 Click to expand the Title section. From the Title type list, choose Manual.

5 In the Title text area, type Magnetostriction curve.

6 Locate the Plot Settings section. Select the x-axis label check box.

7 In the associated text field, type Magnetic field (A/m).

8 Select the y-axis label check box.

9 In the associated text field, type Magnetostriction.

Point Graph 1
1 On the Magnetostriction toolbar, click Point Graph.

2 In the Settings window for Point Graph, locate the Selection section.

3 Click Paste Selection.

4 In the Paste Selection dialog box, type 4 in the Selection text field.

Parameter name Parameter value list Parameter unit

J0
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5 Click OK.

6 In the Settings window for Point Graph, click Replace Expression in the upper-right 
corner of the y-axis data section. From the menu, choose Component 1>Solid Mechanics>

Strain>Strain tensor (Material)>solid.eZZ - Strain tensor, ZZ component.

7 Locate the x-Axis Data section. From the Parameter list, choose Expression.

8 Click Replace Expression in the upper-right corner of the x-axis data section. From the 
menu, choose Component 1>Magnetic Fields>Magnetic>Magnetic field (Material)>mf.HZ - 

Magnetic field, Z component.

9 On the Magnetostriction toolbar, click Plot.

Magnetostriction
In the Model Builder window, under Results right-click Magnetostriction and choose 
Duplicate.

Magnetostriction 1
1 In the Settings window for 1D Plot Group, type BH curve in the Label text field.

2 Locate the Title section. In the Title text area, type BH curve.

3 Locate the Plot Settings section. In the y-axis label text field, type Magnetic flux 
density (T).

Point Graph 1
1 In the Model Builder window, expand the Results>BH curve node, then click Point Graph 

1.

2 In the Settings window for Point Graph, click Replace Expression in the upper-right 
corner of the y-axis data section. From the menu, choose Component 1>Magnetic Fields>

Magnetic>Magnetic flux density (Material)>mf.BZ - Magnetic flux density, Z component.

3 On the BH curve toolbar, click Plot.
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Introduction

In a peristaltic pump, rotating rollers squeeze a flexible tube. As the pushed-down rollers 
move along the tube, fluids in the tube follow the motion. The main advantage of the 
peristaltic pump is that no seals, valves, or other internal parts ever touch the fluid. Due to 
their cleanliness, peristaltic pumps have found many applications in the pharmaceutical, 
chemical, and food industries. Besides this, the action of a peristaltic pump is very gentle, 
which is important if the fluid can be easily damaged. Peristaltic pumps are therefore used 
in medical applications, one of which is to move the blood through the body during open 
heart surgery. Other types of pumps would risk destroying the blood cells.

In this COMSOL Multiphysics example, a peristaltic pump is analyzed by combining 
structural mechanics (to model the squeezing of the tube) and fluid dynamics (to compute 
the fluid’s motion). Thus, it is an example of a fluid-structure interaction (FSI) problem.

Model Definition

The analysis is set up in 2D axial symmetry (Figure 1). A nylon tube 0.1 m long has an 
inner radius of 1 cm and an outer radius of 1.5 cm; it contains fluid with the density 
ρ = 1·103 kg/m3 and viscosity μ = 5·10−3 Pa·s. A time- and position-dependent force 
density is applied to the outer wall of the tube, in the radial direction. This force density 
could have been taken from real data from a peristaltic pump operation. For the sake of 
simplicity, this example models it with a Gaussian distribution along the length of the tube. 
The Gaussian distribution has a width of 1 cm and is moving with the constant velocity 
0.03 m/s in the positive z direction. To represent the engagement of the roll, the force 
density, multiplied by a smoothed Heaviside function, kicks in at t = 0.1 s and takes the 
force to its full development at t = 0.5 s. Likewise, the disengagement of the roll starts at 
t = 1.0 s and ends at t = 1.4 s. The example models the tube’s deformation during a full 
cycle of 1.5 s.
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Figure 1: The geometry of the peristaltic pump as it is deforming under the pressure of the roll. 
The tube is rotationally symmetric with respect to the z-axis. The color shows the deformation 
of the tube material.

D O M A I N  E Q U A T I O N S

The structural mechanics computations use the assumption that the material is linear 
elastic, and they take geometric nonlinearities into account.

The fluid flow is described by the incompressible Navier-Stokes equations:

where ρ denotes the density (SI unit: kg/m3), u the velocity (SI unit: m/s), μ the viscosity 
(SI unit: Pa·s), and p the pressure (SI unit: Pa). The equations are set up and solved inside 
the tube.

The Navier-Stokes equations are solved on a freely moving deformed mesh, which 
constitutes the fluid domain. The deformation of this mesh relative to the initial shape of 
the domain is computed using Winslow smoothing. Inside the solid wall of the tube, the 
moving mesh follows the structural deformation. For more information, please refer to the 

z

ρ
t∂

∂u ρu ∇⋅ u+ ∇p– ∇ μ ∇u ∇u( )T
+( )⋅+=

∇ u⋅ 0=
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chapter The Fluid-Structure Interaction Interface in the Structural Mechanics Module 
User’s Guide.

B O U N D A R Y  C O N D I T I O N S

For the structural mechanics computations, the time- and coordinate-dependent load is 
prescribed as the boundary condition at the tube’s outer surface. This is the load that 
drives the pump operation. The top and bottom ends of the tube are constrained along 
both coordinate axes.

For the fluid simulation, the boundary condition at the inlet and the outlet assumes that 
the total stress is zero, that is:

The mesh is fixed to zero r displacement at the symmetry axis and zero z displacement at 
the top and the bottom of the tube.

At the fluid-solid boundary, the structural velocity is transmitted to the fluid. As a 
feedback, the stresses in the fluid flow act as a loading on the inner boundary of the solid 
wall of the tube.

C O M P U T A T I O N  O F  VO L U M E T R I C  F L O W  R A T E S  A N D  TO T A L  VO L U M E  O F  

P U M P E D  F L U I D

The model’s dependent variables are the displacements of the tube wall together with the 
fluid velocity u = (u, v) and pressure p. 

To get the volumetric flow rate of the fluid  in m3/s and the total volume of pumped 
fluid, you need to perform some additional calculations. To obtain the volumetric flow rate 
at any instant t, compute a boundary integral over the pipe’s inlet and outlet boundary:

where n is the outward-pointing unit normal of the boundary, u is the velocity vector, and 
s is the boundary length parameter, along which you integrate. In this particular model, 
the inlet and outlet boundaries are horizontal so n · u = nxu + nyv simplifies to v or −v 
depending on the direction of the flow.

n pI– μ ∇u ∇u( )T
+( )+[ ]⋅ 0=

V
·

V
·

in 2πr n u⋅( ) sd
sin

–=

V
·

out 2πr n u⋅( ) sd
sout

=
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It is of interest to track how much fluid is conveyed through the outlet during a peristaltic 
cycle, This can be calculated as the following time integral:

To compute this integral, specify the corresponding ODE in COMSOL Multiphysics

with proper initial conditions; the software then will integrate this equation.

Results

Figure 2 shows several snapshots from the peristaltic pump in action.

Figure 2: Snapshots of the velocity field and the shape of the inside of the tube at t = 0.3 s, 
t = 0.5 s, t = 0.7 s, t = 0.9 s, t = 1.1 s and t = 1.3 s. The colors represent the magnitude of the 
velocity, and the arrows its direction.

Figure 3 shows the inner volume of the tube as a function of time. At t = 0.3 s, the roll has 
begun its engagement phase, and it is increasing its pressure on the tube. As less and less 
space is left for the fluid, it is streaming out of the tube, through both the inlet and the 
outlet. At t = 0.5 s, the roll has been fully engaged for a while. As it is moving upward 

Vpump t( ) V
·

out t'd
0

t

=

dVpump
dt

-------------------- V
·

out=
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along the tube, so does the fluid, both at the inlet and at the outlet. This is where most of 
the net flow in the direction from the inlet to the outlet is created. Finally, at t = 1.3 s, the 
engagement process is reversed, and the roll is disengaging. As a result, the fluid is 
streaming into the tube from both ends.

Figure 3: The inner volume (m3) of the tube as a function of time (s).

Figure 4 shows the inlet and outlet flows, and it confirms the overall behavior indicated in 
the velocity snapshots. Note that a real peristaltic pump usually removes or minimizes the 
peaks associated with volume changes with the help of a second roll that engages at the 
same time as the first roll disengages. This way, there are hardly any volume changes, and 
the fluid flows forward all the time. Also note from Figure 4 that by taking the difference 
of the curves,  and integrating over time, you generate Figure 3.V

·
in V

·
out–
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Figure 4: Inlet and outlet flow in m3/s as functions of time. Positive values indicate that the 
fluid is flowing in through the inlet and out through the outlet.
7 |  P E R I S T A L T I C  P U M P



Figure 5 sums up the process, plotting the accumulated net flow versus time. It is worth 
noting that although the accumulated flow during the first 0.5 s of the cycle is zero or 
negative, it is well above zero after the full cycle.

Figure 5: Accumulated flow (m3) through the pump and volume of fluid conveyed out of the 
outlet versus time (s).

Notes About the COMSOL Implementation

This example is primarily intended to demonstrate the use of the Fluid-Structure 
Interaction interface, but it also shows some features for results analysis. Thus, it defines 
integration coupling operators to calculate the flow rate. An ordinary differential equation 
is used for calculating the accumulated fluid volume that has passed through the pump at 
certain points in time. The smooth step function used in this example is called flc2hs (a 
C2-continuous step).

Application Library path: Structural_Mechanics_Module/
Fluid-Structure_Interaction/peristaltic_pump
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D Axisymmetric.

2 In the Select Physics tree, select Fluid Flow>Fluid-Structure Interaction (fsi).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

G E O M E T R Y  1

Rectangle 1 (r1)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 0.01.

4 In the Height text field, type 0.1.

5 Click Build All Objects.

Rectangle 2 (r2)
1 On the Geometry toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 5e-3.

4 In the Height text field, type 0.1.

5 Locate the Position section. In the r text field, type 0.01.

6 Click Build All Objects.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

D E F I N I T I O N S

To define the force density for load applied to the outer wall of the tube, follow the steps 
given below.

Analytic 1 (an1)
1 On the Home toolbar, click Functions and choose Local>Analytic.

2 In the Settings window for Analytic, type load in the Function name text field.

3 Locate the Definition section. In the Expression text field, type flc2hs(t_off/dt-ts,
1)*flc2hs(ts-t_on/dt,1)*exp(-(zs-(z0+v0*ts*dt)/width)^2/2).

4 In the Arguments text field, type zs,ts.

Note that the function arguments are made dimensionless by zs = z/width and ts = t/
dt.

To compute inflow/outflow rates, define the integration over the relevant boundaries.

Integration 1 (intop1)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundary 2 only.

Integration 2 (intop2)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, locate the Source Selection section.

Name Expression Value Description

t_on 0.3[s] 0.3 s Time when roll is engaged

t_off 1.2[s] 1.2 s Time when roll is disengaged

dt 0.2[s] 0.2 s Time to reach full force

z0 0.03[m] 0.03 m z coordinate where roll 
starts

v0 0.03[m/s] 0.03 m/s Vertical velocity of roll

width 0.01[m] 0.01 m Width of Gaussian force 
distribution

Ttot 1.5[s] 1.5 s Total time for a pump cycle

Lmax 1.5e8[N/m^2] 1.5E8 N/m² Max load
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3 From the Geometric entity level list, choose Boundary.

4 Select Boundary 3 only.

Variables 1
1 On the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Nylon.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

M A T E R I A L S

Nylon (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Nylon (mat1).

2 Select Domain 2 only.

3 In the Settings window for Material, locate the Material Contents section.

4 In the table, enter the following settings:

Material 2 (mat2)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 Select Domain 1 only.

3 In the Settings window for Material, locate the Material Contents section.

Name Expression Unit Description

inflow intop1(2*pi*r*w_fluid) m³/s Inflow

outflow intop2(2*pi*r*w_fluid) m³/s Outflow

Property Name Value Unit Property group

Dynamic viscosity mu 0.33 Pa·s Basic
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4 In the table, enter the following settings:

F L U I D - S T R U C T U R E  I N T E R A C T I O N  ( F S I )

1 In the Model Builder window, under Component 1 (comp1) click Fluid-Structure 

Interaction (fsi).

2 In the Settings window for Fluid-Structure Interaction, locate the Physical Model section.

3 From the Compressibility list, choose Incompressible flow.

Linear Elastic Material 1
1 In the Model Builder window, expand the Fluid-Structure Interaction (fsi) node, then click 

Linear Elastic Material 1.

2 Select Domain 2 only.

Damping 1
1 On the Physics toolbar, click Attributes and choose Damping.

2 In the Settings window for Damping, locate the Damping Settings section.

3 In the αdM text field, type 1e-2.

4 In the βdK text field, type 1e-3.

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundary 7 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the FA vector as

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundaries 5 and 6 only.

Open Boundary 1
1 On the Physics toolbar, click Boundaries and choose Open Boundary.

Property Name Value Unit Property group

Density rho 1e3 kg/m³ Basic

Dynamic viscosity mu 5e-3 Pa·s Basic

-Lmax*load(z/width,t/dt) r

0 z
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2 Select Boundaries 2 and 3 only.

Prescribed Mesh Displacement 2
1 On the Physics toolbar, click Boundaries and choose Prescribed Mesh Displacement.

2 Select Boundaries 2 and 3 only.

3 In the Settings window for Prescribed Mesh Displacement, locate the Prescribed Mesh 

Displacement section.

4 Clear the Prescribed r displacement check box.

Prescribed Mesh Displacement 3
1 On the Physics toolbar, click Boundaries and choose Prescribed Mesh Displacement.

2 Select Boundary 1 only.

3 In the Settings window for Prescribed Mesh Displacement, locate the Prescribed Mesh 

Displacement section.

4 Clear the Prescribed z displacement check box.

Define the ordinary differential equations to calculate volume of the pumped fluid and 
the accumulated flow.

5 In the Model Builder window’s toolbar, click the Show button and select Advanced Physics 

Options in the menu.

Global Equations 1
1 On the Physics toolbar, click Global and choose Global Equations.

2 In the Settings window for Global Equations, locate the Global Equations section.

3 In the table, enter the following settings:

4 Locate the Units section. Find the Dependent variable quantity subsection. From the list, 
choose Volume (m^3).

5 Find the Source term quantity subsection. From the list, choose Volume per time (m^3/s).

Global Equations 2
1 On the Physics toolbar, click Global and choose Global Equations.

2 In the Settings window for Global Equations, locate the Global Equations section.

Name f(u,ut,utt,t) 
(1)

Initial value 
(u_0) (1)

Initial value 
(u_t0) (1/s)

Description

netflow netflowt-
(outflow+
inflow)/2

0 0 Accumulated flow
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3 In the table, enter the following settings:

4 Locate the Units section. Find the Dependent variable quantity subsection. From the list, 
choose Volume (m^3).

5 Find the Source term quantity subsection. From the list, choose Volume per time (m^3/s).

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,0.02,1.5).

Get the initial values, which will also generate the default plot to be shown while 
solving.

4 Right-click Study 1>Step 1: Time Dependent and choose Get Initial Value for Step.

5 In the Settings window for Time Dependent, click to expand the Results while solving 
section.

6 Locate the Results While Solving section. Select the Plot check box.

7 In the Model Builder window, expand the Study 1>Solver Configurations node.

Solution 1 (sol1)
1 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 (sol1) 

node.

The problem size is relatively small, so that it can be solved efficiently using a fully 
coupled solver.

2 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Time-Dependent Solver 1 node.

3 Right-click Study 1>Solver Configurations>Solution 1 (sol1)>Time-Dependent Solver 1 and 
choose Fully Coupled.

4 On the Home toolbar, click Compute.

Name f(u,ut,utt,t) 
(1)

Initial value 
(u_0) (1)

Initial value 
(u_t0) (1/s)

Description

Vpump Vpumpt-ou
tflow

0 0 Volume conveyed
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R E S U L T S

The first default plot shows the stress distribution together with the velocity field t = 1.5 s. 
To plot the total displacement at t = 0.7 s (Figure 1), follow these steps:

2D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 2D Plot Group.

2 In the Settings window for 2D Plot Group, locate the Data section.

3 From the Time (s) list, choose 0.7.

Surface 1
1 Right-click 2D Plot Group 4 and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type fsi.disp.

4 From the Unit list, choose mm.

5 On the 2D Plot Group 4 toolbar, click Plot.

6 Click the Zoom Extents button on the Graphics toolbar.

Flow and Stress (fsi)
To animate the velocity field as a function of time, as shown in Figure 2, proceed with the 
following steps:

Surface 1
In the Model Builder window, expand the Flow and Stress (fsi) node.

Flow and Stress (fsi)
1 Right-click Surface 1 and choose Disable.

Run the player to animate the velocity field as a function of time, as shown in Figure 2:

2 In the Model Builder window, under Results click Flow and Stress (fsi).

3 On the Flow and Stress (fsi) toolbar, click Animation and choose Player.

Derived Values
To plot the total volume of fluid contained in the pump (Figure 3), follow the steps given 
below.

Surface Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 Select Domain 1 only.

3 In the Settings window for Surface Integration, locate the Expressions section.
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4 In the table, enter the following settings:

5 Locate the Integration Settings section. Select the Compute volume integral check box.

6 Click Evaluate.

TA B L E

1 Go to the Table window.

2 Click the right end of the Display Table 1 - Surface Integration 1 (1) split button in the 
window toolbar.

3 From the menu, choose Table Graph.

R E S U L T S

Table Graph 1
To plot the inlet and outlet flow rates (Figure 4), accumulated flow through the pump and 
volume of fluid conveyed out of the outlet(Figure 5), follow the steps given below.

1D Plot Group 6
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 Select the y-axis label check box.

4 In the associated text field, type (m^3/s).

Global 1
1 On the 1D Plot Group 6 toolbar, click Global.

2 In the Settings window for Global, locate the y-Axis Data section.

3 In the table, enter the following settings:

4 Click to expand the Title section. From the Title type list, choose None.

5 On the 1D Plot Group 6 toolbar, click Plot.

Expression Unit Description

1 m^3 Inner volume

Expression Unit Description

inflow m^3/s Inflow

outflow m^3/s Outflow
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1D Plot Group 7
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 Select the y-axis label check box.

4 In the associated text field, type (m^3/s).

Global 1
1 On the 1D Plot Group 7 toolbar, click Global.

2 In the Settings window for Global, locate the y-Axis Data section.

3 In the table, enter the following settings:

4 Click to expand the Title section. From the Title type list, choose None.

5 On the 1D Plot Group 7 toolbar, click Plot.

Flow and Stress, 3D (fsi)
1 In the Model Builder window, under Results click Flow and Stress, 3D (fsi).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Time (s) list, choose 0.7.

4 On the Flow and Stress, 3D (fsi) toolbar, click Plot.

Expression Unit Description

netflow m^3 Accumulated flow

Vpump m^3 Volume conveyed
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5 Click the Zoom Extents button on the Graphics toolbar.

The resulting plot should be similar to the one shown in the following figure:
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Introduction

This example is inspired by a classic bridge type called a Pratt truss bridge. You can identify 
a Pratt truss by its diagonal members, which (except for the very end ones) all slant down 
and in toward the center of the span. All the diagonal members are subject to tension 
forces only, while the shorter vertical members handle the compressive forces. Since the 
tension removes the buckling risk, this allows for thinner diagonal members resulting in a 
more economic design.

A truss structure supports only tension and compression forces in its members and you 
would normally model it using bars, but as this model uses 3D beams it also includes 
bending moments to some extent in a frame structure. In the model, shell elements 
represent the roadway. 

Model Definition

B A S I C  D I M E N S I O N S

The length of the bridge is 40 m, and the width of the roadway is 7 m. The main distance 
between the truss members is 5 m.

A N A L Y S I S  TY P E S

The model includes two different analyses of the bridge:

• The goal of the first analysis is to evaluate the stress and deflection fields of the bridge 
when exposed to a pure gravity load and also when a load corresponding to one or two 
trucks cross the bridge.

• Finally, an eigenfrequency analysis shows the eigenfrequencies and eigenmodes of the 
bridge.

L O A D S  A N D  C O N S T R A I N T S

To prevent rigid body motion of the bridge, it is important to constrain it properly. All 
translational degrees of freedom are constrained at the left-most horizontal edge. 
Constraints at the right-most horizontal edge prevent it from moving in the vertical and 
transversal directions but allow the bridge to expand or contract in the axial direction. This 
difference would however only be important if thermal expansion was studied.
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Figure 1 shows the bridge geometry. 

Figure 1: The geometry of the bridge

The first study uses several load cases. In the first load case the effects of self weight are 
analyzed. The following load cases compute the solution when two trucks are moving over 
the bridge. The weight of each truck is 12,000 kg, the wheelbase is 6 m, the axle track is 
2 m, and the weight is distributed with one third on the front axle and two thirds on the 
rear axle. The right side wheels of the truck are 1 m from the edge of the bridge.

In the second study the natural frequencies of the bridge are computed.

M A T E R I A L  P R O P E R T I E S  A N D  C R O S S  S E C T I O N  D A T A

The material in the frame structure is structural steel. The roadway material is concrete; 
the effect of reinforcement is ignored. The frame members have different cross sections: 

• The main beams along the bridge have square box profiles with height 200 mm and 
thickness 16 mm. This is also true for the outermost diagonal members.

• The diagonal and vertical members have a rectangular box section 200x100 mm, with 
12.5 mm thickness. The large dimension is in the transverse direction of the bridge.
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• The transverse horizontal members supporting the roadway (floor beams) are standard 
HEA100 profiles.

• The transverse horizontal members at the top of the truss (struts) are made from solid 
rectangular sections with dimension 100x25 mm. The large dimension is in the 
horizontal direction.

Results and Discussion

Figure 2 and Figure 3 illustrate the result. Figure 2 shows the displacements, and it can be 
seen that the maximum deflection amounts to 3 cm on the roadway. The distribution of 
axial forces (Figure 3) demonstrates the function of the frame: The interplay of members 
in tension and compression contribute to the load carrying function. The upper horizontal 
members are in compression and the lower in tension. The force in the lower members is 
much smaller, since the load is also shared by the roadway in this example. The diagonal 
members are subject to tension forces only, while the shorter vertical members handle the 
compressive forces.

Figure 2: Deformation under self weight.
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Figure 3: The axial forces in the beams. Red is tension and blue is compression.

To study the effects of trucks moving over the bridge, several load cases represent the 
position of the trucks. The trucks are moved 3 m along the bridge for each load case. 
Figure 4 shows the stress distribution in the roadway when the first truck has passed the 
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bridge center and the second truck has entered the bridge deck.

Figure 4: Truck load analysis: Stresses in the bridge deck with two trucks are on the bridge.

The study of eigenfrequencies is important with respect to the excitation and frequency 
content from various loads such as wind loads and earthquakes.
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Figure 5 shows the 10th eigenmode of the bridge, which is the fundamental mode for the 
roadway. The first eight eigenmodes only involve displacements of the weak struts at the 
top of the truss.

Figure 5: The 10th eigenmode.

Notes About the COMSOL Implementation

You can define load cases to activate and deactivate loads within a study. All the loads need 
to be defined in the Model Builder. Under the Stationary Study node, you can then select 
which load or constraint to activate for a specific load case. Moreover for each load case 
you can modify the value of the applied load by changing its weight factor.

When combining two different physics interfaces, each have individual sets of degrees of 
freedom as a default. In structural mechanics, you usually want these to be equal. You can 
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set such connections across various structural mechanics interfaces using built in 
connection features. In this particular model Shell Connection feature in Beam interface and 
Beam Connection feature in Shell interface are used to set up the connection between the 
two. 

Application Library path: Structural_Mechanics_Module/Civil_Engineering/
pratt_truss_bridge

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Shell (shell).

3 Click Add.

4 In the Select Physics tree, select Structural Mechanics>Beam (beam).

5 Click Add.

6 Click Study.

7 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

8 Click Done.

G L O B A L  D E F I N I T I O N S

1 In the Model Builder window, right-click Global Definitions and choose Load Group.

2 Repeat this nine times so that you get ten load groups.

G E O M E T R Y  1

The geometry sequence for the model (see Figure 1) is available in a file. If you want to 
create it from scratch yourself, you can follow the instructions in the Appendix—Geometry 
Modeling Instructions. section. Otherwise, insert the geometry sequence as follows:

1 On the Geometry toolbar, click Insert Sequence.
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2 Browse to the application’s Application Libraries folder and double-click the file 
pratt_truss_bridge_geom_sequence.mph.

3 On the Geometry toolbar, click Build All.

G L O B A L  D E F I N I T I O N S

Parameters
Add the non geometrical parameters.

1 In the Model Builder window, under Global Definitions click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

D E F I N I T I O N S

Create groups for the different beam sections.

Box 1
1 On the Definitions toolbar, click Box.

2 In the Settings window for Box, type BeamsTransvBelow in the Label text field.

3 Locate the Geometric Entity Level section. From the Level list, choose Edge.

4 Locate the Box Limits section. In the x minimum text field, type -(length/2+1).

5 In the x maximum text field, type length/2+1.

6 In the y minimum text field, type 1.

7 In the y maximum text field, type width-1.

8 In the z minimum text field, type -1.

9 In the z maximum text field, type 1.

BeamsTransvBelow 1
1 Right-click BeamsTransvBelow and choose Duplicate.

2 In the Settings window for Box, type BeamsAllBelow in the Label text field.

3 Locate the Box Limits section. In the y minimum text field, type -1.

4 In the y maximum text field, type width+1.

5 Locate the Output Entities section. From the Include entity if list, choose Entity inside 

box.

Name Expression Value Description

truck_weight 12000[kg] 1.2E4 kg Total truck weight
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Box 3
1 On the Definitions toolbar, click Box.

2 In the Settings window for Box, type BeamsTransvAbove in the Label text field.

3 Locate the Geometric Entity Level section. From the Level list, choose Edge.

4 Locate the Box Limits section. In the x minimum text field, type -(length/2+1).

5 In the x maximum text field, type length/2+1.

6 In the y minimum text field, type 1.

7 In the y maximum text field, type width-1.

8 In the z minimum text field, type height-1.

9 In the z maximum text field, type height+1.

Box 4
1 On the Definitions toolbar, click Box.

2 In the Settings window for Box, type BeamsDiag in the Label text field.

3 Locate the Geometric Entity Level section. From the Level list, choose Edge.

4 Locate the Box Limits section. In the x minimum text field, type -(length/2-spacing+
1).

5 In the x maximum text field, type length/2-spacing+1.

6 In the y minimum text field, type -1.

7 In the y maximum text field, type width+1.

8 In the z minimum text field, type 1.

9 In the z maximum text field, type 2.

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type AllBeams in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Edge.

4 Select the All edges check box.

Difference 1
1 On the Definitions toolbar, click Difference.

2 In the Settings window for Difference, type BeamsMain in the Label text field.

3 Locate the Geometric Entity Level section. From the Level list, choose Edge.

4 Locate the Input Entities section. Under Selections to add, click Add.
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5 In the Add dialog box, select AllBeams in the Selections to add list.

6 Click OK.

7 In the Settings window for Difference, locate the Input Entities section.

8 Under Selections to subtract, click Add.

9 In the Add dialog box, In the Selections to subtract list, choose BeamsTransvBelow, 
BeamsTransvAbove, and BeamsDiag.

10 Click OK.

Add the materials.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Concrete.

4 Click Add to Component in the window toolbar.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Structural steel.

3 Click Add to Component in the window toolbar.

4 On the Home toolbar, click Add Material to close the Add Material window.

M A T E R I A L S

Structural steel (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Structural steel 

(mat2).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Edge.

4 From the Selection list, choose All edges.

S H E L L  ( S H E L L )

1 In the Model Builder window, under Component 1 (comp1) click Shell (shell).

2 In the Settings window for Shell, locate the Thickness section.

3 In the d text field, type 0.25.

Add self weight for the bridge deck.
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Gravity 1
1 On the Physics toolbar, click Boundaries and choose Gravity.

2 In the Settings window for Gravity, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

Pinned 1
1 On the Physics toolbar, click Edges and choose Pinned.

2 Select Edge 1 only.

Prescribed Displacement/Rotation 11
1 On the Physics toolbar, click Edges and choose Prescribed Displacement/Rotation.

2 Select Edge 78 only.

3 In the Settings window for Prescribed Displacement/Rotation, locate the Prescribed 

Displacement section.

4 Select the Prescribed in y direction check box.

5 Select the Prescribed in z direction check box.

Add the possible loads from the truck wheels.

Point Load 1
1 On the Physics toolbar, click Points and choose Point Load.

2 Click Load Group and choose Load Group 1.

3 In the Model Builder window, click Point Load 1.

4 Select Points 3 and 4 only.

5 In the Settings window for Point Load, locate the Force section.

6 Specify the FP vector as

Point Load 2
1 Right-click Point Load 1 and choose Duplicate.

2 On the Physics toolbar, click Load Group and choose Load Group 2.

3 In the Model Builder window, under Component 1 (comp1)>Shell (shell) click Point Load 2.

4 In the Settings window for Point Load, locate the Point Selection section.

5 Click Clear Selection.

0 x

0 y

-truck_weight*g_const/6 z
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6 Select Points 5 and 6 only.

7 Repeat this duplication procedure so that you get ten Point Load features. The loaded 
points and corresponding load groups are summarized in the table below:

B E A M  ( B E A M )

On the Physics toolbar, click Shell (shell) and choose Beam (beam).

Set the cross-section data of the different beam types.

Cross Section Data 1
1 In the Model Builder window, under Component 1 (comp1)>Beam (beam) click Cross 

Section Data 1.

2 In the Settings window for Cross Section Data, type Cross Section Main in the Label 
text field.

3 Locate the Cross Section Definition section. From the list, choose Common sections.

4 From the Section type list, choose Box.

5 In the hy text field, type 200[mm].

6 In the hz text field, type 200[mm].

7 In the ty text field, type 16[mm].

8 In the tz text field, type 16[mm].

Section Orientation 1
1 In the Model Builder window, expand the Component 1 (comp1)>Beam (beam)>Cross 

Section Main node, then click Section Orientation 1.

2 In the Settings window for Section Orientation, locate the Section Orientation section.

3 From the Orientation method list, choose Orientation vector.

Point load Points Load goup

Point Load 3 11, 12 Load Group 3

Point Load 4 15, 16 Load Group 4

Point Load 5 19, 20 Load Group 5

Point Load 6 25, 26 Load Group 6

Point Load 7 27, 28 Load Group 7

Point Load 8 33, 34 Load Group 8

Point Load 9 37, 38 Load Group 9

Point Load 10 41, 42 Load Group 10
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4 Specify the V vector as

5 In the Model Builder window, click Beam (beam).

Cross Section Data 2
1 On the Physics toolbar, click Edges and choose Cross Section Data.

2 In the Settings window for Cross Section Data, type Cross Section Diagonals in the 
Label text field.

3 Locate the Edge Selection section. From the Selection list, choose BeamsDiag.

4 Locate the Cross Section Definition section. From the list, choose Common sections.

5 From the Section type list, choose Box.

6 In the hy text field, type 200[mm].

7 In the hz text field, type 100[mm].

8 In the ty text field, type 12.5[mm].

9 In the tz text field, type 12.5[mm].

Section Orientation 1
1 In the Model Builder window, expand the Component 1 (comp1)>Beam (beam)>Cross 

Section Diagonals node, then click Section Orientation 1.

2 In the Settings window for Section Orientation, locate the Section Orientation section.

3 From the Orientation method list, choose Orientation vector.

4 Specify the V vector as

Cross Section Data 3
1 On the Physics toolbar, click Edges and choose Cross Section Data.

2 In the Settings window for Cross Section Data, type Cross Section Transv Below 
in the Label text field.

3 Locate the Edge Selection section. From the Selection list, choose BeamsTransvBelow.

4 Locate the Cross Section Definition section. From the list, choose Common sections.

0 x

1 y

0 z

0 x

1 y

0 z
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5 From the Section type list, choose H-profile.

6 In the hy text field, type 96[mm].

7 In the hz text field, type 100[mm].

8 In the ty text field, type 8[mm].

9 In the tz text field, type 5[mm].

Section Orientation 1
1 In the Model Builder window, expand the Component 1 (comp1)>Beam (beam)>Cross 

Section Transv Below node, then click Section Orientation 1.

2 In the Settings window for Section Orientation, locate the Section Orientation section.

3 From the Orientation method list, choose Orientation vector.

4 Specify the V vector as

Cross Section Data 4
1 On the Physics toolbar, click Edges and choose Cross Section Data.

2 In the Settings window for Cross Section Data, type Cross Section Transv Above 
in the Label text field.

3 Locate the Edge Selection section. From the Selection list, choose BeamsTransvAbove.

4 Locate the Cross Section Definition section. From the list, choose Common sections.

5 In the hy text field, type 100[mm].

6 In the hz text field, type 25[mm].

Section Orientation 1
1 In the Model Builder window, expand the Component 1 (comp1)>Beam (beam)>Cross 

Section Transv Above node, then click Section Orientation 1.

2 In the Settings window for Section Orientation, locate the Section Orientation section.

3 From the Orientation method list, choose Orientation vector.

4 Specify the V vector as

0 x

0 y

1 z

1 x

0 y

0 z
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Add the self weight of the beams.

Gravity 1
1 On the Physics toolbar, click Edges and choose Gravity.

2 In the Settings window for Gravity, locate the Edge Selection section.

3 From the Selection list, choose All edges.

Create connections between beams and shells.

Shell Connection 1
1 On the Physics toolbar, click Edges and choose Shell Connection.

2 Select Edges 2, 8, 18, 30, 40, 50, 62, and 72 only.

Shell Connection 2
1 On the Physics toolbar, click Edges and choose Shell Connection.

2 Select Edges 4, 13, 25, 35, 45, 57, 67, and 76 only.

Shell Connection 3
1 On the Physics toolbar, click Edges and choose Shell Connection.

2 Select Edges 7, 17, 22, 23, 29, 39, 49, 54, 55, 61, and 71 only.

Shell Connection 4
1 On the Physics toolbar, click Edges and choose Shell Connection.

2 Select Edge 1 only.

Shell Connection 5
1 On the Physics toolbar, click Edges and choose Shell Connection.

2 Select Edge 78 only.

S H E L L  ( S H E L L )

In the Model Builder window, expand the Component 1 (comp1)>Shell (shell) node, then 
click Shell (shell).

Beam Connection 1
1 On the Physics toolbar, click Edges and choose Beam Connection.

2 Select Edges 2, 8, 18, 30, 40, 50, 62, and 72 only.

3 In the Settings window for Beam Connection, locate the Beam Connection section.

4 From the list, choose Shell Connection 1 (beam).

5 From the Offset definition list, choose Offset vector.
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6 Specify the d0 vector as

Beam Connection 2
1 On the Physics toolbar, click Edges and choose Beam Connection.

2 Select Edges 4, 13, 25, 35, 45, 57, 67, and 76 only.

3 In the Settings window for Beam Connection, locate the Beam Connection section.

4 From the list, choose Shell Connection 2 (beam).

5 From the Offset definition list, choose Offset vector.

6 Specify the d0 vector as

Beam Connection 3
1 On the Physics toolbar, click Edges and choose Beam Connection.

2 Select Edges 7, 17, 22, 23, 29, 39, 49, 54, 55, 61, and 71 only.

3 In the Settings window for Beam Connection, locate the Beam Connection section.

4 From the list, choose Shell Connection 3 (beam).

5 From the Offset definition list, choose Offset vector.

6 Specify the d0 vector as

Beam Connection 4
1 On the Physics toolbar, click Edges and choose Beam Connection.

2 Select Edge 1 only.

3 In the Settings window for Beam Connection, locate the Beam Connection section.

4 From the list, choose Shell Connection 4 (beam).

5 From the Offset definition list, choose Offset vector.

0 x

beam.hy_box/2 y

-beam.hz_box/2 z

0 x

-beam.hy_box/2 y

-beam.hz_box/2 z

0 x

0 y

-beam.hy_H/2 z
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6 Specify the d0 vector as

Beam Connection 5
1 On the Physics toolbar, click Edges and choose Beam Connection.

2 Select Edge 78 only.

3 In the Settings window for Beam Connection, locate the Beam Connection section.

4 From the list, choose Shell Connection 5 (beam).

5 From the Offset definition list, choose Offset vector.

6 Specify the d0 vector as

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Extremely fine.

4 Click Build All.

5 Click the Zoom Extents button on the Graphics toolbar.

S T U D Y  1

Step 1: Stationary
1 In the Settings window for Stationary, click to expand the Study extensions section.

2 Locate the Study Extensions section. Select the Define load cases check box.

3 Click Add nine times.

4 In the table, select the load cases and set the related weight according to the table:

beam.hz_H/2 x

0 y

-beam.hy_H/2 z

-beam.hz_H/2 x

0 y

-beam.hy_H/2 z

Load case Active load groups and weights

Self Weight

1 truck, position 1 lg1: 2.0; lg3: 1.0
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5 On the Home toolbar, click Compute.

R E S U L T S

Stress (shell)
The default plot is the stress plot for the shells using the last load case, see Figure 4.

Surface 1
1 In the Model Builder window, expand the Stress (shell) node, then click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose MPa.

4 Click the Zoom Extents button on the Graphics toolbar.

5 On the Stress (shell) toolbar, click Plot.

Add a new plot containing both shell and beam results, and examine the self weight load 
case to reproduce Figure 2.

3D Plot Group 11
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Displacement in the Label text field.

3 Locate the Data section. From the Load case list, choose Self weight.

4 Right-click Displacement and choose Surface.

Surface 1
In the Model Builder window, under Results>Displacement right-click Surface 1 and choose 
Deformation.

Displacement
In the Model Builder window, under Results right-click Displacement and choose Line.

1 truck, position 2 lg2: 2.0; lg4: 1.0

1 truck, position 3 lg3: 2.0; lg5: 1.0

1 truck, position 4 lg4: 2.0; lg6: 1.0

2 trucks, position 1 lg1: 1.0; lg5: 2.0; lg7: 1.0

2 trucks, position 2 lg2: 1.0; lg6: 2.0; lg8: 1.0

2 trucks, position 3 lg1: 2.0; lg3: 1.0; lg7: 2.0; lg9: 1.0

2 trucks, position 4 lg2: 2.0; lg4: 1.0; lg8: 2.0; lg10: 1.0

Load case Active load groups and weights
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Line 1
1 In the Settings window for Line, click Replace Expression in the upper-right corner of the 

Expression section. From the menu, choose Component 1>Beam>Displacement>

beam.disp - Total displacement.

You can indicate the dimensions of the beams by drawing them with a size depending on 
the radius of gyration.

2 Locate the Coloring and Style section. From the Line type list, choose Tube.

3 In the Tube radius expression text field, type comp1.beam.re.

4 Click to expand the Inherit style section. Locate the Inherit Style section. From the Plot 
list, choose Surface 1.

Surface 1
1 In the Model Builder window, under Results>Displacement click Surface 1.

2 In the Settings window for Surface, click to expand the Range section.

3 Select the Manual color range check box.

4 In the Maximum text field, type 0.05.

Line 1
In the Model Builder window, under Results>Displacement right-click Line 1 and choose 
Deformation.

Deformation 1
On the Displacement toolbar, click Plot.

Displacement
1 In the Model Builder window, under Results click Displacement.

2 In the Settings window for 3D Plot Group, locate the Plot Settings section.

3 Clear the Plot data set edges check box.

4 Click the Zoom Extents button on the Graphics toolbar.

5 On the Displacement toolbar, click Plot.

Now plot the axial force in beams like in Figure 3.

6 Right-click Results>Displacement and choose Duplicate.

Displacement 1
In the Settings window for 3D Plot Group, type Beam force in the Label text field.

Line 1
1 In the Model Builder window, expand the Results>Beam force node, then click Line 1.
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2 In the Settings window for Line, click Replace Expression in the upper-right corner of the 
Expression section. From the menu, choose Component 1>Beam>Section forces>beam.Nxl 

- Local axial force.

3 Locate the Inherit Style section. From the Plot list, choose None.

4 Click to expand the Range section. Select the Manual color range check box.

5 In the Minimum text field, type -9e5.

6 In the Maximum text field, type 9e5.

7 Locate the Coloring and Style section. From the Color table list, choose Wave.

Surface 1
In the Model Builder window, under Results>Beam force right-click Surface 1 and choose 
Disable.

Beam force
1 Click the Zoom Extents button on the Graphics toolbar.

2 In the Model Builder window, under Results click Beam force.

3 On the Beam force toolbar, click Plot.

Stress (shell)
1 In the Model Builder window, under Results click Stress (shell).

2 On the Stress (shell) toolbar, click Plot.

Create an animation of the trucks passing the bridge.

Animation 1
1 On the Results toolbar, click Animation and choose Player.

2 In the Settings window for Animation, click Show Frame.

3 Locate the Frames section. In the Number of frames text field, type 9.

4 In the Frame number text field, type 9.

You can easily remove unused plots to clean up the structure in the Results tree. An 
alternative could have been to deselect Generate default plots in the Study feature, but then 
you would have needed to create the current plot manually.

5 In the Model Builder window, select Results>Stress Bottom (shell) 1, hold down the Shift 
key, and then select Results>Torsion Moment (beam) 1. Right click and choose Delete.

Now add an eigenfrequency study.
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A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Eigenfrequency.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

Step 1: Eigenfrequency
1 In the Model Builder window, under Study 2 click Step 1: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 Select the Desired number of eigenfrequencies check box.

4 In the associated text field, type 12.

5 On the Home toolbar, click Compute.

R E S U L T S

Mode Shape (shell)
Select the first mode involving the roadway, see Figure 5.

1 In the Model Builder window, click Mode Shape (shell).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Eigenfrequency (Hz) list, choose 3.607.

4 Locate the Plot Settings section. Clear the Plot data set edges check box.

5 In the Model Builder window, expand the Mode Shape (shell) node.

Line 1
1 In the Model Builder window, expand the Results>Mode Shape (beam) node.

2 Right-click Line 1 and choose Copy.

Mode Shape (shell)
In the Model Builder window, under Results right-click Mode Shape (shell) and choose Paste 

Line.

Line 1
1 In the Settings window for Line, locate the Inherit Style section.

2 From the Plot list, choose Surface 1.
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Deformation
1 In the Model Builder window, expand the Results>Mode Shape (shell)>Surface 1 node, 

then click Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 Select the Scale factor check box.

4 In the associated text field, type 0.2.

Surface 1
1 In the Model Builder window, under Results>Mode Shape (shell) click Surface 1.

2 In the Settings window for Surface, locate the Range section.

3 Select the Manual color range check box.

4 In the Maximum text field, type 4.

5 Click the Zoom Extents button on the Graphics toolbar.

6 On the Mode Shape (shell) toolbar, click Plot.

Appendix—Geometry Modeling Instructions.

If you wish to create the geometry yourself, follow these steps.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

Name Expression Value Description

width 7[m] 7 m Width of bridge

height 5[m] 5 m Height of bridge

spacing 5[m] 5 m Spacing between members along the 
bridge

length 40[m] 40 m Total bridge length
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2 In the Settings window for Work Plane, click Show Work Plane.

Plane Geometry
Create the bridge deck.

Rectangle 1 (r1)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type spacing.

4 In the Height text field, type width.

5 Locate the Position section. In the xw text field, type -length/2.

6 On the Work Plane toolbar, click Build All.

Array 1 (arr1)
1 On the Work Plane toolbar, click Transforms and choose Array.

2 In the Settings window for Array, locate the Size section.

3 From the Array type list, choose Linear.

4 Select the object r1 only.

5 In the Size text field, type length/spacing.

6 Locate the Displacement section. In the xw text field, type spacing.

7 On the Work Plane toolbar, click Build All.

8 Click the Zoom Extents button on the Graphics toolbar.

Plane Geometry
Make it possible to create beams along the edges.

Convert to Curve 1 (ccur1)
1 On the Work Plane toolbar, click Conversions and choose Convert to Curve.

2 In the Settings window for Convert to Curve, locate the Input section.

3 Select the Keep input objects check box.

4 Click in the Graphics window and then press Ctrl+A to select all objects.

5 On the Work Plane toolbar, click Build All.

6 In the Model Builder window, click Geometry 1.

7 On the Home toolbar, click Build All.

8 Click the Zoom Extents button on the Graphics toolbar.

Start creating the truss.
24 |  P R A T T  TR U S S  B R I D G E



Work Plane 2 (wp2)
1 On the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, locate the Plane Definition section.

3 From the Plane list, choose xz-plane.

4 Click Show Work Plane.

Bézier Polygon 1 (b1)
1 On the Work Plane toolbar, click Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the General section.

3 From the Type list, choose Open curve.

4 Locate the Polygon Segments section. Find the Added segments subsection. Click Add 

Linear.

5 Find the Control points subsection. In row 2, set xw to spacing and yw to height.

6 Find the Added segments subsection. Click Add Linear.

7 Find the Control points subsection. In row 2, set yw to 0.

8 On the Work Plane toolbar, click Build All.

Bézier Polygon 2 (b2)
1 On the Work Plane toolbar, click Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the General section.

3 From the Type list, choose Open curve.

4 Locate the Polygon Segments section. Find the Added segments subsection. Click Add 

Linear.

5 Find the Control points subsection. In row 1, set yw to height.

6 In row 2, set xw to spacing and yw to height.

7 On the Work Plane toolbar, click Build All.

Array 1 (arr1)
1 On the Work Plane toolbar, click Transforms and choose Array.

2 In the Settings window for Array, locate the Size section.

3 From the Array type list, choose Linear.

4 Click in the Graphics window and then press Ctrl+A to select both objects.

5 In the Size text field, type length/(2*spacing)-1.

6 Locate the Displacement section. In the xw text field, type spacing.

7 On the Work Plane toolbar, click Build All.
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Bézier Polygon 3 (b3)
1 On the Work Plane toolbar, click Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the General section.

3 From the Type list, choose Open curve.

4 Locate the Polygon Segments section. Find the Added segments subsection. Click Add 

Linear.

5 Find the Control points subsection. In row 1, set xw to length/2-spacing and yw to 
height.

6 In row 2, set xw to length/2.

7 On the Work Plane toolbar, click Build All.

Mirror 1 (mir1)
1 On the Work Plane toolbar, click Transforms and choose Mirror.

2 Click in the Graphics window and then press Ctrl+A to select all objects.

3 In the Settings window for Mirror, locate the Input section.

4 Select the Keep input objects check box.

5 On the Work Plane toolbar, click Build All.

6 Click the Zoom Extents button on the Graphics toolbar.

Bézier Polygon 4 (b4)
1 On the Work Plane toolbar, click Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the General section.

3 From the Type list, choose Open curve.

4 Locate the Polygon Segments section. Find the Added segments subsection. Click Add 

Linear.

5 Find the Control points subsection. In row 2, set yw to height.

6 On the Work Plane toolbar, click Build All.

7 In the Model Builder window, click Geometry 1.

8 On the Home toolbar, click Build All.

Copy 1 (copy1)
1 On the Geometry toolbar, click Transforms and choose Copy.

2 In the Settings window for Copy, locate the Displacement section.

3 In the y text field, type width.
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4 Select the object wp2 only.

5 Click Build All Objects.

Bézier Polygon 1 (b1)
1 On the Geometry toolbar, click More Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the Polygon Segments section.

3 Find the Added segments subsection. Click Add Linear.

4 Find the Control points subsection. In row 1, set x to -length/2+spacing and z to 
height.

5 In row 2, set x to -length/2+spacing, y to width, and z to height.

6 Click Build All Objects.

Array 1 (arr1)
1 On the Geometry toolbar, click Transforms and choose Array.
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2 Select the object b1 only.

3 In the Settings window for Array, locate the Size section.

4 From the Array type list, choose Linear.

5 Locate the Displacement section. In the x text field, type spacing.

6 Locate the Size section. In the Size text field, type length/spacing-1.

Create points in the positions where the loads from the truck wheels are to be applied.

Point 1 (pt1)
1 On the Geometry toolbar, click More Primitives and choose Point.

2 In the Settings window for Point, locate the Point section.

3 In the x text field, type -19.

4 In the y text field, type 1.

Array 2 (arr2)
1 On the Geometry toolbar, click Transforms and choose Array.

2 Select the object pt1 only.

3 In the Settings window for Array, locate the Size section.

4 In the x size text field, type 10.

5 In the y size text field, type 2.
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6 Locate the Displacement section. In the x text field, type 3.

7 In the y text field, type 2.

8 Click Build All Objects.
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Introduction

For their integration in microelectronic circuits, MEMS and other devices are often 
overmolded with an epoxy mold compound (EMC) to protect the devices and their 
interconnects with the board. The epoxy polymers used for such applications are subject 
to moisture absorption and hygroscopic swelling, which can lead to delamination between 
the EMC and the board or to incorrect behavior of MEMS components. This example 
studies how the moisture absorption of an EMC affects the response of a MEMS pressure 
sensor over a one-year time period.

Model Definition

Figure 1: Component geometry.

It is sufficient to model a quarter of the whole structure due to the symmetry (Figure 1). 
The geometry is composed of:

• An FR4 board, on which the die is glued.

FR4 board

Epoxy mold
compound

Silicon wafer

Silicon
membrane

Silica glass cap
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• The pressure sensor die made of:

- A silicon component with a processed membrane. The membrane is modeled with a 
shell interface. The strain on the membrane surface is used to measure the pressure.

- A silica glass capping

• An EMC that covers the die and a large part of the board.

When external pressure is applied on the bottom face of the membrane, the membrane 
deforms, and the strain is measured by means of a Wheatstone bridge made of 
piezoresistors. The measure of strain on the X- and Y-axes makes it possible to calculate 
the pressure. The membrane is modeled with a shell interface that is connected to the 
silicon domains via a shell-solid connection.

The moisture transport in the EMC is governed by the diffusion equation:

The moisture diffusion coefficient is temperature dependent:

Here U is the activation energy and k is the Boltzmann’s constant. For a typical EMC, 
D0 = 7.35·10-6 m2/s, U = 0.43 eV, and the diffusion coefficient at 25°C is around 
4·10-13 m2/s. 

The boundary conditions on the exterior faces of the EMC should be a flux of moisture 
concentration. However, given the long simulation time (one year) a concentration 
constraint can be assumed. The concentration applied on the boundaries is the saturation 
concentration of the material at a given temperature and humidity conditions:

where S is the solubility on the water in the material a given condition, Psat is the vapor 
saturation pressure of water, and ϕ is the relative humidity. The product of solubility and 
saturation pressure is supposed to be temperature-independent, thus the saturation 
concentration in the material depends only on the relative humidity. At 60% humidity, the 
saturation concentration is 140 mol/m3. 

The initial moisture concentration after molding is set to 40 mol/m3. This value can be 
also taken as reference for hygroscopic swelling because all the stresses are assumed relaxed 
just after molding.

t∂
∂c ∇ D c∇–( )⋅+ 0=

D D0exp U
kT
-------– 

 =

Csat SPsatϕ=
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In order to avoid problems that can be caused by the discontinuity of concentration at 
initial state, the concentration boundary condition is applied smoothly, and a boundary 
layer type mesh is used near those boundaries (Figure 2).

Figure 2: Mesh of the device.

As hygroscopic swelling induces a one-way coupling between concentration and 
mechanics, the concentration is calculated in a first time-dependent study, and then the 
structural domains are computed in a stationary study. This sequential approach reduces 
the computation time compared to a single solution including all physical interfaces.

Results and Discussion

The moisture diffuses progressively in the EMC. After 6 days, the moisture has already 
partially reached the top face of the die (Figure 3). 
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Figure 4 shows that the concentration at the die location starts to increase after 2 days until 
approximately 100 days. This is confirmed by the mass uptake shown in Figure 5, where 
the maximum value is reached after the same period of time.

Figure 3: Moisture concentration in the EMC after 6 days.

Figure 4: Moisture concentration at die location over time.
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Figure 5: Total mass uptake in the EMC.

The progressive moisture diffusion is also noticed on displacement plots after hygroscopic 
swelling calculation: the EMC swells only on its boundaries during the first days 
(Figure 6), and it swells everywhere after one year (Figure 7). During the first time, the 
expansion on the exterior boundaries implies a stretching on the membrane and thus an 
increase of the measured strain. Then, the expansion of the center implies compression on 
the die and a decrease of the strain along the axes; see Figure 8.

The moisture absorption and hygroscopic swelling have significant effect on the sensor 
sensibility, which have to be taken in account during the measurements, or when designing 
the sensor.
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Figure 6: Displacement after 6 days.

Figure 7: Displacement after 1 year.
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Figure 8: Evolution of measured strain on membrane axes.

Application Library path: Structural_Mechanics_Module/
Hygroscopic_Swelling/pressure_sensor_hygroscopic_swelling

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 In the Select Physics tree, select Structural Mechanics>Shell (shell).

5 Click Add.
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6 In the Select Physics tree, select Chemical Species Transport>Transport of Diluted Species 

(tds).

7 Click Add.

8 Click Study.

9 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Time 

Dependent.

10 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

l 20[mm] 0.02 m length of the device

w 15[mm] 0.015 m width of the device

l_MC 15[mm] 0.015 m length of the eopxy mold 
compound

w_MC 10[mm] 0.01 m width of the epoxy mold 
compound

l_die 1.2[mm] 0.0012 m side length of the 
pressure sensor

l_memb 700[µm] 7E-4 m side length of the silicon 
membrane

l_hole 800[µm] 8E-4 m side length of the hole in 
FR4

t_FR4 1[mm] 0.001 m thickness of the FR4

t_Si 200[µm] 2E-4 m thickness of the silicon

t_memb 20[µm] 2E-5 m thickness of the silicon 
membrane

t_glass 200[µm] 2E-4 m thickness of the silica 
glass wafer

t_MC 1.5[mm] 0.0015 m thickness of the mold 
compound

cmax 140[mol/m^3] 140 mol/m³ saturated concentration of 
the mold compound
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G E O M E T R Y  1

1 In the Model Builder window, expand the Component 1 (comp1)>Geometry 1 node, then 
click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Create a block for silicon wafer and glass cap.

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type l_die/2.

4 In the Depth text field, type l_die/2.

5 In the Height text field, type t_Si+t_glass.

6 Click to expand the Layers section. In the table, enter the following settings:

Create a block for the EMC.

Block 2 (blk2)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type l_MC/2.

4 In the Depth text field, type w_MC/2.

5 In the Height text field, type t_MC.

Create a block and substract it to make the cavity in the wafer.

Block 3 (blk3)
1 On the Geometry toolbar, click Block.

cini 40[mol/m^3] 40 mol/m³ initial moisture 
concentration

pext 1[bar] 1E5 Pa external pressure

t 0[s] 0 s time used for parametric 
sweep

Layer name Thickness (mm)

Layer 1 t_Si

Name Expression Value Description
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2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type l_memb/2.

4 In the Depth text field, type l_memb/2.

5 In the Height text field, type t_Si.

Difference 1 (dif1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Difference.

2 Select the objects blk1 and blk2 only.

3 In the Settings window for Difference, locate the Difference section.

4 Find the Objects to subtract subsection. Select the Active toggle button.

5 Select the object blk3 only.

6 Click Build All Objects.

Create a block for the board.

Block 4 (blk4)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type l/2.

4 In the Depth text field, type w/2.

5 In the Height text field, type t_FR4.

6 Locate the Position section. In the z text field, type -t_FR4.

Create a block and substract it to make a hole in the board.

Block 5 (blk5)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type l_hole/2.

4 In the Depth text field, type l_hole/2.

5 In the Height text field, type t_FR4.

6 Locate the Position section. In the z text field, type -t_FR4.

Difference 2 (dif2)
1 On the Geometry toolbar, click Booleans and Partitions and choose Difference.

2 Select the object blk4 only.

3 In the Settings window for Difference, locate the Difference section.
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4 Find the Objects to subtract subsection. Select the Active toggle button.

5 Select the object blk5 only.

6 Click Build All Objects.

Create rectangle in a workplane to build the membrane.

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

2 In the Settings window for Work Plane, click Show Work Plane.

Rectangle 1 (r1)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type l_memb/2.

4 In the Height text field, type l_memb/2.

5 Right-click Rectangle 1 (r1) and choose Build Selected.

6 In the Model Builder window, click Geometry 1.

7 On the Home toolbar, click Build All.

8 Click the Go to Default 3D View button on the Graphics toolbar.

D E F I N I T I O N S

Create selections to select domains easily in the following steps.

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 Select Domain 4 only.

3 In the Settings window for Explicit, type FR4 in the Label text field.

Explicit 2
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Silicon in the Label text field.

3 Select Domain 3 only.

Explicit 3
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Glass in the Label text field.

3 Select Domain 1 only.
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Explicit 4
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Mold Compound in the Label text field.

3 Select Domain 2 only.

Explicit 5
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Membrane in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundary 1 only.

S H E L L  ( S H E L L )

Set the shell thickness and the offset so that the bottom face is at z = 0, and set the height 
of evaluation so that the results are calculated on the bottom face.

1 In the Model Builder window, under Component 1 (comp1) click Shell (shell).

2 In the Settings window for Shell, locate the Boundary Selection section.

3 From the Selection list, choose Membrane.

4 Locate the Thickness section. In the d text field, type t_memb.

5 From the Offset definition list, choose Relative offset.

6 In the zreloffset text field, type 1.

7 Click to expand the Default through-thickness result location section. Locate the Default 

Through-Thickness Result Location section. In the z text field, type -1.

Solid Connection 1
1 On the Physics toolbar, click Edges and choose Solid Connection.

2 Select Edges 13 and 35 only.

3 In the Settings window for Solid Connection, locate the Solid Connection section.

4 From the Connection type list, choose Simplified.

Use symmetry on the shell edges. The normal of symmetry plane is the second axis of the 
local edge system, which is orthogonal to the edge and to the shell normal.

Symmetry 11
1 On the Physics toolbar, click Edges and choose Symmetry.

2 Select Edges 1 and 2 only.
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Face Load 1
1 On the Physics toolbar, click Boundaries and choose Face Load.

2 In the Settings window for Face Load, locate the Boundary Selection section.

3 From the Selection list, choose Membrane.

4 Locate the Force section. From the Load type list, choose Pressure.

5 In the p text field, type -pext.

S O L I D  M E C H A N I C S  ( S O L I D )

First, set the discretization to Quadratic in Solid Mechanics in order to fit the discretization 
of Shell.

1 In the Model Builder window’s toolbar, click the Show button and select Discretization in 
the menu.

2 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

3 In the Settings window for Solid Mechanics, click to expand the Discretization section.

4 From the Displacement field list, choose Quadratic.

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundary 15 only.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 2, 3, 5, 6, 9, 13, 24, and 26 only.

Shell Connection 1
1 On the Physics toolbar, click Boundaries and choose Shell Connection.

2 Select Boundaries 10 and 23 only.

3 In the Settings window for Shell Connection, locate the Shell Connection section.

4 From the list, choose Solid Connection 1 (shell).

D E F I N I T I O N S

Create a step function in order to apply the concentration boundary condition 
progressively.

Step 1 (step1)
1 On the Home toolbar, click Functions and choose Global>Step.

2 In the Settings window for Step, locate the Parameters section.
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3 In the Location text field, type 0.5.

4 Click to expand the Smoothing section. In the Size of transition zone text field, type 1.

5 Click Plot.

TR A N S P O R T  O F  D I L U T E D  S P E C I E S  ( T D S )

1 In the Model Builder window, under Component 1 (comp1) click Transport of Diluted 

Species (tds).

2 In the Settings window for Transport of Diluted Species, locate the Domain Selection 
section.

3 From the Selection list, choose Mold Compound.

4 Locate the Transport Mechanisms section. Clear the Convection check box.

5 Click to expand the Discretization section. From the Concentration list, choose Quadratic.

Transport Properties 1
1 In the Model Builder window, under Component 1 (comp1)>Transport of Diluted Species 

(tds) click Transport Properties 1.

2 In the Settings window for Transport Properties, locate the Diffusion section.

3 In the Dc text field, type 4e-13[m^2/s].

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Transport of Diluted Species 

(tds) click Initial Values 1.

2 In the Settings window for Initial Values, locate the Initial Values section.

3 In the c text field, type cini.

4 In the Model Builder window, click Transport of Diluted Species (tds).

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 5 and 6 only.

Concentration 1
1 On the Physics toolbar, click Boundaries and choose Concentration.

2 Select Boundaries 8, 20, and 29 only.

3 In the Settings window for Concentration, locate the Concentration section.

4 Select the Species c check box.

5 In the c0,c text field, type cini+(cmax-cini)*step1(t[1/s]/3600).
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M U L T I P H Y S I C S

Add a multiphysics node to model hygroscopic swelling.

Hygroscopic Swelling 1 (hs1)
1 On the Physics toolbar, click Multiphysics and choose Domain>Hygroscopic Swelling.

2 In the Settings window for Hygroscopic Swelling, locate the Domain Selection section.

3 From the Selection list, choose Mold Compound.

4 Locate the Hygroscopic Swelling Properties section. In the cmo, ref text field, type cini.

D E F I N I T I O N S

1 In the Model Builder window, under Component 1 (comp1) right-click Definitions and 
choose Mass Properties.

2 In the Settings window for Mass Properties, locate the Source Selection section.

3 From the Selection list, choose Mold Compound.

4 Locate the Density section. From the Density source list, choose From physics interface.

M A T E R I A L S

Add a material for each domain and for the membrane.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>FR4 (Circuit Board).

4 Click Add to Selection in the window toolbar.

M A T E R I A L S

FR4 (Circuit Board) (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click FR4 (Circuit 

Board) (mat1).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose FR4.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Silicon.

3 Click Add to Selection in the window toolbar.
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M A T E R I A L S

Silicon (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Silicon (mat2).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Silicon.

4 Click Add to Selection in the window toolbar.

Silicon 1 (mat3)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Silicon 1 

(mat3).

2 In the Settings window for Material, type Silicon (membrane) in the Label text field.

3 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

4 From the Selection list, choose Membrane.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Silica glass.

3 Click Add to Selection in the window toolbar.

M A T E R I A L S

Silica glass (mat4)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Silica glass 

(mat4).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Glass.

5 On the Home toolbar, click Add Material to close the Add Material window.

Material 5 (mat5)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Mold Compound in the Label text field.

3 Locate the Geometric Entity Selection section. From the Selection list, choose Mold 

Compound.
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4 Locate the Material Contents section. In the table, enter the following settings:

M E S H  1

Mesh the membrane using a 2D mapped mesh.

Mapped 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Mapped.

2 In the Settings window for Mapped, locate the Boundary Selection section.

3 From the Selection list, choose Membrane.

Distribution 1
1 Right-click Component 1 (comp1)>Mesh 1>Mapped 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 10.

4 Locate the Edge Selection section. From the Selection list, choose All edges.

Free Triangular 1
1 In the Model Builder window, right-click Mesh 1 and choose More Operations>Free 

Triangular.

2 Select Boundaries 11 and 16 only.

Use a swept mesh in the wafer domain to avoid stress singularities near the solid-shell 
connection.

Swept 1
1 Right-click Mesh 1 and choose Swept.

2 In the Settings window for Swept, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Silicon.

Property Name Value Unit Property 
group

Young’s modulus E 22[GPa] Pa Basic

Poisson’s ratio nu 0.4 1 Basic

Density rho 1900 kg/m³ Basic

Coefficient of hygroscopic 
swelling

beta_h 1.1e-4 m³/kg Basic
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Distribution 1
1 Right-click Component 1 (comp1)>Mesh 1>Swept 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 From the Distribution properties list, choose Predefined distribution type.

4 In the Element ratio text field, type 5.

Convert rectangles to triangles on the exterior boundaries to enable tetraedral meshing.

Convert 1
1 In the Model Builder window, right-click Mesh 1 and choose More Operations>Convert.

2 In the Settings window for Convert, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundaries 17 and 27 only.

Free Tetrahedral 1
1 Right-click Mesh 1 and choose Free Tetrahedral.

2 In the Settings window for Free Tetrahedral, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Glass.

Add boundary layer meshing on the exterior faces in order to smooth the initial 
concentration discontinuity.

Boundary Layers 1
1 Right-click Mesh 1 and choose Boundary Layers.

2 In the Settings window for Boundary Layers, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Mold Compound.

Boundary Layer Properties
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1>Boundary Layers 1 

click Boundary Layer Properties.

2 Select Boundaries 8, 20, and 29 only.

3 In the Settings window for Boundary Layer Properties, locate the Boundary Layer 

Properties section.

4 In the Number of boundary layers text field, type 4.

5 In the Thickness adjustment factor text field, type 1.
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Swept 2
1 In the Model Builder window, right-click Mesh 1 and choose Swept.

2 In the Settings window for Swept, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose FR4.

Distribution 1
1 Right-click Component 1 (comp1)>Mesh 1>Swept 2 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 4.

4 Click Build All.

5 Click the Go to Default 3D View button on the Graphics toolbar.

S T U D Y  1

Step 1: Time Dependent
Since the moisture diffusion is independent of the structural behavior, compute only 
transport of diluted species in the time dependent analysis.

1 In the Model Builder window, under Study 1 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type 0 10^range(2,0.1,7.5).

4 Locate the Physics and Variables Selection section. In the table, clear the Solve for check 
box for Solid Mechanics (solid) and Shell (shell).

Prepare a plot to visualize the concentration during the computation.

Solution 1 (sol1)
On the Study toolbar, click Show Default Solver.

R E S U L T S

3D Plot Group 1
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Concentration in the Label text field.

Surface 1
1 Right-click Concentration and choose Surface.
20 |  M E M S  P R E S S U R E  S E N S O R  D R I F T  D U E  T O  H Y G R O S C O P I C  S W E L L I N G



2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1 (comp1)>Transport of 

Diluted Species>c - Concentration.

3 Click to expand the Range section. Select the Manual color range check box.

4 In the Minimum text field, type 40.

5 In the Maximum text field, type 140.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, under Study 1 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, click to expand the Results while solving 
section.

3 Locate the Results While Solving section. Select the Plot check box.

4 In the Model Builder window, click Study 1.

5 In the Settings window for Study, locate the Study Settings section.

6 Clear the Generate default plots check box.

7 On the Home toolbar, click Compute.

R E S U L T S

Concentration
1 In the Model Builder window, under Results click Concentration.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Time (s) list, choose 5.012E5.

4 On the Concentration toolbar, click Plot.

5 Click the Go to Default 3D View button on the Graphics toolbar.

1D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Concentration at Die Location in 
the Label text field.

Point Graph 1
1 On the Concentration at Die Location toolbar, click Point Graph.

2 Select Point 3 only.
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3 In the Settings window for Point Graph, click Replace Expression in the upper-right 
corner of the y-axis data section. From the menu, choose Component 1>Transport of 

Diluted Species>c - Concentration.

4 Locate the x-Axis Data section. From the Unit list, choose d.

Concentration at Die Location
1 In the Model Builder window, under Results click Concentration at Die Location.

2 In the Settings window for 1D Plot Group, locate the Axis section.

3 Select the x-axis log scale check box.

4 On the Concentration at Die Location toolbar, click Plot.

5 Locate the Plot Settings section. Select the x-axis label check box.

6 In the associated text field, type Time (days).

7 Click the Zoom Extents button on the Graphics toolbar.

1D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Mass Uptake in the Label text field.

Global 1
1 On the Mass Uptake toolbar, click Global.

2 In the Settings window for Global, locate the y-Axis Data section.

3 In the table, enter the following settings:

4 Locate the x-Axis Data section. From the Parameter list, choose Expression.

5 In the Expression text field, type sqrt(t[1/d]).

6 Select the Description check box.

7 In the associated text field, type (time)^(1/2) [d^(1/2)].

Mass Uptake
1 In the Model Builder window, under Results click Mass Uptake.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 Select the x-axis label check box.

4 In the associated text field, type Square Root of Time (days^1/2).

Expression Unit Description

(mass1.mass-at(0,
mass1.mass))/at(0,
mass1.mass)*100

1 relative mass uptake (%)
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5 Locate the Axis section. Select the Manual axis limits check box.

6 In the x minimum text field, type 0.

7 In the x maximum text field, type 15.

8 On the Mass Uptake toolbar, click Plot.

9 Click the Zoom Extents button on the Graphics toolbar.

Add a stationary study with a parametric sweep to compute the mechanical behavior.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies.

4 In the Select Study tree, select Preset Studies>Stationary.

5 Click Add Study in the window toolbar.

S T U D Y  2

Step 1: Stationary
1 On the Home toolbar, click Add Study to close the Add Study window.

2 In the Model Builder window, under Study 2 click Step 1: Stationary.

3 In the Settings window for Stationary, locate the Physics and Variables Selection section.

4 In the table, clear the Solve for check box for Transport of Diluted Species (tds).

5 Click to expand the Values of dependent variables section. Locate the Values of Dependent 

Variables section. Find the Values of variables not solved for subsection. From the Settings 
list, choose User controlled.

6 From the Method list, choose Solution.

7 From the Study list, choose Study 1, Time Dependent.

8 From the Time (s) list, choose All.

9 Click to expand the Study extensions section. Locate the Study Extensions section. Select 
the Auxiliary sweep check box.

10 Click Add.

11 In the table, enter the following settings:

Parameter name Parameter value list Parameter unit

t 0 10^range(2,0.1,7.5)
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Solution 2 (sol2)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 2 (sol2) node.

3 In the Model Builder window, expand the Study 2>Solver Configurations>Solution 2 

(sol2)>Stationary Solver 1 node.

4 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Stationary Solver 1 and 
choose Fully Coupled.

5 On the Study toolbar, click Compute.

Plot stress of solid and shell in the same plot group.

R E S U L T S

Surface 1
In the Model Builder window, expand the Results>Stress (shell) node.

Stress (solid)
1 Right-click Surface 1 and choose Copy.

2 In the Model Builder window, under Results click Stress (solid).

3 In the Settings window for 3D Plot Group, type Stress in the Label text field.

Surface 2
1 Right-click Results>Stress and choose Paste Surface.

2 In the Settings window for Surface, click to expand the Title section.

3 From the Title type list, choose None.

4 Click to expand the Inherit style section. Locate the Inherit Style section. From the Plot 
list, choose Surface 1.

Deformation
1 In the Model Builder window, expand the Results>Stress>Surface 1 node, then click 

Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 Select the Scale factor check box.

4 In the associated text field, type 600.

5 On the Stress toolbar, click Plot.

Stress (shell)
In the Model Builder window, under Results right-click Stress (shell) and choose Delete.
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R E S U L T S

Undeformed Geometry (shell)
1 In the Model Builder window, expand the Undeformed Geometry (shell) node.

2 Right-click Results>Undeformed Geometry (shell) and choose Delete.

R E S U L T S

Plot displacement of solid and shell in the same plot group.

Stress
In the Model Builder window, under Results right-click Stress and choose Duplicate.

Stress 1
In the Settings window for 3D Plot Group, type Displacement in the Label text field.

Surface 1
1 In the Model Builder window, expand the Results>Displacement node, then click Surface 

1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>

Displacement>solid.disp - Total displacement.

3 Locate the Expression section. From the Unit list, choose µm.

Surface 2
1 In the Model Builder window, under Results>Displacement click Surface 2.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Shell>Displacement>

shell.disp - Total displacement.

3 Locate the Expression section. From the Unit list, choose µm.

4 On the Displacement toolbar, click Plot.

5 Click the Go to Default 3D View button on the Graphics toolbar.

Displacement
1 In the Model Builder window, under Results click Displacement.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Time list, choose 5.012E5.

4 On the Displacement toolbar, click Plot.
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Plot the strain on the bottom face of the membrane. To do so, add 3D cut points on the 
x and y axes.

1D Plot Group 6
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Strain in the Label text field.

Cut Point 3D 1
1 On the Results toolbar, click Cut Point 3D.

2 In the Settings window for Cut Point 3D, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (sol2).

4 Locate the Point Data section. In the X text field, type l_memb/2-30[µm].

5 In the Y text field, type 0.

6 In the Z text field, type 0.

7 Select the Snap to closest boundary check box.

Cut Point 3D 2
1 On the Results toolbar, click Cut Point 3D.

2 In the Settings window for Cut Point 3D, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (sol2).

4 Locate the Point Data section. In the X text field, type 0.

5 In the Y text field, type l_memb/2-30[µm].

6 In the Z text field, type 0.

7 Select the Snap to closest boundary check box.

8 Click Plot.

Strain
In the Model Builder window, under Results click Strain.

Point Graph 1
1 On the Strain toolbar, click Point Graph.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Data set list, choose Cut Point 3D 1.

4 Locate the y-Axis Data section. In the Expression text field, type shell.eXX.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type t.
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7 From the Unit list, choose d.

8 Click to expand the Legends section. Select the Show legends check box.

9 From the Legends list, choose Manual.

10 In the table, enter the following settings:

Strain
In the Model Builder window, under Results click Strain.

Point Graph 2
1 On the Strain toolbar, click Point Graph.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Data set list, choose Cut Point 3D 2.

4 Locate the y-Axis Data section. In the Expression text field, type shell.eYY.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type t.

7 From the Unit list, choose d.

8 Locate the Legends section. Select the Show legends check box.

9 From the Legends list, choose Manual.

10 In the table, enter the following settings:

Strain
1 In the Model Builder window, under Results click Strain.

2 In the Settings window for 1D Plot Group, locate the Axis section.

3 Select the x-axis log scale check box.

4 Locate the Plot Settings section. Select the x-axis label check box.

5 In the associated text field, type time (days).

6 Click to expand the Legend section. From the Position list, choose Upper left.

7 On the Strain toolbar, click Plot.

Legends

XX strain on X axis

Legends

YY strain on Y axis
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Introduction

In stress analysis, it is common that the regions with high stresses are small when compared 
to the whole structure. Sometimes it is not feasible to have a mesh that at the same time 
captures the global behavior and resolves the stress concentrations with high accuracy. This 
is especially true in nonlinear or dynamic problems.

You can cope with this type of problems with a technique known as submodeling. First you 
solve the complete model with a mesh which is sufficient to capture the stiffness of the 
structure. In a second analysis you create a local model (submodel) of the region around 
the stress concentration with a fine mesh, and solve it using the displacements from the 
global model as boundary conditions.

There are some underlying assumptions when using submodels:

• The global model is accurate enough to give correct displacements on the boundary to 
the submodel.

• The improvements introduced in the submodel are so small that they do not introduce 
significant changes in stiffness on the global level. Given this, it could still be possible 
to introduce a nonlinear material locally in the submodel.

This example shows how to perform submodel analysis in COMSOL Multiphysics.

Model Definition

The wheel rim for this analysis is a ten-spoke example where the design elements of the 
geometry cause the finite element mesh to become quite large. The loading on the tire is 
composed of both the tire pressure and a load transferred from the road via the tire to the 
rim.
2 |  S U B M O D E L  I N  A  W H E E L  R I M



In the submodel (shown in Figure 1), you cut out a small region around the hot spot using 
an intersection between the rim geometry and a 70 mm-by-70 mm-by-60 mm block.

Figure 1: The submodel geometry.

M A T E R I A L

Aluminum with E = 70 GPa, ν = 0.33.

C O N S T R A I N T S

• A region around each bolt hole where the wheel is rim is attached to the wheel hub is 
fixed.

Cut surfaces with displacements mapped from global model
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L O A D S

• Tire pressure: The overpressure is 2 bar = 200 kPa.

Figure 2: Tire pressure distribution

• The total load carried by the wheel corresponds to a weight of 1120 kg. It is applied as 
a pressure on the rim surfaces where the tire is in contact. Assume that the load 
distribution in the circumferential direction can be approximated as p = p0cos(3ϑ), 
where ϑ is the angle from the point of contact between the road and the tire. The loaded 
area thus extends 30° in each direction from the peak of the load. Four different load 
cases are analyzed, where the center of the peak load is rotated 18° each time. In this 
way the whole load cycle for the rotating wheel can be covered. The load distribution 
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is shown in Figure 3.

Figure 3: Tire load when rotated 18° from the center of the first pair of spokes

• In the submodel, the stress history for a full revolution of the wheel is computed. This 
is possible, since results from different spokes are applied to the submodel sequentially.

Results and Discussion

The highest stresses occur in the fillet where the spoke connects to the hub. In the global 
model the maximum effective stress is completely mesh dependent, and not reliable. In the 
submodel, where the resolution is good, the effective stress is about 96 MPa. It occurs 
when the load is rotated 18° from the reference angle. In a fatigue analysis where the 
lifetime could vary as the fifth power of the stress it is essential to get this level of accuracy 
in the critical regions.
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Figure 4: Stresses in the global model.
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Figure 5: Stresses in the submodel at the load position giving the peak effective stress

Notes About the COMSOL Implementation

Two different components are used within the same mph file. In the global model, a 
general extrusion feature is introduced in order to describe the mapping of results from 
the global model to the submodel. The general extrusion is parametrized so that 
displacements form different spokes can be applied to the submodel.

The pressure distribution from the tire must be adjusted so that its resultant is the intended 
(about 11 kN). This can be done in different ways. One simple possibility is to run a 
separate analysis with the tire load as the only loadcase and use an arbitrary load amplitude. 
The total reaction force is then computed, and the load amplitude is rescaled based on the 
result. In this model a more sophisticated method is used: An extra Global Equation is 
added, in which the integral of the distribution load is set equal to the known force. Thus 
the load amplitude is solved simultaneously with the rest of the problem.

Application Library path: Structural_Mechanics_Module/Tutorials/
rim_submodel
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

pInflation 2[bar] 2E5 Pa Inflation pressure

tireLoad 1120[kg]*g_const 1.098E4 N Load on wheel

spokeNo 0 0 Spoke selection

spokeAngle spokeNo*2*pi[rad]/5 0 rad Rotation angle to 
selected spoke

phiLoad 0 0 Peak load angle

numLpos 4 4 Number of load 
positions in first 
sector

angleStep 360/(5*numLpos) 18 Step in peak load 
angle [deg]

angleLast angleStep*
(numLpos-1)

54 Last peak load angle 
[deg]
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G E O M E T R Y  1

1 On the Geometry toolbar, click Insert Sequence.

2 Browse to the application’s Application Libraries folder and double-click the file 
wheel_rim_geom_sequence.mph.

Form Composite Domains 1 (cmd1)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click Form 

Composite Domains 1 (cmd1) and choose Build Selected.

D E F I N I T I O N S

Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type TireAttachment in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 2–4 and 6 only.

Explicit 2
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type PressureSurface in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 2–6 only.

Explicit 3
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type FixedToHub in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 8–12 only.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Aluminum.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.
9 |  S U B M O D E L  I N  A  W H E E L  R I M



M A T E R I A L S

Aluminum (mat1)
In the Model Builder window’s toolbar, click the Show button and select Advanced Physics 

Options in the menu.

S O L I D  M E C H A N I C S  ( S O L I D )

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 In the Settings window for Fixed Constraint, locate the Boundary Selection section.

3 From the Selection list, choose FixedToHub.

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 In the Settings window for Boundary Load, locate the Boundary Selection section.

3 From the Selection list, choose PressureSurface.

4 Locate the Force section. From the Load type list, choose Pressure.

5 In the p text field, type pInflation.

D E F I N I T I O N S

Analytic 1 (an1)
1 On the Home toolbar, click Functions and choose Local>Analytic.

2 In the Settings window for Analytic, locate the Definition section.

3 In the Expression text field, type (abs(atan2(x,y)-z*pi/180)<pi/6)*cos(3*
(atan2(x,y)-z*pi/180)).

4 In the Arguments text field, type x, y, z.

5 Locate the Units section. In the Arguments text field, type m,m,1.

6 In the Function text field, type Pa.

7 In the Function name text field, type loadDistr.

Cylindrical System 2 (sys2)
On the Definitions toolbar, click Coordinate Systems and choose Cylindrical System.

S O L I D  M E C H A N I C S  ( S O L I D )

Boundary Load 2
1 On the Physics toolbar, click Boundaries and choose Boundary Load.
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2 In the Settings window for Boundary Load, locate the Coordinate System Selection 
section.

3 From the Coordinate system list, choose Cylindrical System 2 (sys2).

4 Locate the Boundary Selection section. From the Selection list, choose TireAttachment.

5 Locate the Force section. Specify the FA vector as

D E F I N I T I O N S

Integration 1 (intop1)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose TireAttachment.

S O L I D  M E C H A N I C S  ( S O L I D )

Global Equations 1
1 On the Physics toolbar, click Global and choose Global Equations.

2 In the Settings window for Global Equations, locate the Global Equations section.

3 In the table, enter the following settings:

4 Locate the Units section. Find the Source term quantity subsection. From the list, choose 
Force load (N).

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Tetrahedral.

-loadAmpl*loadDistr(X,Y,phiLoad) r

0 phi

0.2*loadAmpl*loadDistr(X,Y,phiLoad)*(2*(Z>0)-1) a

Name f(u,ut,utt,t) (1) Initial value 
(u_0) (1)

Initial value 
(u_t0) (1/s)

Description

loadAmpl loadAmpl*
intop1(loadDistr(
X,Y,0)*
cos(atan2(X,
Y)))-tireLoad

0 0
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Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. In the Maximum element size text field, type 
0.07.

5 In the Minimum element size text field, type 0.007.

6 In the Maximum element growth rate text field, type 1.8.

7 Click Build All.

S T U D Y  1

Step 1: Stationary
1 In the Settings window for Stationary, click to expand the Study extensions section.

2 Locate the Study Extensions section. Select the Auxiliary sweep check box.

3 Click Add.

4 In the table, enter the following settings:

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

Because of the model’s considerable size, you set up an iterative solver that can 
significantly save on the memory needed for the computations. Use the GMRES 
iterative solver with Geometric Multigrid as a preconditioner. By default, the solver 
lowers the order in the discretization of the displacement variables from the default 
quadratic elements to linear elements. Because the model geometry contains slender 
elements, use SOR Line as presmoother and postsmoother. SOR Line can handle 
slender geometries better than the SOR presmoother used by default. Note however 
that it cannot make full use of the matrix symmetry.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 Right-click Stationary Solver 1 and choose Iterative.

4 Right-click Study 1>Solver Configurations>Solution 1 (sol1)>Stationary Solver 1>Iterative 

1 and choose Multigrid.

Parameter name Parameter value list Parameter unit

phiLoad range(0,angleStep,angleLast)
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5 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 1>Iterative 1>Multigrid 1 node.

6 Right-click Presmoother and choose SOR Line.

7 Right-click Study 1>Solver Configurations>Solution 1 (sol1)>Stationary Solver 1>Iterative 

1>Multigrid 1>Postsmoother and choose SOR Line.

8 On the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
1 In the Model Builder window, click Stress (solid).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Parameter value (phiLoad) list, choose 0.

Surface 1
1 In the Model Builder window, under Results>Stress (solid) click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose MPa.

4 Click to expand the Range section. Select the Manual color range check box.

5 In the Minimum text field, type 0.

6 In the Maximum text field, type 90.

To get a better view of the region with the highest stresses (compare with Figure 4), rotate 
the geometry in the Graphics window and use the Zoom Box tool to obtain a close-up.

D E F I N I T I O N S

View 2
1 In the Model Builder window, under Component 1 (comp1)>Definitions click View 2.

2 In the Settings window for View, locate the View section.

3 Select the Lock camera check box.

R E S U L T S

Stress (solid)
1 In the Model Builder window, under Results click Stress (solid).

2 In the Settings window for 3D Plot Group, locate the Plot Settings section.

3 From the View list, choose View 2.
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4 In the Model Builder window, click Stress (solid).

5 In the Settings window for 3D Plot Group, locate the Plot Settings section.

6 From the View list, choose View 2.

7 On the Stress (solid) toolbar, click Plot.

Start creating the submodel.

R O O T

On the Home toolbar, click Add Component and choose 3D.

G E O M E T R Y  2

1 In the Model Builder window, under Component 2 (comp2) click Geometry 2.

2 On the Geometry toolbar, click Insert Sequence.

3 Browse to the application’s Application Libraries folder and double-click the file 
wheel_rim_geom_sequence.mph.

Form Composite Domains 1 (cmd1)
In the Model Builder window, under Component 2 (comp2)>Geometry 2 right-click Form 

Composite Domains 1 (cmd1) and choose Build Selected.

Rotate 1 (rot1)
In the Model Builder window, under Component 2 (comp2)>Geometry 2 right-click Rotate 1 

(rot1) and choose Disable.

Form Composite Domains 1 (cmd1)
In the Model Builder window, under Component 2 (comp2)>Geometry 2 right-click Form 

Composite Domains 1 (cmd1) and choose Build Selected.

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 6e-2.

4 In the Depth text field, type 7e-2.

5 In the Height text field, type 6e-2.

6 Locate the Position section. In the y text field, type 6.5e-2.

7 In the z text field, type 6e-2.

Intersection 1 (int1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Intersection.
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2 Click in the Graphics window and then press Ctrl+A to select both objects.

Form Composite Domains 1 (cmd1)
1 Right-click Form Composite Domains 1 (cmd1) and choose Build Selected.

2 Click the Zoom Extents button on the Graphics toolbar.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Aluminum.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

D E F I N I T I O N S

In the Model Builder window, under Component 1 (comp1) click Definitions.

General Extrusion 1 (genext1)
1 On the Definitions toolbar, click Component Couplings and choose General Extrusion.

2 In the Settings window for General Extrusion, type from_global in the Operator name 
text field.

3 Locate the Source Selection section. From the Selection list, choose All domains.

4 Locate the Source section. From the Source frame list, choose Material  (X, Y, Z).

5 Locate the Destination Map section. In the X-expression text field, type X*
cos(spokeAngle)-Y*sin(spokeAngle).

6 In the Y-expression text field, type Y*cos(spokeAngle)+X*sin(spokeAngle).

7 In the Z-expression text field, type Z.

8 Click to expand the Advanced section. From the Mesh search method list, choose Closest 

point.

C O M P O N E N T  2  ( C O M P 2 )

In the Model Builder window, click Component 2 (comp2).

A D D  P H Y S I C S

1 On the Home toolbar, click Add Physics to open the Add Physics window.

2 Go to the Add Physics window.

3 In the tree, select Structural Mechanics>Solid Mechanics (solid).
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4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Physics to close the Add Physics window.

S O L I D  M E C H A N I C S  2  ( S O L I D 2 )

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundary 3 only.

Prescribed Displacement 1
1 On the Physics toolbar, click Boundaries and choose Prescribed Displacement.

2 Select Boundaries 1 and 6–8 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in x direction check box.

5 In the u0x text field, type comp1.from_global(comp1.u*cos(spokeAngle)+
comp1.v*sin(spokeAngle)).

6 Select the Prescribed in y direction check box.

7 In the u0y text field, type comp1.from_global(comp1.v*
cos(spokeAngle)-comp1.u*sin(spokeAngle)).

8 Select the Prescribed in z direction check box.

9 In the u0z text field, type comp1.from_global(comp1.w).

M E S H  2

1 In the Model Builder window, under Component 2 (comp2) click Mesh 2.

2 In the Settings window for Mesh, locate the Mesh Settings section.

3 From the Element size list, choose Fine.

4 From the Sequence type list, choose User-controlled mesh.

Free Tetrahedral 1
In the Model Builder window, under Component 2 (comp2)>Mesh 2 right-click Free 
Tetrahedral 1 and choose Size.

Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 Select Boundary 5 only.
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4 Locate the Element Size section. From the Predefined list, choose Extremely fine.

5 Click Build All.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Find the Physics interfaces in study subsection. In the table, clear the Solve check box for 
the Solid Mechanics (solid) interface.

5 Click Add Study in the window toolbar.

6 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

Step 1: Stationary
1 In the Model Builder window, under Study 2 click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Values of dependent variables 
section.

Fetch the displacements from the solution of the global model.

3 Locate the Values of Dependent Variables section. Find the Values of variables not solved 

for subsection. From the Settings list, choose User controlled.

4 From the Method list, choose Solution.

5 From the Study list, choose Study 1, Stationary.

6 From the Parameter value (phiLoad) list, choose All.

7 Locate the Study Extensions section. Select the Auxiliary sweep check box.

8 From the Sweep type list, choose All combinations.

9 Click Add.

10 In the table, enter the following settings:

11 Click Add.

Parameter name Parameter value list Parameter unit

spokeNo
17 |  S U B M O D E L  I N  A  W H E E L  R I M



12 In the table, enter the following settings:

Solution 2 (sol2)
On the Study toolbar, click Show Default Solver.

Solution 2 (sol2)
1 In the Model Builder window, expand the Study 2>Solver Configurations>Solution 2 (sol2) 

node.

For the submodel, you also use an iterative solver with GMG as preconditioner. You 
select the Conjugate gradients solver because it can make full use of the matrix 
symmetry, thus saving memory.

2 In the Model Builder window, expand the Study 2>Solver Configurations>Solution 2 

(sol2)>Stationary Solver 1 node.

3 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Stationary Solver 1 and 
choose Iterative.

4 In the Settings window for Iterative, locate the General section.

5 From the Solver list, choose Conjugate gradients.

6 Right-click Study 2>Solver Configurations>Solution 2 (sol2)>Stationary Solver 1>Iterative 

1 and choose Multigrid.

7 In the Settings window for Multigrid, locate the General section.

8 In the Use hierarchy in geometries list, select Geometry 1.

9 Under Use hierarchy in geometries, click Delete.

S T U D Y  1

Solution 1 (sol1)
1 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1)>

Stationary Solver 1>Iterative 1 click Multigrid 1.

2 In the Settings window for Multigrid, locate the General section.

3 In the Use hierarchy in geometries list, select Geometry 2.

4 Under Use hierarchy in geometries, click Delete.

Avoid saving a lot of duplicate results for the full geometry.

Parameter name Parameter value list Parameter unit

spokeNo range(0,1,4)

phiLoad range(0,angleStep,angleLast)
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S T U D Y  2

Solution 2 (sol2)
1 In the Model Builder window, expand the Study 2>Solver Configurations>Solution 2 

(sol2)>Dependent Variables 1 node, then click Displacement field (Material) (comp1.u).

2 In the Settings window for Field, locate the General section.

3 Clear the Store in output check box.

4 In the Model Builder window, under Study 2>Solver Configurations>Solution 2 (sol2)>

Dependent Variables 1 click State variable loadAmpl (comp1.ODE1).

5 In the Settings window for State, locate the General section.

6 Clear the Store in output check box.

7 On the Study toolbar, click Compute.

R E S U L T S

Surface 1
1 In the Model Builder window, expand the Stress (solid2) node, then click Surface 1.

2 In the Settings window for Surface, locate the Expression section.

3 From the Unit list, choose MPa.

4 Locate the Range section. Select the Manual color range check box.

5 In the Minimum text field, type 0.

6 In the Maximum text field, type 90.

Stress (solid2)
1 In the Model Builder window, under Results click Stress (solid2).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Parameter value (spokeNo) list, choose 0.

4 From the Parameter value (phiLoad) list, choose 18.

Principal Stress Surface 1
1 On the Stress (solid2) toolbar, click More Plots and choose Principal Stress Surface.

2 In the Model Builder window, right-click Principal Stress Surface 1 and choose 
Deformation.

Principal Stress Surface 1
1 In the Model Builder window, under Results>Stress (solid2) click Principal Stress Surface 1.
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2 In the Settings window for Principal Stress Surface, click to expand the Inherit style 
section.

3 Locate the Inherit Style section. From the Plot list, choose Surface 1.

4 Clear the Arrow scale factor check box.

5 Clear the Color check box.

6 Clear the Color and data range check box.

Stress (solid2)
1 In the Model Builder window, under Results click Stress (solid2).

2 In the Settings window for 3D Plot Group, type Stress in Submodel in the Label text 
field.

Again, create a View 3D feature node for the plot

D E F I N I T I O N S

In the Model Builder window, under Component 2 (comp2) right-click Definitions and choose 
View.

View 4
1 In the Settings window for View, locate the View section.

2 Clear the Show grid check box.

In the graphics window rotate the model and capture the highest stressed part.

3 In the Model Builder window, click View 4.

4 In the Settings window for View, locate the View section.

5 Select the Lock camera check box.

Apply the view to 3D Plot Group 3.

R E S U L T S

Stress in Submodel
1 In the Model Builder window, under Results click Stress in Submodel.

2 In the Settings window for 3D Plot Group, locate the Plot Settings section.

3 From the View list, choose View 4.

4 On the Stress in Submodel toolbar, click Plot.

Finally, create an animation, showing the stress history for a complete revolution of the 
wheel.
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Animation 1
1 On the Results toolbar, click Animation and choose File.

2 In the Settings window for Animation, locate the Target section.

3 From the Target list, choose Player.

4 Locate the Scene section. From the Subject list, choose Stress in Submodel.

5 Locate the Animation Editing section. From the Loop over list, choose All solutions.

Replace next instruction with: In the Parameter values list, chose all values.

6 In the Parameter values (phiLoad,spokeNo) list, choose 1: phiLoad=0, spokeNo=0, 2: 

phiLoad=18, spokeNo=0, 3: phiLoad=36, spokeNo=0, 4: phiLoad=54, spokeNo=0, 5: 

phiLoad=0, spokeNo=1, 6: phiLoad=18, spokeNo=1, 7: phiLoad=36, spokeNo=1, 8: 

phiLoad=54, spokeNo=1, 9: phiLoad=0, spokeNo=2, 10: phiLoad=18, spokeNo=2, 11: 

phiLoad=36, spokeNo=2, 12: phiLoad=54, spokeNo=2, 13: phiLoad=0, spokeNo=3, 14: 

phiLoad=18, spokeNo=3, 15: phiLoad=36, spokeNo=3, 16: phiLoad=54, spokeNo=3, 17: 

phiLoad=0, spokeNo=4, 18: phiLoad=18, spokeNo=4, 19: phiLoad=36, spokeNo=4, and 20: 

phiLoad=54, spokeNo=4.

7 Locate the Frames section. From the Frame selection list, choose All.

8 Right-click Animation 1 and choose Play.

S T U D Y  1

Step 1: Stationary
1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Physics and Variables Selection section.

3 In the table, clear the Solve for check box for the Solid Mechanics 2 (solid2) interface.
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Introduction

High rotational speed in, for example, gas turbine machinery can result in centrifugal 
forces of considerable magnitude. This example studies the effects of such forces on the 
natural frequencies of the structure. 

The fictitious forces induced by the rotation give rise to two counteracting effects: 
stress-stiffening and spin-softening (or centrifugal softening). The former is caused by 
the stationary stress field created by the centrifugal force and acts to increase the stiffness 
of the body, and so increase its resonance frequencies. At the same time, any radial 
displacement away from the axis of rotation increases the centrifugal force, while motion 
toward the axis decreases it. This effect therefore tends to amplify any radial motion, which 
is the opposite of stiffening—hence spin-softening. Which mechanism is dominating 
depends on the shape of the particular mode.

In some rotating systems, Coriolis forces can also play an important role. These apparent 
forces split some natural modes of vibration into one co-rotating and one counter-rotating 
precessing mode. In particular, this happens for natural modes that include bending of the 
axis of rotation. For most modes of vibration, however, the Coriolis frequency shifts are 
small.

Model Definition

In the first part of the modeling, you conduct a modal analysis of a blade mounted on a 
rigid rotating cylinder. The rotational speed is 3000 rpm (100π rad/s) about the global 
y-axis. The goal is to compare the fundamental frequency in three cases:

• A basic modal analysis at 0 rpm, thus excluding any fictitious force effects.

• A modal analysis including stress-stiffening and spin-softening at 3000 rpm.

• A complete analysis also including Coriolis effects at 3000 rpm.

The result in the first two cases can be compared directly to an analytical reference 
solution. Once you are satisfied that the solutions are accurate in all cases, the second step 
proceeds to compute the first few natural frequencies for a large range of rotational speeds.

F I C T I T I O U S  F O R C E S  I N  R O T A T I N G  C O O R D I N A T E  S Y S T E M S

The spin-softening and Coriolis effects both ultimately arise because the standard form of 
the laws governing the deformation of solid objects only hold in inertial, that is, 
nonaccelerating, coordinate systems. When you build and simulate a model in a rotating 
coordinate system, you must extend the basic laws of motion to account for the 
acceleration of the system itself. 
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In COMSOL Multiphysics, you can model the frame acceleration effects by using the 
Rotating Frame domain feature.

In this particular case, the axis of rotation is the y-axis, see Figure 1. The only explicit 
boundary condition in the model is on the blade’s base, which is fixed to the axis.

S T R E S S - S T I F F E N I N G  A N D  N O N L I N E A R  E F F E C T S

To include the stress-stiffening effects in the model, you activate the large deformation 
option. This redefines the strain measure to include second-order terms, which make the 
strain-displacement relation nonlinear. The resulting strain measure is called Green strain. 

For the stress stiffening to have any effect on the natural frequencies, you must first solve 
for the stationary stresses from the centrifugal loading in a stationary analysis. Then you 
perform the modal analysis using the static solution as a linearization point.

Note that the spin-softening affects not only the modal solution but also adds a positive 
feedback to the stationary nonlinear solution. If the structure has a natural mode for which 
spin-softening dominates over the stress-stiffening effect, the natural frequency of this 
mode becomes zero for some rotational frequency. This means that the structure looses all 
stiffness, and that no stable solution exists for higher angular velocities. So if the nonlinear 
solver does not converge for a very fast rotation, it should come as no surprise.

M A T E R I A L  A N D  G E O M E T R I C A L  P R O P E R T I E S

The blade’s material and geometrical properties are given in the table below (see also 
Figure 1):

The approximate equation for the natural frequency in Ref. 1 does not include the 
Poisson’s ratio. To facilitate easy comparison, the Poisson’s ratio is set to zero in the 
modeling.

MATERIAL PROPERTIES GEOMETRIC PROPERTIES

E 221·109 Pa Young’s modulus r 10 in Cylinder radius

ν 0 Poisson’s ratio L 5 in Blade length

ρ 7850 kg/m3 Density d 0.0625 in Blade thickness

b 1 in Blade width
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Figure 1: Blade geometry.

A N A L Y T I C A L  S O L U T I O N S

You can compare COMSOL Multiphysics’ results to an accurate analytical approximation. 
Using Euler beam theory, which is sufficiently accurate for the present geometry, the 
fundamental angular frequency for the nonrotating case is given by

where E is the Young’s modulus, I is the area moment of inertia, m is the mass per unit 
length, and L is the blade length.

For a rotating blade attached to a rigid axis with radius r and rotating with angular 
frequency Ω, the fundamental angular frequency according to Ref. 1 is

This formula assumes a blade of uniform cross section slanted at the so-called stagger angle 
. In the present case, . The author states without proof that the Coriolis effect is 
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negligible. You can check the validity of this statement by comparing the finite element 
solutions with and without the Coriolis term included.

Results and Discussion

The following table shows a comparison between the analytical results and the results 
computed in COMSOL Multiphysics:

Apparently, the Coriolis effect is negligible as stated in Ref. 1. Because including the 
Coriolis terms makes the system of equations nonsymmetric—and therefore more 
expensive to solve—there is, in general, no need to include the Coriolis effect when 
modeling systems with a rigid axis.

Figure 2: Campbell diagram created from the parametric sweep output file. Notice the 
crossing modes, which are misinterpreted because of the sorting of the natural frequencies.

Table 0-1:  

CASE ANALYTICAL RESULT COMSOL RESULTS

0 rpm 84.4 Hz 84.4 Hz

3000 rpm, no Coriolis effect 123.6 Hz 124 Hz

3000 rpm, with Coriolis effect - 124 Hz
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The Campbell diagram, see Figure 2, shows that the first 6 natural frequencies all increase 
with increasing rotational speed. However, the balance between stress stiffening and spin 
softening is different for the different modes. Stress stiffening is more pronounced for 
modes 2 and 5 (referring to the mode order at zero rotational frequency) compared to the 
others. Therefore, the order of the modes in the result file—which is sorted on mode 
frequency—changes with increasing rotational velocity. 

Notes About the COMSOL Implementation

Note that the eigenvalue solver always finds the requested number of modes but not 
necessarily the ones with lowest eigenfrequencies. Sometimes it can converge on a 
higher-order mode instead. A jagged appearance of the highest frequency mode in the 
Campbell diagram is a result of the solver’s picking a higher mode instead of requested 
highest mode for some rotational frequencies. In order to avoid this behavior it is 
recommended to solve for one additional eigenfrequency in the study and display results 
for all eigenfrequencies except the one of the highest mode.

When eigenfrequencies are calculated, numerical noise can occasionally be seen via the 
imaginary part of the eigenfrequency. If the imaginary part is several orders of magnitude 
smaller than the real part then use the real part as the eigenfrequency and disregard the 
imaginary part. 

Reference

1. W. Carnegie, “Vibrations of Rotating Cantilever Blading,” J. Mech. Engrg Sci., vol. 1, 
no. 3, London, 1959.

Application Library path: Structural_Mechanics_Module/
Dynamics_and_Vibration/rotating_blade

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Prestressed Analysis, Eigenfrequency.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

Name Expression Value Description

Omega 0*pi[rad/s] 0 rad/s Angular velocity

L 5[in] 0.127 m Blade length

b 1[in] 0.0254 m Blade width

d 0.0625[in] 0.001588 m Blade thickness

E0 221[GPa] 2.21E11 Pa Young’s modulus

rho0 7850[kg/m^3] 7850 kg/m³ Density

r 10[in] 0.254 m Inner radius

mpl rho0*b*d 0.3165 kg/m Mass per unit length

I b*d^3/12 8.468E-12 m^4 Area moment of 
inertia

f_0 1.875^2*sqrt(E0*I/
(mpl*L^4))/(2*pi)

84.35 1/s Euler beam resonance 
frequency

f_ref f_0*sqrt(1+mpl*
Omega^2*r^4/(E0*I)*
((L/r)^3/8+(L/r)^4*
(1/10.6-1/12.45)))

84.35 rad/s Reference resonance 
frequency
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2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type L.

4 In the Depth text field, type b.

5 In the Height text field, type d.

6 Locate the Position section. In the x text field, type r.

7 In the z text field, type -d/2.

8 Right-click Block 1 (blk1) and choose Build Selected.

Form Union (fin)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click Form 

Union (fin) and choose Build Selected.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 Select Domain 1 only.

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

Rotating Frame 1
1 On the Physics toolbar, click Domains and choose Rotating Frame.

2 Select Domain 1 only.

3 In the Settings window for Rotating Frame, locate the Rotating Frame section.

4 From the Axis of rotation list, choose y-axis.

5 In the Ω text field, type Omega.

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

Property Name Value Unit Property group

Young’s modulus E E0 Pa Basic

Poisson’s ratio nu 0 1 Basic

Density rho rho0 kg/m³ Basic
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2 Select Boundary 1 only.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
More Operations>Mapped.

Mapped 1
1 Select Boundary 4 only.

2 Right-click Component 1 (comp1)>Mesh 1>Mapped 1 and choose Distribution.

Distribution 1
Select Edge 4 only.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 2
1 Select Edge 5 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 25.

Mapped 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Mapped 1.

2 In the Settings window for Mapped, click Build Selected.

3 In the Model Builder window, right-click Mesh 1 and choose Swept.

Swept 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Swept 1 and 
choose Distribution.

Distribution 1
1 Select Domain 1 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 4.

4 In the Model Builder window, click Mesh 1.
9 |  F U N D A M E N T A L  E I G E N F R E Q U E N C Y  O F  A  R O T A T I N G  B L A D E



5 In the Settings window for Mesh, click Build All.

S T U D Y  1

The default solver settings consists of a sequence of a stationary study step followed by an 
eigenfrequency analysis. COMSOL Multiphysics stores the solution from the stationary 
solver and uses it as the linearization point for the eigenfrequency analysis. Together with 
the fact that a geometrically nonlinear analysis is pre-selected, this ensures that effects of 
stress-stiffening and spin-softening are included in the calculated eigenfrequencies.

1 On the Home toolbar, click Compute.

R E S U L T S

Surface 1
The default plot shows the scaled deformation for the first mode of vibration for the 
nonrotating blade.

The first mode occurs at 84.4 Hz. This agrees well with the analytical solution, which you 
can compute as described below.

Global Evaluation 1
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Data section.
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3 From the Eigenfrequency selection list, choose First.

4 Click Replace Expression in the upper-right corner of the Expressions section. From the 
menu, choose Global Definitions>Parameters>f_ref - Reference resonance frequency.

5 Click Evaluate.

The table in the Table window shows that the analytical value of the first mode is also 
84.4 Hz.

Next, solve for the eigenfrequencies of the blade rotating at 3000 RPM.

G L O B A L  D E F I N I T I O N S

Parameters
1 In the Model Builder window, under Global Definitions click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Mode Shape (solid)
The default plot now shows the scaled deformation for the first mode of vibration when 
the blade is rotating at 3000 RPM. In this case the first eigenmode occurs at 124 Hz. This 
result clearly shows the effect of stress-stiffening.

Global Evaluation 1
1 In the Model Builder window, under Results>Derived Values click Global Evaluation 1.

2 In the Settings window for Global Evaluation, click Evaluate.

The table in the Table window shows that the analytical value of the first mode is 
123.6 Hz.

In the next section, you will also include the Coriolis effect and solve for the 
eigenfrequencies of the blade rotating at 3000 RPM.

Name Expression Value Description

Omega 100*pi[rad/s] 314.2 rad/s Angular velocity
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S O L I D  M E C H A N I C S  ( S O L I D )

Rotating Frame 1
1 In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 

Rotating Frame 1.

2 In the Settings window for Rotating Frame, locate the Rotating Frame section.

3 Select the Coriolis force check box.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Mode Shape (solid)
The default plot now shows the scaled deformation for the first mode of vibration when 
the blade is rotating at 3000 RPM. In this case the first eigenmode also occurs at 124 Hz. 
This result shows that enabling the Coriolis effect in the equations does not change the 
first natural frequency appreciably compared to the previous case.

In the next section, you perform a parametric study of the effect of rotational velocity and 
use the results to generate a Campbell diagram.

S O L I D  M E C H A N I C S  ( S O L I D )

Rotating Frame 1
1 In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 

Rotating Frame 1.

2 In the Settings window for Rotating Frame, locate the Rotating Frame section.

3 Clear the Coriolis force check box.

S T U D Y  1

Parametric Sweep
1 On the Study toolbar, click Parametric Sweep.

2 In the Settings window for Parametric Sweep, locate the Study Settings section.

3 Click Add.

4 In the table, enter the following settings:

Parameter name Parameter value list Parameter unit

Omega pi*range(0,50,1000)
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Step 2: Eigenfrequency
1 In the Model Builder window, under Study 1 click Step 2: Eigenfrequency.

2 In the Settings window for Eigenfrequency, locate the Study Settings section.

3 In the Search for eigenfrequencies around text field, type 1000.

Compute one additional eigenfrequency to avoid the possibility that the solver 
converges on a higher-order mode.

4 Select the Desired number of eigenfrequencies check box.

5 In the associated text field, type 7.

6 On the Study toolbar, click Compute.

R E S U L T S

Mode Shape (solid) 1
The default plot shows the scaled total displacement for the first mode for a rotational 
velocity of 30,000 RPM as a surface plot in Mode Shape (solid) 1. This mode occurs at a 
frequency of 723 Hz.

You can use the drop-down menu for Parameter value (Omega) and Eigenfrequency to 
find out the six lowest eigenfrequencies for each rotational velocity. A more elegant way 
to visualize this result is by creating a Campbell diagram.

1D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Data set list, choose Study 1/Parametric Solutions 1 (sol3).

4 From the Eigenfrequency selection list, choose Manual.

Display 6 lowest eigenfrequencies.

5 In the Eigenfrequency (Hz) (1-7) text field, type range(1,1,6).

6 Click to expand the Title section. From the Title type list, choose Manual.

7 In the Title text area, type Campbell diagram for the size lowest modes.

8 Locate the Plot Settings section. Select the x-axis label check box.

9 In the associated text field, type Rotational angular velocity [rad/s].

10 Select the y-axis label check box.

11 In the associated text field, type Natural frequency [Hz].

12 Locate the Axis section. Select the Manual axis limits check box.
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13 In the x minimum text field, type -100.

14 In the x maximum text field, type 4000.

15 In the y minimum text field, type 0.

16 In the y maximum text field, type 4500.

Global 1
1 On the 1D Plot Group 3 toolbar, click Global.

2 In the Settings window for Global, click Replace Expression in the upper-right corner of 
the y-axis data section. From the menu, choose Component 1>Solid Mechanics>Global>

solid.freq - Frequency.

3 Locate the x-Axis Data section. From the Axis source data list, choose Outer solutions.

4 Click to expand the Coloring and style section. Locate the Coloring and Style section. Find 
the Line style subsection. From the Line list, choose Cycle.

5 In the Width text field, type 4.

6 Click to expand the Legends section. From the Legends list, choose Manual.

7 In the table, enter the following settings:

1D Plot Group 3
1 In the Model Builder window, under Results click 1D Plot Group 3.

2 In the Settings window for 1D Plot Group, type Campbell diagram in the Label text 
field.

3 Click to expand the Legend section. From the Position list, choose Upper left.

4 On the Campbell diagram toolbar, click Plot.

Legends

Mode 1

Mode 2

Mode 3

Mode 4

Mode 5

Mode 6
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Created in COMSOL Multiphysics 5.2a
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Introduction

This example performs a static analysis on a piezoelectric actuator based on the movement 
of a cantilever beam, using the Piezoelectric Devices predefined multiphysics interface. 
Inspired by work done by V. Piefort (Ref. 1) and A. Benjeddou (Ref. 2), it models a 
sandwich beam using the shear mode of the piezoelectric material to deflect the tip.

Model Definition

G E O M E T R Y

The model consists of a 100-mm long sandwiched cantilever beam (Figure 1).

Figure 1: The shear bender geometry. Note that a piezoceramic material replaces part of 
the foam core.

This beam is composed of a 2-mm thick flexible foam core sandwiched by two 8-mm thick 
aluminum layers. Further, the device replaces part of the foam core with a 10-mm long 
piezoceramic actuator that is positioned between x = 55 mm and x = 65 mm. The 
cantilever beam is orientated along the global x-axis.

Piezoceramic

Foam

Aluminum
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B O U N D A R Y  C O N D I T I O N S

• Solid Mechanics: the cantilever beam is fixed at its surfaces at x = 0; all other surfaces 
are free.

• Electrostatics: The system applies a 20 V potential difference between the top and 
bottom surfaces of the piezoceramic domain (Figure 2). This gives rise to an electric 
field perpendicular to the poling direction (x direction) and thus induces a transverse 
shear strain.

Figure 2: Applied voltage through the piezoelectric material

M A T E R I A L  P R O P E R T I E S

The following table lists the material properties for the aluminum layers and the foam core:

Aluminum is available as a predefined material, whereas you must define the foam material 
manually.

PROPERTY ALUMINUM FOAM PIEZOCERAMIC

E 70 GPa 35.3 MPa -

ν 0.35 0.383 -

ρ 2700 kg/m3 32 kg/m3 7500 kg/m3
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The piezoceramic material in the actuator, PZT-5H, is already defined in the material 
library. Thus, you do not need to enter the components of the elasticity matrix, cE, the 
piezoelectric coupling matrix, e, or the relative permittivity matrix, εrS.

Results

The shear deformation of the piezoceramic core layer and the flexible foam layer induce a 
bending action. Figure 3 shows the resulting tip deflection. The model calculates this 
deflection as 83 nm, a result that agrees well with those of Ref. 1 and Ref. 2.

Figure 3: Tip deflection with the piezoceramic positioned at x = 60 mm.

Notes About the COMSOL Implementation

The matrix components for the piezoelectric material properties refer to a coordinate 
system, where the poling direction is the z direction. Because the poling direction of the 
piezoceramic actuator in this model is aligned with the x-axis, you need to use a local 
coordinate system in the material settings to rotate the piezoceramic material.

More specifically, you define a local coordinate system that is rotated 90 degrees about the 
global y-axis. Then, you use this coordinate system in the piezoelectric material settings to 
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rotate the material so that the polarization direction is aligned with the x-axis (Figure 4).

Figure 4: Definition of local coordinate system to define the piezoelectric orientation. The 
material is poled along the local x3 direction (blue arrow).

References

1. V. Piefort, Finite Element Modelling of Piezoelectric Active Structures, Ph.D. thesis, 
Université Libre de Bruxelles, Belgium, Dept. Mechanical Engineering and Robotics, 
2001.

2. A. Benjeddou, M.A. Trindade, and R. Ohayon, A Unified Beam Finite Element Model 
for Extension and Shear Piezoelectric Actuation Mechanisms, CNAM (Paris, France), 
Structural Mechanics and Coupled Systems Laboratory, 1997.

Application Library path: Structural_Mechanics_Module/
Piezoelectric_Effects/shear_bender
5 |  P I E Z O E L E C T R I C  S H E A R - A C T U A T E D  B E A M



Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Piezoelectric Devices.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 100.

4 In the Depth text field, type 30.

5 In the Height text field, type 18.

Block 2 (blk2)
1 Right-click Block 1 (blk1) and choose Build Selected.

2 On the Geometry toolbar, click Block.

3 In the Settings window for Block, locate the Size and Shape section.

4 In the Width text field, type 100.

5 In the Depth text field, type 30.

6 In the Height text field, type 2.

7 Locate the Position section. In the z text field, type 8.
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8 Click to expand the Layers section. Find the Layer position subsection. Select the Left 
check box.

9 Clear the Bottom check box.

10 In the table, enter the following settings:

11 Click Build All Objects.

12 Click the Zoom Extents button on the Graphics toolbar.

The model geometry is now complete.

13 Click the Transparency button on the Graphics toolbar.

The geometry in the Graphics window should now look like that in Figure 1.

14 Click the Transparency button on the Graphics toolbar.

D E F I N I T I O N S

Define a coordinate system whose third axis is aligned with the global x-axis, that is, the 
polarization direction of the piezoceramic material. Choose the second axis to be parallel 
to the global y-axis.

Base Vector System 2 (sys2)
1 On the Definitions toolbar, click Coordinate Systems and choose Base Vector System.

2 In the Settings window for Base Vector System, locate the Settings section.

3 Find the Base vectors subsection. In the table, enter the following settings:

Leave the other components at their default values. You will use this coordinate system 
in the piezoelectric material settings.

4 Find the Simplifications subsection. Select the Assume orthonormal check box.

E L E C T R O S T A T I C S  ( E S )

1 In the Model Builder window, under Component 1 (comp1) click Electrostatics (es).

2 In the Settings window for Electrostatics, locate the Domain Selection section.

Layer name Thickness (mm)

Layer 1 55

Layer 2 10

x y z

x1 0 0 -1

x3 1 0 0
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3 Click Clear Selection.

4 Select Domain 4 only.

S O L I D  M E C H A N I C S  ( S O L I D )

On the Physics toolbar, click Electrostatics (es) and choose Solid Mechanics (solid).

Piezoelectric Material 1
1 In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 

Piezoelectric Material 1.

2 In the Settings window for Piezoelectric Material, locate the Domain Selection section.

3 Click Clear Selection.

4 Select Domain 4 only.

5 Locate the Coordinate System Selection section. From the Coordinate system list, choose 
Base Vector System 2 (sys2).

M A T E R I A L S

For the aluminum layers, use a library material.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select MEMS>Metals>Al - Aluminum / Aluminium.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Al - Aluminum / Aluminium (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Al - Aluminum 

/ Aluminium (mat1).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 Click Clear Selection.

4 Select Domains 1 and 3 only.

For the foam core, specify the material properties by hand.

Material 2 (mat2)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.
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2 In the Settings window for Material, type Foam in the Label text field.

3 Select Domains 2 and 5 only.

Foam (mat2)
Locate the Material Contents section. In the table, enter the following settings:

A D D  M A T E R I A L

1 Go to the Add Material window.

The piezoceramic PZT-5H is available as a predefined material.

2 In the tree, select Piezoelectric>Lead Zirconate Titanate (PZT-5H).

3 Click Add to Component in the window toolbar.

M A T E R I A L S

Lead Zirconate Titanate (PZT-5H) (mat3)
1 In the Model Builder window, expand the Component 1 (comp1)>Materials>Foam (mat2) 

node, then click Component 1 (comp1)>Materials>Lead Zirconate Titanate (PZT-5H) 

(mat3).

2 Select Domain 4 only.

3 On the Home toolbar, click Add Material to close the Add Material window.

S O L I D  M E C H A N I C S  ( S O L I D )

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundaries 1, 4, and 7 only.

E L E C T R O S T A T I C S  ( E S )

In the Model Builder window, under Component 1 (comp1) click Electrostatics (es).

Electric Potential 1
1 On the Physics toolbar, click Boundaries and choose Electric Potential.

2 Select Boundary 16 only.

Property Name Value Unit Property group

Young’s modulus E 35.3[MPa] Pa Basic

Poisson’s ratio nu 0.383 1 Basic

Density rho 32 kg/m³ Basic
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3 In the Settings window for Electric Potential, locate the Electric Potential section.

4 In the V0 text field, type 20.

Ground 1
1 On the Physics toolbar, click Boundaries and choose Ground.

2 Select Boundary 17 only.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Swept.

Swept 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Swept 1 and 
choose Distribution.

Distribution 1
1 In the Settings window for Distribution, locate the Distribution section.

2 In the Number of elements text field, type 2.

3 Click Build All.

4 Click the Zoom Extents button on the Graphics toolbar.

The mesh consists of 198 hexahedral elements.
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S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Stress (solid)
Replace the default stress plot by displacement to reproduce the plot shown in Figure 3.

1 In the Model Builder window, under Results click Stress (solid).

2 In the Settings window for 3D Plot Group, type Displacement (solid) in the Label 
text field.

Surface 1
1 In the Model Builder window, expand the Results>Displacement (solid) node, then click 

Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>

Displacement>Displacement field (Material)>w - Displacement field, Z component.

3 Locate the Expression section. From the Unit list, choose nm.

4 On the Displacement (solid) toolbar, click Plot.

5 Click the Go to Default 3D View button on the Graphics toolbar.

Multislice 1
1 In the Model Builder window, expand the Electric Potential (es) node.

2 Right-click Multislice 1 and choose Delete.

Electric Potential (es)
In the Model Builder window, under Results right-click Electric Potential (es) and choose 
Surface.

Surface 1
1 In the Settings window for Surface, click Replace Expression in the upper-right corner of 

the Expression section. From the menu, choose Component 1>Electrostatics>Electric>V - 

Electric potential.

2 On the Electric Potential (es) toolbar, click Plot.

Zoom in to find a plot similar to Figure 2.

3 Click the Zoom In button on the Graphics toolbar.
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4 Click the Zoom Extents button on the Graphics toolbar.

Show the base vector that defines the polarization of the piezoelectric material, shown 
on Figure 4.

3D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type PZT coordinate system in the Label 
text field.

Coordinate System Volume 1
1 On the PZT coordinate system toolbar, click More Plots and choose Coordinate System 

Volume.

2 In the Settings window for Coordinate System Volume, locate the Coordinate System 
section.

3 From the Coordinate system list, choose Base Vector System 2 (sys2).

4 Locate the Positioning section. Find the x grid points subsection. From the Entry method 
list, choose Coordinates.

5 In the Coordinates text field, type 60.

6 Find the y grid points subsection. In the Points text field, type 1.

7 Find the z grid points subsection. In the Points text field, type 1.

8 On the PZT coordinate system toolbar, click Plot.
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Introduction

Several numerical algorithms exist to handle structural contact problems. The one used as 
default in COMSOL Multiphysics is based on the so-called Augmented Lagrangian 
method.

Alternatively, you can use the Penalty method. It is based on the penalty factor formulation 
related to the penetration of the solid parts in contact. In some cases, this approach can 
result in faster computations and provide smoother convergence when compared to the 
Augmented Lagrangian method. The penalty method is however not suitable if accurate 
values of the contact pressure are important.

In this example, the purpose of the contact modeling is only to transmit correct contact 
forces in a global sense into the model, which is a situation well suited for using the penalty 
method.

Model Definition

The mechanical problem consists of the insertion of a snap hook into its slot. The objective 
is to compute the force needed to place the hook in the slot and then to remove it.

The geometry is shown in Figure 1. Due to the symmetry, you can study only a half of the 
original snap hook geometry. 
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Figure 1: Geometry of the modeled half of the snap hook and locking mechanism.

M A T E R I A L  P R O P E R T I E S

The locking mechanism is made of steel. The hook is made of a modified nylon material; 
the material parameters are given in the following table:

Since the steel is much stiffer than the nylon, it can be treated as rigid. Therefore, you use 
a linear elastic material model for the hook and rigid domain material model for the 
locking mechanism. 

B O U N D A R Y  C O N D I T I O N S

• The locking mechanism is fixed.

A prescribed displacement boundary condition is applied at the bottom surface of the 
hook. The displacement in the x direction is gradually changed by using the parametric 
solver; the other two displacement components are zero.

• Two side boundaries within the xz plane use symmetry boundary conditions.

MATERIAL PARAMETER VALUE

Young’s modulus 10 GPa

Poisson’s ratio 0.35

Hook

Lock
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• All the other boundaries are free boundaries. However, several of them are selected as 
parts of a contact pair with the destination side being on the hook surface.

Results

Figure 2 shows that the maximum penetration is less than 8 microns during the entire 
analysis. This is a good accuracy when compared to the geometry size.

Figure 2: Evolution of the maximum penetration for all position of the hook.

Note that the penetration is not constant since the contact force varies depending on the 
position of the hook
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The maximum effective stress levels are found at parameter step 0.83, which is just before 
the hook enters the slot, see Figure 3.

Figure 3: The effective stress levels in the hook just before it enters the slot.
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Figure 4 shows the force required for the insertion and removal of the hook versus the 
parameter value. The hook is in its slot at the end of the simulation.

Figure 4: The mounting force as a function of the parameter step.

Application Library path: Structural_Mechanics_Module/
Contact_and_Friction/snap_hook_penalty

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.
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5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
snap_hook_penalty.mphbin.

5 Click Import.

Rotate 1 (rot1)
1 On the Geometry toolbar, click Transforms and choose Rotate.

2 Select the object imp1 only.

3 In the Settings window for Rotate, locate the Rotation Angle section.

4 In the Rotation text field, type 90.

5 Locate the Axis of Rotation section. From the Axis type list, choose Cartesian.

6 In the x text field, type 1.

7 In the z text field, type 0.

8 Right-click Rotate 1 (rot1) and choose Build Selected.

9 Click the Zoom Extents button on the Graphics toolbar.

Name Expression Value Description

Displ_max 4.6[mm] 0.0046 m Maximum hook displacement

disp 0 0 Prescribed hook displacement
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D E F I N I T I O N S

Contact Pair 1 (p1)
1 On the Definitions toolbar, click Pairs and choose Contact Pair.

2 Select Boundaries 4, 6, and 7 only.

3 In the Settings window for Pair, locate the Destination Boundaries section.

4 Select the Active toggle button.

5 Select Boundaries 14, 15, 20, 22, and 23 only.

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 In the Settings window for Material, locate the Material Contents section.

2 In the table, enter the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

Rigid Domain 1
1 On the Physics toolbar, click Domains and choose Rigid Domain.

2 Select Domain 1 only.

3 Right-click Rigid Domain 1 and choose Fixed Constraint.

Prescribed Displacement 1
1 On the Physics toolbar, click Boundaries and choose Prescribed Displacement.

2 Select Boundary 30 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in x direction check box.

5 Select the Prescribed in y direction check box.

6 Select the Prescribed in z direction check box.

Property Name Value Unit Property group

Young’s modulus E 10[GPa] Pa Basic

Poisson’s ratio nu 0.35 1 Basic

Density rho 1150[kg/m^3] kg/m³ Basic
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7 In the u0x text field, type -disp.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 5, 13, and 19 only.

Contact 1
1 On the Physics toolbar, in the Boundary section, click Pairs and choose Contact.

2 In the Settings window for Contact, locate the Pair Selection section.

3 In the Pairs list, select Contact Pair 1 (p1).

4 Locate the Contact Pressure Method section. From the list, choose Penalty.

5 Locate the Penalty Factor section. In the pn text field, type solid.cnt1.E_char/
solid.hmin_dst/10.

M E S H  1

Add a structured mesh on the contact destination boundaries.

Mapped 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Mapped.

2 Select Boundaries 14, 15, 20, 22, and 23 only.

Distribution 1
1 Right-click Component 1 (comp1)>Mesh 1>Mapped 1 and choose Distribution.

2 Select Edges 27, 28, 39, and 48 only.

3 In the Settings window for Distribution, locate the Distribution section.

4 In the Number of elements text field, type 10.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 2
1 Select Edges 31 and 45 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 4.

4 Click Build Selected.

Convert the quad mesh to triangles so that the rest of the geometry can be meshed 
using the free tetrahedral method.
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Convert 1
1 In the Model Builder window, right-click Mesh 1 and choose More Operations>Convert.

2 In the Settings window for Convert, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundaries 14, 15, 20, 22, and 23 only.

5 Click Build Selected.

Free Tetrahedral 1
1 Right-click Mesh 1 and choose Free Tetrahedral.

2 In the Settings window for Free Tetrahedral, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domains 2 and 3 only.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Tetrahedral 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 Click the Custom button.

4 Locate the Element Size Parameters section. Select the Maximum element size check box.

5 In the associated text field, type 4e-4.

Free Tetrahedral 1
Right-click Free Tetrahedral 1 and choose Size.

Size 2
Refine the mesh on boundary where high stresses are expected.

1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 Select Boundary 25 only.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 1e-4.

7 Click Build Selected.

As the groove is modeled as rigid, you only need to represent the surface that is in 
contact with the hook accurately.
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Free Triangular 1
1 In the Model Builder window, right-click Mesh 1 and choose More Operations>Free 

Triangular.

2 Select Boundary 2 only.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Triangular 1 and choose Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Extremely coarse.

Free Triangular 1
Right-click Free Triangular 1 and choose Distribution.

Distribution 1
1 Select Edges 5 and 13 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 10.

4 Click Build Selected.

5 In the Model Builder window, right-click Mesh 1 and choose Swept.

Swept 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Swept 1 and 
choose Distribution.

Distribution 1
1 In the Settings window for Distribution, locate the Distribution section.

2 In the Number of elements text field, type 1.

3 Click Build All.

S T U D Y  1

Step 1: Stationary
Set up an auxiliary continuation sweep for the disp parameter.

1 In the Model Builder window, under Study 1 click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study extensions section.

3 Locate the Study Extensions section. Select the Auxiliary sweep check box.

4 Click Add.
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5 In the table, enter the following settings:

6 Click to expand the Results while solving section. Locate the Results While Solving section. 
Select the Plot check box.

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Stationary Solver 1 node, then click Parametric 1.

4 In the Settings window for Parametric, click to expand the Continuation section.

5 From the Predictor list, choose Linear.

6 On the Study toolbar, click Compute.

R E S U L T S

Global Evaluation 1
1 On the Results toolbar, click Global Evaluation.

2 In the Settings window for Global Evaluation, locate the Expressions section.

3 In the table, enter the following settings:

4 Click Evaluate.

TA B L E

1 Go to the Table window.

2 Click the right end of the Display Table 1 - Global Evaluation 1 (solid.gapmin_p1*

(solid.gapmin_p1<0)) split button in the window toolbar.

3 From the menu, choose Table Graph.

Parameter name Parameter value list Parameter unit

disp range(0.2,1e-2,1)*Displ_max

Expression Unit Description

solid.gapmin_p1*
(solid.gapmin_p1<0)

um Minimum gap distance
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R E S U L T S

Surface Integration 1
1 On the Results toolbar, click More Derived Values and choose Integration>Surface 

Integration.

2 Select Boundary 30 only.

3 In the Settings window for Surface Integration, locate the Expressions section.

4 In the table, enter the following settings:

5 Click Evaluate.

TA B L E

1 Go to the Table window.

2 Click the right end of the Display Table 1 - Global Evaluation 1 (solid.gapmin_p1*

(solid.gapmin_p1<0)) split button in the window toolbar.

3 From the menu, choose Table Graph.

Expression Unit Description

-2*solid.RFx N Total force
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Introduction

This example model consists of a two-hot-arm thermal actuator made of polysilicon. The 
actuator is activated through thermal expansion. The temperature increase required to 
deform the two hot arms, and thus displace the actuator, is obtained through Joule heating 
(resistive heating). The greater expansion of the hot-arms, compared to the cold arm, 
causes a bending of the actuator.

The material properties of polysilicon are temperature dependent, which means that the 
involved physics phenomena are fully coupled. The electric current through the hot arms 
increases the temperature in the actuator, which in turn causes thermal expansion and 
changes the electrical conductivity of the material.

The actuator’s operation thus involves three coupled physics phenomena: electric current 
conduction, heat conduction with heat generation, and structural stresses and strains due 
to thermal expansion.

Model Definition

Figure 1 shows the actuator’s parts and dimensions as well as its position on top of a 
substrate surface.

Figure 1: The thermal microactuator.

Hot arms

Dimple AnchorsCold arm

Substrate

Upper surface

2 μm

3 μm

240 μm
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B O U N D A R Y  C O N D I T I O N S  A N D  C O N S T R A I N T S

An electric potential is applied between the bases of the hot arms’ anchors. The cold arm 
anchor and all other surfaces are electrically insulated.

Figure 2: Electrical boundary conditions.

The temperature of the base of the three anchors and the three dimples is fixed to that of 
the substrate’s constant temperature. Because the structure is sandwiched, all other 
boundaries interact thermally with the surroundings by conduction through thin layers of 
air. This can be implemented as thermal contact conditions or “Convective heat flux” 
condition where the heat flux coefficient represent one over the thermal resistance. In this 
model we chose to use a heat flux condition. The heat transfer coefficient is given by the 
thermal conductivity of air divided by the distance to the surrounding surfaces for the 
system. This exercise uses different heat transfer coefficients for the actuator’s upper and 
other surfaces.

Figure 3: Heat-transfer boundary conditions.

Applied voltage

Ground

Fixed temperature

Fixed temperature

Fixed temperature

Heat flux⊥= h(T-Tamb)
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All three arms are mechanically fixed at the base of the three anchors. The dimples can 
move freely in the plane of the substrate (the xy-plane in the figure) but do not move in 
the direction perpendicular to the substrate (the z direction).

Figure 4: Structural boundary conditions and constraints.

Results

Figure 5 shows the surface temperature distribution for the actuator. It also illustrates the 
displacement field through a deformation plot.

Figure 5: Temperature (surface) and displacement (deformation).

Fixed

Fixed

Roller
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Application Library path: Structural_Mechanics_Module/
Thermal-Structure_Interaction/thermal_actuator_tem_parameterized

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Joule Heating and Thermal 

Expansion.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

C O M P O N E N T  1  ( C O M P 1 )

1 In the Model Builder window, right-click Component 1 (comp1) and choose Rename.

2 In the Rename Component dialog box, type Thermal Actuator in the New label text 
field.

3 Click OK.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.
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3 In the table, enter the following settings:

G E O M E T R Y  1

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

2 In the Model Builder window, right-click Work Plane 1 (wp1) and choose Build Selected.

3 In the Settings window for Work Plane, click Show Work Plane.

Rectangle 1 (r1)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type L3.

4 In the Height text field, type dw.

Name Expression Value Description

d 3[um] 3E-6 m Height of the hot 
arm

dw 15[um] 1.5E-5 m Height of the cold 
arm

gap 3[um] 3E-6 m Gap between arms

wb 10[um] 1E-5 m Width of the base

wv 25[um] 2.5E-5 m Difference in 
length between hot 
arms

L 240[um] 2.4E-4 m Actuator length

L1 L-wb 2.3E-4 m Length of the 
longest hot arm

L2 L-wb-wv 2.05E-4 m Length of the 
shortest hot arm

L3 L-2*wb-wv-L/48-L/6 1.5E-4 m Length of the cold 
arm, thick part

L4 L/6 4E-5 m Length of the cold 
arm, thin part

htc_s 0.04[W/(m*K)]/
2[um]

2E4 W/(m²·K) Heat transfer 
coefficient

htc_us 0.04[W/(m*K)]/
100[um]

400 W/(m²·K) Heat transfer 
coefficient, upper 
surface

DV 5[V] 5 V Applied voltage
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5 Locate the Position section. In the xw text field, type L-L3.

6 Right-click Rectangle 1 (r1) and choose Build Selected.

Rectangle 2 (r2)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type L4.

4 In the Height text field, type d.

5 Locate the Position section. In the xw text field, type L-L3-L4.

6 In the yw text field, type dw-d.

7 Right-click Rectangle 2 (r2) and choose Build Selected.

8 Click the Zoom Extents button on the Graphics toolbar.

Rectangle 3 (r3)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type wb.

4 In the Height text field, type dw.

5 Locate the Position section. In the xw text field, type L-L3-L4-wb.

6 Right-click Rectangle 3 (r3) and choose Build Selected.

7 Click the Zoom Extents button on the Graphics toolbar.

Rectangle 4 (r4)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type L2.

4 In the Height text field, type d.

5 Locate the Position section. In the xw text field, type L-L2.

6 In the yw text field, type dw+gap.

7 Right-click Rectangle 4 (r4) and choose Build Selected.

Rectangle 5 (r5)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type wb.
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4 In the Height text field, type dw+gap+d.

5 Locate the Position section. In the xw text field, type L-L2-wb.

6 Right-click Rectangle 5 (r5) and choose Build Selected.

7 Click the Zoom Extents button on the Graphics toolbar.

Rectangle 6 (r6)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type L1.

4 In the Height text field, type d.

5 Locate the Position section. In the xw text field, type L-L1.

6 In the yw text field, type dw+d+2*gap.

7 Right-click Rectangle 6 (r6) and choose Build Selected.

8 Click the Zoom Extents button on the Graphics toolbar.

Rectangle 7 (r7)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type wb.

4 In the Height text field, type dw+gap+d.

5 Locate the Position section. In the yw text field, type dw+d+2*gap.

6 Right-click Rectangle 7 (r7) and choose Build Selected.

7 Click the Zoom Extents button on the Graphics toolbar.

Rectangle 8 (r8)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type d.

4 In the Height text field, type gap.

5 Locate the Position section. In the xw text field, type L-d.

6 In the yw text field, type dw+gap+d.

7 Right-click Rectangle 8 (r8) and choose Build Selected.

Rectangle 9 (r9)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.
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2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type d.

4 In the Height text field, type gap.

5 Locate the Position section. In the xw text field, type L-d.

6 In the yw text field, type dw.

7 Right-click Rectangle 9 (r9) and choose Build Selected.

Union 1 (uni1)
1 On the Work Plane toolbar, click Booleans and Partitions and choose Union.

2 Click in the Graphics window and then press Ctrl+A to select all objects.

3 In the Settings window for Union, locate the Union section.

4 Clear the Keep interior boundaries check box.

5 Right-click Union 1 (uni1) and choose Build Selected.

Fillet 1 (fil1)
1 On the Work Plane toolbar, click Fillet.

2 In the Settings window for Fillet, locate the Radius section.

3 In the Radius text field, type d/3.

4 On the object uni1, select Points 1, 2, 4–9, 11–14, 16, 17, 19–23, and 28 only.
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5 Right-click Fillet 1 (fil1) and choose Build Selected.

Work Plane 1 (wp1)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 click Work Plane 

1 (wp1).

Extrude 1 (ext1)
1 On the Geometry toolbar, click Extrude.

2 In the Settings window for Extrude, locate the Distances from Plane section.

3 In the table, enter the following settings:

4 Right-click Extrude 1 (ext1) and choose Build Selected.

5 Click the Go to Default 3D View button on the Graphics toolbar.

Work Plane 2 (wp2)
1 On the Geometry toolbar, click Work Plane.

2 In the Model Builder window, right-click Work Plane 2 (wp2) and choose Build Selected.

3 In the Settings window for Work Plane, click Show Work Plane.

Plane Geometry
Click the Zoom Extents button on the Graphics toolbar.

Rectangle 1 (r1)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type wb-2*d.

4 In the Height text field, type 2.5*(wb-2*d).

5 Locate the Position section. In the xw text field, type d.

6 In the yw text field, type (dw+d+2*gap)+(dw+gap+d)-2.5*(wb-2*d)-d.

7 Right-click Rectangle 1 (r1) and choose Build Selected.

Rectangle 2 (r2)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type wb-2*d.

Distances (m)

2e-6
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4 In the Height text field, type 2.5*(wb-2*d).

5 Locate the Position section. In the xw text field, type L-L2-wb+d.

6 In the yw text field, type d.

7 Right-click Rectangle 2 (r2) and choose Build Selected.

Rectangle 3 (r3)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type wb-2*d.

4 In the Height text field, type 2.5*(wb-2*d).

5 Locate the Position section. In the xw text field, type L-L3-L4-wb+d.

6 In the yw text field, type d.

7 Right-click Rectangle 3 (r3) and choose Build Selected.

Fillet 1 (fil1)
1 On the Work Plane toolbar, click Fillet.

2 In the Settings window for Fillet, locate the Radius section.

3 In the Radius text field, type d/3.

4 Select all four vertices for all three rectangles as follows:

5 Click the Select Box button on the Graphics toolbar.

6 In the Graphics window, draw a box encompassing the three rectangles you just created, 
then right-click to confirm the selection.

7 Right-click Fillet 1 (fil1) and choose Build Selected.

Circle 1 (c1)
1 On the Work Plane toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type d/2.

4 Locate the Position section. In the xw text field, type L-L3/4.

5 In the yw text field, type dw/2.

6 Right-click Circle 1 (c1) and choose Build Selected.

Circle 2 (c2)
1 On the Work Plane toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.
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3 In the Radius text field, type d/2.

4 Locate the Position section. In the xw text field, type L-L3/2.

5 In the yw text field, type dw/2.

6 Right-click Circle 2 (c2) and choose Build Selected.

Circle 3 (c3)
1 On the Work Plane toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type d/2.

4 Locate the Position section. In the xw text field, type L-3*L3/4.

5 In the yw text field, type dw/2.

6 Right-click Circle 3 (c3) and choose Build Selected.

Work Plane 2 (wp2)
In the Model Builder window, under Thermal Actuator (comp1)>Geometry 1 click Work Plane 

2 (wp2).

Extrude 2 (ext2)
1 On the Geometry toolbar, click Extrude.

2 In the Settings window for Extrude, locate the Distances from Plane section.

3 In the table, enter the following settings:

4 Select the Reverse direction check box.

Union 1 (uni1)
1 Right-click Extrude 2 (ext2) and choose Build Selected.

2 On the Geometry toolbar, click Booleans and Partitions and choose Union.

3 Click the Zoom Extents button on the Graphics toolbar.

4 Click in the Graphics window and then press Ctrl+A to select both objects.

5 In the Settings window for Union, click Build All Objects.

D E F I N I T I O N S

Explicit 1
1 On the Definitions toolbar, click Explicit.

Distances (m)

2e-6
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2 In the Settings window for Explicit, locate the Input Entities section.

3 From the Geometric entity level list, choose Boundary.

4 Select Boundaries 10, 30, 50, 70, 76, and 82 only.

5 Right-click Explicit 1 and choose Rename.

6 In the Rename Explicit dialog box, type substrate contact in the New label text field.

7 Click OK.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select MEMS>Semiconductors>Si - Polycrystalline Silicon.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

M A T E R I A L S

Si - Polycrystalline Silicon (mat1)
By default, the first material you add applies on all domains so you can keep the Geometric 

Entity Selection settings.

1 In the Model Builder window, under Thermal Actuator (comp1)>Materials click Si - 
Polycrystalline Silicon (mat1).

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundaries 10, 30, and 50 only.

Roller 1
1 On the Physics toolbar, click Boundaries and choose Roller.

2 Select Boundaries 70, 76, and 82 only.

Property Name Value Unit Property 
group

Electrical conductivity sigma 5e4 S/m Basic
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H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, under Thermal Actuator (comp1) click Heat Transfer in Solids 

(ht).

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

This boundary condition applies to all boundaries except the top-surface boundary and 
those in contact with the substrate. A Temperature condition on the substrate 
contact boundaries will override this Heat Flux condition so you do not explicitly need 
to exclude those boundaries. In contrast, because the Heat Flux boundary condition is 
additive, you must explicitly exclude the top-surface boundary from the selection. 
Implement this selection as follows:

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose All boundaries.

4 In the Graphics window, click on the top surface and then right-click to remove it from 
the selection.

A convective heat flux is used to model the heat flux through a thin air layer. The heat 
transfer coefficient, htc_s is defined as the ratio of the air thermal conductivity to the 
gap thickness.

5 Locate the Heat Flux section. Click the Convective heat flux button.

6 In the h text field, type htc_s.

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundary 4 only.

A convective heat flux is used to model the heat flux through a thin air layer. The heat 
transfer coefficient, htc_us is defined as the ratio of the air thermal conductivity to the 
gap thickness.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 In the h text field, type htc_us.

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 In the Settings window for Temperature, locate the Boundary Selection section.

3 From the Selection list, choose substrate contact.
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E L E C T R I C  C U R R E N T S  ( E C )

In the Model Builder window, under Thermal Actuator (comp1) click Electric Currents (ec).

Ground 1
1 On the Physics toolbar, click Boundaries and choose Ground.

2 Select Boundary 10 only.

Electric Potential 1
1 On the Physics toolbar, click Boundaries and choose Electric Potential.

2 Select Boundary 30 only.

3 In the Settings window for Electric Potential, locate the Electric Potential section.

4 In the V0 text field, type DV.

M E S H  1

In the Model Builder window, under Thermal Actuator (comp1) right-click Mesh 1 and 
choose Free Tetrahedral.

Free Tetrahedral 1
In the Model Builder window, under Thermal Actuator (comp1)>Mesh 1 right-click Free 
Tetrahedral 1 and choose Size.

Size
1 In the Settings window for Size, locate the Element Size section.

2 From the Predefined list, choose Fine.

3 Click the Custom button.

4 Locate the Element Size Parameters section. In the Maximum element growth rate text 
field, type 1.2.

This setting makes the mesh more robust for parametric sweeps over the geometry 
length parameter L.

Size 1
1 In the Model Builder window, under Thermal Actuator (comp1)>Mesh 1>Free Tetrahedral 

1 click Size 1.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Finer.

4 Locate the Geometric Entity Selection section. From the Geometric entity level list, choose 
Boundary.

5 Select Boundaries 86–91 only.
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6 Click Build All.

S T U D Y  1

Step 1: Stationary
1 In the Settings window for Stationary, locate the Study Settings section.

2 Select the Include geometric nonlinearity check box.

3 On the Home toolbar, click Compute.

R E S U L T S

Temperature (ht)
1 Click the Go to Default 3D View button on the Graphics toolbar.

The second default plot shows the temperature field.
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Introduction

A tonpilz transducer, such as the one shown in Figure 1, is used for relatively low 
frequency, high power sound emission. It is one of the popular transducer configurations 
for SONAR applications. The transducer consists of piezoceramic rings stacked between a 
head mass and a tail mass which are connected by a central bolt. This example shows how 
to incorporate the effect of a pre-tension in the bolt. The bolt geometry is imported from 
the Part Libraries. The frequency response of the transducer is studied to determine 
structural and acoustic response of the device such as deformation, stresses, radiated 
power, sound pressure level, the transmitting voltage response (TVR) curve, and the 
directivity index (DI) of the sound beam.

Figure 1: A tonpilz transducer. The aluminum head mass is shown in dark gray, the central 
steel bolt and steel tail mass are shown in light gray and the piezostack actuator with four disks 
of PZT-4 is shown in green.

Note: This application requires both the Acoustics Module and the Structural Mechanics 
Module.

A different version of this tutorial entitled Piezoelectric Tonpilz Transducer, is available 
in the Application Libraries under Acoustics Module only. That version of the tutorial does 
not implement the pre-tension in the bolt and hence does not require the Structural 
Mechanics Module. For additional details related to different customized settings and 
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user-defined variables used in both the tonpilz transducer models, you are encouraged to 
read the documentation of the Piezoelectric Tonpilz Transducer tutorial.

Model Definition

The basic working principle involved in the operation of this transducer is that an AC 
electrical signal applied to the piezostack actuator produces vibration in the entire 
transducer which in turn produces sound waves in the surrounding fluid. Thus modeling 
the operation of the transducer requires coupling electrical, structural and acoustic 
phenomena.

In this tutorial we will particularly emphasize on the implementation of pre-tension in the 
central bolt of the transducer and associated solver settings that allow us to model the 
effect of prestress on the frequency response characteristics of the transducer.

The parameters used in this model are shown in Table 1.

P H Y S I C S  I M P L E M E N T A T I O N

The Acoustic-Piezoelectric Interaction, Frequency Domain multiphysics interface 
available in the Acoustics Module is used for simulating the multiphysics interactions. This 
predefined interface includes the necessary fundamental physics which are Pressure 
Acoustics, Solid Mechanics and Electrostatics. The Pressure Acoustics interface is used to 
solve for the wave equation in the water domain. The Solid Mechanics physics is solved on 
all structural materials including the PZT-4 disks. The Electrostatics physics is solved on 
the PZT-4 disks. The multiphysics couplings necessary to model this system are available 
as predefined nodes under the Multiphysics branch. These couplings are:

TABLE 1:  LIST OF MODELING PARAMETERS

NAME EXPRESSION DESCRIPTION

Rwater 40[mm] Water domain radius

Rpml 10[mm] PML layer thickness

a 25[mm] Piston head radius

Zeval -10[m] Directivity evaluation distance

Vrms 1[V] RMS drive voltage

V0 sqrt(2)*Vrms Zero-to-peak drive voltage

f0min 1[kHz] Minimum operating frequency

f0max 40[kHz] Maximum operating frequency

f0step 1[kHz] Frequency step

F_pre 1[kN] Bolt pre-stress force
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Acoustic-Structure Boundary: This node is active on the boundaries that are at the 
interface of the water domain and transducer head mass. On these boundaries a 
bidirectional coupling is automatically set up. The fluid pressure evaluated by the Pressure 
Acoustics physics is applied as a mechanical load in the Solid Mechanics physics. 
Furthermore, the normal component of the structural acceleration is used as a sound 
source.

Piezoelectric Effect: This node is active on the PZT-4 domains only and couple the Solid 
Mechanics and Electrostatics equations solved in these domains via the linear constitutive 
equations that model the piezoelectric effect by coupling stresses and strains with electric 
field and electric displacement.

B O U N D A R Y  S E T T I N G S

The outer curved surface of the steel tail mass is assumed to be fixed. Each of the piezo 
disks are excited with a 1 V RMS electrical signal. 

The head mass is exposed to an unbounded region of water. A Perfectly Matched Layer 
(PML) is used to model the absorption of sound waves as they propagate far away from 
the sound source. Although PML is strictly not a boundary condition, it is used to imitate 
the effect of an open boundary.

A far-field calculation is set up on the interface boundaries between the inner water domain 
and the PML domains. The far-field integral type is set to Full integral which allows 
computation of both amplitude and phase of the acoustic pressure and sound pressure 
level (SPL) at any point in space outside the computational domain. The far field pressure 
variable is used to compute the TVR and DI.

The user-defined variables used to compute the transducer characteristics are shown in 
Table 2.

TABLE 2:  LIST OF VARIABLES

NAME EXPRESSION DESCRIPTION

rho0 intop3(acpr.rho) Density of water at room 
temperature

c0 intop3(acpr.c) Speed of sound in water at 
room temperature

Zaco intop2(p)/intop2(acpr.iomega*(w+eps))/
(rho0*c0)

Specific acoustic impedance

pfar_1 pfar(0,0,-1) Far field pressure at 1 m

prms sqrt(0.5*pfar_1*conj(pfar_1))[Pa] RMS pressure at 1 m
4 |  P I E Z O E L E C T R I C  TO N P I L Z  TR A N S D U C E R  W I T H  A  P R E S T R E S S E D  B O L T



M O D E L I N G  A  B O L T  W I T H  P R E - T E N S I O N

When a bolt is mounted on a device to clamp the components, it is tightened by twisting 
the bolt head. As a reaction to the tightening process, a pre-tension force is experienced 
by the bolt. This force produces a prestress that helps to hold the bolt in place during 
regular operation of the device. This also ensures that when additional stresses develop in 
the bolt during operation of the device, it should not become loose. Note that the 
tightening of the bolt also produces stresses in materials that are touching the bolt. This is 
why accounting for the pre-tension force in the bolt would give us an accurate picture of 
the pre-stress distribution not only in the bolt but also in the entire device.

COMSOL’s Structural Mechanics Module provides a Bolt Pre-Tension feature that can 
be used to implement a desired pre-tension or prestress in bolted joints. You can import 
the bolt geometry from the Part Libraries. These bolt geometries are created in a certain 
way so that we can directly use the Bolt Pre-Tension feature on them. In order to use this 
feature, there should be a cross section surface passing through the shank of the bolt. This 
surface needs to be associated with the Bolt Selection subnode under the Bolt Pre-Tension 
node. COMSOL sets up an additional equation for each bolt that computes the 
pre-deformation of the bolt, the pre-tension force as well as the shear force in the bolt. For 
example, in this model, on application of 1 kN pre-tension, we get a pre-deformation of 
12 μm.

TVR 20*log10(prms/Vrms/1[uPa/V]) Transmitting Voltage 
Response (TVR)

pfar_Zeval pfar(0,0,Zeval[1/m]) Far field pressure at Zeval

Ifront 0.5*pfar_Zeval*conj(pfar_Zeval)[Pa^2]/
(rho0*c0)

On-axis intensity at Zeval

Ptot intop1(down(acpr.Ix)*acpr.nx+
down(acpr.Iy)*acpr.ny+down(acpr.Iz)*
acpr.nz)

Total radiated power

Iave Ptot/(4*pi*Zeval^2) Average intensity of 
monopole source at Zeval

Di Ifront/Iave Intensity directivity

DI 10*log10(Di) Directivity index of Tonpilz 
transducer

k0 2*pi*freq/c0 Wave number

DI_fl_pist 10*log10((k0*a)^2/(1-2*besselj(1,2*k0*
a)/(2*k0*a)))

Directivity index of flanged 
piston

TABLE 2:  LIST OF VARIABLES

NAME EXPRESSION DESCRIPTION
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Note that the deformation along the longitudinal axis of the bolt is discontinuous at the 
surface assigned to the Bolt Selection subnode but the stresses and strains are continuous. 
For more details on implementation of the Bolt Pre-Tension feature, you can refer to the 
section on Using Pre-tensioned Bolts in the Structural Mechanics Module User’s Guide.

As a result of the prestress in the device, if we want to solve a vibrations problem in 
frequency domain, we need to account for the fact that the harmonic variation of stress 
and other physical quantities during vibration takes place on top of the static bias stress. 
Hence we need to solve this model using a two-step approach where the first step involves 
solving for the static stress distribution using a Stationary study step. The solution from 
this step is then used as a linearization point for solving the vibration problem in Frequency 
Domain Perturbation study step.

Note that this workflow is valid only for small perturbations about the static solution. 
Hence we should only use this technique if the magnitude of the stress and other physical 
quantities from the frequency domain problem is significantly smaller than the magnitude 
of the same quantities obtained from the static problem.

The AC voltage signal applied to the piezostack actuator is specified using the linper() 
operator. This operator ensures that the numerical input is used only in the Frequency 
Domain, Perturbation step and not in the Stationary step when solving the model. 
Furthermore, when solving the vibrations problem in frequency domain, you only want to 
account for the stress generated in the device as a result of its operation and hence you do 
not want to solve the pre-deformation variable in the bolt. This is ensured by changing the 
solver settings for the frequency domain part and instructing the solver to not solve for the 
pre-deformation variable.
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Results and Discussion

Figure 2: A slice plot showing the z-component of the prestress in the central bolt and other parts 
of the transducer. This stress arises due to the pre-tension in the bolt.

Figure 2 shows the z-component of the prestress in the transducer. The prestress is fairly 
uniform in the bolt. Note that the prestress exists mainly in the shank of the bolt and in 
the central part of the Aluminum head mass which is located directly below the bolt. 
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Figure 3: A slice plot showing the total acoustic pressure variation in the water domain at 
40 kHz.

Figure 3 shows the total acoustic pressure in the water domain for 40 kHz excitation. The 
inner water domain in the model captures roughly half a wavelength at this frequency. 
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Figure 4: A slice plot showing the variation in sound pressure level (in dB) in the water 
domain at 40 kHz.

Figure 4 shows the sound pressure level (SPL) in the water domain for 40 kHz excitation. 
The SPL is highest near the transducer head mass. The variation in the SPL around the 
transducer would depend on the operating frequency and the dominant mode in which 
the transducer vibrates.
9 |  P I E Z O E L E C T R I C  TO N P I L Z  TR A N S D U C E R  W I T H  A  P R E S T R E S S E D  B O L T



Figure 5: Total structural displacement of the transducer at 40 kHz. An exaggerated 
deformation has been used for better visualization.

Figure 5 shows the total structural displacement of the tonpilz transducer at 40 kHz 
excitation. At this frequency, the head mass vibrates in a mode whose shape is somewhat 
toroidal. If you observe the vibration mode for relatively lower frequencies, say 1 kHz, you 
will observe that the head mass vibrates mainly along its axis similar to a flanged piston.
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Figure 6: A multislice plot of the electric potential distribution within the four PZT-4 disks.

Figure 6 shows the electric potential distribution through the thickness of the PZT-4 
disks. The piezoelectric disks are stacked in a way such that alternate disks are poled along 
opposite directions. This allows us to use a single electrical terminal at the interface of each 
pair of disks and obtain the piezoelectric actuation effect in each of the disks along the 
same direction. Having the piezoelectric strain in-phase in all the disks maximizes the 
actuation.

In this model, the PZT-4 disks actuate in the d33-mode. Hence two of the disks are poled 
along the +Z-direction while the other two are poled along the -Z-direction. The default 
definition of the piezoelectric material properties in COMSOL’s Global Coordinate 
System automatically creates a +Z polarization. In order to create a -Z polarization, a 
user-defined Rotated Coordinate System is used. In this coordinate system, the Euler 
angles are set to α = 0, β = π and γ = 0.
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Figure 7: Frequency response plot of the absolute value, real and imaginary components of the 
specific acoustic impedance at the interface between the head mass and water.

Figure 7 shows the frequency response of the specific acoustic impedance of the head mass 
surface that is exposed to water. A resonance and anti-resonance is observed within the 
frequency range of 20 kHz and 35 kHz.
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Figure 8: Transmitting Voltage Response (TVR) as a function of frequency obtained at an 
on-axis distance of 1 m ahead of the head mass and computed relative to 1 μPa/V.

Figure 8 shows the variation in the TVR of the transducer as a function of operating 
frequency. The fairly flat region between 15 kHz and 25 kHz can be particularly useful for 
sensing applications.
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Figure 9: Frequency response of the Directivity Index (DI) computed at an on-axis distance of 
10 m from the head mass. The DI of the tonpilz transducer is compared to that of a flanged 
piston.

Figure 9 shows the Directivity Index (DI) of the tonpilz transducer (blue curve) and 
compares it with the DI of a flanged piston (green curve). The latter can be computed 
from analytical expression as shown in Table 2. It is defined by the variable DI_fl_pist. 
Note that when the tonpilz transducer operates like a piston at lower frequencies, its DI 
becomes very similar to that of a flanged piston. Another feature worth noting is that 
within the range of 15 kHz and 25 kHz, the DI of the tonpilz transducer changes from 
nearly 4 dB to 11 dB while its TVR remains nearly constant. This can make the transducer 
quite versatile within this operating range.
14 |  P I E Z O E L E C T R I C  TO N P I L Z  TR A N S D U C E R  W I T H  A  P R E S T R E S S E D  B O L T



Figure 10: Total radiated power from the tonpilz transducer within the operating frequency 
range of 1 kHz to 40 kHz.

Figure 10 shows the total radiated power as a function of the operating frequency of the 
tonpilz transducer. Since the radiated power is proportional to the sound intensity, the 
peak in power at around 8 kHz and 34 kHz also indicate that peak sound intensity is 
obtained at these frequencies.

Application Library path: Structural_Mechanics_Module/
Piezoelectric_Effects/tonpilz_transducer_prestressed

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.
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M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Acoustics>Acoustic-Structure Interaction>

Acoustic-Piezoelectric Interaction, Frequency Domain.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Prestressed 

Analysis, Frequency Domain.

6 Click Done.

G E O M E T R Y  1

1 In the Model Builder window, click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Parameters
1 On the Home toolbar, click Parameters.

Import the file containing the model parameters.

G L O B A L  D E F I N I T I O N S

Parameters
1 In the Settings window for Parameters, locate the Parameters section.

2 Click Load from File.

3 Browse to the application’s Application Libraries folder and double-click the file 
tonpilz_transducer_prestressed_parameters.txt.

Work Plane 1 (wp1)
1 On the Geometry toolbar, click Work Plane.

The modeling geometry is created by first drawing the cross section on a workplane and 
then revolving this cross section to get the 3-dimensional geometry. The central bolt in 
the transducer is later added from the Part Libraries.

G E O M E T R Y  1

Work Plane 1 (wp1)
1 In the Settings window for Work Plane, locate the Plane Definition section.

2 From the Plane list, choose xz-plane.
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3 Click Show Work Plane.

Rectangle 1 (r1)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 6.

4 In the Height text field, type 10.

5 Locate the Position section. In the xw text field, type 2.

6 In the yw text field, type 15.

Rectangle 2 (r2)
1 On the Work Plane toolbar, click Primitives and choose Rectangle.

2 In the Settings window for Rectangle, locate the Size and Shape section.

3 In the Width text field, type 2.

4 In the Height text field, type 8.

5 Locate the Position section. In the xw text field, type 4.

6 In the yw text field, type 7.

7 Click to expand the Layers section. In the table, enter the following settings:

Polygon 1 (pol1)
1 On the Work Plane toolbar, click Primitives and choose Polygon.

2 In the Settings window for Polygon, locate the Coordinates section.

3 In the xw text field, type 0 0 2 2 20 a.

4 In the yw text field, type 0 5 5 7 7 0.

Circle 1 (c1)
1 On the Work Plane toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type Rwater+Rpml.

4 In the Sector angle text field, type 90.

5 Locate the Rotation Angle section. In the Rotation text field, type -90.

Layer name Thickness (mm)

Layer 1 2

Layer 2 2

Layer 3 2
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6 Click to expand the Layers section. In the table, enter the following settings:

7 On the Work Plane toolbar, click Build All.

8 Click the Zoom Extents button on the Graphics toolbar.

9 Click Close.

Work Plane 1 (wp1)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Work Plane 1 

(wp1).

Revolve 1 (rev1)
1 On the Geometry toolbar, click Revolve.

2 In the Settings window for Revolve, locate the Revolution Angles section.

3 Click the Angles button.

4 In the End angle text field, type 90.

5 Locate the Selections of Resulting Entities section. Select the Resulting objects selection 
check box.

Explicit Selection 1 (sel1)
1 Right-click Revolve 1 (rev1) and choose Build Selected.

2 On the Geometry toolbar, click Selections and choose Explicit Selection.

Create domain and boundary selections that will be used in the model.

3 In the Settings window for Explicit Selection, type Water domain - Inner in the Label 
text field.

4 On the object rev1, select Domain 2 only.

Explicit Selection 2 (sel2)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Water domain - PML in the Label 
text field.

3 On the object rev1, select Domain 1 only.

Explicit Selection 3 (sel3)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Aluminum in the Label text field.

Layer name Thickness (mm)

Layer 1 Rpml
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3 On the object rev1, select Domain 3 only.

Explicit Selection 4 (sel4)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Steel Part in the Label text field.

3 On the object rev1, select Domain 4 only.

4 Locate the Resulting Selection section. Click New.

5 Clear the Keep selection check box.

6 In the New Cumulative Selection dialog box, type Steel in the Name text field.

7 Click OK.

Explicit Selection 5 (sel5)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type +Z poled Piezo in the Label text 
field.

3 On the object rev1, select Domains 5 and 7 only.

Explicit Selection 6 (sel6)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type -Z poled Piezo in the Label text 
field.

3 On the object rev1, select Domains 6 and 8 only.

Explicit Selection 7 (sel7)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Ground boundaries in the Label text 
field.

3 Locate the Entities to Select section. From the Geometric entity level list, choose 
Boundary.

4 Click the Wireframe Rendering button on the Graphics toolbar.

5 On the object rev1, select Boundaries 19, 25, and 29 only.

Explicit Selection 8 (sel8)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Voltage boundaries in the Label 
text field.
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3 Locate the Entities to Select section. From the Geometric entity level list, choose 
Boundary.

4 On the object rev1, select Boundaries 22 and 28 only.

Explicit Selection 9 (sel9)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Fixed boundaries in the Label text 
field.

3 Locate the Entities to Select section. From the Geometric entity level list, choose 
Boundary.

4 On the object rev1, select Boundary 36 only.

Explicit Selection 10 (sel10)
1 On the Geometry toolbar, click Selections and choose Explicit Selection.

2 In the Settings window for Explicit Selection, type Far Field boundaries in the Label 
text field.

3 Locate the Entities to Select section. From the Geometric entity level list, choose 
Boundary.

4 On the object rev1, select Boundary 6 only.

Rotate 1 (rot1)
1 On the Geometry toolbar, click Transforms and choose Rotate.

2 In the Settings window for Rotate, locate the Input section.

3 From the Input objects list, choose Revolve 1.

4 Locate the Rotation Angle section. In the Rotation text field, type range(0,90,270).

5 Locate the Selections of Resulting Entities section. Select the Resulting objects selection 
check box.

6 Click Build All Objects.

Union 1 (uni1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Union.

The following Union operation combines all the geometry objects created so far. This 
step ensures that when later on an Assembly option is used for finalizing the geometry 
sequence, the process does not create additional and unnecessary boundaries at the 
interface of all the geometry objects.

2 In the Settings window for Union, locate the Union section.
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3 From the Input objects list, choose Rotate 1.

The CAD geometry of a simple bolt with no thread is imported from the Part Libraries. 
The design parameters of the bolt are adjusted to position the bolt in the tonpilz 
transducer.

P A R T  L I B R A R I E S

1 On the Geometry toolbar, click Parts and choose Part Libraries.

2 In the Part Libraries window, select Structural Mechanics Module>Bolts>simple bolt no 

thread in the tree.

3 click Add to Geometry.

G E O M E T R Y  1

Simple Bolt, No Thread 1 (pi1)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Simple Bolt, 

No Thread 1 (pi1).

2 In the Settings window for Part Instance, locate the Input Parameters section.

3 In the table, enter the following settings:

4 Locate the Position and Orientation of Output section. Find the Coordinate system in part 
subsection. From the Work plane in part list, choose Head inner plane (wp1).

5 Find the Displacement subsection. In the zw text field, type 25.

6 Click to expand the Domain selections section. Locate the Domain Selections section. 
Click to select row number 1 in the table.

7 In the table, enter the following settings:

8 Click to expand the Boundary selections section. Locate the Boundary Selections section. 
Click to select row number 5 in the table.

Name Expression Value Description

hdia 8[mm] 8 mm Head diameter

hthic 2[mm] 2 mm Head thickness

ndia 4[mm] 4 mm Nominal diameter

blen 20[mm] 20 mm Bolt length

Name Contribute to Keep Physics

All csel1
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9 In the table, enter the following settings:

10 Right-click Component 1 (comp1)>Geometry 1>Simple Bolt, No Thread 1 (pi1) and choose 
Build Selected.

The geometry finalization method is changed to Form an Assembly to ensure that the 
bolt is not glued or rigidly attached to the adjacent parts.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Form Union 

(fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly 
section.

3 From the Action list, choose Form an assembly.

4 Select the Create imprints check box.

5 On the Geometry toolbar, click Build All.

D E F I N I T I O N S

An Identity Pair is used to get continuity in solution between the external surfaces of the 
bolt and the surfaces of other materials touching them. This continuity in solution is 
applicable for the lower end of the shank that is bolted into the aluminum head mass and 
the lower surface of the bolt head which is resting on the steel tail mass. The outer surface 
of the shank should be allowed to slip through the hole in the tail mass. Hence those 
boundaries need to be removed from the Identity Pair by modifying the default Identity 
Pair that has been created.

1 In the Model Builder window, expand the Component 1 (comp1)>Definitions node, then 
click Identity Pair 1 (ap1).

2 In the Settings window for Pair, locate the Pair Type section.

3 Select the Manual control of selections check box.

4 Locate the Source Boundaries section. Select the Active toggle button.

Name Contribute to Keep Physics

Exterior none

Shank none

Head, free surface none

Head, contact surface none

Pre-tension cut none
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5 Click Clear Selection.

6 Click Paste Selection.

7 In the Paste Selection dialog box, type 59-66 71 72 75 76 112-114 126-129 135 
160 163 164 167 in the Selection text field.

8 Click OK.

9 In the Settings window for Pair, locate the Destination Boundaries section.

10 Select the Active toggle button.

11 Click Clear Selection.

12 Click Paste Selection.

13 In the Paste Selection dialog box, type 174 175 178 183 185-188 196 198 206 207 
216 219 220 230-232 245 249 251 255 256 259 in the Selection text field.

14 Click OK.

15 In the Settings window for Pair, locate the Destination Boundaries section.

16 Click Create Selection.

17 In the Create Selection dialog box, type Destination boundaries in the Selection name 
text field.

18 Click OK.

Union 1
1 On the Definitions toolbar, click Union.

Create additional domain selections that will be used in the model.

2 In the Settings window for Union, type Water domains in the Label text field.

3 Locate the Input Entities section. Under Selections to add, click Add.

4 In the Add dialog box, In the Selections to add list, choose Water domain - Inner and 
Water domain - PML.

5 Click OK.

Union 2
1 On the Definitions toolbar, click Union.

2 In the Settings window for Union, type Piezo domains in the Label text field.

3 Locate the Input Entities section. Under Selections to add, click Add.

4 In the Add dialog box, In the Selections to add list, choose +Z poled Piezo and -Z poled 

Piezo.

5 Click OK.
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Complement 1
1 On the Definitions toolbar, click Complement.

2 In the Settings window for Complement, type Solid domains in the Label text field.

3 Locate the Input Entities section. Under Selections to invert, click Add.

4 In the Add dialog box, select Water domains in the Selections to invert list.

5 Click OK.

Complement 2
1 On the Definitions toolbar, click Complement.

2 In the Settings window for Complement, type Non-PML domains in the Label text field.

3 Locate the Input Entities section. Under Selections to invert, click Add.

4 In the Add dialog box, select Water domain - PML in the Selections to invert list.

5 Click OK.

Integration 1 (intop1)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

Define an integration coupling operator on the far-field boundary.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Far Field boundaries.

Integration 2 (intop2)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

Define an integration coupling operator on the acoustic-structure interface.

2 In the Settings window for Integration, locate the Source Selection section.

3 From the Geometric entity level list, choose Boundary.

4 Click Paste Selection.

5 In the Paste Selection dialog box, type 14 15 87 125 in the Selection text field.

6 Click OK.

Integration 3 (intop3)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

Define an integration coupling operator to retrieve values at the summit point of the 
water domain.

2 In the Settings window for Integration, locate the Source Selection section.
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3 From the Geometric entity level list, choose Point.

4 Click Paste Selection.

5 In the Paste Selection dialog box, type 58 in the Selection text field.

6 Click OK.

Variables 1
1 On the Definitions toolbar, click Local Variables.

Import the file containing the variable definitions. These variables will mainly be used 
for post-processing calculations.

2 In the Settings window for Variables, locate the Variables section.

3 Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
tonpilz_transducer_prestressed_variables.txt.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Water, liquid.

4 Click Add to Component 1.

M A T E R I A L S

Water, liquid (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Water, liquid 

(mat1).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Water domains.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Aluminum.

3 Click Add to Component 1.
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M A T E R I A L S

Aluminum (mat2)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Aluminum 

(mat2).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Aluminum.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Built-In>Steel AISI 4340.

3 Click Add to Component 1.

M A T E R I A L S

Steel AISI 4340 (mat3)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Steel AISI 4340 

(mat3).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Steel.

A D D  M A T E R I A L

1 Go to the Add Material window.

2 In the tree, select Piezoelectric>Lead Zirconate Titanate (PZT-4).

3 Click Add to Component 1.

M A T E R I A L S

Lead Zirconate Titanate (PZT-4) (mat4)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Lead Zirconate 

Titanate (PZT-4) (mat4).

2 In the Settings window for Material, locate the Geometric Entity Selection section.

3 From the Selection list, choose Piezo domains.

4 On the Home toolbar, click Add Material to close the Add Material window.

P R E S S U R E  A C O U S T I C S ,  F R E Q U E N C Y  D O M A I N  ( A C P R )

1 In the Model Builder window, under Component 1 (comp1) click Pressure Acoustics, 

Frequency Domain (acpr).
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2 In the Settings window for Pressure Acoustics, Frequency Domain, locate the Domain 

Selection section.

3 From the Selection list, choose Water domains.

4 Locate the Sound Pressure Level Settings section. From the Reference pressure for the 

sound pressure level list, choose Use reference pressure for water.

5 Locate the Typical Wave Speed for Perfectly Matched Layers section. In the cref text field, 
type 1500[m/s].

Far-Field Calculation 1
1 On the Physics toolbar, click Boundaries and choose Far-Field Calculation.

2 In the Settings window for Far-Field Calculation, locate the Boundary Selection section.

3 From the Selection list, choose Far Field boundaries.

4 Locate the Far-Field Calculation section. Select the Symmetry in the z=0 plane check box.

5 From the Type of integral list, choose Full integral.

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the Domain Selection section.

3 From the Selection list, choose Solid domains.

Piezoelectric Material 1
1 In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 

Piezoelectric Material 1.

2 In the Settings window for Piezoelectric Material, locate the Domain Selection section.

3 From the Selection list, choose +Z poled Piezo.

4 In the Model Builder window, click Solid Mechanics (solid).

Piezoelectric Material 2
1 On the Physics toolbar, click Domains and choose Piezoelectric Material.

2 In the Settings window for Piezoelectric Material, locate the Domain Selection section.

3 From the Selection list, choose -Z poled Piezo.

Define a rotated system that will be used for the poling of the -Z poled piezoelectric 
disks.
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D E F I N I T I O N S

Rotated System 2 (sys2)
1 On the Definitions toolbar, click Coordinate Systems and choose Rotated System.

2 In the Settings window for Rotated System, locate the Settings section.

3 Find the Euler angles (Z-X-Z) subsection. In the β text field, type pi.

S O L I D  M E C H A N I C S  ( S O L I D )

Piezoelectric Material 2
1 In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 

Piezoelectric Material 2.

2 In the Settings window for Piezoelectric Material, locate the Coordinate System Selection 
section.

3 From the Coordinate system list, choose Rotated System 2 (sys2).

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 In the Settings window for Fixed Constraint, locate the Boundary Selection section.

3 From the Selection list, choose Fixed boundaries.

Bolt Pre-Tension 1
1 On the Physics toolbar, click Global and choose Bolt Pre-Tension.

2 In the Settings window for Bolt Pre-Tension, locate the Bolt Pre-Tension section.

3 In the Fp text field, type F_pre.

Bolt Selection 1
1 In the Model Builder window, expand the Bolt Pre-Tension 1 node, then click Bolt 

Selection 1.

2 In the Settings window for Bolt Selection, locate the Boundary Selection section.

3 From the Selection list, choose Pre-tension cut (Simple Bolt, No Thread 1).

Continuity 1
1 On the Physics toolbar, in the Boundary section, click Pairs and choose Continuity.

2 In the Settings window for Continuity, locate the Pair Selection section.

3 In the Pairs list, select Identity Pair 1 (ap1).

E L E C T R O S T A T I C S  ( E S )

1 In the Model Builder window, under Component 1 (comp1) click Electrostatics (es).
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2 In the Settings window for Electrostatics, locate the Domain Selection section.

3 From the Selection list, choose Piezo domains.

Ground 1
1 On the Physics toolbar, click Boundaries and choose Ground.

2 In the Settings window for Ground, locate the Boundary Selection section.

3 From the Selection list, choose Ground boundaries.

Electric Potential 1
1 On the Physics toolbar, click Boundaries and choose Electric Potential.

2 In the Settings window for Electric Potential, locate the Boundary Selection section.

3 From the Selection list, choose Voltage boundaries.

4 Locate the Electric Potential section. In the V0 text field, type linper(V0).

The linper() operator ensures that the voltage V0 is only applied in the frequency 
domain perturbation study step and not during the stationary analysis. If you have the 
AC/DC Module you can right click and add the Harmonic Perturbation sub-feature, 
which will do the same.

D E F I N I T I O N S

Perfectly Matched Layer 1 (pml1)
1 On the Definitions toolbar, click Perfectly Matched Layer.

Insert a Perfectly Matched Layer to model the absorption of acoustic wave far away 
from the source.

2 In the Settings window for Perfectly Matched Layer, locate the Domain Selection section.

3 From the Selection list, choose Water domain - PML.

4 Locate the Geometry section. From the Type list, choose Spherical.

5 Locate the Scaling section. From the Coordinate stretching type list, choose Rational.

6 In the PML scaling factor text field, type 0.5.

7 In the PML scaling curvature parameter text field, type 5.

Mesh the geometry; create a tetrahedral mesh in the solid and the water-inner domains 
and create a swept mesh in the PML.

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Free Tetrahedral.
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Free Tetrahedral 1
1 In the Settings window for Free Tetrahedral, locate the Domain Selection section.

2 From the Geometric entity level list, choose Domain.

3 From the Selection list, choose Non-PML domains.

Size 1
1 Right-click Component 1 (comp1)>Mesh 1>Free Tetrahedral 1 and choose Size.

Define a mesh size in the water domain to ensure that the smallest wavelength is 
resolved by at least 5 elements.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Selection list, choose Water domains.

4 Locate the Element Size section. Click the Custom button.

5 Locate the Element Size Parameters section. Select the Maximum element size check box.

6 In the associated text field, type 1500[m/s]/f0max/5.

Free Tetrahedral 1
Right-click Free Tetrahedral 1 and choose Size.

Size 2
Apply a mesh setting on the Destination boundaries of the Identity Pair such that the mesh 
on these surfaces is somewhat finer than the mesh on the Source boundaries of the Identity 
Pair.

1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 From the Selection list, choose Destination boundaries.

4 Locate the Element Size section. From the Predefined list, choose Finer.

5 In the Model Builder window, right-click Mesh 1 and choose Swept.

Swept 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Swept 1 and 
choose Distribution.

Distribution 1
1 In the Settings window for Distribution, click Build All.

Create a boundary layer mesh at the external boundaries of the water domain. This will 
ensure numerically well defined normal gradients used in the far-field calculation 
feature.
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Boundary Layers 1
1 In the Model Builder window, right-click Mesh 1 and choose Boundary Layers.

2 In the Settings window for Boundary Layers, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Water domain - Inner.

Boundary Layer Properties
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1>Boundary Layers 1 

click Boundary Layer Properties.

2 In the Settings window for Boundary Layer Properties, locate the Boundary Selection 
section.

3 From the Selection list, choose Far Field boundaries.

4 Locate the Boundary Layer Properties section. In the Number of boundary layers text field, 
type 1.

5 From the Thickness of first layer list, choose Manual.

6 In the Thickness text field, type 1500[m/s]/f0max/5/20.

7 Click Build All.

The Stationary step solves for the effect of pre-tension in the bolt and hence does not 
need to solve for the Acoustics problem. The Frequency-Domain Perturbation step 
solves all the physics.

S T U D Y  1

Step 1: Stationary
1 In the Settings window for Stationary, locate the Physics and Variables Selection section.

2 In the table, clear the Solve for check box for the Pressure Acoustics, Frequency Domain 

(acpr) interface.

Step 2: Frequency-Domain Perturbation
1 In the Model Builder window, under Study 1 click Step 2: Frequency-Domain Perturbation.

2 In the Settings window for Frequency-Domain Perturbation, locate the Study Settings 
section.

3 In the Frequencies text field, type range(f0min,f0step,f0max).

The following steps are performed to ensure that the pre-deformation in the bolt as a 
result of the pre-tension is not computed in the Frequency-Domain Perturbation step.
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Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1) click 
Dependent Variables 2.

4 In the Settings window for Dependent Variables, locate the General section.

5 From the Defined by study step list, choose User defined.

6 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1)>

Dependent Variables 2 click Pre-deformation (comp1.solid.pblt1.sblt1.d_pre).

7 In the Settings window for State, locate the General section.

8 Clear the Solve for this state check box.

9 In the Model Builder window, click Study 1.

10 In the Settings window for Study, locate the Study Settings section.

11 Clear the Generate default plots check box.

12 On the Study toolbar, click Compute.

The following instructions describe how to create the plots shown in the Results section.

R E S U L T S

Data Sets
In the Model Builder window, expand the Results node.

Study 1/Solution 1 (sol1)
In the Model Builder window, expand the Data Sets node, then click Study 1/Solution 1 

(sol1).

Selection
1 On the Results toolbar, click Selection.

2 In the Settings window for Selection, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Non-PML domains.

5 Select the Propagate to lower dimensions check box.

3D Plot Group 1
1 On the Results toolbar, click 3D Plot Group.
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2 In the Settings window for 3D Plot Group, type Static stress from pre-tension 
in the Label text field.

3 Locate the Data section. From the Data set list, choose Study 1/Solution Store 1 (sol2).

4 Click the Go to YZ View button on the Graphics toolbar.

Slice 1
1 Right-click Static stress from pre-tension and choose Slice.

2 In the Settings window for Slice, locate the Plane Data section.

3 In the Planes text field, type 1.

4 Locate the Expression section. In the Expression text field, type solid.sz.

5 Click to expand the Range section. Select the Manual color range check box.

6 In the Minimum text field, type -1e8.

7 In the Maximum text field, type 1e8.

8 On the Static stress from pre-tension toolbar, click Plot.

3D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Acoustic Pressure in the Label text 
field.

Multislice 1
1 On the Acoustic Pressure toolbar, click More Plots and choose Multislice.

2 Click Plot.

Acoustic Pressure
In the Model Builder window, under Results right-click Acoustic Pressure and choose 
Duplicate.

Acoustic Pressure 1
In the Settings window for 3D Plot Group, type Sound Pressure Level  in the Label 
text field.

Multislice 1
1 In the Model Builder window, expand the Results>Sound Pressure Level node, then click 

Multislice 1.

2 In the Settings window for Multislice, locate the Expression section.

3 In the Expression text field, type acpr.Lp.

4 On the Sound Pressure Level toolbar, click Plot.
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3D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Displacement in the Label text field.

Surface 1
1 Right-click Displacement and choose Surface.

2 In the Settings window for Surface, locate the Expression section.

3 In the Expression text field, type w.

4 Right-click Results>Displacement>Surface 1 and choose Deformation.

5 On the Displacement toolbar, click Plot.

Sound Pressure Level
In the Model Builder window, under Results right-click Sound Pressure Level and choose 
Duplicate.

Sound Pressure Level 1
In the Settings window for 3D Plot Group, type Electric Potential in the Label text 
field.

Multislice 1
1 In the Model Builder window, expand the Results>Electric Potential node, then click 

Multislice 1.

2 In the Settings window for Multislice, locate the Expression section.

3 In the Expression text field, type V.

4 On the Electric Potential toolbar, click Plot.

5 Click the Go to Default 3D View button on the Graphics toolbar.

1D Plot Group 6
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, type Specific Acoustic Impedance in 
the Label text field.

3 Click to expand the Title section. From the Title type list, choose Manual.

4 In the Title text area, type Specific Acoustic Impedance (Zaco).

5 Locate the Plot Settings section. Select the x-axis label check box.

6 In the associated text field, type f (kHz).

7 Select the y-axis label check box.

8 In the associated text field, type Z/(\rho c).
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Global 1
1 On the Specific Acoustic Impedance toolbar, click Global.

2 In the Settings window for Global, locate the y-Axis Data section.

3 In the table, enter the following settings:

4 Click to expand the Legends section. From the Legends list, choose Manual.

5 In the table, enter the following settings:

6 Locate the x-Axis Data section. From the Parameter list, choose Expression.

7 In the Expression text field, type freq.

8 From the Unit list, choose kHz.

9 Click to expand the Coloring and style section. Locate the Coloring and Style section. In 
the Width text field, type 2.

10 Find the Line style subsection. From the Line list, choose Cycle.

11 On the Specific Acoustic Impedance toolbar, click Plot.

Specific Acoustic Impedance
In the Model Builder window, under Results right-click Specific Acoustic Impedance and 
choose Duplicate.

Specific Acoustic Impedance 1
1 In the Settings window for 1D Plot Group, type Transmitting Voltage Response in 

the Label text field.

2 Locate the Title section. In the Title text area, type Transmitting Voltage Response.

3 Locate the Plot Settings section. In the y-axis label text field, type TVR (dB rel. 1\mu 
Pa/V).

4 Click to expand the Legend section. From the Position list, choose Lower right.

Expression Unit Description

abs(Zaco) 1

real(Zaco) 1

imag(Zaco) 1

Legends

Absolute value

Real part

Imaginary part
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Global 1
1 In the Model Builder window, expand the Results>Transmitting Voltage Response node, 

then click Global 1.

2 In the Settings window for Global, click Replace Expression in the upper-right corner of 
the y-axis data section. From the menu, choose Component 1>Definitions>Variables>TVR 

- Transmitting Voltage Response (TVR).

3 Locate the Legends section. From the Legends list, choose Automatic.

4 On the Transmitting Voltage Response toolbar, click Plot.

Transmitting Voltage Response
In the Model Builder window, under Results right-click Transmitting Voltage Response and 
choose Duplicate.

Transmitting Voltage Response 1
1 In the Settings window for 1D Plot Group, type Directivity Index (DI) in the Label 

text field.

2 Locate the Title section. In the Title text area, type Directivity Index (DI).

3 Locate the Plot Settings section. In the y-axis label text field, type DI (dB).

4 Locate the Legend section. From the Position list, choose Lower left.

Global 1
1 In the Model Builder window, expand the Results>Directivity Index (DI) node, then click 

Global 1.

2 In the Settings window for Global, click Replace Expression in the upper-right corner of 
the y-axis data section. From the menu, choose Component 1>Definitions>Variables>DI - 

Directivity index of Tonpilz transducer.

3 Click Add Expression in the upper-right corner of the y-axis data section. From the 
menu, choose Component 1>Definitions>Variables>DI_fl_pist - Directivity index of flanged 

piston.

4 On the Directivity Index (DI) toolbar, click Plot.

Directivity Index (DI)
In the Model Builder window, under Results right-click Directivity Index (DI) and choose 
Duplicate.

Directivity Index (DI) 1
1 In the Settings window for 1D Plot Group, type Total Radiated Power in the Label 

text field.
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2 Locate the Title section. In the Title text area, type Total Radiated Power.

3 Locate the Plot Settings section. In the y-axis label text field, type Ptot (mW).

4 Locate the Legend section. From the Position list, choose Upper left.

Global 1
1 In the Model Builder window, expand the Results>Total Radiated Power node, then click 

Global 1.

2 In the Settings window for Global, click Replace Expression in the upper-right corner of 
the y-axis data section. From the menu, choose Component 1>Definitions>Variables>Ptot 

- Total radiated power.

3 Locate the y-Axis Data section. In the table, enter the following settings:

4 On the Total Radiated Power toolbar, click Plot.

Expression Unit Description

Ptot mW Total radiated power
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Introduction

Trusses are commonly used to create light structures that can support heavy loads. When 
designing such a structure, it is important to ensure its safety. For a tower made of bars, 
buckling can cause the structure to collapse. This example shows how to compute the 
critical buckling load using a linear buckling analysis. The solution is compared with an 
analytical expression for critical load estimation for Euler buckling.

Model Definition

The model geometry consists of a 19-meters tall truss tower with a rectangular section. 
The critical buckling load is computed using the linear buckling analysis available in the 
Truss interface.

The geometry is the periodic structure represented in Figure 1 below. It consists of 19 
blocks of trusses. Each block has width of 0.45 m, depth of 0.40 m and height of 1.0 m. 
The trusses that are perpendicular to the ground are thicker and have outer radius of 
15 cm and inner radius of 10 cm. The remaining trusses have outer radius of 10 cm and 
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inner radius of 7 cm. The tower is made out of structural steel that is one of the predefined 
materials in the material library. 

Figure 1: Geometry of the truss tower.

The tower is fixed at the ground level and a vertical load is applied at the top. 

One fourth of the unit load is applied at each point of the tower top so that the critical 
load factor returned by the linear buckling analysis corresponds to the load that would 
cause the collapse of the structure.

Results and Discussion

For a simple column the critical buckling load is given by the Euler buckling formula

where E is the Young’s modulus, I is the area moment of inertia, L is the unsupported 
length of the column and K is the column effective length factor.

For a column with one end fixed and the other end free to move laterally, K = 2. 

Fc
π2EI

KL( )2
----------------=
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For a tower like the one in this example with 4 main bars in the axial direction, the area of 
moment of inertia of the section can be computed as:

where h is the distance between the vertical bars, and S the cross section area of the bars.

As the section is rectangular with different depth and width value, the tower has one weak 
direction. Here the depth is 40 cm and the width is 45 cm. This means that the first critical 
buckling load is expected to be about 8.6e4N in the depth direction (y-direction). In the 
width direction, which is expected to be stiffer, the critical buckling load is estimated to be 
about 1.1e5N.

The results obtained with the linear buckling analysis agree well with these values.

Figure 2 shows the value of the first critical buckling load and the deformation shape.

Figure 2: Deformation shape at the first critical buckling load

I 4S h
2
--- 
  2

=
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Figure 3 shows the value of the second critical buckling load and the deformation shape.

Figure 3: Deformation shape at the second critical buckling load

Note that the approximation given for the Euler buckling critical load is suitable for a 
tower structure when the height is significantly larger than the width or the depth.

Notes About the COMSOL Implementation

For a model with only a Truss interface you can improve the performance by deactivating 
the Straight-edge constraint node. 

Application Library path: Structural_Mechanics_Module/Buckling/
truss_tower_buckling

Modeling Instructions

From the File menu, choose New.
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N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Truss (truss).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Linear Buckling.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

ro1 1.5[cm] 0.015 m Outer radius tube 1

ri1 1[cm] 0.01 m Inner radius tube 1

ro2 1[cm] 0.01 m Outer radius tube 2

ri2 0.7[cm] 0.007 m Inner radius tube 2

A1 pi*(ro1^2-ri1^2) 3.927E-4 m² Area tube 1

A2 pi*(ro2^2-ri2^2) 1.602E-4 m² Area tube 2

depth 0.4[m] 0.4 m Depth of the tower

width 0.45[m] 0.45 m Width of the tower

height 1[m] 1 m Height of the tower

n 10 10 Number of sections

L height*(2*n-1) 19 m Total height of the 
tower

I1 4*A1*(depth/2)^2 6.283E-5 m^4 Area moment of 
inertia weak 
direction

Fc1 pi^2*200e9[Pa]*I1/
(2*L)^2

8.589E4 N First critical 
buckling load
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G E O M E T R Y  1

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type width.

4 In the Depth text field, type depth.

5 In the Height text field, type height.

Bézier Polygon 1 (b1)
1 Right-click Block 1 (blk1) and choose Build Selected.

2 On the Geometry toolbar, click More Primitives and choose Bézier Polygon.

3 In the Settings window for Bézier Polygon, locate the Polygon Segments section.

4 Find the Added segments subsection. Click Add Linear.

5 Find the Control points subsection. In row 1, set y to depth.

6 In row 2, set z to height.

7 Find the Added segments subsection. Click Add Linear.

8 Find the Control points subsection. In row 2, set x to width and z to 0.

9 Find the Added segments subsection. Click Add Linear.

10 Find the Control points subsection. In row 2, set y to depth and z to height.

11 Find the Added segments subsection. Click Add Linear.

12 Find the Control points subsection. In row 2, set x to 0 and z to 0.

Bézier Polygon 2 (b2)
1 On the Geometry toolbar, click More Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the Polygon Segments section.

3 Find the Added segments subsection. Click Add Linear.

4 Find the Control points subsection. In row 1, set y to depth.

5 In row 2, set x to width.

I2 4*A1*(width/2)^2 7.952E-5 m^4 Area moment of 
inertia stiffer 
direction

Fc2 pi^2*200e9[Pa]*I2/
(2*L)^2

1.087E5 N Second critical 
buckling load

Name Expression Value Description
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Bézier Polygon 3 (b3)
1 On the Geometry toolbar, click More Primitives and choose Bézier Polygon.

2 In the Settings window for Bézier Polygon, locate the Polygon Segments section.

3 Find the Added segments subsection. Click Add Linear.

4 Find the Control points subsection. In row 1, set z to height.

5 In row 2, set x to width, y to depth, and z to height.

Convert to Curve 1 (ccur1)
1 Right-click Bézier Polygon 3 (b3) and choose Build Selected.

2 On the Geometry toolbar, click Conversions and choose Convert to Curve.

3 Click in the Graphics window and then press Ctrl+A to select all objects.

Mirror 1 (mir1)
1 Right-click Convert to Curve 1 (ccur1) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Mirror.

3 Select the object ccur1 only.

4 In the Settings window for Mirror, locate the Input section.

5 Select the Keep input objects check box.

6 Locate the Point on Plane of Reflection section. In the z text field, type height.

Array 1 (arr1)
1 Right-click Mirror 1 (mir1) and choose Build Selected.

2 On the Geometry toolbar, click Transforms and choose Array.

3 Select the object ccur1 only.

4 In the Settings window for Array, locate the Size section.

5 In the z size text field, type n.

6 Locate the Displacement section. In the z text field, type 2*height.

7 Right-click Array 1 (arr1) and choose Build Selected.

8 Click the Go to Default 3D View button on the Graphics toolbar.

Array 2 (arr2)
1 On the Geometry toolbar, click Transforms and choose Array.

2 Select the object mir1 only.

3 In the Settings window for Array, locate the Size section.

4 In the z size text field, type n-1.
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5 Locate the Displacement section. In the z text field, type 2*height.

6 Right-click Array 2 (arr2) and choose Build Selected.

7 Click the Zoom Extents button on the Graphics toolbar.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Structural steel.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.

TR U S S  ( T R U S S )

Cross Section Data 1
1 In the Model Builder window, under Component 1 (comp1)>Truss (truss) click Cross 

Section Data 1.

2 In the Settings window for Cross Section Data, locate the Cross Section Data section.

3 In the A text field, type A2.

Cross Section Data 2
1 On the Physics toolbar, click Edges and choose Cross Section Data.

2 Select all the vertical edges. You can use the Select box tool for easier selection.

3 In the Settings window for Cross Section Data, locate the Cross Section Data section.

4 In the A text field, type A1.

Pinned 1
1 On the Physics toolbar, click Points and choose Pinned.

2 Select Points 1, 21, 41, and 61, located at the bottom of the tower.

Point Load 1
1 On the Physics toolbar, click Points and choose Point Load.

2 Select Points 20, 40, 60 and 80 located at the top of the tower.

3 In the Settings window for Point Load, locate the Force section.

4 Specify the FP vector as

0 x
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S T U D Y  1

Step 2: Linear Buckling
1 In the Model Builder window, under Study 1 click Step 2: Linear Buckling.

2 In the Settings window for Linear Buckling, locate the Study Settings section.

3 In the Desired number of buckling modes text field, type 2.

4 On the Home toolbar, click Compute.

R E S U L T S

Line
1 In the Model Builder window, expand the Mode Shape (truss) node, then click Line.

2 In the Settings window for Line, click to expand the Title section.

3 From the Title type list, choose None.

4 Locate the Coloring and Style section. Clear the Color legend check box.

5 On the Mode Shape (truss) toolbar, click Plot.

6 Click the Zoom Extents button on the Graphics toolbar.

Mode Shape (truss)
1 In the Model Builder window, under Results click Mode Shape (truss).

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Critical load factor list, choose 1.072E5.

4 On the Mode Shape (truss) toolbar, click Plot.

0 y

-1/4 z
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Introduction

A tube connection consisting of a flange with four prestressed bolts (see Figure 1) is 
subjected to an external bending moment. In this example, you study how the stress state 
in the tube and the bolts varies with the applied load.

Figure 1: Tube connection.

Note: This application requires the Structural Mechanics Module and the CAD Import 
Module.

Model Definition

The tube is made of steel and has an outer diameter of 220 mm and an inner diameter of 
200 mm. The flange has a diameter of 360 mm and a thickness of 30 mm. The connection 
consists of four prestressed M24 bolts. The bolts are prestressed to 75% of the yield 
strength. The total bending moment on the tube is increased from 0 to 26 kNm.

To compute the influence of the tensile force on the stress level in the bolt, the modeling 
includes a parametric analysis. Because of symmetry in both load and geometry, you only 
need to analyze one half of one of the flanges. The geometry has been created in the CAD 
software SOLIDWORKS® and is available as an IGES file.

Two contact regions are modeled. One contact pair acts between the bottom surface of 
the flange and the top surface of an additional fixed solid which supplies the symmetry 
condition with respect to contact. The other contact pair acts between the washers under 
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the bolt heads and the flange. The possibility to automatically detect potential contact 
surfaces is used when creating the contact pairs.

Results and Discussion

After the pretension step, there is a tensile stress in the bolt, and compressive stress in the 
flange under the bolt. This is illustrated in Figure 2.

Figure 2: The axial stress after the pretension step.

The general stress state at maximum external load is shown in Figure 3. In addition to the 
stress that has increased in the fillet between tube and flange, additional features are visible. 
The stress state in the bolt on the tensile side has increased significantly and is no longer 
axisymmetric. Furthermore, a stress of the order of 300 MPa has developed in the fillet 
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between the tube and the flange.This stress is caused by local bending, since the flange no 
longer is in contact with the mating surface at the tensile side.

Figure 3: Effective stress at maximum external load.

The applied external load in this example overloads the bolted joint. Up to about half the 
full load, it works fairly well, but then the contact between the two mating flanges start to 
open up on the tensile side. This is displayed in Figure 4. Actually, the conditions are even 
worse than the average force indicates. The bolt is subjected to bending with a 
non-uniform stress distribution over the cross section. The maximum stress has increased 
from the prestress value of 75% of the yield stress to 88% of the yield stress, and the 
progression is fast. The development of the axial stress in two points on opposite sides of 
the bolt is displayed in Figure 5. The points are located in the x-z symmetry plane. One 
point is as close to the tube centerline as possible and the other as far out as possible.
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Figure 4: The bolt force as a function of the tensile force.

Figure 5: The development of the bolt stress at two different positions in the cross section.
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The plots of the contact pressure between the mating flanges are shown in Figure 6 and 
Figure 7. By comparing these two figures, it is clear that the contact pressure shifts away 
from the initially prestressed area which at the peak load becomes almost stress free. This 
indicates that there are too few bolts that connect the two parts with each other.

Figure 6: Contact pressure between flanges after pretensioning the bolts.
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Figure 7: Contact pressure between the flanges at full external load.

Notes About the COMSOL Implementation

The analysis is performed in two steps and therefore represented by two studies. In the first 
step, the effects of pretensioning the bolt are computed, and in the second step the 
external load on the tube is applied as a parametric sweep.

The prestress in the bolts is introduced using the built-in Bolt Pre-tension feature. This 
feature creates one degree of freedom for each bolt, which can be interpreted as the 
shortening of the bolt caused by prestress. This degree of freedom is then kept fixed under 
service loads.

In order to keep the solution time down, a coarse mesh is used, and it probably needs a 
refinement if one needs to obtain accurate quantitative results for stresses.

Application Library path: Structural_Mechanics_Module/
Contact_and_Friction/tube_connection
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Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Stationary.

6 Click Done.

G E O M E T R Y  1

First, make sure that the CAD Import Module kernel is used.

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Advanced section.

3 From the Geometry representation list, choose CAD kernel.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

Di_wash 25[mm] 0.025 m Washer inner 
diameter

Do_wash 45[mm] 0.045 m Washer outer 
diameter

T_wash 4[mm] 0.004 m Washer thickness

Do_bolthead 38[mm] 0.038 m Bolthead diameter

H_bolthead 15[mm] 0.015 m Bolthead height
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G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
tube_connection.igs.

5 Click Import.

Use the bolts and washers from the part library.

P A R T  L I B R A R I E S

1 On the Home toolbar, click Windows and choose Part Libraries.

2 In the Part Libraries window, select Structural Mechanics Module>Bolts>flat washer in the 
tree.

3 click Add to Geometry.

As_bolt 353[mm^2] 3.53E-4 m² Stress area of 
bolt

Ds_bolt sqrt(4/pi*
As_bolt)

0.0212 m Effective bolt 
diameter

R_bc 150[mm] 0.15 m Bolt circle radius

Do_pipe 0.22[m] 0.22 m Pipe outer 
diameter

Di_pipe 0.20[m] 0.2 m Pipe inner 
diameter

Wb pi/32*
(Do_pipe^4-Di_pip
e^4)/Do_pipe

3.314E-4 m³ Pipe bending 
resistance

M_appl 26E3[N*m] 2.6E4 N·m Applied bending 
moment

ps 1 1 Parameter for 
spring relaxation

lp 0 0 Loading parameter

Name Expression Value Description
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G E O M E T R Y  1

Flat Washer 1 (pi1)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Flat Washer 

1 (pi1).

2 In the Settings window for Part Instance, type Washer 1 in the Label text field.

3 Locate the Input Parameters section. In the table, enter the following settings:

4 Locate the Position and Orientation of Output section. Find the Displacement subsection. 
In the xw text field, type R_bc.

5 Find the Coordinate system in part subsection. From the Work plane in part list, choose 
Outer plane (wp2).

6 Find the Rotation subsection. From the Axis type list, choose xw-axis.

7 In the Rotation angle text field, type 90.

8 Click to expand the Boundary selections section. Locate the Boundary Selections section. 
In the table, enter the following settings:

P A R T  L I B R A R I E S

1 On the Home toolbar, click Windows and choose Part Libraries.

2 In the Model Builder window, click Geometry 1.

3 In the Part Libraries window, select Structural Mechanics Module>Bolts>simple bolt no 

thread in the tree.

4 click Add to Geometry.

Name Expression Value Description

odia Do_wash 0.045 m Outer diameter

idia Di_wash 0.025 m Inner diameter

thickness T_wash 0.004 m Thickness

Name Contribute to Keep Physics

Exterior none √

Inner face none √

Outer face none √ √

Hole faces none √
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G E O M E T R Y  1

Simple Bolt, No Thread 1 (pi2)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Simple Bolt, 

No Thread 1 (pi2).

2 In the Settings window for Part Instance, type Bolt 1 in the Label text field.

3 Locate the Input Parameters section. In the table, enter the following settings:

4 Locate the Position and Orientation of Output section. Find the Coordinate system in part 
subsection. From the Work plane in part list, choose Head inner plane (wp1).

5 Find the Coordinate system to match subsection. From the Take work plane from list, 
choose Washer 1 (pi1).

6 From the Work plane list, choose Inner plane (wp1).

7 Find the Rotation subsection. From the Axis type list, choose xw-axis.

8 In the Rotation angle text field, type 180.

9 Locate the Boundary Selections section. In the table, enter the following settings:

In the Model Builder window, select Component 1 (comp1)>Geometry 1>Bolt 1 (pi2) and 
Component 1 (comp1)>Geometry 1>Washer 1 (pi1), right click and choose Duplicate.

Washer 1.1 (pi3)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Washer 1.1 

(pi3).

2 In the Settings window for Part Instance, type Washer 2 in the Label text field.

Name Expression Value Description

hdia Do_bolthead 0.038 m Head diameter

hthic H_bolthead 0.015 m Head thickness

ndia Ds_bolt 0.0212 m Nominal diameter

blen 30[mm]+T_wash 0.034 m Bolt length

Name Contribute to Keep Physics

Exterior none √

Shank none √

Head, free surface none √

Head, contact surface none √

Pre-tension cut none √ √
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3 Locate the Position and Orientation of Output section. Find the Displacement subsection. 
In the xw text field, type 0.

4 In the zw text field, type -R_bc.

Bolt 1.1 (pi4)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Bolt 1.1 

(pi4).

2 In the Settings window for Part Instance, type Bolt 2 in the Label text field.

3 Locate the Position and Orientation of Output section. Find the Coordinate system to 

match subsection. From the Take work plane from list, choose Washer 2 (pi3).

4 From the Work plane list, choose Inner plane (wp1).

In the Model Builder window, select Component 1 (comp1)>Geometry 1>Bolt 2 (pi4) and 
Component 1 (comp1)>Geometry 1>Washer 2 (pi3), right click and choose Duplicate.

Washer 2.1 (pi5)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Washer 2.1 

(pi5).

2 In the Settings window for Part Instance, type Washer 3 in the Label text field.

3 Locate the Position and Orientation of Output section. Find the Displacement subsection. 
In the xw text field, type -R_bc.

4 In the zw text field, type 0.

Bolt 2.1 (pi6)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Bolt 2.1 

(pi6).

2 In the Settings window for Part Instance, type Bolt 3 in the Label text field.

3 Locate the Position and Orientation of Output section. Find the Coordinate system to 

match subsection. From the Take work plane from list, choose Washer 3 (pi5).

4 From the Work plane list, choose Inner plane (wp1).

Rotate 1 (rot1)
1 On the Geometry toolbar, click Transforms and choose Rotate.

2 Select the objects pi1 and pi2 only.

3 In the Settings window for Rotate, locate the Point on Axis of Rotation section.

4 In the x text field, type R_bc.

5 Locate the Rotation Angle section. In the Rotation text field, type 30.
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6 Locate the Axis of Rotation section. From the Axis type list, choose y-axis.

Rotate 2 (rot2)
1 Right-click Rotate 1 (rot1) and choose Duplicate.

2 In the Settings window for Rotate, locate the Input section.

3 Find the Input objects subsection. Select the Active toggle button.

4 Select the objects pi5 and pi6 only.

5 Locate the Point on Axis of Rotation section. In the x text field, type -R_bc.

Split 1 (spl1)
1 Right-click Component 1 (comp1)>Geometry 1>Rotate 2 (rot2) and choose Build Selected.

2 On the Geometry toolbar, click Conversions and choose Split.

3 Select the objects rot2(2), rot1(2), and pi4 only.

Union 1 (uni1)
1 Right-click Split 1 (spl1) and choose Build Selected.

2 On the Geometry toolbar, click Booleans and Partitions and choose Union.

3 Select the objects spl1(18), spl1(20), spl1(30), spl1(52), spl1(38), spl1(6), spl1(48), 
spl1(16), spl1(27), rot2(1), spl1(2), spl1(25), spl1(1), spl1(15), spl1(43), spl1(39), pi3, 
spl1(17), spl1(54), spl1(37), spl1(12), spl1(24), spl1(34), spl1(33), spl1(53), spl1(21), 
spl1(36), spl1(9), spl1(3), spl1(51), spl1(10), rot1(1), spl1(35), spl1(42), spl1(19), spl1(46), 
spl1(7), spl1(45), and spl1(28) only.

4 In the Settings window for Union, locate the Union section.

5 Clear the Keep interior boundaries check box.

Union 2 (uni2)
1 Right-click Union 1 (uni1) and choose Build Selected.

2 On the Geometry toolbar, click Booleans and Partitions and choose Union.

3 Select the objects spl1(14), spl1(40), spl1(8), spl1(11), spl1(4), spl1(22), spl1(23), spl1(41), 
spl1(32), spl1(50), spl1(5), spl1(26), spl1(49), spl1(29), spl1(13), spl1(31), spl1(47), and 
spl1(44) only.

4 In the Settings window for Union, locate the Union section.

5 Clear the Keep interior boundaries check box.

Union 3 (uni3)
1 Right-click Union 2 (uni2) and choose Build Selected.

2 On the Geometry toolbar, click Booleans and Partitions and choose Union.
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3 Select the objects uni2 and uni1 only.

4 Right-click Union 3 (uni3) and choose Build Selected.

Remove half of the geometry to make use of symmetry.

Work Plane 1 (wp1)
On the Geometry toolbar, click Work Plane.

Partition Objects 1 (par1)
1 On the Geometry toolbar, click Booleans and Partitions and choose Partition Objects.

2 In the Settings window for Partition Objects, locate the Partition Objects section.

3 Find the Tool objects subsection. Select the Active toggle button.

4 From the Partition with list, choose Work plane.

5 Click Build All Objects.

Now create the selection for upper half of the geometry to be removed.

Box Selection 1 (boxsel1)
1 On the Geometry toolbar, click Selections and choose Box Selection.

2 In the Settings window for Box Selection, type Upper half in the Label text field.

3 Locate the Box Limits section. In the z minimum text field, type -0.01.

4 Locate the Output Entities section. From the Include entity if list, choose Entity inside 

box.

Delete Entities 1 (del1)
1 In the Model Builder window, right-click Geometry 1 and choose Delete Entities.

2 In the Settings window for Delete Entities, locate the Entities or Objects to Delete 
section.

3 From the Geometric entity level list, choose Domain.

4 From the Selection list, choose Upper half.

5 Right-click Component 1 (comp1)>Geometry 1>Delete Entities 1 (del1) and choose Build 

Selected.

Create a rigid block to act as symmetry condition for the contact modeling.

Block 1 (blk1)
1 On the Geometry toolbar, click Block.

2 In the Settings window for Block, locate the Size and Shape section.

3 In the Width text field, type 0.4.
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4 In the Depth text field, type 0.01.

5 In the Height text field, type 0.25.

6 Locate the Position section. In the x text field, type -0.2.

7 In the y text field, type -0.04.

8 In the z text field, type -0.2.

Form Union (fin)
1 In the Model Builder window, under Component 1 (comp1)>Geometry 1 click Form Union 

(fin).

2 In the Settings window for Form Union/Assembly, locate the Form Union/Assembly 
section.

3 From the Action list, choose Form an assembly.

4 From the Pair type list, choose Contact pair.

5 On the Geometry toolbar, click Build All.

Ignore Edges 1 (ige1)
1 On the Geometry toolbar, click Virtual Operations and choose Ignore Edges.

2 On the object fin, select Edges 27 and 47 only.

This will improve the mesh at the transition to fillet, where large stresses can be 
expected.
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3 On the Geometry toolbar, click Build All.

This completes the geometry modeling stage. The geometry should now look like that 
in the figure below.

D E F I N I T I O N S

Define selections to use later in the modeling.

Box 1
1 On the Definitions toolbar, click Box.

2 In the Settings window for Box, type Symmetry boundaries (Tube) in the Label text 
field.

3 Locate the Geometric Entity Level section. From the Level list, choose Boundary.

4 Locate the Box Limits section. In the y minimum text field, type -0.04.

5 In the y maximum text field, type 0.16.

6 In the z minimum text field, type -0.005.

7 In the z maximum text field, type 0.01.

8 Locate the Output Entities section. From the Include entity if list, choose Entity inside 

box.

Explicit 1
1 On the Definitions toolbar, click Explicit.
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2 In the Settings window for Explicit, type Symmetry boundaries (Bolts) in the Label 
text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Select Boundaries 45, 92, and 149 only.

5 Select the Group by continuous tangent check box.

Union 1
1 On the Definitions toolbar, click Union.

2 In the Settings window for Union, type Symmetry boundaries (All) in the Label text 
field.

3 Locate the Geometric Entity Level section. From the Level list, choose Boundary.

4 Locate the Input Entities section. Under Selections to add, click Add.

5 In the Add dialog box, In the Selections to add list, choose Symmetry boundaries (Tube) 
and Symmetry boundaries (Bolts).

6 Click OK.

Union 2
1 On the Definitions toolbar, click Union.

2 In the Settings window for Union, type Contact boundaries (Washers) in the Label 
text field.

3 Locate the Geometric Entity Level section. From the Level list, choose Boundary.

4 Locate the Input Entities section. Under Selections to add, click Add.

5 In the Add dialog box, In the Selections to add list, choose Outer face (Washer 1), Outer 

face (Washer 2), and Outer face (Washer 3).

6 Click OK.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Structural steel.

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.
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S O L I D  M E C H A N I C S  ( S O L I D )

Fixed Constraint 1
1 On the Physics toolbar, click Domains and choose Fixed Constraint.

2 Select Domain 1 only.

Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 In the Settings window for Symmetry, locate the Boundary Selection section.

3 From the Selection list, choose Symmetry boundaries (All).

Add a constraint suppressing any rigid body translation in the x direction.

Prescribed Displacement 1
1 On the Physics toolbar, click Points and choose Prescribed Displacement.

2 Select Point 22 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in x direction check box.

Bolt Pre-Tension 1
1 On the Physics toolbar, click Global and choose Bolt Pre-Tension.

2 In the Settings window for Bolt Pre-Tension, locate the Bolt Pre-Tension section.

3 From the Pre-tension type list, choose Pre-tension stress.

4 In the σp text field, type 800[MPa]*0.8*0.75.

Bolt Selection 1
1 In the Model Builder window, expand the Bolt Pre-Tension 1 node, then click Bolt 

Selection 1.

2 In the Settings window for Bolt Selection, locate the Boundary Selection section.

3 From the Selection list, choose Pre-tension cut (Bolt 1).

Bolt Pre-Tension 1
In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click Bolt 

Pre-Tension 1.

Bolt Selection 2
1 On the Physics toolbar, click Attributes and choose Bolt Selection.

2 In the Settings window for Bolt Selection, locate the Bolt Selection section.
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3 In the Bolt label text field, type Bolt_2.

4 Locate the Boundary Selection section. From the Selection list, choose Pre-tension cut 

(Bolt 2).

Bolt Pre-Tension 1
In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click Bolt 

Pre-Tension 1.

Bolt Selection 3
1 On the Physics toolbar, click Attributes and choose Bolt Selection.

2 In the Settings window for Bolt Selection, locate the Bolt Selection section.

3 In the Bolt label text field, type Bolt_3.

4 Locate the Boundary Selection section. From the Selection list, choose Pre-tension cut 

(Bolt 3).

Spring Foundation 1
1 On the Physics toolbar, click Domains and choose Spring Foundation.

2 Select Domains 2–8 only.

3 In the Settings window for Spring Foundation, locate the Spring section.

4 From the Spring type list, choose Total spring constant.

5 From the list, choose Diagonal.

6 In the ktot table, enter the following settings:

Before creating the contact conditions, check the automatically created contact pairs. The 
automatically generated source and destination selections are good in this case, so there is 
no need to change anything. The pair ap2 is not needed. You can delete it to clean up the 
model, but this is not necessary.

D E F I N I T I O N S

1 In the Model Builder window, expand the Component 1 (comp1)>Definitions node, then 
click Contact Pair 1 (ap1).

2 In the Settings window for Pair, locate the Advanced section.

3 From the Mapping method list, choose Initial configuration.

1e10*(1-ps) 0 0

0 1e12*(1-ps) 0

0 0 1e10*(1-ps)
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4 In the Model Builder window, under Component 1 (comp1)>Definitions click Contact Pair 

3 (ap3).

5 In the Settings window for Pair, locate the Advanced section.

6 From the Mapping method list, choose Initial configuration.

S O L I D  M E C H A N I C S  ( S O L I D )

Contact 1
1 On the Physics toolbar, in the Boundary section, click Pairs and choose Contact.

2 In the Settings window for Contact, locate the Pair Selection section.

3 In the Pairs list, select Contact Pair 1 (ap1).

4 Locate the Penalty Factor section. From the Tuned for list, choose Speed.

Contact 2
1 On the Physics toolbar, in the Boundary section, click Pairs and choose Contact.

2 In the Settings window for Contact, locate the Pair Selection section.

3 In the Pairs list, select Contact Pair 3 (ap3).

4 Locate the Penalty Factor section. From the Tuned for list, choose Speed.

Friction 1
1 On the Physics toolbar, click Attributes and choose Friction.

2 In the Settings window for Friction, locate the Friction section.

3 In the μstat text field, type 0.15.

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundary 14 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the FA vector as

M E S H  1

1 In the Model Builder window, under Component 1 (comp1) click Mesh 1.

2 In the Settings window for Mesh, locate the Mesh Settings section.

0 x

lp*M_appl/Wb*X/(Do_pipe/2) y

0 z
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3 From the Sequence type list, choose User-controlled mesh.

Size
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size.

2 In the Settings window for Size, locate the Element Size section.

3 From the Predefined list, choose Fine.

Free Tetrahedral 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Free 
Tetrahedral 1 and choose Size.

Size 1
1 In the Settings window for Size, locate the Geometric Entity Selection section.

2 From the Geometric entity level list, choose Boundary.

3 Select Boundaries 13 and 20 only.

4 Locate the Element Size section. From the Predefined list, choose Fine.

5 Click Build All.

Free Tetrahedral 1
Refine the mesh on the destination boundaries of the contact pairs.

Size 2
1 Right-click Free Tetrahedral 1 and choose Size.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Contact boundaries (Washers).

5 Locate the Element Size section. From the Predefined list, choose Finer.

6 Click Build All.

Since the block is rigid, one brick element is enough to represent it.

Mapped 1
1 In the Model Builder window, right-click Mesh 1 and choose More Operations>Mapped.

2 Select Boundary 5 only.

Distribution 1
1 Right-click Component 1 (comp1)>Mesh 1>Mapped 1 and choose Distribution.

2 Select Edges 6 and 8 only.

3 In the Settings window for Distribution, locate the Distribution section.
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4 In the Number of elements text field, type 1.

5 In the Model Builder window, right-click Mesh 1 and choose Swept.

Free Tetrahedral 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Free Tetrahedral 

1.

2 In the Settings window for Free Tetrahedral, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

Remove Domain 1 from the selection.

4 Click Build All.

The mesh should now look as in the figure below

S T U D Y  1

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Study 1: Prestress in the Label text field.

S T U D Y  1 :  P R E S T R E S S

Step 1: Stationary
1 In the Model Builder window, under Study 1: Prestress click Step 1: Stationary.

2 In the Settings window for Stationary, click to expand the Study extensions section.

3 Locate the Study Extensions section. Select the Auxiliary sweep check box.
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4 Click Add.

5 In the table, enter the following settings:

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 1 (sol1) node.

3 In the Model Builder window, expand the Study 1: Prestress>Solver Configurations>

Solution 1 (sol1)>Dependent Variables 1 node, then click Displacement field (Material) 

(comp1.u).

4 In the Settings window for Field, locate the Scaling section.

5 In the Scale text field, type 1e-4.

The default scale for the displacements is 1% of the model size. This is significantly more 
than can be expected here.

6 On the Study toolbar, click Compute.

R E S U L T S

Stress (solid)
Reproduce the plot in Figure 2 with the following steps:

Surface 1
1 In the Model Builder window, expand the Stress (solid) node, then click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>Stress>

Stress tensor (Spatial)>solid.sy - Stress tensor, y component.

3 Click to expand the Range section. Select the Manual color range check box.

4 In the Minimum text field, type -3e8.

5 In the Maximum text field, type 5e8.

Deformation
1 In the Model Builder window, expand the Surface 1 node, then click Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 In the Scale factor text field, type 50.

Parameter name Parameter value list Parameter unit

ps 0 1
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Surface 1
In the Model Builder window, under Results>Stress (solid) right-click Surface 1 and choose 
Filter.

Filter 1
1 In the Settings window for Filter, locate the Element Selection section.

2 In the Logical expression for inclusion text field, type dom>6.

This removes the rigid block from the plot, since it contains the boundaries 1 to 6.

Deformation
1 In the Model Builder window, under Results>Stress (solid)>Surface 1 click Deformation.

2 On the Stress (solid) toolbar, click Plot.

R O O T

Add a new study for the loading of the tube.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

Step 1: Stationary
1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Study 2: External load in the Label text field.

S T U D Y  2 :  E X T E R N A L  L O A D

Step 1: Stationary
1 In the Model Builder window, under Study 2: External load click Step 1: Stationary.

2 In the Settings window for Stationary, locate the Study Extensions section.

3 Select the Auxiliary sweep check box.

4 Click Add.
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5 In the table, enter the following settings:

6 Click to expand the Values of dependent variables section. Locate the Values of Dependent 

Variables section. Find the Initial values of variables solved for subsection. From the 
Settings list, choose User controlled.

7 From the Method list, choose Solution.

8 From the Study list, choose Study 1: Prestress, Stationary.

9 Find the Values of variables not solved for subsection. From the Settings list, choose User 

controlled.

10 From the Method list, choose Solution.

11 From the Study list, choose Study 1: Prestress, Stationary.

The pre-deformation in the bolts is to be kept constant during the application of the 
external load, so it should not be solved for.

Solution 2 (sol2)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Solution 2 (sol2) node.

3 In the Model Builder window, under Study 2: External load>Solver Configurations>Solution 

2 (sol2) click Dependent Variables 1.

4 In the Settings window for Dependent Variables, locate the General section.

5 From the Defined by study step list, choose User defined.

6 In the Model Builder window, under Study 2: External load>Solver Configurations>Solution 

2 (sol2)>Dependent Variables 1 click Pre-deformation (comp1.solid.pblt1.sblt1.d_pre).

7 In the Settings window for State, locate the General section.

8 Clear the Solve for this state check box.

Repeat the same steps for the variables comp1.solid.pblt1.sblt2.d_pre and 
comp1.solid.pblt1.sblt3.d_pre."

9 In the Model Builder window, under Study 2: External load>Solver Configurations>Solution 

2 (sol2)>Dependent Variables 1 click Displacement field (Material) (comp1.u).

10 In the Settings window for Field, locate the Scaling section.

11 In the Scale text field, type 1e-4.

12 On the Study toolbar, click Compute.

Parameter name Parameter value list Parameter unit

lp range(0.2,0.2,1)
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R E S U L T S

Stress (solid) 1
The following steps reproduce the plot in Figure 3:

Surface 1
1 In the Model Builder window, expand the Stress (solid) 1 node, then click Surface 1.

2 In the Settings window for Surface, locate the Range section.

3 Select the Manual color range check box.

4 In the Maximum text field, type 4e8.

Deformation
1 In the Model Builder window, expand the Surface 1 node, then click Deformation.

2 In the Settings window for Deformation, locate the Scale section.

3 In the Scale factor text field, type 50.

Surface 1
In the Model Builder window, under Results>Stress (solid) 1 right-click Surface 1 and choose 
Filter.

Filter 1
1 In the Settings window for Filter, locate the Element Selection section.

2 In the Logical expression for inclusion text field, type dom>6.

Deformation
Proceed to plot the bolt forces as a function of the applied moment as in Figure 4.

1D Plot Group 3
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Data set list, choose Study 2: External load/Solution 2 (sol2).

Global 1
1 On the 1D Plot Group 3 toolbar, click Global.

2 In the Settings window for Global, click Replace Expression in the upper-right corner of 
the y-axis data section. From the menu, choose Component 1>Solid Mechanics>Bolts>

Bolt_1>solid.pblt1.sblt1.F_bolt - Bolt force.
26 |  P R E S T R E S S E D  B O L T S  I N  A  TU B E  C O N N E C T I O N



3 Locate the y-Axis Data section. In the table, enter the following settings:

The bolts in the symmetry plane need the factor 2 in order to give the full bolt force.

4 Click to expand the Legends section. Clear the Show legends check box.

5 Click to expand the Coloring and style section. Locate the Coloring and Style section. In 
the Width text field, type 2.

6 Locate the x-Axis Data section. From the Parameter list, choose Expression.

7 In the Expression text field, type M_appl*lp/1000.

1D Plot Group 3
1 In the Model Builder window, under Results click 1D Plot Group 3.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 Select the x-axis label check box.

4 In the associated text field, type Bending Moment on Tube (kNm).

5 Select the y-axis label check box.

6 In the associated text field, type Axial Force in bolts (kN).

Global 1
1 In the Model Builder window, under Results>1D Plot Group 3 click Global 1.

2 In the Settings window for Global, locate the Legends section.

3 Select the Show legends check box.

4 Click to collapse the Coloring and style section.

1D Plot Group 3
1 In the Model Builder window, under Results click 1D Plot Group 3.

2 In the Settings window for 1D Plot Group, click to expand the Title section.

3 From the Title type list, choose None.

4 Click to expand the Legend section. From the Position list, choose Upper left.

The following steps create the plot in Figure 5:

1D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

Expression Unit Description

solid.pblt1.sblt1.F_bolt*2 kN Force in Bolt 1

solid.pblt1.sblt2.F_bolt kN Force in Bolt 2

solid.pblt1.sblt3.F_bolt*2 kN Force in Bolt 3
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2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Data set list, choose Study 2: External load/Solution 2 (sol2).

Point Graph 1
1 On the 1D Plot Group 4 toolbar, click Point Graph.

2 Select Points 143 and 163 only.

3 In the Settings window for Point Graph, click Replace Expression in the upper-right 
corner of the y-axis data section. From the menu, choose Component 1>Solid Mechanics>

Stress>Stress tensor (Spatial)>solid.sy - Stress tensor, y component.

4 Locate the y-Axis Data section. From the Unit list, choose MPa.

5 Locate the x-Axis Data section. From the Parameter list, choose Expression.

6 In the Expression text field, type M_appl*lp/1000.

7 Click to expand the Coloring and style section. Locate the Coloring and Style section. Find 
the Line style subsection. From the Line list, choose Cycle.

8 In the Width text field, type 2.

9 Click to expand the Legends section. Select the Show legends check box.

10 From the Legends list, choose Manual.

11 In the table, enter the following settings:

1D Plot Group 4
1 In the Model Builder window, under Results click 1D Plot Group 4.

2 In the Settings window for 1D Plot Group, locate the Plot Settings section.

3 Select the x-axis label check box.

4 In the associated text field, type Bending Moment on Tube (kNm).

5 Select the y-axis label check box.

6 In the associated text field, type Bolt stress (MPa).

7 Locate the Legend section. From the Position list, choose Upper left.

Finally, reproduce the contact pressure plots shown in Figure 6 and Figure 7:

3D Plot Group 5
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

Legends

Inside

Outside
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2 On the 3D Plot Group 5 toolbar, click Surface.

Surface 1
1 In the Model Builder window, under Results>3D Plot Group 5 click Surface 1.

2 In the Settings window for Surface, click to expand the Range section.

3 Click Replace Expression in the upper-right corner of the Expression section. From the 
menu, choose Component 1>Solid Mechanics>Contact>Contact 1>solid.cnt1.Tn - Contact 

pressure.

4 Locate the Range section. Select the Manual color range check box.

5 In the Maximum text field, type 1E8.

6 Click the Go to Default 3D View button on the Graphics toolbar.

7 On the 3D Plot Group 5 toolbar, click Plot.

3D Plot Group 5
1 In the Model Builder window, under Results click 3D Plot Group 5.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Data set list, choose Study 2: External load/Solution 2 (sol2).

4 From the Parameter value (lp) list, choose 1.

5 On the 3D Plot Group 5 toolbar, click Plot.
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Introduction

The conditions within gas turbines are extreme. The pressure can be as high as 40  bars, 
and the temperature far above 1000 K. Any new component must therefore be carefully 
designed to be able to withstand thermal stress, vibrations due to the rotating machinery 
and aerodynamic loads exerted by the fluid rushing through the turbine. If a component 
fails, the high rotational speeds can result in a complete rupture of the whole turbine.

The most extreme conditions are found in the high pressure part downstream of the 
combustion chamber where hot combustion gas flows through a cascade of rotors and 
stators. To prevent the parts from melting, relatively “cold” air is taken from bleeding 
vanes located in the high-pressure compressor casing, then led past the combustion 
chamber into the turbine casing in order to be used as a coolant. Directly behind the 
combustion chamber, both internal cooling within ducts and film cooling over the blade 
side surfaces are applied. Further downstream, where the temperature is somewhat lower, 
it may suffice with internal cooling. For more details on gas turbines, see Ref. 1.

Since the physics within a gas turbine is very complex, simplified approaches are often used 
at initial stages of the development of the new components. In this tutorial, the thermal 
stresses in a stator blade with internal cooling are analyzed.

Note: This application requires the Structural Mechanics Module and the CFD Module 
or Heat Transfer Module. It also uses the Material Library.

Model Definition

The model geometry is shown in Figure 1. The stator blade profile is a modified version 
of a design shown in Ref. 2. The model includes some generic mounting details as well as 
a generic internal cooling duct.
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Figure 1: A stator blade with mounting details.

Use the Thermal Stress interface from the Structural Mechanics Module to set up the 
model. The blade and the mounting details are assumed to be made of the M-152 alloy 
which is a 12 Cr alloy with high tensile strength (Ref. 1). M-152 is available in the 
COMSOL Material Library. In addition to the data covered by the Material Library, the 
linear elastic model requires a reference temperature that is set to 300 K and a Poisson’s 
Ratio that is set to 0.33, a number comparable to that for other stainless steels. Any coating 
has been neglected.

Figure 2 shows the cooling duct. The duct geometry is simplified and does not include 
details such as the ribs (Ref. 3) typical for cooling ducts. Instead of simulating the 
complicated flow in the duct, an average Nusselt number correlation from Ref. 3 is used 
to calculate a heat transfer coefficient. Assume the cooling fluid to be air at 30 bar and 
600 K.
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Figure 2: The internal cooling duct.

The heat flux on the stator blade surfaces is calculated using the heat transfer coefficient. 
The pressure and suction sides are approximated as two flat plates using the local heat 
transfer coefficient for external forced convection. The combustion gases are 
approximated as air at 30 bar and 1100 K. The corresponding speed of sound is 
approximately 650 m/s. 

Ref. 4 contains a Mach number plot of stators without film cooling. A typical Mach 
number is 0.7 on the pressure side (the concave side) and 0.45 on the suction side (the 
convex side). This corresponds to approximately 450 m/s on the pressure side and 300 m/
s on the suction side.

The platform walls adjacent to the stator blades are treated in the same way as the stator 
itself but with the free stream velocity set to 350 m/s.
4 |  T H E R M A L  S T R E S S  A N A L Y S I S  O F  A  TU R B I N E  S T A T O R  B L A D E



The stator blade exchanges heat with the cooling air through the boundaries highlighted 
in Figure 3. It is assumed that the turbine has a local working temperature of 900 K, and 
that the heat transfer coefficient to the stator is 25 W/(m2·K).

Figure 3: Boundaries through which heat is exchanged with the cooling air.

The attachment of the stator element to a ring support is simulated via roller and spring 
foundation boundary conditions on few boundaries. All other boundaries are free to 
deform as a result of thermal expansion.

Results and Discussion

Figure 4 shows a temperature surface plot. The internal cooling creates significant 
temperature gradients within the blade. However, the trailing edge reaches a temperature 
close to that of the combustion gases, which indicates that the cooling might be 
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insufficient. The side walls also become very hot, and some additional cooling can be 
beneficial.

Figure 4: Surface temperature plot.

Figure 5 shows a surface plot of the von Mises stress. The maximum stress with a value 
close to the yield stress for the material (Ref. 5) occurs in the internal cooling duct. No 
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definite assessment can however be made without conducting a more advanced analysis 
that includes details of the flow inside the duct.

Figure 5: Surface plot of the von Mises stress.
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Figure 6: Surface plot of the displacement. 
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Modeling Instructions

Note: Instructions below require to select entities corresponding to a particular numbers 
list. For example:
Select Boundaries 113 and 139 only.
In most cases the easiest way to select them is to click the Paste Selection button  and 
paste the numbers as they are printed in the document (for example paste “113 and 
139” for the example above).

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Thermal Stress.

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies for Selected Physics Interfaces>Stationary.

6 Click Done.

G L O B A L  D E F I N I T I O N S

Parameters
1 On the Home toolbar, click Parameters.

2 In the Settings window for Parameters, locate the Parameters section.

3 In the table, enter the following settings:

Name Expression Value Description

Pr_cool 0.72 0.72 Cooling Prandtl 
number

U_suction_side 450[m/s] 450 m/s Gas velocity on 
stator suction side

U_pressure_sid
e

300[m/s] 300 m/s Gas velocity on 
stator pressure 
side
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G E O M E T R Y  1

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
turbine_stator.mphbin.

5 Click Import.

To see the interior:

6 Click the Transparency button on the Graphics toolbar.

The imported geometry should look as shown in the Figure 1.

7 On the Home toolbar, click Build All.

8 Click the Zoom Extents button on the Graphics toolbar.

D E F I N I T I O N S

Define a number of sections to simplify the model setup. First define the internal cooling 
duct boundaries.

U_platform 350[m/s] 350 m/s Gas velocity along 
platform walls

T_gas 1100[K] 1100 K Gas temperature

p_high 30[bar] 3E6 Pa High pressure level

mu_cool 3.1e-5[Pa*s] 3.1E-5 Pa·s Viscosity of the 
cooling air

Cp_cool 770[J/kg/K] 770 J/(kg·K) Heat capacity of the 
cooling air

T_cool 800[K] 800 K Cooling air 
temperature

H_cool 0.01[m] 0.01 m Characteristic 
length scale of 
cooling channels

T_work 900[K] 900 K Working temperature

Nu_cool 400 400 Average Nusselt 
number in cooling 
channel

Name Expression Value Description
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Explicit 1
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Cooling_Duct in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Click Paste Selection.

5 In the Paste Selection dialog box, type 222-225, 236, 261-266, 270-271, 278-279, 
283-285, 292-305, 308-311, 313-314, 316, 321 in the Selection text field.

If you are reading an electronic version of this document, you can copy the geometric 
entity numbers from the text.

6 Click OK.

7 Click the Transparency button on the Graphics toolbar.

8 Click the Wireframe Rendering button on the Graphics toolbar.

The selection is shown in Figure 2.

Proceed to select the boundaries through which heat exchanger with the rest of turbine 
occur Figure 3.

Explicit 2
1 On the Definitions toolbar, click Explicit.

2 In the Settings window for Explicit, type Exchange_Boundaries in the Label text field.

3 Locate the Input Entities section. From the Geometric entity level list, choose Boundary.

4 Click Paste Selection.

5 In the Paste Selection dialog box, type 3-4, 9, 12, 14, 16, 19-20, 22-24, 28-96, 
98-117, 122-135, 138-162, 166-221, 223, 226-231, 239-260, 267-269, 

272-277, 280-282, 322-444 in the Selection text field.

6 Click OK.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Material Library>Iron Alloys>JETHETE M-152 or Moly Ascoloy>JETHETE 

M-152 or Moly Ascoloy [solid].

4 Click Add to Component in the window toolbar.

5 On the Home toolbar, click Add Material to close the Add Material window.
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M A T E R I A L S

JETHETE M-152 or Moly Ascoloy [solid] (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click JETHETE M-152 

or Moly Ascoloy [solid] (mat1).

2 In the Settings window for Material, locate the Material Contents section.

3 In the table, enter the following settings:

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window’s toolbar, click the Show button and select Discretization in 
the menu.

2 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

3 In the Settings window for Solid Mechanics, click to expand the Discretization section.

4 From the Displacement field list, choose Linear.

M U L T I P H Y S I C S

1 In the Model Builder window, under Component 1 (comp1)>Multiphysics click Thermal 

Expansion 1 (te1).

2 In the Settings window for Thermal Expansion, locate the Thermal Expansion Properties 
section.

3 In the Tref text field, type 300[K].

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

On the Physics toolbar, click Solid Mechanics (solid) and choose Heat Transfer in Solids (ht).

Initial Values 1
1 In the Model Builder window, under Component 1 (comp1)>Heat Transfer in Solids (ht) 

click Initial Values 1.

2 In the Settings window for Initial Values, type T_gas in the T text field.

3 In the Model Builder window, click Heat Transfer in Solids (ht).

Heat Flux 1
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

Property Name Value Unit Property group

Poisson’s ratio nu 0.33 1 Young’s modulus and 
Poisson’s ratio
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3 From the Selection list, choose Exchange_Boundaries.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type 25.

6 In the Text text field, type T_work.

Heat Flux 2
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 In the Settings window for Heat Flux, locate the Boundary Selection section.

3 From the Selection list, choose Cooling_Duct.

4 Locate the Heat Flux section. Click the Convective heat flux button.

5 In the h text field, type Nu_cool*mu_cool*Cp_cool/2/Pr_cool/H_cool.

6 In the Text text field, type T_cool.

Heat Flux 3
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 137 and 163 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 From the Heat transfer coefficient list, choose External forced convection.

6 From the list, choose Plate, local transfer coefficient.

7 In the xpl text field, type 0.1675-x.

8 In the U text field, type U_suction_side.

9 In the pA text field, type p_high.

10 In the Text text field, type T_gas.

Heat Flux 4
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 136 and 312 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 From the Heat transfer coefficient list, choose External forced convection.

6 From the list, choose Plate, local transfer coefficient.

7 In the xpl text field, type 0.1675-x.

8 In the U text field, type U_pressure_side.
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9 In the pA text field, type p_high.

10 In the Text text field, type T_gas.

Heat Flux 5
1 On the Physics toolbar, click Boundaries and choose Heat Flux.

2 Select Boundaries 15, 21, 118–121, 164, 165, 232, 234, 235, 237, 286, 289–291, 
306, 307, 315, 317, and 320 only.

3 In the Settings window for Heat Flux, locate the Heat Flux section.

4 Click the Convective heat flux button.

5 From the Heat transfer coefficient list, choose External forced convection.

6 From the list, choose Plate, local transfer coefficient.

7 In the xpl text field, type 0.19-x.

8 In the U text field, type U_platform.

9 In the pA text field, type p_high.

10 In the Text text field, type T_gas.

S O L I D  M E C H A N I C S  ( S O L I D )

In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

Roller 1
1 On the Physics toolbar, click Boundaries and choose Roller.

2 Select Boundaries 140, 146, and 213 only.

Spring Foundation 1
1 On the Physics toolbar, click Boundaries and choose Spring Foundation.

2 Select Boundaries 426 and 428 only.

3 In the Settings window for Spring Foundation, locate the Spring section.

4 From the list, choose Diagonal.

5 In the kA table, enter the following settings:

Spring Foundation 2
1 On the Physics toolbar, click Boundaries and choose Spring Foundation.

1e9 0 0

0 0 0

0 0 0
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2 Select Boundaries 82, 90, 192, and 255 only.

3 In the Settings window for Spring Foundation, locate the Spring section.

4 From the list, choose Diagonal.

5 In the kA table, enter the following settings:

Spring Foundation 3
1 On the Physics toolbar, click Boundaries and choose Spring Foundation.

2 Select Boundary 17 only.

3 In the Settings window for Spring Foundation, locate the Spring section.

4 From the list, choose Diagonal.

5 In the kA table, enter the following settings:

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Size.

Size
1 In the Settings window for Size, locate the Element Size section.

2 From the Predefined list, choose Fine.

Size 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Size 1.

2 In the Settings window for Size, locate the Geometric Entity Selection section.

3 From the Geometric entity level list, choose Boundary.

4 From the Selection list, choose Cooling_Duct.

5 Locate the Element Size section. From the Predefined list, choose Fine.

6 In the Model Builder window, right-click Mesh 1 and choose Free Tetrahedral.

0 0 0

0 0 0

0 0 1e10

0 0 0

0 1e9 0

0 0 0
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Free Tetrahedral 1
In the Settings window for Free Tetrahedral, click Build All.

S T U D Y  1

On the Home toolbar, click Compute.

R E S U L T S

Stress (solid)
The first default plot show the von Mises stress. Disable the deformation and create a max/
min plot to display the critical point in the stator.

Surface 1
In the Model Builder window, expand the Stress (solid) node.

Deformation
1 In the Model Builder window, expand the Surface 1 node.

2 Right-click Deformation and choose Disable.

3 On the Stress (solid) toolbar, click More Plots and choose Max/Min Surface.

Max/Min Surface 1
1 In the Settings window for Max/Min Surface, click Replace Expression in the upper-right 

corner of the Expression section. From the menu, choose Component 1>Solid Mechanics>

Stress>solid.mises - von Mises stress.

2 On the Stress (solid) toolbar, click Plot.

3 Click the Zoom Extents button on the Graphics toolbar.

4 Click the Transparency button on the Graphics toolbar.

The second default plot shows the temperature distribution Figure 4.

Temperature (ht)
1 In the Model Builder window, under Results click Temperature (ht).

2 In the Settings window for 3D Plot Group, locate the Plot Settings section.

3 Clear the Plot data set edges check box.

4 On the Temperature (ht) toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.

Finally, plot the total displacement (Figure 6).

3D Plot Group 4
On the Home toolbar, click Add Plot Group and choose 3D Plot Group.
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Volume 1
1 In the Model Builder window, right-click 3D Plot Group 4 and choose Volume.

2 In the Settings window for Volume, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>

Displacement>solid.disp - Total displacement.

3 Locate the Expression section. From the Unit list, choose mm.

4 On the 3D Plot Group 4 toolbar, click Plot.

5 Click the Zoom Extents button on the Graphics toolbar.
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Introduction

The example studies a forced response of a typical viscoelastic damper. Damping elements 
involving layers of viscoelastic materials are often used for reduction of seismic and wind 
induced vibrations in buildings and other tall structures. The common feature is that the 
frequency of the forced vibrations is low.

Model Definition

The geometry of the viscoelastic damper is shown in Figure 1, from Ref. 1. The damper 
consists of two layers of viscoelastic material confined between mounting elements made 
of steel.

Figure 1: Viscoelastic damping element.

You model the viscoelastic layers by the generalized Maxwell model available in COMSOL 
Multiphysics. The generalized Maxwell model represents the viscoelastic material as a 
series of branches, each with a spring-dashpot pair. You can find more details about this 
material model in the section “About Viscoelastic Materials” in the Structural Mechanics 
Module User’s Guide.
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Eighteen viscoelastic branches guarantee accurate representation of the material behavior 
for a wide range of excitation frequencies, when the damper is subjected to forced 
vibration. The values of the shear moduli and relaxation times for each branch are available 
in Ref. 1. They are summarized in the following table:

TABLE 1:  MODEL DATA FOR THE VISCOELASTIC DAMPER MODEL

PROPERTY VALUE DESCRIPTION

G 5.86·10-2 MPa Long time shear modulus

ρ 1.06 g/cm3 Density

G1 13,3 MPa Shear modulus branch 1

τ1 10-7 s Relaxation time branch 1

G2 286 MPa Shear modulus branch 2

τ2 10-6 s Relaxation time branch 2

G3 2.91·102 MPa Shear modulus branch 3

τ3 3.16·10-6 s Relaxation time branch 3

G4 2.12·102 MPa Shear modulus branch 4

τ4 10-5 s Relaxation time branch 4

G5 1.12·102 MPa Shear modulus branch 5

τ5 3.16·10-5 s Relaxation time branch 5

G6 61.6 MPa Shear modulus branch 6

τ6 10-4 s Relaxation time branch 6

G7 29.8 MPa Shear modulus branch 7

τ7 3.16·10-4 s Relaxation time branch 7

G8 16.1 MPa Shear modulus branch 8

τ8 10-3 s Relaxation time branch 8

G9 7.83 MPa Shear modulus branch 9

τ9 3.16·10-3 s Relaxation time branch 9

G10 4.15 MPa Shear modulus branch 10

τ10 10-2 s Relaxation time branch 10

G11 2.03 MPa Shear modulus branch 11

τ11 3.16·10-2 s Relaxation time branch 11

G12 1.11 MPa Shear modulus branch 12

τ12 0.1 s Relaxation time branch 12

G13 0.491 MPa Shear modulus branch 13

τ13 0.316 s Relaxation time branch 13
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One of the mounting elements is fixed; the other two are loaded with periodic forces with 
frequencies in the range 0–5 Hz.

The time-domain representation of the forced solution is computed using the fast Fourier 
transform (FFT).

Results and Discussion

The harmonic response at 3 Hz is shown in Figure 2.

In the frequency domain, the viscoelastic properties of the material appear as the storage 
modulus and loss modulus. The computed variation of the viscoelastic moduli with 
frequency is shown in Figure 3. The result is in very good agreement with the 
experimental data (Figure 7 in Ref. 2)

G14 0.326 MPa Shear modulus branch 14

τ14 1 s Relaxation time branch 14

G15 8.25·10-2 MPa Shear modulus branch 15

τ15 3.16 s Relaxation time branch 15

G16 0.126 MPa Shear modulus branch 16

τ16 10 s Relaxation time branch 16

G17 3.73·10-2 MPa Shear modulus branch 17

τ17 100 s Relaxation time branch 17

G18 1.18·10-2 MPa Shear modulus branch 18

τ18 1000 s Relaxation time branch 18

TABLE 1:  MODEL DATA FOR THE VISCOELASTIC DAMPER MODEL

PROPERTY VALUE DESCRIPTION
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.

Figure 2: Vertical displacement of the damper, harmonic response. 

Figure 3: Viscoelastic storage modulus (solid line) and loss modulus (dashed line). Both 
quantities are normalized by 6.895 to simplify the comparison with Ref. 2.
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The time domain solution obtained via FFT for the case of excitation frequency of 3 Hz 
is shown in Figure 4.

Figure 4: Displacement of the damper after 1/3 second of forced vibrations.
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Finally, the total vertical force vs vertical displacement for one of the mounting holes is 
shown in Figure 5.

Figure 5: Hysteresis loop for excitation frequency of 3 [Hz] over the time interval of 1/
3 second.

Notes About the COMSOL Implementation

You model in 3D and use the Solid Mechanics interface with Linear Elastic Material, add 
the Viscoelasticity node to the domains representing the viscoelastic layers.
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Application Library path: Structural_Mechanics_Module/
Dynamics_and_Vibration/viscoelastic_damper_frequency

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Frequency Domain.

6 Click Done.

G E O M E T R Y  1

You import the damper geometry from a file.

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
viscoelastic_damper.mphbin.

5 Click Import.

6 Click the Go to Default 3D View button on the Graphics toolbar.

The imported geometry should look similar to that shown in Figure 1.

S O L I D  M E C H A N I C S  ( S O L I D )

Linear Elastic Material 2
1 On the Physics toolbar, click Domains and choose Linear Elastic Material.
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2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the Specify list, choose Bulk modulus and shear modulus.

4 Select the Nearly incompressible material check box.

5 Select Domains 2 and 4 only.

Viscoelasticity 1
1 On the Physics toolbar, click Attributes and choose Viscoelasticity.

Since there are 18 branches in this material model, the data has been collected in a text 
file which you can load.

2 In the Settings window for Viscoelasticity, locate the Viscoelasticity Model section.

3 Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
viscoelastic_damper_viscoelastic_data.txt.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Steel AISI 4340.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Steel AISI 4340 (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Steel AISI 4340 

(mat1).

2 Select Domains 1, 3, and 5 only.

Material 2 (mat2)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.

2 In the Settings window for Material, type Viscoelastic in the Label text field.

3 Select Domains 2 and 4 only.
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4 Locate the Material Contents section. In the table, enter the following settings:

5 On the Home toolbar, click Add Material to close the Add Material window.

S O L I D  M E C H A N I C S  ( S O L I D )

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundaries 24–27 only.

Prescribed Displacement 1
1 On the Physics toolbar, click Boundaries and choose Prescribed Displacement.

2 Select Boundaries 40 and 41 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in x direction check box.

5 Select the Prescribed in y direction check box.

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 40 and 41 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the FA vector as

Phase 1
1 On the Physics toolbar, click Attributes and choose Phase.

2 In the Settings window for Phase, locate the Phase section.

Property Name Value Unit Property group

Bulk modulus K 4e8 N/m² Bulk modulus and shear 
modulus

Shear modulus G 5.86e4 N/m² Bulk modulus and shear 
modulus

Density rho 1060 kg/m³ Basic

0 x

0 y

8.5e6[Pa] z
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3 Specify the φ vector as

Prescribed Displacement 2
1 On the Physics toolbar, click Boundaries and choose Prescribed Displacement.

2 Select Boundaries 32 and 33 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in y direction check box.

Boundary Load 2
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 32 and 33 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the FA vector as

M E S H  1

Mesh the side surfaces of the viscoelastic layers and then sweep the resulting mesh into the 
layers.

Free Triangular 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Free Triangular.

2 Select Boundaries 6 and 20 only.

3 In the Settings window for Free Triangular, click Build Selected.

Swept 1
1 In the Model Builder window, right-click Mesh 1 and choose Swept.

2 In the Settings window for Swept, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

0 x

0 y

pi/2 z

5e5[Pa] x

0 y

8.5e6[Pa] z
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4 Select Domains 2 and 4 only.

Distribution 1
1 Right-click Component 1 (comp1)>Mesh 1>Swept 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 3.

Swept 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Swept 1.

2 In the Settings window for Swept, click Build Selected.

Mesh the rest of the geometry using a free tetrahedral mesh.

Free Tetrahedral 1
1 In the Model Builder window, right-click Mesh 1 and choose Free Tetrahedral.

2 In the Settings window for Free Tetrahedral, click Build Selected.

The complete mesh should look similar to that shown in the figure below.
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S T U D Y  1

Step 1: Frequency Domain
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Frequency 

Domain.

2 In the Settings window for Frequency Domain, locate the Study Settings section.

3 In the Frequencies text field, type range(0,0.125,0.5) range(1,0.5,5).

Solution 1 (sol1)
On the Study toolbar, click Show Default Solver.

R E S U L T S

Before computing the solution, set up a displacement plot that will be displayed and 
updated after every frequency response computation.

3D Plot Group 1
1 On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

2 In the Settings window for 3D Plot Group, type Displacement, Frequency Domain 
in the Label text field.

Surface 1
1 Right-click Displacement, Frequency Domain and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1 (comp1)>Solid Mechanics>

Displacement>Displacement field (Material)>w - Displacement field, Z component.

3 Locate the Expression section. From the Unit list, choose mm.

4 Right-click Results>Displacement, Frequency Domain>Surface 1 and choose Deformation.

S T U D Y  1

Step 1: Frequency Domain
1 In the Model Builder window, under Study 1 click Step 1: Frequency Domain.

2 In the Settings window for Frequency Domain, click to expand the Results while solving 
section.

3 Locate the Results While Solving section. Select the Plot check box.

Solution 1 (sol1)
1 In the Model Builder window, expand the Study 1>Solver Configurations node, then click 

Solution 1 (sol1).
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2 In the Settings window for Solution, click Compute.

R E S U L T S

Displacement, Frequency Domain
1 In the Model Builder window, under Results click Displacement, Frequency Domain.

2 In the Settings window for 3D Plot Group, locate the Data section.

3 From the Parameter value (freq (Hz)) list, choose 3.

4 Click to expand the Color legend section. Locate the Color Legend section. Select the 
Show maximum and minimum values check box.

5 On the Displacement, Frequency Domain toolbar, click Plot.

6 Click the Go to Default 3D View button on the Graphics toolbar.

The computed solution should closely resemble that shown in Figure 2.

To plot the storage and loss moduli, follow these steps:

Cut Point 3D 1
1 On the Results toolbar, click Cut Point 3D.

2 In the Settings window for Cut Point 3D, locate the Point Data section.

3 In the X text field, type 0.

4 In the Z text field, type 0.

5 In the Y text field, type -0.01.

1D Plot Group 2
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Data set list, choose Cut Point 3D 1.

4 Click to expand the Title section. From the Title type list, choose Manual.

5 In the Title text area, type Storage and loss moduli.

Point Graph 1
1 On the 1D Plot Group 2 toolbar, click Point Graph.

2 In the Settings window for Point Graph, locate the y-Axis Data section.

3 In the Expression text field, type solid.Gstor/6.895.

1D Plot Group 2
In the Model Builder window, under Results click 1D Plot Group 2.
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Point Graph 2
1 On the 1D Plot Group 2 toolbar, click Point Graph.

2 In the Settings window for Point Graph, locate the y-Axis Data section.

3 In the Expression text field, type solid.Gloss/6.895.

4 Click to expand the Coloring and style section. Locate the Coloring and Style section. Find 
the Line style subsection. From the Line list, choose Dashed.

5 On the 1D Plot Group 2 toolbar, click Plot.

Add a new study to compute by using FFT the solution representation in time domain for 
the exitation frequency of 3 [Hz].

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Empty Study.

4 Click Add Study.

S T U D Y  2

Frequency to Time FFT
On the Study toolbar, click Study Steps and choose Time Dependent>Frequency to Time FFT.

Step 1: Frequency to Time FFT
1 In the Settings window for Frequency to Time FFT, locate the Study Settings section.

2 From the Input study list, choose Study 1, Frequency Domain.

3 In the Output times text field, type range(0,1/(3*30), 1/3).

4 Select the Use window function check box.

5 From the Window function list, choose Rectangular.

6 In the Window start text field, type 2.9.

7 In the Window end text field, type 3.1.

8 From the Scaling list, choose Discrete Fourier transform.

D E F I N I T I O N S

Set up a variable to compute the time domain equivalent of the total force applied to one 
of the mounting holes.
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Variables 1
1 On the Home toolbar, click Variables and choose Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

4 On the Home toolbar, click Compute.

The default plot will show the stress at the last time moment. Change it to visualize the 
vertical displacement as shown in Figure 4.

R E S U L T S

Stress (solid)
1 In the Model Builder window, under Results click Stress (solid).

2 In the Settings window for 3D Plot Group, type Displacement, Time Domain in the 
Label text field.

3 Click to expand the Color legend section. Locate the Color Legend section. Select the 
Show maximum and minimum values check box.

Surface 1
1 In the Model Builder window, expand the Results>Displacement, Time Domain node, then 

click Surface 1.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1>Solid Mechanics>

Displacement>Displacement field (Material)>w - Displacement field, Z component.

3 Locate the Expression section. From the Unit list, choose mm.

4 On the Displacement, Time Domain toolbar, click Plot.

1D Plot Group 4
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

Plot the total vertical force vs vertical displacement for one of the mounting holes, 
Figure 5.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Data set list, choose Study 2/Solution 2 (sol2).

Name Expression Unit Description

Fz1 8.5e6[Pa]*cos(2*pi*t*
3[1/s])*pi*0.016[m]*
0.01[m]

N Total force, Z component
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Point Graph 1
1 On the 1D Plot Group 4 toolbar, click Point Graph.

2 In the Settings window for Point Graph, locate the Selection section.

3 Select the Active toggle button.

4 Select Point 23 only.

5 Locate the y-Axis Data section. In the Expression text field, type Fz1.

6 From the Unit list, choose kN.

7 Locate the x-Axis Data section. From the Parameter list, choose Expression.

8 In the Expression text field, type w.

9 From the Unit list, choose mm.

10 Click to expand the Title section. From the Title type list, choose Manual.

11 In the Title text area, type Hysteresis loop.

12 On the 1D Plot Group 4 toolbar, click Plot.
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Introduction

The model studies the forced response of a typical viscoelastic damper. Damping elements 
involving layers of viscoelastic materials are often used for reduction of seismic and wind 
induced vibrations in buildings and other tall structures. The common feature is that the 
frequency of the forced vibrations is low.

Model Definition

The geometry of the viscoelastic damper is shown in Figure 1, from Ref. 1. The damper 
consists of two layers of viscoelastic material confined between mounting elements made 
of steel.

Figure 1: Viscoelastic damping element.

You model the viscoelastic layers by the generalized Maxwell model available in COMSOL 
Multiphysics. The generalized Maxwell model represents the viscoelastic material as a 
series of branches, each with a spring-dashpot pair. You can find more details about this 
material model in the section “About Viscoelastic Materials” in the Structural Mechanics 
Module User’s Guide.
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Eighteen viscoelastic branches guarantee accurate representation of the material behavior 
for different excitation frequencies, when the damper is subjected to forced vibration. The 
values of the shear moduli and relaxation times for each branch are available in Ref. 1. They 
are summarized in the following table:

TABLE 1:  MODEL DATA FOR THE VISCOELASTIC DAMPER MODEL

PROPERTY VALUE DESCRIPTION

K 4·104 MPa Bulk modulus

G 5.86·10-2 MPa Long time shear modulus

ρ 1.06 g/cm3 Density

G1 13,3 MPa Shear modulus branch 1

τ1 10-7 s Relaxation time branch 1

G2 286 MPa Shear modulus branch 2

τ2 10-6 s Relaxation time branch 2

G3 2.91·102 MPa Shear modulus branch 3

τ3 3.16·10-6 s Relaxation time branch 3

G4 2.12·102 MPa Shear modulus branch 4

τ4 10-5 s Relaxation time branch 4

G5 1.12·102 MPa Shear modulus branch 5

τ5 3.16·10-5 s Relaxation time branch 5

G6 61.6 MPa Shear modulus branch 6

τ6 10-4 s Relaxation time branch 6

G7 29.8 MPa Shear modulus branch 7

τ7 3.16·10-4 s Relaxation time branch 7

G8 16.1 MPa Shear modulus branch 8

τ8 10-3 s Relaxation time branch 8

G9 7.83 MPa Shear modulus branch 9

τ9 3.16·10-3 s Relaxation time branch 9

G10 4.15 MPa Shear modulus branch 10

τ10 10-2 s Relaxation time branch 10

G11 2.03 MPa Shear modulus branch 11

τ11 3.16·10-2 s Relaxation time branch 11

G12 1.11 MPa Shear modulus branch 12

τ12 0.1 s Relaxation time branch 12

G13 0.491 MPa Shear modulus branch 13
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One of the mounting elements is fixed; the other two are loaded with periodic forces with 
a frequency of 3 Hz. 

Results and Discussion

Figure 2 shows the results of the transient computations after two seconds of forced 
vibrations. 

The typical viscoelastic hysteresis loops for a point within one of the mounting elements 
are shown in Figure 3.

τ13 0.316 s Relaxation time branch 13

G14 0.326 MPa Shear modulus branch 14

τ14 1 s Relaxation time branch 14

G15 8.25·10-2 MPa Shear modulus branch 15

τ15 3.16 s Relaxation time branch 15

G16 0.126 MPa Shear modulus branch 16

τ16 10 s Relaxation time branch 16

G17 3.73·10-2 MPa Shear modulus branch 17

τ17 100 s Relaxation time branch 17

G18 1.18·10-2 MPa Shear modulus branch 18

τ18 1000 s Relaxation time branch 18

TABLE 1:  MODEL DATA FOR THE VISCOELASTIC DAMPER MODEL

PROPERTY VALUE DESCRIPTION
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Figure 2: Displacement field.

Figure 3: Displacement vs. applied force.
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Application Library path: Structural_Mechanics_Module/
Dynamics_and_Vibration/viscoelastic_damper_transient

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 3D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 Click Study.

5 In the Select Study tree, select Preset Studies>Time Dependent.

6 Click Done.

G E O M E T R Y  1

You import the predefined geometry from a file.

Import 1 (imp1)
1 On the Home toolbar, click Import.

2 In the Settings window for Import, locate the Import section.

3 Click Browse.

4 Browse to the application’s Application Libraries folder and double-click the file 
viscoelastic_damper.mphbin.

5 Click Import.
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6 Click the Go to Default 3D View button on the Graphics toolbar.

The imported geometry should look similar to that shown in Figure 1.

S O L I D  M E C H A N I C S  ( S O L I D )

Linear Elastic Material 2
1 On the Physics toolbar, click Domains and choose Linear Elastic Material.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the Specify list, choose Bulk modulus and shear modulus.

4 Select the Nearly incompressible material check box.

5 Select Domains 2 and 4 only.

Viscoelasticity 1
1 On the Physics toolbar, click Attributes and choose Viscoelasticity.

Since there are 18 branches in this material model, the data has been collected in a text 
file which you can load.

2 In the Settings window for Viscoelasticity, locate the Viscoelasticity Model section.

3 Click Load from File.

4 Browse to the application’s Application Libraries folder and double-click the file 
viscoelastic_damper_viscoelastic_data.txt.

A D D  M A T E R I A L

1 On the Home toolbar, click Add Material to open the Add Material window.

2 Go to the Add Material window.

3 In the tree, select Built-In>Steel AISI 4340.

4 Click Add to Component in the window toolbar.

M A T E R I A L S

Steel AISI 4340 (mat1)
1 In the Model Builder window, under Component 1 (comp1)>Materials click Steel AISI 4340 

(mat1).

2 Select Domains 1, 3, and 5 only.

Material 2 (mat2)
1 In the Model Builder window, under Component 1 (comp1) right-click Materials and 

choose Blank Material.
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2 In the Settings window for Material, type Viscoelastic in the Label text field.

3 Select Domains 2 and 4 only.

4 Locate the Material Contents section. In the table, enter the following settings:

5 On the Home toolbar, click Add Material to close the Add Material window.

S O L I D  M E C H A N I C S  ( S O L I D )

Fixed Constraint 1
1 On the Physics toolbar, click Boundaries and choose Fixed Constraint.

2 Select Boundaries 24–27 only.

Prescribed Displacement 1
1 On the Physics toolbar, click Boundaries and choose Prescribed Displacement.

2 Select Boundaries 40 and 41 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in x direction check box.

5 Select the Prescribed in y direction check box.

Boundary Load 1
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 40 and 41 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the FA vector as

Property Name Value Unit Property group

Bulk modulus K 4e8 N/m² Bulk modulus and shear 
modulus

Shear modulus G 5.86e4 N/m² Bulk modulus and shear 
modulus

Density rho 1060 kg/m³ Basic

0 x

0 y

8.5e6[Pa]*sin(pi/2+2*pi*t*3[1/s]) z
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Prescribed Displacement 2
1 On the Physics toolbar, click Boundaries and choose Prescribed Displacement.

2 Select Boundaries 32 and 33 only.

3 In the Settings window for Prescribed Displacement, locate the Prescribed Displacement 
section.

4 Select the Prescribed in y direction check box.

Boundary Load 2
1 On the Physics toolbar, click Boundaries and choose Boundary Load.

2 Select Boundaries 32 and 33 only.

3 In the Settings window for Boundary Load, locate the Force section.

4 Specify the FA vector as

D E F I N I T I O N S

Set up an integration operator to compute the total force applied to one of the mounting 
holes. You configure the integration to be performed on the Material frame, because this 
is the frame used within the Solid Mechanics interface.

Integration 1 (intop1)
1 On the Definitions toolbar, click Component Couplings and choose Integration.

2 In the Settings window for Integration, locate the Advanced section.

3 From the Frame list, choose Material  (X, Y, Z).

4 Locate the Source Selection section. From the Geometric entity level list, choose 
Boundary.

5 Select Boundaries 32 and 33 only.

Variables 1
1 On the Definitions toolbar, click Local Variables.

2 In the Settings window for Variables, locate the Variables section.

5e5[Pa]*sin(2*pi*t*3[1/s]) x

0 y

8.5e6[Pa]*sin(2*pi*t*3[1/s]) z
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3 In the table, enter the following settings:

M E S H  1

Mesh the side surfaces of the viscoelastic layers and then sweep the resulting mesh into the 
layers.

Free Triangular 1
1 In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 

More Operations>Free Triangular.

2 Select Boundaries 6 and 20 only.

3 In the Settings window for Free Triangular, click Build Selected.

Swept 1
1 In the Model Builder window, right-click Mesh 1 and choose Swept.

2 In the Settings window for Swept, locate the Domain Selection section.

3 From the Geometric entity level list, choose Domain.

4 Select Domains 2 and 4 only.

Distribution 1
1 Right-click Component 1 (comp1)>Mesh 1>Swept 1 and choose Distribution.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 3.

Swept 1
1 In the Model Builder window, under Component 1 (comp1)>Mesh 1 click Swept 1.

2 In the Settings window for Swept, click Build Selected.

Mesh the rest of the geometry using a free tetrahedral mesh.

Free Tetrahedral 1
1 In the Model Builder window, right-click Mesh 1 and choose Free Tetrahedral.

Name Expression Unit Description

Fz1 intop1(solid.FperAreaz) N Total force, Z 
component
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2 In the Settings window for Free Tetrahedral, click Build Selected.

The complete mesh should look similar to that shown in the figure below.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, expand the Study 1 node, then click Step 1: Time 

Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,0.01,2).

Solution 1 (sol1)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Study 1>Solver Configurations node.

3 In the Model Builder window, expand the Solution 1 (sol1) node, then click Dependent 

Variables 1.

4 In the Settings window for Dependent Variables, locate the Scaling section.

5 From the Method list, choose Manual.
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6 In the Scale text field, type 0.1.

This scale is applied to the visoelastic strain variables. The scales for the displacement 
components are choosen according to the size of the geometry. Use the following scale 
for the pressure help variable.

7 In the Model Builder window, expand the Study 1>Solver Configurations>Solution 1 

(sol1)>Dependent Variables 1 node, then click Auxiliary pressure (comp1.solid.pw).

8 In the Settings window for Field, locate the Scaling section.

9 In the Scale text field, type 1e6.

10 In the Model Builder window, under Study 1>Solver Configurations>Solution 1 (sol1) click 
Time-Dependent Solver 1.

11 In the Settings window for Time-Dependent Solver, click to expand the Output section.

12 Clear the Store time derivatives check box.

The values of derivatives are not needed for the analysis. By not storing them, you 
reduce significantly the size of the output data.

R E S U L T S

Before computing the solution, set up a displacement plot that will be displayed and 
updated after every time step of the transient analysis.

3D Plot Group 1
On the Home toolbar, click Add Plot Group and choose 3D Plot Group.

Surface 1
1 In the Model Builder window, right-click 3D Plot Group 1 and choose Surface.

2 In the Settings window for Surface, click Replace Expression in the upper-right corner of 
the Expression section. From the menu, choose Component 1 (comp1)>Solid Mechanics>

Displacement>Displacement field (Material)>w - Displacement field, Z component.

3 Locate the Expression section. From the Unit list, choose mm.

4 Right-click Results>3D Plot Group 1>Surface 1 and choose Deformation.

S T U D Y  1

Step 1: Time Dependent
1 In the Model Builder window, under Study 1 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, click to expand the Results while solving 
section.

3 Locate the Results While Solving section. Select the Plot check box.
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Solution 1 (sol1)
1 In the Model Builder window, under Study 1>Solver Configurations click Solution 1 (sol1).

2 In the Settings window for Solution, click Compute.

R E S U L T S

3D Plot Group 1
1 Click the Go to Default 3D View button on the Graphics toolbar.

The computed solution should closely resemble that shown in Figure 2.

To plot the displacement vs. applied force, follow these steps:

1D Plot Group 2
1 On the Home toolbar, click Add Plot Group and choose 1D Plot Group.

2 In the Settings window for 1D Plot Group, click to expand the Title section.

3 From the Title type list, choose Manual.

4 In the Title text area, type Hysteresis loops .

Point Graph 1
1 On the 1D Plot Group 2 toolbar, click Point Graph.

2 Select Point 23 only.

3 In the Settings window for Point Graph, locate the x-Axis Data section.

4 From the Parameter list, choose Expression.

5 Click Replace Expression in the upper-right corner of the x-axis data section. From the 
menu, choose Component 1>Solid Mechanics>Displacement>Displacement field 

(Material)>w - Displacement field, Z component.

6 Locate the x-Axis Data section. From the Unit list, choose mm.

7 Locate the y-Axis Data section. In the Expression text field, type Fz1.

8 From the Unit list, choose kN.

9 On the 1D Plot Group 2 toolbar, click Plot.
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Introduction

This example studies the temperature effects on the viscoelastic stress relaxation in a 
generalized Maxwell material with four branches.

Assume that the viscous part of the deformation is incompressible, so that the volume 
change is purely elastic. The relaxation shear modulus function is approximated by a Prony 
series as

 (1)

where Gm represents the stiffness of the spring in the mth Maxwell branch, and τm is the 
relaxation time of the spring-dashpot pair in the same branch.

The instantaneous shear modulus is defined as

The alternative form of Equation 1 is

where the constants μm = Gm/G0 are such that

For many materials the viscoelastic properties have a strong dependence on the 
temperature. A common assumption is that the material is thermorheologically simple 
(TRS). In a material of this class, a change in the temperature can be transformed directly 
into a change in the time scale. Thus, the relaxation time for a TRS material is modified to 
aT(T)τm, where aT(T) is a shift function. One of the most commonly used shift functions 
is defined by the WLF (Williams-Landel-Ferry) equation:
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where a base-10 logarithm is assumed. Usually T0 is the glass transition temperature of 
the material. Note that aT(T0) = 1. If the temperature drops below T0 − C2, the WLF 
equation is no longer valid. The constants C1 and C2 are material dependent.

Model Definition

A long thick-walled cylinder has an inner radius of 5 mm and an outer radius of 10 mm. 
The inner surface is subjected to a prescribed radial displacement of 0.001 mm. A 
four-branch generalized Maxwell model represents the viscoelastic material.

In this example, you study the decay of the stresses during a period of two hours under the 
influence of the temperature field. You model a quarter of the cylinder and use the Solid 
Mechanics interface to compute the displacements in the cylinder cross section. The 
geometry is shown in Figure 1.

Figure 1: Geometry and mesh.

Study the following two cases:

• Apply a stationary temperature field, causing the problem to lose its axisymmetry.

• Make the temperature field transient.
3 |  S T R E S S  R E L A X A T I O N  O F  A  V I S C O E L A S T I C  TU B E



M A T E R I A L  P A R A M E T E R S

• Elastic data: instantaneous shear modulus G0 = 2.746·104 MPa and long-term shear 
modulus of G = μ0G0, bulk modulus K = 3.988·104 MPa.

• Viscoelastic data: four-branch Generalized Maxwell material with the hear modulus per 
branch defined from Gm = μmG0

- μ1 = 0.04, τ1 = 30 s

- μ2 = 0.08, τ2 = 300 s

- μ3 = 0.09, τ3 = 3000 s

- μ4 = 0.25, τ4 = 12000 s

• Thermal properties: A WLF shift function is used with C1 = 17.44 and C2 = 51.6. These 
values are reasonable approximations for many polymers. 

• The reference temperature is 500 K.

• Heat transfer properties: ρ = 7850 kg/m3 = 7.85·10−9 t/mm3, Cp = 2100 J/
(kg·K) = 2100·106 N·mm/(t·K), k = 6·10−2 W/(m·K) = 6·10−2 N/(s·K).

C O N S T R A I N T S

• The circumferential displacements are constrained on the radial edges.

• The inner edge of the hole is constrained to a radial displacement of 0.001 mm.

H E A T  TR A N S F E R  B O U N D A R Y  C O N D I T I O N S

• Stationary analysis: The inner and outer circular edges both have a temperature 
distribution varying linearly with the y-coordinate from 500 K at the y = 0 symmetry 
section to 506 K at the x = 0 symmetry section.

• Transient analysis: The temperature distribution obtained from the stationary analysis is 
used as initial condition, while all edges are insulated.
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Results and Discussion

In the first case, the temperature field is stationary and is shown in Figure 2. 

Figure 2: Stationary temperature distribution.
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The stress relaxation is faster where the temperature is higher. In Figure 3, the plots of 
radial stresses at radius 7.5 mm display this effect. The solid line is taken at y = 0 (cold) 
and the dashed line at x = 0 (warm).

Figure 3: Stress relaxation under a stationary temperature distribution.

In the second case, the temperature initially has the same distribution as shown in 
Figure 2, but it is allowed to settle in time to a final homogeneous value. Again, compare 
the radial stresses at radius 7.5 mm. The initial behavior is similar to the previous case, but 
as the difference in material properties decreases, the curves approach each other; see 
Figure 4. The strain rate in the initially warm point decreases, while it increases in the 
initially cold point.
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Figure 4: Stress relaxation under temperature settling conditions.

Notes About the COMSOL Implementation

When you solve a problem where a load is applied instantaneously at the beginning of a 
transient analysis, you can choose between two approaches to compute the initial stresses: 
either apply the load over a short period of time at the beginning of the time-dependent 
study. An alternative approach is to set the viscoelastic material to use an instantaneous 
static stiffness, and to add a separate stationary step before the time-dependent step. In the 
present example, you use the later method. 

The results computed during the stationary step are stored and used as the initial value for 
the consequent transient analysis. COMSOL Multiphysics handles this automatically if you 
use a single study with one solver sequence. In this example, however, you study two 
different relaxation histories with different thermal boundary conditions. In the second 
case, the thermal boundary conditions differ between the computation of the initial state 
and the transient analysis. For this reason you use two separate studies for the stationary 
and the time-dependent studies.
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Application Library path: Structural_Mechanics_Module/Viscoelasticity/
viscoelastic_tube

Modeling Instructions

From the File menu, choose New.

N E W

In the New window, click Model Wizard.

M O D E L  W I Z A R D

1 In the Model Wizard window, click 2D.

2 In the Select Physics tree, select Structural Mechanics>Solid Mechanics (solid).

3 Click Add.

4 In the Select Physics tree, select Heat Transfer>Heat Transfer in Solids (ht).

5 Click Add.

6 Click Done.

G E O M E T R Y  1

1 In the Model Builder window, under Component 1 (comp1) click Geometry 1.

2 In the Settings window for Geometry, locate the Units section.

3 From the Length unit list, choose mm.

Circle 1 (c1)
1 On the Geometry toolbar, click Primitives and choose Circle.

2 In the Settings window for Circle, locate the Size and Shape section.

3 In the Radius text field, type 10.

Circle 2 (c2)
1 Right-click Circle 1 (c1) and choose Build Selected.

2 On the Geometry toolbar, click Primitives and choose Circle.

3 In the Settings window for Circle, locate the Size and Shape section.

4 In the Radius text field, type 5.
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Difference 1 (dif1)
1 Right-click Circle 2 (c2) and choose Build Selected.

2 On the Geometry toolbar, click Booleans and Partitions and choose Difference.

3 Select the object c1 only.

4 In the Settings window for Difference, locate the Difference section.

5 Find the Objects to subtract subsection. Select the Active toggle button.

6 Select the object c2 only.

Rectangle 1 (r1)
1 Right-click Difference 1 (dif1) and choose Build Selected.

2 On the Geometry toolbar, click Primitives and choose Rectangle.

3 In the Settings window for Rectangle, locate the Size and Shape section.

4 In the Width text field, type 11.

5 In the Height text field, type 11.

Intersection 1 (int1)
1 Right-click Rectangle 1 (r1) and choose Build Selected.

2 On the Geometry toolbar, click Booleans and Partitions and choose Intersection.

3 Click in the Graphics window and then press Ctrl+A to select both objects.

4 Right-click Intersection 1 (int1) and choose Build Selected.

5 Click the Zoom Extents button on the Graphics toolbar.

Form Union (fin)
In the Model Builder window, under Component 1 (comp1)>Geometry 1 right-click Form 

Union (fin) and choose Build Selected.

The equations only need to include first-order time derivatives since the inertia effects can 
be neglected for this class of problems.

S O L I D  M E C H A N I C S  ( S O L I D )

1 In the Model Builder window, under Component 1 (comp1) click Solid Mechanics (solid).

2 In the Settings window for Solid Mechanics, locate the Structural Transient Behavior 
section.

3 From the list, choose Quasi-static.
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Linear Elastic Material 1
1 In the Model Builder window, under Component 1 (comp1)>Solid Mechanics (solid) click 

Linear Elastic Material 1.

2 In the Settings window for Linear Elastic Material, locate the Linear Elastic Material 
section.

3 From the Specify list, choose Bulk modulus and shear modulus.

Viscoelasticity 1
1 On the Physics toolbar, click Attributes and choose Viscoelasticity.

2 In the Settings window for Viscoelasticity, locate the Viscoelasticity Model section.

3 In the table, enter the following settings:

4 Click Add.

5 In the table, enter the following settings:

6 Click Add.

7 In the table, enter the following settings:

8 Click Add.

9 In the table, enter the following settings:

10 Locate the Model Inputs section. From the T list, choose Temperature (ht).

11 Locate the Thermal Effects section. From the Shift function list, choose 
Williams-Landel-Ferry.

12 In the TWLF text field, type 500[K].

13 Locate the Viscoelasticity Model section. From the Static stiffness list, choose 
Instantaneous.

Branch Shear modulus (Pa) Relaxation time (s)

1 0.04*G_inst 30

Branch Shear modulus (Pa) Relaxation time (s)

1 0.08*G_inst 300

Branch Shear modulus (Pa) Relaxation time (s)

1 0.09*G_inst 3000

Branch Shear modulus (Pa) Relaxation time (s)

1 0.25*G_inst 12000
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Symmetry 1
1 On the Physics toolbar, click Boundaries and choose Symmetry.

2 Select Boundaries 1 and 2 only.

Prescribed Displacement 1
1 On the Physics toolbar, click Boundaries and choose Prescribed Displacement.

2 Select Boundary 3 only.

3 In the Settings window for Prescribed Displacement, locate the Coordinate System 

Selection section.

4 From the Coordinate system list, choose Boundary System 1 (sys1).

5 Locate the Prescribed Displacement section. Select the Prescribed in n direction check 
box.

6 In the u0n text field, type -1e-6.

H E A T  TR A N S F E R  I N  S O L I D S  ( H T )

In the Model Builder window, under Component 1 (comp1) click Heat Transfer in Solids (ht).

Temperature 1
1 On the Physics toolbar, click Boundaries and choose Temperature.

2 Select Boundaries 3 and 4 only.

3 In the Settings window for Temperature, locate the Temperature section.

4 In the T0 text field, type (500+6*y/sqrt(x^2+y^2))[K].

M A T E R I A L S

In the Model Builder window, under Component 1 (comp1) right-click Materials and choose 
Blank Material.

Material 1 (mat1)
1 Select Domain 1 only.

2 In the Settings window for Material, locate the Material Contents section.
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3 In the table, enter the following settings:

D E F I N I T I O N S

Variables 1
1 On the Home toolbar, click Variables and choose Local Variables.

2 In the Settings window for Variables, locate the Variables section.

3 In the table, enter the following settings:

M E S H  1

In the Model Builder window, under Component 1 (comp1) right-click Mesh 1 and choose 
Mapped.

Mapped 1
In the Model Builder window, under Component 1 (comp1)>Mesh 1 right-click Mapped 1 and 
choose Distribution.

Distribution 1
1 Select Boundary 1 only.

2 In the Settings window for Distribution, locate the Distribution section.

Property Name Value Unit Property 
group

Bulk modulus K 3.988e4[MPa
]

N/m² Bulk 
modulus and 
shear 
modulus

Shear modulus G 0.54*G_inst N/m² Bulk 
modulus and 
shear 
modulus

Density rho 7.85E-9[t/
mm^3]

kg/m³ Basic

Thermal conductivity k 0.06[N/(s*
K)]

W/(m·K) Basic

Heat capacity at constant 
pressure

Cp 2.1E9[N*mm/
(t*K)]

J/(kg·K) Basic

Name Expression Unit Description

G_inst 2.746e4[MPa] Pa Instantaneous shear modulus
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3 In the Number of elements text field, type 12.

Mapped 1
Right-click Mapped 1 and choose Distribution.

Distribution 2
1 Select Boundary 3 only.

2 In the Settings window for Distribution, locate the Distribution section.

3 In the Number of elements text field, type 24.

4 Click Build All.

5 Click the Zoom Extents button on the Graphics toolbar.

R O O T

Next, add a stationary study to model the instantaneous preloading step.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Stationary.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  1

1 In the Model Builder window, click Study 1.

2 In the Settings window for Study, type Study: Stationary in the Label text field.

3 On the Home toolbar, click Compute.

R E S U L T S

Stress (solid)
Display the stationary temperature.

Temperature (ht)
1 In the Model Builder window, under Results click Temperature (ht).

2 On the Temperature (ht) toolbar, click Plot.

3 Click the Zoom Extents button on the Graphics toolbar.

Proceed to add a transient study for analyzing the stress relaxation process.
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A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Time 

Dependent.

4 Click Add Study in the window toolbar.

5 On the Home toolbar, click Add Study to close the Add Study window.

S T U D Y  2

1 In the Model Builder window, click Study 2.

2 In the Settings window for Study, type Study: Transient constant temperature 
in the Label text field.

S T U D Y :  TR A N S I E N T  C O N S T A N T  T E M P E R A T U R E

Step 1: Time Dependent
1 In the Model Builder window, under Study: Transient constant temperature click Step 1: 

Time Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,20,200) range(250,50,1000) range(1100,
100,2000) range(2200,200,7200).

4 Select the Relative tolerance check box.

5 In the associated text field, type 1e-3.

Solution 2 (sol2)
1 On the Study toolbar, click Show Default Solver.

2 In the Model Builder window, expand the Study: Transient constant temperature>Solver 

Configurations node.

Prescribe solution of the stationary study as the initial step in the transient analysis.

3 In the Model Builder window, expand the Solution 2 (sol2) node, then click Dependent 

Variables 1.

4 In the Settings window for Dependent Variables, locate the General section.

5 From the Defined by study step list, choose User defined.

6 Locate the Initial Values of Variables Solved For section. From the Method list, choose 
Solution.

7 From the Solution list, choose Solution 1 (sol1).
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8 Locate the Scaling section. From the Method list, choose Initial value based.

Force solver to evaluate results in between the specified time steps.

9 In the Model Builder window, under Study: Transient constant temperature>Solver 

Configurations>Solution 2 (sol2) click Time-Dependent Solver 1.

10 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

11 Locate the Time Stepping section. From the Steps taken by solver list, choose 
Intermediate.

12 On the Study toolbar, click Compute.

R E S U L T S

Temperature (ht) 1
Click the Zoom Extents button on the Graphics toolbar.

Display stress relaxation.

Cut Point 2D 1
1 On the Results toolbar, click Cut Point 2D.

2 In the Settings window for Cut Point 2D, locate the Point Data section.

3 In the X text field, type 7.5.

4 In the Y text field, type 0.

5 Locate the Data section. From the Data set list, choose Study: Transient constant 

temperature/Solution 2 (sol2).

Cut Point 2D 2
1 On the Results toolbar, click Cut Point 2D.

2 In the Settings window for Cut Point 2D, locate the Point Data section.

3 In the X text field, type 0.

4 In the Y text field, type 7.5.

5 Locate the Data section. From the Data set list, choose Study: Transient constant 

temperature/Solution 2 (sol2).

1D Plot Group 7
1 On the Results toolbar, click 1D Plot Group.

2 In the Settings window for 1D Plot Group, locate the Data section.

3 From the Data set list, choose Study: Transient constant temperature/Solution 2 (sol2).
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Point Graph 1
1 On the 1D Plot Group 7 toolbar, click Point Graph.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Data set list, choose Cut Point 2D 1.

4 Click Replace Expression in the upper-right corner of the y-axis data section. From the 
menu, choose Component 1>Solid Mechanics>Stress>Stress tensor (Spatial)>solid.sx - 

Stress tensor, x component.

5 On the 1D Plot Group 7 toolbar, click Plot.

1D Plot Group 7
In the Model Builder window, under Results click 1D Plot Group 7.

Point Graph 2
1 On the 1D Plot Group 7 toolbar, click Point Graph.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Data set list, choose Cut Point 2D 2.

4 Click Replace Expression in the upper-right corner of the y-axis data section. From the 
menu, choose Component 1>Solid Mechanics>Stress>Stress tensor (Spatial)>solid.sy - 

Stress tensor, y component.

5 On the 1D Plot Group 7 toolbar, click Plot.

6 Click to expand the Coloring and style section. Locate the Coloring and Style section. In 
the Width text field, type 2.

7 Find the Line style subsection. From the Line list, choose Dashed.

Point Graph 1
1 In the Model Builder window, under Results>1D Plot Group 7 click Point Graph 1.

2 In the Settings window for Point Graph, locate the Coloring and Style section.

3 In the Width text field, type 2.

1D Plot Group 7
1 In the Model Builder window, under Results click 1D Plot Group 7.

2 In the Settings window for 1D Plot Group, type Stress relaxation at constant 
temperature in the Label text field.

3 Locate the Plot Settings section. Select the x-axis label check box.

4 In the associated text field, type Time (s).

5 Select the y-axis label check box.
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6 In the associated text field, type Radial stress (Pa).

Now, simulate stress relaxation at constant temperature.

A D D  S T U D Y

1 On the Home toolbar, click Add Study to open the Add Study window.

2 Go to the Add Study window.

3 Find the Studies subsection. In the Select Study tree, select Preset Studies>Time 

Dependent.

4 Click Add Study in the window toolbar.

S T U D Y  3

Step 1: Time Dependent
1 In the Model Builder window, under Study 3 click Step 1: Time Dependent.

2 In the Settings window for Time Dependent, locate the Study Settings section.

3 In the Times text field, type range(0,20,200) range(250,50,1000) range(1100,
100,2000) range(2200,200,7200).

4 Select the Relative tolerance check box.

5 In the associated text field, type 1e-3.

6 Locate the Physics and Variables Selection section. Select the Modify physics tree and 

variables for study step check box.

7 In the Physics and variables selection tree, select Component 1 (comp1)>Heat Transfer in 

Solids (ht).

8 In the Physics and variables selection tree, select Component 1 (comp1)>Heat Transfer in 

Solids (ht)>Temperature 1.

9 Click Disable.

10 In the Model Builder window, click Study 3.

11 In the Settings window for Study, type Study: Transient variable temperature 
in the Label text field.

Solution 3 (sol3)
On the Study toolbar, click Show Default Solver.
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S T U D Y :  TR A N S I E N T  V A R I A B L E  T E M P E R A T U R E

Solution 3 (sol3)
1 In the Model Builder window, expand the Study: Transient variable temperature>Solver 

Configurations node.

Prescribe solution of the stationary study as the initial step in the transient analysis.

2 In the Model Builder window, expand the Solution 3 (sol3) node, then click Dependent 

Variables 1.

3 In the Settings window for Dependent Variables, locate the General section.

4 From the Defined by study step list, choose User defined.

5 Locate the Initial Values of Variables Solved For section. From the Method list, choose 
Solution.

6 From the Solution list, choose Solution 1 (sol1).

7 Locate the Scaling section. From the Method list, choose Initial value based.

Force solver to evaluate results in between the specified time steps.

8 In the Model Builder window, under Study: Transient variable temperature>Solver 

Configurations>Solution 3 (sol3) click Time-Dependent Solver 1.

9 In the Settings window for Time-Dependent Solver, click to expand the Time stepping 
section.

10 Locate the Time Stepping section. From the Steps taken by solver list, choose 
Intermediate.

11 On the Study toolbar, click Compute.

Display the results of stress relaxation.

R E S U L T S

Cut Point 2D 1
In the Model Builder window, expand the Results>Data Sets node.

Cut Point 2D 3
1 Right-click Cut Point 2D 1 and choose Duplicate.

2 In the Settings window for Cut Point 2D, locate the Data section.

3 From the Data set list, choose Study: Transient variable temperature/Solution 3 (sol3).

Cut Point 2D 2
In the Model Builder window, under Results>Data Sets right-click Cut Point 2D 2 and choose 
Duplicate.
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Cut Point 2D 4
1 In the Settings window for Cut Point 2D, locate the Data section.

2 From the Data set list, choose Study: Transient variable temperature/Solution 3 (sol3).

Stress relaxation at constant temperature
In the Model Builder window, under Results right-click Stress relaxation at constant 

temperature and choose Duplicate.

Stress relaxation at constant temperature 1
In the Settings window for 1D Plot Group, type Stress relaxation at variable 
temperature in the Label text field.

Point Graph 1
1 In the Model Builder window, expand the Results>Stress relaxation at variable 

temperature node, then click Point Graph 1.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Data set list, choose Cut Point 2D 3.

Point Graph 2
1 In the Model Builder window, under Results>Stress relaxation at variable temperature 

click Point Graph 2.

2 In the Settings window for Point Graph, locate the Data section.

3 From the Data set list, choose Cut Point 2D 4.

4 On the Stress relaxation at variable temperature toolbar, click Plot.
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